Jump to: navigation, search

Running Composer for the First Time

When running Composer for the first time, check out the video Getting Started After Installation. Composer is built on Eclipse. If you have not already done so, run Eclipse as described in the video.

Workspaces

When you run Composer, before the user interface appears, a dialog box opens with a suggested workspace, which is a location (folder) for your projects and files in addition to any special folders that Eclipse needs to maintain for its internal bookkeeping. The dialog box gives the option of changing the workspace to a different location. New projects created in Composer will be created under this workspace as subfolders. After the Composer interface opens, the Project Explorer shows this location. You can change this location by selecting File > Switch Workspace.

Important
Genesys recommends that the workspace folder name has no spaces in its path (for example, c:\comp81dev. This recommendation is not required and Composer does not enforce this. Genesys also recommends using the component version in the name to avoid confusion during upgrades. When prompted for a workspace folder, do not specify parenthesis in the workspace path. The workspace should not be located in a ClearCase view, as this will cause problems accessing files later during development.
  • Genesys recommends that the workspace folder name has no spaces in its path (for example, c:\comp81dev). This recommendation is not required and Composer does not enforce this. Genesys also recommends using the component version in the name to avoid confusion during upgrades.
  • When prompted for a workspace folder, do not specify parenthesis in the workspace path.
  • The workspace should not be located in a ClearCase view, as this will cause problems accessing files later during development.

Setting Up Your Workspace

The first time you open Composer, it asks you to specify the location of your workspace. Eclipse remembers this location and will present it for all subsequent times when you open Composer. If you do not wish to be prompted each time for this path and plan to use the same location for all your projects, you can check the Use this as the default and do not ask again option to skip this screen on future launches.

Welcome Screen

When a new workspace is created for the first time, you will be taken to the Welcome screen, which provides getting started overview topics, tutorials and links for references on the Web. The next time you open Composer, if the Welcome screen still opens, click it by clicking the "x" on the Welcome tab. To go back to the Welcome screen at any time:

  • Select Help > Welcome.

Opening Composer Perspective

Select Window > Perspective > Open Perspective > Other. All perspectives (views) available in Eclipse are listed, including those not used by Composer. Select Composer perspective.

Feedback

Comment on this article:

blog comments powered by Disqus
This page was last modified on June 15, 2017, at 05:49.