Jump to: navigation, search

Using the Interface

Blocks

A block is the basic building unit that you use to create applications. In Composer perspective, the palette of blocks is located in the right-most part of the main window (unless the Help window is also visible) and contains various categories of blocks. Every application must start with an voice Entry block or routing Entry block. You can also create Custom Blocks. A routing applications starts with Interaction Process Diagram Blocks.

Using Blocks

When creating voice application callflows and routing application workflows using the designer:

  • You double-click or drag-and-drop callflow blocks and/or workflow blocks to place them onto the center area (canvas).
  • You configure properties for each block.
  • You connect the blocks together by drawing connection links to define the flow.

Block Names and Multi-Byte Characters

Composer block names can contain only alphanumeric characters. If multiple-byte characters are used in block names, the code generation step fails and no SCXML or VXML file is generated from the Composer diagram.

Methods for Adding Blocks

There are a few ways to add blocks from the Palette to the canvas. The most common methods are as follows:

  • Click on the block icon on the palette, release the mouse and click on the target location on the canvas area.
  • Double-click a block icon on the palette.
  • Click on the block icon on the palette, and while holding down the mouse button, drag and drop the block to the canvas.

Any of these methods will add the new block and you can then type the name of the block on the canvas itself. Click here to read about block naming restrictions.

Outline View

For large call or workflows, the Outline view allows you to navigate to a portion of the flow diagram to view in the main canvas. It can also be used to facilitate navigation for other types of elements that might appear in the canvas or editor window, such as a large VXML file displayed in the VXML Editor. For more information, see the Outline View topic in the Eclipse Workbench User Guide (Help > Help Contents).

Simulation View

Simulation view shows the VoiceXML or SCXML code (read only) for a selected block (IPD blocks do not have this view). To add the Simulation view to the current perspective:

  • Click  Window > Show View > Other > Composer > Simulation.

Block Context Menus

Or, you can use a block's context menu as follows:

  • Select a block in the canvas, then right-click the box and select Simulate Code from the context menu as shown in the figure below. The Simulation view displays the code for the selected block.

The History view maintains previous versions of call and workflows and application files, allowing you to revert to any previous version if needed.

  • For more information, see the Local History topic in the Eclipse Workbench User Guide (Help > Help Contents).

The Problems view is used during validation of callflows, workflows, and files (VXML, SCXML, GRXML, and so on). It displays information about errors encountered when validating an application.

  • For more information, see the Problems View topic in the Eclipse Workbench User Guide (Help > Help Contents).

Comment on this article:

blog comments powered by Disqus
This page was last modified on 20 October 2016, at 10:25.