Jump to: navigation, search

Creating a New Workflow Diagram

Cheat Sheets

Composer provides a cheat sheet to walk you through the steps for building a routing strategy.

  • In the Welcome Screen (Help > Welcome), click the Composer link and select the Create a Routing Strategy tutorial. It will also describe the steps for how to simulate calls.
  • If you are already inside the workbench, access the same cheat sheet from the Menu bar at the top by selecting Help > Cheat Sheets > Composer > Routing Strategy.

Adding a Workflow Diagram to a Project

To add a new workflow diagram to an existing Composer Project:

  1. Click the button on the main toolbar to create a new workflow .
  • Or use the keyboard shortcut: Ctrl+Alt+R.  
  • Or select File > New > Workflow Diagram.
  • Or right-click the Workflows folder in a Project and select New > Other > Workflow Diagram.
  1. In the wizard, select the tab for the type of the workflow.  There are two main types of workflows in Composer represented by wizard tabs:
  • Main Workflow: Used for the main application where the call will land or be transferred to from another application.
  • Subworkflow: Used for modularizing your applications. It is useful for structuring large applications into manageable components.
  1. Select either Main Workflow or Subworkflow.
  2. Select the type of diagram.
  3. Click Next.
  4. Select the Project.
  5. Click Finish.
  6. Create the workflow. See Your First Application "DNIS Routing" on how to get started.

Note: The condition expression for event-related properties in interaction process (IPD) and workflow diagrams are not XML-escaped when generating the SCXML code. For more information, see Troubleshooting ORS Compile Errors and Non Escaped Special Charcters.

Feedback

Comment on this article:

blog comments powered by Disqus
This page was last modified on 17 October 2016, at 11:44.