Jump to: navigation, search

Diagram Templates

You can save a diagram as a template and have it appear on the list of available templates when creating a new callflow diagram or creating a new workflow diagram. Diagrams saved as templates can exported to/imported from the file system.

Saving a Diagram as a Template

To save a diagram as a template:

  1. In the Project Explorer, right-click the diagram in the Workflows or Callflows folder.
  2. Select Save <Callflow or Workflow> as Template.  The Add Template dialog box opens.
  3. Name and describe the template.
  4. Click OK. Upon a successful save the following message appears: Custom template added to your configuration.

Accessing Saved Diagram Templates

To view a diagram previously saved as template:

  1. From the File menu, select New <Callflow or Workflow> Diagram. The New <Callflow or Workflow> dialog box opens. The template appears in the Main Workflow tab under Custom Templates.
  2. Select the template and click one of the following:
  • Next to name the diagram, select the Project, and then click Finish.
  • Finish to keep the template name and save in the Workflows or Callflows folder under the current Project.  

Removing a Diagram Template

To remove a diagram template from the Custom Templates list, use Customization Manager.

Exporting a Diagram Template to the File System

To export a diagram to the file system or another user's Composer:

  1. In the Project Explorer, right-click the diagram in the Workflows or Callflows folder.
  2. Select Export. The Export dialog box opens.
  3. Under General, select File System and click Next.
  4. In the File System dialog box, select the folder containing the diagram(s).
  5. On the right, click check boxes to indicate the diagrams (s) to export.
  6. Opposite To directory, select the Composer installation to export to or Browse for the destination directory.
  7. Under Options, select one of the following:
  • Overwrite existing files without warning
  • Create directory structure for files
  • Create only selected directories (default).
  1. Click Finish.

Importing a Diagram Template

To import a diagram previously saved as a template:

  1. In the Project Explorer, right-click the diagram in the Workflows or Callflows folder.
  2. Select Import. The Import dialog box opens.
  3. Under General, select File System and click Next.
  4. In the File System dialog box, opposite From directory, click Browse.
  5. Open the workspace directory followed by the Project folder.
  6. Within the Project folder, select the Workflows folder that contains the template to import and click OK.
  7. In the File System dialog box on the right, click check boxes to indicate the template(s) to import.
  8. Opposite Into folder, browse for and select the folder to import into.
  9. Under Options, select one of the following:
  • Overwrite existing files without warning
  • Create directory structure for files
  • Create only selected directories (default).
  1. Click Finish.

Editing a Diagram Template

Use Customization Manager: Window > Show View > Other > Customization Manager. Select Workflow Diagram Editor or Callflow Diagram Editor.

Feedback

Comment on this article:

blog comments powered by Disqus
This page was last modified on 9 March 2015, at 09:48.