Jump to: navigation, search

Window Menu

The Window menu allows you to display, hide, and otherwise manipulate the various views, perspectives, and actions in the Workbench. The Window menu contains the following items:

New Window Opens a new workbench window with the same perspective as the current perspective. The Composer perspective is the default for building your application.
New Editor Opens an editor based on the currently active editor. It will have the same editor type and input as the original.
Open Perspective Opens a new perspective in this workbench window
Show View Displays the selected view in the current perspective. Views support editors and provide alternative presentations as well as ways to navigate the information in your workbench. For example, the Project Explorer and other navigation views display projects and other resources that you are working with. You can configure how views are opened on the Window > Preferences > General > Perspectives preference page.
Customize Perspective Opens the Customize Perspective dialog box. The Shortcuts tab lets you select shortcuts you want added as cascade items to submenus. The Commands tab lets you select command groups that you want added to the current perspective.
Save Perspective As Saves the current perspective thereby creating your own custom perspective. You can open more perspectives of this type using the Window > Open Perspective > Other menu item once you have saved a perspective.
Reset Perspective Changes the layout of the current perspective to its original configuration
Close Perspective Closes the active perspective
Close All Perspectives Closes all open perspectives in the workbench window
Navigation Displays the following submenu and shortcut keys:
  • Show System Menu (Alt+-): Shows the menu that is used for resizing, closing or pinning the current view or editor
  • Show View Menu (Ctrl+F10): Shows the drop down menu that is available in the toolbar of the active view
  • Quick Access (Ctrl+3): Shows a listing of available quick access categories
  • Maximize active view or editor (Ctrl+M): Causes the active part to take up the entire screen, or if it already is, returns it to its previous state
  • Minimize active view or editor: Causes the active part to be minimized.
  • Activate Editor (F12): Makes the current editor active
  • Next Editor (Ctrl+F6): Activates the next open editor in the list of most recently used editors
  • Previous Editor (Ctrl+Shift+F6): Activates the previous open editor in the list of most recently used editors
  • Switch to editor (Ctrl+Shift+E): Shows a dialog that allows switching to opened editors. Shows a dialog that allows switching to opened editors.
  • Next View: Activates the next open view in the list of most recently used views
  • Previous View (Ctrl+F7): Activates the previous open view in the list of most recently used editors
  • Next Perspective (Ctrl+F8): Activates the next open perspective in the list of most recently used perspectives
  • Previous Perspective (Ctrl+Shift+F8): Activates the previous open perspective in the list of most recently used perspectives
Preferences Opens a dialog box for indicating various Composer preferences. There are a wide variety of preferences for configuring the appearance of Composer and its views, and for customizing the behavior of all tools that are installed in the workbench. See Preferences for Voice Applications and Preferences for Routing Applications.

Feedback

Comment on this article:

blog comments powered by Disqus
This page was last modified on 9 March 2015, at 09:46.