Jump to: navigation, search

Localization

Localization in Composer allows you to use Composer in your preferred language. There are some limitations to localization, which are detailed here.

Bundled Help Always in English

The majority of the documentation for Composer exists in this online wiki. In addition, there remains a small help guide that is bundled with Composer, available in the product by clicking on Help > Help Contents > Composer.

The contents of this bundled help guide are always in English, regardless of the user's operating system locale, or any language packs they have installed on Composer. This does not affect the ability to use Composer in languages other than English, or to access the online Composer documentation in languages other than English.

Translating the Palette

After installing the Composer Language Pack, if you open Composer and continue to use an existing workspace, you will discover that the Palette is not localized. This is because Palette customization happens within Composer. You can change the labels, descriptions, and visibility of individual tools in the Palette. Composer preserves your customizations and, for that reason, Composer keeps the settings of your workspace Palette even after a Language Pack is installed. To workaround this issue, you can perform one of the following actions.

  1. Start a new workspace. The Palette will be localized in the new workspace.
  2. If you are willing to lose your current Palette settings:
  • Shut down Composer.
  • In a file explorer, go to <workspace>\.metadata\.plugins\com.genesyslab.composer.diagram, where <workspace> is your Composer workspace.
  • Delete the file paletteSettings.xml.
  • Restart Composer. The Palette will be localized in your existing workspace.

Translating Diagram Properties

The diagram preferences shown below use the Eclipse GMF runtime preferences, including their message strings. Due to limitations in Eclipse related to translating GMF Runtime, when localizing, certain diagram preferences are not translated.

  • Window > Preferences > Composer > Composer Diagram > Appearance
  • Window > Preferences > Composer > Composer Diagram > Connections
  • Window > Preferences > Composer > Composer Diagram > Pathmaps
  • Window > Preferences > Composer > Composer Diagram > Printing
  • Window > Preferences > Composer > Composer Diagram > Rulers and Grid

Translating Enumeration Properties

In the Properties view, many properties of blocks are enumerations, which are collection of fixed values, from which one is selected. Internally within Composer, a number of different dialogs, drop-down boxes, and various other mechanisms are used to display the various enumeration properties. The 8.1.3 release of Composer does not to enforce uniform behavior when translating enumeration properties. As a result, some enumeration properties will appear localized, while others may not. This has no impact on diagram validation, code generation, or runtime behaviour. It is merely the values displayed in the Properties view that appear either translated or untranslated. The underlying code that is generated will always be the same.

East Asian Characters

If you are using characters from an East Asian language (for example, Chinese, Japanese, Korean) in Expression Builder, you may find that they do not display properly, and appear as squares rather than the expected characters. The most likely cause of this issue is that the operating system font does not support East Asian language characters. As a workaround, change the Dialog Font setting from within Composer.

  1. In Composer, go to Window > Preferences.
  2. Select General > Appearance > Colors and Fonts.
  3. In the preference dialog, select Basic > Dialog Font.
  4. Click Edit to bring up the font selection dialog.
  5. Choose a font which can render East Asian languages, such as Arial Unicode MS.
  6. Click OK on the font selection dialog, then click OK on the preferences dialog.

Connection Profile and Non-ASCII Characters

Database Connection Profiles do not support non-ASCII characters. Use only ASCII characters when creating Connection Profiles.


This page was last modified on August 1, 2013, at 13:53.

Feedback

Comment on this article:

blog comments powered by Disqus