Jump to: navigation, search

Universal Contact Server

General Information - Universal Contact Server

Universal Contact Server is part of the eServices product line. For supported operating environment information for eServices, see the eServices page page.

Important
Please note the following:
  • Universal Contact Server 9.x and 8.x are parallel software streams. Keep that in mind when reviewing the supported versions in the tables on this page.
  • Unless stated otherwise in the table(s) below, Universal Contact Server is synonymous with Universal Contact Server and Universal Contact Server Proxy.

Supported Operating Systems

Genesys Data Processing Server Support

OS Family Operating System Release Conditions
Linux CentOS Linux 7 9.0+ Starting with 9.0.001.02.
Linux Oracle Linux 7 9.0+ Coupled with Unbreakable Enterprise Kernel Release 4, supported starting with 9.0.001.02.
Linux Red Hat Enterprise Linux 6 8.5+
Linux Red Hat Enterprise Linux 7 8.5+
Windows Windows Server 2008 8.5
Windows Windows Server 2012 8.5+
Windows Windows Server 2016 9.0+ Starting with 9.0.001.02.

Universal Contact Server (Cassandra version) Support

Notes:
  • This table is specific to 9.x versions of UCS and for on-premises implementations.
OS Family Operating System Release Conditions
Linux CentOS Linux 7 9.1+ Supported starting with 9.1.002.03.
Linux Oracle Linux 7 9.1+ Coupled with Unbreakable Enterprise Kernel Release 4, supported starting with 9.1.002.03.
Linux Red Hat Enterprise Linux 7 9.1+ Supported starting with 9.1.002.03.
Windows Windows Server 2012 9.1+ Supports 64-bit native.
Windows Windows Server 2016 9.1+ Supported starting with 9.1.002.03.

Universal Contact Server (SQL version) Support

Notes:
  • This table is specific to 8.x versions of UCS and for on-premises and Cloud implementations.
OS Family Operating System Release Conditions
AIX AIX Power PC 64-bit (AIX 5L for POWER) 7.1 8.1 - 8.5.3
AIX AIX Power PC 64-bit 6.1 8.0.1 - 8.5.2
Linux CentOS Linux 7 8.5.3+ Supports by the following with the starting version as indicated:
  • Universal Contact Server 8.5.300.16
  • Universal Contact Server Proxy 8.5.300.01
Linux Oracle Linux 7 8.5.3+ Coupled with Unbreakable Enterprise Kernel Release 4, this OS is supported by the following components with the starting version as indicated:
  • Universal Contact Server 8.5.300.16
  • Universal Contact Server Proxy 8.5.300.01
Linux Red Hat Enterprise Linux 5 8.1 - 8.5.2
Linux Red Hat Enterprise Linux 6 8.1.4+
Linux Red Hat Enterprise Linux 7 8.5.3+ Supported by the following:
  • Universal Contact Server 8.5.300.05
  • Universal Contact Server Proxy 8.5.300.01
Solaris Solaris SPARC 64-bit 10 7.6 - 8.5
Windows Windows Server 2008 8.1 - 8.5.2
Windows Windows Server 2012 8.5+
Windows Windows Server 2016 8.5.3+ Supports 64-bit native.
Windows Windows Server 2019 8.5.3+ Supported starting with 8.5.300.39.

Supported Browsers


No browser information at this time

Supported Database/DB Clusters


Database Release Conditions/Limitations
Cassandra 3.11 9.1+ In addition, Cassandra 3.11.3 is supported starting with 9.1.001.02.
Elasticsearch 9.1+ Elasticsearch 5.5 and 6.2 are supported starting with 9.1.001.02.
IBM DB2 10 8.1.4 - 8.5.3 Last supported version is 8.5.300.12.
IBM DB2 9.7 8.1.4 - 8.5.2
MS SQL Server 2008 8.0.1 - 8.5.2
MS SQL Server 2012 8.5
MS SQL Server 2014 8.5.3 - 8.5.x
MS SQL Server 2014 Cluster 8.5.2 - 8.5.x Supported starting with 8.5.200.19. Supports AlwaysOn functionality.
MS SQL Server 2016 8.5.3 - 8.5.x
MS SQL Server 2016 Cluster 8.5.3 - 8.5.x Supports AlwaysOn functionality.
Oracle 11g 8.1 - 8.5 It is not supported by 8.1.3 but is supported from 8.1.4 onward.
Oracle 11g R2 RAC 8.1.4 - 8.5
Oracle 11g RAC 8.0.3 - 8.5
Oracle 12c R1 8.5
Oracle 12c R2 RAC 8.5
Oracle 18c 8.5.3+ Supported starting with 8.5.300.39.
Oracle 18c RAC 8.5.3+ Supported starting with 8.5.300.39. Support includes Transparent Application Failover (TAF).
PostgreSQL 9.3 8.5.1 - 8.5.x
PostgreSQL 9.4 8.5.1 - 8.5.x Clustering is not supported.
PostgreSQL 9.6 8.5.3

Supported Virtualization Platforms

Tip
See the global page that lists all Virtualization-related information.

IPV6 Support for Common Interfaces


Notes:
  • This table applies to UCS 8.x and 9.x releases.
Component Release Interface Conditions
8.1.3+ Universal Contact Server

IPV6 Support for Additional Interfaces


No IPV6 information for additional components at this time.

Prerequisites


Universal Contact Server - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Component Prerequisites

OpenJDK 11 Yes No Release: 8.5.3+
Supported starting with 8.5.300.39 for all UCS 8.5-supported versions of Windows, Red Hat Enterprise Linux, and CentOS Linux.
Oracle Java 7 Developer's Kit (JDK) Yes No Release: 8.1.3 - 8.5.2
Oracle Java 8 Developer's Kit (JDK) Yes No Release: 8.5.3+
This page was last modified on October 16, 2019, at 07:01.

Feedback

Comment on this article:

blog comments powered by Disqus