Jump to: navigation, search

Framework

Important
Genesys support for the platform versions mentioned on this page ends when the respective vendors declare End of Support. For more information, see Discontinued Support.

Supported Operating Systems

Notes:
  • For Microsoft products with sub-versions such as R1/R2, all versions are supported except as noted for the specific product.
  • With your Red Hat Linux subscription, be sure to download the following 32-bit compatibility libraries, as these must be installed before installing Genesys components:
    • glibc.i686
    • libnsl.i686
    • libcrypt.i686
    • openssl-devel
    • compat-openssl10.i686
    • libxcrypt.i686
    • libstdc++.i686
    • libstdc++-devel.i686

OS Family OS Release Conditions
OS Family OS Release Conditions
Linux CentOS Linux 7 8.1.3+ Only supported by DB Server starting with 8.1.301.18. Refer to Management Framework Release notes for specific framework server versions.
Linux CentOS Linux 7 8.5.1+ Support for this operating system includes the following components, starting with the version listed:
  • Configuration Database Maintenance Scripts 8.5.100.19
  • Configuration Server 8.5.101.18
  • Genesys Security Pack on UNIX 8.5.100.14
  • Local Control Agent 8.5.100.23
  • Message Server 8.5.100.14
  • Solution Control Server 8.5.100.26
Linux Oracle Linux 7 8.1.3+ Only supported by DB Server starting with 8.1.302.05, coupled with Unbreakable Enterprise Kernel Release 4.x. Refer to the Management Framework Release Notes for specific Framework server versions.
Linux Oracle Linux 7 8.5.1+ Coupled with Unbreakable Enterprise Kernel Release 4.1, this operating system is supported by the following components starting with the version specified:
  • Configuration Database Maintenance Scripts 8.5.100.22
  • Configuration Server 8.5.101.28
  • Genesys Security Pack on UNIX 8.5.100.18
  • Local Control Agent 8.5.100.29
  • Message Server 8.5.100.23
  • Solution Control Server 8.5.100.36
  • Linux Red Hat Enterprise Linux 7 8.5.1+ Support for this operating system includes the following components, starting with the version listed:
  • Message Server 8.5.100.09
  • Configuration Database Maintenance Scripts 8.5.100.06
  • Configuration Server 8.5.100.17
  • Local Control Agent 8.5.100.15
  • Security Pack on UNIX 8.5.100.10
  • SNMP Master Agent 8.5.100.07
  • Solution Control Server 8.5.100.13
  • Linux Red Hat Enterprise Linux 8 8.5.1+ Support for this operating system includes the following components, starting with the version listed:
  • Configuration Server - 8.5.101.50
  • Database Server - 8.5.100.06
  • Local Control Agent - 8.5.100.36
  • Solution Control Server - 8.5.100.46
  • Security Pack on UNIX - 8.5.100.23
  • Message Server - 8.5.100.30
  • Configuration Database Maintenance Scripts - 8.5.100.24
  • Refer to the information mentioned about Red Hat in the Notes column above.
    Windows Windows 10 8.1+ Note the following:
    • Support starts with 8.1.101.
    • Internet Explorer 11 is required.
    Windows Windows 10 8.1.3 Starting with 8.0.301.05
    Windows Windows Server 2012 8.1.100.06+
    Windows Windows Server 2012 8.1.3 Starting with 8.0.301.05
    Windows Windows Server 2012 8.1.3+
    Windows Windows Server 2016 8.1+ Note the following:
  • Support starts with 8.1.101.
  • Internet Explorer 11 is required.
  • Windows Windows Server 2016 8.1.3 Starting with 8.0.301.05
    Windows Windows Server 2016 8.5.1+ Support for this operating system includes the following components, starting with the version listed:
  • DB Server 8.1.301.16
  • Configuration Server 8.5.101.11
  • Message Server 8.5.100.14
  • Local Control Agent 8.5.100.22
  • Solution Control Server 8.5.100.25
  • Windows Windows Server 2019 8.5.1+ Support for this operating system includes the following components, starting with the version listed:
  • Configuration Database Maintenance Scripts 8.5.100.24
  • Configuration Server 8.5.101.33
  • DB Server 8.1.302.09
  • Genesys Security Pack on UNIX 8.5.100.23
  • Local Control Agent 8.5.100.32
  • Message Server 8.5.100.25
  • Solution Control Server 8.5.100.40
  • Supported Browsers


    No browser information at this time

    Supported Database/DB Clusters


    Notes:
    • An asterisk (*) indicates the oldest databases supported for the Genesys 7.x and Genesys 8.x Maintenance Interoperable Components, including IBM DB2, Informix, MS SQL, Oracle, and Sybase.
    • For Microsoft products with sub-versions such as R1/R2, all versions are supported except as noted for the specific product.
    • Genesys Administrator 8.1+ does not require a database to operate. However, certain Genesys Administrator features do have access to databases, such as the Centralized logging and Outbound Contact. For these purposes, Genesys Administrator uses DB Server and, if a solution supports storing data in a particular database, Genesys Administrator can access it through DB Server.
    • Genesys supports Genesys products on the database patch levels up to the latest currently available patch sets.
    • Starting with release 8.5, all versions of Informix, and Sybase database support have been discontinued.
    Database Release Conditions/Limitations
    MS SQL Server 2012 8.1.3+ Genesys does not support Windows authentication mode of MSSQL database.
    MS SQL Server 2012 Cluster 8.5+ Note the following: AlwaysOn Cluster with sync mirroring capability is supported for Framework Business Continuity. DB Server 8.1.301 is required if accessing latest MSSQL Server/Cluster from applications, configured to use DB Server.
    MS SQL Server 2014 8.5.1+ Supported by DB Server starting with 8.1.301.
    MS SQL Server 2014 Cluster 8.5.1+ AlwaysOn Cluster with sync mirroring capability is supported for Framework Business Continuity. DB Server 8.1.301 is required if accessing latest MSSQL Server/Cluster from applications, configured to use DB Server.
    MS SQL Server 2016 8.5.1+ Note the following support starting with the version indicated: DB Server 8.1.301.14; Configuration Server 8.5.101.07; Message Server 8.5.100.13
    MS SQL Server 2016 Cluster 8.5.1+ AlwaysOn Cluster with sync mirroring capability is supported for Framework Business Continuity. DB Server 8.1.301 is required if accessing latest MSSQL Server/Cluster from applications, configured to use DB Server.
    MS SQL Server 2017 (Linux) 8.1.3+ Supported by DB Server starting with 8.1.302.01.
    MS SQL Server 2017 (Linux) 8.5.1+ Note the following support starting with the version indicated: Configuration Server 8.5.101.20; Message Server 8.5.100.16
    MS SQL Server 2017 (Windows) 8.1.3+ Note the following support starting with the version indicated: Configuration Server 8.5.101.77; Message Server 8.5.100.31; DB Server 8.5.100.07. Note: Supported by PostgreSQL client 10.1
    MS SQL Server 2017 (Windows) 8.1.3+ Supported by DB Server starting with 8.1.302.01.
    MS SQL Server 2017 (Windows) 8.5.1+ Note the following support starting with the version indicated: Configuration Server 8.5.101.20; Message Server 8.5.100.16
    MS SQL Server 2019 8.5.1+ Note the following support starting with the version indicated: Configuration Server 8.5.101.50; DB Server 8.5.100.06; Message Server 8.5.100.30
    MS SQL Server 2019 Cluster 8.5.1+ AlwaysOn Cluster with sync mirroring capability is supported for Framework Business Continuity.Note the following support starting with the version indicated: Configuration Server 8.5.101.50; DB Server 8.5.100.06; Message Server 8.5.100.30
    Oracle 12c R1 8.1.3+ Supported by DB Server starting with 8.1.301.
    Oracle 12c R1 RAC 8.1.3+ Supported by DB Server starting with 8.1.301.
    Oracle 12c R1 RAC 8.5+
    Oracle 12c R2 8.1.3+ Supported by DB Server starting with 8.1.302.
    Oracle 12c R2 8.5+
    Oracle 12c R2 RAC 8.1.3+ Supported by DB Server starting with 8.1.302.
    Oracle 12c R2 RAC 8.5+ Note the following support starting with the version indicated: Configuration Server 8.5.101.18; Message Server 8.5.100.16
    Oracle 18c 8.1.3+ Supported by DB Server starting with 8.1.302.07.
    Oracle 18c 8.5.1+ Support of Oracle 18c and RAC server: Configuration Server 8.5.101.32, Message Server 8.5.100.24. Support of Oracle 18c dbclient: Configuration Server 8.5.101.83, Message Server 8.5.100.32, DB Server 8.5.100.09
    Oracle 19c 8.5.1+ Support of Oracle 19c and RAC server: Configuration Server 8.5.101.50; DB Server 8.5.100.06; Message Server 8.5.100.30. Support of Oracle 19c dbclient: Configuration Server 8.5.101.92, Message Server 8.5.100.36, DB Server 8.5.100.12
    Oracle Golden Gate 8.5+
    PostgreSQL 10.1 8.1.3+ Supported by DB Server starting with 8.1.302.01.
    PostgreSQL 10.1 8.5.1+ Note the following support starting with the version indicated:Configuration Server 8.5.101.20; Message Server 8.5.100.16.
    PostgreSQL 12 8.5.1+ Note the following support starting with the version indicated: Configuration Server 8.5.101.77; Message Server 8.5.100.31; DB Server 8.5.100.07. Note: Supported by PostgreSQL client 10.1
    PostgreSQL 13 8.5.1+ Support for PostgreSQL 13: Configuration Server 8.5.101.89, Message Server 8.5.100.35, DB Server 8.5.100.11

    Supported Virtualization Platforms

    Tip
    See the global page that lists all Virtualization-related information.

    IPV6 Support for Common Interfaces


    Notes:
    • Release Support numbers refer to Framework.
    Component Release Interface Conditions
    Configuration Server 8.1 License Server
    Configuration Server 8.1 Management Framework Configuration Server/Proxy
    DB Server 8.1 Management Framework Configuration Server/Proxy
    DB Server no direct interface License Server
    Local Control Agent 8.1 Solution Control Server
    Local Control Agent no direct interface License Server
    Local Control Agent no direct interface Management Framework Configuration Server/Proxy
    Message Server 8.1 Management Framework Configuration Server/Proxy IPv6 is supported at all interfaces to components which use Message Server, for example, T-Server, Universal Routing Server, SIP Server, Outbound Contact Server.
    Message Server no direct interface License Server
    SNMP Master Agent 8.1 Management Framework Configuration Server/Proxy
    Solution Control Interface 8.0.3 Management Framework Configuration Server/Proxy IPv6 is supported at all interfaces to components which use Message Server, for example, T-Server, Universal Routing Server, SIP Server, Outbound Contact Server.
    Solution Control Server 8.1 License Server
    Solution Control Server 8.1 Management Framework Configuration Server/Proxy

    IPV6 Support for Additional Interfaces


    Notes:
    • This section provides IPv6 information for Configuration Server, DB Server, Local Control Agent, Message Server, SNMP Master Agent, Solution Control Interface, and Solution Control Server.
    • This section provides IPv6 information for Configuration Server, DB Server, Local Control Agent, Message Server, SNMP Master Agent, Solution Control Interface, Solution Control Server, and Stat Server.
    Component Release Interface Conditions
    Configuration Server 8.1 Management User Interfaces Configuration Management Environment (CME) and legacy UIs are excluded from IPv6 support. Use Genesys Administrator or Genesys Administrator Extension for all configuration and management tasks.
    DB Server 8.1.1 Database Management Server (DBMS)
    Solution Control Server 8.1 Management User Interfaces Configuration Management Environment (CME) and legacy UIs are excluded from IPv6 support. Use Genesys Administrator or Genesys Administrator Extension for all configuration and management tasks.
    Solution Control Server no support Third-party SNMP agent

    Prerequisites













































































































































































































































































































































































































































































































































































































































































































































    This page was last edited on December 17, 2021, at 18:42.
    blog comments powered by Disqus