Jump to: navigation, search

Genesys Administrator Extension

Important
Genesys support for the platform versions mentioned on this page ends when the respective vendors declare End of Support. For more information, see Discontinued Support.

Supported Operating Systems

Genesys Administrator (GA) Support

OS Family Operating System Release Conditions
Windows Windows Server 2012 8.1.304+
Windows Windows Server 2016 8.1.310+ As per Oracle, this version of Windows requires Java 8 version 1.8.0_111+.

Genesys Administrator Extension (GAX) Support

OS Family Operating System Release Conditions
Linux CentOS Linux 7 8.5.2+ Supported starting with 8.5.290.20.
Linux Red Hat Enterprise Linux 7 8.5.2+
Linux Red Hat Enterprise Linux 8 9.0.1+ Starting with 9.0.100.72 +
Windows Windows Server 2012 8.1.4+ With 64-bit applications running natively on a 64-bit OS.
Windows Windows Server 2016 8.5.260+ As per Oracle, this version of Windows requires Java 8 version 1.8.0_111+.
Windows Windows Server 2019 9.0.1+ Starting with 9.0.100.72+

Supported Browsers


Notes:
  • Unless otherwise noted, browser plug-ins are not supported for these browsers. Only the browser is supported.
Component Browser Release Conditions/Limitations
Genesys Administrator (GA) Firefox ESR 8.0.2 - 8.1
Genesys Administrator (GA) Microsoft IE 8.1.304+ Version 11 is supported
Genesys Administrator Extension Microsoft Edge Chromium 9.0.1+
Genesys Administrator Extension (GAX) Apple Safari 8.5.2+ Versions 7 and 8 are supported
Genesys Administrator Extension (GAX) Firefox ESR 8.5+
Genesys Administrator Extension (GAX) Google Chrome 8.1.2+ Starting from 8.5.2+, Chrome is supported on MAC OS X v10.9+.
Genesys Administrator Extension (GAX) Microsoft Edge 8.5.24+
Genesys Administrator Extension (GAX) Microsoft IE 8.5.0+ Version 11 is supported

Supported Database/DB Clusters


Notes:
  • Genesys Administrator does not support the AlwaysOn Availability Groups feature.
  • Genesys supports Genesys products on the database patch levels up to the latest currently available patch sets.
Database Release Conditions/Limitations
MS SQL Server 2012 8.1.4+
MS SQL Server 2014 8.5.24+
MS SQL Server 2014 Cluster 8.5.24+ Supports AlwaysOn Cluster with Synchronous Mirroring capability. However, JTDS, the third-party JDBC driver that GAX uses, does not officially support the AlwaysOn configuration. Therefore, even though Genesys successfully tested GAX with MS SQL Server 2014 Cluster/AlwaysOn, Genesys cannot officially recommend anything but a simple failover clustering configuration.
MS SQL Server 2016 8.5.26+
MS SQL Server 2016 Cluster 8.5.26+ Supports AlwaysOn Cluster with Synchronous Mirroring capability. However, JTDS, the third-party JDBC driver that GAX uses, does not officially support the AlwaysOn configuration. Therefore, even though Genesys successfully tested GAX with MS SQL Server 2016 Cluster/AlwaysOn, Genesys cannot officially recommend anything but a simple failover clustering configuration.
MS SQL Server 2017 8.5.26+ Starting with 8.5.260.11
Oracle 12c R1 8.1.4+
Oracle 12c R1 RAC 8.5.2+ SCAN is supported.
Oracle 12c R2 RAC 8.5.2+ Starting with 8.5.260.12; SCAN is supported.
Oracle 18c 9.0.100+
Oracle 18c RAC 9.0.100+ SCAN is supported.
Oracle 19c 9.0.100+ Enterprise Edition 19.0.0.0.0 is supported.
PostgreSQL 10 8.5.2+ Starting with 8.5.260.12.
PostgreSQL 9 8.1.3+
PostgreSQL 9.3 8.5.2+

Supported Virtualization Platforms

Tip
See the global page that lists all Virtualization-related information.

IPV6 Support for Common Interfaces


Notes:
  • Release numbers refer to Genesys Administrator.
Component Release Interface Conditions
Genesys Administrator (GA) 8.1 Management Framework Configuration Server/Proxy
Genesys Administrator (GA) no direct interface License Server
Genesys Administrator Extension (GAX) no direct interface License Server

IPV6 Support for Additional Interfaces


Notes:
  • Release numbers refer to Genesys Administrator.
Component Release Interface Conditions
Genesys Administrator (GA) 8.1 Browser to Genesys Administrator Extension backend

Prerequisites


Genesys Administrator (GA) - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Windows Server 2008 (except for R2)

ASP.NET 2.0 Yes No
Microsoft .NET Framework 3.5 SP1 Yes No
Microsoft Internet Information Services (IIS) Version 7 Yes No

Windows Server 2008 R2

ASP.NET 2.0 Yes No
Microsoft .NET Framework 3.5 SP1 Yes No
Microsoft Internet Information Services (IIS) Version 7.5 Yes No

Windows Server 2012

Both Microsoft .NET Framework 4.5 by default (includes ASP.NET 4.5) and Microsoft .NET Framework 3.5 (includes .NET 2.0 and 3.0) installed. Yes No
Microsoft Internet Information Services (IIS) Version 8.0 Yes No

Windows Server 2012 R2

Both Microsoft .NET Framework 4.5 by default (includes ASP.NET 4.5) and Microsoft .NET Framework 3.5 (includes .NET 2.0 and 3.0) installed. Yes No
Microsoft Internet Information Services (IIS) Version 8.5 Yes No

Genesys Administrator Extension (GAX) - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Component Prerequisites

Apache/Tomcat 8 Yes No Release: 8.5.260+
Support starts with version 8.5.260
Apache/Tomcat 9 Yes No Release: 9.0.100+
GAX 9.0.100+ supports Tomcat 9.0.36.
Cometd 3.1.1 Yes No Release: 8.5.280+
Older versionsuse Cometd 2.8.0.
Hibernate 5 Yes No Release: 8.5.270+
Older versions use Hibernate 3.
Jackson 2.9.4 Yes No Release: 8.5.270+
Older versions use Jackson 1.9.
OpenJDK 11 Yes No Release: 9.0+
Support is for OpenJDK 11.0.1 or later starting with 9.0.001.26.
OpenJDK 8 Yes No Release: 8.5.2+
Starting with 8.5.290.09.
Oracle Java 6 Runtime (JRE) Yes No Release: 8.1.2 - 8.5.250
JDK/JRE 6 is not supported starting with 8.5.260.11.
Oracle Java 7 Runtime (JRE) Yes No Release: 8.1.4+
JDK/JRE 7 is mandatory to install GAX starting with version 8.5.260.11 and higher.
Oracle Java 8 Runtime (JRE) Yes No Release: 8.5.2+
Oracle Java 8 Runtime (JRE) Yes No Release: 9.0.1

Note the following:

  • Starting with 9.0.100.72
  • Requires Java version 1.8.0_211 or later
Spring 4.3.13 Yes No Release: 8.5.270+
This page was last edited on February 25, 2021, at 08:48.
blog comments powered by Disqus