Jump to: navigation, search

Workspace Desktop Edition

General Information - Workspace Desktop Edition

This product was called Interaction Workspace prior to release 8.5.0

General Information - Workspace Desktop Edition

This product was called Interaction Workspace prior to release 8.5.0

Supported Operating Systems

OS Family OS Release Conditions
OS Family OS Release Conditions
Windows Windows 10 8.5 Note the following:
  • Supported starting with 8.5.112.08.
  • Application running in 32-bit compatibility mode on 64-bit OS.
Windows Windows 7 8.0+ Application running in 32-bit compatibility mode on 64-bit OS.
Windows Windows 8 8.1+ Application running in 32-bit compatibility mode on 64-bit OS. Supported in release 8.1.401.
Windows Windows Server 2008 8.0+ Application running in 32-bit compatibility mode on 64-bit OS.
Windows Windows Server 2012 8.5 Application running in 32-bit compatibility mode on 64-bit OS.
Windows Windows Server 2016 8.5 Application running in 32-bit compatibility mode on 64-bit OS.

OS Family OS Release Conditions
OS Family OS Release Conditions
Windows Windows 10 8.5 Note the following:
  • Supported starting with 8.5.112.08.
  • Application running in 32-bit compatibility mode on 64-bit OS.
Windows Windows 7 8.0+ Application running in 32-bit compatibility mode on 64-bit OS.
Windows Windows 8 8.1+ Application running in 32-bit compatibility mode on 64-bit OS. Supported in release 8.1.401.
Windows Windows Server 2008 8.0+ Application running in 32-bit compatibility mode on 64-bit OS.
Windows Windows Server 2012 8.5 Application running in 32-bit compatibility mode on 64-bit OS.
Windows Windows Server 2016 8.5 Application running in 32-bit compatibility mode on 64-bit OS.

Supported Browsers


No browser information at this time

Supported Database/DB Clusters


No DB information at this time.

Supported Virtualization Platforms

Tip
See the global page that lists all Virtualization-related information.

IPV6 Support for Common Interfaces


Component Release Interface Conditions
Workspace Desktop Edition 8.5 Interaction Server
Workspace Desktop Edition 8.5 Management Framework Configuration Server/Proxy
Workspace Desktop Edition 8.5 SIP Server/T-Server
Workspace Desktop Edition 8.5 Stat Server

IPV6 Support for Additional Interfaces


Component Release Interface Conditions
Workspace Desktop Edition 8.5 Chat Server
Workspace Desktop Edition 8.5 Universal Contact Server/Proxy

Prerequisites


Workspace Desktop Edition - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Development Workstation Prerequisites

Microsoft .NET Framework 3.5 SP1 Yes No Release: 8.0-8.1.4
Requires Visual Studio 2008 as customization development tool (Visual C# 2008 Express Edition free version is sufficient)
Microsoft .NET Framework 4 (4.5+) Yes No Release: 8.5+
Requires Visual Studio 2012 as customization development tool (Visual C# 2012 Express Edition free version is sufficient)

Agent Workstation Runtime Prerequisites

Microsoft .NET Framework 3.5 SP1 Yes No Release: 8.0-8.1.4
Microsoft .NET Framework 4 (4.5+) Yes No Release: 8.5+

Agent Workstation–Centralized Deployment Prerequisites

Microsoft Internet Explorer (IE11+) or Firefox ESR or Google Chrome Yes No Release: 8.0-8.1.4
Google Chrome requires Meta4 ClickOnce Launcher. Firefox requires FxClickOnce.
Microsoft Internet Explorer (IE11+) or Firefox ESR or Google Chrome or Microsoft Edge Yes No Release: 8.5+
Google Chrome requires Meta4 ClickOnce Launcher. Firefox requires FxClickOnce.

Centralized Deployment Server (ClickOnce)

Microsoft .NET Framework 2.0+ Yes No Release: 8.0-8.1.4
Requires HTTP Server: MS IIS 6 or 7 or Apache HTTP Server 2.2.
Microsoft .NET Framework 4 (4.5+) Yes No Release: 8.5+
Requires HTTP Server: MS IIS 7 or 8 or Apache HTTP Server 2.2
Red Hat Enterprise Linux 6 Yes No Release: 8.0-8.1.4
Requires Apache HTTP Server 2.2.
Red Hat Enterprise Linux 5 Yes No Release: 8.5+
Requires Apache HTTP Server 2.2.
Red Hat Enterprise Linux RHEL 5 Yes No Release: 8.0-8.1.4
Requires Apache HTTP Server 2.2.
Red Hat Enterprise/CenOS Linux 6 Yes No Release: 8.5+
Requires Apache HTTP Server 2.2.
Solaris Sparc 7/8/9/10 Yes No Release: 8.0-8.1.4
  • Requires Apache HTTP Server 2.2.
  • From Interaction Workspace 8.1.3 and higher, deployment is no longer supported on Solaris SPARC 7.
Solaris Sparc10 Yes No Release: 8.5+
Requires Apache HTTP Server 2.2.
This page was last modified on December 11, 2018, at 08:16.

Feedback

Comment on this article:

blog comments powered by Disqus