Jump to: navigation, search

Interaction SDK

General Information - Interaction SDK

From 7.2 and higher, Genesys Integration Server (GIS) is no longer a standalone product; it is part of Interaction SDK.

Supported Operating Systems

Notes:
  • An asterisk (*) indicates the oldest operating systems supported for the Genesys 7.x and Genesys 8.x Maintenance Interoperable Components, including AIX Power PC, HP-UX, and Solaris SPARC.
  • For Microsoft products with sub-versions such as R1/R2, all versions are supported except as noted for the specific product.
  • Genesys supports use of products on Oracle Linux, provided that the Oracle Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution, and that the Oracle Unbreakable Enterprise Kernel is not used. Genesys will only support Oracle Linux based on testing and reproduction of any issues in the equivalent Red Hat Linux version; no investigation or testing will be performed on Oracle Linux itself. Support only applies to Oracle Linux versions 5.x and later.
  • The GIS proxies for .NET are only supported on the Microsoft .NET Framework, so they are only supported on Windows.
  • When running on Windows, the GIS is only supported on Windows Server operating systems, not on Windows Client operating systems.

OS Family OS Release Conditions
OS Family OS Release Conditions
AIX Power PC AIX Power PC 64-bit (AIX 5L for POWER) 7.1 7.6.5+
Linux Red Hat Enterprise Linux 5 7.6.3+
Linux Red Hat Enterprise Linux 6 7.6.5+
Solaris SPARC Solaris SPARC 64-bit 10 7.2+
Windows Windows 10 7.6.6+ Only valid for Agent Interaction Layer (AIL) clients and Genesys Integration Server (GIS) Proxies. Note: This operating system is only supported for user interface implementations not server implementations.
Windows Windows 7 7.6.3+ Only valid for Agent Interaction Layer (AIL) clients and Genesys Integration Server (GIS) Proxies. Note: This operating system is only supported for user interface implementations not server implementations.
Windows Windows 8 7.6.6+ Only valid for Agent Interaction Layer (AIL) clients and Genesys Integration Server (GIS) Proxies. Note: This operating system is only supported for user interface implementations not server implementations.
Windows Windows Server 2008 7.6.3+
Windows Windows Server 2012 7.6.6+ Supported starting with 7.6.600.10.
Windows Windows Server 2016 7.6.6+ Supported by Genesys Integration Server starting with version 7.6.601.36.

Supported Browsers


No browser information at this time

Supported Database/DB Clusters


No DB information at this time.

Supported Virtualization Platforms

Tip
See the global page that lists all Virtualization-related information.

IPV6 Support for Common Interfaces


No IPV6 information for common interfaces at this time.

IPV6 Support for Additional Interfaces


No IPV6 information for additional components at this time.

Prerequisites


Notes:
  • AIL third party dependencies The AIL installs with all needed external libraries. Client applications must make sure that those dependencies exist and are not overridden by other classpath libraries. AIL 7.6.4 third party-libraries: Apache log4j. File: log4j.jar JavaMail 1.3.1 (spec 1.3): File: mail.jar FlexLM Java 7.2: flexlm.jar
  • Needed only when not using JDK 6 or higher: JavaBeans Activation Framework 1.0.2 (spec 1.0). Used by JavaMail. File: activation.jar Java Architecture for XML binding (ref impl 2.1.1, spec 2.1): jaxb-api.jar, jaxb-impl.jar

Interaction SDK - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

AIL and GIS

1.6 Yes No Release: 7.6.3
Java SE 7 Yes No Release: 7.6.4+
Interaction SDK 7.6.5+
Java SE 8 Yes No Release: 7.6.4+
Interaction SDK 7.6.6+
JDK 1.4.2 Yes No Release: 7.5
JDK 1.4.2 Yes No Release: 7.6.3
JDK 1.4.2 Yes No Release: 7.2
JDK 1.5 Yes No Release: 7.5
JDK 1.5 Yes No Release: 7.6.3
JDK 1.5 Yes No Release: 7.2
JDK 1.5 Yes No Release: 7.6.4+
JDK 1.6 Yes No Release: 7.6.4+

GIS

Apache 2.0 with Tomcat 4.1 or 5.5 on Windows, Solaris, and Linux only Yes No Release: 7.2
Apache 2.0 with Tomcat 5.5 on Windows, Solaris, and Linux only Yes No Release: 7.5
Apache 2.0 with Tomcat 5.5 or 6.0 on Windows, Solaris, and Linux only Yes No Release: 7.6.4+
Apache 2.0 with Tomcat 5.5 or 6.0 on Windows, Solaris, and Linux only Yes No Release: 7.6.3
IIS 5.0/6.0 with Tomcat 4.1 or 5.5 on Windows only Yes No Release: 7.2
IIS 5.0/6.0 with Tomcat 5.5 on Windows only Yes No Release: 7.5
IIS 5.0/6.0 with Tomcat 5.5 or 6.0 on Windows only Yes No Release: 7.6.4+
IIS 5.0/6.0 with Tomcat 5.5 or 6.0 on Windows only Yes No Release: 7.6.3
WebLogic 8.1 on Solaris only Yes No Release: 7.5
WebLogic 8.1 on Solaris only Yes No Release: 7.2
WebLogic 9/10 on Solaris only Yes No Release: 7.6.4+
WebLogic 9/10 on Solaris only Yes No Release: 7.6.3
WebSphere and WebSphere Express 5.1/6.0 Yes No Release: 7.5
WebSphere and WebSphere Express 5.1/6.0 Yes No Release: 7.2
WebSphere and WebSphere Express 6.0/6.1 Yes No Release: 7.6.3
WebSphere and WebSphere Express 6.1/7.0 Yes No Release: 7.6.4+

GIS proxy libraries

Apache Axis Toolkit 1.1 and 1.3 Yes No Release: 7.2
Apache Axis Toolkit 1.1, 1.3, and 1.4 (1.4 is recommended) Yes No Release: 7.5
Apache Axis Toolkit 1.4 Yes No Release: 7.6.4+
Apache Axis Toolkit 1.4 Yes No Release: 7.6.3
Microsoft .NET Framework SDK 1.1 and 2.0 Yes No Release: 7.5
Microsoft .NET Framework SDK 1.1 and 2.0 Yes No Release: 7.2
Microsoft .NET Framework SDK 1.1, 2.0, 3.0, 3.5 Yes No Release: 7.6.4+
Microsoft .NET Framework SDK 1.1, 2.0, 3.0, 3.5 Yes No Release: 7.6.3
This page was last modified on January 10, 2019, at 14:32.

Feedback

Comment on this article:

blog comments powered by Disqus