Jump to: navigation, search

eServices

Important
  • Genesys support for the platform versions mentioned on this page ends when the respective vendors declare End of Support. For more information, see Discontinued Support.
  • Please note the following:
  • Messaging Apps and Social Engagement information was moved to the Messaging Apps/Social Engagement SOE page.
  • Universal Contact Server information was moved to the Universal Contact Server SOE page.

Supported Operating Systems

Bot Gateway Server Support

OS Family Operating System Release Conditions
Linux Red Hat Enterprise Linux 6 9.0+ Supported starting with 9.0.004.08.
Linux Red Hat Enterprise Linux 7 9.0+ Supported starting with 9.0.004.08.
Windows Windows Server 2012 9.0+ Supported starting with 9.0.004.08.
Windows Windows Server 2016 9.0+ Supported starting with 9.0.004.08.

Content Analyzer (Plugin for Genesys Administrator Extension) Support

OS Family Operating System Release Conditions
Linux CentOS Linux 7 8.5.305+
Linux Red Hat Enterprise Linux 5 8.5.0 - 8.5.2 Supported for use on Kernel Virtual Machine (KVM) starting with 8.5.300.09.
Linux Red Hat Enterprise Linux 6 8.5.1 - 8.5.2
Linux Red Hat Enterprise Linux 7 8.5.305+ Supported starting with 8.5.305.03
Linux Red Hat Enterprise Linux 8 9.0.0+ Supported starting with 9.0.001.04.
Windows Windows Server 2008 8.5.0 - 8.5.2
Windows Windows Server 2012 8.5 - 9.0 Support discontinued as of 9.0.001.03.
Windows Windows Server 2016 8.5.305+
Windows Windows Server 2019 9.0+ Supported starting with 9.0.001.03.

eServices Manager (Plugin for Genesys Administrator Extension) Support

OS Family Operating System Release Conditions
Linux CentOS Linux 7 8.5.3 Support starting with 8.5.301.09.
Linux Red Hat Enterprise Linux 5 8.5.0 - 8.5.1
Linux Red Hat Enterprise Linux 6 8.5.1 - 8.5.302
Linux Red Hat Enterprise Linux 7 8.5.3+ Supported for use on Kernel Virtual Machine (KVM) starting with 8.5.300.09.
Linux Red Hat Enterprise Linux 8 9.0.0+ Supported starting with 9.0.003.07.
Windows Windows Server 2008 8.5.0 - 8.5.302
Windows Windows Server 2012 8.5 - 9.0 Support discontinued as of 9.0.003.06.
Windows Windows Server 2016 8.5.304+
Windows Windows Server 2019 9.0+ Supported starting with 9.0.003.03.

eServices Server Components Support

Notes:
  • An asterisk (*) indicates the oldest operating systems supported for the Genesys 7.x and Genesys 8.x Maintenance Interoperable Components, including AIX Power PC, HP-UX, and Solaris SPARC.
  • eServices server components include Classification Server, Chat Server, E-mail Server, Interaction Server, Interaction Server Proxy, SMS Server, and Training Server. It also includes the following groups of servers: Web API (Web API Server, Web API Server for WebLogic, Web API Server for WebSphere, .NET Web API Server and Samples)
  • For Microsoft products with sub-versions such as R1/R2, all versions are supported except as noted for the specific product.
  • Genesys supports use of products on Oracle Linux, provided that the Oracle Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution, and that the Oracle Unbreakable Enterprise Kernel is not used. Genesys will only support Oracle Linux based on testing and reproduction of any issues in the equivalent Red Hat Linux version; no investigation or testing will be performed on Oracle Linux itself. Support only applies to Oracle Linux versions 5.x and later.
  • Web Collaboration is not supported on AIX.
OS Family Operating System Release Conditions
AIX AIX Power PC 64-bit (AIX 5L for POWER) 7.1 8.0.2+ Supported by the following:
  • eServices components are supported beginning with Release 8.0.210.
  • eServices WebAPI supports AIX 7.1 starting from 8.5+.

No longer supported by the following components:

  • Chat Server as of 8.5.201.05
  • Classification Server as of 8.5.300.03
  • E-mail Server as of 8.5.200.02
  • Interaction Server/Interaction Server Proxy as of 8.5.3
  • Training Server as of 8.5.305.01
Linux CentOS Linux 7 8.5.1+ Supported by Interaction Server 8.5.104.13
Linux CentOS Linux 7 8.5.2+ Supported by Interaction Server Proxy 8.5.201.00+
Linux CentOS Linux 7 8.5.3+ Supported by the following:
  • Chat Server starting with 8.5.301.06
  • Classification Server starting with 8.5.300.03
  • Training Server starting with 8.5.305.01
Linux Oracle Linux 7 8.5.3+ Note the following:
  • Classification Server starting with 8.5.300.03, with Oracle Linux 7, coupled with Unbreakable Enterprise Kernel Release 4.
  • Chat Server, starting with 8.5.306.03.
Linux Red Hat Enterprise Linux 5 8.1+ No longer supported by:
  • Interaction Server and Interaction Server Proxy as of 8.5.2
  • Interaction Server Cluster Plug-in for GAX as of 8.5.200.08
  • Chat Server as of 8.5.201.05
  • Classification Server as of 8.5.300.03
  • Training Server as of 8.5.305.01
RHEL 5 is still supported by Email Server.
Linux Red Hat Enterprise Linux 6 8.1.4+ Supported by the following:
  • eServices WebAPI supports RHEL6 starting from 8.5+

No longer supported by the following:

  • Chat Server as of 8.5.201.05
  • Classification Server as of 8.5.301.01
  • E-mail Server as of 8.5.200.02
  • Interaction Server as of 9.0.001.07
  • Interaction Server Proxy as of 9.0.001.02
  • Interaction Server Cluster Plug-in for GAX as of version 9.0.000.00
  • Training Server as of 8.5.305.01
Linux Red Hat Enterprise Linux 7 8.5.1+ Supported by following:
  • Chat Server starting with 8.5.102.08
  • Classification Server starting with 8.5.300.03, including usage on a Kernel Virtualization Machine (KVM)
  • E-mail Server starting with 8.5.104.13
  • Interaction Server starting with 8.5.107.06
  • Interaction Server Proxy starting with 8.5.107.14
  • Training Server starting with 8.5.305.01
Linux Red Hat Enterprise Linux 8 8.5.2+ Supported by E-mail Server starting with 8.5.200.02.
Linux Red Hat Enterprise Linux 8 8.5.3+ Supported by Chat Server starting with 8.5.314.02
Linux Red Hat Enterprise Linux 8 9.0+ Supported by the following:
  • Interaction Server starting with 9.0.000.10.
  • Interaction Server Proxy starting with 9.0.000.03.
  • Classification Server starting with 9.0.000.07.
  • Interaction Server Cluster Plug-in for GAX starting with version 9.0.000.00.
  • Training Server starting with 9.0.000.08
Solaris Solaris SPARC 64-bit 10 7.6 - 8.1 Web API Server for WebLogic and Web API Server for WebSphere supports this through 8.1.
Solaris Solaris SPARC 64-bit 10 7.6 - 8.5 Supported by the following:
  • Interaction Server/Interaction Server Proxy supports this through 8.5.2
  • Classification Server supports this through 8.5.2
  • Email Server supports this through 8.5.1
  • Training Server supports this through 8.5.1
  • Chat Server supports this through 8.5.1
  • SMS Server supports this through 8.5.1
  • Web API Server supports this through 8.5.1
Windows Windows Server 2008 8.1+ No longer supported by the following:
  • Chat Server as of 8.5.302.03
  • Classification Server as of 8.5.301.01
  • E-mail Server as of 8.5.200.02
  • Interaction Server and Interaction Server Proxy as of 8.5.2
  • Training Server as of 8.5.305.01
  • Interaction Server Cluster Plug-in for GAX as of version 9.0.000.00
Windows Windows Server 2012 8.5+ Supported by the following:
  • Classification Server starting with 8.5.000.14

No longer supported by the following:

  • Chat Server as of 8.5.314.02
  • E-mail Server as of 8.5.202.02
  • Classification Server as of 9.0.000.08
  • Training Server as of 9.0.000.08
Windows Windows Server 2016 8.5+ Supported by the following:
  • E-mail Server starting with 8.5.104.13
  • Chat Server starting with 8.5.201.05
  • Classification Server starting with 8.5.301.01
  • Interaction Server starting with 8.5.201.05
  • Interaction Server Proxy starting with 8.5.201.00
  • Training Server starting with 8.5.305.01
  • Interaction Server Cluster Plug-in for GAX starting with version 9.0.000.00
Windows Windows Server 2019 8.5.3 Supported by the following:
  • Chat Sever starting with 8.5.314.02
  • E-mail Server starting with 8.5.200.02
  • Interaction Server starting with 8.5.304.07
  • Interaction Server Proxy starting with 8.5.304.02
Windows Windows Server 2019 9.0.0+ Supported by the following:
  • Training Server starting with 9.0.000.08
  • Classification Server starting with 9.0.000.07
  • Interaction Server Cluster Plug-in for GAX starting with version 9.0.000.00

Knowledge Manager (Legacy) Support

OS Family Operating System Release Conditions
Windows Windows 7 8.0.1+
Windows Windows Server 2008 8.0.1-8.5.1

Privacy Manager (Plugin for Genesys Administrator Extension) Support

OS Family Operating System Release Conditions
Linux CentOS Linux 7 8.5.305+
Linux Red Hat Enterprise Linux 5 8.5.0 - 8.5.1 Supported for use on Kernel Virtual Machine (KVM) starting with 8.5.300.09.
Linux Red Hat Enterprise Linux 6 8.5.1 - 8.5.300 Supported starting with 8.5.300.10.
Linux Red Hat Enterprise Linux 7 8.5.3 Support starting with 8.5.300.10, including use on a Kernel Virtualization Machine (KVM).
Linux Red Hat Enterprise Linux 8 9.0.0+ Supported starting with 9.0.001.06.
Windows Windows Server 2008 8.5.0 - 8.5.300
Windows Windows Server 2012 8.5 - 9.0 Support discontinued as of 9.0.001.05.
Windows Windows Server 2016 8.5.305+
Windows Windows Server 2019 9.0+ Supported starting with 9.0.001.05.

Supported Browsers


Notes:
Component Browser Release Conditions/Limitations
Content Analyzer (Plugin for Genesys Administrator Extension) Firefox ESR 8.5.2+
Content Analyzer (Plugin for Genesys Administrator Extension) Google Chrome 8.5.2+
Content Analyzer (Plugin for Genesys Administrator Extension) Microsoft Edge Chromium 9.0.0+ Starting with version 9.0.001
Content Analyzer (Plugin for Genesys Administrator Extension) Microsoft IE11 8.5.2+
eServices Manager (Plugin for Genesys Administrator Extension) Firefox ESR 8.5+ Tested with version 46
eServices Manager (Plugin for Genesys Administrator Extension) Google Chrome 8.5+
eServices Manager (Plugin for Genesys Administrator Extension) Microsoft Edge Chromium 9.0.0+ Starting with version 9.0.002
eServices Manager (Plugin for Genesys Administrator Extension) Microsoft IE11 8.5+
Interaction Server Cluster (Plugin for Genesys Administrator Extension) Firefox ESR 8.5.1+ Minimum supported version: 38
Interaction Server Cluster (Plugin for Genesys Administrator Extension) Google Chrome 8.5.1+ Minumum supported version: 44
Interaction Server Cluster (Plugin for Genesys Administrator Extension) Microsoft IE11 8.5.1+
Privacy Manager (Plugin for Genesys Administrator Extension) Firefox ESR 8.5.1+
Privacy Manager (Plugin for Genesys Administrator Extension) Google Chrome 8.5+
Privacy Manager (Plugin for Genesys Administrator Extension) Microsoft Edge Chromium 9.0.0+ Starting with version 9.0.001
Privacy Manager (Plugin for Genesys Administrator Extension) Microsoft IE11 8.5+

Supported Database/DB Clusters


Notes:
  • An asterisk (*) indicates the oldest databases supported for the Genesys 7.x and Genesys 8.x Maintenance Interoperable Components, including IBM DB2, Informix, MS SQL, Oracle, and Sybase.
  • Genesys supports Genesys products on the database patch levels up to the latest currently available patch sets.
Database Release Conditions/Limitations
Cassandra 2 8.5.1 - 8.5.3 Not supported by Chat Server starting with 8.5.314.02.
Cassandra 3.11 8.5.3+ Supported in high availability mode by Chat Server starting with 8.5.307.04.
IBM DB2 10 8.1.4+ Not supported by Interaction Server starting from 8.5.2.
IBM DB2 9.7 8.1+ Not supported by Interaction Server starting with 8.5.2.
MS SQL Server 2008 8.0.1+ Not supported by Interaction Server starting with 8.5.2.
MS SQL Server 2012 8.5+ Not supported by Interaction Server starting with 8.5.2.
MS SQL Server 2012 Cluster 8.5+ Also supports AlwaysOn Cluster with Synchronous Mirroring capability. Not supported by Interaction Server and Interaction Server Proxy starting from 8.5.2.
MS SQL Server 2014 8.5.1+ Supported by Interaction Server starting with 8.5.108.05.
MS SQL Server 2014 Cluster 8.5.1+ Supported by Interaction Server starting with 8.5.108.05. Also supports AlwaysOn capability.
MS SQL Server 2016 8.5+ Supported by Interaction Server starting with 8.5.201.05.
MS SQL Server 2016 Cluster 8.5.1+ Supported by Interaction Server starting with 8.5.201 with AlwaysOn capability.
MS SQL Server 2017 8.5.3 Supported by Interaction Server starting with 8.5.300.07.
MS SQL Server 2019 8.5.3+ Supported by Interaction Server starting with 8.5.306.04
Oracle 11g RAC 8.1+ SCAN is not supported. Oracle 11g RAC is supported by Interaction Server 8.1.2+. Oracle 11g Rel 1 and Rel 2 are supported. Not supported by Interaction Server starting with 8.5.2.
Oracle 12c R1 8.5+
Oracle 12c R1 RAC 8.5+ SCAN is not supported.
Oracle 12c R2 8.5.3 Supported by Interaction Server starting with 8.5.2.
Oracle 12c R2 RAC 8.5.3 Supported by Interaction Server starting with 8.5.2. SCAN is not supported.
Oracle 18c 8.5.3+ Interaction Server - Last supported version: 9.0.003.06
Oracle 18c RAC 8.5.3+ Interaction Server - Last supported version: 9.0.003.06. SCAN is not supported.
Oracle 19c 8.5.3+ Supported by Interaction Server starting with 8.5.307.02.
Oracle 19c RAC 8.5.3+ Supported by Interaction Server starting with 8.5.307.02. Support includes Transparent Application Failover (TAF). SCAN is not supported.
PostgreSQL 10 8.5.2+ Supported by Interaction Server starting with 8.5.2.
PostgreSQL 12 9.0.0+ Supported by Interaction Server starting with 9.0.003.06.
PostgreSQL 9 8.5.1+ Limited PostgreSQL support will be available for UCS and Interaction Server starting with 8.5.x (2015). Please see release notes. Last supported version: 9.0.004.07
PostgreSQL 9.6 8.5.2+ Interaction Server - Last supported version: 9.0.004.07

Supported Virtualization Platforms

Tip
See the global page that lists all Virtualization-related information.

IPV6 Support for Common Interfaces


Notes:
  • Release Support numbers refer to eServices.
Component Release Interface Conditions
eServices 8.1 Interaction Server
eServices 8.1.3+ E-mail Server
eServices no direct interface License Server
eServices no direct interface SIP Server/T-Server

IPV6 Support for Additional Interfaces


No IPV6 information for additional components at this time.

Prerequisites


Bot Gateway Server - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Component Prerequisites

OpenJDK 11 Yes No Release: 9.0+
Oracle Java 8 Developer's Kit (JDK), OpenJDK 8 Yes No Release: 9.0+
Transport Layer Security 1.2 Yes No Release: 9.0+

Classification Server - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Component Prerequisites

OpenJDK 11 Yes No Release: 9.0+
Starting with 9.0.000.02
Oracle Java 7 Developer's Kit (JDK) Yes No Release: 8.1.3 - 8.5.3
Discontinued as of December 11, 2018.
Oracle Java 8 Developer's Kit (JDK) Yes No Release: 8.5.1+
Starting with 8.5.110.03

Content Analyzer (Plugin for Genesys Administrator Extension) - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Genesys Administrator Extension

8.5.220.25-8.5.260.XX No Yes Release: 8.5.2
Tested with GAX 8.5.220.25
8.5.290.09 + No Yes Release: 9.0.0

Note the following:

  • Tested with GAX 8.5.290.09
  • Tested with GAX 9.0.001.37
  • Tested with GAX 9.0.100.56
  • New text
8.5.290.09-9.0.001.XX No Yes Release: 8.5.3

Note the following:

  • Tested with GAX 8.5.290.09
  • Tested with GAX 9.0.001.37

Digital Messaging Server - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Component Prerequisites

OpenJDK 11 Yes No Release: 9.1+
Support starts with 9.1.002.02.

Email Server - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Component Prerequisites

OpenJDK 11 Yes No Release: 8.5.1+
Support starts with 8.5.106.01.
Oracle Java 7 Yes No Release: 8.1.4 - 8.5.1
Discontinued as of June 28, 2019.
Oracle Java 8 Yes No Release: 8.5.1+
Support starts with 8.5.103.11.

eServices Manager (Plugin for Genesys Administrator Extension) - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Genesys Administrator Extension

GAX 8.5.210.10 - GAX 8.5.260.xx No Yes Release: 8.5.1
GAX 8.5.220.25 - GAX 8.5.260.xx No Yes Release: 8.5.2
GAX 8.5.240.19 - GAX 8.5.260.xx No Yes Release: 8.5.300.09 - 8.5.301.09
GAX 8.5.270.06 No Yes Release: 8.5.3
Support starts with 8.5.302.02.
GAX 8.5.290.09 - GAX 9.0.001.xx No Yes Release: 9.0.000.09
GAX 8.5.290.09 - GAX 9.0.001.xx No Yes Release: 8.5.3
Supports starts with 8.5.304.10.
GAX 8.5.290.09 - GAX 9.0.101.xx No Yes Release: 9.0.001.08 - 9.0.003.03
GAX 8.5.290.09+ No Yes Release: 9.0
Support starts with 9.0.003.05.

Interaction Server - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Component Prerequisites

OpenJDK 11 Yes No Release: 8.5.3

Note the following:

  • Starting with 8.5.302.12
  • Required only for the following optional functionalities
    • JMS and Kafka Capture Points
    • XML transformations
    • JMS and Groovy Event Loggers
OpenJDK 8 Yes No Release: 8.5.3

Note the following:

  • Starting with 8.5.302.12
  • Required only for the following optional functionalities
    • JMS and Kafka Capture Points
    • XML transformations
    • JMS and Groovy Event Loggers

Interaction Server Cluster (Plugin for Genesys Administrator Extension) - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Genesys Administrator Extension

GAX 8.5.240.19+ No Yes Release: 8.5.1+
GAX 9.0.001.37 No Yes Release: 9.0.0+
GAX 9.0.101.29 No Yes Release: 9.0.0+

Third-Party Component Prerequisites

OpenJDK 11 Yes No Release: 8.5.2+
Starting with version 8.5.200.08
OpenJDK 8 Yes No Release: 8.5.2+
Starting with version 8.5.200.08
Oracle Java 8 Developer's Kit (JDK) Yes No Release: 8.5.1+

Knowledge Manager (Legacy) - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Library Dependencies

Oracle Java 6 Developer's Kit (JDK) Yes No Release: 8.5.0
JDK 6 32-bit only, is used with 8.5.0 of Knowledge Manager.
Oracle Java 7 Developer's Kit (JDK) Yes No Release: 8.5.1
JDK 7 is used with 8.5.1 of Knowledge Manager.

Privacy Manager (Plugin for Genesys Administrator Extension) - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Genesys Administrator Extension

8.5.240.19 - 8.5.260.XX No Yes Release: 8.5.3

Note the following:

  • Support starting with 8.5.300.10
  • Tested with GAX 8.5.240.19
8.5.290.09 - 9.0.001.XX No Yes Release: 8.5.3

Note the following:

  • Support starts with 8.5.305.01.
  • Tested with GAX 8.5.290.09
  • Tested with GAX 9.0.001.37
9.0.100 + No Yes Release: 9.0.0

Note the following:

  • Support starts with 9.0.001.04.
  • Tested with GAX 9.0.100.56
GAX 8.5.210.10 - 8.5.260.xx No Yes Release: 8.5.1

Training Server - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Component Prerequisites

OpenJDK 11 Yes No Release: 9.0+
Supported starting with 9.0.000.07
Oracle Java 7 Developer's Kit (JDK) Yes No Release: 7.6 - 8.5.1
Oracle Java 8 Developer's Kit (JDK) Yes No Release: 8.5.1+
Supported starting with 8.5.110.03.

Web API Server (Legacy) - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Library Dependencies

Apache HTTP Server No Yes Release: 7.2 - 8.0.11
Apache HTTP Server 2.0 (7.2 - 7.5) 2.2.4 (7.6) 2.2.11 (8.0) 2.2.14 (8.0.1+)
Apache Tomcat No Yes Release: 7.2+
Tomcat 5.5 with WebAPI 7.2 Tomcat 6.0 with WebAPI 7.6+ Tomcat 7.0 with WebAPI 8.5
BEA WebLogic Yes No Release: 7.2 - 8.0.11
BEA WebLogic 8.1 with WebAPI 7.2 - 7.6.1 BEA WebLogic 9.2 with WebAPI 8.0+
IBM WebSphere Yes No Release: All
IBM WebSphere 6.0 (7.2 - 7.6.1); WebSphere 6.1 (8.0+); WebSphere 7.0 (8.1.0); WebSphere 8.5 (8.1.2+)
Jetty Yes No Release: 8.5
Jetty 8 and 9 supported by WebAPI 8.5 only
Microsoft IIS Yes No Release: 8.0.1+
IIS 6.0 and IIS 7.0 (8.0.1+) IIS is not supported with WebAPI 8.5
Oracle Java Developer's Kit (JDK) Yes No Release: All
JDK 1.4.2 (7.0.1 - 7.6.1); JDK 1.5 (7.6); JDK 1.6 (8.0+); JDK 1.7 (8.5+) From Release 8.0.1, Web API Server supports the JDK version that is included in the supported configuration Web Server/Application Server.
Oracle WebLogic Yes No Release: 8.5
WebLogic 12cR3 supported by WebAPI 8.5 only

Supported Combinations of Web Servers and Servlet Engines

AIX; DB2; IBM WebSphere & HTTP Server Yes No Release: 8.5
WebAPI 8.5 supports AIX 7.1, WebSphere 8.5, IBM SDK 1.7_64
Linux; Apache/Tomcat Yes No Release: 8.5
WebAPI 8.5 supports RHEL 6.5, Apache 2.4, Tomcat 6, 7
Solaris; Oracle; Apache/Tomcat; IBM WebSphere and HTTP Server; BEA WebLogic Yes No Release: 8.5
WebAPI 8.5 supports Solaris 10, Apache 2.4, Tomcat 6, 7, WebSphere 8.5, WebLogic 12cR3
This page was last edited on November 24, 2021, at 09:39.
blog comments powered by Disqus