Jump to: navigation, search

Genesys Voice Platform


Supported Operating Systems

Notes:
  • For Microsoft products with sub-versions such as R1/R2, all versions are supported except as noted for the specific product.
  • For Microsoft products with sub-versions such as R1/R2, all versions are supported except as noted for the specific product.
  • Genesys supports use of products on CentOS Linux, provided that the CentOS Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution.
  • Genesys supports use of products on CentOS Linux, provided that the CentOS Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution.
  • Genesys supports use of products on Oracle Linux, provided that the Oracle Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution, and that the Oracle Unbreakable Enterprise Kernel is not used. Genesys will only support Oracle Linux based on testing and reproduction of any issues in the equivalent Red Hat Linux version; no investigation or testing will be performed on Oracle Linux itself. Support only applies to Oracle Linux versions 5.x and later.
  • Genesys supports use of products on Oracle Linux, provided that the Oracle Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution, and that the Oracle Unbreakable Enterprise Kernel is not used. Genesys will only support Oracle Linux based on testing and reproduction of any issues in the equivalent Red Hat Linux version; no investigation or testing will be performed on Oracle Linux itself. Support only applies to Oracle Linux versions 5.x and later.

OS Family OS Release Conditions
OS Family OS Release Conditions
Red Hat Enterprise Linux 6 8.1.7+ Supported for the following components:
  • VP Call Control Platform
  • VP CTI Connector
  • VP Supplementary Services Gateway
  • VP Policy Server
  • VP MRCP Proxy
Linux Red Hat Enterprise Linux 5 8.1.2+
Windows Windows Server 2008 8.1.2+
Windows Windows Server 2012 8.5.1+ Supported for the following components:
  • CTI Connector
  • Supplementary Services Gateway
  • MRCP Proxy
  • Third Party Squid
  • Windows Windows Server 2016 9.0+ The Standard version is supported for the following components:
  • Call Control Platform
  • CTI Connector
  • Supplementary Services Gateway
  • MRCP Proxy
  • Notes:
    • For Microsoft products with sub-versions such as R1/R2, all versions are supported except as noted for the specific product.
    • For Microsoft products with sub-versions such as R1/R2, all versions are supported except as noted for the specific product.
    • Genesys supports use of products on CentOS Linux, provided that the CentOS Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution.
    • Genesys supports use of products on CentOS Linux, provided that the CentOS Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution.
    • Genesys supports use of products on Oracle Linux, provided that the Oracle Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution, and that the Oracle Unbreakable Enterprise Kernel is not used. Genesys will only support Oracle Linux based on testing and reproduction of any issues in the equivalent Red Hat Linux version; no investigation or testing will be performed on Oracle Linux itself. Support only applies to Oracle Linux versions 5.x and later.
    • Genesys supports use of products on Oracle Linux, provided that the Oracle Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution, and that the Oracle Unbreakable Enterprise Kernel is not used. Genesys will only support Oracle Linux based on testing and reproduction of any issues in the equivalent Red Hat Linux version; no investigation or testing will be performed on Oracle Linux itself. Support only applies to Oracle Linux versions 5.x and later.

    OS Family OS Release Conditions
    OS Family OS Release Conditions
    Red Hat Enterprise Linux 6 8.1.7+ Supported for the following components:
    • VP Call Control Platform
    • VP CTI Connector
    • VP Supplementary Services Gateway
    • VP Policy Server
    • VP MRCP Proxy
    Linux Red Hat Enterprise Linux 5 8.1.2+
    Windows Windows Server 2008 8.1.2+
    Windows Windows Server 2012 8.5.1+ Supported for the following components:
  • CTI Connector
  • Supplementary Services Gateway
  • MRCP Proxy
  • Third Party Squid
  • Windows Windows Server 2016 9.0+ The Standard version is supported for the following components:
  • Call Control Platform
  • CTI Connector
  • Supplementary Services Gateway
  • MRCP Proxy
  • Supported Browsers


    Notes:

    Supported Database/DB Clusters


    Notes:
    • For database support information, see the Supported Database/DB Cluster table on the Genesys Media Server page in this document.
    • For database support information, see the Supported Database/DB Cluster table on the Genesys Media Server page in this document.
    • For database support information, see the Supported Database/DB Cluster table on the Genesys Media Server page in this document.
    • For database support information, see the Supported Database/DB Cluster table on the Genesys Media Server page in this document.

    Supported Virtualization Platforms

    Tip
    See the global page that lists all Virtualization-related information.

    IPV6 Support for Common Interfaces


    Notes:
    Component Release Interface Conditions
    Genesys Media Server 8.1 Management Framework Configuration Server/Proxy
    Genesys Media Server 8.1 SIP Server/T-Server
    Genesys Media Server no direct interface Interaction Server

    IPV6 Support for Additional Interfaces


    Notes:
    • Release Support numbers refer to Genesys Voice Platform.
    • Release Support numbers refer to Genesys Voice Platform.
    Component Release Interface Conditions
    Genesys Voice Platform 8.1.5 F5 or NLB/Radware for load-balancing
    Genesys Voice Platform 8.1.5 IVR Server 7.5 or 8.0
    Genesys Voice Platform 8.1.5 SIP Phones
    Genesys Voice Platform 8.1.5 Web Interface-HTTP

    Prerequisites


    Notes:
    • For additional prerequisites, see the Prerequisite table in the Genesys Media Server page in this document.
    • For additional prerequisites, see the Prerequisite table in the Genesys Media Server page in this document.

    Genesys Voice Platform - Prerequisites

    Third-Party Component Prerequisites

    Acquired by Customer

    Provided by Genesys

    Conditions/Limitations

    Cisco Queue Adapter (for GVP 7.6) or CTI-Connector (Cisco)

    Cisco ICM Yes No Release: 7.6
    Depending on the GVP release that is deployed, there are different supported versions of Cisco ICM.

    Microsoft IIS for GVP 8.1.1 or earlier or GVPi applications on GVP 8.1.1–8.1.4.

    Common Files Yes No Release: 8.1.5
    Not needed for GVP 8.1.5 or later.
    Internet Information Server Snap-In Yes No Release: 8.1.5
    Not needed for GVP 8.1.5 or later.
    Microsoft Internet Information Server (IIS) 6.0 components Yes No Release: 8.1.5
    Not needed for GVP 8.1.5 or later.
    World Wide Web Server Yes No Release: 8.1.5
    Not needed for GVP 8.1.5 or later.

    Cisco ICM AIM (CTIC support)

    Cisco ICM 7.5 or later Yes No Release: 8.1.5+

    If using ASR

    Any validated MRCP compliant speech-recognition software Yes Resell Release: All
    Reference the Supported Media Interfaces reference manual for compatibility of GVP with Nuance and any GValidated speech integration. It is your responsibility to order the appropriate number of speech licenses. Contact Genesys Sales for additional guidance.

    If using TTS

    Any validated MRCP compliant text-to-speech software Yes Resell Release: All
    Reference the Supported Media Interfaces reference manual for compatibility of GVP with Nuance and any GValidated speech integration. It is your responsibility to order the appropriate number of speech licenses. Contact Genesys Sales for additional guidance.

    SIP Server to Resource Manager HA (active-active mode) (Optional)

    Third-party Load Balancer Yes No Release: All
    F5, Microsoft Network Load Balancer (NLB) are supported.

    Voice Platform Policy Server - Prerequisites

    Third-Party Component Prerequisites

    Acquired by Customer

    Provided by Genesys

    Conditions/Limitations

    Policy Server

    Java 7 (JRE) Yes No Release: 8.5+
    This page was last modified on November 7, 2018, at 10:12.

    Feedback

    Comment on this article:

    blog comments powered by Disqus