Jump to: navigation, search

Platform SDK

General Information - Platform SDK

For details about compatibility between Platform SDK protocols and specific Genesys Framework servers for each major Platform SDK release, refer to the Platform SDK Compatibility with Genesys Framework Components section of Platform SDK Deployment Guide.

Important
Platform SDK does not explicitly state support for web browsers, Server Virtualization or Desktop Virtualization platforms. If you are planning to use such a platform, please check that the operating system on which your Platform SDK application runs is supported, and that Platform SDK prerequisites are met. In case of any doubts, please contact your Genesys account team or e-mail the virtualization support team.

Supported Operating Systems

Notes:
  • For Microsoft products with sub-versions such as R1/R2, all versions are supported except as noted for the specific product.
  • Genesys supports use of products on Oracle Linux, provided that the Oracle Linux distribution is 100% compatible with a Genesys-supported Red Hat distribution, and that the Oracle Unbreakable Enterprise Kernel is not used. Genesys will only support Oracle Linux based on testing and reproduction of any issues in the equivalent Red Hat Linux version; no investigation or testing will be performed on Oracle Linux itself. Support only applies to Oracle Linux versions 5.x and later.

OS Family OS Release Conditions
OS Family OS Release Conditions
Linux Red Hat Enterprise Linux 5 8.1 - 8.5.3 No support for RHEL 5 as of version 9.0 of PSDK.
Linux Red Hat Enterprise Linux 6 8.1.2+
Linux Red Hat Enterprise Linux 7 8.5.1+
Windows Windows 10 8.5.201.04+ This operating system is only supported for user interface implementations not server implementations.
Windows Windows 7 8.0.2+ This operating system is only supported for user interface implementations not server implementations.
Windows Windows 8 8.1.3+ This operating system is only supported for user interface implementations not server implementations.
Windows Windows Server 2008 8.0+
Windows Windows Server 2008 8.1+
Windows Windows Server 2012 8.1.2+
Windows Windows Server 2016 9.0+

Supported Browsers


No browser information at this time

Supported Database/DB Clusters


No DB information at this time.

Supported Virtualization Platforms

Tip
See the global page that lists all Virtualization-related information.

IPV6 Support for Common Interfaces


No IPV6 information for common interfaces at this time.

IPV6 Support for Additional Interfaces


No IPV6 information for additional components at this time.

Prerequisites


Notes:
  • Be aware that Java SE 5, 6, and 9 are no longer supported by Platform SDK.
  • Customers using Platform SDK 8.0 and 8.1.0 must upgrade to version 8.1.1 or higher using a Genesys-supported Java version.
  • For details about compatibility between Platform SDK protocols and specific Genesys servers for each major Platform SDK release, refer to Platform SDK Compatibility with Genesys Framework Components.
  • Platform SDK for .NET has no dependency on third-party libraries.

Platform SDK - Prerequisites

Third-Party Component Prerequisites

Acquired by Customer

Provided by Genesys

Conditions/Limitations

Third-Party Library Dependencies

Netty No Yes Release: 8.1.3
Platform SDK Java 8.1.3 requires netty-3.6.5.Final.jar
Netty No Yes Release: 8.5.1
Platform SDK Java 8.5.1: netty-3.9.4.Final.jar
Netty No Yes Release: 9.0
Platform SDK Java 9.0 requires netty-3.10.6.Final.jar
Netty No Yes Release: 8.1.2
Platform SDK Java 8.1.2 requires netty-3.5.11.Final.jar

Supported Versions

Java SE 11 Yes No Release: 9.0.004+
Java SE 7 Yes No Release: 8.1.1 - 8.5.2
Java SE 8 Yes No Release: 8.5+
Microsoft .NET Framework 3.5 Yes No Release: 8.0 - 8.5.2
Microsoft .NET Framework 4.5.2 Yes No Release: 8.1.2+
Microsoft .NET Framework 4.6 Yes No Release: 9.0+
Microsoft .NET Framework 4.7 Yes No Release: 9.0+
This page was last modified on February 20, 2019, at 15:00.

Feedback

Comment on this article:

blog comments powered by Disqus