Jump to: navigation, search

8.1 Interoperability with Configuration Layer Environment

This page describes the interoperability for Genesys 8.1 products with Configuration Layer Environment.

Symbol/Term Definition
yes
Version of the product is compatible with specified version of Configuration Layer.
no
Version of the product is not compatible with specified version of Configuration Layer.
n/a
Not applicable. The product does not depend on Configuration Layer.


8.1 Interoperability with Configuration Layer Environment

8.1 Products Configuration Layer Environment Conditions/ Limitations

7.6 8.0 8.1 8.5
Desktops and Gplus Adapters
Genesys Agent Scripting yes yes yes yes Works with Genesys Agent Desktop Versions 7.5 and 7.6.
Composer yes yes yes yes For further information, including usage of Composer in conjunction with URS and GVP, see the Composer production documentation.
Interaction Workspace no yes yes yes
  • Interactive Workspace 8.1.x does not support the multi-language feature of Configuration Server 8.5.
  • Configuration Server 8.0.2+ is required to support Role Based Access Control.
Framework
Genesys Administrator no yes yes yes
  • In order to perform monitoring of the Genesys environment using Genesys Administrator, version 8.0 of Framework Management Layer is required (in addition to Configuration Layer 8.0). For availability of product-specific monitoring features inside Genesys Administrator, and versions supported, please see the relevant product documentation.
  • For RBAC functionality of Genesys Administrator and for Hierarchical multi-tenancy,  Configuration Layer 8.0.2 is required.
Genesys Administrator Extension no no yes yes
  • In order to perform monitoring of the Genesys environment using Genesys Administrator Extension, version 8.1+ of Framework Management Layer is required (in addition to Configuration Layer 8.1+). For availability of product-specific monitoring features inside Genesys Administrator Extension, and versions supported, please see the relevant product documentation.
  • For RBAC functionality of Genesys Administrator Extension and for Hierarchical multi-tenancy, Configuration Layer 8.1+ is required.
License Reporting Manager
no yes yes no
Network T-Servers
yes yes yes yes
SIP Proxy yes yes yes yes Using Interaction Workspace 8.1.1 in Disaster Recovery deployment requires MFW 8.0.2+.
SIP Server yes yes yes yes Using Interaction Workspace 8.1.1 in Disaster Recovery deployment requires MFW 8.0.2+.
T-Servers yes yes yes yes
Load Distribution Server yes yes yes yes
Multi-Channel
intelligent Workload Distribution (iWD) no no yes yes In order to use the iWD  Stat Server Java Extension (included with iWD  8.x) to support current-day reporting through Stat Server clients such as CCPulse+, Stat Server 8.0+ is required.
eServices/Multimedia yes yes yes yes Formerly called Multi-Channel Routing [MCR]. See Genesys Migration Guide for more details on eServices interoperability.
Genesys Web Engagement
no
no
yes
yes Full interoperability details for all dependent products are included with the deployment guide.
Outbound Contact
Outbound Contact yes yes yes yes
Reporting
Advisors Cisco Adapter no yes yes no
Advisors Genesys Adapter no yes yes no
  • Advisors 8.1.2, 8.1.3, and 8.1.4 are compatible with Configuration Server 8.0.3xx.
  • Advisors 8.1.5 is compatible with Configuration Server 8.1.2.
Agent Advisor no yes yes no
  • Advisors 8.1.2, 8.1.3 and 8.1.4 are compatible with Configuration Server 8.0.3xx.
  • Advisors 8.1.5 is compatible with Configuration Server 8.1.2.
CCPulse+ no yes yes yes
Contact Center Advisor no yes yes no
  • Advisors 8.1.2, 8.1.3 and 8.1.4 are compatible with Configuration Server 8.0.3xx.
  • Advisors 8.1.5 is compatible with Configuration Server 8.1.2.
Contact Center Advisor - Mobile Edition no yes yes no Version 8.1.1, 8.1.2 and 8.1.4 Mobile Edition are available.
Contact Center Analyzer (CCA) yes yes yes yes
Frontline Advisor no yes
yes no
  • Advisors 8.1.2, 8.1.3 and 8.1.4 are compatible with Configuration Server 8.0.3xx.
  • Advisors 8.1.5 is compatible with Configuration Server 8.1.2.
Genesys Info Mart (GIM) yes yes yes yes At a minimum, Genesys Info Mart release 8.1 requires Interaction Concentrator 8.1.000.24. To enable all of the functionality provided in this release of Genesys Info Mart, Genesys recommends that you use Interaction Concentrator release 8.1.400.08 or higher.
Genesys Interactive Insights (GI2) n/a n/a n/a n/a
Genesys Interactive Insights for iWD n/a n/a n/a n/a
Genesys Pulse no no yes yes Genesys Pulse requires Genesys Administrator Extension, which requires Management Framework version 8.1.1 or higher.
Interaction Concentrator (ICON) yes yes yes yes
Real-Time Metrics Engine (RTME) yes yes yes yes
Workforce Advisor no yes yes no
  • Advisors 8.1.2 and 8.1.3 is compatible with Configuration Server 8.0.3xx.
  • Advisors 8.1.4 is compatible with Configuration Server 8.0.3xx.
  • Advisors 8.1.5 is compatible with Configuration Server 8.1.2.
Routing
Orchestration Server (ORS)
no
yes
yes
yes Orchestration Server 8.0 and 8.1 do not require a T-Server connection. However, Orchestration Server 8.0 and 8.1 with Voice Mode require a T-Server connection. See details in ‘Interoperability for T-Servers’ section.
Universal Routing (UR)
yes yes yes yes
SDKs
IVR SDK yes yes yes yes
Platform SDK yes yes yes yes
See Platform SDK Interoperability with Genesys Components for more detailed information.
Voice Self Service
Genesys Voice Platform (GVP) no yes yes yes Requires Genesys Administrator 8 for both configuration and management functionalities.
Interactive Voice Response (IVR) Interface Option yes yes yes yes
Workforce Management
Genesys Quality Management yes yes yes yes
Genesys Workforce Management yes yes yes yes
Other Products
Genesys Mobile Services no no yes
no
Genesys Rules System yes
yes
yes
yes
Genesys Speech and Text Analytics no no no no

SIP Voicemail Server yes
yes
yes
yes Requires SIP Server 8.1.


This page was last modified on September 20, 2018, at 11:05.

Feedback

Comment on this article:

blog comments powered by Disqus