Jump to: navigation, search

Reports

Report templates are "shells" of reports that describe the fields to be displayed and their sub-totaling and grand-totaling logic. Report templates are accessed using the Report Expert window. To access the Report Expert window, click the Reports icon, or click Results > Report Expert. This window enables you to:

  • Create a new report template by clicking the Create Template button, and clicking OK.
  • Edit an existing report template by highlighting the report template name in the list, selecting Edit Template, and then clicking OK. Note that, if you edit a report template, it will be changed for all users.
  • Delete an existing report template by highlighting the report template name in the list, selecting Delete Template, and then clicking OK. Note that if you delete a report template, it will be deleted for all users.
  • Open an existing report template by selecting Open a Report from an Existing Report Template, and then highlighting the report template name in the list and clicking Ok.

What is Report Viewer?

The Report Viewer displays report templates and allows you to select and interactively modify report characteristics, such as the date range, weekly or monthly display, and Center, Staff, and Contact Type. The Report Viewer window enables you to:

  • Select the Center, Staff Type, Contact Type/Group and/or Business Unit to display. You also have the ability to sort these in ascending and descending order. The All selection remains at the top for easy access. The ability to collapse this along with the date and type of scenario data is available for maximum viewing capabilities. To do this,click the subtraction symbol in the upper left hand corner of the report viewer. If the symbol has changed to an addition sign, this means that it is already collapsed.
  • Select the display of weekly or monthly values by going to Settings > Time Interval and selecting between Weekly or Monthly.
  • Select the kind of data you would like to display on the report and the start and end dates of each (i.e. scenario, actual history and/or scenario history). The ability to collapse this along with the Center, Staff Type, Contact Type/Group and/or Business Unit selection is available for maximum viewing capabilities. To do this, click the subtraction symbol in the upper left hand corner of the report viewer. If the symbol has changed to an addition sign, it means that this section is already collapsed.
  • Select the sort order of fields that are displayed. See Modifying the Order of Rows and Columns on a Report for more information.
  • Compare similar reports. The compare feature is located in the report template itself.
  • There is a zoom bar in the bottom right hand corner of the window to allow for maximum viewing capabilities. Adjust accordingly so you are still able to read text.

Creating a Report Template

To create a new report template:

  1. Click the Reports button, or click Results > Report Expert. When in the template window, click File > Report expert. The Report Expert dialog box will open.
  2. Select Create a New Report Template. The New Template window will open.

In the Report Template Settings window, the user must create a Report Template Name and then select a Security Setting. These settings include Public, Public Read-Only, and Private.

  • Select Public to allow full access for all users (View, Edit, Copy, Execute, Delete).
  • Select Public Read-Only to allow full access for the creator. Limited access for other users (View, Copy, Execute).
  • Select Private to allow full access for the creator and no access for other users.
  • Enter a name for the template in the Template Name field.
  • Select the fields you wish to include on the report from the Available Fields column on the left of the window. Note that selecting the bolded field category will select all fields in that category. Click Add.
  • To find metrics to add to the report template, there is a search field directly below the template name. Type the metric name or part of the metric name you are searching for and click Search Fields or press enter. This will highlight the first metric that relates to the search. By clicking the Search Fields button or pressing enter again, the next related metric in the available fields list will be highlighted.
  • If you wish to delete fields from the report, highlight the fields you wish to remove in the Selected Fields column, and click remove.
  • Click Save to save the template.
    The Report Viewer window will open using the new template.

Modifying Fields on a Report Template

  1. Click the Reports button or click Results, and then click Report Expert. The Report Expert dialog box will open.
  2. Select Edit an Existing Report Template.
    The Edit Template window will open.
  3. Alternatively, from within the Report Template, click the File button.
    The Edit Report Template window will open.
  4. Select the fields you wish to include on the report from the Available Fields column on the left of the window. Note that selecting the bolded field category will select all fields in that category. Click Add.
  5. If you wish to delete fields from the report, highlight the fields you wish to remove in the Selected Fields column and click remove.
  6. Click Save to save the template, or Save As to save your changes under a new name.
  7. If you wish to change the order in which fields are displayed in your report, refer to Modifying the Order of Rows and Columns on a Report.
    The Report Viewer window will open using the new template.

Modifying the Order of Rows and Columns on a Report

  • In the Report Template, drag and drop the Center, Staff, and/or Contact type headers into the gray bar at the top that reads, Drag a column header here to sort by that column.”This will break down the totals into sub totals for the corresponding Center, Staff, and/or Contact type you sort by.
  • Sort metric information in the report template by dragging and dropping the entire row where you see fit in the template. Click and hold the left mouse button on the gray box with a black arrow to drag the metric up and down the report template.
  • In the Report Template, change the color of the metric rows containing data by selecting the Display Options menu dropdown and going to Colors.
  • Click the Field Chooser button for the ability to hide and unhide entire columns you do or do not want visible in the report. If the Field Chooser icon is blue, this means a column is hidden within the report.
    Summary information for the specific metric is in gray text and is located at the bottom of the expanded metric. It is based on the lowest sorting header in descending order:
    • CenterType – subtotals cannot be shown when sorted by this column header.
    • StaffType
    • ContactType
  • Click the header for the column in order to change the sorting order from descending to ascending and back again.
  • Column summaries are displayed at the end of the Summary row for each metric. You can disable these in the settings.
  • Any column that has a header can also be filtered as well. A blue filter icon indicates a filter is applied. Default filter features are:
    • Equals (value or text)
    • Doesn’t Equal (value or text)
    • Begins with… (value or text)
    • Ends with… (value or text)
    • Contains… (value or text)
    • Or Custom Filter
  • The thumbtack feature keeps a date or metric column pinned to the far left side of the report so you can sort through the data without the column moving. This is very similar to how freeze pane works in Microsoft Excel©. If a thumbtack is removed, the column that was pinned will return to its original sorting position.
  • In the options menu, you have the ability to collapse and expand all available metrics.

Custom Filtering

Customer filtering enables you to filter out columns of your choice with any of the specified criteria below. The conditions are what enable you to filter data within the specified columns. The user has the ability to filter by multiple conditions as well.

To apply a custom filter, click the funnel icon, select Text Filters and click Custom Filter…. This enables the Enter filter criteria for (column you are attempting to filter) box where you have the following options:

  • Condition Operator: This is the filter by section of the condition where you choose between the following options:
    • Equals – Matches whatever entry is in the operand box.
    • Does Not Equal – Does not match whatever entry is in the operand box.
    • Greater Than – If text is involved, whatever is alphabetically greater than the entry in the operand box will display.
    • Less Than – If text is involved, whatever is alphabetically less than the entry in the operand box will display.
    • Greater Than or Equal to – If text is involved, whatever is alphabetically greater than the entry in the operand box will display including current entry.
    • Less Than or Equal to - If text is involved, whatever is alphabetically less than the entry in the operand box will display including current entry.
    • Like – Condition that has to match exactly what is entered in the operand. Example: If you are looking for a Category of Telecom, you must type Telecom in the operand box.
    • Matches Regular Expression – Condition that pulls anything containing the current entry into operand whether it is partial or whole entry.
    • Starts With – Condition that pulls anything that starts with the letters or numbers entered within the operand field.
    • Contains – If the column that you are searching by contains the characters in the typed order of the operand field, they will display.
    • Ends With – Condition that pulls anything that ends with the letters or numbers entered within the operand field.
  • Condition Operand Acts as the constraint to which you filter your data. You can type partial entries and select from a dropdown depending on the entry.
  • The Operator and Operand complete one condition for the search. However, the ability to have multiple conditions is available. To do this, click the Add a Condition button.
  • Once you add a second condition or more, the options for And or Or conditions become available. And conditions display results only if ALL the conditions are met. Or conditions display results if at least one of the conditions is met, otherwise does not display anything.
  • Click OK to execute the conditions and display the results.

Opening a Report Template

To open an existing report template

  1. Click the Reports button or Click Results, and then Report Expert. The Report Expert dialog box will open.
    The box will open with Open a Report from an Existing Report Template selected.
  2. Click Show: My Templates, to display only those report templates that you have created. Otherwise, the system will display all templates which all users have created.
  3. Click the name of the report that you wish to run.
  4. Click OK, and the report viewer will open.
Tip
Report templates can also be opened by clicking on the report template name displayed at the bottom of the Results drop down menu on the menu bar. The drop down menu will show recently accessed report templates.

Using the Report Viewer

Once you have selected a report template to view, the Report Viewer window will open. This window contains a set of options that enable you to "drill" up or down through the various levels of your center network, and select date ranges and other characteristics of your report without modifying the report template. The data that is returned, as a result of your selections, is the final report.

  • Select Settings -> Time Span: Weekly or Monthly, to show weekly or monthly values.
  • Select Settings -> Currency: Local or Base, to show different monetary amounts while reporting.
  • Select History: Actuals, Scenario, or None to display history in the report. Select the date ranges for the selected data sets.
  • Select Center Staff Contact Type or Business Unit to choose a specific workgroup to view, or select All in any of the drop down boxes to consolidate values for Centers, Staff, and Contact Types.
  • Select File -> Export to export the data to an optional program. Available formats are the following:
    • CSV format exports in .csv format for Microsoft Office Excel use.
      • Classic export shows the classic format the reports used to be in previous versions of the software. This is for easy manipulations for customers who are already using the current report exports to populate another analysis tool.
    • Excel format exports in .xls format for Microsoft Office Excel use. This export contains the scenario information in grouping format for collapsible metrics.
      • Classic export shows the classic format the reports used to be in previous versions of the software. This is for easy manipulations for customers who are already using the current report exports to populate another analysis tool.
    • HTML format exports to your default browser set in windows. (i.e. Internet Explorer, Firefox, Safari, etc.)
  • Click Execute, to display the report values.

Using the Report Viewer Scenario Comparison

The Report Viewer contains a comparison feature which enables you to save a report from a scenario, change your scenario, and then create a new report that compares to your old scenario.

  • From the Report Viewer window, execute a report, and click the Compare dropdown button.
  • Click Save For Comparison. The Save As dialog box will open.
  • Choose a name for your comparison file, and click Save.
  • Change the scenario assumptions or open a new scenario.
  • Execute the same report template, as previously with the same settings in the template for Display Options, Data Sets, Currency, Center, Staff Type, and Contact Type, as in the saved report file.
  • Click Compare, Open Comparison File. Choose the filename previously saved.
  • Once the comparison is open, use the tabs at the bottom of the report viewer to switch between the current report values, the saved comparison values, and the differences.
  • If the comparison is open in the report viewer, the ability to export is available.
  • These tabs are also available if you export the comparison to Excel. If you have exported the data and saved it, a box will prompt you to open the file, the containing folder, or cancel to make other changes before opening comparison exports. The export shows all of the values in different tabs, including differences (but only in Excel, not CSV)
  • When you are finished using the comparison, instead of closing out of the report, click the Comparison menu dropdown and select Close Comparison.
Important
In order for the comparison to generate, the Report Viewer settings that generate each report must be identical. If the settings are not identical, an error message will display, indicating that the settings that do not match. You may also use the Variance Analysis window to compare two scenarios by saving each scenario as a budget and then comparing them to each other.

Feedback

Comment on this article:

blog comments powered by Disqus
This page was last modified on August 14, 2018, at 14:11.