Jump to: navigation, search

Supporting Software Components

Advisors components and all related components (Stat Server, Configuration Server) must be installed on the same network.

All physical servers used in a given Advisors installation must have their system clocks synchronized with a central time server.

Before commencing Advisors migration, ensure that the following external software is installed on the appropriate physical computer involved in Advisors operation:

  • Java Development Kit (JDK) – Advisors application support for Java changes starting with release 8.5.2. Check the Genesys Supported Operating Environment Reference Guide for information about supported Java versions.
  • Apache HTTP Server
    If the Apache server is installed on the same machine as Advisors Platform, the Apache server must use a port other than 8080 (which is used by Advisors Platform). In most cases, Apache can use port 80.
  • One of the following Relational Database Management Systems (RDBMS):
    • Microsoft SQL Server
    • Oracle (applicable to Releases 8.1 and later)
      If you use Oracle, the appropriate Oracle JDBC driver is also required. You can obtain the driver from the Oracle Web site (www.oracle.com).

For information about specific versions of the preceding software components that are compatible with the Advisors release to which you are migrating, see the Genesys Supported Operating Environment Reference Guide.

Advisors and the Adobe Flash Player Plugin

Starting with release 8.5.2, the Advisors dashboards (Contact Center Advisor, Workforce Advisor, and Frontline Advisor) no longer require the Adobe Flash Player plugin in order to run. Currently, the Adobe Flash Player plugin is required only on machines on which you run the Advisors administration module.

Using Advisors Installation Wizards on Linux Servers

If you install Advisors components on Linux machines, be aware that there are additional security concerns related to Advisors installation. The Advisors installation wizards are graphical installers. To run these installers as they were intended, you require the X Windows System on your Linux machines.

Without the X Windows System, passwords that you enter during the installation process display in plain text; therefore, during installation, Genesys recommends that you take extra precautions to ensure that only users with the correct security permissions are allowed to view the screen where you are running the Advisors installers.

Advisors Applications and Adapters

The following Table shows which Advisors adapter to install for each Advisors application.

Important
The Advisors Cisco Adapter is available only for Advisors releases prior to release 8.5.2. Support for Cisco data sources is discontinued starting with Advisors release 8.5.2. Advisors Cisco Adapter release 8.5.100.09 was the final release for this Advisors component.
Application Cisco Data Source Genesys Data Source Mixed Data Sources (Cisco and Genesys)
Contact Center Advisor No Adapter required Advisors Genesys Adapter Advisors Genesys Adapter
Frontline Advisor Advisors Cisco Adapter Advisors Genesys Adapter Advisors Cisco Adapter for the Cisco data source and Advisors Genesys Adapter for the Genesys data source
Contact Center Advisor and Frontline Advisor Advisors Cisco Adapter Advisors Genesys Adapter for CCAdv and Advisors Genesys Adapter for FA Advisors Genesys Adapter for CCAdv (CCAdv does not require an adapter when installed with Cisco data sources). Advisors Genesys Adapter for FA for the Genesys data source and Advisors Cisco Adapter for FA for the Cisco data source.
Important
AGA serving both FA and CCAdv/WA from one system is not recommended for performance reasons.

Contact Center Advisor–Mobile Edition

Before commencing migration, ensure that the following software is installed on the appropriate physical computer:

  • Windows Server or Red Hat Enterprise Linux
  • Microsoft SQL Server or Oracle
  • Java JDK
  • Apache or Apache SSL Secure Web Server
  • Advisors Platform
  • Contact Center Advisor

Not all releases of CCAdv/ME support all of the preceding software. For compatibility and supported versions of the preceding software, see the Genesys Supported Operating Environment Reference Guide.

Important
Starting with release 8.5.2, CCAdv–ME is no longer supported.

Feedback

Comment on this article:

blog comments powered by Disqus
This page was last modified on February 7, 2018, at 21:44.