As of Friday October 16th, access to restricted content on this site now requires you to log in with your Genesys account. If you don't have an account, you can request one at these locations: Request MyPartner Portal Account or Request My Support Account.
Jump to: navigation, search

9.0.003.09

Advisors Platform is part of 9.x starting in 9.0.000.06.

Advisors Platform Release Notes

Release Date Release Type Restrictions
04/17/20 Update

Advisors Platform is platform-independent software. You can deploy the installation package on any operating system that Advisors Platform supports.

Helpful Links

Releases Info

Product Documentation

Genesys Products


What's New

  • Updated Platform—Tomcat server has been upgraded to version 9.0.33 to address a potential security vulnerability with AJP requests. For details, see Injection and potential Remote Code Execution (CVE-2020-1938).
    As a result of this upgrade, you need to do the following Pulse Advisors configuration:
    • On the Platform installation of the Advisors web services, edit the apache-tomcat-9.0.12/conf/server.xml file to add the following attribute in the AJP connector section: secret="your_secret". The value of secret is a validation key between Apache and Tomcat. For example:
      <Connector port="${AJPPort}" protocol="AJP/1.3"
                 connectionTimeout="${WebConnectorConnTimeout}"
                 maxThreads="${MaxThreadPoolSize}" maxConnections="${MaxThreadPoolSize}" minSpareThreads="${MinThreadPoolSize}"
                 redirectPort="${HTTPSPort}" relaxedQueryChars="[,]" secret="your_secret" address="TOMCAT_HOST_IP"/>
    • If the Apache HTTP Server and Tomcat are on different hosts, then you must add an attribute of address="TOMCAT_HOST_IP" to the AJP connector section as well. See the preceding example. For detailed information, see Tomcat configuration documentation.
    • The Apache HTTP Server Proxy configuration needs to be updated to pass the configured secret in each of the ProxyPass directives. For example, here is an updated Proxypass directive:
      ProxyPass / ajp://<hostname>:8009/ secret=your_secret
      For details, see Apache mod_proxy_ajp configuration.
    For additional information about Apache Web Server configuration for Pulse Advisors, see Deploy and Configure Apache in the Pulse Advisors Deployment Guide. On that page, the section titled Configure Routing for Advisors Components describes the ProxyPass directives for Pulse Advisors. The section titled Configuring Tomcat AJP connector contains the preceding information with additional detail.
  • Compatibility—This release is compatible with the following Advisors components:
    • Advisors Genesys Adapter release 9.0.003.09
    • Contact Center Advisor/Workforce Advisor release 9.0.003.09
    • Frontline Advisor release 9.0.003.09



Resolved Issues

This release contains the following resolved issues:


Contact Center Advisor (CCAdv) XML Generator no longer throws ORA-04068: existing state of packages has been discarded exceptions. Previously when this happened, the import process and dashboard updates would fail. This occurred only in installations with Oracle. (PLT-8299)



Upgrade Notes

No special procedure is required to upgrade to release 9.0.003.09.

This page was last edited on April 17, 2020, at 16:34.

Feedback

Comment on this article:

blog comments powered by Disqus