Jump to: navigation, search

9.0.015.04

Predictive Routing - Agent State Connector Release Notes


9.0
Predictive Routing - Agent State Connector is part of 9.0 starting in 9.0.006.06.
Release Date Release Type Restrictions AIX Linux Solaris Windows
07/19/19 General Under Shipping Control X X

Helpful Links


What's New

This release includes the following new features and improvements:

  • The numeric datatype now replaces both float and integer datatypes in Agent and Customer Profiles. This change resolves confusion about when to use float and integer datatypes.
    This is a breaking change from previous releases of AICS and Agent State Connector (ASC). If you upgrade either component you MUST also upgrade the other. The following versions are compatible:
    • AICS 9.0.015.03 and higher + ASC 9.0.015.04 and higher.
    • AICS 9.0.015.00 and lower + ASC 9.0.015.01 and lower
    (PRR-4834; PRR-5100)
  • You can now optionally run ASC without a connection to Stat Server. ASC automatically detects whether there is a Stat Server Application in the ASC Application Connections tab. If so, ASC connects as in previous releases. If not, ASC does not connect to Stat Server and does not send agent login status updates to the GPR platform. In this case, AICS receives agent availability information from Universal Routing Server (URS). (PRR-4569)
  • ASC now validates the values you enter in the include-skills and include-groups configuration options. If ASC detects a skill name or Agent Group specified in these options that does not exist in Configuration Server, ASC triggers one of the following Standard-level log messages (Message Server log event number: 60401):
    • The following Agent Groups are not found in Configuration Server. Please verify the correct names for these Agent Groups: ".."
    • There are no agents present in Configuration Server with the following skills. Please verify the correct names for these skills: ".."
    (PRR-4344)
  • The Deployment and Operations Guide now contains complete instructions for configuring HTTPS connections among all GPR components. Configure GPR to Use HTTPS


Resolved Issues

This release contains the following resolved issues:


ASC deployed with Java 8 no longer generates a ConcurrentModificationException error message. This error message was the result of a known issue with Java 8. (PRR-4511)


ASC now logs the Duplicate 'RequestID' log message as an error instead of a warning. You can safely disregard this error message. (PRR-4388)



Upgrade Notes

No special procedure is required to upgrade to release 9.0.015.04.

This page was last modified on July 19, 2019, at 11:21.

Feedback

Comment on this article:

blog comments powered by Disqus