Jump to: navigation, search

Creating a Template in GRDT

Rule Templates are created as Projects in GRDT. The New Project Wizard is used to create new templates.

New Project Wizard

The New Project Wizard guides you through the steps to create a new Rule Template Project. This wizard can be accessed in the following ways:

  • Select File > New > Rule Template Project from the menu bar.
  • Right-click within the Project Explorer and select New > Project from the context-sensitive menu.

The wizard leads you through the following steps:

  1. The first screen prompts you to select which wizard you need that is, which type of project you wish to create. If it is not already selected, navigate to Genesys Rules System > Rule Template Project and click Next.
  2. Enter a name for the new template project. Template names must be unique within a tenant. Either use the default location, or clear the check-box and select a new location. Click Next.
  3. Verify the type of template you are creating in the drop-down list. The default template type is Stateless. To create an iWD template, select iWD. To create a template  for Genesys Web Engagement, select type CEP.
  4. Important
    CEP support requires the presence of GWE to function.
    Important
    The iCFD template type has been removed. The iWD template type is the only reserved template type. Any other new template types required can be created by using the Configure Types link (see step 4).
  5. Click the Configure Types link to create new template types or maintain existing ones.
  6. Use the Enable event support check box to indicate whether the template will support events. In templates that support events, the Fact Model editor can be used to create both facts and events.
  7. Select the appropriate Tenant, and enter a description of the template.
  8. Click Finish. The new template project will now appear in the Project Explorer.

Editing and Configuring Rule Templates

Once it is created, the rule template appears in the Project Explorer. Expanding the template displays a list of components that can be configured. Double-click the component type in the Project Explorer to open the appropriate Editor and begin configuring components.

Renaming Rule Templates

Renaming rule templates does not change the name within the repository. When you publish the renamed rule template, it will be added to the repository as a new template, and the template with the old name will still exist.

You can rename your template by right-clicking the template in the Project Explorer and selecting Rename from the context-sensitive menu, by selecting the template and navigating to File > Rename, or by selecting the F2 key on your keyboard. Many features can be accessed in similar ways.

Important
In release 8.1.2, duplicate template names are not allowed within tenants, but are allowed in different tenants. Creating such a duplicate name will rename the project, but the name as published in GRAT is set via Project/Properties/Template Properties.

Copying Rule Templates

Existing rule templates can be copied to be used as a basis for a new template. Right-click the template in the Project Explorer, and select Copy. As with renaming, there are multiple ways to access the Copy functionality, such as the  Ctrl + C keyboard shortcut, Edit > Copy, and so on.

Deleting Rule Templates

Rule templates can be deleted using the GRS Server Explorer, provided that:

  • The user has rule template delete permissions, and;
  • The rule is not used in any rule package.

Feedback

Comment on this article:

blog comments powered by Disqus
This page was last modified on September 19, 2016, at 09:48.