As of Friday October 16th, access to restricted content on this site now requires you to log in with your Genesys account. If you don't have an account, you can request one at these locations: Request MyPartner Portal Account or Request My Support Account.
Jump to: navigation, search

How to Use the Migration Information

Composer 8.1.2 allows you to migrate routing strategies created with Interaction Routing Designer 8.0+ into Composer Projects as SCXML-based workflow diagrams, which can run on the Orchestration Platform. This guide details the process for doing so.

Important: Composer 8.1.2 migration only supports IRD 8.0+. If the exported IRD XML strategy files were created in versions prior to IRD 8.0, the migrated content may not be supported. In the case where the IRD XML strategy is not version 8.0+, please import the strategy to an Interaction Routing Designer 8.0+ version, make a small change, save, and export as XML. This will insure that the exported IRD XML format is compliant for the IRD to Composer 8.1.2 Migration.

Read a summary of the process below.

Summary of Migration Process

  • Your strategies must be Interaction Routing Designer (IRD) 8.0+ strategies before starting this process. For information on migrating IRD strategies, refer to Chapter 1 in the Universal Routing 8.1 Reference Manual.
  • Start by using IRD to export the strategy as an XML file. Use IRD's Export to File option. Set Files of type to (*.xml) (open). You can also export export multiple strategies at once.
  • Continue in Composer by using File > Import > Composer > Import IRD Strategy to bring up a wizard. Browse for the XML file(s) to import, select the Composer Project, and click Finish to start the migration process.
  • View the imported strategy as a workflow diagram in Composer's *.workflow diagram editor. The migration process attempts to re-create the IRD strategy so it can run on the Orchestration platform.
  • A dialog box appears asking if the user would like to see the migration report. Consult the migration report, which indicates the status of objects migrated and indicates if any manual steps are required. The report also appears in Composer's Reports project folder. When viewing the report in the future, right-click the report and select Open With > Web Browser. Or open the Internal Web Browser view (Window > Show View > Other > General).
  • After making any necessary changes to the workflow diagram, click the Validate button on the main toolbar to check that objects exist in the Configuration Database to which you have connected. In the case of errors, the Problems view becomes visible and error markers are put on the blocks that contain errors. Double clicking on an error in the Problems view will take you to the corresponding blocks that contain the errors. Review each of the errors and do the fixes, then validate again.
  • After successful validation, click the Generate Code button on the main toolbar to create a properly-formatted SCXML file from the workflow diagram. Static pages (pure SCXML code) are generated in the src-gen folder of the Composer Project.
  • Use the Log block under Flow Control to record information about an application.

Command Line Migration

A command line interface is also supported for migrating IRD strategies to Composer. Below is a sample command line that can be used to launch Composer and migrate strategies in bulk:

Composer.exe -console -consoleLog -debug --launcher.suppressErrors -migrate -composerProject "JavaComposerProject" -irdXmlFile "D:\\Documents and Settings\\skathire.AP01\\Desktop\\New Folder\\URS_Multifunc5_drop3.xml" -Xms40m -Xmx256m -XX:MaxPermSize=256m

Command Line Argument
Required
Description
-migrate Yes
IRD Migration flag to indicate that a command line migration is involved. The other command line arguments, listed below, are used for information on what IRD exported XML file(s) should be used for the migration.
-composerProject Yes
An existing Composer project where migrateddiagramsshould be added. Composer should be set to automatically use the workspace where this project exists.
-irdXmlFile

Yes (Mutually exclusive with "-irdXmlFolder".)

IRD XML File Location. Should be specified while migrating only a single file.

-irdXmlFolder

Yes (Mutually exclusive with "-irdXmlFile".)

IRD XML Folder Location for bulk migration. Should be specified only while migrating multiple files present in the specified folder. The migration will proceed to migrate the XML file extensions located directly under the specified folder. Please make sure any XML files not relevant to the exported IRD XML are not located directly under this folder.

Important: Use a new workspace for migrating IRD strategies using the command line method. If you use an existing workspace, graphical aspects of the diagram may not migrate over correctly, for example, you may see black color filled Entry and / or Exit blocks and the connectors will be of a different style, etc. If you need to use an existing workspace, use a new workspace for migration purposes and then copy over the Composer diagrams to the older workspace.

Note: Dialogs that are shown while migrating using the wizard are not displayed in the IRD command line migration execution. Continue with the About IRD To Composer Migration.

This page was last edited on August 10, 2016, at 16:34.

Feedback

Comment on this article:

blog comments powered by Disqus