Jump to: navigation, search

Configuration Prerequisites

Genesys Composer

The Conversation Rules template requires Genesys Composer release 8.1.300.89 at minimum.

Configuration Options

The following configuration options must be set in order to use the Conversation Rules template:

Genesys Rules Engine

  • json-hierarchical-driver = true

Genesys Rules Authoring Tool

These options control how GRAT connects to the Context Services REST API.

  • context-services-rest-api-protocolhttp or https
  • context-services-rest-api-host—Host name
  • context-services-rest-api-port—Port number
  • context-services-rest-api-base-path—The base path

Contact Server

  • map-names = true

When a rule package is deployed and map-name is set to true, the business attribute name is encoded in the rule package. With value false, the DBID is encoded in the rule package.

If the map-name option is changed on UCS at any time from rule authoring to deployment to actual operation, existing rule packages based on the Conversation Manager template must be redeployed.

This page was last modified on February 19, 2015, at 10:43.

Feedback

Comment on this article:

blog comments powered by Disqus