Jump to: navigation, search

Known Issues and Recommendations

Genesys Security Pack on UNIX

The Known Issues and Recommendations section is a cumulative list for all 8.5.x releases of Genesys Security Pack on UNIX. This section provides the latest information on known issues and recommendations associated with this product. It includes information on when individual items were found and, if applicable, corrected. The Resolved Issues section for each release describes the corrections and may list additional issues that were corrected without first being documented as Known Issues.



There is a known memory leak in Genesys Security Pack that originates in third-party software used by Genesys Security Pack. When using mutual TLS, 6 to 10 KB of memory will leak for each client connection accepted by a server application. The amount of memory leaked might increase if the client uses a long certificate chain or a certificate with many extensions.

The leak only occurs when a client connects to a server using mutual TLS. Connections using simple TLS are unaffected. Only server-side applications are affected.

Components that receive static connections from other applications will generally be unaffected by the leak. Components that receive many different client connections using mutual TLS will be affected by the leak. Client connections that reconnect frequently might also cause an active memory leak.

Recommendation: To keep the total amount of memory leaked at a reasonable level, try to reduce the number of client connections accepted when using mutual TLS. Do not use mutual TLS for client connections that are frequently received, served, and dropped.

ID: MFWK-16911 Found In: 8.5.100.02 Fixed In: 8.5.100.06


Internationalization Issues

Information in this section is included for international customers.


There are no internationalization issues for this product.


Feedback

Comment on this article:

blog comments powered by Disqus
This page was last modified on April 29, 2016, at 10:33.