Jump to: navigation, search

8.5.004.09

Genesys Info Mart Release Notes

Release Date Release Type Restrictions AIX Linux Solaris Windows
04/28/16 General X X X X

Helpful Links

Releases Info

Deployment Procedure

8.5.0 Deployment Procedure

Product Documentation

Genesys Info Mart

Genesys Products

List of Release Notes

What's New

This release contains the following new features and enhancements:

  • A new configuration option, link-vrp-vq-msf-to-irf, in the [gim-transformation] section, enables linking of the MSF record for a virtual queue to the IRF record for the target agent, with a technical result of Diverted/AnsweredByAgent, in scenarios where a nonself-service IVR port uses a virtual routing point for routing operations, and the strategy includes a virtual queue.

    The default value of false preserves the existing behavior of not linking the MSF record to the agent's IRF record, and assigning a technical result of Diverted/Unspecified.

    Important
    Do not change this value unless directed to do so by Genesys Customer Care.


Resolved Issues

This release contains the following resolved issues:


When upgrading Genesys Info Mart instances with a partitioned database, the following tables are now correctly created as partitioned tables:

  • SDR_EXT_REQUEST_FACT
  • SDR_USER_INPUTS_FACT

Previously in scenarios where Genesys Info Mart was upgraded to release 8.5.004.06 in Microsoft SQL Server and Oracle deployments, these tables were created as non partitioned.

Note that support for Genesys Designer and SDR_* tables is available only in certain Genesys Cloud implementations.

(GIM-10638)


The transformation job no longer fails in deployments where the Info Mart database resides on a Microsoft SQL Server RDBMS with the Turkish collation set. Previously in such deployments, the transformation job might fail with an error about Invalid column name 'CALLID'. (GIM-10626)


In PostgreSQL deployments, the update statistics job (Job_UpdateStats) no longer fails. Previously, when Genesys Info Mart release 8.5.003.12 or later was operating in a PostgreSQL deployment, Job_UpdateStats might fail with the error message: Database error: ERROR: relation "run_analyze_tables" does not exist. (GIM-10605)


Genesys Info Mart now correctly reports the technical descriptor in the IRF table in scenarios where:

  1. The introduced-transfer-threshold configuration option is set to a value greater than zero.
  2. An agent initiates a consultation call that goes through more than one nonself-service IVR Port prior to reaching a second agent.
  3. The consultation call is completed with a conference.
  4. The initiator of the conference hangs up before the number of seconds specified by the value of the introduced-transfer-threshold configuration option has elapsed.

Previously, Genesys Info Mart populated the IRF record for the conference recipient with an incorrect technical descriptor (66) referring to a resource role and reason of Unknown/Unspecified instead of ReceivedTransfer/IntroducedTransfer.

(GIM-10587)


In PostgreSQL deployments, Genesys Info Mart now correctly passes job history data to Genesys Info Mart Manager, allowing Genesys Info Mart Manager to correctly display job history information. Previously in such deployments, an error in the SQL query syntax prevented Genesys Info Mart from passing job history data to Genesys Info Mart Manager. (GIM-10582)



Upgrade Notes

Refer to the Deployment Procedure for this release to deploy the installation package within your environment.

Dependencies

  • To enable all of the functionality provided in this release, Genesys Info Mart requires Interaction Concentrator release 8.1.509.07 or higher. At a minimum, Genesys Info Mart release 8.5 requires Interaction Concentrator 8.1.100.36. For additional recommendations, see ICON Recommendations in the Known Issues and Recommendations section.
  • Genesys recommends that you manage jobs using Genesys Info Mart Manager, but if you continue to use Genesys Info Mart Administration Console, Genesys recommends that you use Genesys Info Mart Administration Console release 8.1.3 or higher.
  • Genesys Info Mart Manager release 8.5 requires Genesys Info Mart release 8.5.002 or later. Genesys Info Mart release 8.5 is compatible with Genesys Info Mart Manager release 8.1.4 and higher.

Feedback

Comment on this article:

blog comments powered by Disqus
This page was last modified on June 27, 2016, at 14:05.