Jump to: navigation, search

9.0.000.22

Billing Data Server Release Notes


Billing Data Server is part of 9.x starting in 9.0.000.01.
Release Date Release Type Restrictions AIX Linux Solaris Windows
04/12/19 General X


Helpful Links

Releases Info

Product Documentation

  • [[Documentation/|]]

Genesys Products


What's New

This release contains the following new features and enhancements:

  • New data handling options — BDS now offers enhanced options to more easily control how data is handled in premise (subscription) mode (whether it is uploaded to S3, or only stored locally), and to allow a wide range of usage metrics to be tracked. A new Premise section in the configuration .json file provides parameters to enable these options. For more information, see the Billing Data Server Deployment Guide. (CBILL-2510)
  • Genesys Chat configured (enabled) seats — The Genesys Chat metric now checks the interaction flag in the sm_fact dataset, and counts only sessions where at least one chat interaction was handled. (CBILL-2427)
  • Third-party work items metric enhancements — The Third-party work items metric now checks the interaction flag in the sm_fact dataset, and counts only sessions where at least one work item interaction was handled. (CBILL-2465)
  • Oracle support is now optional — Oracle support is no longer automatically installed with BDS. For information about how to add Oracle support, see the Billing Data Server Deployment Guide. (CBILL-2563)

Resolved Issues

This release contains the following resolved issues:


In scenarios where a gvm_mailbox is defined on more than one object, the voicemail_boxes metric now correctly represents the number of enabled voicemail boxes. Previously, BDS could double-report in scenarios where a gvm_mailbox was defined on more than one object, and both objects were of the same type with the same name, for example when a given agent login was defined on two switches for DR purposes, and had the same gvm_mailbox option value. (CBILL-2544)



Upgrade Notes

No special procedure is required to upgrade to release 9.0.000.22.

This page was last edited on April 12, 2019, at 20:03.
blog comments powered by Disqus