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Note: Not all changes listed below may pertain to your deployment.
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March 11, 2021 (9.0.043.00)

What's New
Resolved Issues

• The accuracy of Estimated Wait Time (EWT) values, used in the processing of scheduled callbacks, has
been improved. When calculating EWT, the system now excludes all calls that are not ready to be
routed. Previously, all calls in the queue – regardless of status – were being used to calculate the EWT.
(GES-2383)

• Call-in match requests now treat numbers in the DNIS pools with leading '+' characters as equivalent to
numbers without them. Previously, numbers in the DNIS pool with a leading '+' were unmatchable.
(GES-2194)

January 28, 2021 (9.0.040.00)

What's New
Resolved Issues

• Click-To-Call-In Group configuration no longer expires after 2 weeks of inactivity. (GES-2314)
• Scheduled callbacks that are booked without the inclusion of the userData parameter now correctly

start processing at the Estimated Wait Time (EWT) number of minutes before the desired callback time.
Previously, Scheduled callbacks that did not include the userData parameter didn't start processing
until after the desired callback time had passed. (GES-2290)

• An issue has been fixed that sometimes interfered with the operation of rescheduled callbacks.
Previously, when the desired time of an already-scheduled callback was rescheduled to an earlier
desired time, the new desired time was updated in the callback record and displayed in the UI, but the
system continued to use the original desired time as the time at which to fetch the callback for
processing. As a result, the exclamation mark warning icon – an indicator that a callback is past due –
displayed for these rescheduled callbacks. (GES-2249)

• Creating a new rule on the Permitted & Blocked Numbers page in the UI using the Select All
Countries check box now saves correctly. Previously a rule of this type provided no error message
when saving, but the new rule failed to display in the drop-down list of saved rules on the Permitted &
Blocked Numbers page and it wasn't available for selection on the Callback Queues page.
(GES-2149)
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November 25, 2020 (9.0.039.57)

What's New
Resolved Issues

• Precise Estimated Wait Time (EWT) values are now used in callback processing for scheduled callbacks.
Previously, EWT for scheduled callbacks was capped at 90 minutes. In cases where the EWT was longer
than 90 minutes, callback processing did not begin until 90 minutes before the desired time.
(GES-2285)

November 12, 2020 (9.0.038.92)

What's New
General maintenance

• The Genesys team made a few minor updates to improve your experience.

November 5, 2020 (9.0.038.91)

What's New
UI improvement

• To improve accuracy in the UI, the Desired Callback Time now includes a grace period, which must
elapse before a scheduled callback displays a warning.

Changes associated with Firebase credential testing

• The Test Firebase Credentials section of the Credential Management > Push Notification page
has been updated to accommodate changes associated with version 7.0 of the Firebase API/SDK. This
change should not impact any apps already leveraging GES/Callback Push functionality other than the
testing of provisioned credentials. In addition, the changes to testing your credentials in the Callback UI
will not interfere with or otherwise break any existing Firebase/Push integrations. Regardless, Genesys
recommends that you conduct your own testing to verify the correct operation of all apps that use
callback-related Push Notifications.

When upgrading the Firebase client to version 7.0, you require the following information for each
Firebase web app when testing the credentials in the Callback UI:

• App ID
• Public API Key
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• Sender ID

• The Project Name entry is no longer redacted on the Credential Management > Push Notification
page.

Updates to the phone number validation process

• The phone number validation process has been updated to accommodate recent changes in some
countries, such as the addition of new area codes.

Resolved Issues

• You can again test your Firebase Cloud Messaging (FCM) Push Notification credentials using the Callback
UI. Previously, an issue with the Push Notification service sometimes interfered with the credential
testing capabilities on the Credential Management > Push Notification page in the UI. In addition,
there were changes in FCM that might impact your configuration. More specifically, you might have to
update your Firebase projects in order to successfully test credentials in the Callback UI. For more
information, see the entry for FCM in the Firebase JavaScript SDK Release Notes, under Version 7.0.0 -
September 26, 2019.

June 18, 2020 (9.0.036.01)

What's New
Resolved Issues

• An issue has been fixed that sometimes caused a scheduled callback to be missing the original call
data.

May 28, 2020 (9.0.035.55)

What's New
General maintenance

• Genesys continuously reviews and monitors product functionality; this release includes minor updates
and improvements in the UI.

Resolved Issues

• On the Region Affinity Rules page in the UI, the buttons for creating a new rule, deleting an existing
rule, and saving a rule no longer display for users with read-only access. Clicking and dragging a region
name is also disabled for those users.
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• An issue has been fixed in the Callback UI that previously let users see callbacks for queues that were
restricted to them based on line-of-business filtering.

April 9, 2020 (9.0.034.43)

What's New
Region Affinity

• The Callback UI has a new page under the Tools tab: Region Affinity Rules. A Region Affinity rule
specifies the region or regions that you want to use to manage interactions for a given callback
queue.This is an advanced feature. You must consult with your Genesys representative before you use
it. The Region Affinity Rules page is described in the Configuring Region Affinity rules.

Resolved Issues

• You can now log in to the Callback UI over MPLS.
• An issue has been fixed that sometimes caused a delay in fetching stats from the Statistics API.

April 2, 2020

What's New
Routine maintenance

• Genesys is performing routine maintenance on the operating system. There are no other changes.

February 20, 2020 (9.0.033.56)

What's New
Changes to auto-cancel of longstanding PROCESSING-state callbacks

• Callback includes a feature that automatically cancels callbacks that are in the PROCESSING state for
more than 30 minutes. The feature is now disabled by default. Contact Customer Care to have the
feature enabled in your environment.

Performance and stability enhancements
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• As part of our continuous effort to make things better, this release includes performance improvements,
which in turn improve callback resiliency.

Resolved Issues

• When creating a custom date range in the Advanced Options dialog on the Callback tab, you can
now include spaces in the name. Previously, if you included at least one space in the name of a custom
date range, Callback failed to recognize the offset values (the number of days before and after) and no
results were displayed on the tab for that date range.

January 07, 2020 (9.0.032.04)

What's New
Auto-cancel of longstanding PROCESSING-state callbacks

• Callback now automatically cancels callbacks that are in the PROCESSING state for more than 30
minutes. All callbacks cancelled as a result of this condition will appear in the Callback UI as
COMPLETED (CANCELLED_BY_SYSTEM).

Performance and stability enhancements

• As part of our ongoing commitment to improve customer experience, this release has functional and
performance improvements that include updates to the Callback tab in the UI.

November 7, 2019 (9.0.030.40)

What's New
Support for Edge browsers

• Callback is now supported on EdgeHTML version 16.0 and up and on the new Chromium-based Edge.

Performance and stability enhancements

• Genesys is always looking for ways to improve customer experience. In this release, we're rolling out
the following performance and stability enhancements to improve both your user experience and your
consumers' experience:
• Ongoing styling and performance improvements to the UI, including enhanced diagnostic data for

callbacks.
• More precise handling of Scheduled callbacks to ensure that they are never purged from the queue

before the Desired Callback Time.
• Improved accuracy for starting scheduled callbacks.
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• Improved monitoring and handling of large volumes of concurrent callbacks.
• Improved performance and stability to better handle environmental changes or failures.

Resolved Issues

• In the UI, filtering the list of callbacks based on a specific callback state now works correctly. Previously,
callbacks in a state other than the one on which you were filtering could sometimes be included in the
list, although this rarely happened.

October 10, 2019 (9.0.029.90)

What's New
Partial support for Edge browsers

• Microsoft Edge and Chromium-based Edge support is now in the beta phase. Although most
functionality is supported, you might experience some display issues. Ensure that you are running the
latest version of Edge.

Access to GWS statistics

• You can now access GWS statistics through the Genesys Engagement Services (GES) Statistics API. To
use the Statistics API, you must first register your GWS credentials with Callback using the new GWS
Credentials tab under Developer > Credential Management in the Callback UI.

Callback-type indicator on queues

• On the Tools > Queues page in the Callback UI, icons beside each queue name indicate if the queue
supports Immediate callbacks ( ), Scheduled callbacks ( ), or both.

Performance and stability enhancements

• Genesys is always looking for ways to improve customer experience. In this release, we're rolling out
the following performance and stability enhancements to improve both your user experience and your
consumers' experience:
• Improved response times in the Callback UI.
• Improvements to Scheduled callbacks, ensuring that they start at the correct (desired) time.
• Internal improvements that maximize service availability and minimize time spent troubleshooting.
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September 26, 2019 (9.0.028.35)

What's New
Callback UI Enhancements

• This release includes the following UI enhancements:
• On the Tools > Queues page, you can now open a Filter Displayed Queues dialog in which you

select the specific queues that you want to display on the Callback Queues page.
• On the Callback tab, in the State column, a calendar icon displays beside callbacks that are

scheduled. If there is no icon associated with a callback's state, then the callback is immediate.

September 5, 2019 (9.0.027.59)

What's New
Upload JSON-format capacity data

• To make it easier to add data to your new or existing capacity rule, you can now copy JSON-format
capacity data from a file and paste it directly into an open and focused capacity rule. The rule is
updated with the pasted data; this overwrites all existing data in the rule. For more information, see
Using JSON-format capacity statements to configure a capacity rule.

Updates to diagnostic data associated with callback records

• On the Callback tab in the UI, the following updates have been made to the diagnostic data that is
available for callbacks:
• There is now diagnostic data, including error messages, available for a callback that is in the

SCHEDULED state.
• When a callback in the SCHEDULED state remains in that state past the Desired Callback Time, a

Warning icon displays to alert you. Hovering over the icon displays a message.

August 8, 2019 (9.0.026.60)

What's New
UI styling enhancements

• The following Callback UI pages have been re-designed for an improved user experience:
• Call-In
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• Tools > Queues
• Tools > Callback Search
• Tools > Permitted & Blocked Numbers

Resolved Issues

• Unchecking Canada or Unites States at the top of the Permitted & Blocked Numbers page now
correctly removes the country from the Currently Selected Countries list. (GES-1732)

• An issue has been fixed that, in rare scenarios, caused changes to a Permitted & Blocked Numbers
rule to be saved automatically instead of being discarded when the user navigated away from the rule
without clicking Save. (GES-1729)

• Custom date ranges now work correctly for users who set their browser language to Australian English.
Previously, depending on the date range that was specified, the Callback UI might generate an error
and fail to save the custom date range setting. (GES-1709)

• Previously, an error was posted on the Errors page if someone tried to cancel a callback that was in the
PROCESSING state. That error is no longer tracked on the Errors page. (GES-1700)

July 18, 2019 (9.0.025.55)

What's New
UI styling enhancements

• The following Callback UI pages have been re-designed for an improved user experience:
• Tools > Capacity
• Tools > Click-To-Call-In Config
• Callback
• Developer > Errors
• Developer > Credential Management

Resolved Issues

• When UTC mode is selected as a display option for the Callback UI tab, the server now correctly uses
UTC time for date ranges instead of the local time zone. (GES-1681)

• An issue has been fixed that could cause localized date formatting (based on your browser's language
setting) to display incorrectly in the Callback UI. (GES-1685)

• An issue has been fixed that occasionally caused an unexpected server error (1001). (GES-1688)
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June 27, 2019 (9.0.000.23)

What's New
Updates to Callback metrics

• Callback metrics on the Callback tab in the UI now include the name of the user who created,
cancelled, rescheduled, or recreated the callback. The username is captured for these actions only
when they are performed in the Callback UI.

Changes to callback record storage

• Callback records are now stored for 14 days; the 14 days start at the Desired Callback Time. The
Callback TTL (seconds) setting in the CALLBACK_SETTINGS data table no longer has any effect on
how long a callback record is stored.

UI enhancements

• Genesys continues to improve text, styling, and performance in the Callback UI.

Resolved Issues

• The callback ID now displays correctly when you search for a callback record using Tools > Callback
Search. Previously, when using a customer's number to search for a scheduled callback, the UI found
the information for the record but failed to display the callback ID.

• The occasional failure to fetch callback details while a callback was in the PROCESSING state has been
fixed. Previously when this happened, no metrics were available in the UI for the callback record once
the state reached COMPLETED.

• Using a complete and valid URL to search for an error on the Developer tab now works correctly.
Previously in this scenario, the Developer tab sometimes failed to return any results.

June 6, 2019 (9.0.000.22)

What's New
Click-To-Call-In

• Callback now supports the Click-To-Call-In (Immediate) scenario. Consumers tap a ClickToCall button in
your mobile app to initiate a call to your contact center. For more information, see Callback Scenarios.

• To implement the Click-To-Call-In scenario for Callback, you must configure at least one Click-To-Call-In
group. You provision the Click-To-Call-In Groups on the new Tools > Click-To-Call-In Config page. For
more information, see Configuring Click-To-Call-In Groups.

Updates to the Patterns page
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In the Callback UI, improvements have been made to the Tools > Patterns page, including the
following:

• The Patterns page has been re-named to Permitted & Blocked Numbers.
• It is no longer possible to delete a rule when it is assigned to a queue.
• When you select a rule, the names of the queues to which the rule is assigned are now listed on the

page.
• The page now includes a Save button. Previously, rule settings were saved automatically.

Updates to the Capacity page

In the Callback UI, improvements have been made to the Tools > Capacity page, including the
following:

• A message displays at the top of the Capacity page that indicates the number of queues to which the
selected capacity rule is assigned.

• You can now delete a capacity rule as long as it is not assigned to any queue.
• You can enter up to 1000 callbacks per time slot.

Updates to the CAPTCHA tab

• Minor text fixes and styling updates have been made to the Developer > Credential Management >
CAPTCHA tab.

May 16, 2019 (9.0.000.21)

What's New
Capacity rules

• You can now configure capacity rules on the Tools > Capacity tab to specify the maximum number of
scheduled callbacks that are allowed within each time slot for a week. After rules are configured, assign
them to queues. For more information, see the Configuring Capacity Rules article.

Updates to the Callback tab

• Advanced Options improvements:
• Styling updates have been made to the Advanced Options window to enhance clarity.
• A Select All checkbox is now available for filtering the grid based on the different callback states.

• Custom Date Range improvements:
• Minor text fixes and styling updates have been made to the Configure Custom Date Range

section of the Advanced Options window.
• Custom date entries in the time range drop-down menu on the Callback tab are now prefixed with
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Custom.

RBAC and Line of Business filtering

• The Role-Based Access Control and Line of Business filtering that was described as an upcoming feature
in an earlier Release Note is now fully implemented. For more information, including a note about the
migration of roles, see the Controlling User Access article.

Developer resources

• Users with the Developer role may now access the following areas under the Developer tab:
• Allowed CORS Domains for troubleshooting Web integration with Callback services. For more

information, see the Using the Developer Tab article.
• Credential Management > CAPTCHA for provisioning reCAPTCHA to protect against bot-based

attacks for a customer's Callback Services integration.

Resolved Issues

• Previously, users might have encountered an error message that indicated that the system Failed to
Fetch All Callbacks for Queue <queue-name>. The issue that caused the error message has been
fixed. The error message sometimes displayed during start up of the Callback UI or when users
refreshed the list of callbacks using the F5 key when there was a large number of callbacks in the
system (for example, 10,000 or more). (GES-1354, GES-1350)

• Name recordings that are made when a customer initially requests a callback are now working correctly.
Previously, name recordings were not played back to the customer during the callback attempt.
(GES-1477)

April 18, 2019 (9.0.000.19)

What's New
Number validation

• To avoid initiating callbacks to numbers that you know to be fraudulent, you can now configure number
validation rules on the Tools > Patterns tab. In addition, you can create rules that specify a list of
countries to which you allow callbacks. After the rules are configured, apply them to queues.

April 4, 2019 (9.0.000.18)

What's New
Developer tab
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• The Callback UI now includes a Developer tab that provides access to a set of tools to facilitate or
troubleshoot developer integration efforts. A user must be a member of the Callback Developer or
Administrator Role to access the Developer tab. For more information, see Using the Developer Tab in
the Callback documentation.

Support for Push Notification

• The Callback UI now includes a Push Notification page on which you enable push notification
configuration for features that can leverage this capability. A user must be a member of the Callback
Developer or Administrator Role to access the Push Notification configuration page. For more
information, see Provisioning Push Notifications in the Callback documentation.

Tools tab

• The Callback UI now includes a Tools tab, which offers additional views and tools to assist with callback
management, configuration, and troubleshooting. A user must be a member of the Administrator,
Supervisor, or Developer Role to access the Tools tab. For more information, see Using Callback Tools
in the Callback documentation.

Security improvements

• Security improvements have been made to the Callback application.

March 21, 2019 (9.0.000.17)

What's New
URL changes

• The URLs for all of the Callback UI web pages now include /ges/app/*, rather than /ges/ui/* or /ges/
react/* .

Resolved Issues

• You can now successfully recreate a callback using the automatically-generated Desired Date value
without any manual intervention. Previously, when you tried to recreate a completed callback using the
Desired Date that the application selected, you received a Please select a valid callback time
error. In this scenario, the only way to recreate the callback using the auto-generated date was to open
the calendar and select that date. (GES-1160)

• Callbacks no longer return error messages when in the PROCESSING state. Previously, the interface
generated an error message about a failure to get diagnostic data when a call was being processed.
(GES-1300)
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March 7, 2019 (9.0.000.16)

What's New
Updated UI

• Colors and styling have been updated on the Callback login screen and throughout the UI.

Resolved Issue

• Styling issues have been fixed in the Callback Advanced Options window. Previously, long queue
names did not display properly in the Advanced Options window and users could sometimes
experience issues when scrolling through the list. (GES-1148)

February 27, 2019 (9.0.000.15)

What's New
MPLS

• Support for environments that use MPLS. (GES-1121)

Resolved Issue

• The Callback tab now displays all pages of results when you filter the list and more than 250 callbacks
are returned. Previously, Callback would sometimes display only one page of callbacks in this scenario
(subsequent pages failed to display). (GES-1149)

February 7, 2019 (9.0.000.14)

Features Coming Soon
Role-Based Access Control

• Role-Based Access Control (RBAC) gives you customized control over user activities within the interface.
Using RBAC, you can define Roles such as Administrator, Developer, Monitor, and Supervisor, and then
configure access control that is appropriate for each Role. Users can then perform only the tasks
allowed for the Role to which they are assigned. For example, a user with a “Monitor” role can log in to
the Callback interface and view the list of callbacks, but cannot make any changes. RBAC will be
available for use with the Callback application when Platform Administration has been updated to
support this feature for Callback. Watch this Callback Release Note for future updates.
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Restricting user access based on lines of business

• You can limit the scope of what logged-in users can see and access based on your lines of business.
Currently, any user who is logged in to the Callback application can see all callback requests as long as
the user has access to that tab in the user interface. Using the line-of-business filtering feature,
administrators have the option to limit which callback requests a specific group or user can view. For
example, if you have a Sales group, then you can allow that group to view only callback requests for
Sales. The ability to limit user access based on lines of business will be available for use with the
Callback application when Platform Administration has been updated to support this feature for
Callback. Watch this Callback Release Note for future updates.

December 28, 2018 (9.0.000.06)

What's New
Initial release

Genesys Callback enables you to provide a deferred option to connect consumers and agents at a
mutually beneficial time, and provides support for Call-In behavior.

Callback is a generic product name that includes support for many scenarios and triggering sources
including:

• Immediate (as soon as an agent is available) or Scheduled Callback offers
• IVR in-queue callback.
• Web or mobile callback — Public API-driven from mobile apps, Web sites, or the Genesys Widgets for

Callback.
• Click-To-Call-In — A mobile app requests call-in details provided immediately or when an agent becomes

available.
• Additional public APIs for queue Estimated Wait Time (EWT) and office hours availability
• Web administration UI for general management (list, create, cancel, reschedule callbacks)

Genesys Callback is enabled through Genesys Engagement Services (GES), the successor to Genesys
Mobile Services (GMS) in the cloud. Designer is used to configure Callback.

Known Issues

• When the desired time of an already-scheduled callback is updated or rescheduled to an earlier desired
time, the new desired time is updated in the callback record and displays in the UI. However, the
system continues to use the original desired time as the time at which to fetch the callback for
processing. As a result, the exclamation mark warning icon – an indicator that a callback is past due –
displays for these rescheduled callbacks. (GES-2249)
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