Jump to: navigation, search

Manage Contacts

The Workspace Contact History view enables you to view and manage previous interactions with a contact.

This lesson contains the following sections:

Managing Contact History

The Contact History view enables you to view and manage previous interactions with a contact. You can find and select previous interactions by using the following views:

Interactions are stored with various attributes. You can use these attributes to find specific interactions. Search results are shown in the interactions table. You can sort, filter, and perform actions on the interactions that you select. Use the Contact History view to do the following:

  • Find interactions for the current contact or the currently selected contact.
  • Perform the following actions on selected interactions:
    • Mark open interactions as done
    • Merge interactions
    • Unmerge interactions
  • View information about selected interactions

This section contains the following procedures:

Lesson: Finding and viewing an interaction in the contact database

Purpose: To find and view or modify existing interactions for a contact in the contact database.

Prerequisites

Start

  1. In the Main Window, click the Access and use Workspace supporting views button (IW Supporting Views Button 850.png) to display the Supporting Views menu, then select Contact Directory.
    Contact Directory tab
  2. Click in the Quick Search field and enter the name of the contact for whom you are searching to find the contact in the contact database.
  3. Click the magnifying-glass icon, or press Enter, to begin the search.
  4. Click the name of the contact in the search-results table or list.
  5. In the Show Details Panel drop-down list, display the Details panel (see the Contact Details view, displaying the Contact Information tab figure).
    Contact Details view, displaying the Contact Information tab
  6. Click the History tab to display the contact History view (see the Contact Details view, displaying the Contact History tab figure).
    Contact Details view, displaying the Contact History tab
  7. Find the interaction that you want to view by using one of the following search types:
  8. If more than one interaction matches your search criteria, specify the time interval that is to be used to filter your search results by using the Chronology slider.
    Iw us IW History Tab Time Filter 850.png

    The slider has five positions that represent different time intervals:

    • Arch.—Search the database for messages that have been archived.
    • All—Search the entire database from the most recent interaction, back to the earliest interaction.
    • 1M—Search the database from the most recent interaction, back to one month ago.
    • 1W—Search the database from the most recent interaction, back to one week ago.
    • 1D—Search the database from the most recent interaction, back to one day ago.
  9. If more than one type of interaction matches your search criteria, use the Type filters to search only for interactions of a specific type. Select the filter type from the drop-down list to turn the filters on and off. When a filter is on, a check mark appears beside its name in the menu.
    Iw us IW History Tab Type Filters 850.png
  10. The interaction filters might include the following types:

  • Show All Interactions
  • Show Voice Interactions
  • Show E-mail Interactions
  • Show Chat/Instant Message Interactions
  • Show SMS Interactions
  • Show Other Media Interactions—Includes workitems and social-media interactions
Your administrator might also include filter types that are related to your specific role in the company, such as the type of customer that your deal with or the business area for which you are responsible.
  • If more than one interaction matches your search criteria, you can sort the contents of the search-results table by an attribute. The attributes are defined by your system administrator. To sort the interactions by one of the attributes, click the column headings that match the attribute that you wan to use to sort the results (see the History View for the current or selected contact figure). Your available search criteria might include one of the following:
    • Status—The disposition code that was assigned to the interaction, if any
    • Subject—For e-mail interactions only
    • Start Date—The date and timestamp when the interaction was first received
    • End Date—The date and timestamp when the interaction was marked Done.
  • Workspace enables you to view contact interactions either by attributes or as threads. Click the Show Interactions in Grid View/Show Interactions in Tree View button ( IWContactListGridViewButton 850.png/IWContactListTreeViewButton 850.png) to specify how the Contact History panel is displayed. Grid View displays interactions by attribute and Tree View displays interactions chronologically by thread. A thread is a group of two or more interactions with a single contact that were created in the same context (e-mail replies, multichannel conversations, social-media threads, and so on).
  • Click an interaction to select it. The Details panel displays information about interactions on the Details tab, the Notepad tab, and the Case Data tab (see the History View for the current or selected contact figure). If you are configured to see the detailed status of the in-progress interaction, the status of the interaction is displayed in the Details tab. If the status of an e-mail interaction in the Contact History view is in one of the in-progress states, when you select the interaction, the Open button (IW Contact History Pull Button 850.png) is displayed (if the e-mail is in a queue, a workbin, or in routing"including outbound in-progress e-mails).
    1. Click Open to open the e-mail interaction in the current active interaction window, or in a new E-mail Interaction window if you are opening the e-mail from the Main Window Contact History view.
    2. After you open the in-progress e-mail interaction, you can read or handle it as an inbound e-mail interaction or an outbound e-mail interaction (refer to Lesson: Replying to a inbound e-mail interaction and Lesson: Creating and sending a new e-mail interaction to a contact). You can also click Put back in original location (IW Contact History Put Button 850.png) to return the e-mail interaction back to the In-Progress workbin or into a queue.
    3. If you are configured to manage contact data, open the Actions menu and then choose one of the following actions:
      • Mark Done—Displayed only if an interaction is still in progress. If you complete an interaction, select it in the interactions table, and then click Mark Done. The status of the interaction will be changed to Done.
      • Change Contact—Assign a different contact for the selected interaction.
  • When you have finished working on the selected interaction in the Main Window, clear the search results by clicking the X button beside the search field. When you have finished working on the selected interaction in the Interaction window, close the Information view by clicking the Contact button on the right-hand side of the current interaction.
  • End

    Lesson: Finding and viewing an interaction in the contact view of the Interaction window

    Purpose: To find and view or modify existing interactions for a contact in the contact database from an active interaction.

    Prerequisites

    • You are configured to view or manage the contact database.
    • You are logged in to Workspace (see Lesson: Logging in to Workspace).
    • You have an active interaction.

    Start

    1. In the active interaction window, click Contact to display the Contact tab (see the Contact Details view, displaying the Contact Information tab figure).
      Contact Details view displaying the Contact Information tab
      The Information tab displays information about the current contact.
    2. Click the History tab to display the list of interactions for the current contact (see the History View for the current or selected contact figure).
      History View for the current or selected contact
    3. Find the interaction that you want to view by using one of the following search types:
    4. If more than one interaction matches your search criteria, specify the time interval that is to be used to filter your search results by using the Chronology slider.
      Iw us IW History Tab Time Filter 850.png

      The slider has five positions that represent different time intervals:

      • Arch.—Search the database for messages that have been archived.
      • All—Search the entire database from the most recent interaction back to the earliest interaction.
      • 1M—Search the database from the most recent interaction back to one month ago.
      • 1W—Search the database from the most recent interaction, back to one week ago.
      • 1D—Search the database from the most recent interaction, back to one day ago.
    5. If more than one type of interaction matches your search criteria, use the Type filters to search only for interactions of a specific type. Select the filter type from the drop-down list to turn the filters on and off. When a filter is on, a check mark appears beside its name in the menu.
      Iw us IW History Tab Type Filters 850.png

      The interaction filters might include the following types:

      • Show All Interactions
      • Show Voice Interactions
      • Show E-mail Interactions
      • Show Chat/Instant Message Interactions
      • Show SMS Interactions
      • Show Other Media Interactions—Includes workitems and social-media interactions
      Your administrator might also include filter types that are related to your specific role in the company, such as the type of customer that your deal with or the business area for which you are responsible.
    6. If more than one interaction matches your search criteria, you can sort the contents of the search-results table by an attribute. The attributes are defined by your system administrator. To sort the interactions by one of the attributes, click the column headings that match the attribute that you wan to use to sort the results (see the History View for the current or selected contact figure). Your available search criteria might include one of the following:
      • Status—The disposition code that was assigned to the interaction, if any.
      • Subject—For e-mail interactions only.
      • Start Date—The date and timestamp when the interaction was first received.
      • End Date—The date and timestamp when the interaction was marked Done.
    7. Workspace enables you to view contact interactions either by attributes or as threads. Click the Show Interactions in Grid View/Show Interactions in Tree View button (IWContactListGridViewButton 850.png/IWContactListTreeViewButton 850.png) to specify how the Contact History panel is displayed. Grid View displays interactions by attribute, and Tree View displays interactions chronologically by thread. A thread is a group of two or more interactions with a single contact that were created in the same context (e-mail replies, multichannel conversations, social-media threads, and so on).
    8. Click an interaction to select it. The Details panel displays information about interactions on the Details tab, the Notepad tab, and the Case Data tab (see the History View for the current or selected contact figure). If you are configured to see the detailed status of the in-progress interaction, the status of the interaction is displayed in the Details tab. If the status of an e-mail interaction in the Contact History view is in one of the in-progress states, when you select the interaction, the Pull button (IW Contact History Pull Button 850.png) is displayed (if the e-mail is in a queue, a workbin, or in routing"including outbound in-progress e-mails).
      1. Click Pull to open the e-mail interaction in the current active interaction window, or in a new E-mail Interaction window if you are opening the e-mail from the Main Window Contact History view.
      2. After you pull the in-progress e-mail interaction, you can read or handle it as an inbound e-mail interaction or an outbound e-mail interaction (refer to Lesson: Replying to a inbound e-mail interaction and Lesson: Creating and sending a new e-mail interaction to a contact). You can also click Put back in original location (IW Contact History Put Button 850.png) to return the e-mail interaction back to the In-Progress workbin or into a queue.
    9. If you are configured to manage contact data, open the Actions menu and then choose one of the following actions:
      • Mark Done—Displayed only if an interaction is still in progress. If you complete an interaction, select it in the interactions table, and then click Mark Done. The status of the interaction will be changed to Done.
      • Change Contact—Assign a different contact for the selected interaction.
      When you have finished working on the selected interaction in the Main Window, clear the search results by clicking the X button beside the search field. When you have finished working on the selected interaction in the Interaction window, close the Information view by clicking the Contact button on the right side of the current interaction.

    End

    Lesson: Using the History tab Quick Search to find an interaction

    Purpose: To search for any interaction by status, end date, and start date.

    Prerequisites

    Start

    1. To search the contact history, in the History tab, type in the Quick Search field (see the Contact History view Quick Search tool figure) the attribute value for which you are searching. You can use the standard Windows wildcard characters—such as ?, *, _, and %"to expand your search.
      Contact History view Quick Search tool
      Important
      Quick Search is a contains search.
    2. Click the magnifying-glass icon, or press Enter, to search for the criteria that you have entered. Your search results are displayed in the Search Results table (see Lesson: Finding and viewing an interaction in the contact database).
    3. Click the X to clear the Quick Search field and the Search Results table.

    End

    Lesson: Using the History tab Advanced Search to find an interaction

    Purpose: To enter multiple interaction criteria to refine your search of the contact database. The Advanced Search pane contains drop-down lists of search criteria, such as Status, Start Date, End Date, and Subject. It also contains drop-down lists with modifiers that determine how the criteria will affect the search.

    Prerequisites

    Start

    1. To search the contact history, in the History tab, enter in the Advanced Search view (see the Contact History view Advanced Search tool figure) the attribute value or values that you want to find. You can use the standard Windows wildcard characters to expand your search.
      Contact History view Advanced Search tool
      • From the column of search attributes on the left, choose the attribute within which you want to search from the drop-down lists.
      • From the column of search modifiers to the right of the attribute column, choose how the search string should be considered.
        Menus for predefined fields, such as Status, contain the predefined field names from the database—for example: All, Done, and In progress.

      Menus for date fields contain the following choices:

      • On—The exact date.
      • On or after—The specified date or any date after.
      • Before—Before the specified date.

      Menus for text fields contain the following choices:

      • Contains—The specified text string occurs anywhere in the selected criterion.
      • Begins With—The specified text string occurs at the beginning of the selected criterion.
      • Is—The specified text string exactly matches the criterion.

      Enter the search value in the text field on the right-hand side. If your criterion is a start date or end date, use the calendar pop-up window to specify the date, then select a Match Conditions option to specify whether All or Any of the search conditions that you have specified are applied.

    2. Click the magnifying-glass icon, or press Enter, to search for the values that you have entered. Your search results are displayed in the Search Results table (see Lesson: Finding and viewing an interaction in the contact database).
    3. Click the X to clear the Advanced Search fields and the Search Results table.

    End

    Managing Your History

    The My History view enables you to view and manage previous interactions between you and a contact. You can find and select your previous interactions by using the following views:

    • My History tab in the Main Window
    • My History window

    Interactions are stored with various attributes. You can use these attributes to find specific interactions. Search results are shown in the interactions table. You can sort, filter, and perform actions on the interactions that you select. Use the My History view to do the following:

    • Find interactions for contacts whom you have handled
    • Perform the following actions on selected interactions:
      • Mark done open interactions
      • Assign interaction to another contact
    • View information about selected interactions

    This section contains the following procedure:

    Lesson: Finding and viewing your interactions in the contact database

    Purpose: To find and view or modify your interactions for a contact in the contact database by using the My History view.

    Prerequisites

    Start

    1. Do one of the following:
      • On the Workspace Main Window (see the Main Window, displaying the My History tab in Workspace view figure):
      1. Click Workspace to display your workspace.
      2. Click the My History tab to display all of your interactions.
      Main Window, displaying the My History tab in Workspace view
    2. To find all of your interactions with a specific contact, do the following:
      1. Click in the Quick Search field and enter the name of the contact for whom you are searching.
      2. Click the magnifying-glass icon, or press Enter, to begin the search. When the search is complete, a list is displayed of all of your interactions in the contact database that match your search criteria.
      To find a specific interaction in the list of search results, you can filter the results by date, interaction type, or advanced criteria.
    3. To filter the search results by date, specify the time interval that is to be used to filter your search results by using the Chronology slider.
      Iw us IW History Tab Time Filter 850.png

      The Chronology slider has five positions that represent different time intervals:

      • Arch.—Search the database for messages that have been archived.
      • All—Search the entire database from the most recent interaction back to the earliest interaction.
      • 1M—Search the database from the most recent interaction back to one month ago.
      • 1W—Search the database from the most recent interaction, back to one week ago.
      • 1D—Search the database from the most recent interaction, back to one day ago.
    4. To filter the search results by type of interaction, use the Type filters to search only for interactions of a specific type (see the My History view Filter menu figure). The interaction types are: Voice, E-mail, and Chat/Instant Message. Select the types to display from the Filter drop-down menu. The Filter menu options turn the filters on and off. When a filter is on, a check mark is displayed next to its name in the menu. Your administrator might include filter types that are related to your specific role in the company, such as the type of customer that your deal with or the business area for which you are responsible.
      My History view Filter menu.
    5. The Advanced Search enables you to use multiple criteria to refine your search. The Advanced Search pane contains drop-down lists of search criteria, such as Status, Start Date, and Subject (see the Advanced Search view displaying the My History tab figure). It also contains drop-down lists with modifiers that determine how the criteria will affect the search. See Lesson: Using the History tab Advanced Search to find an interaction.
      Advanced Search view displaying the My History tab
    6. If more than one interaction matches your search criteria, you can sort the contents of the search-results table by an attribute (see the Search results displaying the My History tab figure). The attributes are defined by your system administrator.
      Search results displaying the My History tab

      To sort the interactions by one of the attributes, click the column headings that match the attribute that you want to use to sort the results (see the Search results displaying the My History tab figure). Your available search criteria might include one of the following:

      • StatusDone or In Progress
      • Subject—For e-mail interactions only
      • Start Date—The date and timestamp when the interaction was first received
      • End Date—The date and timestamp when the interaction was marked Done
    7. Workspace enables you to view contact interactions either by attributes or as threads. Click the Show Interactions in Grid View/Show Interactions in Tree View button (IWContactListGridViewButton 850.png/IWContactListTreeViewButton 850.png) to specify how the Contact History panel is displayed. Grid View displays interactions by attribute and Tree View displays interactions chronologically by thread. A thread is a group of two or more interactions with a single contact that were created in the same context (e-mail replies, multichannel conversations, social-media threads, and so on).
    8. Click an interaction to select it. The Details panel displays information about interactions on the Details tab, the Notepad tab, and the Case Data tab (see the Main Window, displaying the My History tab in Workspace view figure). If you are configured to see the detailed status of the in-progress interaction, the status of the interaction is displayed in the Details tab. If the status of an e-mail interaction in the Contact History view is in one of the in-progress states, when you select the interaction, the Open button (IW Contact History Pull Button 850.png) is displayed (if the e-mail is in a queue, a workbin, or in routing—including outbound in-progress e-mails).
      1. Click Open to open the e-mail interaction in the current active interaction window, or in a new E-mail Interaction window if you are opening the e-mail from the Main Window Contact History view.
      2. After you open the in-progress e-mail interaction, you can read or handle it as an inbound e-mail interaction or an outbound e-mail interaction (refer to Lesson: Replying to a inbound e-mail interaction and Lesson: Creating and sending a new e-mail interaction to a contact). You can also click Put back in original location (IW Contact History Put Button 850.png) to return the e-mail interaction back to the In-Progress workbin or into a queue.
    9. If you are configured to manage contact data, open the More Actions menu and then choose one of the following actions:
      • Mark Done—If you complete an interaction, select it in the interactions table, and then click Mark Done. The status of the interaction will be changed to Done.
      • Change Contact—Assign a different contact for the selected interaction.
    10. When you have finished working on the selected interaction in the My History tab, clear the search results by clicking the X button beside the search field.

    End

    Managing Contacts and Contact Information

    The Contact Directory view enables you to view and manage contacts and contact information. You can manage contacts by using the following views:

    Interactions are stored with various attributes. You can use these attributes to find specific interactions. Search results are shown in the interactions table. You can sort, filter, and perform actions on the interactions that you select. Use the Contact Directory view to do the following:

    • Find interactions for the current contact or the currently selected contact
    • Perform the following actions on selected interactions:
      • Mark done open interactions
      • Merge contacts
      • Unmerge contacts
    • View information about selected interactions

    This section contains the following procedures:

    Lesson: Adding a contact

    Purpose: To add a contact to the contact database.

    Prerequisites

    Start

    1. If you are configured to do so, you can add new contacts to the contact database by using one of the following Contact Information views:
      • The Contact Directory in the Contact Information tab. Click Create New Contact (IWAddContactIcon 850.png) to launch the Add Contact view.
      • The Contact Information tab of the current Interaction window.
      The Contact Information view enables you to view and edit contact information (see the Contact Information tab figure). If the contact is already in the contact database, their information will be displayed in this view. Use the fields to add or modify contact information.
      Contact Information tab
    2. Enter the contact information in the fields. A small red triangle appears in the top left hand corner of the text field to indicate that the information is not saved.
    3. Do one of the following:
      • Click the Save icon (IWNewContactSaveIcon 850.png) to save the information in the contact database.
      • Click the Reset icon (IWNewContactResetIcon 850.png) to clear any unsaved changes from the Add Contact view.
    4. If you want to add additional phone numbers and e-mail addresses for the new contact, click the Add Phone Number or Add E-mail Address link. A new set of fields is added into which you can enter this information.
    5. To specify a phone number or e-mail address as the primary contact number or address, click the Primary radio button beside the phone number or e-mail address that you want to specify as the primary number or address (respectively) for the contact.

    End

    Lesson: Deleting a contact

    Purpose: To remove or delete a contact from the contact database.

    Prerequisites

    Start

    1. To delete a contact, you first must find the contact in the contact database and then select it in the Contact Directory (see the Lesson: Using the Team Communicator feature to find a contact).
    2. With one or more contacts that you want to delete selected, click the Delete icon (IWDeleteContactIcon 850.png).
    3. A confirmation dialog box is displayed.
      • Click OK to remove the contact permanently from the contact database.
      • Click Cancel to cancel the delete-contact function; this leaves the contact in the contact database.
    4. When you have finished working on the selected interaction in the My History tab, clear the search results by clicking the X button that is displayed next to the search field.

    End

    Next Steps

    Lesson: Updating contact information

    Purpose: To update contact information in the contact database.

    Prerequisites

    Start

    1. If you are configured to do so, you can edit contacts in the contact database by using the Contact Directory in the Contact Information tab. The Contact Information view enables you to view and edit contact information (see the Contact Information tab figure). If the contact is already in the contact database, their information will be displayed in this view. Use the fields to add or modify contact information.
      Contact Information tab
    2. Enter the contact information in the fields. A small red triangle appears in the top left-hand corner of the text field to indicate that the information is not saved.
    3. Do one of the following:
      • Click the Save icon (IWNewContactSaveIcon 850.png) to save the information in the contact database.
      • Click the Reset icon (IWNewContactResetIcon 850.png) to clear any unsaved changes from the Add Contact view.
    4. If you want to add additional phone numbers and e-mail addresses for the new contact, click the Add Phone Number or Add E-mail Address link. A new set of fields is added, into which you can enter this information.
    5. To specify a phone number or e-mail address as the primary contact number or address, click the Primary radio button beside the phone number or e-mail address that you want to specify as the primary number or address (respectively) for the contact.

    End

    Lesson: Merging contacts

    Purpose: To combine two contacts in the contact database.

    Prerequisites

    Start

    1. If there are two contact entries in the contact database for the same contact, you can merge the two entries into a single entry. To merge a contact, you first must find the contact in the contact database (see the Lesson: Using the Team Communicator feature to find a contact) and then select it in the Contact Directory (see the Two contact entries for the same contact in the Contact Directory figure).
      Two contact entries for the same contact in the Contact Directory
    2. Click the More Actions menu and select Merge (see the Contact Directory More Actions menu figure).
      Contact Directory More Actions menu
    3. The Merge Contact dialog box is displayed (see the Merge Contact <name> With dialog box figure).
      Merge Contact <name> With dialog box
      Use the search tools to find the duplicate contact.
    4. Select the duplicate contact.
    5. If you are required to enter a description and/or reasons for the merge, use the fields after selecting the duplicate contact.
    6. Do one of the following:
      • Click Merge to complete the merge of the two selected contact entries.
      • Click Cancel to cancel the merge and return to the Main Window.

    End

    Lesson: Unmerging contacts

    Purpose: To unmerge into their original contact entries two contact entries in the contact database that previously have been merged.

    Prerequisites

    Start

    1. First, find the contact in the contact database (see the Lesson: Using the Team Communicator feature to find a contact).
    2. In the Contact Directory, select the contact who is to be unmerged.
    3. In the More Actions menu, select Undo Merge.
    4. A confirmation dialog box is displayed.
      • Click Yes to unmerge into the original two contact entries.
      • Click No to keep the contact merged.

    End

    Lesson: Manually assigning an interaction to a contact

    Purpose: To assign an interaction with an unknown contact to a contact that is in your contact database.

    Sometimes a known contact might connect anonymously to your contact-center by using a phone, e-mail account, or other media that is not part of the information that is stored about that contact in the contact database.

    If your system is not configured to create a new contact automatically for an unknown contact, the Contact Information view for the current interaction window will be blank.

    Tip
    You can also use the Assign Another Contact to This Interaction button to create a new contact or to manually reassign an interaction that has been assigned to the wrong contact. You can also use the Change Contact view.

    Start

    1. If you are handling an interaction that has an unknown contact, there will not be a contact name displayed in the party display area (see the Interaction window with an unknown contact figure).
      Interaction window with an unknown contact
    2. If you identify the contact as being one of your known contacts, you can add the interaction to the history of the contact. Click Contact to display the Contact Directory (see the Information tab of the Contact Directory figure).
      Information tab of the Contact Directory
    3. Click Assign Another Contact to this Interaction (see the Assign another contact to this interaction button figure).
      Assign another contact to this interaction button

      The Contact Search view is displayed (see the The Contact Search view and Quick Search field figure).

      The Contact Search view and Quick Search field
    4. In the Quick Search field, enter the name or other identifying information of the contact.
    5. Click the magnifying-glass icon to begin the search of the contact database (see the Quick Search results figure).
      Quick Search results
    6. In the Search Results list or grid, select the correct contact (see the Search Results list figure).
      Search Results list
    7. Click Assign to assign this interaction to the selected contact. The interaction is added to the Contact History (see the Assign button figure). Click Cancel to return to the blank Contact Information view.
      Assign button

      The title bar, tab, and party action area of the interaction window is updated to display the name of the contact (see the Interaction window displaying the name of the contact figure).

      Interaction window displaying the name of the contact

    End

    This page was last modified on June 3, 2014, at 07:39.

    Feedback

    Comment on this article:

    blog comments powered by Disqus