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To give you a better idea of how to use the Playground application, let's walk through an example of
building a "keyword search" scenario.

Test Scenario Steps

Here are the steps in our scenario:

1. An anonymous user visits the site.
2. The user enters a search term, "contract", in the search box.
3. The user browses the search results.
4. A chat invitation window appears.
5. The user accepts the invitation.
6. The user fills out the registration form and submits it.
7. The user chats with an agent.
8. The agent sees pages the user visited.
9. The agent sends the user a link to a page of interest.

10. The user exits the chat session.

Test Scenario Preparation

Here are the steps to complete before we can walk through our test scenario. Note that for steps 1
through 6, you do not need to take any action if you are using the Playground application, as these
items are covered out of the box.

1. Customize the DSL file with the InTool application.
IMPORTANT: If your web browser blocks the installation of extensions, you can try the steps described in InTools installation for
Chrome (Windows).

Complete the steps below to add the events to the DSL file for our test scenario.

Start

1. Open the Playground application in InTools. You can launch InTools by navigating to
GWE_installation_directory\tools\intools\. Take the intools.crx file and drop it into the
Extensions page of your Google Chrome or Chromium browser.

2. Press F12 to open the developer tools and select GPE DSL Editor.
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The left window shows the DSL for Playground application, while the left window shows the events
on the page.

3. Find the "TimeoutEvent10" <event> in the DSL and select the "element" attribute on its
<trigger>. InTool goes into search mode.

4. Select Search. The selector for Search replaces the "element" attribute value. We now have a
trigger for the event in Step 5 of our test scenario: 10 seconds after loading the search results
appears chat invitation window.
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5. If you select a "value" attribute in the DSL, InTool goes into search mode. Now you can select an
item on the page and the selector for that item will replace the "value" attribute in the DSL.
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6. Click Test to confirm your event works.
End

2. Create categories using the GWE Management interface.
In the steps below we create a category that matches the "contract" search term, Step 2 in our Test Scenario.

Start

1. Open a browser and go to http(s)://<GWE Load Balancer host>:<GWE Load Balancer
port>/server

2. On the Categories page, click New Category.
3. Enter the following information:

• Category Name — Playground-SearchWithCategory

• Category Description — Keywords for search

• Enable "Reveal category in Agent Portal" to make the category available for agents.
• Click Save. The new category is added to the list of categories.

4. Select the Playground-SearchWithCategory category.
5. In the Matching Tags section, click +.
6. Enter the following information:

• Name — PlayGround-SearchWithCategory
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• Type — Plain Text

• Expression — contact

• Language — Select a language from the list.
• Click Save. The tag is added to the Category Matching Tags section.

7. In the Language section, click +.
8. Enter the following information:

• Name — PlayGround-SearchWithCategory

• Language — Select a language from the list.
• Click Save. The language is added to the Language section.

End

3. Configure Genesys Rules System
Complete the following procedures Genesys Rules System to work with Web Engagement.

Configuring Genesys Rules Development Tool
Prerequisites

• Your environment includes Genesys Rules Development Tool (GRDT), deployed as a Composer plug-
in. See Genesys environment prerequisites for compliant versions. For more information about
installing GRDT, refer to Installing the GRDT Component in the the Genesys Rules System
Deployment Guide.

• You enabled the Galileo update site in GRDT, as described in Installing the GRDT Component.
Start

1. Open Genesys Rules Development Tool by starting Composer.
2. Navigate to Window > Preferences. The Preferences window opens.
3. Navigate to Genesys Rules System > Configuration Server. Edit the settings.

• Enter the Configuration Server host name. For instance, localhost.
• Enter the Configuration Server port. For instance, 2020.
• Enter the application name for the Rules Authoring Client application. For instance,

RulesAuthoringClient.
• In the Authentication section, enter the name and password for a user who can connect to

Configuration Server and click Apply.
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GRDT settings for Configuration Server.

4. Navigate to Genesys Rules System > Repository Server. Edit the settings.
• Enter the Repository Server host name. This is the name of the host specified for the GRS

application (application with type Business Rules Execution Server) in Genesys CME. For
instance, localhost.

• Enter the Repository Server port. This is the port with the ID genesys-rules-engine that is
specified for the GRS application (with type Business Rules Execution Server) in Genesys CME.
For instance, 8020.

• Enter the Servlet path as genesys-rules-authoring.
• In the Authentication section, enter a name and password for a user who:

• Has Read and Execute permissions for the Genesys Rules Authoring client application (set up
in Configuration Server); this user must have explicit Read and Execute permissions or must
belong to an access group with those permissions.

• Belongs to a Role with the following privileges: Template - Create, Template - Modify,
Template - Delete.
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5. Click Apply.

GRDT settings for the Repository Server.

6. Navigate to Genesys Rules System > Template Types. If it is not present, add the
web_engagement template type and set Event Support to true. Click Apply.
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Template types in Composer

7. Click OK.
End

Configuring Genesys Rules Authoring Tool
Prerequisites

• Your environment includes Genesys Rules Authoring Tool (GRAT). See Genesys environment
prerequisites for compliant versions. For more information about installing GRAT, refer to the
Genesys Rules System Deployment Guide.

Start

1. In Genesys Administrator, navigate to Provisioning > Environment > Applications, select the
GRAT application (the application with type Business Rules Execution Server), and click Edit.
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2. In the Connections section, click Add....
3. Select the Genesys Web Engagement Cluster and click OK.
4. Select the Web Engagement Cluster in the list of connections and click Edit.
5. In the Connection Info window, select default for the ID field. Click OK.

ID is set to the default port.

6. Select the Options tab.
7. In the [settings] section, set verify-deploy-address to false. You must set this option because in

Genesys Web Engagement, rule packages are deployed to the Web Engagement Server, not to
Genesys Rules Engine. When set to false, this option prevents GRS from trying to verify that the
server deploying the rules is Genesys Rules Engine.

verify-deploy-address is set to false.

8. In the Security tab, set a user who has Read, Create, Change rights for the Scripts folder in Log On
As. This user should also have: Read access to all tenants which are supposed to be used; Role with
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sufficient permissions (as detailed in Genesys Rules System Deployment Guide); Read access to
Business Structure folder and associated nodes that are supposed to be used; Read access to
Scripts folder and Scripts objects (which are representations of the rule templates).

9. Click Save & Close.
End

(Optional) Configuring Roles Settings for Rules Management
You should complete this procedure if you need to import permissions to enable a user to create rules for Genesys Web
Engagement. Once roles are imported, you can assigned them to the user who publishes the rule templates and creates rules for
GWE.

You should not complete this procedure if you have already created a user who has permissions to create rules packages in
Genesys Rules Authoring (as described in the "Role-based Access Control" chapter of the Genesys Rules System Deployment
Guide).

Start

1. In Genesys Administrator, navigate to Provisioning > Accounts > Roles and click New....
2. Enter a name for the new role. For example, GWE_Rules_Administrator.
3. In the Memebers section, you can specify who should have this role. Click Add to add as many

access groups or users as you need.
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New Role

4. Select the Role Privileges tab and select Genesys Rules Authoring Tool. The privileges for
GRAT are added to the GWE_Rules_Administrator role.
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Imported Role Privileges

5. Click Save & Close.
End

Members of the GWE_Rules_Administrator role can now do the following:

• Create, modify, and delete rules
• Create, modify, delete, and deploy rule packages
• Create, modify, and publish CEP rule templates
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4. Prepare the CEP Rule Templates.
Complete the following procedures to import, configure, and publish the CEP Rule Templates.

Importing the CEP Rule Templates in Genesys Rules Development Tool
Complete this procedure to import the CEP rule templates in the Genesys Rules Development Tool. Even if you do not plan to
customize the templates, your rule template must be published in the Rules System Repository before you try to create rules.
Prerequisites

• The Genesys Rules Development Tool is installed, configured, and opened in Composer.
Start

1. Navigate to Window > Open Perspective > Other > Template Development to switch to the
Template Development perspective of the Genesys Rules Development Tool.

2. Select File > Import....
3. In the Import dialog window, navigate to General > Existing Projects into Workspace. Click

Next.
4. Select Select Root Directory:, then click Browse.
5. Import your project, located in the folder at Web Engagement installation directory\apps\

playground\resources\_composer-projects\WebEngagement_CEPRule_Templates. Select
the rules template project to import:
• Browse to the \apps\playground\resources\_composer-projects folder in the Genesys Web

Engagement installation directory and select a project.
• Click OK. WebEngagement_CEPRule_Templates_playground is added to the Projects list.
• Select the WebEngagement_CEPRule_Templates_playground project.
• Warning: Do not enable the option Copy projects into workspace.
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Import the default templates by clicking Finish.

• Click Finish to import the project. WebEngagement_CEP_Rule_Templates_playground is
added to the Project Explorer.

WebEngagement_CEP_Rule_Templates_playground is added to the Project Explorer.
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End

Configuring the CEP Rule Templates
Prerequisites

• The Web Engagement Categories business attribute is defined in Genesys Administrator.
Start

1. In the GRDT Project Explorer, right-click on the WebEngagement_CEPRule_Templates project.
Click Properties.

2. In the Properties dialog window, navigate to Template Properties. In Publishing Data, set Type
to web_engagement.

Set the type to web_engagement.

3. Navigate to Template Properties > Imports. The Imports panel opens.
4. Select the Enable global imports option.
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Enabling global imports.

Note: The com.genesyslab.wme.cep.api.Event and
com.genesyslab.wme.cep.drools.EventDispatcher packages must be present.

5. Click OK.
6. In the Project Explorer, navigate to WebEngagement_CEPRule_Templates > Parameters >

category.
7. In the Parameters Editor panel, set Attribute Name to Web Engagement Categories.
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8. Click Save.
End

Publishing the CEP Rule Templates in the Rules Repository
Prerequisites

• Your user has the correct permissions to manage rules in GRAT, as detailed in the Genesys Rules
System Deployment Guide.

• You configured GRDT to enable a connection to Configuration Server and Rules Repository Server.
Start

1. In Project Explorer, right click WebEngagement_CEPRule_Templates.
2. Select Publish. The Publish Template Wizard opens.
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The Publish Template Wizard.

3. Select WebEngagement_CEP_Rule_Templates.
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Select WebEngagement_CEP_Rule_Templates.

4. Click Finish.
End

5. Create business rules in Genesys Rules Authoring Tool.
Complete the steps below to create business rules in GRAT to use in our Test Scenario.

Start

1. In GRAT, navigate to your site and select New Rule Package
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2. Enter the following information:
• Package Name — com.playground

• Business Name — Playground Rules

• Package Type — Select web_engagement
• Description — Rules for the Playground application test scenario.

• Template — Select the Web Engagement CEP template from the list.
• Click Save.

3. Select the package you just created and select the Rules tab.
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4. Click New Linear Rule and enter the following information:
• Name — Search

• Phase — *

5. Click Add Condition and select "event 'Search' with parameter {category} save as {event}".
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6. Select "PlayGround-SearchWithCategory" and "$event1".

7. Click Add Action and select "generate actionable event based on {event}".
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8. Select "$event1" from the list.
9. Click Save. We now have a business rule for our search with category scenario.
End

6. Deploy rules to the Genesys Web Engagement Environment.
Complete the steps below to deploy your rules to the GWE environment.
Prerequisites

• You started the Web Engagement servers.

Start

1. In Genesys Rules Authoring Tool, navigate to Solution > your rules package > Deploy Rules.
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2. Select the checkbox next to your rules package in the Package Snapshots section.
3. Click Deploy Now. The Deploy window opens.
4. Select your Genesys Web Engagement Server for the Location.
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5. Click Deploy. The rules package is deployed to the Web Engagement system.
End

7. Deploy the Playground application.

Warning
Make sure that your GWE Server is running before deploying an application.

Deploying your Application
Start

1. Navigate to the installation directory for Genesys Web Engagement and open a new console
window.

2. Type:
deploy playground

End

8. Make sure the components in your Genesys environment are running.
• Configuration Server
• Universal Routing Server
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• Interaction Server
• Orchestration Server
• Stat Server
• Chat Server
• Interaction Workspace

9. Start the Web Engagement servers.
Start

To start your servers from Genesys Administrator:

1. Navigate to Provisioning > Environment > Applications.
2. Select the Web Engagement Server.
3. Click Start applications in the Runtime panel.
To start your servers using the provided start script (start.bat on Windows and start.sh on Linux):

1. Navigate to the Web Engagement installation directory and launch a console window.
• For Windows, type: start.bat
• For Linux, type: start.sh

End

The Web Engagement Server is started.

10. Confirm that the test scenario is a success by walking through the Test Scenario Steps.

Other Test Scenarios

You can use the Playground application to complete the following test scenarios:

• Entrance to a specific page (Singleton)
• Inactivity timeout for the user (Singleton)
• Select an element on the page (Singleton)
• Search
• Get information about user
• Successful completion of the wizard (Sequence)
• Go to the previous page of the wizard (Sequence)
• Repeated input on the same page (Counter)
• Send custom event
• Changing the type of invitation depending on the status of the user (gold, platinum)
• Filling out the form (Sequence)
• Display advertisement (Sequence)
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