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Testing with GWM Proxy

Testing with GWM Proxy

The GWM Proxy is a development tool, which enables you to test your application without adding the
JavaScript tracking code to your website. Once you have configured this proxy, you can launch it and
start the Genesys Web Engagement servers to start testing your application by emulating a visit on
your website. In a few clicks, without modifying your website, Genesys Web Engagement features will
show up on a set of web pages, according to the rules and categories that you created.

There are two proxy tools available in the Genesys Web Engagement installation: Simple and
Advanced. See the appropriate tabs below for details and configuration information.

Simple GWM Proxy

To use the Simple GWM Proxy, you must first complete a few procedures to configure the tool and
your web browser.

Getting the GWM Proxy Port

Complete this procedure to retrieve the GWM Proxy port, which you will need later when you
configure your web browser.

Start

1. Navigate to C:\Users\current user\GWMProxy.
If this folder does not exist, navigate to your Web Engagement installation directory and launch
servers\proxy\startserver.bat (on Windows) or servers\proxy\startserver.sh (on Linux). The
GWMProxy folder appears automatically.

2. Edit config.xml' and find the <proxy> tag.

3. Check that the value of the <ip> tag is set to your host IP address.
Note: You cannot use 127.0.0.1 or localhost for this value.

4. Note the value of the <port> tag (usually 15001).

5. Save your changes.

End

Starting the Proxy

Navigate to your Web Engagement installation directory and launch servers\proxy\startserver.bat
(on Windows) or servers\proxy\startserver.sh (on Linux). The Simple GWM Proxy starts.
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EAveb Engagement Prony [_|Of =]

201468718 @7:37:53,.486 DEBUG ConfigurationlUtils — Configuration loaded from thel’
abszolute path C:isllzerssAdministrators~GUMProxysconfig.xml

201468718 @7:37:53,.447 DEBUG ConfigurationlUtils — Configuration loaded from thel
abszolute path C:isllzserssAdministrators~GUMProxysconfig.xml

20148718 @7:37:53,.455 INF0O GUHMProxy — GUMProxy 3.2.13 started.

2014-87-18 A7:-37:53.751 DEBUG Configurationltils — Configuration loaded from the
abzolute path C:\UserssAdministratorsGUMProxysconfig.xml

2014-@7-18 A7:-37:53.763 DEBUG Configurationltils — Configuration loaded from the
abzolute path C:\UserssAdministratorsGUMProxy config.xml

2014-87-18 @7:-37:53.772 DEBUG Configurationlltils — Configuration loaded from the
abzolute path C:sUserssAdministratorsGUMProxysconfig.xml

2014-87-18 @7:37:54,.263 INFO Control — new session file created

The Simple GWM Proxy

Setting Up your Web Browser

Configure your web browser to use the Simple GWM Proxy.

Start

1. Start your web browser.

2. Open your Internet settings. For instance, in Mozilla Firefox, select Tools > Options'. The Options
dialog window appears.

3. Select Advanced’, and in the Network tab click Settings... The Connection Settings dialog
windows appears.

4. Select the Manual proxy configuration option:
* Enter your host IP address in the HTTP proxy text box.

* Enter the port used by the GWMProxy in the Port text box. This is the value you retrieved in
"Getting the GWMProxy Port".

* Select the option Use this proxy server for all protocols.
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GWMProxy used in Firefox

5. Click OK. Now your browser is set up for the GWM Simple Proxy. To use the proxy, all you need to do is

navigate to the site where you want the proxy to inject the Web Engagement instrumentation script
and browse through the web pages.

End

Modifying the Script in the GWM Proxy (Optional)

You can edit the map.xml file in the /tools/proxy directory to customize the code injected in the
HTTP response retrieved through the proxy.

To do this, add your code under the <content></content> element with CDATA masking.

If you want to browse a secure domain, insert your code under
<secure><content>...</content></secure> elements; otherwise, use the
<simple><content>...</content></simple> element.

In the root <map> tag, the "replace" attribute uses regular expressions to specify where the code

must be injected. For instance, the string "%s </head>" means that the "%s" code must be added
before the "</head>" tag.

Do not forget to restart GWM Proxy after making modifications to the map.xml file so
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that your changes will take effect.

Here is an example of a modified map.xml file that injects the DSL code in the HTTP response.

<?xml version="1.0"7?>
<mapping>
<map replace="%s </head>" domains="genesyslab.com;www.genesyslab.com;www-
ssl.genesyslab.com;">
<simple>
<content>

<! [CDATA[
<script>

var gt = gt || [];

_gt.push(['config', {

dslResource: ( 'https:' == document.location.protocol ?
"https://demosrv:8443'
"http://demosrv:8081') + '/frontend/resources/dsl/domain-model.xml',

httpEndpoint: "http://demosrv:8081',
httpsEndpoint: "https://demosrv:8443'
)
var gwc = {
widgetUrl: ( 'https:' == document.location.protocol ?

"https://demosrv:8443"' :
"http://demosrv:8081') + '/frontend/resources/chatWidget.html'

’

(function(gpe, gwc) {
if (document.getElementById(gpe)) return;
var s = document.createElement('script'); s.id = gpe;
s.src = ( 'https:' == document.location.protocol ?
"https://demosrv:8443"'

"http://demosrv:8081') + '/frontend/resources/js/build/GPE.min.js";
s.setAttribute('data-gpe-var', gpe);
s.setAttribute('data-gwc-var', gwc);
(document.getElementsByTagName('head') [0] ||
document.body) .appendChild(s);

P _gt', ' gwc');
</script>
11>
</content>
</simple>
</map>
</mapping>

Advanced GWM Proxy

The Advanced GWM Proxy is based on the OWASP Zed Attack Proxy Project (ZAProxy). In addition to
acting as a proxy, the Advanced GWM Proxy also provides a Ul and validates vulnerabilities in your
website at the same time.
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While Genesys Web Engagement requires a minimum of Java version 1.6, the
Advanced GWM Proxy requires JDK 1.7 or higher.

To use the Advanced GWM Proxy, you must first complete a few procedures to configure the tool.

Starting the Proxy

Navigate to your Web Engagement installation directory and launch servers\proxy2\zap.bat (on
Windows) or servers\proxy2\zap.sh (on Linux). The proxy starts.
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File Edit “iew Analyse Report Tools Online Help

(Standardmode ju) | | B 5 & BE OO ¢V =«b X%k E o
J i@ Sites T L] Seripts ] J < Quick StartWT = Request T 4= Response T 3 Bre
@ Sites

Welcome to the OWASP Zed

FAP is an easyto use integrated penetration testing tool for fi
Please be aware that you should only attack applications that

To quickly test an application, enter its LIRL below and press

LIRL to attack: hitpSf

l L Aftack J M stop

Progress: Mot started
E ] i
[ #° Farced Browse T L Fuzer T [ ] Params T =} Hittp Sessions T i) Zest Results T P
j = Histary T Cl, Search T 24 Break Paints I U slerts
@ | FilterOFF

| Alerts M0 fO D RQ

The Advanced GWM Proxy

Configuring the Proxy

Once the proxy is running, you can configure it using the GUI.

Start
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1. Open Tools > Filter....

Eile Edit iew Analyse Report ﬂnline Help

| standard mode |=] | ] L [ o == PN @
; i : Erowse AP|
o 8l L SEripts
—[-“ﬁ' SJL%T = E ] Encode/Decode/Hash...
@ Sites Manual Request Editor...

Run the Garbage Collector
Manual Send WebSocket Message

Options...

Select the Filter menu item.

2. In the list of filters, select Replace HTTP response body using multiple patterns and click ... to
edit the filter.
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Select the filter.

3. Click Add and enter the following information:

¢ Pattern - </head>

* Replace with -

<script>
var gt = gt

[] [1;

_gt.push(['config', {

dslResource: (

"https:' == document.location.protocol ? 'https://localhost:8081'

"http://localhost:8081') + '/frontend/resources/dsl/domain-model.xml',

httpEndpoint:
httpsEndpoint:
s

var gwc = {

"http://localhost:8081",
"https://localhost:8081"'
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widgetUrl: ( 'https:' == document.location.protocol ? 'https://localhost:8081 :
"http://localhost:8081') + '/frontend/resources/chatWidget.html'

(function(gpe, gwc) {

if (document.getElementById(gpe)) return;

var s = document.createElement('script'); s.id = gpe;

s.src = ( 'https:' == document.location.protocol ? 'https://localhost:8081'
"http://localhost:8081') + '/frontend/resources/js/build/GPE.min.js";
s.setAttribute('data-gpe-var', gpe);

s.setAttribute('data-gwc-var', gwc);
(document.getElementsByTagName('head')[0] || document.body).appendChild(s);
ne_gt', '_gwe');

</script>

</head>
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'Q ”~ Filters D
¥ Filters Filter ()
Enable all Disable All

Fiter | & W Edit pattern

fvoid B g Enter a regular expression as the pattern,
Logun — Pattern: '-c:fhead:-
Log un
Log ref | Replace with: —
Replac wvar _gt = _gt || [l
Replac _gt.pushi['config’, {
Replac dslResource: ( 'https:' == document.location.protocol 7
Replaf ‘http:fflocalhost:BOBL') + 'ffrontend/resources/dsl/doms

Pag i httpEndpoint: ‘http:/flocalhost:8081",

Detecl L httpsEndpoint: 'https:/flocalhost: 8081
Replac 10
Log co
Detectin. var _gwe = {
chanael widgetUrl: ( 'https:' == document.location.protocol 7 'ht

‘http:/flocalhost:BO81') + ‘ffrontend/resources/chatWwidc
1= dilE ]_:
Send ZAF (functionigpe, gwc) {

Enter the pattern and text to replace it with

4. Click OK to save the pattern.

End

Configuring the URL Filter

if (document.getElementByldigpe)) return;

var s = document.createElement('script'}; s.id = gpe;
s.src = [ 'https:' == document.location.protocol 7 'http:
‘http:/flocalhost:B081') + 'ffrontend/resources/js/build/C
s.setittribute('data-gpe-var', gpel:
s.setAttribute('data-gwe-var', gwcl;
{document.getElementsByTaghame('head')[0] || docum
0 gt '_gwe');

=(script=

<(head=|

Complete this procedure to use the GUI to configure URLs that the proxy should ignore.
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Start You can exclude a site in one of two ways:
* In the Sites tab, right-click on a site and select Exclude from > Proxy.

Eile Edit “iew Analyse Report Tools Online Help
[Standardmode i | | E M 2 o EE 22 Y =+« 1k b

[ @ sites | | | scripts |

v & [ sites

|| VI GET:event 75585,5246048108,t,u
= Delete
s http:HCdn.op
Include in Context

| W http://mozorg

L P http:/ivideos Flag as C.cmt.ey:t

B M http:www. gl Fun application

BE R httpiffwwwm Exclude rc:rn Context

B R http:www.m Exclude from
Break...

Alerts for this node S
Resend...

Mew Alert...

Shew in History tab

Open URL in Browser

Copy URLs to clipboard

Generate anti CSRF test FORM
Imvoke with script... [ 2
&dd to Zest Script [
Compare 2 requests

Compare 2 responses

¥ ¥yyy¥Tyr
T B A A

Scanner
Spider

Befresh Sites tree

Save Raw |

Select a site to exclude

e Select File > Properties. In the Session Properties window, select Exclude from proxy, add your
URL, and click OK.
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.

File Edit iew Analyse Report Tools Online Help

(Standardmede ) | B H M 2 & DE OEE § =«b P 0XL& 0 o
J._-@-Sitas_] L Scripts ]

v @ v Sites

Y& ™ http: (/246059135 log. optimizely.com
,_L: U GET:event(a.d.f.n 5245617832 5245677587, 5245875585,52460481 08, t, u,wxhr.y)

» [ ] P http:/fcdn.op Ay L Session Properties
e !-tl http.!!mnzar ¥ Session [Exclude from proxy
» ] o http:/fvideos e bbb e
. Fu http:/fwww.g Exclude from proxy URLs which will be ignored by the proxy
| RO http e Exclude from scanner R
* ] P http:fAww.n Exclude from spider g
F Contexts

Exclude from WebSock

ok

Enter a URL to exclude.

* If you want the proxy to remember the excluded URLs beyond the current session, select File >
Persist session... and select a file to save your session.

End

Developer's Guide 13



Testing with GWM Proxy

Working with the Proxy

After you have configured the proxy, keep it open and open up a web browser. Now you can browse
through your web pages that are instrumented with Genesys Web Engagement and they will be
displayed in the Sites tab of the proxy GUI:

W

File Edit Wiew Analyse Report Tools Cnline Help
Standardmode ) [ 1 B M £ % @2 OE5@ V =« P %&N o
Jﬁ Sites_T L] Scripts ]

v @ Msites

» || http://426-tdw-681.mktoresp.com

» B ™ http://707225039.l0g. optimizely.com
» | [ http:/fapi.demandbase.com

» || [ httpyfedn. optimizely. com

» || [ http://d3foqifuyf87qj.cloudfront.net
* | U http:/dnns06yrbagrg. cloudfront.net
U http:ffgenesyslab.com

F http:ffigenweb.genesyslab.com

F httpdfmunchkin.marketo.net

F httpiifstart. ubuntu.com

| http://stats.g.doubleclick.net

L [ http:ffwww, genesys.com

L P http:/fwww.genesyslab.com

| M http:/fwww.google-analytics.com

L M http:/fwww.google.com

| http:/iwww.google.com.ua

__| M http:/fwww.googleadservices.com
__| [ http:/fwww.googletagmanager.com

B |

[

¥y ¥ ¥ ¥y ¥y ¥y ¥y ¥y " o™

Your instrumented pages show up in the Sites tab

For more information about working with ZAProxy, see https://www.owasp.org/index.php/
OWASP Zed Attack Proxy Project

Security Testing with ZAProxy

Genesys performs security testing with OWASP Zed Attack Proxy (ZAProxy) to make sure the Genesys
Web Engagement solution is invincible to known attacks.
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/AP Overview

The ZAProxy is an easy-to-use, integrated penetration testing tool for finding vulnerabilities in
websites and web applications.

Among others, ZAProxy supports the follow methods for penetration security testing:

* passive scan

e active scan

Genesys uses both methods.

Passive Scan Overview

ZAP is an Intercepting Proxy. It allows you to see all of the requests made to a website/web app and
all of the responses received from it. For example, you can see AJAX calls that might not otherwise be
obvious.

Once set up, ZAP automatically passively scans all of the requests to and responses from the web
application being tested.

While mandatory use cases for the application that is being tested are followed (either manually or
automatically), ZAProxy analyzes the requests to verify the usual operations are safe.

Active Scan Overview

Active scanning attempts to find potential vulnerabilities by using known web attacks against the
selected targets. Active scanning is an attack on those targets. ZAProxy emulates known attacks
when active mode is used.

Through active scanning, Genesys Web Engagement is verified against the following types of attacks:

e Spider attack — Automatically discovers all URL links found on a web resource, sends requests, and
analyzes results (including src attributes, comments, low-level information disclosure, and so on).

¢ Brute browsing (based on the Brute Force technique) — Systematically makes requests to find secure
resources based on known (commonly used) rules. For example, backup, configuration files, temporary
directories, and so on.

e Active scan — Attempts to perform a predefined set of attacks on all resources available for the web
resource. You can find the default set of rules here.

¢ Ajax spider — Automatically discovers web resources based on presumed rules of AJAX control (JS
scripts investigation, page events, common rules, dynamic DOM, and so on).
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Requests to other web applications must be excluded from scanning in order to see a
report for a particular web application.

Web applications that are being tested should be started on the local box because
some types of verification (like active scanning) can be forbidden by network
administrators.

References

If you want to examine your website against vulnerabilities in a similar way, refer to the OWASP Zed
Attack Proxy Project or other documentation to learn about how to perform security testing with ZAP.
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