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Configuring the GVP Components
Perform these advanced configuration procedures after GVP installation and basic configuration.

• Integrating
Application Objects

• Creating a
Connection to a
Server

• Provisioning the
Speech Resources

• Provisioning the
MRCP Proxy

• Configuring the CTI Connector
for Cisco ICM

• Provisioning the PSTN
Connector

• Provisioning the
Supplementary Services
Gateway

• Preparing the Call Control
Platform for Outbound Calling

• Using Resource Groups
• Creating IVR Profiles and DID Groups
• Assigning Default Tenants and Creating

Default Profiles
• Integrating the Reporting Server User

Interface with GVP
• Configuring the Reporting Server Locale

Integrating Application Objects

After the Media Control Platform and Call Control Platform Application objects are created and the
components are installed, they are integrated with the Resource Manager which acts as a proxy
server. SIP devices and VoiceXML or CCXML applications can then make use of media-centric services
through the proxy, without having to know the actual location of these resources.

This procedure is optional and required only if you want the Resource Manager to act as a proxy
server for outbound requests. To integrate these Application objects with the Resource Manager, you
configure the Session Initiation Protocol (SIP) settings.

This procedure describes how to integrate Application objects with the Resource Manager by
configuring SIP and secure SIP options.

Procedure: Integrating Application Objects with Resource Manager
Integrate an Application object with Resource Manager by configuring the Application parameters.

1. Verify that all GVP components are installed. See Procedure: Using the Deployment Wizard to Install
GVP.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Click the Application object that you want to configure for example, the Media Control Platform or Call

Control Platform Application.
The Configuration tab appears.

5. Click the Options tab, and use the View drop-down list to select Show options in groups...
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6. In the sip section, find the routeset option.
7. In the Value field of the routeset option, enter the following:

• sip:<IP_RM>:<SIPPort_RM>;lr
to integrate the Media Control Platform with Resource Manager.

• sip:<IP_RM>:<SIPPort_RM>;lr
to integrate the Call Control Platform with Resource Manager.

...where IP_RM is the IP address of the Resource Manager, and SIPPort_RM is the SIP port of the
Resource Manager typically, 5060.
For both MCP & CCP the syntax is the same:
routeset = sip:<RM1_IP>:<RM1_proxy_port>;lr
for half of the MCPs & CCPs, the other half use
routeset = sip:<RM2_IP>:<RM2_proxy_port>;lr

(Where anything not in italics is required verbatim.)
...where proxy_port is the port from [proxy] sip.transport.n

Tip
You must include the angle brackets in the Value field in the sip.routeset and sip.securerouteset
parameters.

8. In the Value field of the securerouteset option, enter the following:
• sip:<IP_RM>:<SIPSecurePort_RM>;lr to integrate the Media Control Platform with Resources

Manager.
• sip:<IP_RM>:<SIPSecurePort_RM> to integrate the Call Control Platform with Resource Manager.

...where IP_RM is the IP address of the Resource Manager, and SIPSecurePort_RM is the SIP secure
port of the Resource Manager typically, 5061.

Tip
The GVP components and the external SIP Server support secure SIP capabilities.

9. To use the Call Recording Solution through third-party recording servers: In the vrmrecorder section,
configure the following options (pointing to the Resource Manager's IP address and SIP port, as shown
in the two previous steps:
• sip.routeset

• sip.securerouteset

10. Save the configuration.
11. Create the connections to the Message Server. See Procedure: Creating a Connection to a Server.
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Creating a Connection to a Server

Use the procedure in this section to create connections to:

• The Message Server—Create a connection in the Media Control Platform, Call Control Platform, Resource
Manager, Supplementary Services Gateway, CTI Connector, PSTN Connector, MRCP Proxy, Reporting
Server and Policy Server Applications to ensure that component log information reaches the Log
database and can be viewed in the Solution Control Interface (SCI).

• The Reporting Server—Create a connection in the Media Control Platform, Call Control Platform,
Resource Manager, PSTN Connector, CTI Connector, Supplementary Services Gateway, and MRCP Proxy
Applications to ensure that these components detect the Reporting Server to which they are sending
reporting data. Genesys Administrator also requires a connection to Reporting Server to monitor GVP
components.

• SIP Server—Create a connection in the Resource Manager, Supplementary Services Gateway, and PSTN
Connector Applications to manage the initiation of outbound calls.

• MRCP Proxy—Create a connection in the Media Control Platform Application if you are planning to use
the proxy to manage MRCPv1 RTSP traffic within the GVP deployment.

• MRCP Server—Create a connection in the MRCP Proxy Application if you are planning to use the proxy to
manage MRCPv1 RTSP traffic within the GVP deployment (in the Media Control Platform Application if
you are not deploying the MRCP Proxy).

• Cisco T-Server—Create a connection in the UCM Connector Application to ensure the tenant DBID of the
Cisco T-Server is included in Request URI in any SIP INVITE messages sent to the UCM Connector.

• The SNMP Master Agent—Create a connection in the Media Control Platform, Call Control Platform,
Resource Manager, Supplementary Services Gateway, CTI Connector, PSTN Connector, MRCP Proxy,
and Reporting Server Applications if you want to capture alarm and trap information.

Procedure: Creating a Connection to a Server
This procedures creates a connection in an Application object to a server or component.

1. Verify that all GVP components are installed. See Procedure: Using the Deployment Wizard to Install GVP
2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Click the Application object for which you are creating the connection; for example, the Media Control

Platform Application object.
The Configuration tab appears.

5. In the General section, in the Connections field, click Add.
The Connection Info dialog box appears.

6. In the Server field, click the down arrow to open the Browse Application dialog box.
7. Select the server or component to which you want to create a connection for example, Message Server,

SIP Server, or SNMP Master Agent. The required fields in the Connection Info section are populated
automatically. (Ensure the Connection Protocols field is left blank. It is not required for GVP
components.)

8. Click OK.
The server or component you selected in Step 6 appears under Connections.
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9. Save the configuration.
10. Complete the remaining post-installation activities for the Media Control Platform. See Procedure:

Provisioning Speech Resource Application Objects.

Provisioning the Speech Resources

The Media Resource Control Protocol (MRCP) speech resources are controlled by the Call Manager
Application Program Interface (CMAPI), which opens and closes sessions, and provides the speech
recognition and speech synthesis commands that the MRCP Server uses to carry out speech requests.

If the MRCP Proxy is deployed, the configurations in this procedure vary slightly. Therefore, the
configurations are described with and without the MRCP Proxy. If you have installed the MRCP Proxy,
see also Provisioning the MRCP Proxy.

Tip
The procedures in this section are required only if you are using Automatic Speech
Recognition (ASR) and Text-to-Speech (TTS) speech resources, and have an MRCP
Server or MRCP Proxy in your deployment.

This section contains two procedures that create the Speech Resource Applications and assign the
MRCP Server or MRCP Proxy to the Media Control Platform.

Procedure: Provisioning Speech Resource Application Objects
This procedure creates the MRCP Speech Resource Applications for ASR and TTS. After a Speech
Resource Application is created with the basic configuration, it must be provisioned with the IP
address and port number of the MRCP Server or the MRCP Proxy (if required).

1. Verify that:
• The ASR and TTS servers are installed and operational.
• The MRCP Speech Resource object templates are imported. See Procedure: Importing Application

Object Templates Manually.
• The MRCP Speech Resource objects are created. See Procedure: Creating Application Objects

Manually.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Select the Speech Resource Application you want to configure.

The Configuration tab appears.
5. Click the Options tab, and scroll to the provision section.
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6. Enter the value for each Option as described in this table:
Table: MRCP Application Properties Options Tab

Option name Option value
For MRCPv1

vrm.client.resource.name

Enter the identifier used to link the VoiceXML
application to a common set of speech
resources; for example,
• For ASR, enter ATT, IBM, LOQUENDO,

LUMENVOX, NUANCE, TELISMA, or ONMOBILE.
• For TTS, enter ATT, ACAPELA, VOCALIZER,

IBM, or VOXYGEN.
Notes:

• A common set of speech resources means
that the provisioning data for each speech
resource with the same name is identical. A
resource with the same name but different
provisioning data should not be added to the
common set of resources.

• GVP supports dynamically removing and
adding ASR/TTS servers (resources), but does
not support dynamically changing a
resource's provisioning data. To change a
resource's provisioning data, follow these
steps:
1. Remove (delete) the resource.
2. Modify the resource s provisioning data.
3. Add back (reconnect) the resource.
Important: If the provisioning data of the
modified resource is different from an
existing common set of resources with the
same name, then you must use a different
name for this resource.

vrm.client.resource.uri

The URI must contain the IP address and port
number of the MRCP Server by using the
following format:
rtsp://servername:<port>/<path> For the recommended
resource Uniform Resource Identifier (URI), check the MRCP
vendor documentation.

Tip
The MRCP Proxy supports MRCPv1 speech resources
only.

vrm.proxy.ping_interval

Enter a value (or retain the default) to specify the
ping interval in milliseconds (used only when the
MRCP Proxy is deployed).

Default value: 30000

For MRCPv2
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Option name Option value

vrm.client.resource.name

Enter the identifier used to link the VoiceXML
application to a common set of speech resources
for example,

For ASR, enter NUANCE or RECOGNIZER.
For TTS, enter NUANCE or VOCALIZER.

vrm.client.resource.uri

The URI must contain the IP address and port
number of the MRCP server using one of two
formats:
sip:mresources@<MRCP server IP>:<port>;transport=TLS
sips:mresources@<MRCP server IP>:<port> (The default
SIPS port number for Nuance Speech Servers is 5061.)
For the recommended resource URI, check the MRCP vendor
documentation.

vrm.client.TransportProtocol

Enter one of two values:
MRCPv2 without Security
MRCPv2 with secure TLS

7. Save the configuration.

Tip
Complete Steps 8 to 11 if you are deploying MRCPv2 with Secure RTP (SRTP) only.

Configure the Media Control Platform Application

8. Select the Media Control Platform Application that is associated with this speech resource.
The Configuration tab appears.

9. Click the Options tab, and scroll to the mpc section.
10. Configure the following parameters with the values that are shown here:

• asr.srtp.mode=offer

• asr.srtp.sessionparams=none

• tts.srtp.mode=offer

• tts.srtp.sessionparams=none

11. Save the configuration.
Configure the ASR Server

12. Configure the following options on the ASR Server:
• If the ASR Server supports session timeout, configure 600000 (milliseconds, or 10 minutes) for the

timeout value to prevent interruption of any active recognition sessions.
• For Nuance SpeechWorks MediaServer and OpenSpeech Recognizer, configure the

server.transport.sessionTimeout VXIInteger option with a value of 600000 (10 minutes).
• For Nuance Speech Server and Nuance Recognizer, configure the

server.mrcp2.sip.sessionTimeout and server.mrcp1.rtsp.sessionTimeout options with a
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value of 600000 (10 minutes).
For other ASR vendors, check the vendor documentation.

13. To make the ASR service work correctly with GVP, you must edit the Nuance Recognizer file
baseline.xml. and comment out the fourth and fifth lines in the code sample below:
<param name="swirec_extra_nbest_keys">
<declaration group="result" type="string_set" set_by="default+api"> </declaration>
<value>SWI_meaning</value>
<value>SWI_literal</value>
<value>SWI_grammarName</value>
</param>
The characters to add to the code are marked in red.

14. Assign the MRCP Server to the Media Control Platform Application object. See Procedure: Assigning the
MRCP Server to the Media Control Platform.

Procedure: Assigning the MRCP Server to the Media Control Platform
Use this procedure if you have not deployed the MRCP Proxy, otherwise see Provisioning the MRCP
Proxy.

1. Verify that:
• The MRCP Speech Resource object templates are imported. See Procedure: Integrating Application

Objects with Resource Manager.
• The MRCP Speech Resource objects are created. See Procedure: Creating Application Objects

Manually.
• The MRCP Speech Resource objects are provisioned. See Procedure: Provisioning Speech Resource

Application Objects.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Double-click the Media Control Platform Application object that you want to configure.

The Configuration tab appears.
5. In the General section, in the Connections field, click Add.

The Connection Info dialog box appears.
6. Enter the information in the required fields, as shown in this table:

Table: Connection Info Dialog Box
Field Description

Server Browse to select the MRCP Server.

ID This field is populated automatically with the
value default.

Trace Mode This field is populated automatically with the
value Trace is Turned Off.

Application Parameters
Enter provisiontype=primary for a primary
MRCP server.

Enter provisiontype=backup for a backup MRCP server.
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7. Click OK.
8. Save the configuration.

Tip
There is no limit to the number of primary or backup MRCP servers that you can assign to the Media Control
Platform; however, do not assign the same server as both primary and backup.

9. If required, complete the post-installation activities for the Supplementary Services Gateway. See
Provisioning the PSTN Connector.

Provisioning the MRCP Proxy

The MRCP Proxy is an optional component, but must be deployed if ASR and TTS usage reporting is
required. You can deploy the MRCP Proxy in stand-alone or warm active standby HA mode. The
procedures in this section describe the steps for each configuration.

Tip
By design, the MRCP Proxy supports only the NUANCE speech resource.

Procedure: Configuring the MRCP Proxy
Configure the MRCP Proxy to act as a proxy for all MRCPv1 traffic in the environment.

1. Verify that:
• The MRCP Speech Resource objects are provisioned. See Procedure: Provisioning Speech Resource

Application Objects.
• The server connections are created. See Procedure: Creating a Connection to a Server.
• The connections to the ASR and TTS resource access points are created. See Procedure: Provisioning

Speech Resource Application Objects.

2. Log in to Genesys Administrator.
3. On the Provisioning tab, select Environment > Applications.
4. Double-click the MRCP Proxy Application that you want to configure.

The Configuration tab appears.
5. Click the Options tab, in the vrmproxy section, configure the host part of the uri configuration option

with the actual IP address of the MRCP Proxy.
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Important
If the Media Control Platform is installed on the same host as the MRCP Proxy, retain the default value for the
uri configuration option.

6. Create a connection to the MRCP Server. See the Prerequisites section of this procedure.
7. Save the configuration.

Procedure: Configuring the MRCP Proxy for HA
A configured MRCP Proxy acts as a warm standby in case of failover which means that, like a hot
standby, the standby instance becomes active if the active instance fails. However, unlike a hot
standby, a warm standby does not handle existing sessions. Application requests are rejected mid-
stream during a failover; and applications must be designed to accommodate such a failure.

The failover sequence of events is as follows:

1. The primary MRCP Proxy terminates.
2. The LCA in the primary MRCPP machine informs SCS about this event.
3. SCS checks to see if the terminated MRCPP has a backup instance configured.
4. If there is a backup instance configured, SCS instructs through LCA in the backup computer the other

MRCPP to become primary.

In a standard configuration, the MRCP Proxies are configured as backup to each other, and SCS has
an HA license to perform a switch-over.

This procedure configures the MRCP Proxy in HA mode to act as a proxy for all MRCPv1 traffic in the
environment.

1. Verify that:
• The latest versions of Management Framework and LCA are installed and the Solution Control Server

(SCS) Application is configured to support HA licenses. See the Framework 8.5.1 Deployment Guide
and the Framework Management Layer User's Guide.

• The prerequisites in Procedure: Configuring the MRCP Proxy are fulfilled.
The prerequisites for the MRCP Proxy backup server are the same as for the primary in HA mode,
and the connections must be the same on both MRCP Proxy Applications in the HA pair.|2}}

2. Complete Procedure: Configuring the MRCP Proxy for both MRCP Proxy Applications in the HA pair.
3. In the primary MRCP Proxy Application, click the Configurations tab.
4. In the Server Info section, in the Backup Server field, browse to the backup MRCP Proxy Application and

click to select it.
5. In the Redundancy field, select warm-standby.
6. Save the configuration.

Connect to the MCP
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7. In the Media Control Platform Application, create a connection to the primary MRCP Proxy.
8. Save the configuration.

Procedure: Adding a Speech Server as Primary or Backup

1. Log in to Genesys Administrator.
2. On the Provisioning tab, select Environment > Applications.
3. Select the MRCP Proxy Application that you want to configure and click Manage Connections.

The Manage Connections dialog appears.
4. Click Next twice in the Manage Connections dialog.

The Add Connections dialog appears.
5. Click Add and select the speech server to add.
6. Click Edit and select the Advanced tab.
7. Enter provisiontype=primary in the Application Parameters field, to add the speech resource as

primary.
OR
Enter provisiontype=backup in the Application Parameters field to add the speech resource as
backup.

8. Click Execute and then Finish.
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