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Deploy Agent State Connector
Agent State Connector (ASC) connects to Configuration Server and (in release 9.0.015.04 and higher,
optionally) to Stat Server. It retrieves changes to Person and Agent Group configuration objects and
updates to agent login data. It sends that information to the AI Core Services (AICS), which uses it to
update agent profiles, agent availability, and (optionally) agent statistics.

Deploying ASC has three main phases:

• Create and configure the ASC Application object in your Genesys configuration application.
• Install Agent State Connector.
• Configure HTTP/HTTPS Connections and (Optional) Configure ASC to Use Shift-JIS Encoding.

Environment Assumptions
The instructions in this section assume that you are creating new Application objects under the
Environment folder, in either a single-tenant or multi-tenant configuration environment. To create
Application objects under a particular Tenant folder in a multi-tenant configuration environment,
replace the word Environment with the name of your Tenant folder in the configuration instructions.

Important
In a multi-tenant environment, configure one ASC instance for each Tenant.

Configure the ASC Application

Create and Configure the ASC Application Object

1. Import the Application Template
2. Create an ASC Application Object
3. Configure the General tab
4. Configure the Server Info tab
5. Configure the Start Info tab
6. Configure the Options tab - The configuration options control many aspects of ASC behavior, including

the ability to monitor Stat Server statistics, to control threading and timeouts, and to specify whether to
create an Agent Profile schema automatically.

7. Configure the Tenants tab
8. Configure the Connections tab
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Import the Application Template
Before you can configure an Application object for ASC, you must import its Application template.
The Application template provides a majority of the configuration options, as well as the default
values for them. You can use this Application template to create as many Application objects of
the same type as you need.

Important
For an explanation of how to use Genesys Administrator Extension to import the
Application template and to create a new Application object, see the Genesys
Administrator Extension Help file, which is directly available from Genesys
Administrator Extension user interface, as well as from the link given here.

1. On the Configuration Manager window in Genesys Administrator Extension, select the Environment >
Application Templates folder.

2. From the File menu, select Import Application Template.
3. In the Look In box, click the down arrow.
4. Browse to the IP for Agent State Connector and open the TEMPLATES folder.
5. Select the template file for Agent State Connector; it is called 'AgentStateConnector_900.apd.
6. Click Open to open the Properties dialog box for the template.
7. Make any changes that you require.
8. Click OK to save the template and close the Properties dialog box.

The next step is to configure an ASC Application object.

Create an ASC Application Object
After you import the application template, you can create and configure an Application object for
ASC by using the Configuration Manager tab in Genesys Administrator.

1. On the Configuration Manager window, select the Environment > Applications folder.
2. From the File menu, select New > Application.
3. From the available application templates in the Browse dialog box, select the template that you

imported for ASC.
4. On each of the Application tabs, enter the settings appropriate for your environment, as explained in

detail in the section that follow.
5. Click OK to save your changes, then close the Properties dialog box.
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Configure the General tab
In the Properties dialog box, click the General tab, and then enter a name for this application.

Configure the Server Info tab
Click the Server Info tab, and then specify the following properties:

• Host—Select or enter the name or IP address of the computer on which you want to install and/or run
this server.

• Port—Enter the value 0 (zero) for the port number.

Important
In IPv6 deployments, you cannot set the IP address of the host—only IPv4 addresses
can be set for the host. Therefore, enter the name of the host instead.

Configure the Start Info tab

Tip
The properties you define here are updated automatically during the installation
procedure.

Click the Start Info tab, and then specify the following properties:

• Working Directory—Enter the full path to the directory from which the application starts.
• Command Line—<Path_to_JDK_installation_folder>\bin\java.exe
• Command Line Arguments—Add the following startup arguments that will be used in

AgentStateConnector.bat (Windows) or AgentStateConnector.sh (unix) environments:

Dcom.genesyslab.platform.commons.log.loggerFactory=log4j -jar agent_state_connector-
<AGENT_STATE_CONNECTOR_VERSION>-jar-with-dependencies.jar -host <cfg server host>
-port <cfg server port> -app <ASC Application object>

• For additional information about command-line parameters, see Starting and Stopping the ASC
Application.
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Configure the Options tab
Click the Options tab, and then specify or change the values of the configuration options, as suitable
for your deployment.

Important
• If you are deploying ASC 9.0.015.04 or higher and plan not to connect to Stat Server,

see Configure ASC Without Stat Server for the required configuration options settings.

• For information about the entire set of ASC configuration options, see ASC Configuration Options.
• For recommendations and tips on what values to use for certain of the ASC configuration options, see

Guidelines for Configuration Options Values in the Operations: Agent State Connector topic.

(Optional) Configure ASC to Monitor Statistics

1. Make sure the statistics you want to monitor are configured in Stat Server. StatAgentOccupancy is not a
default statistic and requires you to set it up manually. For instructions, see Create a Custom Stat
Server Statistic, below.

2. On the ASC Application object Options tab, create a new section, named statistics. (All other ASC
options are configured in the default section.)

3. In the [statistics] section, create a new option with the same name as the statistic you want to
monitor. For example, StatAgentOccupancy.

In the 9.0.012.00 release, the only supported statistic is StatAgentOccupancy.

4. Set the option value to the correct TimeProfileName for the specified statistic, as specified in the Stat
Server Application object. For StatAgentOccupancy, set the value to SinceLogin.

5. Save the new option.
6. Check that the value for the timebased-statistic-interval is appropriate for your environment. The

default value is 60 seconds.
7. Restart ASC to have the changes take effect.

The new statistic is also saved as part of the Agent Profile schema.

Create a Custom Stat Server Statistic

To create custom statistics, including the StatAgentOccupancy statistic, use the following procedure:

1. In the Stat Server Application object, create a new configuration section with the name of the desired
statistic. For example, StatAgentOccupancy.

2. Create the following options within the new [StatAgentOccupancy] section, and set them to the
specified values:
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• Category=RelativeTimePercentage
• MainMask=CallDialing, CallRinging, AfterCallWork, CallInbound, CallOutbound, CallInternal,

CallConsult, CallUnknown
• RelMask= Monitored, LoggedIn, OnHook, WaitForNextCall, OffHook, CallDialing, CallRinging,

NotReadyForNextCall, AfterCallWork, OfflineWorkType2, BreakType1, BreakType2, CallOnHold,
NotUsed, NotUsed, ASM_Engaged, ASM_Outbound, CallInbound, CallOutbound, CallInternal,
CallConsult, CallUnknown

• Objects=Agent, GroupAgents
• Subject=AgentStatus

3. Save your changes in the Stat Server Application object.
For additional information on statistics configuration in Stat Server, see Statistic Configuration
Options in the Stat Server User's Guide.

4. Check whether the necessary TimeProfile value is configured in the [TimeProfiles] section on the Stat
Server Application object. For StatAgentOccupancy, you must configure the SinceLogin time profile
type. If it does not exist:
1. Open the [TimeProfiles] section.
2. Create a new option with name SinceLogin,SinceLogin. All options in the [TimeProfiles] section

have the name format <TimeProfileName>,<Type>.
3. Leave the option value empty.
4. Save changes in Stat Server Application object.

For additional information on time profiles in Stat Server, see TimeProfiles Section in the Stat
Server User's Guide.

5. Restart Stat Server.

Log Options

• Configure both ASC-specific log options and common log options in the log-related configuration
sections. For option descriptions, see Log Options and the Framework Configuration Options Reference
Manual.

Configure the Tenants tab

Tip
The Tenants tab is displayed only in a multi-tenant environment.

• Click the Tenants tab, and then click Add to add all tenants that this ASC application will serve. ASC
only monitors Person objects that are associated with the tenants you specify.

• If this ASC instance is required to monitor the objects that are configured under the Environment
folder, assign the Environment tenant among the other tenants.
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Configure the Connections tab
Click the Connections tab, and then add the following connections:

• Configuration Server
• Stat Server (optional in release 9.0.015.04 and higher; if you do not add a Stat Server to the

Connections tab, agent availability data is taken from Universal Routing Server)
• Message Server

Configure ASC Without Stat Server

In ASC release 9.0.015.04 and higher, configure the following settings to operate without Stat Server:

1. Do not add Stat Server from the Connections tab. If Stat Server was added previously, remove it.
2. Specify the following configuration option values on the Predictive_Route_DataCfg Transaction List

object:
• use-action-filters = false

• login-status-expression = &((loginStatus>0&loginStatus<23)|loginStatus>23)

• use-login-status = true

High Availability

In high availability (HA) environments using primary and backup pairs of servers, the servers listed on
the Connections tab are handled as primary. To specify the backup servers for any primary servers,
open the Application object for the primary server and add the backup server on the primary
server’s Server Info tab.

Install Agent State Connector

You can install ASC on either a Windows system or a Linux 64-bit system.

Prerequisites

• You have created and configured an ASC Application object in the interface you use for configuration,
as described above.

• Configuration Server is installed and running in your environment.
• You have identified the following parameters, which you need to configure the connection to

Configuration Server:
• ASC Host name: By default, this is the host name of the machine on which you install ASC.
• Configuration Server Host name.
• Network port: Configuration Server network port.
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• User name: Configuration Server user name.
• Password: Configuration Server password.
• Installation path: Full path to the ASC installation directory.

Installing on Windows

To install, perform the following steps:

1. Do one of the following:
• Insert the ASC CD into the CD-ROM drive of the machine on which you want to install ASC.
• Download the ASC IP to the desired location on the target machine.

2. Navigate to, and open, the .../windows directory.
3. Double-click the setup.exe file, and then follow the directions in the installation wizard.

Installing on RedHat Linux 7 64-Bit

Linux-specific prerequisite:

• Install tar and gunzip.

To install, perform the following steps:

1. Install the C runtime libraries using the following command:
yum install glibc.i686

• Troubleshooting Notes:
• If the C runtime libraries are not available, the following error message appears: ./Perl: /lib/

ld-linux.so.2: bad ELF interpreter: No such file or directory.
• If you see the following error during installation, copy the 32-bit versions of libgcc_s.so.1 and

libstdc++.so.6 to the .../lib/ directory: ./cfgutility: error while loading shared
libraries: libstdc++.so.6: cannot open shared object file: No such file or
directory.

2. Insert the ASC CD into the CD-ROM drive of the machine on which you want to install ASC; or, download
the ASC IP to the desired location on the target machine.

3. Unzip the installation file using the following command:
tar -xvzf ip_<version_number>.tar.gz

4. Update the install.sh script to work on 64-bit systems by making the following changes:
• Replace ./gunzip with gunzip.
• Replace tar_name=./tar with tar_name=tar.

5. Run install.sh and follow the instructions to set up ASC, using the configuration parameters you
gathered.
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Configure HTTP/HTTPS Connections

You should already have configured HTTPS for AI Core Services before starting the following
procedure.

1. Import the tango.crt file from the <GPR_IP_version>/conf folder to the java keystore. For example,
you might enter a command similar to the following:
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keytool -import -alias gpr-ssl -keystore /usr/java/jdk1.8.0_171-amd64/jre/lib/security/cacerts -file tango.crt -storepass
"changeit"
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2. Depending on your version of ASC and your platform, perform the following steps.
• For ASC release 9.0.015.00 and higher, HTTP/S configuration is done using only the jop-base-url

configuration option:
In both Linux and Windows environments:

• Change the value of the URL entered in the jop-base-url configuration option so that it specifies
https or http, as desired.

For example, to configure ASC to use HTTPS, your new option value might look similar to
the following:

https://fce-u0009.us.int.genesyslab.com/api/v2.0.

• For Agent State Connector 9.0.014.01 and lower, HTTP/S configuration is done using only the
USE_HTTP environment variable:

In Linux environments:

• To use HTTPS, set the USE_HTTP environment variable to " " (an empty string).
• To use HTTP, set the USE_HTTP environment variable to true.

In Windows environments:

• To use HTTPS, remove the USE_HTTP environment variable entirely.
• To use HTTP, set the USE_HTTP environment variable to true.

3. Restart ASC.

(Optional) Configure ASC to Use Shift-JIS Encoding

By default, ASC uses UTF-8 encoding. To configure ASC to use Shift_JIS encoding, perform the manual
configuration steps specified for your environment:

Linux

1. Navigate to the directory where you installed ASC.
2. Open the AgentStateConnector.sh file.
3. Locate the following line:

JVMPARAMS="-server -Xmx2g -Xms2g -Xss512k"

4. At the end of the line, add the following:
-Dfile.encoding=Shift_JIS

The line should now read:
JVMPARAMS="-server -Xmx2g -Xms2g -Xss512k -Dfile.encoding=Shift_JIS"

5. Save the AgentStateConnector.sh file.
6. Restart ASC.
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Windows

1. Navigate to the directory where you installed ASC.
2. Open the AgentStateConnector.bat file.
3. Locate the following line:

SET JVMPARAMS="-server -Xmx2g -Xms2g -Xss512k"

4. At the end of the line, add the following:
-Dfile.encoding=Shift_JIS

The line should now read:
SET JVMPARAMS="-server -Xmx2g -Xms2g -Xss512k -Dfile.encoding=Shift_JIS"

5. Save the AgentStateConnector.bat file.
6. Restart ASC.
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