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Overview

The Business Edition Premise email routing application can:

• Screen incoming email subject lines for recognized terms
• Distribute the email to a target agent group
• Send an acknowledgement based on contact center status

Important
Agents can send replies to incoming emails, but the routing strategy does not support
the sending of unsolicited outbound emails.

Distribution
The screening rule determines the target and overflow agent groups. If the email is not handled by an
agent from the Email target agent group within the Email target timeout (default is one hour), the
email is routed to the Email overflow target agent group.

If the email is not handled by an agent from the overflow target agent group within the Email
overflow target timeout (default is one day), the email returns either to the target agent group or to
the overflow agent group, at a higher priority.
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Acknowledgements
Like the voice routing application, the email application can send a different acknowledgement email
based on the status of the contact center: open, closed, or special day.

Deployment

To deploy the Business Edition Premise routing applications, you deploy the solution definition in
Genesys Administrator Extension (GAX). Solution definitions are also known as solution package
definitions, or SPDs.

The email routing application also requires you to deploy eServices applications, import Knowledge
Manager templates, and deploy the email strategy.

This section describes how to deploy the email routing application. Email deployment is optional; if
you are not installing the email option, you can skip these steps.

Install the email solution definition
WATCH: A short demonstration of the email solution definition installation.

Link to video

1. In GAX, go to Administration > Solution Definitions and select Genesys One OPM Email
Parameters.

2. Click Related (it's the gear icon) and select Install.
3. Complete the wizard, using default values except for:

• GAX host: VM host name
• Switch: eServices_Switch
• Email address: the Do Not Reply address that you select for the customer mail server
• Email Sample Configuration: True

Install Knowledge Manager
You need to install Knowledge Manager so you can import the Knowledge Manager templates in the
next step.

1. Go to http://core VM host name or IP address/ips and copy the kmgr_version folder to the host
where you want to install KM.

2. On the local host, unzip the file you copied.
3. Go to the Installation Package and install Knowledge Manager.
4. In GAX, go to Environment > Application Templates, and select New.
5. Click Import Application Template.
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6. Browse for the KnowledgeManager_851.apd template, and then click Save.
7. In GAX, go to Environment > Application, and select New.
8. For Name, enter eServices_KnowledgeManager.
9. Select the Knowledge Manager template you created earlier and click Apply.

10. Go to the Application Options tab and under Security, set the disable-rbac option to true.
11. Go to the Connection tab and click Add.
12. Browse for UCS and click OK.

Import the Knowledge Manager templates
WATCH: A short demonstration of how to import the Knowledge Manager templates

Link to video

Important
Localized versions of the templates do not include the required categories, so even for
localized environments you must import the
GenesysOne_KnowledgeManager_Rules_Responses_ENU.kme file.

1. In Genesys Administrator, ensure that the eServices solution is started.
2. Go to: http://VM host name or IP address/ips and locate and download

email_strategy_ext_version.zip.
3. Unzip the file.
4. Browse to email_strategy_ext\KNOWLEDGE and copy the

GenesysOne_KnowledgeManager_Rules_Responses_ENU.kme file to a temp folder on the local
disk.

5. Under Genesys Solutions\eServicesxxx\Knowledge Manager, start Knowledge Manager.
• Username: default
• Password: password
• Application: eServices_KnowledgeManager
• Host: VM name

6. Go to File > Import and select the kme file from the temp folder.
Important:

• Uncheck Preserve uniqueness of objects
• Check Update screening rules.

Click OK and ignore the 5 warnings.

7. If you are localizing your environment, and only after first importing the English kme file, you can import
the localized kme files, one at a time (the example below uses the French version,
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GenesysOne_KnowledgeManager_Rules_Responses_FRA.kme):
• On the VM host, copy the GenesysOne_KnowledgeManager_Rules_Responses_FRA.kme file

(from the unzipped email_strategy_ext_version.zip file) to a temp folder on the local disk.
• Start Knowledge Manager

• Application: eServices_KnowledgeManager
• Host: your VM name

• Go to File > Import and select the kme file from the temp folder.
Important:

• Uncheck Preserve uniqueness of objects
• Check Update screening rules.

Click OK and ignore the 5 warnings.

8. If you are using Special Day Auto Responses in Email, you must manually change the Time Zones for
AutoResponse:
• Start Knowledge Manager.
• Click AutoResponse, and then double-click Special Day.
• Locate the two instances of TimeZone and replace them with the correct time zone IDs.

Important: You must use time zone database IDs to indicate time zones. For a list of time zone
database IDs, see http://en.wikipedia.org/wiki/List_of_tz_database_time_zones.

• Click Check field Codes to view the Special Day Auto Response with the field codes rendered.
• Click OK.

Deploy the email strategy (BEP version 8.5.000)
Download and deploy the email strategy. (For BEP versions 8.5.001 and higher, refer to this
procedure.)

WATCH: A short demonstration of the email strategy deployment.

Link to video

1. In a browser, go to http://core VM name or IP address/ips. Locate, download, and extract the
following zip files:
• email_strategy_version.zip

• composer_version_enus.zip

2. Install Composer 8.1.4 on a Windows system that is not a VM and is not already running Apache Tomcat
(to avoid port conflicts). Follow the installation instructions in the Composer 8.1 Deployment Guide.

Note that Composer 8.1.4 is an Eclipse plugin that requires JDK 1.7 and a supported version of
Eclipse. Composer installs its own Apache Tomcat server.

3. Copy the GenesysOne_Email folder (from the email_strategy_ext_version zip that you just
extracted) to a temp folder on the Composer system.

4. Open Composer and go to File > Import > General > Existing Projects into Workspace.
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5. Choose Select root directory and then select the email strategy you copied from the VM.
Important: Select the project from the newly populated list, ensuring Copy projects into
workspace is enabled, and click Finish.

6. Verify that the local Tomcat server details are correct for your Composer installation:
• Go to Window > Preferences > Composer > Tomcat.
• Enter the Port, Login (admin), and Password (admin).
• Check the Tomcat Location to confirm that it is on the local disk (for example, c:\Program Files

(x86)\GCTI\Composer 8.1\tomcat).

7. In Composer Package Explorer, expand the GenesysOne_Email package, right-click Interaction
Processes > Email ixnprocess, and select Publish to Configuration Server (you might first need
to connect to Configuration Server from the Composer menu bar).

8. Right-click the package name and select Properties. Deploy the project.
9. Create a WAR file:

• Right-click the package name and select Export > Composer > Java Composer Project as WAR
file.

10. In the Export window, select Export Composer WAR file to a location. (You can ignore any warning
messages that are generated.)

11. Copy the WAR file to \\VM host\c$\GCTI\apache-tomcat\webapps. The WAR file automatically
extracts to a new GenesysOne_Email folder.

12. Point the new scripts to the correct server:
• Open GA and go to Provisioning > Routing/eServices > Orchestration, which includes nine

enhanced routing scripts.
• Double-click GenesysOne_Email.Email.Entered.Routing and change the Orchestration URI to

include the correct VM server name; for example, http://g1-sngl-p:8380/GenesysOne_Email/
IPD_Email_Entered.scxml.

• Repeat for each of the other scripts.

Deploy the email strategy (BEP version 8.5.001)
Download and deploy the email strategy.

1. In a browser, go to http://core VM name or IP address/ips. Locate, download, and extract the
following zip file:
• email_strategy_version.zip

2. Open Composer and go to File > Import > General > Existing Projects into Workspace.
3. Choose Select root directory and then select the folder for the GenesysOne_Email email strategy

you extracted earlier.
Important: Select the project from the newly populated list, ensuring Copy projects into
workspace is enabled, and click Finish.

4. Verify that the local Tomcat server details are correct for your Composer installation:
• Go to Window > Preferences > Composer > Tomcat.
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• Enter the Port, Login (admin), and Password (admin).
• Check the Tomcat Location to confirm that it is on the local disk (for example, c:\Program Files

(x86)\GCTI\Composer 8.1\tomcat).

5. Start Tomcat.
6. Right-click the package name and select Properties. Deploy the project.
7. In Composer Package Explorer, expand the GenesysOne_Email package, right-click Interaction

Processes > Email ixnprocess, and select Publish to Configuration Server (you might first need
to connect to Configuration Server from the Composer menu bar).

8. Create a WAR file:
• Right-click the package name and select Export > Composer > Java Composer Project as WAR

file.

9. In the Export window, select Export Composer WAR file to a location. (You can ignore any warning
messages that are generated.)

10. Copy the WAR file to \\VM host\c$\GCTI\apache-tomcat\webapps. The WAR file automatically
extracts to a new GenesysOne_Email folder.

11. Point the new scripts to the correct server:
• Open GA and go to Provisioning > Routing/eServices > Orchestration, which includes nine

enhanced routing scripts.
• Double-click GenesysOne_Email.Email.Entered.Routing and change the Orchestration URI to

include the correct VM server name; for example, http://g1-sngl-p:8380/GenesysOne_Email/
IPD_Email_Entered.scxml.

• Repeat for each of the other scripts.

Configuration

Business Edition Premise routing configuration occurs at two levels:

• Initial configuration, which involves the setup of auto-attendant menus, business rules, and other
configuration objects, requires a basic understanding of Genesys software, particularly Genesys
Administrator, SIP Server, and, for email, eServices Knowledge Manager.

• Administrative configuration, such as setting open hours and switching among auto-attendant menu
trees, is a subset of the initial configuration tasks and takes place entirely within Genesys Administrator
Extension (GAX). It requires no advanced knowledge of Genesys software.

You can configure different values for a number of routing parameters, such as open hours and call
priority. To handle different call flow and email scenarios, you use GAX to create parameter groups
based on the default parameter group templates supplied in Business Edition Premise.

Email solution definitions (SPDs)

Installation of the solution definitions (SPDs) automatically creates several objects. Configuration
Server objects created by previous voice or email installations are not overwritten.

The Email SPD creates these objects:
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• Parameters
• Parameter group templates
• Parameter groups
• Transaction (Technical, Email Default)

The Email SPD creates these additional samples (object name in parentheses):

• Agent groups (AG_Email_Sample, AG_Email_Overflow_Sample, Email Supervisors)
• Business attributes (Disposition Code (Attributes), iWS_ToastUserData, iWS_UserData)
• Capacity Rule (GenesysOne_1Voice_1Email)
• Persons (AgentSample, SupervisorSample)
• SIP Switch Virtual queue (VQ_Default_email)
• Transactions (Category1OverrideIWS, Category2OverrideIWS, Category3OverrideIWS,

Category4OverrideIWS, Category5OverrideIWS)

Initial configuration
Initial configuration of the email routing application depends on the needs of the customer. In many
cases, the defaults supplied in the solution definition will be sufficient.

You can adjust email routing parameters in either of two ways:

• To set new default values to be used in all new parameter groups that use the parameter, open Genesys
Administrator Extension, navigate to Routing Parameters > Parameters, and adjust values as
desired. Do not change Key Names.

• To set a new value that applies only to a specific parameter group, open Genesys Administrator
Extension, navigate to Routing Parameters > Parameter groups, and adjust values as desired.

1. Configure screening rules

You can use the eServices Knowledge Manager application to customize the screening rules used to
route email to any of the five Category parameter groups.

"Content screening", in the Overview section, explains how screening works in Business Edition
Premise.

"Screening Rules" in the eServices 8.1 User's Guide explains how to use the Screening Rule Editor
and details how the rules work.

2. Configure email acknowledgements

You can also use the eServices Knowledge Manager application to customize the text of the
acknowledgement emails: Email acknowledgement body open hours, Email
acknowledgement body closed hours, and Email acknowledgement body special days, as
well as the opening (salutation), closing, and time zone.
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"Using Categories and Standard Responses" in the eServices 8.1 User's Guide explains how to edit
the acknowledgement content.

3. Configure distribution

After you customize the screening rules, you can adjust their associated parameter groups to
distribute emails to the correct targets. If you added the term "sales" to the Category 3 screening
rule, for example, you can route emails with "sales" in their subject lines to a particular target agent
group by setting the Category 3 parameter group Email target value to the Sales agent group.

You can also enable or disable supervisor review, and change the percentage of emails subject to
review.

4. Set open hours and special days

The parameter Email open hours sets the standard hours that your office is open during the week.
Use the Email special day parameter to set:

• The dates or days of the week on which your office is closed for the entire day.
• The dates or days of the week on which your office is closed for only part of the day. In these cases, you

use the Time Ranges field in GAX to set the hours that you will be open on that date.

Specific dates set in Email open hours are treated as special days. Hours set for the same date or
day of the week in Email special day override those set in Email open hours; for example, if
Email open hours specifies that you are open from 9AM to noon on December 31, and Email
special day sets the hours of 11AM-2PM for the same date, people who send an email at 10AM on
that date receive the special day acknowledgement.

Similarly, in both parameters, date patterns higher in the list take precedence over those lower in the
list.

5. Tune priorities

You can adjust the priority of emails using the two priority tuning parameters:

• Email priority sets the initial email priority; you typically have little reason to change the default of
100.

• Email overflow priority sets the priority of emails that exceed the Email target timeout. The
default value is also 100, which means that emails that have already passed the overflow timeout will
be re-queued based solely on their age, ensuring that the oldest emails will appear in the queue first.

6. Send a test email

To verify that Business Edition Premise is correctly receiving and routing emails, send a test email:

1. Install an email client and ensure that it connects to your email server.
2. Send an email to the address specified during the eServices SPD deployment.
3. In GAX, add the Agents Access Group to the AgentSample user account.
4. Ensure that you have installed an Workspace Desktop Edition (WDE) client (you did this when you were

making a test call during the voice routing configuration). Launch WDE and log in using these
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credentials:
• User Name: AgentSample
• Password: AgentSample

5. If Business Edition Premise is successfully installed, a WDE interaction window containing the email
appears when the email arrives.

7. Configure UCS database pruning

Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size.

Important
Changes made to the UCS database maintenance settings will apply to all deployed
media strategies (Voice, Email, Chat, and Outbound).

1. On the VM host, log in to Universal Contact Server Manager.
2. Select the Scheduled task on Main DB tab.
3. Configure the Main DB maintenance settings as desired.
4. Click Save.

Operational Parameters

This section describes the operational parameters that are available for the email routing application.
For instructions on setting these parameters, see Configuration.

Acknowledgements
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email acknowledgement True, False Yes

Sends customer an
acknowledgement
email, content
depending on whether
you are open, closed, or
on a special day

Email acknowledgement
body open hours

Thank you for your
email. We will get
back to you as soon
as possible., text
string entered in Value

Yes
The body text used for
acknowledgements sent
during regular hours
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Parameter Values (default in
bold) Mandatory? Description

field

Email acknowledgement
body closed hours

Thank you for your
email. We are
currently closed and
will get back to you
as soon as possible.
Our office hours are:,
text string entered in
Value field

Yes
The body text used for
acknowledgements sent
during closed hours

Email acknowledgement
body special days

Thank you for your
email. We are
currently closed and
will get back to you
as soon as possible.
Our office reopens on
date, text string
entered in Value field

Yes
The body text used for
acknowledgements sent
during special days

Email acknowledgement
opening

Dear Customer name,
text string entered in
Value field

Yes
The greeting to the
customer at the
beginning of the
acknowledgement

Email acknowledgement
closing

Regards, text string
entered in Value field Yes

The closing term to the
customer at the end of
the acknowledgement

Email acknowledgement
time zone

[none], free-form text
such as Central Time
or GMT

No
The time zone text that
you want to include in
your email
acknowledgements.

Email from [none], email address No
The email address
(typically DoNotReply)
used in sending email
responses to customers

Contact center status
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email open hours

From Monday to
Friday, 0800-2000,
closed Saturday and
Sunday, any value set
in the Value > Date
Pattern field

Yes

Sets the hours that you
are open and accepting
emails; to specify open
hours on specific dates,
you must place the date
above all day-of-week
entries

Email special day
December 25,
January 1, any value
set in the Value > Date

No
A list of exceptions to
the regular open hours,
for a holiday or other
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Parameter Values (default in
bold) Mandatory? Description

Pattern field reason.

Distribution
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email screening True, False Yes Enables email screening
rules

Email target [none], agent group Yes The agent group that
first receives all emails

Email overflow target [none], agent group No
The agent group that
receives all emails that
exceed the overflow
target timeout

Email target timeout 3600, integer between
1 and 99999 No

The length of time (in
seconds) that an email
can go unattended
before being passed to
the overflow agent
group

Email overflow target
timeout

86400 (24 hours),
integer between 1 and
99999

No

The length of time (in
seconds) that an email
can go unattended
before being passed to
the first available agent
group (either target or
overflow)

Email supervisor review False, True Yes Enables supervisor
review.

Email supervisor review
percentage

100, integer between 0
and 100 Yes

The percentage of
emails routed to
supervisors for review

Email supervisor agent
group [none], agent group No

The supervisor agent
group that receives the
emails when supervisor
review is enabled

Email default virtual
queue

VQ_Default_email, a
target virtual queue set
in GA

Yes
The default virtual
queue to which all
emails are routed, for
reporting

Priority tuning
[+] Show parameters.

Email routing application

Business Edition Premise Provider's Guide 13



Parameter Values (default in
bold) Mandatory? Description

Email priority 100, integer between 1
and 99999 Yes

The initial priority
assigned to each
incoming email

Email overflow priority 100, integer between 1
and 99999 Yes

The priority assigned to
all emails that exceed
the overflow target
timeout
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