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Business Edition Premise Provider's Guide
Business Edition Premise is an all-in-one pre-installed packaging of Genesys technology onto a single
virtual machine or a set of five virtual machines, typically run on a single hypervisor server. It
includes SIP Inbound, Outbound, Chat, and Email solutions, as well as real-time and historical
reporting for up to 300 contact center agents.

Business Edition Premise installation and initial configuration requires some knowledge of Genesys
software. The Business Edition Premise Guide documents the procedures needed to configure and
maintain an existing Business Edition Premise environment.

The "If you are new to Genesys software…" section below clarifies the expected roles of providers
and customers.

If you are new to Genesys software…
Business Edition Premise enables you to use the Genesys Administrator Extension interface to set
options (parameters) that tailor routing operations. Some of these options, such as declaring an
emergency or changing open hours, are easily set even if you have no prior experience configuring
Genesys software. Other options, such as auto-attendant (IVR) menus and business targets, are tied
to more complex features that must be synchronized with settings in other Genesys applications.

We suggest that customers rely on their Business Edition Premise provider to set up these features
for them. The provider can then show the customer what options they have customized, such as
business reporting categories (Service, Segment, and Department, for example) and announcements.
The Business Edition Premise Guide specifies the tasks that customers can complete without
assistance from their provider.

Business Edition Premise Provider's Guide
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Architecture

Business Edition Premise overview

Overview

Depending on your business needs, you can install the Business Edition Premise platform in one of
two ways:

• As a single-VM platform, consisting of one VM installed on a single Dell R430 server running VMware
ESXi 5.5.

• As a multi-VM platform, consisting of five VMs installed on a single Dell R720 or Dell R420 server
running VMware ESXi 5.5.

Both platforms include the following features and components:

• Genesys software components, such as Framework, LCA/GDA, 3rd party Components (Apache Tomcat),
eServices, Routing, and SIP Server, and the PostgreSQL configuration database

• Database features, including MS SQL Server, Genesys DB Servers, Genesys InfoMart, and RAA
• Genesys Voice Platform features, including Voice Platform components such as Media Control Platform

and Resource Manager
• User interfaces, such as Genesys Administrator and Genesys Administrator Extension, IWS, Pulse, and

GI2

After installation and initial configuration, the Business Edition Premise server is a basic Genesys 8
suite, which customers can extend with additional Genesys applications and functionality.

Architecture
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Multi-VM roles
In a multi-VM deployment, the five VMs play specific roles:

• Core VM includes core Genesys software components such as Framework, Routing, and SIP Server, as
well as the PostgreSQL configuration database

• DB VM includes MS SQL Server, Genesys DB Servers, Genesys InfoMart, and RAA
• GVP VM includes Voice Platform components such as Media Control Platform and Resource Manager
• UI VM includes user interfaces such as Genesys Administrator and Genesys Administrator Extension,

IWS, Pulse, and GI2
• Aux VM includes some Genesys Framework components (LCA/GDA), 3rd party components (Apache

Tomcat), and room for additional packages such as eServices (required for email and chat functionality)

User interfaces

The table lists the key components used to control settings and reports. The component name links
to its documentation home page.

Component Role

Genesys Administrator User and extension configuration, Outbound
management

Genesys Administrator Extension
Web-based product that simplifies operation
management with the ability to provision, deploy,
and monitor all Genesys applications

Interaction Workspace UI for agents and supervisors
Universal Contact Server Manager Email contact management

Composer Email deployment (and potential customization of
voice and email routing)

Knowledge Manager Email configuration
Genesys Interactive Insights Historical reporting
Pulse (also known as EZPulse) Real-time reporting

Architecture
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Pre-installed software components
The table below lists the pre-installed software components (or included IP Packages) that contribute
to the Business Edition Premise solution.

Important
To view the supported version numbers (available after the virtual machines are
deployed and tuned up), open a browser to http://VM name or IP address (for
multi-VM deployments, use the core VM).

Component Name Release Note
Composer Composer 8.1.x Release Note
Configuration Conversion Wizard Framework 8.1.x Wizard Advisory Release Note
Configuration Import Wizard Framework 8.1.x Wizard Advisory Release Note
Configuration Manager Configuration Manager 8.1.x Release Note
Configuration Server ST Configuration Server 8.1.x Release Note
DB Server DB Server 8.1.x Release Note Release Note
Genesys Pulse Genesys Pulse 8.1.x Release Note Release Note
Genesys Pulse Collector Genesys Pulse Collector 8.1.x Release Note
eServices Chat Server Chat Server 8.1.x Release Note
eServices Classification Server Classification Server 8.1.x Release Note
eServices E-Mail Server Java E-mail Server 8.1.x Release Note

eServices Interaction Concentrator eServices Interaction Concentrator 8.1.x Release
Note

eServices Interaction Server Interaction Server 8.1.x Release Note
eServices Knowledge Manager Knowledge Manager 8.1.x Release Note
eServices Universal Contact Server Universal Contact Server 8.1.x Release Note

eServices Universal Contact Server Manager Universal Contact Server Manager 8.1.x Release
Note

eServices Web API Server eServices Web API Server 8.1.x Release Note

eServices GAX Deployment SPD
Restricted release; the release documentation is
available from the installation package or through
FTP.

Flex LM (License Manager) -
Genesys Administrator Genesys Administrator 8.1.x Release Note

Genesys Administrator Extension Genesys Administrator Extension 8.1.x Release
Note

Genesys Deployment Agent Genesys Administrator Extension 8.1.x Release

Architecture Pre-installed software components
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Note
Genesys Info Mart Genesys Info Mart 8.1.x Release Note

Genesys Info Mart Administration Console Genesys Info Mart Administration Console 8.1.x
Release Note

Genesys Interactive Insights Genesys Interactive Insights 8.1.x Release Note

Genesys Voice Platform Media Control Platform Voice Platform Media Control Platform 8.1.x Release
Note

Genesys Voice Platform Resource Manager Voice Platform Resource Manager 8.1.x Release
Note

Genesys Web Services Genesys WebRTC Gateway 8.5.x Release Note
Interaction Concentrator Interaction Concentrator 8.1.x Release Note
Interaction Workspace Interaction Workspace 8.1.x Release Note

Interaction Workspace SIP Endpoint Interaction Workspace SIP Endpoint 8.0.x Release
Note

Local Control Agent Local Control Agent 8.1.x Release Note
Message Server Message Server 8.1.x Release Note
Orchestration Server Orchestration Server 8.1.x Release Note
Outbound Contact Server Outbound Contact Server 8.1.x Release Note
Reporting and Analytics Aggregates Release Note Data Mart 8.1.x Release Note
SIP Server SIP Server 8.1.x Release Note
SNMP Master Agent SNMP Master Agent 8.1.x Release Note
Solution Control Server Solution Control Server 8.1.x Release Note
Stat Server Stat Server 8.1.x Release Note
Universal Routing Server Universal Routing Server 8.1.x Release Note

Business Edition Premise and its components use these third-party components:

• Apache Tomcat
• Apache Cassandra
• Apache HTTPD
• Apache Tomcat Commons Daemon
• Eclipse Jetty Web Server
• MS SQL Server 2008
• MS SQL Server JDBC Driver
• Business Objects
• SoX
• Postgre SQL
• VMware vSphere

Architecture Pre-installed software components

Business Edition Premise Provider's Guide 7



For information about updating components, see the Genesys Migration Guide.
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Sizing and performance assumptions
This page describes the sizing and performance assumptions for each of the Business Edition Premise
routing applications.

Voice input assumptions
[+] More Information
Input Assumptions BEP 50 BEP 100 BEP 300
Agents per system (90%
of customers) 50 100 300

Worst-case agents per
system 50 100 300

Agent utilization 80% 80% 80%
Call qualification time 60s 60s 60s
Queue time 120s 120s 120s
Talk time 180s 180s 180s
Calculated worst-case values
Calls/Agent/Hour 16 16 16
Concurrent active calls 100 100 300
Peak CAPS (Call Arrivals
per Second) 0.4 0.8 2.2

Busy hour calls 1440 2880 7920
Calls per day 6,667 13,334 40,000
Calls per month 146,674 293,348 880,000
Additional assumptions
Percentage of hold time 30% 30% 30%
Percentage of
transferred calls 30% 30% 30%

Percentage of
conference calls 10% 10% 10%

Percentage of monitored
calls 5% 5% 5%

Average attached data
size 512 bytes 512 bytes 512 bytes

Attached data requests
per call 5 5 5

Retention period for
historical data 13 months 13 months 13 months

UCS data retention 3 months 3 months 3 months

Architecture Sizing and performance assumptions
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Input Assumptions BEP 50 BEP 100 BEP 300
ICON data retention 7 days 7 days 7 days

Email input assumptions
[+] More Information
Input Assumptions 50 Agent 100 Agent 300 Agent
Agents per system (90%
of customers) 12 25 75

Worst-case agents per
system 12 25 75

Agent utilization 80% 80% 80%
Queue time 1-2 days 1-2 days 1-2 days
Processing time 10m 10m 10m
Calculated worst-case values
Emails/Agent/Hour 4 4 4
Concurrent active
emails being processed
by an agent

12 25 75

Peak EAPS (Email
Arrivals per Second) 0.2 0.4 1.25

Busy hour emails 720 1440 4500
Emails per day 1667 3334 10,000
Emails per month 36,674 73,348 220,000
Additional assumptions
Average email size 50 K 50 K 50 K
Average attached data
size 512 bytes 512 bytes 512 bytes

Attached data requests
per email 5 5 5

Chat input assumptions
[+] More Information
Input Assumptions 50 Agent 100 Agent 300 Agent
Agents per system (90%
of customers) 12 25 75

Worst-case agents per
system 12 25 75

Agent utilization 80% 80% 80%
Queue time 120s 120s 120s
Processing time 10m 10m 10m

Architecture Sizing and performance assumptions
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Input Assumptions 50 Agent 100 Agent 300 Agent
Calculated worst-case values
Chats/Agent/Hour 16 16 16
Concurrent active chats
being processed by an
agent

4 4 4

Peak chats per second 0.15 0.3 1
Busy hour chats 540 1080 3600
Chats per day 3,000 6,000 18,000
Chats per month 66,000 132,200 396,000

Outbound input assumptions
[+] More Information
Input Assumptions 50 Agent 100 Agent 300 Agent
Agents per system (90%
of customers) 20 40 60

Outbound interactions
per day 1334 2667 8000

Outbound voice peak
IPS 1.5 3 9

Inbound + outbound
peak IPS 2 3.8 11.2

Peak Outbound CPH per
System 54 108 324

Avg Talk Time (includes
ACW) 20s 20s 20s

Outbound campaigns
per system 5 5 10

Records per Outbound
calling list 4,000 8,000 24,000

Bytes per Outbound
calling record 600 600 600

Outbound customer
calls (% answered) 33% 33% 33%

Outbound customer
calls (% busy) 33% 33% 33%

Outbound customer
calls (% no answer) 33% 33% 33%

Architecture Sizing and performance assumptions
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Known Issues and Corrections
<tabber>

General=

This tab includes known issues found in or affecting all versions of Business Edition Premise 8.1.2.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

eServices component shutdown through the eServices Solution can cause voice call
routing to stop

If you have deployed the email option in Business Edition Premise, any subsequent stoppage of
eServices using the eServices solution shuts down call routing due to the presence of shared
components in eServices and voice solutions. (ESHDP-153)

Workaround: Do not use the eServices solution to shut down eServices while voice call routing is
ongoing; to shut down eServices, shut down the individual eServices applications.

|-| English=

Latest version: 8.1.200.07

This tab includes known issues found in or affecting English (U.S.) versions of BEP. All issues under
the General tab also affect the English localization.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

Known Issues and Corrections Sizing and performance assumptions
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Installing Business Edition Premise
The Business Edition Premise installation consists of an off-site and on-site portion. The off-site
installation steps are performed before the server is delivered to the Premise (or customer) site and
the on-site installation steps are performed after the server is delivered to the Premise site.

Although Business Edition Premise typically comes pre-installed on a server, you can also procure the
required server and install Business Edition Premise on it yourself, as detailed on this page.
Depending on your site or hardware requirements, you can install Business Edition Premise on a
single virtual machine (VM) or as a set of five virtual machines.

Tip
If you have received your server with the VM(s) already deployed, you can skip Part I:
Off-site installation and proceed directly to Part II: On-site installation.

Part I: Off-site installation

These steps describe how to prepare the server for delivery to the Premise site.

[+] Step 1. Procure the required hardware

Hardware requirements
The hardware required to run Business Edition Premise depends on the number of agents in the
contact center and the virtual machine platform being deployed (multi-VM or single-VM).

Single-VM platforms
51 to 300 agents

Requirement Minimum configuration
Server type Dell PowerEdge R420
Processor Intel Xeon E5-2470 (2.30 GHz, 20 M Cache)
Additional processor Intel Xeon E5-2470 (2.30 GHz, 20 M Cache)
Memory (RAM) 48 GB
Controller PERC H710P 1 GB RAID Controller

Hard drives 7x300GB 15 K SAS disks: 6 disks for RAID5 + 1 hot
spare; 2.5 inch drive chassis

Installing Business Edition Premise Sizing and performance assumptions
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Requirement Minimum configuration
Guest Operating System Microsoft Windows 2008 Server R2
Hypervisor Operating System ESXi 5.5

50 agents or less

Requirement Minimum configuration
Server type Dell PowerEdge R430
Processor Intel Xeon E5-2630 v3 (2.40 GHz, 20 M Cache)
Additional processor Intel Xeon E5-2630 v3 (2.40 GHz, 20 M Cache)
Memory (RAM) 48 GB
Controller PERC H730 1 GB RAID Controller

Hard drives 4x600 GB 15 K SAS disks: 3 disks for RAID5 + 1 hot
spare; 2.5 inch drive chassis

Guest Operating System Microsoft Windows 2008 Server R2
Hypervisor Operating System ESXi 5.5

Multi-VM platforms
100 to 300 agents

Requirement Minimum configuration
Server type Dell PowerEdge R720 or Genesys BEP 300
Processor Intel Xeon E5-2665 (2.40 GHz, 20 M Cache)
Additional processor Intel Xeon E5-2665 (2.40 GHz, 20 M Cache)
Memory (RAM) 64 GB
Controller PERC H710P 1 GB RAID Controller

Hard drives 7x300 GB 15 K SAS disks: 6 disks for RAID5 + 1 hot
spare; 2.5 inch drive chassis

Guest Operating System Microsoft Windows 2008 Server R2
Hypervisor Operating System ESXi 5.5

100 agents or less

Requirement Minimum configuration
Server type Dell PowerEdge R420 or Genesys BEP 100
Processor Intel Xeon E5-2470 (2.30 GHz, 20 M Cache)
Additional processor Intel Xeon E5-2470 (2.30 GHz, 20 M Cache)
Memory (RAM) 48 GB
Controller PERC H710P 1 GB RAID Controller

Hard drives 7x300 GB 15 K SAS disks: 6 disks for RAID5 + 1 hot
spare; 2.5 inch drive chassis

Installing Business Edition Premise Sizing and performance assumptions
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Requirement Minimum configuration
Guest Operating System Microsoft Windows 2008 Server R2
Hypervisor Operating System ESXi 5.5

[+] Step 2. Provision the network
Provision the network to include:

• One IP address within a management control subnet for Dell iDRAC setup and configuration.
• One IP address within the same subnet and available on a Windows domain running DNS/DHCP services

for ESXi 5.5 server.

[+] Step 3. Set up the server hardware and iDRAC

1. Perform the initial hardware setup of the server:
• Connect a network cable to the iDRAC internal management board.
• Connect a network cable to port 1 of the main Ethernet board (integrated with the motherboard).
• Connect the power cable.
• Directly attach a monitor, keyboard, and mouse.

2. Power-on the server by pressing the power button on the front of the console.
3. After the Dell Lifecycle Controller completes the system inventory and displays the Settings –

Language and Keyboard screen, do the following:
• Select Next to accept the defaults for Language and Keyboard Type (English/United States).
• On the Network Settings screen, select DHCP from the IP Address Source drop-down list and

click Finish.

4. Configure the server for remote access using the iDRAC management board:
• Go to Hardware Configuration > Configuration Wizards > iDRAC settings > Network.
• Record the MAC Address displayed under Network Settings (this is required for an upcoming

step).
• In the IPV4 Settings section, set Enable DHCP and Use DHCP to obtain DNS server

addresses to Enabled.
• In the IPMI Settings section, set Enable IPMI Over LAN to Enabled.
• Click Back.
• Click Finish and select Yes to save the changes.
• Click System Time and Date Configuration.
• Set Time to the current local time.
• Click Finish and then click Back to exit the Configuration Wizard.

Installing Business Edition Premise Sizing and performance assumptions
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• Go to System Setup > Advanced Hardware Configuration > System BIOS > System Profile
Settings.

• From the System Profile drop-down menu, select Performance.
• Click Back.
• Click Finish and select Yes to save the changes.

5. Update DHCP and DNS for the iDRAC management board:
• Enter the MAC address you recorded earlier into the DHCP server configuration and restart the DHCP

service.
• Update the DNS server with the iDRAC hostname and IP address.
• You can access the system using iDRAC by entering the following URL into a browser:

https://<hostname or ip address>/login.html

[+] Step 4. Obtain the required licenses
Obtain the following licenses:

<tabber> Single VM=

License requirements for single-VM installations

• One Microsoft SQL Server 2008 R2 64-bit license, required for internal access of server components.
Important: This license to be applied on the Premise site.

• One Microsoft Windows Server 2008 R2 64-bit licenses with the appropriate number of client access
licenses.

Important: These licenses to be applied on the Premise site.

• One VMware vSphere Standard Server ESXi 5.5 license for 2 physical CPUs (unlimited cores per CPU).
• Alternatively, you can purchase the BEP Operations pack from Genesys, which contains appropriate

licenses from Microsoft without the need for client access licenses.
• One Genesys software license for 50 agents, or 100 or 300 agents.

Important: The MAC address information required for this license is obtained from the VM during
server configuration.

|-| Multi-VM=

License requirements for multi-VM installations

• One Microsoft SQL Server 2008 R2 64-bit license, required for internal access of server components.
Important: This license to be applied on the Premise site.

• Three Microsoft Windows Server 2008 R2 64-bit licenses with the appropriate number of client access

Installing Business Edition Premise Sizing and performance assumptions
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licenses.
Important: These licenses to be applied on the Premise site.

• One VMware vSphere Standard Server ESXi 5.5 license for 2 physical CPUs (unlimited cores per CPU).
• Alternatively, you can purchase the BEP Operations pack from Genesys, which contains appropriate

licenses from Microsoft without the need for client access licenses.
• One Genesys software license for 100 or 300 agents.

Important: The MAC address information required for this license is obtained from the core VM
during server configuration.

[+] Step 5. Configure the server
This step describes how to configure the server storage as a RAID-5 disk group containing two virtual
disks. Virtual Disk 1 is used for the installation of the ESXi operating system and Virtual Disk 2 is used
for the virtual machine(s) VMFS5 datastore.

WATCH: To view a short demonstration of how to configure the server storage (for 100 to 300
agents) as a RAID-5 disk group containing two virtual disks, click the Genesys icon below:

Important
The creation of a root password for the ESXi server and the configuration of additional
user accounts is at the discretion of the party performing the installation.

1. Login to iDRAC and launch the Virtual Console, and then power on the server.
2. Configure disk group 0 and Virtual Disk 1:

a. Press <CTRL> + <R> during POST to enter the RAID Configuration Utility.
b. Configure the server as RAID-5 with a single hot spare drive:

• Under Physical Disks, select the Disk IDs as follows:
For single-VM or BEP50 configurations of less than 50 agents, select Disk IDs *:00 through *:02

For all other configurations, select Disk IDs *:00 through *:05

c. Under Basic Settings, change the VD Size to 20 GB and type ESXi as the VD Name.
d. Enable the Advanced Settings option and select Initialize (reply OK to the warning) and

Configure Hot Spare.

Installing Business Edition Premise Sizing and performance assumptions
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e. In the Dedicated Hotspare for Disk Group 0 window, select the first Disk ID and select OK.

3. Configure virtual disk two:
• From the Virtual Disk Management screen, select Disk Group and then Add New VD.
• For the VD Name, type VM Storage.
• Enable Advanced Settings and confirm that the Read Policy is Adaptive Read-Ahead and the

Write Policy is Write Back.
• Select Initialize (reply OK to the warning).
• Exit and reboot the server.

4. Modify the boot sequence for the server:
• Press F2 during POST to enter the system BIOS.
• From the BIOS menu, navigate to System Setup Main Menu > System BIOS > Boot Settings >

Bios Boot Settings > Hard-Disk Drive Sequence.
• Move the Integrated RAID Controller (H710P or H730) to the top of the list.
• Exit and reboot the server.

[+] Step 6. Install the VMware vSphere ESXi Server and Client
WATCH: To view a short demonstration of the ESXi Server installation, click the Genesys icon below:

1. Install VMware vSphere 5.5 Standard ESXi Server on the 20 GB Virtual Disk 1 (configured in the previous
step), using the license you procured. Give the server a unique name such as bep_location.

For more information about VMware vSphere 5.5 Standard ESXi Server, see the VMware vSphere
ESXi and vCenter Server 5.5 Documentation (opens in a new window or tab).

• After installing, navigate to Configure Management Network > IPv6 Configuration and disable
IPv6 support.

2. If you are installing the VMs off-site, you must perform the following steps, which you will need to repeat
at the customer site (see On-site installation):
• Power on the ESXi server and retrieve its MAC address (for setup in a DHCP server to assign an IP

address and in a DNS server so the host name of the ESXi server can be associated to the assigned
IP address when first connected to the network):
• Open the ESXi console for your ESXi server and go to <F2> Customize System/View Logs >

Configure Management Network > Network Adapters/<D> View Details.
• Copy the MAC address.

Installing Business Edition Premise Sizing and performance assumptions
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• Log into the DHCP server.
• In the Command window, configure the MAC address with the assigned IP address for the ESXi

server.
• Restart the DHCP server.

3. Install the VMware vSphere 5.5 Client on any Windows workstation that has network connectivity to the
ESXi Server:

IMPORTANT: The ESXi server must be powered on.

• Open a browser and enter the IP address assigned to the ESXi server.
• On the VMware ESXi Welcome page, click the download link for the VMware vSphere 5.5 Client

and follow the prompts to install. For more information, see the VMware vSphere ESXi and vCenter
Server 5.5 Documentation (opens in a new window or tab).

[+] Step 7. Configure the VM storage requirements
WATCH: To view a short demonstration of the virtual storage configuration, click the Genesys icon
below:

1. Log in to the vSphere Client workstation as a user with ESXi administrator rights and select the
Configuration tab.

2. In the Hardware section, click Storage, and then select Add Storage.
3. Accept the default settings by clicking Next for each configuration screen, and give the datastore a

name (for example, VM Storage).
4. For the Capacity, accept the default selection of Maximum available space.
5. Click Finish.

[+] Step 8. Deploy the VM platform (single or multi)
<tabber> Single VM=

Single-VM deployment

1. Obtain the OVA VM template:

Installing Business Edition Premise Sizing and performance assumptions
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• Log into the vSphere Client as a user with ESXi administrator rights.
• Select File > Deploy OVF Template
• Save the BEP OVA VM template to a network drive on the same subnet as the ESXi Server or to a

Genesys-supplied hard drive.

2. Launch the file and deploy the VM:
• The VM name must be in the following format:

VM role-platform-product version-language code.

Example: g1-sngl-p-win2008r2std_sp1-8120007-enus.

file:BEP_dep_vm_sngl.png

Important
Do not change the VM naming format!

• Genesys recommends that you keep the default settings during deployment.

Important
When selecting storage for the OVA file, a minimum of 800 GB of available storage is required.

|-| Multi-VM=

Multi-VM deployment

1. Obtain the OVA VM template:
• Log into the vSphere Client as a user with ESXi administrator rights.
• Select File > Deploy OVF Template
• Save the BEP OVA VM template to a network drive on the same subnet as the ESXi Server or to a

Genesys-supplied hard drive.

2. Launch the file and deploy the five VMs (aux, core, db, gvp, ui).
• The VM names must be in the following format:

VM role-platform-product version-language code

Example: g1-core-p-win2008r2std_sp1-8120008-enus

file:BEP_dep_vm_multi.png
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Important
Do not change the format.

• Genesys recommends that you keep the default settings during deployment.

Important
When selecting storage for the OVA file, a minimum of 1.2 TB of available storage is required.

Dell R420 or Genesys BEP100 memory allocation: The default memory allocation for each VM applies to the Dell R720
or Genesys BEP300 and its 64GB of total memory. If you are installing the VMs on a Dell R420 or Genesys BEP100, you must
open each VM Properties window and adjust the memory and processor allocation for each VM.

VM Memory Processors
Aux 4 GB 4
Core 6 GB 4
DB 6 GB 4
GVP 4 GB 4
UI 4 GB 4

[+] Step 9. Enable VM restoration
To enable VM restoration, take a snapshot of a VM in its current state. To take a snapshot, do the
following for each deployed VM:

1. Right-click on the VM and select Snapshot.
2. From the Snapshot menu, select Take Snapshot.
3. In the Take Virtual Machine Snapshot window, enter a name and description for the snapshot.
4. Click Ok.

For more information about snapshots, see Using Snapshots To Manage Virtual Machines in the
VMware in VMware vSphere ESXi and vCenter Server 5.1 Documentation (opens in a new window or
tab).

[+] Step 10. Confirm that the VM(s) start
Power on each deployed VM and confirm that it starts by opening its Console window and verifying
that the Set Up Windows screen is visible. Once confirmed, power off the VM.

Important: Do not proceed with the Set Up Windows steps unless the server is located at the
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Back to top

Premise site.

Tip
Although the tune-up script starts automatically on the VM after you log in, you can
select to postpone the tune-up procedure until the next restart of the VM. To do so,
select No when the script asks "Would you like to do the tune-up now?" The script
automatically starts when the VM restarts at the customer site, and continues to run
during each restart until it completes successfully.

[+] Step 11. Off-site verification checklist
This step confirms that the off-site portion of the installation is complete and that the server is ready
for delivery to the Premise site.

1. Log in to iDRAC and confirm the following:
• The server configuration is RAID-5.
• The storage controller card model is H730 for R430 models (or H710P for all other models).
• Disk sizes are 600 GB, 15K, SAS (or 300 GB, 15K, SAS, for multi-VM, 100 to 300 agents).

2. Connect to the ESXi server with a vSphere client and confirm the following:
• The VM is deployed and able to start. (If you installed the multi-VM platform, confirm this for each of

the five VMs.)
• The ESXi server has all CPUs (>= 16 CPUs) and RAM (48 GB, or 64 GB for multi-VM, 100 to 300

agents).
• The VM is present, with a snapshot taken. (If you installed the multi-VM platform, confirm for each of

the five VMs.)
• You can locate the MAC address for the VM, as this is needed when ordering appropriate Genesys

licenses. (For multi-VM, use the MAC address for the core VM.)
• Ensure that you have adjusted the memory and CPU values of the VMs according to the table shown

in the step for deploying the VMs, as required for your deployment.
• The VM(s) are the same version. If you deployed the VM(s) according to the steps described in this

wiki, the version is included in the name of the VM.
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Part II: On-site installation

Important
These steps describe how to finalize the server installation and configuration at the
Premise site. Perform these steps only after the off-site portion of the installation is
complete and the server is delivered to the Premise site. The steps are divided into
several subsections and must be completed in the order described.

<tabber>

Single VM=

Single-VM installation

Follow these instructions if you are installing the single-VM environment for Business Edition Premise.

Before you begin
[+] Step 1. Confirm that you have the required licenses

Important
You require the following licenses before installing Business Edition Premise. If you do
not have all required licenses, do not proceed with the installation steps.

• One Windows Server 2008 license key for activating Windows when starting the VM.
• One Genesys software license for the required number of agents.
• One Business Objects Enterprise (BOE) version 3.1 license key.
• One Microsoft SQL Server 2008 R2 64-bit license.

[+] Step 2. Provision the network
Provision the network to include:

• One IP address within a single subnet and available on the Windows domain running DNS/DHCP services
for the Virtual Machine (VM); you also need to assign a hostname for the VM for entry into a DNS server

• One IP address within a management control subnet for Dell iDRAC configuration, to enable hardware
alarming using email (the address must be able to access the customer corporate email server)
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• One IP address within the same subnet and available on a Windows domain running DNS/DHCP services
for ESXi server.

Hardware configuration
[+] Step 3. Set up hardware monitoring
Your Dell server includes an Integrated Dell Remote Access Controller (iDRAC) that monitors the
server hardware and can send email notifications to help you avoid the data loss that will occur if two
drives in the RAID array fail.

Warning
Failure to monitor the health of your RAID array can result in loss of data.
Ensure that you set up Dell hardware monitoring with email notification.

To configure the iDRAC to send email notifications:

1. Use a browser to log into the Dell iDRAC at https://IP address/login.html, where IP address is the
management interface IP address or DNS entry name. Enter the username and password that you
specified when configuring the iDRAC.

2. Navigate to Alerts > Alerts Filter.
• Ensure that only System Health, Storage, Warning, and Critical are checked.
• Uncheck the other five items.
• Click Apply.

3. Under Alerts and Remote System Log Configuration, check the Email box in the heading for each
of the 8 pages.

4. Select the SNMP and E-Mail Settings tab.
• Under Destination E-mail Addresses, add up to four addresses to receive alert emails.
• Check State for each address.
• Click Apply.

5. Under SMTP (E-Mail) Server Address Settings:
• Enter the IP address or FQDN/DNS name of the corporate email server (authentication is optional).
• Click Apply.

6. Under Destination E-mail Addresses:
• Click Send to send an email alert to each of the configured accounts.
• Verify that each account received the test email.

7. Return to the Alerts tab. Enable alerts and click Apply.
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[+] Step 4. Configure Time Zone and Network Time Protocol (NTP)
To configure the Time Zone and NTP settings:

1. Navigate to Overview > iDRAC Settings > Properties > Settings. The Time Zone and NTP page
appears.

2. From the Time Zone drop-down menu, select the required time zone and click Apply.
3. Enable NTP, enter the NTP server addresses, and click Apply.

DHCP and DNS server assignment
[+] Step 5. Update DHCP and DNS servers for ESXi
Power on the ESXi server (if needed) and retrieve its MAC address (for setup in a DHCP server to
assign an IP address and in a DNS server so the host name of the ESXi server can be associated to
the assigned IP address when first connected to the network):

1. Open the ESXi console for your ESXi server and do the following:
• Go to <F2> Customize System/View Logs > Configure Management Network > Network

Adapters/<D> View Details.
• Copy the MAC address.

2. Log into the customer DHCP server.
• In the Command window, replace the existing MAC address for the ESXi server with the one you

copied.

3. Restart the DHCP server.
4. Update the customer DNS server with new host name of the ESXi server and the IP address assigned

from the customer pool of addresses and given out by their DHCP server.
5. Open a DOS prompt and confirm the DNS association by doing a Forward and Reverse nslookup, as

follows:
• nslookup <IP_address>
• nslookup <hostname>

[+] Step 6. Update DHCP and DNS servers for the VM
Before you power on the VM, retrieve its MAC address (from VM properties) to populate the DHCP
server and update the DNS server:

1. In the vSphere Client inventory, do the following:
• Right-click the VM and select Edit Settings > Network adapter 1.
• Copy the MAC address.

2. Log into the DHCP server.
• In the Command window, replace the existing MAC address for the VM with the one you copied.
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3. Restart the DHCP server.
4. Update the customer DNS server with the new host name of the VM server and the IP address assigned

from the customer pool of addresses and given out by their DHCP server.
5. Open a DOS prompt and confirm the DNS association by doing a Forward and Reverse nslookup, as

follows:
• nslookup <IP_address>
• nslookup <hostname>

[+] Step 7. Configure NTP on the ESXi server to synchronize the VM
Configure an NTP (network time) daemon to synchronize the customer VM:

1. In the vSphere Client, select the ESXi server, and then select the Configuration tab.
2. From the Software menu, click Time Configuration and select Properties.
3. Select NTP Client Enabled and then click Options. The NTP Daemon (ntpd) Options window

opens.
4. In the NTP Daemon Options window, do the following:

• Under General, select Start and stop with host.
• Click OK.

Important
You must be back in the Time Configuration screen to do the next step.

• In the Time Configuration window, click Options.
• Under NTP Settings, add an NTP Server in the customer time zone (the NTP Server website lists

available NTP servers) and select Restart NTP service to apply changes.
• Click OK.

5. Select Options and verify that the General settings are as follows:
• Status = Running.
• Startup Policy = Start and Stop with Host.
• The Start button appears in the Service Commands section.

6. Click OK to close the NTP Daemon Options and Time Configuration windows.

VM configuration
[+] Step 8. Power on and configure the VM

1. Power on the VM.
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2. In Windows setup, enter the locale and product key, accept the license terms, and change the
password.

3. Confirm that the dialog for changing the user password at the first login appears. The Windows desktop
loads and the tuneup script automatically runs.

Tip
If you enter incorrect information during the tuneup script configuration, Genesys
recommends that you redeploy the VM and begin the tuneup script configuration
again. If you made a snapshot of the VM prior to entering any data for the tuneup
configuration script, you can revert to that snapshot.

4. After the tuneup script launches automatically, enter values when prompted.
a. For the Host naming scheme:

• Select 1 to use default host name (g1-sngl-p).
Use this option for environments that you do not plan to extend and if the default naming convention suits your needs.

• Select 2 to use default host names with custom suffixes (such as g1-sngl-p-env1).
The script prompts you for the suffix. Use this option if default names with suffixes agree with your host naming
convention.

Important
The suffix can contain no more than 4 characters.

• Select 3 to use a custom name for the host (such as newyork-sngl).
The script prompts you for a name. Use this option if you need to conform to a customer naming convention.

Important
The host name can contain no more than 15 characters.

b. For the Domain configuration:
This setting defines how the FQDN of the hosts is presented in Genesys Configuration; Genesys software uses these names
when establishing network connections.

• Select 1 to have the tuneup script use the domain name that it detects automatically.
• Select 2 (Other domain name) to enter the domain name manually. When prompted, enter the

domain name.
• Select 3 if your environment does not require a domain name. (Typically, this option is reserved

for lab use on systems not running in a domain.)

c. Set the time zone in the format Continent/City or Region. For a list of time zones, see the TZ column
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in List of tz database time zones.
d. When prompted, specify the following as required for your VoIP media gateway (source and

destination of VoIP traffic) configuration:
• gateway-ip-address

• gateway-port

e. Rename? Yes

f. Reboot? Yes

Important
Ensure that the VM fully restarts before proceeding.

[+] Step 9. Configure the BOE tuneup script
The tuneup_boe.bat script launches automatically after VM startup.

1. Enter the BOE license code (Genesys does not provide this).
2. Wait for the BOE tuneup script to finish and close (the script can take 30 minutes or more to complete).
3. When it completes, restart the VM.

[+] Step 10. Configure Windows Server for the VM

Important
Make sure the BOE configuration script has already run before completing this step.

1. In the Initial Configuration Tasks window, click Set time zone.
• Set the time zone in the format Continent/City or Region. For a list of time zones, see the TZ column

in List of tz database time zones.

2. Set up licenses by placing the Flex LM license file (acquired in the previous step) in the GCTI\flexlm
folder.

3. If your environment uses a domain, you can add it by doing the following:
• Click Provide computer name and domain.
• In the System Properties window, click Change.
• In the Computer Name/Domain Changes window, select Domain and enter the domain name.
• Click OK.
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• Restart the VM.

[+] Step 11. Verify the IP address of the VM

1. Verify the VM IP address is correct by doing the following:

• Run the Windows command ipconfig/all. If the host received proper IP configuration from your DHCP
Server, the values will match your network settings.

• Verify that the server can reach the remote host:
Ping an external server (such as a server you plan to use for your agent desktops) by running the command ping <remote host
name or IP address>. The remote host must be reachable via ping and the output of the ping command looks similar to this
example (note the shortened output and sample IP addresses; ping times may vary):

Pinging agent-desktop.domain.com [1.2.3.4] with 32 bytes of data:

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Ping statistics for 1.2.3.4:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms

• From the remote host you just pinged, open the console window and issue the following command:
ping <remote host name or IP address>

Important
The VM host must be reachable and the output of the ping command must look similar to the example above.

[+] Step 12. Verify the status of Genesys services

1. Click Start.
2. Enter Services in the Search programs and files dialog box.
3. Select Services and locate groups of services with names starting with Genesys in the list of local

services.
4. Confirm that all Genesys services have a status of Started with a startup type of Automatic, with the

following exceptions:
• Genesys DB Server [DBServer_OCS] (not started, Manual)
• Genesys Outbound Contact Server [OCS] (not started, Manual)
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Back to top

[+] Step 13. Enter Configuration Manager details

1. On the VM console, click Start and select All programs > Genesys Solutions > Framework >
Configuration Manager > Start Configuration Manager.

2. In the dialog box, enter:
• User name: default
• Password: password
• Application: default
• Host name: localhost
• Port: 8888

Important
Before proceeding to the next step, ensure that Configuration Manager starts and its
main window displays Environment and Resources objects.

Final steps
[+] Step 14. Backup the VM
Genesys recommends that you backup the VM by exporting it to an external location or device.

1. Open the vSphere Client.
2. Power off the VM.
3. In the vSphere client, highlight the target VM and select File > Export > Export OVF Template.
4. For the file format, select Single File (OVA).
5. Specify the output file name and location.
6. Export the file.

|-| Multi-VM=

Multi-VM installation

Follow these instructions if you are installing the multi-VM environment for Business Edition Premise.
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Before you begin
[+] Step 1. Confirm that you have the required licenses

Important
You require the following licenses before installing Business Edition Premise. If you do
not have all required licenses, do not proceed with the installation steps.

• Three Windows Server 2008 license keys for activating Windows when starting each VM.
• One Genesys software license for either 100 or 300 agents.
• One Business Objects Enterprise (BOE) version 3.1 license key.
• One Microsoft SQL Server 2008 R2 64-bit license.

[+] Step 2. Provision the network
Provision the network to include:

• Five IP addresses within a single subnet and available on the Windows domain running DNS/DHCP
services for the Virtual Machines (VMs); you also need to assign five hostnames for the VMs for entry
into a DNS server

• One IP address within a management control subnet for Dell iDRAC configuration, to enable hardware
alarming using email (the address must be able to access the customer corporate email server)

• One IP address within the same subnet and available on a Windows domain running DNS/DHCP services
for ESXi server.

Hardware configuration
[+] Step 3. Set up hardware monitoring
Your Dell server includes an Integrated Dell Remote Access Controller (iDRAC) that monitors the
server hardware and can send email notifications to help you avoid the data loss that will occur if two
drives in the RAID array fail.

Warning
Failure to monitor the health of your RAID array can result in loss of data.
Ensure that you set up Dell hardware monitoring with email notification.

To configure the iDRAC to send email notifications:
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1. Use a browser to log into the Dell iDRAC at https://IP address/login.html, where IP address is the
management interface IP address or DNS entry name. Enter the username and password that you
specified when configuring the iDRAC.

2. Navigate to Alerts > Alerts Filter.
• Ensure that only System Health, Storage, Warning, and Critical are checked.
• Uncheck the other five items.
• Click Apply.

3. Under Alerts and Remote System Log Configuration, check the Email box in the heading for each
of the 8 pages.

4. Select the SNMP and E-Mail Settings tab.
• Under Destination E-mail Addresses, add up to four addresses to receive alert emails.
• Check State for each address.
• Click Apply.

5. Under SMTP (E-Mail) Server Address Settings:
• Enter the IP address or FQDN/DNS name of the corporate email server (authentication is optional).
• Click Apply.

6. Under Destination E-mail Addresses:
• Click Send to send an email alert to each of the configured accounts.
• Verify that each account received the test email.

7. Return to the Alerts tab. Enable alerts and click Apply.

[+] Step 4. Configure Time Zone and Network Time Protocol (NTP)
To configure the Time Zone and NTP settings:

1. Navigate to Overview > iDRAC Settings > Properties > Settings. The Time Zone and NTP page
appears.

2. From the Time Zone drop-down menu, select the required time zone and click Apply.
3. Enable NTP, enter the NTP server addresses, and click Apply.

DHCP and DNS server assignment
[+] Step 5. Update DHCP and DNS servers for ESXi
Power on the ESXi server (if needed) and retrieve its MAC address (for setup in a DHCP server to
assign an IP address and in a DNS server so the host name of the ESXi server can be associated to
the assigned IP address when first connected to the network):

1. Open the ESXi console for your ESXi server and do the following:
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• Go to <F2> Customize System/View Logs > Configure Management Network > Network
Adapters/<D> View Details.

• Copy the MAC address.

2. Log into the customer DHCP server.
• In the Command window, replace the existing MAC address for the ESXi server with the one you

copied.

3. Restart the DHCP server.
4. Update the customer DNS server with new host name of the ESXi server and the IP address assigned

from the customer pool of addresses and given out by their DHCP server.
5. Open a DOS prompt and confirm the DNS association by doing a Forward and Reverse nslookup, as

follows:
• nslookup <IP_address>
• nslookup <hostname>

[+] Step 6. Update DHCP and DNS servers for VMs
Before you power on the VMs, retrieve the MAC address for each deployed VM (from VM properties)
to populate the DHCP server and update the DNS server:

1. In the vSphere Client inventory, do the following for each VM:
• Right-click the virtual machine and select Edit Settings > Network adapter 1.
• Copy the MAC address.

2. Log into the DHCP server.
• In the Command window, replace the existing MAC address for each VM.

3. Restart the DHCP server.
4. Update the customer DNS server with the new host name of each VM server and the IP address

assigned from the customer pool of addresses and given out by their DHCP server.
5. Open a DOS prompt and confirm the DNS association by doing a Forward and Reverse nslookup, as

follows:
• nslookup <IP_address>
• nslookup <hostname>

[+] Step 7. Configure NTP on the ESXi server to synchronize VMs
Configure an NTP (network time) daemon to synchronize the customer VMs:

1. In the vSphere Client, select the ESXi server, and then select the Configuration tab.
2. From the Software menu, click Time Configuration and select Properties.
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3. Select NTP Client Enabled and then click Options. The NTP Daemon (ntpd) Options window
opens.

4. In the NTP Daemon Options window, do the following:
• Under General, select Start and stop with host.
• Click OK.

Important
You must be back in the Time Configuration screen to do the next step.

• In the Time Configuration window, click Options.
• Under NTP Settings, add an NTP Server in the customer time zone (the NTP Server website lists

available NTP servers) and select Restart NTP service to apply changes.
• Click OK.

5. Select Options and verify that the General settings are as follows:
• Status = Running.
• Startup Policy = Start and Stop with Host.
• The Start button appears in the Service Commands section.

6. Click OK to close the NTP Daemon Options and Time Configuration windows.

VM configuration

Important
You must power on and configure the core VM before powering on or configuring any
of the other VMs.

CORE

[+] Step 8. Power on and configure the core VM

1. Power on the core VM.
2. In Windows setup, enter the locale and product key, accept the license terms, and change the

password.
3. Confirm that the dialog for changing the user password at the first login appears. The Windows desktop

loads and the tuneup script automatically runs.
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Tip
If you enter incorrect information during the tuneup script configuration, Genesys
recommends that you redeploy the core VM and begin the tuneup script
configuration again. If you made a snapshot of the core VM prior to entering any
data for the tuneup configuration script, you can revert to that snapshot. This
approach can also be applied to the other VMs; however, if you redeploy the core
VM (or revert to a snapshot), you must also redeploy the other VMs.

4. After the tuneup script launches automatically, enter values when prompted.
For the Host naming scheme:

• Select 1 to use default host names (g1-core-p, g1-ui-p, g1-db-p, g1-aux-p, g1-gvp-p).
Use this option for environments that you do not plan to extend and if the default naming convention suits your needs.

• Select 2 to use default host names with custom suffixes (such as g1-core-p-env1).
The script prompts you for the suffix. Use this option if default names with suffixes agree with your host naming
convention.

Important
The suffix can contain no more than 4 characters.

• Select 3 to use custom names for each host (such as newyork-core and newyork-ui).
The script prompts you for each name, which should identify the role of the host (core, ui, db, aux, or gvp). Use this
option if you need to conform to a customer naming convention.

Important
Each host name can contain no more than 15 characters.

For the Domain configuration:

This setting defines how the FQDN of the hosts is presented in Genesys Configuration; Genesys software uses these names
when establishing network connections.

• Select 1 to have the tuneup script use the domain name that it detects automatically.
• Select 2 (Other domain name) to enter the domain name manually. When prompted, enter the

domain name.
• Select 3 if your environment does not require a domain name. (Typically, this option is reserved

for lab use on systems not running in a domain.)
• Rename? Yes

• Reboot? Yes
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Important
Ensure that the core VM fully restarts before you proceed.

[+] Step 9. Configure Windows Server for the core VM

1. In the Initial Configuration Tasks window in the vSphere client on the core VM:
• Set the time zone in the format Continent/City or Region. For a list of time zones, see the TZ column

in List of tz database time zones.

2. Set up licenses by placing the Flex LM license file (acquired in the previous step) in the GCTI\flexlm
folder.

3. If your environment uses a domain, you can add it by doing the following:
• Click Provide computer name and domain.
• In the System Properties window, click Change.
• In the Computer Name/Domain Changes window, select Domain and enter the domain name.
• Click OK.

4. Reboot the VM.

[+] Step 10. Verify the core IP address

1. Verify that the IP address of the core VM is correct:

• Run the Windows command ipconfig/all. If the host received proper IP configuration from your DHCP
Server, the values will match your network settings.

• Verify that the server can reach the remote host:
Ping an external server (such as a server you plan to use for your agent desktops) by running the command ping remote host
name or IP address. The remote host must be reachable via ping and the output of the ping command looks similar to this
example (note the shortened output and sample IP addresses; ping times may vary):

Pinging agent-desktop.domain.com [1.2.3.4] with 32 bytes of data:

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Ping statistics for 1.2.3.4:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms
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• From the remote host you just pinged, open the console window and issue the following command:
ping core VM name or IP address

The core VM host must be reachable and the output of ping command must look similar to the example in the previous substep.

[+] Step 11. Verify the status of Genesys services

1. Click Start.
2. Enter Services in the Search programs and files dialog box.
3. Select Services and locate groups of services with names starting with Genesys in the list of local

services.
4. Confirm that all Genesys services have a status of Started with a startup type of Automatic.

[+] Step 12. Enter Configuration Manager details for the core VM

1. On the console of the core VM, click Start and select All programs > Genesys Solutions > Start
Configuration Manager.

2. In the dialog box, enter:
• User name: default
• Password: password
• Application: default
• Host name: localhost
• Port: 8888

Important
Before proceeding to the next step, ensure that Configuration Manager starts and its
main window displays Environment and Resources objects.

DB

[+] Step 13. Configure the db VM
You must configure the db VM first, followed by the remaining VMs (do not configure the ui VM until
instructed to do so).

1. Power on the db VM.
2. In Windows setup, set the locale, enter the product key, accept the license terms, and change the

password. To verify, use the same criteria as for the core server.
3. The tuneup script automatically launches. When prompted:
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• Enter the Primary Core Host IP address (do not use the host name).

4. The time zone is configured as part of the tuneup script (this only applies to the db VM).
• Set the time zone for GIM in the format Continent/City or Region. (For a list of time zones, see the TZ

column in List of tz database time zones.)

5. Enter Yes to rename and restart the VM.

Important
Ensure that the VM fully restarts before you proceed.

[+] Step 14. Configure Windows Server for the db VM

1. In the Initial Configuration Tasks window in the vSphere client on the db VM:
• Set the time zone in the format Continent/City or Region. For a list of time zones, see the TZ column

in List of tz database time zones.

2. If your environment uses a domain, you can add it by doing the following:
• Click Provide computer name and domain.
• In the System Properties window, click Change.
• In the Computer Name/Domain Changes window, select Domain and enter the domain name.
• Click OK.

3. Reboot the VM.

AUX and GVP

[+] Step 15. Configure the aux and gvp VMs
For the gvp and aux VMs, do the following:

1. Power on the VM.
2. In Windows setup, set the locale, enter the product key, accept the license terms, and change the

password. To verify, use the same criteria as for the core server.
3. Confirm that the dialog for changing the user password at the first login appears.
4. The Windows desktop loads and the tuneup script automatically runs. When prompted:

• Enter the Primary Core Host IP address (do not use the host name).

5. For the gvp VM only: When prompted, specify the following as required for your VoIP media gateway
(source and destination of VoIP traffic) configuration:
• gateway-ip-address

• gateway-port
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6. Enter Yes to rename and restart the VM.

Important
Ensure that the VM fully restarts before you proceed.

[+] Step 16. Configure Windows Server for the aux and gvp VMs

1. In the Initial Configuration Tasks window in the vSphere client on the aux and gvp VMs:
• Set the time zone in the format Continent/City or Region. For a list of time zones, see the TZ column

in List of tz database time zones.

2. If your environment uses a domain, you can add it by doing the following:
• Click Provide computer name and domain.
• In the System Properties window, click Change.
• In the Computer Name/Domain Changes window, select Domain and enter the domain name.
• Click OK.

3. Reboot the VM.

[+] Step 17. Verify the gvp and aux IP addresses

1. For the gvp and aux VMs, verify that their IP addresses is correct:

• Run the Windows command ipconfig/all. If the host received proper IP configuration from your DHCP
Server, the values will match your network settings.

• Verify that the server can reach the remote host:
Ping an external server (such as a server you plan to use for your agent desktops) by running the command ping remote host
name or IP address. The remote host must be reachable via ping and the output of the ping command looks similar to this
example (note the shortened output and sample IP addresses; ping times may vary):

Pinging agent-desktop.domain.com [1.2.3.4] with 32 bytes of data:

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Ping statistics for 1.2.3.4:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms
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• From the remote host you just pinged, open the console window and issue the following command:
ping <remote host name or IP address>

UI

[+] Step 18. Configure the ui VM

Important
Configure the ui VM only after you have configured all other VMs.

1. Power on the VM.
2. In Windows setup, set the locale, enter the product key, accept the license terms, and change the

password. To verify, use the same criteria as for the core server.
3. The UI tuneup script automatically launches. When prompted:

• Enter the Primary Core Host IP address.
• Enter Yes to rename and restart the VM. Ensure that the ui VM fully restarts before you proceed.

{{NoteFormat|After the ui VM restarts, the tuneup script for BOE (tuneup_boe.bat) runs automatically. Do not respond to the
prompts at this time. Minimize the script window and continue to the next steps.

[+] Step 19. Configure Windows Server for the ui VM

Important
You must complete this step before configuring the BOE script.

1. In the Initial Configuration Tasks window in the vSphere client on the ui VM:
• Set the time zone in the format Continent/City or Region. For a list of time zones, see the TZ column

in List of tz database time zones.

2. If your environment uses a domain, you can add it by doing the following:
• Click Provide computer name and domain.
• In the System Properties window, click Change.
• In the Computer Name/Domain Changes window, select Domain and enter the domain name.
• Click OK.
• Reboot the VM.

{{NoteFormat|After the ui VM restarts, the tuneup script for BOE (tuneup_boe.bat) runs automatically. Do not respond to the
prompts at this time. Minimize the script window and continue to the next steps.
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[+] Step 20. Verify the ui IP address

1. Verify the ui VM IP addresses is correct by doing the following:

• Run the Windows command ipconfig/all. If the host received proper IP configuration from your DHCP
Server, the values will match your network settings.

• Verify that the server can reach the remote host:
Ping an external server (such as a server you plan to use for your agent desktops) by running the command ping <remote host
name or IP address>. The remote host must be reachable via ping and the output of the ping command looks similar to this
example (note the shortened output and sample IP addresses; ping times may vary):

Pinging agent-desktop.domain.com [1.2.3.4] with 32 bytes of data:

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Ping statistics for 1.2.3.4:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms

• From the remote host you just pinged, open the console window and issue the following command:
ping <remote host name or IP address>

[+] Step 21. Configure the BOE tuneup script
The tuneup_boe.bat script runs automatically during ui VM startup and should be minimized on your
desktop. Restore the script window and do the following:

1. Enter the BOE license code (Genesys does not provide this).
2. Wait for the BOE tuneup script to finish and close (the script can take 30 minutes or more to complete).
3. In the Initial Configuration Tasks window, set the time zone in the format Continent/City or Region.

For a list of time zones, see the TZ column in List of tz database time zones.
4. If your environment uses a domain, you can add it by doing the following:

• Click Provide computer name and domain.
• In the System Properties window, click Change.
• In the Computer Name/Domain Changes window, select Domain and enter the domain name.
• Click OK.

5. In the Windows security window, enter the administrator ID and password.
6. Restart the VM.
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Final steps
[+] Step 22. Backup the VMs
Genesys recommends that you backup the VMs by exporting them to an external location or device.

1. Open the vSphere Client.
2. For each VM, do the following:

• Power off the VM.
• In the vSphere client, highlight the target VM and select File > Export > Export OVF Template.
• For the file format, select Single File (OVA).
• Specify the output file name and location.
• Export the file.
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Voice routing application

Overview

Inbound routing

The voice routing application is deployed automatically during BEP installation and provides essential
inbound call center functions using built-in strategies:

• Entry handling based on contact center status
• Auto-attendant (Interactive Voice Response) menus
• Call distribution based on agent availability and call priority

Entry handling
The application receives the incoming call, retrieves the dialed number (DNIS), and applies status
conditions to the call. Is the contact center closed, and if so, why?

• Is it a holiday? If so, the caller hears the Special Day announcement.
• Did the call come in outside of normal operating hours? If so, the caller hears the Closed

announcement.
• Is an emergency underway? If so, the caller hears the Emergency announcement.
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If the contact center is open, the caller hears an announcement or the auto-attendant menu (if one
exists), or the call passes directly to an agent.

Auto-attendant menus
If you have given the caller a menu of options (“Press 1 for Sales,” and so on), the call passes to the
Auto-attendant menu (DTMF) workflow, which specifies the action to be taken depending on the
caller’s menu choice. The Auto-attendant flow can cycle up to three times, to accommodate three
layers of routing. The Auto-Attendant Menus (DTMF) workflow, diagrammed below, acts as an
Interactive Voice Response tree to the customer. It plays a menu announcement configured in the
Inbound Template, and assigns a Distribution Parameter Group or an Inbound Parameter Group based
on the digit (touch tones) collected. For example: The announcement gives the customer three
choices (Press 1 for Customer Service, 2 for Sales, and 3 for Technical Support):

• Touch tone 1 = Customer Service (Distribution Template)
• Touch tone 2 = Sales (Distribution Template)
• Touch tone 3 = Tech Support at Route Point 6001 (the Inbound Template that matches the DNIS for the

Technical Support Route Point)

The auto-attendant flow can accommodate up to three cycles during a call. In the example above,
Touch tone 2 (Sales) might give the caller a second set of options: for Product A, press 1; for product
B, press 2, and so on. To learn how to build your menus, see the Configuration tab.

Call distribution
The Distribution call flow distributes the call to an agent:

1. It collects statistics to determine what agents are logged in and available to take the call.
2. It routes the call to an agent from a target agent group: it first tries an agent from Target 1, then, in

sequence, tries Targets 2, 3, and 4 if it does not find an agent within the timeout set for that target.
Finally, if it does not find an agent from Targets 1-4 within the allotted time, it sends the call to the
overflow target, which can be a standard telephone number (such as 415-555-1212) or a routing point
(such as 6001). Note that Targets 2-4 are optional; routing skips any undefined targets.

The application plays queue music in a loop until the call is distributed to an agent or abandoned.

Redirect On No Answer (RONA): if the call has already been distributed to an agent who does not
answer, the Distribution flow distributes the call as if it had not been previously distributed, and sets
to Not Ready the status of the agent who did not answer.

Configuration

Business Edition Premise routing configuration occurs at two levels:

• Initial configuration, which involves the automated setup of auto-attendant menus, business rules, and
other configuration objects. The voice routing solution is automatically deployed and installed as part of
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the BEP software installation, with default initial configuration settings. These settings are usually
sufficient for most site requirements and do not need to be changed.

• Administrative configuration, such as setting open hours and switching among auto-attendant menu
trees, is a subset of the initial configuration tasks and takes place entirely within Genesys Administrator
Extension (GAX). It requires no advanced knowledge of Genesys software.

Important
To use Internet Explorer 10 to access Genesys Administrator Extension or Genesys
Administrator, you must add your VM domain to the IE Trusted Sites (for multi-VM
deployments, use the ui VM).

You can configure different values for a number of routing parameters, such as open hours and call
priority. To handle different call flow and email scenarios, you use GAX to create parameter groups
based on the default parameter group templates supplied in Business Edition Premise.

Voice solution definitions (SPDs)

When solution definitions (SPDs) are installed, they automatically create several
objects. If you install a new SPD, Configuration Server objects created by
previous voice or email installations are not overwritten. [+] Show more info
The Voice SPD creates these objects:

• Default personality
• Audio resources
• Parameters
• Parameter group templates
• Parameter groups

The Voice SPD also creates these samples (object name in parentheses):

• ACD Queues (9000)
• Action codes (Admin Work, Locked, Lunch, Meeting, Pause, RONA, Training)
• Agent groups (AG_Voice_Sample, AG_Voice_Skill_Sample)
• Agent Logins (1000)
• Business attributes
• DN Groups (All_ACDQueues, All_RoutePoints, All_VirtualQueues)
• Extensions (8000)
• Place Groups (All_Places)
• Places (Place_SIP_8000)
• Route Point (selected during SPD installation)
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• Skill (Skill_Sample)
• Virtual queue (VQ_Default_sample)

Initial configuration
Initial configuration of the voice routing application is done automatically during the BEP software
installation. Typically, the defaults supplied in the solution definition are sufficient for most customer
requirements. Changing these settings requires some knowledge of Genesys software.

You can adjust voice routing parameters in either of two ways:

• To set new default values to be used in all new parameter groups that use the parameter, open Genesys
Administrator Extension, navigate to Operations > Parameters, and adjust values as desired. Do not
change Key Names.

• To set a new value that applies only to a specific parameter group, open Genesys Administrator
Extension, navigate to Operations > Parameter groups, and adjust values as desired.

Administrative configuration
You can use the following procedures to change the administrative configuration settings of your
voice routing solution:

[+] Define the auto-attendant menus
You can use parameter groups to build multiple sets of up to three cascading auto-attendant menus.
Keep in mind that you must record corresponding Auto attendant menu announcements for each set
you build.

To create a single set of three cascading menus:

1. Plan your menu set, because it is most efficient to begin by creating the third tier and its touch-
tone selections, then the second tier, then the first. Your plan will look something like the following
(the parameter group type is in parentheses):

8000 (Inbound)
1: Customer Service (Distribution)

1: Wondrous Product Line (Distribution)
2: Stupendous Product Line (Distribution)

2: Sales (Distribution)
1: North America (Distribution)
2: EMEA (Distribution)

3: Technical Support at routing point 6001 (Inbound)
1: Printers (Distribution)
2: Monitors (Distribution)
3: Mice (Distribution)

A customer having difficulty with their mouse calls the number that corresponds to routing point
8000, then presses 3 for Technical Support and 3 again for Mice. In this example, you create 11
parameter groups: 2 Inbound and 9 Distribution.

2. Deploy the third-tier parameter groups (in the example, Wondrous Product Line, Mice, and the
other 5). See below for help in setting the individual parameters.
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3. Deploy the second-tier parameter groups. Add the third-tier groups as values for the Touch tone
parameters. In the example, you deploy the Sales parameter group, then assign the North America
group to Touch tone 1, and EMEA to Touch tone 2.

Important
When you create an Inbound parameter group, the name of the parameter group
must be the same as the routing point that you want to handle these incoming calls
(in the example, the Technical Support group must be named 6001).

4. Deploy a parameter group based on the Inbound parameter group template. Add the second-tier
groups as values for the Touch tone parameters. In the example, you deploy the 8000 parameter
group, then assign the Customer Service group to Touch tone 1, Sales to Touch tone 2, and 6001 to
Touch tone 3.

[+] Upload audio resources
In GAX, for each audio resource, upload the corresponding audio (WAV) files:

Resource name Description
Announcement-Auto attendant menu Played when the auto attendant is enabled
Announcement-Closed Played when the service is closed
Announcement-Emergency Played when Emergency declared is activated
Announcement-Greeting 1 Played when Greeting 1 is enabled
Announcement-Greeting 2 Played after Greeting 1 when Greeting 2 is enabled
Announcement-Special day Played for a Special day
Music File Music played while the caller is in the queue

[+] Customize business attributes
Your customer might require different Disposition Codes, which are the codes agents can select to
specify the outcome of an interaction. The default disposition codes are:

• Cross Sell
• Not Right Skill
• Terminated
• Transferred
• Up Sell

To modify these samples or create your own codes, in Genesys Administrator, navigate to
Provisioning > Routing > eServices > Business Attributes, and open the existing Disposition
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Code Business Attribute.

Your customer might also require different reporting categories. The five default business parameters
(Service, Segment, Product, Department, and Flow) represent reporting categories and are
completely customizable to your business model. You can assign different combinations of these
parameters to each of your Inbound and Distribution parameter groups, to distinguish them in
reporting and enable you to identify the unique properties of the parameter group.

[+] Set open hours and special days
The parameter Open hours sets the standard hours that your office is open during the week. Use
the Special day parameter to set:

• The dates or days of the week on which your office is closed for the entire day.
• The dates or days of the week on which your office is closed for only part of the day. In these cases, you

use the Time Ranges field in GAX to set the hours that you will be open on that date.

Specific dates set in Open hours are treated as special days. Hours set for the same date in Special
day override those set in Open hours; for example, if Open hours specifies that you are open from
9AM to noon on December 31, and Special day sets the hours of 11AM-2PM for the same date,
callers who call at 10AM on that date hear the Closed announcement. Similarly, in both parameters,
date patterns higher in the list take precedence over those lower in the list.

[+] Set targets and target timeouts
Assign at least one target agent group for each parameter group. Change the timeout for each group
as needed (default is 300 seconds, or 5 minutes). You should also assign a Target overflow, which
serves as the "last resort" number to which a call is transferred when none of the other target agent
groups answers within their timeout.

[+] Tune priorities
You can adjust the priority of calls using the four priority tuning options. Over time, unanswered calls
receive higher and higher priority, ensuring that calls do not remain in the queue for excessive
lengths of time.

• Priority start sets the initial call priority; you typically have little reason to change the default of 1.
• Priority interval sets the number of seconds between priority increments. If you set the priority

interval to 60 seconds, for example, and the priority increment is 1, then after 5 minutes of wait time,
the call would have a priority level of 6, pushing it ahead of calls with priority values of 1-5.

• Priority Increment sets the number to add to the priority value each time the priority interval is
exceeded. As the priority levels are relative, a setting of 1 typically works.

• Priority limit sets the upper limit for priority increments; all calls at the maximum priority level receive
equal treatment.
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[+] Configure UCS database pruning (recommended)
Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size.

Important
Changes made to the UCS database maintenance settings will apply to all deployed
media strategies (Voice, Email, Chat, and Outbound).

1. On the VM host (for multi-VM installations, use the ui VM), log in to Universal Contact Server Manager.
2. Select the Scheduled task on Main DB tab.
3. Configure the Main DB maintenance settings as desired.
4. Click Save.

Verification of voice call routing and reporting

You can use the following procedures to verify that your BEP system is correctly receiving and routing
calls and that the call reporting functionality is working.

[+] Verify call routing
To verify that Business Edition Premise is correctly receiving and routing calls, make a test call to an
agent:

1. Ensure that you have:
• A soft phone, such as SJPhone
• A sound-enabled Windows PC that can connect to the Core server

2. In GA, set the SIPS TServer option enable-unknown-gateway to true.
Important: After completing the verification process, restore this value to false.

3. In GA, ensure that the user TestAgent belongs to the agent group AG_Voice_Sample.
4. In GAX, for parameter group 6000, ensure that:

• Greetings activated is True.
• Target 1 is AG_Voice_Sample.
• Open Hours includes the current time (or the call will not route to the agent).

5. Install the Interaction Workspace (IWS) client by navigating to http://VM name or IP

Voice routing application Sizing and performance assumptions

Business Edition Premise Provider's Guide 49



Back to top

address/InteractionWorkspace/publish.htm and selecting Install or Launch. (For multi-VM
installations, use the ui VM.)

6. Open IWS and log in using these credentials:
• User name: TestAgent
• Password: (none)
• Place: Place_1000
• Queue: 1004@SIP_Switch

Ensure that the agent can log in and set their status to ready.

7. Open a soft phone as any user. For Domain, enter the FQDN of the SIP Server. Uncheck Register with
domain.

8. Dial 6000. If the installation was successful, the call appears in IWS.

[+] Verify call reporting
To verify reporting, run a report in Interactive Insights (GI2).

VIDEO: To watch a short demonstration of running a report, click the Genesys icon below:

Generating a Report Generating a Report using Pre-Set Values

1. In a browser, log into GI2 at http://VM name or IP address:9080/CmcApp/logon.faces (for multi-VM
installations, use the ui VM).
• User: administrator
• Password: G3n35y5

2. Go to Folders > Interactive Insights > 8.1.1 > Agents.
3. Run the report Agent Group Interaction Handling Report.
4. In the report list, click Refresh until status = success.
5. Open the report and click Instance Time. If the installation was successful, the call appears in the

report.
6. In GA, reset the TServer option enable-unknown-gateway to false.
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Operational Parameters

For each parameter group, enter a description in the Description field. For instructions on setting
these parameters, see Configuration.

Audio and Announcements
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Announcement-Closed Closed Annc, any valid
audio resource Yes

Audio Resource played
when the service is
closed

Announcement-Auto
attendant menu

Auto-attendant Menu
1, any valid audio
resource

Yes
Audio Resource played
when the auto
attendant is enabled

Announcement-
Emergency

Emergency Annc, any
valid audio resource Yes

Audio Resource played
when Emergency
declared is True

Announcement-Greeting
1

Greeting 1, any valid
audio resource Yes

Audio Resource played
when Greeting 1 is
enabled

Announcement-Greeting
2

Greeting 2, any valid
audio resource No

Audio Resource played
after Greeting 1 when
Greeting 2 is enabled

Announcement-Special
day

Special Day Annc, any
valid audio resource Yes Audio Resource played

for a special day

Greetings activated False, True Yes
Activates the Greeting 1
and, if enabled,
Greeting 2
announcements

Music File Music In Queue, any
valid audio resource Yes

Audio Resource for
music played while the
caller is in the queue

Personality
Default Personality,
other personality
defined in GAX

Yes The voice used in the
announcements

Auto-attendant menus
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Auto attendant menu
activated False, True Yes

Activates an auto-
attendant menu (such
as Press 1 for Sales) for
this parameter group
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Parameter Values (default in
bold) Mandatory? Description

Touch tone 0 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 0

Touch tone 1 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 1

Touch tone 2 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 2

Touch tone 3 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 3

Touch tone 4 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 4

Touch tone 5 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 5

Touch tone 6 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 6

Touch tone 7 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 7

Touch tone 8 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 8

Touch tone 9 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 9

Business (reporting)
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Department [none], an item from No A business organization
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Parameter Values (default in
bold) Mandatory? Description

the Department custom
list for the parameter
group

used as a category in
reporting

Flow
[none], an item from
the Flow custom list for
the parameter group

No A business flow used as
a category in reporting

Product
[none], an item from
the Product custom list
for the parameter group

No
A product or product
group used as a
category for reporting

Segment
[none], an item from
the Segment custom list
for the parameter group

No
A customer category
used as a category for
reporting

Service
[none], an item from
the Service custom list
for the parameter group

No
Business categories
typically used as the top
level of the auto-
attendant menu choices

Target virtual queue [none], a target virtual
queue set in GA No

A reporting entity set up
in Genesys
Administrator

Contact center status
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Emergency declared False, True Yes

Activates the
emergency
announcement,
overriding any other
announcement

Open Hours

From Monday to
Friday, 0800-2000,
closed Saturday and
Sunday, value set for
parameter group

Yes

Sets the hours that you
are open and accepting
calls; to specify open
hours on specific dates,
you must place the date
above all day-of-week
entries

Special day December 25,
January 1, any dates No

A list of exceptions to
the regular open hours,
for a holiday or other
reason.

Distribution
[+] Show parameters.
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Parameter Values (default in
bold) Mandatory? Description

Default distribution
parameter group

[none], parameter
group No

The distribution
parameter group that
provides the default and
overflow target for this
parameter group; if you
do not set this
parameter, the call flow
uses the originally
defined list of targets
and timeouts

Target 1 [none], agent group No The first agent group to
which the call is routed

Target 2 [none], agent group No
The second agent group
to which the call is
routed

Target 3 [none], agent group No The third agent group to
which the call is routed

Target 4 [none], agent group No
The fourth agent group
to which the call is
routed

Target 1 timeout 300, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target 2 timeout 1, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target 3 timeout 1, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target 4 timeout 1, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target overflow
[none], a standard
telephone number, such
as 8005551212

No

The phone number to
which a call is routed if
the final Target timeout
is exceeded or if no
target agent group is
specified. Important:
you cannot use a
routing point as this
number.

Priority tuning
[+] Show parameters.
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Parameter Values (default in
bold) Mandatory? Description

Priority Increment 0, integer between 0
and 99999 No

Sets the number to add
to the priority value
each time the priority
interval is exceeded

Priority Interval 0, integer between 0
and 99999 No

The time interval (in
seconds) between
priority increments

Priority Limit 0, integer between 0
and 99999 No

Sets the upper limit for
priority increments; all
calls at the maximum
priority level receive
equal treatment

Priority Start 1, integer between 1
and 99999 Yes

The initial priority
assigned to each
incoming call
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eServices application

Overview

The Business Edition Premise eServices application allows you to install and configure the optional
Email and Chat routing solutions.

Important
You cannot install Chat as a standalone application. You can only install Chat if you
have also installed and activated the Email routing application.

For more information about eServices, see the eServices documentation page.

Deployment

The following steps describe how to deploy the eServices application. If you are not installing the
Email or Chat options, you do not have to do these steps.

WATCH: To view a short demonstration of the eServices application deployment, click the Genesys

icon below:

1. In GAX, go to Configuration > Solution Definitions and select Genesys eServices Single Host
Deployment.

2. From the > menu next to the Delete button, select Install.
3. Use the default values, except for the following:

• Check or uncheck Activate chat-media support, depending on whether or not you want to
activate chat.

• DB Server for Interaction Server: DBServer_AUX
• DB Server for Interaction Concentrator: DBServer_ICON
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• Database Administrator Name: sa
• Database Administrator Password: G3n35y5!
• Database User Name: genesys
• Database User Password: Genesy$_0
• Set the customer Email Server Client Address, Email Server Domain Name, and Email Server POP

Client Login Password.

Next Steps: After eServices is installed, you can deploy the Business Edition Premise Email and Chat
routing applications. For more information, see Email routing and Chat routing.
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Email routing application

Overview

Email routing

The Business Edition Premise email routing application can:

• Screen incoming email subject lines for recognized terms
• Enable supervisor review before the emailer receives an agent response
• Distribute the email to a target agent group
• Send an acknowledgement based on contact center status

Content screening
If you enable screening, the application scans the subject line of the email, looking for terms that
match those defined in the screening rules. If it finds a match, it uses the parameter values defined
in one of the five Category parameter groups.

For example, if the email subject includes the term "annoyed", and the Category2 screening rule
includes the term "annoyed", the application uses the Category2 parameter group values, such as
Email supervisor review=True and Email supervisor review percentage=100, meaning that a
supervisor will review every response to such an email.
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If there is no match or screening is not enabled, the application assigns the default category.

Distribution
The screening rule also determines the target and overflow agent groups. If the email is not handled
by an agent from the Email target agent group within the Email target timeout (default is one hour),
the email is routed to the Email overflow target agent group. If the email is not handled by an agent
from the overflow target agent group within the Email overflow target timeout (default is one day),
the email returns either to the target agent group or to the overflow agent group, at a higher priority.

Acknowledgements
Like the voice routing application, the email application can send a different acknowledgement email
based on the status of the contact center: open, closed, or special day.

Deployment

To deploy the Business Edition Premise routing applications, you deploy the solution definition in
Genesys Administrator Extension (GAX). Solution definitions are also known as solution package
definitions, or SPDs. The email routing application also requires you to deploy eServices applications,
import Knowledge Manager templates, and deploy the email strategy.

This section describes how to deploy the email routing application. Email deployment is optional; if
you are not installing the email option, you can skip these steps.

[+] Step 1. Install the email solution definition
WATCH: To view a short demonstration of the email solution definition installation, click the Genesys

icon below:

1. In GAX, go to Configuration > Solution Definitions and select Genesys One OPM Email
Parameters.

2. Complete the wizard, using default values except for:
• GAX host: VM host name (for multi-VM installations, use the ui VM)
• Switch: eServices_Switch
• Email address: the Do Not Reply address that you select for the customer mail server
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• Email Sample Configuration: True

[+] Step 2. Import the Knowledge Manager templates
VIDEO: To watch a short demonstration of how to import the Knowledge Manager templates (for a

multi-VM envinronment), click the Genesys icon below:

1. In Genesys Administrator, ensure that the eServices solution is started.
2. Go to: http://VM host name or IP address/ips and locate and download

email_strategy_ext_version.zip. (For multi-VM installations, use the aux host.)
3. Unzip the file.
4. Browse to email_strategy_ext\KNOWLEDGE and copy the

GenesysOne_KnowledgeManager_Rules_Responses_ENU.kme file to a temp folder on the local
disk.

5. Under Genesys Solutions\eServicesxxx\Knowledge Manager, start Knowledge Manager.
• Username: default
• Password: password
• Application: eServices_KnowledgeManager
• Host: VM name (for multi-VM installations, use the core VM)

6. Go to File > Import and select the kme file from the temp folder.
Important:

• Uncheck Preserve uniqueness of objects
• Check Update screening rules.

Click OK and ignore the 5 warnings.

7. If you are using Special Day Auto Responses in Email, you must manually change the Time Zones for
AutoResponse:
• Start Knowledge Manager.
• Click AutoResponse, and then double-click Special Day.
• Locate the two instances of TimeZone and replace them with the correct time zone IDs.

Important: You must use time zone database IDs to indicate time zones. For a list of time zone
database IDs, see http://en.wikipedia.org/wiki/List_of_tz_database_time_zones.

• Click Check field Codes to view the Special Day Auto Response with the field codes rendered.
• Click OK.
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[+] Step 3. Deploy the email strategy

1. In a browser, go to http://VM name or IP address/ips (for multi-VM installations, use the core VM).
Locate, download, and extract the following zip files:
• email_strategy_version.zip

• composer_version_enus.zip

2. Install Composer 8.1.3 on a Windows system that is not a VM and is not already running Apache Tomcat
(to avoid port conflicts). Follow the installation instructions in the Composer 8.1 Deployment Guide.

Note that Composer 8.1.3 is an Eclipse plugin that requires JDK 1.7 and a supported version of
Eclipse. Composer installs its own Apache Tomcat server.

3. Copy the GenesysOne_Email folder (from the email_strategy_ext_version zip that you just
extracted) to a temp folder on the Composer system.

4. Open Composer and go to File > Import > General > Existing Projects into Workspace.
5. Choose Select archive file and then select the email strategy you copied from the VM.

Important: Select the project from the newly populated list, ensuring Copy projects into
workspace is enabled, and click Finish.

6. Verify that the local Tomcat server details are correct for your Composer installation:
• Go to Window > Preferences > Composer > Tomcat.
• Enter the Port, Login (admin), and Password (admin).
• Check the Tomcat Location to confirm that it is on the local disk (for example, c:\Program Files

(x86)\GCTI\Composer 8.1\tomcat).

7. In Composer Package Explorer, expand the GenesysOne_Email package, right-click Interaction
Processes > Email ixnprocess, and select Publish to Configuration Server (you might first need
to connect to Configuration Server from the Composer menu bar).

8. Right-click the package name and select Properties. Deploy the project.
9. Create a war file:

• Right-click the package name and select Export > Composer > Java Composer Project as WAR
file.

10. Copy the war file to \\VM host\c$\GCTI\apache-tomcat\webapps (for multi-VM installations, use the
core VM). The war file automatically extracts to a new GenesysOne_Email folder.

11. Point the new scripts to the correct server:
• Open GA and go to Provisioning > Routing/eServices > Orchestration, which includes nine

enhanced routing scripts.
• Double-click GenesysOne_Email.Email.Entered.Routing and change the Orchestration URI to

include the correct VM server name; for example, http://g1-sngl-p:8380/GenesysOne_Email/
IPD_Email_Entered.scxml (single-VM) or http://g1-core-p:8080/GenesysOne_Email/
IPD_Email_Entered.scxml (multi-VM).

• Repeat for each of the other scripts.
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Configuration

Business Edition Premise routing configuration occurs at two levels:

• Initial configuration, which involves the setup of auto-attendant menus, business rules, and other
configuration objects, requires a basic understanding of Genesys software, particularly Genesys
Administrator, SIP Server, and, for email, eServices Knowledge Manager.

• Administrative configuration, such as setting open hours and switching among auto-attendant menu
trees, is a subset of the initial configuration tasks and takes place entirely within Genesys Administrator
Extension (GAX). It requires no advanced knowledge of Genesys software.

You can configure different values for a number of routing parameters, such as open hours and call
priority. To handle different call flow and email scenarios, you use GAX to create parameter groups
based on the default parameter group templates supplied in Business Edition Premise.

Email solution definitions (SPDs)

Installation of the solution definitions (SPDs) automatically creates several
objects. Configuration Server objects created by previous voice or email
installations are not overwritten. [+] Show more info
The Email SPD creates these objects:

• Parameters
• Parameter group templates
• Parameter groups
• Transaction (Technical, Email Default)

The Email SPD creates these additional samples (object name in parentheses):

• Agent groups (AG_Email_Sample, AG_Email_Overflow_Sample, Email Supervisors)
• Business attributes (Disposition Code (Attributes), iWS_ToastUserData, iWS_UserData)
• Capacity Rule (GenesysOne_1Voice_1Email)
• Persons (AgentSample, SupervisorSample)
• SIP Switch Virtual queue (VQ_Default_email)
• Transactions (Category1OverrideIWS, Category2OverrideIWS, Category3OverrideIWS,

Category4OverrideIWS, Category5OverrideIWS)

Initial configuration
Initial configuration of the email routing application depends on the needs of the customer. In many
cases, the defaults supplied in the solution definition will be sufficient.

You can adjust email routing parameters in either of two ways:

• To set new default values to be used in all new parameter groups that use the parameter, open Genesys
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Administrator Extension, navigate to Operations > Parameters, and adjust values as desired. Do not
change Key Names.

• To set a new value that applies only to a specific parameter group, open Genesys Administrator
Extension, navigate to Operations > Parameter groups, and adjust values as desired.

[+] Step 1. Configure screening rules
You can use the eServices Knowledge Manager application (for multi-VM, this is on the aux VM) to
customize the screening rules used to route email to any of the five Category parameter groups.

"Content screening", in the Overview section, explains how screening works in Business Edition
Premise.

"Screening Rules" in the eServices 8.1 User's Guide explains how to use the Screening Rule Editor
and details how the rules work.

[+] Step 2. Configure email acknowledgements
You can also use the eServices Knowledge Manager application to customize the text of the
acknowledgement emails: Email acknowledgement body open hours, Email
acknowledgement body closed hours, and Email acknowledgement body special days, as
well as the opening (salutation), closing, and time zone.

"Using Categories and Standard Responses" in the eServices 8.1 User's Guide explains how to edit
the acknowledgement content.

[+] Step 3. Configure distribution
After you customize the screening rules, you can adjust their associated parameter groups to
distribute emails to the correct targets. If you added the term "sales" to the Category 3 screening
rule, for example, you can route emails with "sales" in their subject lines to a particular target agent
group by setting the Category 3 parameter group Email target value to the Sales agent group.

You can also enable or disable supervisor review, and change the percentage of emails subject to
review.

[+] Step 4. Set open hours and special days
The parameter Email open hours sets the standard hours that your office is open during the week.
Use the Email special day parameter to set:

• The dates or days of the week on which your office is closed for the entire day.
• The dates or days of the week on which your office is closed for only part of the day. In these cases, you

use the Time Ranges field in GAX to set the hours that you will be open on that date.
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Specific dates set in Email open hours are treated as special days. Hours set for the same date or
day of the week in Email special day override those set in Email open hours; for example, if
Email open hours specifies that you are open from 9AM to noon on December 31, and Email
special day sets the hours of 11AM-2PM for the same date, people who send an email at 10AM on
that date receive the special day acknowledgement.

Similarly, in both parameters, date patterns higher in the list take precedence over those lower in the
list.

[+] Step 5. Tune priorities
You can adjust the priority of emails using the two priority tuning parameters:

• Email priority sets the initial email priority; you typically have little reason to change the default of
100.

• Email overflow priority sets the priority of emails that exceed the Email target timeout. The
default value is also 100, which means that emails that have already passed the overflow timeout will
be re-queued based solely on their age, ensuring that the oldest emails will appear in the queue first.

[+] Step 6. Send a test email
To verify that Business Edition Premise is correctly receiving and routing emails, send a test email:

1. Install an email client and ensure that it connects to your email server.
2. Send an email to the address specified during the eServices SPD deployment.
3. Ensure that you have installed an IWS client (you did this when you were making a test call during the

voice routing configuration).
4. If Business Edition Premise is successfully installed, an IWS interaction window containing the email

appears when the email arrives.

[+] Step 7. Configure UCS database pruning
Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size.

Important
Changes made to the UCS database maintenance settings will apply to all deployed
media strategies (Voice, Email, Chat, and Outbound).

1. On the VM host, log in to Universal Contact Server Manager. (For multi-VM, use the ui VM.)
2. Select the Scheduled task on Main DB tab.
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3. Configure the Main DB maintenance settings as desired.
4. Click Save.

Operational Parameters

This section describes the operational parameters that are available for the email routing application.
For instructions on setting these parameters, see Configuration.

Acknowledgements
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email acknowledgement True, False Yes

Sends customer an
acknowledgement
email, content
depending on whether
you are open, closed, or
on a special day

Email acknowledgement
body open hours

Thank you for your
email. We will get
back to you as soon
as possible., text
string entered in Value
field

Yes
The body text used for
acknowledgements sent
during regular hours

Email acknowledgement
body closed hours

Thank you for your
email. We are
currently closed and
will get back to you
as soon as possible.
Our office hours are:,
text string entered in
Value field

Yes
The body text used for
acknowledgements sent
during closed hours

Email acknowledgement
body special days

Thank you for your
email. We are
currently closed and
will get back to you
as soon as possible.
Our office reopens on
date, text string
entered in Value field

Yes
The body text used for
acknowledgements sent
during special days

Email acknowledgement
opening

Dear Customer name,
text string entered in
Value field

Yes
The greeting to the
customer at the
beginning of the
acknowledgement

Email acknowledgement Regards, text string Yes The closing term to the
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Parameter Values (default in
bold) Mandatory? Description

closing entered in Value field customer at the end of
the acknowledgement

Email acknowledgement
time zone

[none], free-form text
such as Central Time
or GMT

No
The time zone text that
you want to include in
your email
acknowledgements.

Email from [none], email address No
The email address
(typically DoNotReply)
used in sending email
responses to customers

Contact center status
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email open hours

From Monday to
Friday, 0800-2000,
closed Saturday and
Sunday, any value set
in the Value > Date
Pattern field

Yes

Sets the hours that you
are open and accepting
emails; to specify open
hours on specific dates,
you must place the date
above all day-of-week
entries

Email special day
December 25,
January 1, any value
set in the Value > Date
Pattern field

No
A list of exceptions to
the regular open hours,
for a holiday or other
reason.

Distribution
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email screening True, False Yes Enables email screening
rules

Email target [none], agent group Yes The agent group that
first receives all emails

Email overflow target [none], agent group No
The agent group that
receives all emails that
exceed the overflow
target timeout

Email target timeout 3600, integer between
1 and 99999 No

The length of time (in
seconds) that an email
can go unattended
before being passed to
the overflow agent
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Parameter Values (default in
bold) Mandatory? Description

group

Email overflow target
timeout

86400 (24 hours),
integer between 1 and
99999

No

The length of time (in
seconds) that an email
can go unattended
before being passed to
the first available agent
group (either target or
overflow)

Email supervisor review False, True Yes Enables supervisor
review.

Email supervisor review
percentage

100, integer between 0
and 100 Yes

The percentage of
emails routed to
supervisors for review

Email supervisor agent
group [none], agent group No

The supervisor agent
group that receives the
emails when supervisor
review is enabled

Email default virtual
queue

VQ_Default_email, a
target virtual queue set
in GA

Yes
The default virtual
queue to which all
emails are routed, for
reporting

Priority tuning
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Email priority 100, integer between 1
and 99999 Yes

The initial priority
assigned to each
incoming email

Email overflow priority 100, integer between 1
and 99999 Yes

The priority assigned to
all emails that exceed
the overflow target
timeout
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Chat routing application

Overview

The Business Edition Premise chat routing application delivers chat interactions to the
AG_Voice_Sample Agent Group.

Important
You cannot install chat as a standalone application. Chat can only be activated if you
have first deployed, installed, and activated the email routing application.

Acknowledgements
The chat application sends acknowledgements to customers, informing them that:

• They are queuing.
• Their chat interaction has been delivered, along with the name of the receiving agent.

The AG_Voice_Sample Agent Group is a system-defined destination and cannot be changed. To
configure a different destination for chat interactions, you must modify the chat strategy in
Composer. For more information about configuring the chat strategy, refer to the Composer
documentation.

Deployment

This section describes how to activate, install, and deploy the chat routing strategy.

[+] Step 1. Activate the chat option
You can activate the chat option when first deploying the email routing application or when modifying
an existing email routing application deployment.

Activating chat when deploying the email routing application
To deploy chat with email, follow the instructions described in Deploying the email routing
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application, but select Activate chat-media support when choosing the eServices applications to
install.

Activating chat by modifying an existing email routing application deployment
To activate chat by modifying an existing email deployment, do the following:

1. In GAX, go to Configuration > Solution Definitions and select Genesys eServices Single Host
Deployment.

2. Click the operations icon (gear) and select Upgrade.
3. Click Next to check the availability of required Installation Packages.
4. Select eServices Solution and check Activate chat-media support, and then click Next.
5. Click Finish to start the deployment.

[+] Step 2. Install the chat solution definition
WATCH: To view a short demonstration of the chat solution installation, click the Genesys icon below:

1. In GAX, go to Configuration > Solution Definitions and select Genesys One OPM Chat
Parameters [ENU].

2. Keep all default options, except for the following, which are specific to your site:
• GAX host
• GAX user
• GAX password
• Application Server host

[+] Step 3. Deploy the chat strategy
WATCH: To view a short demonstration of the chat strategy deployment, click the Genesys icon
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below:

1. In a browser, go to http://<VM name or IP address>/ips (for multi-VM, use the core VM). Locate,
download, and extract the following zip files:
• chat_strategy_version.zip

• composer_version_enus.zip

2. Install Composer 8.1.xx on a Windows system that is not a VM and is not already running Apache
Tomcat (to avoid port conflicts). To do this, follow the installation instructions in the Composer 8.1
Deployment Guide.

Important: Composer 8.1.xx is an Eclipse plugin that requires JDK 1.7 and a supported version of
Eclipse. Composer installs its own Apache Tomcat server. (See the Release Note.)

3. Open Composer and go to File > Import > General > Existing Projects into Workspace.
4. Choose Select archive file and then select the chat strategy you downloaded and extracted.

Important: Select the project from the newly populated list, ensuring Copy projects into
workspace is enabled, and click Finish.

5. Create a .war file:
• Right-click the package name and select Export > Composer > Java Composer Project as WAR

file.

6. Copy the .war file to \\<VM name or IP address>\c$\GCTI\apache-tomcat\webapps (for multi-VM,
use the core VM). The .war file automatically extracts to a new GenesysOne_Chat folder.

Important
If this folder is not automatically generated, a restart of the Apache/Tomcat service
may be required. To do this, use GA to restart the apache-tomcat_ors application.

After chat is activated and deployed, you can access the following sample chat page: http://<VM
name or IP address>:8380/eservicesweb/chat/index.jsp (for multi-VM, use the aux VM and port
8080)

[+] Step 4. Verify that chat is deployed successfully

1. Log into Interaction Workspace (IWS) as an agent and confirm that:
• Chat is listed in the Media column with a Ready status.
• The Agent Group is AG_Voice_Sample.
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2. Go to http://<VM name or IP address>:8380/eservicesweb/chat/index.jsp (for multi-VM, use the
aux VM and port 8080) and do the following:
• Click Chat > Simple Chat.
• Complete all fields and click Live Help online click to chat.

3. If the deployment is successful, accept the chat request using the IWS Agent.

Configuration

There are no specific Business Edition Premise configuration requirements for chat. However,
Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size.

Important
Changes made to the UCS database maintenance settings will apply to all deployed
media strategies (voice, email, chat, and outbound).

To configure automatic pruning of the UCS database, do the following:

1. On the VM host, log in to Universal Contact Server Manager. (For multi-VM, use the ui VM.)
2. Select the Scheduled task on Main DB tab.
3. Configure the Main DB maintenance settings as desired.
4. Click Save.
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Outbound routing application

Overview

The Business Edition Premise Outbound solution is an Outbound VoIP deployment that allows for the
following types of dialing modes:

• Predictive: This dialing mode predicts agent availability when it dials calls from a calling list and is
recommended for high-volume, low-value campaigns.

• Progressive: This dialing mode dials calls from a calling list when an agent is actually available and is
recommended for low-volume, high-value campaigns.

• Preview: This dialing mode allows an agent to request one or several records from Outbound Contact
Server (OCS), preview each record, and decide whether to dial a call.

For more information about dialing modes, see Dialing Modes in the Outbound documentation.

Outbound routing
The Outbound routing strategy directs the outbound call to an agent group according to the options
configured in the Outbound Parameter Group. For more information about Outbound routing, see the
Outbound documentation.

Deployment

This section describes how to deploy the outbound routing application.

Important
You must obtain and install a valid license for outbound before deploying the
application.

[+] Show deployment steps.

1. Log into the core host.
2. Go to Start > All Programs > Genesys Solutions and select Activate Outbound Contact Server.

Important: Confirm that the appropriate Outbound license is installed before proceeding.
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3. Click Yes to start the deployment.
4. After the deployment completes, verify that it was successful (see video):

a. In GA,
confirm
that Outbound Contact Server (OCS) is started.

b. In GA, load and start the sample campaign:
• Go to Operations > Outbound Contact > Dialing Sessions.
• For Campaign ID, select Test > TestCampaign and for Outbound Contact Server, select

OCS.
• Click Load, and then click Start.

c. Log into IWS using the TestAgent ID:
• Navigate to http://VM name or IP address/InteractionWorkspace/publish.htm and select Launch.

(For multi-VM, use the ui VM.)

d. Add a record to be dialed:
• Go to Operations > Outbound Contact > Calling Lists.
• Select Calling Lists: Test > TestCallingList.
• Select Insert record.
• Enter the details for a valid destination, changing contact_info to the telephone number to be

dialed by SIPS.
• Select OK.

Important: You might need to adjust the following options, depending on the time of day and
your timezone:
daily_from — The time you want calling to start
daily_till — The time you want calling to cease.
tz_dbid — Your timezone.

5. When the outbound call is established, TestAgent receives a call using IWS.

Configuration

There are no specific Business Edition Premise configuration requirements for the outbound routing
application. By default, the Outbound Parameter Group is loaded against Routing Point 7000. To edit
the Outbound Parameter Groups, login to GAX and go to Operations > Parameter Groups.

Also, Genesys recommends that you configure automatic pruning of the Universal Contact Server
(UCS) database to prevent it from growing too large in size. To configure automatic pruning of the
UCS database, do the following:
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Important
Changes made to the UCS database maintenance settings will apply to all deployed
media strategies (voice, email, chat, and outbound).

1. On the VM, log in to Universal Contact Server Manager (for multi-VM, use the aux VM).
2. Select the Scheduled task on Main DB tab.
3. Configure the Main DB maintenance settings as desired.
4. Click Save.

Operational Parameters

To edit the Outbound Parameter Groups, log in to GAX and under Operations, select Parameter
Groups.

Outbound Parameter Group
[+] Show parameters.

Parameter Values (default in
bold) Mandatory? Description

Voice Target TestAgentGroup,
agent group Yes The Agent Group to

which the call is routed.

Voice Target Timeout 2, integer between 1
and 99999 Yes

The timeout (in
seconds) after which the
call is routed to the
overflow target.

Overflow Voice Target (none) No

The number to which
the call is routed if no
target is specified or if
the target timeout is
exceeded.
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Related Topics

• Installing Business Edition Premise
• System Maintenance

Frequently Asked Questions About...

Business Edition Premise System Requirements

This page provides answers to common questions
that IT personnel might have when planning or
considering the addition of a Business Edition
Premise system to their site. The information on
this page applies to 8.1.x versions of Business
Edition Premise.

Hardware

This section contains common questions about BEP hardware requirements.

[+] Can I deploy Business Edition Premise in a High Availability (HA)
configuration?
Yes, please contact Genesys Professional Services for more information.

[+] What type of disk configuration is used?
Business Edition Premise uses a RAID-5 disk configuration.

[+] Is the storage disk or data encrypted?
No, the storage disk or data is not encrypted, although some of the logs do have masking ability.
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[+] Which system components do I need to monitor (for example,
uptime, disks, ports)?
The Dell iDRAC system management tool is built-into the system board and can be configured to
provide all required hardware and system monitoring.

[+] How do I get replacement parts? What is the warranty and service
arrangement?
This depends on your agreed maintenance contract. If you are experiencing hardware issues, contact
your BEP provider for diagnostics and replacement of failed components.

[+] My servers are utilizing the iDRAC7 controller, but I am unable to
access or login after several days of continuous use.
For best performance, make sure the iDRAC firmware is version 1.57.57 or higher. For workarounds
and additional information, visit Dell support.

[+] What are the memory requirements for Business Edition Premise
8.1.201?
The Business Edition Premise 8.1.201 single-host VM image is assigned with 32 GB memory. In
addition, the ESXi 5.5 operating system requires a minimum of 4 GB memory (8 GB is required for full
functionality). The Business Edition Premise server (Dell PowerEdge) has dual CPUs, which use dual
memory banks that must contain the same amount of memory in each bank.

To ensure maximum system performance, a total of 48 GB memory is recommended for Business
Edition Premise 8.1.201.

Software

This section contains common questions about BEP software requirements.

[+] Which operating systems does BEP use?
Business Edition Premise uses the following operating systems:
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• ESXi 5.5
• Windows Server 2008 R2

[+] Does the system include a database?
Yes, Business Edition Premise uses the following database types:

• Postgre SQL (Configuration Server)
• MS SQL Server 2008 R2 (all other Genesys servers)
• Apache Cassandra (ORS, GWS)

[+] Can MS SQL Server be used instead of Postgre SQL?
Yes, if you prefer to use MS SQL Server, you can remove Postgre SQL. After your Business Edition
Premise solution is fully tuned-up, contact Professional Services and ask them to migrate your
Configuration Manager database from Postgre SQL to MS SQL Server.

[+] Does the system have a built-in antivirus or anti-malware package?
No, customers are responsible for their own antivirus and anti-malware monitoring.

[+] Which types of authentication methods are used (for example,
Kerberos, RADIUS, or LDAP)? Will it work with Active Directory?
For details on the authentication methods used and for Active Directory compatibility, refer to the
following VMware document: VMware-vCenter-Server-5.5-Technical-Whitepaper.pdf.

[+] Does the system store any personally-identifiable information (PII)
or protocol-control information (PCI)?
Yes, during the course of normal operations the Universal Contact Server (UCS) database does store
some caller information.

[+] How do I back up the critical system files and configuration files?
The VM Snapshots utility (included as part of the VMware server software) allows you to capture the
VM images in their present state and, if required, instantly restore the system to a known good earlier
state. Genesys recommends that you create snapshots of each VM before performing the tune-up
procedures, as well as when performing important deployments and configuration modifications.
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Note that the VM Snapshots are stored on the ESXi server, so you will need to monitor the hard disk
space being used for the backups. For more information, refer to the following document: VMware-
vCenter-Server-5.5-Technical-Whitepaper.pdf.

[+] What kind of routine maintenance procedures are required?
The Genesys component software in Business Edition Premise requires limited maintenance. Any
required maintenance is described in the documentation for each component.

[+] How do I update the operating systems for security and critical
fixes?
You can update the operating systems using the following methods:

• For Windows, use the Windows 2008 Server Download and Install Updates function on the VM. (If
your Business Edition Premise installation does not have internet access, you can update Windows
offline. Contact Genesys Professional Services for more information.)

• For VMware, use the VMware vSphere Update Manager.

[+] For a multi-VM deployment, is there a specific order in which the
Virtual Machines must be powered-on or off?
Yes, the VMs must be powered-on in the following order:

1. core
2. db
3. aux
4. gvp
5. ui

There is no specific order in which the VMs must be powered-off.

[+] Are any routing applications deployed automatically during BEP
installation?
Yes, the voice routing application is deployed automatically during BEP installation.

[+] Where do I get the required licenses?
For information about requesting licenses, contact your Genesys representative or visit this page.
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[+] While executing the tuneup_boe script on the ui VM (for a multi-VM
deployment), I received a CMS error. What might be the cause?
The db VM hostname must be resolvable in DNS or the BOE installation will fail. Check the network
configuration by performing an nslookup command (both forward and reverse) for all VMs. For
example:

nslookup <FQDN version of VM hostname>

nslookup <IP version of VM hostname>

Do this for each VM in your system. Each should return a successful result.

[+] During tuneup, I entered incorrect information. What do I do?
If you enter incorrect information during the tuneup script configuration, Genesys recommends that
you redeploy the VM and begin the tuneup script configuration again. If you made a snapshot of the
VM prior to entering any data for the tuneup configuration script, you can revert to that snapshot. In
a multi-VM environment, you would redeploy the core VM or revert to a snapshot. But note that if you
redeploy the core VM (or revert to a snapshot), you must also redeploy the other VMs.

[+] I am receiving calls from gateways that are not represented as
Trunk DNs in my environment. How do I fix this?
Go to the SIP Server application in Configuration Manager. Under the T-Server option, make sure that
the value of the enable-unknown-gateway option is false. This secures the SIP Server so that it
only accepts calls from configured Trunk DNs within the configuration environment.

[+] I want to install chat but I am not using the email application. Can I
do this?
No, you cannot install chat as a standalone application. It can only be used if the email application is
also installed and activated.

[+] I have deployed my email (or chat) strategy but they are not
routing. What could be wrong?
After you exported the .war file in Composer, did you copy it to the \\g1-core-p\c$\GCTI\apache-
tomcat\webapps folder? Once copied, the .war file will automatically extract itself to a new
GensysOne_xx folder and the routing should work correctly. (If this folder is not automatically
generated, a restart of the Apache/Tomcat service may be required. To do this, use Genesys
Administrator to restart the apache-tomcat_ors application.)
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[+] How do I optimize my Universal Contact Server database so that it
does not use too much disk space?
Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size. You can do this by modifying the main database
maintenance settings in Universal Contact Server Manager.

[+] How do I check the software version of the pre-installed
components?
To view the supported version numbers (available after the virtual machine(s) are deployed and
tuned up), go to http://VM name or IP address (for multi-VM, use the core VM).

[+] I’m making changes to the configuration sever settings. What is the
[chef] section used for?
This section is used by Genesys during the deployment of your software and can be ignored. It has no
impact on Genesys servers or services.

[+] Our installation is in a Middle Eastern time zone. Why do our reports
not show the correct local time?
If your system is in a Middle Eastern time zone, you should select NET for your local time zone.

Networking

This section contains common questions about BEP networking requirements.

[+] How many IP addresses are required?
This depends on which version of the Virtual Machine (VM) platform you decide to install (single-VM
or multi-VM). Business Edition Premise requires the following IP addresses to prepare the server for
delivery and to finalize the server installation and configuration at the Premise site:

For single-VM:
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• The Dell iDRAC configuration requires one IP address that is within a management control subnet to
allow hardware alarms to be sent using email (the email address used to receive alarms must have
access to the email server at the site).

• The ESXi server requires one IP address that is within the same subnet and is available on a Windows
domain running DNS/DHCP services.

• The Virtual Machine requires an IP address that is within a single subnet and is available on the
Windows domain running DNS/DHCP services. You will also need to assign a hostname for the VM for
entry into a DNS server.

For multi-VM:

• The Dell iDRAC configuration requires one IP address that is within a management control subnet to
allow hardware alarms to be sent using email (the email address used to receive alarms must have
access to the email server at the site).

• The ESXi server requires one IP address that is within the same subnet and is available on a Windows
domain running DNS/DHCP services.

• Each of the five Virtual Machines (VM) requires an IP address that is within a single subnet and is
available on the Windows domain running DNS/DHCP services. You will also need to assign five
hostnames for the VMs for entry into a DNS server.

[+] Do external vendors require remote access?
No.

[+] Does the server need access to the internet?
Internet access is not required; however, if you choose to deploy optional eServices features, such as
Chat or Email, the virtual machine(s) will require internet access.

[+] Does the system have a built-in firewall?
The Virtual Machine(s) use the Windows operating system, which has a built-in firewall that is
disabled by default. If desired, you can enable and configure this firewall.

[+] What are the network speeds, and can I configure network load
balancing or link aggregation?
Business Edition Premise uses 1 GbE (Gigabit Ethernet) networking and is compatible with network
load balancing configurations.
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Requesting licenses
To request Genesys and VMware licenses for Business Edition Premise, complete the following steps:

1. Prepare an email request containing the following details:
• Your software order number or purchase order number.
• The Core VM NIC MAC address (this is for the Genesys software license). If you do not know the MAC

address, and your server was provided by Genesys, you can find it on the label of the box in which
your server was shipped. Otherwise, contact your Genesys Partner.

• For existing deployments, include a copy of your existing license file.
• For non-revenue orders, you should request licenses only if you are upgrading to a major version

release (for example, if you are upgrading version 7.x to 8.x).

2. Send the email request to the appropriate Genesys contact for your geographical region:
• Americas / APAC
• EMEA
• Japan

The response time for license requests is typically 2-3 days.

For more information about licenses, refer to the Genesys Licensing Guide.
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