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Overview

Customer

Email routing

The Business Edition Premise email routing application can:

e Screen incoming email subject lines for recognized terms
* Enable supervisor review before the emailer receives an agent response
e Distribute the email to a target agent group

¢ Send an acknowledgement based on contact center status

Content screening

If you enable screening, the application scans the subject line of the email, looking for terms that
match those defined in the screening rules. If it finds a match, it uses the parameter values defined
in one of the five Category parameter groups.

For example, if the email subject includes the term "annoyed", and the Category2 screening rule
includes the term "annoyed", the application uses the Category2 parameter group values, such as
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Email supervisor review=True and Email supervisor review percentage=100, meaning that a
supervisor will review every response to such an email.

If there is no match or screening is not enabled, the application assigns the default category.

Distribution

The screening rule also determines the target and overflow agent groups. If the email is not handled
by an agent from the Email target agent group within the Email target timeout (default is one hour),
the email is routed to the Email overflow target agent group. If the email is not handled by an agent
from the overflow target agent group within the Email overflow target timeout (default is one day),
the email returns either to the target agent group or to the overflow agent group, at a higher priority.

Acknowledgements

Like the voice routing application, the email application can send a different acknowledgement email
based on the status of the contact center: open, closed, or special day.

Deployment

To deploy the Business Edition Premise routing applications, you deploy the solution definition in
Genesys Administrator Extension (GAX). Solution definitions are also known as solution package
definitions, or SPDs. The email routing application also requires you to deploy eServices applications,
import Knowledge Manager templates, and deploy the email strategy.

This section describes how to deploy the email routing application. Email deployment is optional; if
you are not installing the email option, you can skip these steps.

[+] Step 1. Install the email solution definition

VIDEO: To watch a short demonstration of the email solution definition installation, click the Genesys

= Genesys

icon below:

1. In GAX, go to Configuration > Solution Definitions and select Genesys One OPM Email
Parameters.

2. Complete the wizard, using default values except for:
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e GAX host: UI host name

* Switch: eServices Switch

Email address: the Do Not Reply address that you select for the customer mail server

* Email Sample Configuration: True

[+] Step 2. Import the Knowledge Manager templates

Localized versions of the templates do not include the required categories, so even for
localized environments you must import the
GenesysOne_KnowledgeManager _Rules Responses ENU.kme file.

VIDEO: To watch a short demonstration of how to import the Knowledge Manager templates, click

= Genesys

the Genesys icon below:

1. In Genesys Administrator, ensure that the eServices solution is started.

2. On the Aux host, go to http://Core VM host name or IP address/ips and locate and download
email strategy ext version.zip. Unzip the file.

3. Browse to email strategy ext\KNOWLEDGE and copy the
GenesysOne_KnowledgeManager_Rules_Responses_ENU.kme file to a temp folder on the local
disk.

Important: If you are using Business Edition Premise version 8.1.100.20, this file is named
GenesysOne_KnowledgeManager_Rules_Responses.kme.

4. Under Genesys Solutions\eServicesxxx\Knowledge Manager, start Knowledge Manager.
* Username: default
* Password: password
* Application: eServices KnowledgeManager
* Host: your Core VM name

5. Go to File > Import and select the kme file from the temp folder.
Important:

* Uncheck Preserve uniqueness of objects

* Check Update screening rules.
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Click OK and ignore the 5 warnings.

6. If you are localizing your environment, and only after first importing the English kme file, you can import
the localized kme files, one at a time (the example below uses the French version,
GenesysOne_KnowledgeManager_Rules_Responses_FRA.kme):

* On the Aux host, copy the GenesysOne_KnowledgeManager_Rules_Responses_FRA.kme file
(from the unzipped email strategy ext version.zip file) to a temp folder on the local disk.

» Start Knowledge Manager
e Application: eServices KnowledgeManager

e Host: your Core VM name

* Go to File > Import and select the kme file from the temp folder.
Important:

¢ Uncheck Preserve uniqueness of objects

e Check Update screening rules.
Click OK and ignore the 5 warnings.

7. If you are using Special Day Auto Responses in Email, you must manually change the Time Zones for
AutoResponse:

e Start Knowledge Manager.
* Click AutoResponse, and then double-click Special Day.

* Locate the two instances of TimeZone and replace them with the correct time zone IDs.
Important: You must use time zone database IDs to indicate time zones. For a list of time zone
database IDs, see http://en.wikipedia.org/wiki/List of tz database time zones.

* Click Check field Codes to view the Special Day Auto Response with the field codes rendered.
* Click OK.

[+] Step 3. Deploy the email strategy

1. In a browser, go to http://Core VM name or IP address/ips. Locate, download, and extract the
following zip files:
* email strategy version.zip

* composer_version _enus.zip

2. Install Composer 8.1.3 on a Windows system that is not one of the VMs and is not already running
Apache Tomcat (to avoid port conflicts). Follow the installation instructions in the Composer 8.1
Deployment Guide.

Note that Composer 8.1.3 is an Eclipse plugin that requires JDK 1.7 and a supported version of
Eclipse. Composer installs its own Apache Tomcat server.

3. Copy the GenesysOne_Email folder (from the email strategy ext version zip that you just extracted)
to a temp folder on the Composer system.

4. Open Composer and go to File > Import > General > Existing Projects into Workspace.

5. Choose Select archive file and then select the email strategy you copied from the Core VM.
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Important: Select the project from the newly populated list, ensuring Copy projects into
workspace is enabled, and click Finish.

6. Verify that the local Tomcat server details are correct for your Composer installation:
* Got to Window > Preferences > Composer > Tomcat.
* Enter the Port, Login (admin), and Password (admin).

* Check the Tomcat Location to confirm that it is on the local disk (for example, c:\Program Files
(x86)\GCTI\Composer 8.1\tomcat).

7. In Composer Package Explorer, expand the GenesysOne_Email package, right-click Interaction
Processes > Email ixnprocess, and select Publish to Configuration Server (you might first need
to connect to Configuration Server from the Composer menu bar).

8. If you are localizing your environment:

* In Project Explorer, open GenesysOne_Email > Workflows >
RouteToAgentWithAutoResponse.workflow.

* For each of the three Create Email blocks (SendOutOfOfficeHours, SendSpecialDay,
SendOfficeHours):

¢ Click the block and open its Properties view.

¢ Click Message Settings > Standard Response.

¢ Replace the English text (such as 0fficeHours) with the localized text.
* Save and generate the code.

9. Right-click the package name and select Properties. Deploy the project.
10. Create a war file:

* Right-click the package name and select Export > Composer > Java Composer Project as WAR
file.

11. Copy the war file to \\gl-core-p\c$\GCTN\apache-tomcat\webapps. The war file automatically
extracts to a new GenesysOne_Email folder.

12. Point the new scripts to the correct core server:

* Open GA and go to Provisioning > Routing/eServices > Orchestration, which includes nine
enhanced routing scripts.

* Double-click GenesysOne_Email.Email.Entered.Routing and change the Orchestration URI to

include the correct core server name; for example, http://gl-core-p:8080/GenesysOne Email/
IPD Email Entered.scxml.

* Repeat for each of the other scripts.

13. If you are using Business Edition Premise version 8.1.100.20, restart Orchestration Server. If you are
using a later version, you do not have to complete this step.

Configuration

Business Edition Premise routing configuration occurs at two levels:
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« |nitial configuration, which involves the setup of auto-attendant menus, business rules, and other
configuration objects, requires a basic understanding of Genesys software, particularly Genesys
Administrator, SIP Server, and, for email, eServices Knowledge Manager.

¢ Administrative configuration, such as setting open hours and switching among auto-attendant menu
trees, is a subset of the initial configuration tasks and takes place entirely within Genesys Administrator
Extension (GAX). It requires no advanced knowledge of Genesys software.

You can configure different values for a number of routing parameters, such as open hours and call
priority. To handle different call flow and email scenarios, you use GAX to create parameter groups
based on the default parameter group templates supplied in Business Edition Premise.

Email solution definitions (SPDs)

Installation of the solution definitions (SPDs) automatically creates several
objects. Configuration Server objects created by previous voice or email
installations are not overwritten. [+] Show more info

The Email SPD creates these objects:

* Parameters
e Parameter group templates
e Parameter groups

¢ Transaction (Technical, Email Default)
The Email SPD creates these additional samples (object name in parentheses):

e Agent groups (AG_Email Sample, AG_Email Overflow_Sample, Email Supervisors)

* Business attributes (Disposition Code (Attributes), iWS_ToastUserData, iWS_UserData)
* Capacity Rule (GenesysOne_1Voice 1Email)

e Persons (AgentSample, SupervisorSample)

» SIP Switch Virtual queue (VQ_Default_email)

e Transactions (CategorylOverridelWS, Category2OverridelWS, Category3OverridelWs,
Category4OverridelWS, Category50verridelWS)

Initial configuration

Initial configuration of the email routing application depends on the needs of the customer. In many
cases, the defaults supplied in the solution definition will be sufficient.

You can adjust email routing parameters in either of two ways:

¢ To set new default values to be used in all new parameter groups that use the parameter, open Genesys
Administrator Extension, navigate to Operations > Parameters, and adjust values as desired. Do not
change Key Names.

¢ To set a new value that applies only to a specific parameter group, open Genesys Administrator
Extension, navigate to Operations > Parameter groups, and adjust values as desired.
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[+] Step 1. Configure screening rules

You can use the eServices Knowledge Manager application (on the Aux VM) to customize the
screening rules used to route email to any of the five Category parameter groups.

"Content screening", in the Overview section, explains how screening works in Business Edition
Premise.

"Screening Rules" in the eServices 8.1 User's Guide explains how to use the Screening Rule Editor
and details how the rules work.

[+] Step 2. Configure email acknowledgements

You can also use the eServices Knowledge Manager application to customize the text of the
acknowledgement emails: Email acknowledgement body open hours, Email
acknowledgement body closed hours, and Email acknowledgement body special days, as
well as the opening (salutation), closing, and time zone.

"Using Categories and Standard Responses" in the eServices 8.1 User's Guide explains how to edit
the acknowledgement content.

[+] Step 3. Configure distribution

After you customize the screening rules, you can adjust their associated parameter groups to
distribute emails to the correct targets. If you added the term "sales" to the Category 3 screening
rule, for example, you can route emails with "sales" in their subject lines to a particular target agent
group by setting the Category 3 parameter group Email target value to the Sales agent group.

You can also enable or disable supervisor review, and change the percentage of emails subject to
review.

[+] Step 4. Set open hours and special days

The parameter Email open hours sets the standard hours that your office is open during the week.
Use the Email special day parameter to set:

* The dates or days of the week on which your office is closed for the entire day.

e The dates or days of the week on which your office is closed for only part of the day. In these cases, you
use the Time Ranges field in GAX to set the hours that you will be open on that date.

Specific dates set in Email open hours are treated as special days. Hours set for the same date or
day of the week in Email special day override those set in Email open hours; for example, if
Email open hours specifies that you are open from 9AM to noon on December 31, and Email
special day sets the hours of 11AM-2PM for the same date, people who send an email at 10AM on
that date receive the special day acknowledgement.
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Similarly, in both parameters, date patterns higher in the list take precedence over those lower in the
list.

[+] Step 5. Tune priorities
You can adjust the priority of emails using the two priority tuning parameters:

« Email priority sets the initial email priority; you typically have little reason to change the default of
100.

¢ Email overflow priority sets the priority of emails that exceed the Email target timeout. The
default value is also 100, which means that emails that have already passed the overflow timeout will
be re-queued based solely on their age, ensuring that the oldest emails will appear in the queue first.

[+] Step 6. Send a test email
To verify that Business Edition Premise is correctly receiving and routing emails, send a test email:

1. Install an email client and ensure that it connects to your email server.
2. Send an email to the address specified during the eServices SPD deployment.

3. Ensure that you have installed an IWS client (you did this when you were making a test call during the
voice routing configuration).

4. If Business Edition Premise is successfully installed, an IWS interaction window containing the email
appears when the email arrives.

[+] Step 7. Configure UCS database pruning

Genesys recommends that you configure automatic pruning of the Universal Contact Server (UCS)
database to prevent it from growing too large in size.

Changes made to the UCS database maintenance settings will apply to all deployed
media strategies (Voice, Email, Chat, and Outbound).

. On the Ul host, log in to Universal Contact Server Manager.
. Select the Scheduled task on Main DB tab.
. Configure the Main DB maintenance settings as desired.

. Click Save.

A W N -
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Operational Parameters

This section describes the operational parameters that are available for the email routing application.

Acknowledgements

For instructions on setting these parameters, see the Configuration tab.

Values (default in

= A
Parameter bold) Mandatory? Description
Sends customer an
acknowledgement
Email acknowledgement True, False Yes g?paélr;c;:i(r)wgti:twhether
you are open, closed, or
on a special day
Thank you for your
email. We will get
Email acknowledgement back to you as soon The body text used for
. Yes acknowledgements sent
body open hours as possible., text durina reaular hours
string entered in Value 9 reg
field
Thank you for your
email. We are
currently closed and
Email acknowledgement will get back to you Yes gslfntz)(\)/\(/jlz(;ce)éﬁnuesrfti ic;rnt
body closed hours as soon as possible. durin cIosged hours
Our office hours are:, 9
text string entered in
Value field
Thank you for your
email. We are
currently closed and
Email acknowledgement will get back to you Yes g?l?n?)?/vdlgc;egnfneti goernt
body special days as soon as possible. during s egial davs
Our office reopens on 9sp y
date, text string
entered in Value field
Email acknowledgement DIEETY R GENE, IBsethrfsslg’?t;Oethe
opening tvixltuset%llglgdentered n VEE beginning of the
acknowledgement
Email acknowledgement Regards, text string The closing term to the
closing entered in Value field ves customer at the end of
the acknowledgement
The time zone text that
. [nonel, free-form text . .
E_mall acknowledgement such as Central Time No you want to include in
time zone or GMT your email
acknowledgements.
Email from [nonel, email address No The email address

(typically DoNotReply)
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Parameter

Contact center status

For instructions on setting these parameters, see the Configuration tab.

Parameter

Email open hours

Email special day

Distribution

For instructions on setting these parameters, see the Configuration tab.

Parameter
Email screening

Email target

Email overflow target

Email target timeout

Email overflow target
timeout

Values (default in
bold)

Values (default in
bold)

From Monday to
Friday, 0800-2000,
closed Saturday and
Sunday, any value set
in the Value > Date
Pattern field

December 25,

January 1, any value
set in the Value > Date

Pattern field

Values (default in
bold)

True, False

[nonel, agent group

[nonel, agent group

3600, integer between
1 and 99999

86400 (24 hours),
integer between 1 and
99999

Yes

No

Yes

Yes

No

No

No

Mandatory?

Mandatory?

Mandatory?

Description

used in sending email
responses to customers

Description

Sets the hours that you
are open and accepting
emails; to specify open
hours on specific dates,
you must place the date
above all day-of-week
entries

A list of exceptions to
the regular open hours,
for a holiday or other
reason.

Description

Enables email screening
rules

The agent group that
first receives all emails

The agent group that
receives all emails that
exceed the overflow
target timeout

The length of time (in
seconds) that an email
can go unattended
before being passed to
the overflow agent

group

The length of time (in
seconds) that an email
can go unattended
before being passed to
the first available agent
group (either target or
overflow)
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Parameter
Email supervisor review

Email supervisor review
percentage

Email supervisor agent
group

Email default virtual
queue

Priority tuning

For instructions on setting these parameters, see the Configuration tab.

Parameter

Email priority

Email overflow priority

Values (default in
bold)

False, True

100, integer between 0
and 100

[nonel, agent group

VQ_Default_email, a
target virtual queue set
in GA

Values (default in
bold)

100, integer between 1
and 99999

100, integer between 1
and 99999

Yes

Yes

No

Yes

Yes

Yes

Mandatory?

Mandatory?

Description

Enables supervisor
review.

The percentage of
emails routed to
supervisors for review

The supervisor agent
group that receives the
emails when supervisor
review is enabled

The default virtual
queue to which all
emails are routed, for
reporting

Description

The initial priority
assigned to each
incoming email

The priority assigned to
all emails that exceed
the overflow target
timeout
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