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Business Edition Premise Provider's Guide
Business Edition Premise, originally known as Genesys One, is an all-in-one pre-installed packaging of
Genesys technology onto a set of virtual machines typically run on a single hypervisor server. It
includes a SIP Inbound solution, an optional Email solution, and real-time and historical reporting for
up to 300 contact center agents.

Business Edition Premise installation and initial configuration requires some knowledge of Genesys
software. The Business Edition Premise Guide documents the procedures needed to configure and
maintain an existing Business Edition Premise environment.

The "If you are new to Genesys software…" section below clarifies the expected roles of providers
and customers.

If you are new to Genesys software…
Business Edition Premise enables you to use the Genesys Administrator Extension interface to set
options (parameters) that tailor routing operations. Some of these options, such as declaring an
emergency or changing open hours, are easily set even if you have no prior experience configuring
Genesys software. Other options, such as auto-attendant (IVR) menus and business targets, are tied
to more complex features that must be synchronized with settings in other Genesys applications. We
suggest that customers rely on their Business Edition Premise provider to set up these features for
them. The provider can then show the customer what options they have customized, such as
business reporting categories (Service, Segment, and Department, for example) and announcements.
The Business Edition Premise Guide specifies the tasks that customers can complete without
assistance from their provider.

Business Edition Premise Provider's Guide
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Architecture

Business Edition Premise overview

The Business Edition Premise platform consists of a set of five virtual machines (VMs), installed on a
single Dell R720 or Dell R420 server running VMware ESXi 5.1.

After installation and initial configuration, the Business Edition Premise server is a basic Genesys 8
suite, which customers can extend with additional Genesys applications and functionality.

Virtual Machines

The five VMs play specific roles:

• Core VM includes core Genesys software components such as Framework, Routing, and SIP Server, as
well as the PostgreSQL configuration database

• DB VM includes MS SQL Server, Genesys DB Servers, Genesys InfoMart, and RAA
• GVP VM includes Voice Platform components such as Media Control Platform and Resource Manager
• UI VM includes user interfaces such as Genesys Administrator and Genesys Administrator Extension,

IWS, EZPulse, and GI2
• Aux VM includes some Genesys Framework components (LCA/GDA), 3rd party components (Apache

Tomcat), and room for additional packages such as eServices (required for email functionality)

User interfaces

The table lists the key components used to control settings and reports. The component name links

Architecture
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to its documentation home page.

Component Role
Genesys Administrator User and extension configuration
Genesys Administrator Extension Routing configuration
Interaction Workspace UI for agents and supervisors
Universal Contact Server Manager Email contact management

Composer Email deployment (and potential customization of
voice and email routing)

Knowledge Manager Email configuration
Genesys Interactive Insights Historical reporting
Pulse (also known as EZPulse) Real-time reporting

Architecture
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Components
The table below lists the pre-installed components (or included IP Packages) that contribute to the
Business Edition Premise solution. To view the supported version numbers (available after the virtual
machines are deployed and tuned up), open a browser to http://Core VM name or IP address.

Component Name Release Note
Composer Composer 8.1.x Release Note
Configuration Conversion Wizard Framework 8.1.x Wizard Advisory
Configuration Import Wizard Framework 8.1.x Wizard Advisory
Configuration Manager Configuration Manager 8.1.x Release Note
Configuration Server ST Configuration Server 8.1.x Release Note
DB Server DB Server 8.1.x Release Note
Genesys Pulse (formerly EZPulse) Genesys Pulse 8.1.x Release Note
Genesys Pulse Collector (formerly EZPulse
Collector) Genesys Pulse Collector 8.1.x Release Note

eServices MCR Classification Server Classification Server 8.1.x Release Note
eServices MCR E-Mail Server Java E-mail Server 8.1.x Release Note
eServices MCR Interaction Server Interaction Server 8.1.x Release Note
eServices MCR Java Environment and Libraries for
eServices and UCS

Java Environment and Libraries for eServices and
UCS 8.1.x Release Note

eServices MCR Knowledge Manager Knowledge Manager 8.1.x Release Note
eServices MCR Universal Contact Server Universal Contact Server 8.1.x Release Note

eServices MCR Universal Contact Server Manager Universal Contact Server Manager 8.1.x Release
Note

eServices Plugin for GAX
Restricted release; the release documentation is
available from the installation package or through
ftp.

Flex LM (License Manager) -
Genesys Administrator Genesys Administrator 8.1.x Release Note

Genesys Administrator Extension Genesys Administrator Extension 8.1.x Release
Note

Genesys Info Mart Genesys Info Mart 8.1.x Release Note

Genesys Info Mart Administration Console Genesys Info Mart Administration Console 8.1.x
Release Note

Genesys Interactive Insights Genesys Interactive Insights 8.1.x Release Note
Genesys Voice Platform Media Control Platform
(MCP) Voice Platform Media Control Platform 8.1.x

Genesys Voice Platform Resource Manager (RM) Voice Platform Resource Manager 8.1.x
Interaction Concentrator Interaction Concentrator 8.1.x Release Note

Architecture Components
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Interaction Workspace Interaction Workspace 8.1.x
Interaction Workspace SIP Endpoint Interaction Workspace 8.1.x
Local Control Agent Local Control Agent 8.1.x
Message Server Message Server 8.1.x Release Note
Orchestration Server (ORS) Orchestration Server 8.1.x Release Note
SIP Server SIP Server 8.1.x
SNMP Master Agent SNMP Master Agent 8.1.x Release Note
Solution Control Server Solution Control Server 8.1.x Release Note
Stat Server Stat Server 8.1.x Release Note
Universal Routing Server Universal Routing Server 8.1.x

Business Edition Premise and its components use these third-party components:

• Apache Tomcat
• Apache Cassandra
• Eclipse
• Java SE
• MS SQL Server 2008
• MS SQL Server JDBC Driver
• Postgre SQL
• VMware vSphere

Architecture Components
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Voice routing overview

Inbound routing

The Business Edition Premise voice routing application provides essential inbound call center
functions using built-in strategies:

• Entry handling based on contact center status
• Auto-attendant (Interactive Voice Response) menus
• Call distribution based on agent availability and call priority

Entry handling

The application receives the incoming call, retrieves the dialed number (DNIS), and applies status
conditions to the call. Is the contact center closed, and if so, why?

• Is it a holiday? If so, the caller hears the Special Day announcement.
• Did the call come in outside of normal operating hours? If so, the caller hears the Closed

announcement.
• Is an emergency underway? If so, the caller hears the Emergency announcement.

If the contact center is open, the caller hears an announcement or the auto-attendant menu (if one

Voice routing overview Components
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exists), or the call passes directly to an agent.

Auto-attendant menus

If you have given the caller a menu of options (“Press 1 for Sales,” and so on), the call passes to the
Auto-attendant menu (DTMF) workflow, which specifies the action to be taken depending on the
caller’s menu choice. The Auto-attendant flow can cycle up to three times, to accommodate three
layers of routing. The Auto-Attendant Menus (DTMF) workflow, diagrammed below, acts as an
Interactive Voice Response tree to the customer. It plays a menu announcement configured in the
Inbound Template, and assigns a Distribution Parameter Group or an Inbound Parameter Group based
on the digit (touch tones) collected. For example: The announcement gives the customer three
choices (Press 1 for Customer Service, 2 for Sales, and 3 for Technical Support):

• Touch tone 1 = Customer Service (Distribution Template)
• Touch tone 2 = Sales (Distribution Template)
• Touch tone 3 = Tech Support at Route Point 6001 (the Inbound Template that matches the DNIS for the

Technical Support Route Point)

The auto-attendant flow can accommodate up to three cycles during a call. In the example above,
Touch tone 2 (Sales) might give the caller a second set of options: for Product A, press 1; for product
B, press 2, and so on. To learn how to build your menus, see Voice routing configuration.

Call distribution

The Distribution call flow distributes the call to an agent:

1. It collects statistics to determine what agents are logged in and available to take the call.
2. It routes the call to an agent from a target agent group: it first tries an agent from Target 1, then, in

sequence, tries Targets 2, 3, and 4 if it does not find an agent within the timeout set for that target.
Finally, if it does not find an agent from Targets 1-4 within the allotted time, it sends the call to the
overflow target, which can be a standard telephone number (such as 415-555-1212) or a routing point
(such as 6001). Note that Targets 2-4 are optional; routing skips any undefined targets.

The application plays queue music in a loop until the call is distributed to an agent or abandoned.

Redirect On No Answer (RONA): if the call has already been distributed to an agent who does not
answer, the Distribution flow distributes the call as if it had not been previously distributed, and sets
to Not Ready the status of the agent who did not answer.

Voice routing overview Components

Business Edition Premise Provider's Guide 9

https://docs.genesys.com/Documentation/IW/8.1.101/Dep/voiceroutconf


Email routing overview

Email routing

The Business Edition Premise email routing application can:

• Screen incoming email subject lines for recognized terms
• Enable supervisor review before the emailer receives an agent response
• Distribute the email to a target agent group
• Send an acknowledgement based on contact center status

Content screening

If you enable screening, the application scans the subject line of the email, looking for terms that
match those defined in the screening rules. If it finds a match, it uses the parameter values defined
in one of the five Category parameter groups.

For example, if the email subject includes the term "annoyed", and the Category2 screening rule
includes the term "annoyed", the application uses the Category2 parameter group values, such as
Email supervisor review=True and Email supervisor review percentage=100, meaning that a
supervisor will review every response to such an email.

If there is no match or screening is not enabled, the application assigns the default category.

Email routing overview Components
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Distribution

The screening rule also determines the target and overflow agent groups. If the email is not handled
by an agent from the Email target agent group within the Email target timeout (default is one hour),
the email is routed to the Email overflow target agent group. If the email is not handled by an agent
from the overflow target agent group within the Email overflow target timeout (default is one day),
the email returns either to the target agent group or to the overflow agent group, at a higher priority.

Acknowledgements

Like the voice routing application, the email application can send a different acknowledgement email
based on the status of the contact center: open, closed, or special day.

Email routing overview Components
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Known Issues and Corrections
<tabber>

General=

This tab includes known issues found in or affecting all versions of Business Edition Premise 8.1.101.
If you are using a localized version of BEP, the issues listed under the tab for your localized version
also apply.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

Incoming calls temporarily not routing

In rare cases under heavy load, Orchestration Server (ORS) can terminate unexpectedly, causing BEP
to stop processing inbound calls. The issue does not affect existing calls already being processed by
an agent, but all incoming calls are abandoned and those currently in queue are stuck on Media
Control Platform until the caller releases. (ORS-1393)

Found in: BEP 8.1.101.07

Workaround: None, but ORS restarts automatically.

eServices component shutdown through the eServices Solution can cause voice call
routing to stop

If you have deployed the email option in Business Edition Premise, any subsequent stoppage of
eServices using the eServices solution shuts down call routing due to the presence of shared
components in eServices and voice solutions. (ESHDP-153)

Workaround: Do not use the eServices solution to shut down eServices while voice call routing is
ongoing; to shut down eServices, shut down the individual eServices applications.

|-| English=

Latest version: 8.1.101.22

This tab includes known issues found in or affecting English (U.S.) versions of BEP. All issues under
the General tab also affect the English localization.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

ORS can quit unexpectedly

ORS can quit unexpectedly when disconnecting from the T-Server. (ORS-1496)

Known Issues and Corrections Components
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Found in: BEP 8.1.101.07 | Fixed in: BEP 8.1.101.22

Workaround: None, but ORS restarts automatically.

Genesys Administrator Extension displays incorrect time zone

The Genesys Administrator Extension application does not indicate the correct time zone for end time
of deployed solutions. (GAX-5422)

Found in: BEP 8.1.101.07

Workaround: None.

Special Day auto-response email does not display date

In a localized environment, the auto-response email sent to customers on a special day does not
include the correct reopening date. The email instead displays the following error message:

$Error: Cannot evaluate method (Date):
com.genesyslab.icc.util.stencil.expr.EvalException: ParseException (GRA-426)

Found in: Genesys Routing Applications 8.1.002.01 | Fixed in: Genesys Routing Applications
8.1.002.06

EZPulse Collector service is initially set to start-up type automatic

The EZPulse Collector service is initially set to start-up type automatic instead of manual. As a result,
the service is shown as running before tune-up script execution. (GENONE-1025)

Found in: BEP 8.1.100.20 | Fixed in: BEP 8.1.101.07

SS_Rep application has two option sections for logging

The SS_Rep application has two option sections, log and Log, while it should have just one.
(GENONE-1016)

Found in: BEP 8.1.100.20 | Fixed in: BEP 8.1.101.07

32-bit rather than 64-bit versions of MCP and RM installed

The 32-bit versions of the Media Control Platform and Resource Manager applications are installed
rather than the 64-bit versions. (GENONE-982)

Found in: BEP 8.1.100.20 | Fixed in: BEP 8.1.101.07

ORS not processing interactions received for email

After eServices is deployed in BEP, ORS does not process the interactions it receives for email until it

Known Issues and Corrections Components
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is restarted. (ORS-1445)

Found in: BEP 8.1.100.20 | Fixed in: BEP 8.1.101.07

Duplicate entries for logs created in Genesys Administrator

When creating a new application for Stat Server in Genesys Administrator using the wizard and
importing the templates and metadata, duplicate entries (log and Log) are created. (SS-5706)

Found in: BEP 8.1.100.20 | Fixed in: BEP 8.1.101.07

|-| French=

Latest version: 8.1.101.22

This tab includes known issues found in or affecting French (France) versions of BEP. All issues under
the General tab also affect the French (France) localization.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

ICON purge job does not complete

In the FRA localization (8.1.101.07), the nightly ICON database purge does not complete, causing the
ICON database to grow indefinitely. (GENONE-1074)

Found in: BEP 8.1.101.07 | Fixed in: BEP 8.1.101.10

Special Day auto-response email does not display date

In a localized environment, the auto-response email sent to customers on a special day does not
include the correct reopening date. The email instead displays the following error message:

$Error: Cannot evaluate method (Date):
com.genesyslab.icc.util.stencil.expr.EvalException: ParseException (GRA-426)

Found in: Genesys Routing Applications 8.1.002.01 | Fixed in: BEP 8.1.101.10

ORS can quit unexpectedly

ORS can quit unexpectedly when disconnecting from the T-Server. (ORS-1496)

Found in: BEP 8.1.101.10 | Fixed in: BEP 8.1.101.22

Workaround: None, but ORS restarts automatically.

Genesys Administrator Extension displays incorrect time zone

The Genesys Administrator Extension application does not indicate the correct time zone for end time

Known Issues and Corrections Components
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of deployed solutions. (GAX-5422)

Found in: BEP 8.1.101.10

Workaround: None.

MSSQL system databases use different collation than Genesys databases

The MSSQL system databases (master, tempdb) use a different collation than the Genesys
databases. (GENONE-1095)

Found in: BEP 8.1.101.10 | Fixed in: BEP 8.1.101.22

|-| German=

Latest version: 8.1.101.22

This tab includes known issues found in or affecting German versions of BEP. All issues under the
General tab also affect the German localization.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

ORS can quit unexpectedly

ORS can quit unexpectedly when disconnecting from the T-Server. (ORS-1496)

Found in: BEP 8.1.101.09 | Fixed in: BEP 8.1.101.22

Workaround: None, but ORS restarts automatically.

Genesys Administrator Extension displays incorrect time zone

The Genesys Administrator Extension application does not indicate the correct time zone for end time
of deployed solutions. (GAX-5422)

Found in: BEP 8.1.101.09

Workaround: None.

MSSQL system databases use different collation than Genesys databases

The MSSQL system databases (master, tempdb) use a different collation than the Genesys
databases. (GENONE-1095)

Found in: BEP 8.1.101.09 | Fixed in: BEP 8.1.101.22

|-| Spanish=

Known Issues and Corrections Components
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Latest version: 8.1.101.22

This tab includes known issues found in or affecting Spanish versions of BEP. All issues under the
General tab also affect the Spanish localization.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

ORS can quit unexpectedly

ORS can quit unexpectedly when disconnecting from the T-Server. (ORS-1496)

Found in: BEP 8.1.101.12 | Fixed in: BEP 8.1.101.22

Workaround: None, but ORS restarts automatically.

Genesys Administrator Extension displays incorrect time zone

The Genesys Administrator Extension application does not indicate the correct time zone for end time
of deployed solutions. (GAX-5422)

Found in: BEP 8.1.101.12

Workaround: None.

|-| Portuguese=

Latest version: 8.1.101.22

This tab includes known issues found in or affecting Portuguese (Brazil) versions of BEP. All issues
under the General tab also affect the Portuguese (Brazil) localization.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

ORS can quit unexpectedly

ORS can quit unexpectedly when disconnecting from the T-Server. (ORS-1496)

Found in: BEP 8.1.101.13 | Fixed in: BEP 8.1.101.22

Workaround: None, but ORS restarts automatically.

Genesys Administrator Extension displays incorrect time zone

The Genesys Administrator Extension application does not indicate the correct time zone for end time
of deployed solutions. (GAX-5422)

Found in: BEP 8.1.101.13

Known Issues and Corrections Components
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Workaround: None.

|-| Japanese=

Latest version: 8.1.101.22

This tab includes known issues found in or affecting Japanese versions of BEP. All issues under the
General tab also affect the Japanese localization.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

GI2 Language Pack is available for Japanese locales

The GI2 Language Pack is available at http://g1-core-p/ips, in the following file format:
gi2-lp-<version>-<locale>.zip. To select a Language Pack, login to CMC as an Administrator, go to
Preferences, and select the appropriate Product Locale. (GENONE-1175)

Interaction Workspace does not support spelling-checks for Japanese

The BEP documentation should mention how to add or create IWS spell-checkers for Japanese and
Simplified Chinese locales. (GENONE-1130)

Found in: BEP 8.1.101.22

Workaround: If you are using the Japanese version of BEP, Genesys recommends that you create your
own dictionary for IWS spelling-checks. For instructions on how to do this, see the Interaction
Workspace documentation, specifically the Spelling tab on the Handling Interactions page.

Composer Help must be manually switched to Japanese

After installing BEP for Japanese locales, users must manually switch Composer Help to Japanese.

Found in: BEP 8.1.101.19

Workaround: To switch Composer Help to Japanese, do the following:

1. Launch Composer.
2. Select Main Menu > Edit > Preferences.
3. Select Composer > Help
4. In the Online Wiki URL edit box, enter the following value:

http://docs.genesys.com/wiki/index.php?title=Special:ComposerHelp&keyword=
{keyword}&locale=ja-JP&version={version}

5. Click OK.

Genesys Administrator Extension displays incorrect time zone
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The Genesys Administrator Extension application does not indicate the correct time zone for end time
of deployed solutions. (GAX-5422)

Found in: BEP 8.1.101.19

Workaround: None.

Multibyte Character Sets (MBCS) appear as squares in charts associated with GI2 reports

Multibyte Character Sets in charts associated with GI2 reports can appear as squares.
(GENONE-1128)

Found in: BEP 8.1.101.19

Workaround: You can modify the default display font of the report charts by changing the Web
Intelligence default view format to interactive and then selecting the appropriate font. For more
information about Web Intelligence, see the Business Objects documentation.

ORS can quit unexpectedly

ORS can quit unexpectedly when disconnecting from the T-Server. (ORS-1496)

Found in: BEP 8.1.101.19 | Fixed in: BEP 8.1.101.22

Workaround: None, but ORS restarts automatically.

ORS runs out of memory after one hour of traffic in a 7x24 environment

The ORS application runs out of memory in a 7x24 environment after one hour of traffic. (ORS-1610)

Found in: BEP 8.1.101.19 | Fixed in: BEP 8.1.101.22

|-| Chinese=

Latest version: 8.1.101.22

This tab includes known issues found in or affecting Chinese versions of BEP. All issues under the
General tab also affect the Chinese localization.

To view known issues in BEP components, click the links in the Release Note column of the
Components topic.

GI2 Language Pack is available for Simplified Chinese locales

The GI2 Language Pack is available at http://g1-core-p/ips, in the following file format:
gi2-lp-<version>-<locale>.zip. To select a Language Pack, login to CMC as an Administrator, go to
Preferences, and select the appropriate Product Locale. (GENONE-1175)

Interaction Workspace does not support spelling-checks for Simplified Chinese
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The BEP documentation should mention how to add or create IWS spell-checkers for Japanese and
Simplified Chinese locales. (GENONE-1130)

Found in: BEP 8.1.101.22

Workaround: If you are using the Simplified Chinese version of BEP, Genesys recommends that you
create your own dictionary for IWS spelling-checks. For instructions on how to do this, see the
Interaction Workspace documentation, specifically the Spelling tab on the Handling Interactions page.

Genesys Administrator Extension displays incorrect time zone

The Genesys Administrator Extension application does not indicate the correct time zone for end time
of deployed solutions. (GAX-5422)

Found in: BEP 8.1.101.19

Workaround: None.

Multibyte Character Sets (MBCS) appear as squares in charts associated with GI2 reports

Multibyte Character Sets in charts associated with GI2 reports can appear as squares.
(GENONE-1128)

Found in: BEP 8.1.101.19

Workaround: You can modify the default display font of the report charts by changing the Web
Intelligence default view format to interactive and then selecting the appropriate font. For more
information about Web Intelligence, see the Business Objects documentation.

ORS can quit unexpectedly

ORS can quit unexpectedly when disconnecting from the T-Server. (ORS-1496)

Found in: BEP 8.1.101.19 | Fixed in: BEP 8.1.101.22

Workaround: None, but ORS restarts automatically.

ORS runs out of memory after one hour of traffic in a 7x24 environment

The ORS application runs out of memory in a 7x24 environment after one hour of traffic. (ORS-1610)

Found in: BEP 8.1.101.19 | Fixed in: BEP 8.1.101.22
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Installing Business Edition Premise
Business Edition Premise typically comes pre-installed on a server; if you have already received the
server, you can skip these topics and start with deployment of the routing applications. You can,
however, procure the required server and install Business Edition Premise on it yourself, as detailed
in these topics.

Next: Off-site installation.

Installing Business Edition Premise Components
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Off-site installation
This topic describes the steps required to install Business Edition Premise on a server before it is
delivered to the customer site. After you successfully complete these steps, the off-site portion of the
Business Edition Premise installation is complete and you can proceed to the on-site portion of the
installation, to be performed at the customer site.

<multistep> Procure the required hardware=

Hardware requirements
The hardware required to run Business Edition Premise depends on the number of agents in the
contact center.

100 to 300 agents

Requirement Minimum configuration
Server type Dell PowerEdge R720 or Genesys BEP300

Processor Intel Xeon E5-2665 2.40 GHz, 20 M Cache, 8.0 GT/s
QPI, Turbo, 8 C, 115 W, Max Mem 1600 MHz

Additional processor Intel Xeon E5-2665 2.40 GHz, 20 M Cache, 8.0 GT/s
QPI, Turbo, 8 C, 115 W

Memory (RAM) 96 GB
Controller PERC H710P 1 GB RAID Controller

Hard drives 7x300 GB 15 K SAS disks: 6 disks for RAID5 + 1 hot
spare; 2.5 inch drive chassis

Guest Operating System Microsoft Windows 2008 Server R2
Hypervisor Operating System ESXi 5.1

Fewer than 100 agents

Requirement Minimum configuration
Server type Dell PowerEdge R420 or Genesys BEP100

Processor Intel Xeon E5-2470 2.30 GHz, 20 M Cache, 8.0 GT/s
QPI, Turbo, 8 C, 95 W, Max Mem 1600 MHz

Additional processor Intel Xeon E5-2470 2.30 GHz, 20 M Cache, 8.0 GT/s
QPI, Turbo, 8 C, 95 W

Memory (RAM) 48 GB
Controller PERC H710P 1 GB RAID Controller

Hard drives 7x300 GB 15 K SAS disks: 6 disks for RAID5 + 1 hot
spare; 2.5 inch drive chassis

Guest Operating System Microsoft Windows 2008 Server R2
Hypervisor Operating System ESXi 5.1

Installing Business Edition Premise Off-site installation
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|-| Provision the network= Provision the network to include:

• One IP address within a management control subnet for Dell iDRAC setup and configuration.
• One IP address within the same subnet and available on a Windows domain running DNS/DHCP services

for ESXi5.1 server.

|-| Set up the server hardware and iDRAC=

1. Perform the initial hardware setup of the server:
• Connect a network cable to the iDRAC internal management board.
• Connect a network cable to port 1 of the main Ethernet board (integrated with the motherboard).
• Connect the power cable.
• Directly attach a monitor, keyboard, and mouse.

2. Power-on the server by pressing the power button on the front of the console.
3. After the Dell Lifecycle Controller completes the system inventory and displays the Settings –

Language and Keyboard screen, do the following:
• Select Next to accept the defaults for Language and Keyboard Type (English/United States).
• On the Network Settings screen, select DHCP from the IP Address Source drop-down list and

click Finish.

4. Configure the server for remote access using the iDRAC management board:
• Go to Hardware Configuration > Configuration Wizards > iDRAC settings > Network.
• Record the MAC Address displayed under Network Settings (this is required for an upcoming

step).
• In the IPV4 Settings section, set Enable DHCP and Use DHCP to obtain DNS server

addresses to Enabled.
• In the IPMI Settings section, set Enable IPMI Over LAN to Enabled.
• Click Back.
• Click Finish and select Yes to save the changes.
• Click System Time and Date Configuration.
• Set Time to the current local time.
• Click Finish and then click Back to exit the Configuration Wizard.
• Go to System Setup > Advanced Hardware Configuration > System BIOS > System Profile

Settings.
• From the System Profile drop-down menu, select Performance.
• Click Back.
• Click Finish and select Yes to save the changes.

5. Update DHCP and DNS for the iDRAC management board:
• Enter the MAC address you recorded earlier into the DHCP server configuration and restart the DHCP

service.
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• Update the DNS server with the iDRAC hostname and IP address.
• You can access the system using iDRAC by entering the following URL into a browser:

https://<hostname or ip address>/login.html

The default iDRAC username and password are as follows:

Username: root

Password: calvin

For more information about iDRAC, see the Dell Owner's Manual for your R720 or R420, particularly
the section "iDRAC Settings Utility", and also the iDRAC7 User's Guide available at Dell product
support.

|-| Obtain licenses= Obtain the following licenses:

• One Microsoft SQL Server 2008 R2 64-bit license with 50 client access licenses required for internal
access of server components.

Important: This license to be applied on the Premise site.

• Three Microsoft Windows Server 2008 R2 64-bit licenses with the appropriate number of client access
licenses.

Important: These licenses to be applied on the Premise site.

• One VMware vSphere Server ESXi 5.1 license.
• Alternatively, you can purchase the BEP Operations pack from Genesys, which contains appropriate

licenses from Microsoft without the need for client access licenses.
• One Genesys software license for 100 or 300 agents.

Important: The MAC address information required for this license is obtained from the core VM
during server configuration.

|-| Configure the server=

Important
The creation of a root password for the ESXi server and the configuration of additional
user accounts is at the discretion of the party performing the installation.

Configure the Dell or Genesys server by completing the following steps:

1. Configure the RAID array:
• Press <CTRL> + <R> during POST to enter the RAID Configuration Utility.
• Confirm that RAID is configured as RAID 5 with a single hot spare drive.
• Enable RAID controller caching.
• Under the Advanced Settings menu for the virtual disk, set the write policy to write-back and the

read policy to read-through.

2. Modify the boot sequence for the server:
• Press F2 during POST to enter the system BIOS.
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• From the BIOS menu, select System Setup Main Menu > System BIOS > Boot Settings > Bios
Boot Settings > Hard-Disk Drive Sequence.

• Move Integrated RAID Controller 1:PERC H710P Mini(bus 01 dev 00) to the top of the list.

3. Install VMware vSphere 5.1 Standard ESXi Server, using the license you procured. Give the server a
unique name such as bep_location.

See VMware vSphere ESXi and vCenter Server 5.1 Documentation (open in a new window or tab).

4. If you are installing the VMs off-site, you must perform the following steps, which you will need to repeat
at the customer site (see On-site installation):
• Power on the ESXi server and retrieve its MAC address (for setup in a DHCP server to assign an IP

address and in a DNS server so the host name of the ESXi server can be associated to the assigned
IP address when first connected to the network):
• Open the ESXi console for your ESXi server and go to <F2> Customize System/View Logs >

Configure Management Network > Network Adapters/<D> View Details.
• Copy the MAC address.
• Log into the DHCP server.
• In the Command window, configure the MAC address with the assigned IP address for the ESXi

server.
• Restart the DHCP server.

|-| Obtain the templates= Obtain the five OVA VM templates for importing into the ESXi Server (from
either a network drive on the same subnet as the ESXi Server or from a Genesys-supplied hard drive).
|-| Install a VMware vSphere 5.1 Client= Install a VMware vSphere 5.1 Client on any Windows
workstation that has network connectivity to the ESXi Server.

Important
The ESXi server must be powered on.

1. Open a browser and enter the IP address assigned to the ESXi server.
The VMware ESXi Welcome page appears.

2. Click the download link for the VMware Sphere client to download and install.

For more information, see the VMware vSphere ESXi and vCenter Server 5.1 Documentation (open in
a new window or tab). |-| Deploy the VMs=

1. To deploy the VMs onto the ESXi server, log in to the vSphere Client workstation as a user with ESXi
administrator rights.

2. Open the vSphere client and deploy the five VMs: aux, core, db, gvp, ui.
The VM names use the format VM role-platform-product version-language code; for example,
g1-core-p-win2008r2std_sp1-8110020-enus. Important: Do not change the format.

Dell R420 or Genesys BEP100 memory allocation: The default memory allocation for each VM
applies to the Dell R720 or Genesys BEP300 and its 96GB of total memory. If you are installing the
VMs on a Dell R420 or Genesys BEP100, you must open each VM Properties window and adjust the
memory and processor allocation for each VM:
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VM Memory Processors
Aux 4 GB 4
Core 6 GB 4
DB 6 GB 4
GVP 4 GB 4
UI 4 GB 4

|-| Enable VM restoration= To enable restoration of the VMs in case problems arise, you can take a
snapshot of each VM in its current state. To take a snapshot, do the following for each deployed VM:

1. Right-click on the VM and select Snapshot.
2. From the Snapshot menu, select Take Snapshot.
3. In the Take Virtual Machine Snapshot window, enter a name and description for the snapshot.
4. Click Ok.

For more information about snapshots, see Using Snapshots To Manage Virtual Machines in the
VMware in VMware vSphere ESXi and vCenter Server 5.1 Documentation (open in a new window or
tab). |-| Confirm that the VMs start= Power on each VM and confirm that the VM starts by opening its
Console window and verifying that the Set Up Windows screen is visible. Once confirmed, power off
the VM.

Important: Do not proceed with the Set Up Windows steps unless the server is located at the
customer site.

Tip
Although the tune-up script starts automatically on the VM after you log in, you can
select to postpone the tune-up procedure until the next restart of the VM. To do so,
select No when the script asks "Would you like to do the tune-up now?" The script
automatically starts when the VM restarts at the customer site, and continues to run
during each restart until it completes successfully.

|-| Off-site verification checklist= This step confirms that the off-site portion of the installation is
complete and that the server is ready for delivery to the Premise site.

1. Login to iDRAC and confirm the following:
• Verify a RAID 5 configuration (6 disks plus 1 hot spare).
• Verify that the storage controller card is model H710P.
• Confirm that disk sizes are 300 GB, 15K, SAS.

2. Connect to the ESXi server with a vSphere client and confirm that all five VMs are deployed and able to
start.
• Verify that the ESXi server has all CPUs (>= 16 CPUs) and RAM (96 GB)
• Verify that the five VMS are present (aux, core, db, gvp, ui), with snapshots for each.
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• The MAC address for the g1-core-p VM is obtainable (used for ordering appropriate Genesys
licenses).

• If your deployment is a Dell 420 or BEP 100 (100 agents), the memory and CPU for VMs must be
adjusted according to the table shown in the step for deploying the VMs.

• Verify that all VMs are the same version. If you deployed the VMs according to the steps described in
this documentation, the version is included in the name of the VM.

</multistep> Next: On-site installation.
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On-site installation

Important
The following steps must occur at the customer site, as they require specific customer
network information.

<multistep> Required licenses=

Important
You require the following licenses before installing Business Edition Premise. If you do
not have all required licenses, do not proceed with the installation steps.

• Three Windows Server 2008 license keys for activating Windows when starting each VM.
• One Genesys software license for either 100 or 300 agents.
• One Business Objects Enterprise (BOE) version 3.1 license key.
• One Microsoft SQL Server 2008 R2 64-bit license with 50 client access.

|-| Provision the network= Provision the network to include:

• Five IP addresses within a single subnet and available on the Windows domain running DNS/DHCP
services for the Virtual Machines (VMs); you also need to assign five hostnames for the VMs for entry
into a DNS server

• One IP address within a management control subnet for Dell iDRAC configuration, to enable hardware
alarming via email (the address must be able to access the customer corporate email server)

• One IP address within the same subnet and available on a Windows domain running DNS/DHCP services
for ESXi 5.1 server.

|-| Set up hardware monitoring= Your Dell server includes an Integrated Dell Remote Access
Controller (iDRAC) that monitors the server hardware and can send email notifications to help you
avoid the data loss that will occur if two drives in the RAID array fail.

Warning
Failure to monitor the health of your RAID array can result in loss of data.
Ensure that you set up Dell hardware monitoring with email notification.

To configure the iDRAC to send email notifications:
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1. Ensure that you have configured your iDRAC. See the section "iDRAC Settings Utility" in the Dell Owner's
Manual for your R720 or R420.

2. Use a browser to log into the Dell iDRAC at https://IP address/login.html, where IP address is the
management interface IP address or DNS entry name. Enter the username and password that you
specified when configuring the iDRAC.

3. Navigate to Alerts > Alerts Filter. Ensure that only System Health, Storage, Warning, and Critical
are checked. Uncheck the other five items. Click Apply.

4. Under Alerts and Remote System Log Configuration, check the Email box in the heading for each
of the 8 pages.

5. Select the SNMP and E-Mail Settings tab. Under Destination E-mail Addresses, add up to four
addresses to receive alert emails. Check State for each address. Click Apply.

6. Under SMTP (E-Mail) Server Address Settings, enter the IP address or FQDN/DNS name of the
corporate email server (authentication is optional). Click Apply.

7. Under Destination E-mail Addresses, click Send to send an email alert to each of the configured
accounts.

8. Verify that each account received the test email.
9. Return to the Alerts tab. Enable alerts and click Apply.

|-| Configure the server=

1. Configure the external interfaces:
• Media Gateway/SBC: add network bandwidth and provision the network infrastructure
• Agent phones: add network bandwidth and provision the network and phones
• Organization email (if the customer selects the email option): provision the network
• Organization backend servers (optional): provision the network and security information

• Organization Network Management System (optional): provision the network and security
information

2. For the optional email package, set up an account for the ESJ server to connect with the corporate email
server to pick up incoming email.
• Meet network voice requirements:

• 50ms between particular endpoints
• MOS > 4
• R factor > 70
• network jitter < 40ms
• RTP packet loss 0

3. The customer is responsible for the following:
• Completing a backup of the system after installation
• Updating Genesys One credentials after installation
• Installing anti-virus software consistent with corporate guidelines (Genesys does not recommend

anti-virus software running on hosts with SIP RTP messaging as it can affect voice quality)
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• Enabling security policies/firewall per corporate guidelines
• Installing updates
• Being aware that FTC regulations may require that Outbound Contact Server (OCS) audit logs be

stored for up to 24 months. Due to storage limitations, the log zip utility on the Core VM is
configured to only retain these logs for a maximum of 60 days. Customers must move these logs to
external storage before the 60-day expiration.

|-| Update DHCP and DNS servers for ESXi= Power on the ESXi server (if needed) and retrieve its MAC
address (for setup in a DHCP server to assign an IP address and in a DNS server so the host name of
the ESXi server can be associated to the assigned IP address when first connected to the network):

1. Open the ESXi console for your ESXi server and go to <F2> Customize System/View Logs >
Configure Management Network > Network Adapters/<D> View Details. Copy the MAC
address.

2. Log into the customer DHCP server. In the Command window, replace the existing MAC address for the
ESXi server.

3. Restart the DHCP server.
4. Update the customer DNS server with new host name of the ESXi server and the IP address assigned

from the customer pool of addresses and given out by their DHCP server.

|-| Update DHCP and DNS servers for VMs= Before you power on the VMs, retrieve their MAC
addresses (from VM properties) to populate the DHCP server and update the DNS server:

1. In the vSphere Client inventory, right-click each virtual machine and select Edit Settings > Network
adapter 1 to view its MAC address. Copy each address.

2. Log into the DHCP server. In the Command window, replace the existing MAC address for each VM.
3. Restart the DHCP server.
4. Update the customer DNS server with the new host names of the VM servers and the IP addresses

assigned from the customer pool of addresses and given out by their DHCP server.

|-| Configure NTP to synchronize VMs= Configure an NTP (network time) daemon to synchronize the
customer VMs.

1. In the vSphere Client, select the ESXi server, and then select the Configuration tab.
2. From the Software menu, click Time Configuration and select Properties.
3. Select NTP Client Enabled and then click Options. The NTP Daemon (ntpd) Options window

opens.
4. In the NTP Daemon Options window, do the following steps:

• Under General, select Start and stop with host.
• Under NTP Settings, add an NTP Server in the customer time zone (the NTP Server website lists

available NTP servers) and select Restart NTP service to apply changes.
• Click OK.

5. Click OK again to close the Time Configuration window.

|-| Power on the Core VM=
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1. Power on the Core VM (this step must take place before you power on any of the other VMs).
2. In Windows setup, enter the locale and product key, accept the license terms, and change the

password. (For localized versions, you must first select a language before proceeding with Windows
setup.)

3. Confirm that the dialog for changing the user password at the first login appears. The Windows desktop
loads and the tuneup script automatically runs.

|-| Configure the VM using the tuneup script=

1. After the tuneup script launches automatically, enter values when prompted:
• Host naming scheme:

• Select 1 to use default host names (g1-core-p, g1-ui-p, g1-db-p, g1-aux-p, g1-gvp-p).
Use this option for environments that you do not plan to extend and if the default naming
convention suits your needs.

• Select 2 to use default host names with custom suffixes (such as g1-core-p-env1). The script
prompts you for the suffix. Use this option if default names with suffixes agree with your host
naming convention. Important: The suffix can contain no more than 4 characters.

• Select 3 to use custom names for each host (such as newyork-core and newyork-ui). The script
prompts you for each name, which should identify the role of the host (core, ui, db, aux, or gvp).
Use this option if you need to conform to a customer naming convention. Important: Each host
name can contain no more than 15 characters.

• Domain configuration (this setting defines how the FQDN of the hosts is presented in Genesys
Configuration; Genesys software uses these names when establishing network connections):
• Select 1 to have the tuneup script use the domain name that it detects automatically.
• Select 2 (Other domain name) to enter the domain name manually. When prompted, enter the

domain name.
• Select 3 if your environment does not require a domain name.

• Rename? Yes
• Reboot? Yes

Important: Ensure that the Core VM fully restarts before you proceed.

To verify that the IP address is correct, run the Windows command ipconfig/all. If the host received
proper IP configuration from your DHCP Server, the values will match your network settings.

To verify that the server can reach the remote host, ping an external server (such as a server you
plan to use for your agent desktops) by running the command ping remote host name or IP
address. The remote host must be reachable via ping and the output of the ping command looks
similar to this example (note the shortened output and sample IP addresses; ping times may vary):

Pinging agent-desktop.domain.com [1.2.3.4] with 32 bytes of data:

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Reply from 1.2.3.4: bytes=32 time<1ms TTL=128
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Reply from 1.2.3.4: bytes=32 time<1ms TTL=128

Ping statistics for 1.2.3.4:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms

From the remote host you just pinged, open the console window and issue the following command:

ping Core VM name or IP address

The Core VM host must be reachable and the output of ping command must look similar to the
example in the previous substep.

Tip
If you enter incorrect information during the tuneup script configuration, Genesys
recommends that you redeploy the Core VM and begin the tuneup script configuration
again. If you made a snapshot of the Core VM prior to entering any data for the
tuneup configuration script, you can revert to that snapshot. This approach can also
be applied to the other VMs; however, if you redeploy the Core VM (or revert to a
snapshot), you must also redeploy the other VMs.

|-| Apply licenses and configuration changes= WATCH: To view a short demonstration of the license

application, click the Genesys icon below:

In the Initial Configuration Tasks window in the vSphere client on the Core VM:

1. Set the time zone in the format Continent/City or Region. For a list of time zones, see the TZ column in
List of tz database time zones.

2. Set up Genesys License Manager by placing the Flex LM license file (acquired earlier) in the GCTI\
flexlm folder.

Important
Altering the Windows Operating System Regional settings (other than time zone) may result in a failure when
attempting to apply the MS SQL Server 2008 license key at the completion of the BEP installation.
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3. To add the Microsoft SQL Server 2008 R2 64-bit license:
• Go to Start > All Programs > Microsoft SQL Server 2008 R2 > Configuration Tools > SQL

Server Installation Center (64-bit)
• Select Maintenance.
• Select Edition Upgrade, and click OK to begin the setup.
• Click Next through the Setup Support Rules.
• Enter the Product Key, and click Next.
• Accept the license terms, and click Next.
• Select the Instance, and click Next.
• Click Upgrade.

4. If your environment uses a domain, you can add it by doing the following:
• Click Provide computer name and domain.
• In the System Properties window, click Change.
• In the Computer Name/Domain Changes window, select Domain and enter the domain name.
• Click OK.

5. Reboot the VM.

|-| Verify the Genesys services=

1. Click Start.
2. To verify this step, enter Services in the Search programs and files dialog box.
3. Select Services and locate groups of services with names starting with Genesys in the list of local

services.
4. Check the status and startup type of these services. All Genesys services are in status Started, with

startup type Automatic.

|-| Enter Configuration Manager details=

1. On the console of the Core VM, click Start and select All programs > Genesys Solutions > Start
Configuration Manager.

2. In the dialog box, enter:
• User name: default
• Password: password
• Application: default
• Host name: localhost
• Port: 8888

Before proceeding to the next step, ensure that Configuration Manager starts and its main window
displays Environment and Resources objects. |-| Configure db, aux, and gvp VMs=
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1. Configure the db, aux, and gvp VMs, beginning with the db VM (do not configure the ui VM until the
next step):
• Power on each VM. In Windows setup, set the locale and the product key, accept the license terms,

and change the password. (For localized versions, you must first select a language before
proceeding with Windows setup.) To verify, use the same criteria as for the core server.

• The tuneup script automatically launches. When prompted:
• Enter the Primary Core Host IP address (do not use the host name).
• Enter Yes to rename and restart the VM. Ensure that each VM fully restarts before you proceed.

2. Configure the time zone settings:
• For DB VM only: The time zone is configured as part of the tuneup script. Set the time zone for

GIM in the format Continent/City or Region. For a list of time zones, see the TZ column in List of tz
database time zones.

• For all VMs: In the Initial Configuration Tasks window, click Set time zone. Configure the time
zone in the format Continent/City or Region. For a list of time zones, see the TZ column in List of tz
database time zones.

3. If your environment uses a domain, select Provide computer name and domain > Change and
enter the domain name.

4. In the Windows security window, enter the administrator ID and password.
5. Restart the VM.

|-| Configure ui VM=

1. Power on the ui VM. In Windows setup, set the locale and the product key, accept the license terms, and
change the password. To verify, use the same criteria as for the core server.

2. The UI tuneup script automatically launches. When prompted:
• Enter the Primary Core Host IP address.
• Enter Yes to rename and restart the VM.

3. The tuneup_boe.bat script launches automatically. Enter the BOE license code (which Genesys does
not provide).

4. Wait for the BOE tuneup script to finish and close (the script can take 30 minutes or more to complete).
5. In the Initial Configuration Tasks window, set the time zone in the format Continent/City or Region.

For a list of time zones, see the TZ column in List of tz database time zones.
6. If your environment uses a domain, select Provide computer name and domain > Change and

enter the domain name.
7. In the Windows security window, enter the administrator ID and password.
8. Restart the VM.

|-| Configure BOE for GI2=

Important
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This step is only required for Business Edition Premise version 8.1.100.20. If you have
a later version, you can skip this step.

1. To configure BOE for GI2, open the ui VM after the ui VM fully restarts for the second time.
2. Open Business Objects Universe Designer and log in with these credentials:

• System: your ui host name:6400
• User: administrator
• Password: G3n35y5
• Authentication: Enterprise

3. Create a connection, MSSQL 2008 > JDBC, that uses these values:
• Connection name: GI2-JDBC
• Username: sa
• Password: G3n35y5!
• Server host: your db host name:1433
• Database: gim_etl

4. Import Universe from the folder Interactive Insights > 8.1.1.
5. In the Universe Parameters window, specify the new GI2-JDBC connection.
6. Export the Universe.

|-| Backup the VMs= Genesys recommends that you backup the VMs by exporting them to an
external location or device.

1. Open the vSphere Client.
2. For each VM, do the following:

• Power off the VM.
• In the vSphere client, highlight the target VM and select File > Export > Export OVF Template.
• For the file format, select Single File (OVA).
• Specify the output file name and location.
• Export the file.

</multistep>

Next: Deploy the routing applications.
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Deploying the routing applications
To deploy the Business Edition Premise routing applications, you deploy the voice solution definition
and, optionally, the email solution definition in Genesys Administrator Extension (GAX). Solution
definitions are also known as solution package definitions, or SPDs.

The email routing application also requires you to deploy eServices applications, import Knowledge
Manager templates, and deploy the email strategy.

To deploy the routing applications, follow the procedures in Deploying the voice routing application
and, if applicable, Deploying the email routing application.
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Deploying the voice routing application

Important
You do not need to perform these steps if you are using Business Edition Premise
version 8.1.101.19 or later.

<multistep> Add Trusted Sites to Internet Explorer= To use Internet Explorer 10 to access Genesys
Administrator Extension or Genesys Administrator, you must add the following to the IE Trusted Sites:

• http://your UI VM domain

• about:blank

|-| Extract the zip file=

1. In a browser, go to http://Core VM name or IP address/ips.
2. Locate, download, and extract voice_strategy_ext_version.zip.

|-| Install the voice solution definition=

1. In a browser, open Genesys Administrator Extension (UI VM name or IP address:8080/gax), navigate
to Configuration > Solution Definitions, click +, and upload GenesysOne_OPM_Voice_ENU.xml
(which you just extracted).

2. Select Genesys One OPM Voice Parameters, select Install from the > menu next to the Delete
button (see the graphic below), and then complete the wizard, using default values except for:
• GAX host: your UI VM host name
• GAX user name: default
• GAX password: password
• Routing Stat Server Application: SS
• Switch: SIP_Switch
• Application Server Host: your Core VM host name
• Name for Inbound PG: 6000
• Name for Distribution PG: Dist_PG
• Number For RONA RP: 9990
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SPD installation

|-| Make a test call to the routing point=

1. In GA, set the SIPS TServer option enable-unknown-gateway to true. The deployment is successful if
the call connects and you hear an announcement (during closed hours) or queue music (during open
hours).

Important
After completing the verification process, restore the value to false. This secures the
SIP Server so that it only accepts calls from configured Trunk DNs within the
configuration environment.

</multistep>
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Deploying the email routing application
If you are not installing the email option, skip the following steps. <multistep> Deploy the eServices
applications for email=

1. In GAX, go to Configuration > Solution Definitions and click +.
2. Locate and upload the following file: \\g1-ui-p\c$\GCTI\eSrvcPluginGAX\spd\

eServicesSingleHostDeployment.xml
3. Select Genesys eServices Single Host Deployment.
4. From the > menu next to the Delete button, select Install, using default values except for:

• Uncheck Activate chat-media support
• DB Server for Interaction Server: DBServer_AUX
• DB Server for Interaction Concentrator: DBServer_ICON
• Database Administrator Name: sa
• Database Administrator Password: G3n35y5!
• Database User Name: sa
• Database User Password: G3n35y5!
• Set the customer Email Server Client Address, Email Server Domain Name, and Email Server POP

Client Login Password

|-| Install the email solution definition=

1. In GAX, go to Configuration > Solution Definitions and select Genesys One OPM Email
Parameters.

2. Complete the wizard, using default values except for:
• GAX host: UI host name
• Switch: eServices_Switch
• Email address: the Do Not Reply address that you select for the customer mail server
• Email Sample Configuration: True

|-| Import the Knowledge Manager templates= Important: Localized versions of the templates do
not include the required categories, so even for localized environments you must import the
GenesysOne_KnowledgeManager_Rules_Responses_ENU.kme file.

1. In Genesys Administrator, ensure that the eServices solution is started.
2. Go to http://Core VM host name or IP address/ips and locate and download

email_strategy_ext_version.zip. Unzip the file.
3. On the Aux host, copy the GenesysOne_KnowledgeManager_Rules_Responses_ENU.kme file to a

temp folder on the local disk.
Important: If you are using Business Edition Premise version 8.1.100.20, this file is named
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GenesysOne_KnowledgeManager_Rules_Responses.kme.

4. Start Knowledge Manager
• Application: eServices_KnowledgeManager
• Host: your Core VM name

5. Go to File > Import and select the kme file from the temp folder.
Important:

• Uncheck Preserve uniqueness of objects
• Check Update screening rules.

Click OK and ignore the 5 warnings.

6. If you are localizing your environment, and only after first importing the English kme file, you can import
the localized kme files, one at a time (the example below uses the French version,
GenesysOne_KnowledgeManager_Rules_Responses_FRA.kme):
• On the Aux host, copy the GenesysOne_KnowledgeManager_Rules_Responses_FRA.kme file

(from the unzipped email_strategy_ext_version.zip file) to a temp folder on the local disk.
• Start Knowledge Manager

• Application: eServices_KnowledgeManager
• Host: your Core VM name

• Go to File > Import and select the kme file from the temp folder.
Important:

• Uncheck Preserve uniqueness of objects
• Check Update screening rules.

Click OK and ignore the 5 warnings.

7. If you are using Special Day Auto Responses in Email, you must manually change the Time Zones for
AutoResponse:
• Start Knowledge Manager.
• Click AutoResponse, and then double-click Special Day.
• Locate the two instances of TimeZone and replace them with the correct time zone IDs.

Important: You must use time zone database IDs to indicate time zones. For a list of time zone
database IDs, see http://en.wikipedia.org/wiki/List_of_tz_database_time_zones.

• Click Check field Codes to view the Special Day Auto Response with the field codes rendered.
• Click OK.

|-| Deploy the email strategy=

1. In a browser, go to http://Core VM name or IP address/ips. Locate, download, and extract the
following zip files:
• email_strategy_version.zip

• composer_version_enus.zip
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2. Install Composer 8.1.3 on a Windows system that is not one of the VMs and is not already running
Apache Tomcat (to avoid port conflicts). Follow the installation instructions in the Composer 8.1
Deployment Guide.

Note that Composer 8.1.3 is an Eclipse plugin that requires JDK 1.7 and a supported version of
Eclipse. Composer installs its own Apache Tomcat server.

3. Copy the GenesysOne_Email folder (from the email_strategy_ext_version zip that you just extracted)
to a temp folder on the Composer system.

4. Open Composer and go to File > Import > General > Existing Projects into Workspace.
5. Choose Select archive file and then select the email strategy you copied from the Core VM.

Important: Select the project from the newly populated list, ensuring Copy projects into
workspace is enabled, and click Finish.

6. Verify that the local Tomcat server details are correct for your Composer installation:
• Got to Window > Preferences > Composer > Tomcat.
• Enter the Port, Login (admin), and Password (admin).
• Check the Tomcat Location to confirm that it is on the local disk (for example, c:\Program Files

(x86)\GCTI\Composer 8.1\tomcat).

7. In Composer Package Explorer, expand the GenesysOne_Email package, right-click Interaction
Processes > Email ixnprocess, and select Publish to Configuration Server (you might first need
to connect to Configuration Server from the Composer menu bar).

8. If you are localizing your environment:
• In Project Explorer, open GenesysOne_Email > Workflows >

RouteToAgentWithAutoResponse.workflow.
• For each of the three Create Email blocks (SendOutOfOfficeHours, SendSpecialDay,

SendOfficeHours):
• Click the block and open its Properties view.
• Click Message Settings > Standard Response.
• Replace the English text (such as OfficeHours) with the localized text.

• Save and generate the code.

9. Right-click the package name and select Properties. Deploy the project.
10. Create a war file:

• Right-click the package name and select Export > Composer > Java Composer Project as WAR
file.

11. Copy the war file to \\g1-core-p\c$\GCTI\apache-tomcat\webapps. The war file automatically
extracts to a new GenesysOne_Email folder.

12. Point the new scripts to the correct core server:
• Open GA and go to Provisioning > Routing/eServices > Orchestration, which includes nine

enhanced routing scripts.
• Double-click GenesysOne_Email.Email.Entered.Routing and change the Orchestration URI to

include the correct core server name; for example, http://g1-core-p:8080/GenesysOne_Email/
IPD_Email_Entered.scxml.

• Repeat for each of the other scripts.
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13. If you are using Business Edition Premise version 8.1.100.20, restart Orchestration Server. If you are
using a later version, you do not have to complete this step.

</multistep> Next: Configure the routing applications to meet your customer's business
requirements.
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Configuring the routing applications
Business Edition Premise routing configuration occurs at two levels:

• Initial configuration, which involves the setup of auto-attendant menus, business rules, and other
configuration objects, requires a basic understanding of Genesys software, particularly Genesys
Administrator, SIP Server, and, for email, eServices Knowledge Manager.

• Administrative configuration, such as setting open hours and switching among auto-attendant menu
trees, is a subset of the initial configuration tasks and takes place entirely within Genesys Administrator
Extension (GAX). It requires no advanced knowledge of Genesys software.

You can configure different values for a number of routing parameters, such as open hours and call
priority. To handle different call flow and email scenarios, you use GAX to create parameter groups
based on the default parameter group templates supplied in Business Edition Premise.

What the routing solution definitions create

Installation of the solution definitions (SPDs) automatically creates several objects. Configuration
Server objects created by previous voice or email installations are not overwritten.

Voice
The Voice SPD creates these objects:

• Default personality
• Audio resources
• Parameters
• Parameter group templates
• Parameter groups

The Voice SPD also creates these samples (object name in parentheses):

• ACD Queues (9000)
• Action codes (Admin Work, Locked, Lunch, Meeting, Pause, RONA, Training)
• Agent groups (AG_Voice_Sample, AG_Voice_Skill_Sample)
• Agent Logins (1000)
• Business attributes
• DN Groups (All_ACDQueues, All_RoutePoints, All_VirtualQueues)
• Extensions (8000)
• Place Groups (All_Places)
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• Places (Place_SIP_8000)
• Route Point (selected during SPD installation)
• Skill (Skill_Sample)
• Virtual queue (VQ_Default_sample)

Email
The Email SPD creates these objects:

• Parameters
• Parameter group templates
• Parameter groups
• Transaction (Technical, Email Default)

The Email SPD creates these additional samples (object name in parentheses):

• Agent groups (AG_Email_Sample, AG_Email_Overflow_Sample, Email Supervisors)
• Business attributes (Disposition Code (Attributes), iWS_ToastUserData, iWS_UserData)
• Capacity Rule (GenesysOne_1Voice_1Email)
• Persons (AgentSample, SupervisorSample)
• SIP Switch Virtual queue (VQ_Default_email)
• Transactions (Category1OverrideIWS, Category2OverrideIWS, Category3OverrideIWS,

Category4OverrideIWS, Category5OverrideIWS)
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Configuring voice routing
Initial configuration of the voice routing application depends on the needs of the customer. In many
cases, the defaults supplied in the solution definition will be sufficient.

You can adjust voice routing parameters in either of two ways:

• To set new default values to be used in all new parameter groups that use the parameter, open Genesys
Administrator Extension, navigate to Operations > Parameters, and adjust values as desired. Do not
change Key Names.

• To set a new value that applies only to a specific parameter group, open Genesys Administrator
Extension, navigate to Operations > Parameter groups, and adjust values as desired.

<multistep> Define auto-attendant menus=

You can use parameter groups to build multiple sets of up to three cascading auto-attendant menus.
Keep in mind that you must record corresponding Auto attendant menu announcements for each set
you build.

To create a single set of three cascading menus:

1. Plan your menu set, because it is most efficient to begin by creating the third tier and its touch-
tone selections, then the second tier, then the first. Your plan will look something like the following
(the parameter group type is in parentheses):

8000 (Inbound)
1: Customer Service (Distribution)

1: Wondrous Product Line (Distribution)
2: Stupendous Product Line (Distribution)

2: Sales (Distribution)
1: North America (Distribution)
2: EMEA (Distribution)

3: Technical Support at routing point 6001 (Inbound)
1: Printers (Distribution)
2: Monitors (Distribution)
3: Mice (Distribution)

A customer having difficulty with their mouse calls the number that corresponds to routing point
8000, then presses 3 for Technical Support and 3 again for Mice. In this example, you create 11
parameter groups: 2 Inbound and 9 Distribution.

2. Deploy the third-tier parameter groups (in the example, Wondrous Product Line, Mice, and the
other 5). See below for help in setting the individual parameters.

3. Deploy the second-tier parameter groups. Add the third-tier groups as values for the Touch tone
parameters. In the example, you deploy the Sales parameter group, then assign the North America
group to Touch tone 1, and EMEA to Touch tone 2.
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Important
When you create an Inbound parameter group, the name of the parameter group
must be the same as the routing point that you want to handle these incoming calls
(in the example, the Technical Support group must be named 6001).

4. Deploy a parameter group based on the Inbound parameter group template. Add the second-tier
groups as values for the Touch tone parameters. In the example, you deploy the 8000 parameter
group, then assign the Customer Service group to Touch tone 1, Sales to Touch tone 2, and 6001 to
Touch tone 3. |-| Upload audio resources=

Note: To use Internet Explorer 10 to access Genesys Administrator Extension or Genesys
Administrator, you must add the following to the IE Trusted Sites:

• http://your UI VM domain

• about:blank

In GAX, for each audio resource, upload the corresponding audio (WAV) files:

Resource name Description
Announcement-Auto attendant menu Played when the auto attendant is enabled
Announcement-Closed Played when the service is closed
Announcement-Emergency Played when Emergency declared is activated
Announcement-Greeting 1 Played when Greeting 1 is enabled
Announcement-Greeting 2 Played after Greeting 1 when Greeting 2 is enabled
Announcement-Special day Played for a Special day
Music File Music played while the caller is in the queue

|-| Customize business attributes=

Your customer might require different Disposition Codes, which are the codes agents can select to
specify the outcome of an interaction. The default disposition codes are:

• Cross Sell
• Not Right Skill
• Terminated
• Transferred
• Up Sell

To modify these samples or create your own codes, in Genesys Administrator, navigate to
Provisioning > Routing > eServices > Business Attributes, and open the existing Disposition
Code Business Attribute.

Your customer might also require different reporting categories. The five default business parameters
(Service, Segment, Product, Department, and Flow) represent reporting categories and are
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completely customizable to your business model. You can assign different combinations of these
parameters to each of your Inbound and Distribution parameter groups, to distinguish them in
reporting and enable you to identify the unique properties of the parameter group. |-| Set open hours
and special days=

The parameter Open hours sets the standard hours that your office is open during the week. Use
the Special day parameter to set:

• The dates or days of the week on which your office is closed for the entire day.
• The dates or days of the week on which your office is closed for only part of the day. In these cases, you

use the Time Ranges field in GAX to set the hours that you will be open on that date.

Specific dates set in Open hours are treated as special days. Hours set for the same date in Special
day override those set in Open hours; for example, if Open hours specifies that you are open from
9AM to noon on December 31, and Special day sets the hours of 11AM-2PM for the same date,
callers who call at 10AM on that date hear the Closed announcement. Similarly, in both parameters,
date patterns higher in the list take precedence over those lower in the list.

5. Set targets and target timeouts.

Assign at least one target agent group for each parameter group. Change the timeout for each group
as needed (default is 300 seconds, or 5 minutes). You should also assign a Target overflow, which
serves as the "last resort" number to which a call is transferred when none of the other target agent
groups answers within their timeout.

6. Tune priorities.

You can adjust the priority of calls using the four priority tuning options. Over time, unanswered calls
receive higher and higher priority, ensuring that calls do not remain in the queue for excessive
lengths of time.

• Priority start sets the initial call priority; you typically have little reason to change the default of 1.
• Priority interval sets the number of seconds between priority increments. If you set the priority

interval to 60 seconds, for example, and the priority increment is 1, then after 5 minutes of wait time,
the call would have a priority level of 6, pushing it ahead of calls with priority values of 1-5.

• Priority Increment sets the number to add to the priority value each time the priority interval is
exceeded. As the priority levels are relative, a setting of 1 typically works.

• Priority limit sets the upper limit for priority increments; all calls at the maximum priority level receive
equal treatment.

|-| Verify call routing=

To verify that Business Edition Premise is correctly receiving and routing calls, make a test call to an
agent:

1. Ensure that you have:
• A soft phone such as SJPhone
• A sound-enabled Windows PC that can connect to the Core server

2. In GA, set the SIPS TServer option enable-unknown-gateway to true. Important: After completing
the verification process, restore the value to false.
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3. In GA, ensure that the user TestAgent belongs to the agent group AG_Voice_Sample.
4. In GAX, for parameter group 6000, ensure that:

• Greetings activated is True.
• Target 1 is AG_Voice_Sample.
• Open Hours includes the current time (or the call will not route to the agent).

5. Install the Interaction Workspace (IWS) client by navigating to http://UI VM name or IP
address/InteractionWorkspace/publish.htm and selecting Install or Launch.

6. Open IWS and log in using these credentials:
• User name: TestAgent
• Password: (none)
• Place: Place_1000
• Queue: 1004@SIP_Switch

Ensure that the agent can log in and set their status to ready.

7. Open a soft phone as any user. For Domain, enter the FQDN of the SIP Server. Uncheck Register with
domain.

8. Dial 6000. If the installation was successful, the call appears in IWS.

|-| Verify call reporting= To verify reporting, run a report in Interactive Insights (GI2):

1. In a browser, log into GI2 at http://UI VM name or IP address:9080/CmcApp/logon.faces
• User: administrator
• Password: G3n35y5

2. Go to Folders > Interactive Insights > 8.1.1 > Agents.
3. Run the report Agent Group Interaction Handling Report.
4. In the report list, click Refresh until status = success.
5. Open the report and click Instance Time. If the installation was successful, the call appears in the

report.
6. In GA, reset the TServer option enable-unknown-gateway to false.
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Operational parameters for voice routing
For each parameter group, enter a description in the Description field.

Audio and Announcements
For instructions on setting these parameters, see Upload audio resources.

Parameter Values (default in
bold) Mandatory? Description

Announcement-Closed Closed Annc, any valid
audio resource Yes

Audio Resource played
when the service is
closed

Announcement-Auto
attendant menu

Auto-attendant Menu
1, any valid audio
resource

Yes
Audio Resource played
when the auto
attendant is enabled

Announcement-
Emergency

Emergency Annc, any
valid audio resource Yes

Audio Resource played
when Emergency
declared is True

Announcement-Greeting
1

Greeting 1, any valid
audio resource Yes

Audio Resource played
when Greeting 1 is
enabled

Announcement-Greeting
2

Greeting 2, any valid
audio resource No

Audio Resource played
after Greeting 1 when
Greeting 2 is enabled

Announcement-Special
day

Special Day Annc, any
valid audio resource Yes Audio Resource played

for a special day

Greetings activated False, True Yes
Activates the Greeting 1
and, if enabled,
Greeting 2
announcements

Music File Music In Queue, any
valid audio resource Yes

Audio Resource for
music played while the
caller is in the queue

Personality
Default Personality,
other personality
defined in GAX

Yes The voice used in the
announcements

Auto-attendant menus
For instructions on setting these parameters, see Define auto-attendant menus.

Parameter Values (default in
bold) Mandatory? Description

Auto attendant menu
activated False, True Yes Activates an auto-

attendant menu (such
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Parameter Values (default in
bold) Mandatory? Description

as Press 1 for Sales) for
this parameter group

Touch tone 0 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 0

Touch tone 1 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 1

Touch tone 2 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 2

Touch tone 3 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 3

Touch tone 4 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 4

Touch tone 5 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 5

Touch tone 6 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 6

Touch tone 7 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 7

Touch tone 8 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 8

Touch tone 9 [none], target
parameter group No

Distribution or Inbound
parameter group
selected when the caller
selects 9

Business (reporting)
For instructions on setting these parameters, see Customize business attributes.
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Parameter Values (default in
bold) Mandatory? Description

Department
[none], an item from
the Department custom
list for the parameter
group

No
A business organization
used as a category in
reporting

Flow
[none], an item from
the Flow custom list for
the parameter group

No A business flow used as
a category in reporting

Product
[none], an item from
the Product custom list
for the parameter group

No
A product or product
group used as a
category for reporting

Segment
[none], an item from
the Segment custom list
for the parameter group

No
A customer category
used as a category for
reporting

Service
[none], an item from
the Service custom list
for the parameter group

No
Business categories
typically used as the top
level of the auto-
attendant menu choices

Target virtual queue [none], a target virtual
queue set in GA No

A reporting entity set up
in Genesys
Administrator

Contact center status
For instructions on setting these parameters, see Set open hours and special days.

Parameter Values (default in
bold) Mandatory? Description

Emergency declared False, True Yes

Activates the
emergency
announcement,
overriding any other
announcement

Open Hours

From Monday to
Friday, 0800-2000,
closed Saturday and
Sunday, value set for
parameter group

Yes

Sets the hours that you
are open and accepting
calls; to specify open
hours on specific dates,
you must place the date
above all day-of-week
entries

Special day December 25,
January 1, any dates No

A list of exceptions to
the regular open hours,
for a holiday or other
reason.

Distribution
For instructions on setting these parameters, see Set targets and target timeouts.
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Parameter Values (default in
bold) Mandatory? Description

Default distribution
parameter group

[none], parameter
group No

The distribution
parameter group that
provides the default and
overflow target for this
parameter group; if you
do not set this
parameter, the call flow
uses the originally
defined list of targets
and timeouts

Target 1 [none], agent group No The first agent group to
which the call is routed

Target 2 [none], agent group No
The second agent group
to which the call is
routed

Target 3 [none], agent group No The third agent group to
which the call is routed

Target 4 [none], agent group No
The fourth agent group
to which the call is
routed

Target 1 timeout 300, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target 2 timeout 1, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target 3 timeout 1, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target 4 timeout 1, integer between 0
and 99999 No

The timeout, in seconds,
after which the call is
routed to the next
target agent group

Target overflow
[none], a standard
telephone number, such
as 8005551212

No

The phone number to
which a call is routed if
the final Target timeout
is exceeded or if no
target agent group is
specified. Important:
you cannot use a
routing point as this
number.

Priority tuning
For instructions on setting these parameters, see Tune priorities.
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Parameter Values (default in
bold) Mandatory? Description

Priority Increment 0, integer between 0
and 99999 No

Sets the number to add
to the priority value
each time the priority
interval is exceeded

Priority Interval 0, integer between 0
and 99999 No

The time interval (in
seconds) between
priority increments

Priority Limit 0, integer between 0
and 99999 No

Sets the upper limit for
priority increments; all
calls at the maximum
priority level receive
equal treatment

Priority Start 1, integer between 1
and 99999 Yes

The initial priority
assigned to each
incoming call
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Configuring email routing
Initial configuration of the email routing application depends on the needs of the customer. In many
cases, the defaults supplied in the solution definition will be sufficient.

You can adjust email routing parameters in either of two ways:

• To set new default values to be used in all new parameter groups that use the parameter, open Genesys
Administrator Extension, navigate to Operations > Parameters, and adjust values as desired. Do not
change Key Names.

• To set a new value that applies only to a specific parameter group, open Genesys Administrator
Extension, navigate to Operations > Parameter groups, and adjust values as desired.

<multistep> Configure screening rules= You can use the eServices Knowledge Manager application
(on the Aux VM) to customize the screening rules used to route email to any of the five Category
parameter groups.

Content screening explains how screening works in Business Edition Premise.

"Screening Rules" in the eServices 8.1 User's Guide explains how to use the Screening Rule Editor
and details how the rules work. |-| Configure email acknowledgements= You can also use the
eServices Knowledge Manager application to customize the text of the acknowledgement emails:
Email acknowledgement body open hours, Email acknowledgement body closed hours, and
Email acknowledgement body special days, as well as the opening (salutation), closing, and time
zone.

"Using Categories and Standard Responses" in the eServices 8.1 User's Guide explains how to edit
the acknowledgement content. |-| Configure distribution= After you customize the screening rules,
you can adjust their associated parameter groups to distribute emails to the correct targets. If you
added the term "sales" to the Category 3 screening rule, for example, you can route emails with
"sales" in their subject lines to a particular target agent group by setting the Category 3 parameter
group Email target value to the Sales agent group.

You can also enable or disable supervisor review, and change the percentage of emails subject to
review. |-| Set open hours and special days= The parameter Email open hours sets the standard
hours that your office is open during the week. Use the Email special day parameter to set:

• The dates or days of the week on which your office is closed for the entire day.
• The dates or days of the week on which your office is closed for only part of the day. In these cases, you

use the Time Ranges field in GAX to set the hours that you will be open on that date.

Specific dates set in Email open hours are treated as special days. Hours set for the same date or
day of the week in Email special day override those set in Email open hours; for example, if
Email open hours specifies that you are open from 9AM to noon on December 31, and Email
special day sets the hours of 11AM-2PM for the same date, people who send an email at 10AM on
that date receive the special day acknowledgement.

Similarly, in both parameters, date patterns higher in the list take precedence over those lower in the
list. |-| Tune priorities= You can adjust the priority of emails using the two priority tuning parameters:
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• Email priority sets the initial email priority; you typically have little reason to change the default of
100.

• Email overflow priority sets the priority of emails that exceed the Email target timeout. The
default value is also 100, which means that emails that have already passed the overflow timeout will
be re-queued based solely on their age, ensuring that the oldest emails will appear in the queue first.

|-| Send a test email= To verify that Business Edition Premise is correctly receiving and routing
emails, send a test email:

1. Install an email client and ensure that it connects to your email server.
2. Send an email to the address specified during the eServices SPD deployment.
3. Ensure that you have installed an IWS client (you did this when you were making a test call during the

voice routing configuration).
4. If Business Edition Premise is successfully installed, an IWS interaction window containing the email

appears when the email arrives.

</multistep>
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Operational parameters for email routing
Acknowledgements
For instructions on setting these parameters, see Configure email acknowledgements.

Parameter Values (default in
bold) Mandatory? Description

Email acknowledgement True, False Yes

Sends customer an
acknowledgement
email, content
depending on whether
you are open, closed, or
on a special day

Email acknowledgement
body open hours

Thank you for your
email. We will get
back to you as soon
as possible., text
string entered in Value
field

Yes
The body text used for
acknowledgements sent
during regular hours

Email acknowledgement
body closed hours

Thank you for your
email. We are
currently closed and
will get back to you
as soon as possible.
Our office hours are:,
text string entered in
Value field

Yes
The body text used for
acknowledgements sent
during closed hours

Email acknowledgement
body special days

Thank you for your
email. We are
currently closed and
will get back to you
as soon as possible.
Our office reopens on
date, text string
entered in Value field

Yes
The body text used for
acknowledgements sent
during special days

Email acknowledgement
opening

Dear Customer name,
text string entered in
Value field

Yes
The greeting to the
customer at the
beginning of the
acknowledgement

Email acknowledgement
closing

Regards, text string
entered in Value field Yes

The closing term to the
customer at the end of
the acknowledgement

Email acknowledgement
time zone

[none], free-form text
such as Central Time
or GMT

No
The time zone text that
you want to include in
your email
acknowledgements.

Email from [none], email address No The email address
(typically DoNotReply)
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Parameter Values (default in
bold) Mandatory? Description

used in sending email
responses to customers

Contact center status
For instructions on setting these parameters, see Set open hours and special days.

Parameter Values (default in
bold) Mandatory? Description

Email open hours

From Monday to
Friday, 0800-2000,
closed Saturday and
Sunday, any value set
in the Value > Date
Pattern field

Yes

Sets the hours that you
are open and accepting
emails; to specify open
hours on specific dates,
you must place the date
above all day-of-week
entries

Email special day
December 25,
January 1, any value
set in the Value > Date
Pattern field

No
A list of exceptions to
the regular open hours,
for a holiday or other
reason.

Distribution
For instructions on setting these parameters, see Configure distribution.

Parameter Values (default in
bold) Mandatory? Description

Email screening True, False Yes Enables email screening
rules

Email target [none], agent group Yes The agent group that
first receives all emails

Email overflow target [none], agent group No
The agent group that
receives all emails that
exceed the overflow
target timeout

Email target timeout 3600, integer between
1 and 99999 No

The length of time (in
seconds) that an email
can go unattended
before being passed to
the overflow agent
group

Email overflow target
timeout

86400 (24 hours),
integer between 1 and
99999

No

The length of time (in
seconds) that an email
can go unattended
before being passed to
the first available agent
group (either target or
overflow)
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Parameter Values (default in
bold) Mandatory? Description

Email supervisor review False, True Yes Enables supervisor
review.

Email supervisor review
percentage

100, integer between 0
and 100 Yes

The percentage of
emails routed to
supervisors for review

Email supervisor agent
group [none], agent group No

The supervisor agent
group that receives the
emails when supervisor
review is enabled

Email default virtual
queue

VQ_Default_email, a
target virtual queue set
in GA

Yes
The default virtual
queue to which all
emails are routed, for
reporting

Priority tuning
For instructions on setting these parameters, see Tune priorities.

Parameter Values (default in
bold) Mandatory? Description

Email priority 100, integer between 1
and 99999 Yes

The initial priority
assigned to each
incoming email

Email overflow priority 100, integer between 1
and 99999 Yes

The priority assigned to
all emails that exceed
the overflow target
timeout
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Requesting licenses
To request Genesys and VMware licenses for Business Edition Premise, complete the following steps:

1. Prepare an email request containing the following details:
• Your software order number or purchase order number.
• The Core VM NIC MAC address (this is for the Genesys software license). If you do not know the MAC

address, and your server was provided by Genesys, you can find it on the label of the box in which
your server was shipped, or alternatively, on the license card of the system. Otherwise, contact
your Genesys Partner.

• For existing deployments, include a copy of your existing license file.
• For non-revenue orders, you should request licenses only if you are upgrading to a major version

release (for example, if you are upgrading version 7.x to 8.x).

2. Send the email request to the appropriate Genesys contact for your geographical region:
• Americas / APAC
• EMEA
• Japan

The response time for license requests is typically 2-3 days.

For more information about licenses, refer to the Genesys Licensing Guide.
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