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Welcome

Welcome

Welcome to the Composer 8.1.4 Help. Composer is an Integrated Development Environment (IDE),
based on Eclipse, for developing:

* Routing applications for the Genesys Orchestration Platform 8.x (ORS)—which takes the Genesys core
capability of routing, extends it, and integrates it tightly with other Genesys products.

* Voice applications for Genesys Voice Platform (GVP) 8.1+—a software suite, which unifies voice and web
technologies to provide a complete solution for customer self-service or assisted service.

Expand the Table of Contents on the left to view all topics. Use the links below to get started in
functional areas.

Tip
You can also click Search at the top right. To search all Genesys docs, or just

Composer, position the cursor immediately after the magnifying glass and press Enter.
A search page appears. Composer is under On-Premise Content.

Quick Start

See the Composer Videos, specifically the video on Getting Started After Installation.

¢ Use the information below Quick Start to learn how to create a simple routing strategy, attach data
that will appear on the agent desktop, and route to the preferred agent.

Videos

Don't miss the Composer videos. Since Orchestration Server executes the SCXML-based routing
strategies created in Composer, you might also be interested in the Orchestration Video.

Introduction to Composer Validation, Debugging & Deployment
This section includes the following This section includes information on:
information:
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Quick Start
Introduction to Composer

Interface Overview

Samples and Templates

Validation
Debugging Routing Applications
Debugging Voice Applications

Testing on Tomcat

GVP Voice Applications

This section includes information on:

Creating Voice Applications
Sample Text-to-Speech Application
Preferences for Voice Applications

How Do Voice Applications Work?

Sample Applications & Templates

This section includes information on:

Routing Templates and Samples
Project Templates
Diagram Templates

GVP Voice Project Templates

\/nice Rlack Palette Reference

|l act Called Aaent Routina

Orchestration Routing Applications

This section includes information on:

Creating Routing Applications
Sample DNIS Routing Application
Preferences for Routing Applications

Interaction Process Diagrams

Installation, Videos, Troubleshooting

This section includes information on:

Installation Video
Installation/Deployment Guide
Troubleshooting

Best Practices

Routina Rlock Palette Reference

Llcefiil Recnlircec

Common Voice & Route Functionality

This section includes information on:

Links to Useful Docs

This section includes information on:
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Code Generation
Exception Events

Diagram Preferences

Defining Variables

Orchestration Server Wiki
Orchestration Server Extensions
SCXML Language Reference

Genesys Voice Platform Wiki

Expression Builder

System-Level Guides
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Composer Overview

Use to Create Routing and Voice Applications

Composer is an Integrated Development Environment (IDE), based on Eclipse, for developing:

Routing applications for the Genesys Orchestration Platform 8.x, which includes:

e Universal Routing Server (URS)—which enables intelligent distribution of voice and multimedia
interactions throughout the enterprise.

e Orchestration Server (ORS)—an open standards-based platform with an SCXML engine, which enables
the customer service process. ORS is responsible for executing orchestration logic (SCXML) that is
provided by an application server (such as an application server hosting an SCXML-based routing
application created in Composer). The responsibility of URS within the Orchestration Platform is to
provide a necessary service to Orchestration Server to support Routing functions.

Voice applications for Genesys Voice Platform (GVP) 8.14+—a software suite, which unifies voice and
web technologies to provide a complete solution for customer self-service or assisted service.

Tip

* In the past, Interaction Routing Designer was used to create routing applications.
Genesys Composer is now the tool of choice for creating both routing and voice self-
service applications.

e Previously Composer was known as "Composer Voice," as it was used only to develop
voice applications for Genesys Voice Platform. Starting with 8.0.2, the capabilities of the
IDE were expanded to include support for Universal Routing application development.
Due to this expansion in scope, the product name was shorted to "Composer."

e The terms Composer Voice and Composer Route are used in some places in the product,
to refer to the collection of product features that are used specifically for Genesys Voice
Platform application development, and Universal Routing Application development,
respectively.

e Users may enable/disable Composer Voice and/or Composer Route capabilities through a
Composer preference setting (Window > Preferences > General > Capabilities >
Advanced). This is useful for developers who are only using one of these Genesys
platforms.

Application Development

Composer provides both drag-and-drop graphical development of voice applications (or “callflows”)
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and routing strategies (or “workflows”) as well as syntax-directed editing of these applications.

* For voice applications for the Genesys Voice Platform, Composer supports editing of VoiceXML 2.1,
CCXML1.0 and SRGS 1.0.

e For routing applications for the Genesys Orchestration Platform, Composer supports editing of SCXML
1.0. Applications may be developed in an "offline” mode, without requiring the user to connect to
Genesys Configuration Server.

Application Debugging
Composer provides real-time debugging capabilities for both voice and routing applications.

e The Genesys Voice Platform Debugger is integrated with GVP for making test calls, viewing call traces,
and debugging applications. It supports accessing SOAP and REST-based Web Services. Database
access is possible using server-side logic and a Web Services interface.

e The Orchestration Server Debugger, integrated within the workflow editor, works with both live and
simulated calls. For live calls, it places those calls into a T-Server/SIP Server connected to a URS/ORS
system. The capabilities include setting breakpoints, stepping through a workflow, viewing and setting
the values of variables, and viewing event messages from the URS/ORS platform.

Eclipse

Composer is an Eclipse-based application. The use of Eclipse as the underlying framework enables
the use of third party IDE plug-ins, supporting integration with third party source code control
systems, server-side development enhancements, and side-by-side development of any business
logic required to support your applications.

Operating Systems

For information on supported operating systems, see the Genesys Supported Operating Environment
Reference Guide.

Composer Help Wiki URL

The URL to the Composer Help wiki is configurable by using the Online Wiki URL field: Window >
Preferences > Help. The default works with English but if, for example, Japanese pages were
available in a different location, then you could change the URL accordingly.

Composer Help 17


https://docs.genesys.com/Documentation/IW/8.1.4/Help/DebuggingVoiceApplications
https://docs.genesys.com/Documentation/IW/8.1.4/Help/DebuggingRoutingApplications

Welcome

Third Party Software

For information on the third party software used in Composer, see the Legal Notices under More
Release Information at the bottom of the Composer main page.
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Getting Help

¢ Use the Search This Manual (or Product) box at the top right. You can search by product, book type,
version, and book type.

* Create a searchable PDF. Scroll down to PDF version at the bottom left of a page.
¢ Use the TOC on the left of each page to locate information.
¢ Depending on your location in the user interface, Composer's context sensitive help triggers wiki pages.

* Press F1 to get help on a page. A Help view opens on the right.

Block Palette Reference

For information on Composer blocks and block properties, you can go directly to the following:

* Voice Block Palette Reference (when building applications for Genesys Voice Platform (GVP))

¢ Interaction Process Diagram Block Palette Reference (used for multimedia/routing applications to
define how interactions move through various processing objects)

* Routing Block Palette Reference (when building routing applications for the Orchestration Platform)

e Common Blocks Block Palette Reference (blocks used for both voice and routing applications)
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Composer Installation Video

Video Tutorial

Below is a video tutorial on installing Composer 8.1.4 on Windows in an Eclipse environment.

B Genomys infs Mat Bunnses Corinuly Dapicyren] Geids

For additional installation information, see Installation in the Composer 8.1.4 Deployment Guide.

Composer Help
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Composer Quick Start

Tip
See Getting Started After Installation the Composer Videos.

The information below is intended to be a Quick Start for routing strategy development with Genesys
Composer. A routing strategy is comprised of one or more routing workflows. Regardless of the
version of Composer you have installed, this Quick Start (which reflects the Composer 8.1.2 interface)
will help you get started using Composer.

The goal of this Quick Start is to:

1. Create a simple routing strategy workflow that will distribute an inbound call to an agent.
2. Add attached data to this workflow that will be popped when the call is delivered to the agent desktop.

3. Route the call to a preferred agent and if the agent is not available then expand the agent pool.

The steps below assume you have already installed a Genesys environment and have configured an
Orchestration Solution, which includes Workspace Desktop Edition, Interaction Server, Composer, and
Orchestration Server.

Creating a Sample Workflow

1. In Workspace Desktop Edition (or "Interaction Workspace"), log in and make agents Ready). This
example uses 04 Agent KSippo, and 05 Agent KMilburn. Also make Ready the customer phone. This
example uses the Pat Thompson customer phone.

2. Click the Eclipse icon on your desktop to open Genesys Composer.

3. Ensure that Genesys Composer is connected to Configuration Server. The current status of the
connection to Configuration Server is displayed in the lower right of Composer.

Tip

When you set up your Configuration Database (Configuration Server), you define certain database objects,
such as agents (Persons), Agent Groups, Skills, and so on. These objects can be defined in Configuration
Manager or in Genesys Administrator. When you use Composer to create SCXML-based routing strategies
executed by Orchestration Server (and Universal Routing Server), there is a button to connect to
Configuration Server. When creating a routing workflow in Composer, those Configuration Database objects
will be available in the Composer workflow building blocks that use them. For example, you might be creating
a workflow that routes to an Agent Group and using Composer’s Target block. The Agent Group you defined in
the Configuration Database would be available for selection in the Target block.

4. If Composer indicates Disconnected from Configuration Server, then select Configuration Server
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5.

11

12.

13

14.

from the main toolbar and click Connect.

Enter the appropriate connection information and click Next.

m Connect to Configuration Server O
Configuration Server Parameters

Enter the Configuration Server parameters
User Name*; demo |
User Password: |
Application®;  default I
Host*: 10.10.26.82 ]
Port*: 2020 |
Client Port Range*: 51000 | = [ 51200 l

1
@ <pack [ Nea> Finish Cancel

Give the Project a name, for example, MySample.

Ensure that Integrated Voice and Route is selected.

. Click Finish.

default workflow.

Upon selecting the default.workflow a blank workflow palette will appear.

. Within Composer, create a new Project: File > New > Java Composer Project.

. Select the tenant, such as Environment, or the name of another tenant (business entity).

. Go to the new Project folder that you was just created (MySample) and open the Main workflow and

Within the .workflow, drag and drop an Entry block, Target block, and Exit block from the palette of
blocks onto the workspace. Make sure you are working within .workflow and not the .callflow (used

for GVP voice self-service applications).

. Go to the Target block and select the Targets property. This is done by selecting: Target > Properties

> Target Selection > Targets on the far right. Upon selecting the Targets property, a new Targets box

will appear:

Within the Target block, select Add and enter the following:
* Type: Agent Group
* Name: SIP Group

» Stat Server: Stat Server

Composer Help
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Tip
If you are connected to Configuration Server, you are able to directly pull information from Configuration

Server to populate the options. You are not required to be connected to Configuration Server to perform

development as Composer allows you to perform development offline and then connect and validate against
Configuration Server at a later time.

15. In the Target block set the Timeout property to 99.

16. Click the main toolbar buttons to validate your workflow and then generate the code.

Tip
To validate the workflow and generate the code, the focus must be within the palette where the workflow is

being designed. To validate you can enter Alt+V. Or you can validate by right clicking the default.workflow

from the Project Explorer window and selecting Validate from the main toolbar. Code can be generated by
entering Alt+G or clicking on the Generate button on the main toolbar.

17. Go to the Interaction Processes folder in the left Project Explorer. Right-click on the interaction process

diagram file (default.ixnprocess) and perform a similar process to validate and generate the code
validate the default interaction process diagram.

18. Right-click on the interaction process diagram file (default.ixnprocess) and select Publish to

Configuration Server. You should receive a message that the interaction process diagram was validated
and published to Configuration Server.

Tip
An SCXML-based workflow is first invoked by the interaction process diagram. If you open the interaction
process folder, you will see that there is a workflow named defaultworkflow. This workflow in turn points to

the actual workflow that you just created, which is in the Location/Resource property of the Workflow block. If

you change the name or have multiple workflows, you need to ensure that the appropriate association is
maintained.

19. Assuming this routing strategy only contains one workflow, you are now ready to "provision" the new
workflow. Within Genesys Administrator, provision a new DN on the SIP_Switch
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Example: Number: 4000 Type: Routing Point

20. Under Routing > Orchestration (see below), select the workflow that was just created:
MySample.default.defaultWorkflow.
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21. Confirm that your routing strategy works:
* Make your agents Not Ready.

* Place a call from the customer phone to 4000. Note: We do not yet have a treatment so the caller
will not hear any initial treatment.

* Make KSippola Ready.

» Confirm that the call is delivered to the available agent and they receive a screen pop.
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Add a Treatment

Add a simple queue treatment that the caller will hear while waiting for an available agent.

1. Utilizing the existing workflow, select the Target block. In the properties under Route Target, set Use
Treatments to true.

2. Add a Play Sound block from the Voice Treatment icons palette. Connect the Busy Treatments from
the Target block to the Play Sound block. Connect the output from the Play Sound block to look back
to the Target block.
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3. Within the Play Sound block set the Resource property to play back the badon_hold.wav file, which
is already present on the Demo Server.

4. Proceed to validate the code, generate the code, and then place a call back into to your Routing
Point with all agents in a Not Ready state. Confirm that queue music is received by the caller.

Attaching Data

Add attached data to this strategy that will be popped when the call is delivered to the agent desktop. In this example you will
need to add your name as a value for one of the appropriate keys and ensure that it is popped to the Interaction Workspace

desktop.
1. Utilizing the existing workflow that was just created add a User Data block from the palette in
between the Entry and Target blocks.
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In the Assign property of the User Data block configure an appropriate key and value where the
value is your name; for example, Don Huovinen.

x|
Add Assign Data

Select the key and value.
Key: |Literal x| [Newscve
R [Literal =] [ pon Huovinen
Value is numeric [

o o] ons

While we are attaching data using this block you must also ensure that the new key; NewKVP in the
example shown above, will appear properly in Interaction Workspace.

Validate your workflow and then generate the code.

Modify the settings of Interaction Workspace to display the key-value pair ,which we just added, in
our case the key is "NewKVP” and we want this displayed in Workspace as "My Complete Name”.
Within Interaction Workspace, the key-value pairs that will be displayed are based on the keys that
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are listed in the CaseData Business Attribute so we need to add "NewKVP"” as one of the values in

the CaseData business attribute for this KVP to be properly displayed in Interaction Workspace. This
can be done by searching for the Case Data business attribute.
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5. Then double-click on Case Data, select the Attribute Values tab, and then select to Add a new

attribute. The Name will be the name of the key (NewKVP) and the Display Name is the name we
want displayed in Interaction Workspace.
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Make your agents Not Ready.
Place a call from the customer phone to 4000. The caller should hear music.

Make the agent Ready.

© o N o

Confirm that the call is delivered to the available agent and they receive a screen pop.
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Routing to a Preferred Agent (Add Flexibility)

Provide routing to a preferred (last handling) agent and if that agent is not available within the defined threshold expand the pool
of available agents so that the call can be successfully delivered.

1. Using the existing routing workflow, add a new Target block from the palette in between the
UserData block and existing Target blocks.

2. Within the new Target block label it "Personal_Agent” and set the Target block to target KSippola.
* Type: Agent
e Name: KSippola

* StatServer: Stat Server
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4. Set the Exceptions property to capture an exception of error.queue.submit

5. Within the workspace, connect the error.queue.submit exception from the new Target block you
just added to the previous SIP group target block that you already have. Connect the normal outlink
from this new Target block to the existing Exit block. A example flow is provided below.
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Validate your workflow and then generate the code.

Test that your routing and logic works as desired:

Make KSippola and KMilburn ready.

Place a call from the customer phone to 4000.

Confirm that the call is delivered to KSippola and he receives a screen pop.

Make KSippola NotReady

Place a call from the customer phone to 4000.

Confirm that the caller waits and after the timeout the set of targeted agents has been expanded
the call is delivered to KMilburn. Note: The prior example is a scenario that shows target
expansion, but can be improved if another different treatment is provided while the caller is waiting

for their personal agent. As the target expansion occurs, you could also change the treatment to
provide an audible queue position. An example is callflow is shown below.
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Validate your workflow, Generate the code and then proceed to place a call to show the new
scenario:

Make KSippola Not Ready and KMilburn Ready.
Place a call from the customer phone to 4000.

Confirm that the caller waits and after the timeout the set of targeted agents has been expanded
the call is delivered to KMilburn.

Summary of Example Workflow

This example workflow strategy could represent a "last agent routing" approach or preferred/
personal agent routing. If the preferred destination is not available, you could expand the target list
so that you have 1) optimal routing and 2) do so within the context of desired service levels. As the
target group is expanded, you not just moving from A to B when expanded. The workflow is now
looking at the A + B. You coulde alternatively just overflow to B if desired through the Target
Selection properly (Clear Targets = True).

You could also place a subsequent call, wait until the timeout and then make KSippola available
showing that KSippola is still part of the target group and will receive the call. Technically KSippola
is a subset of SIP agents therefore you really don’t have the A+B as described previously as A is a
member of B but the A+B target expansion discussed previously is still valid.

When attaching User Data. you can utilize any key name you want. However. you need to make the
necessary changes in Interaction Workspace to display the desired attached data. The workspace
will utilize attached data present in the call such as the caller ID to look up information from
Universal Contact Server and use the information obtained from UCS for the screen pop in Contact
area.

Interaction Workspace may take a long time to start. This is becasue the Interaction Workspace
agents are configured for a number of interaction channels such as e-mail, SMS, chat, and so on.
Therefore, when Workspace starts, it attempts to connect to Interaction Server. If Interaction Server
is unavailable, then each channel will be attempted sequentially and need to time out before
proceeding to the subsequent channel.
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Eclipse Workbench

e As described in the Composer Deployment Guide, Composer 8.1.4 is installed as an Eclipse plugin.

Since Composer is based on based on Eclipse, you may wish to familiarize yourself with basic Eclipse
concepts by referring to the Workbench User Guide although this is not mandatory. The Workbench
User Guide presents an overview of many of the same concepts used within Composer, but from the
Eclipse development environment framework perspective. Reviewing this information can be valuable
as a first step in getting familiar with the Eclipse user interface on which Composer is based. To
access the Workbench User Guide online help:

1. Select Help > Help Contents. The system displays the Help - Composer window.

2. In the Contents navigation pane, click Workbench User Guide.

3. Click Concepts in the main Help pane.
Review the multiple sections of the Concepts section to gain familiarity with Eclipse.

e Select Search from the main Help menu to search the Eclipse Help.
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Introduction to Composer

Composer is an Integrated Development Environment (IDE) based on Eclipse for building voice
applications for the Genesys Voice Platform (GVP) 8.1+ and routing applications for the Orchestration
Server 8.0+.

What is Composer?

Composer is the next generation version of Genesys Studio based on Eclipse 3.5.1. It provides a rich
development experience, which Web Application developers are already used to, for building
VoiceXML, CCXML, and SCXML applications. Familiarize yourself with basic Eclipse concepts by
referring to the Workbench User Guide (Help > Help Contents). Composer provides ability to
develop the following types of applications.

For the GVP 8.x NGI Interpreter:

e Pure VoiceXML Applications with full support for Genesys extensions

e CCXML + VXML Applications requiring advanced call control features including Conferencing

e CTI + VXML Applications for Genesys Framework

For the Orchestration Server 8.x SCXML Engine/Interpreter:
e Pure SCXML Applications with full support for all Genesys predefined SCXML functional modules and
extensions used for creating SCXML-based strategies and routing applications.
* Voice Routing SCXML applications for handling media of type voice for Inbound channels.

e Integrated CTI + VoiceXML applications for end-to-end treatment handling in conjunction with GVP and
Stream Manager.

GUI Designer

Composer provides a drag-and-drop based interface for creating VXML and SCXML applications. Users
can easily create flow diagrams by placing and connecting blocks and configuring properties. This
approach also provides an easy mechanism for invoking Web Services and doing database lookups
from the Application server-side. Custom blocks can be created that can be added to the supplied
palette of blocks.

Code Editors

For those who prefer to write their own code, Composer provides a set of rich editors for SCXML,
VXML, CCXML, and GRXML along with use case templates.
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Templates

Out-of-the-box, reusable template applications are provided. These can act as a starting point for new
projects and visual flows and serve as guidelines and tutorials for routing and voice application
developers. Composer also provides templates for its rich editors with the ability to create user-
defined custom code snippet templates, which can be exported and imported to share across team
members.

Code Generation

When generating code, Composer provides the ability to generate Static VXML pages to take
advantage of the Platform optimizations. For SCXML routing strategies, Composer provides the ability
to generate Static SCXML pages for improved performance due to caching.

Debugging

Debugging functionality includes the ability to debug VoiceXML applications and callflow diagrams
with the GVP Debugger and GVP Debugging perspective. The real-time GVP Debugger supports both
Run and Debug modes. In the Run mode, call traces are provided and the application continues
without any breakpoints. In the Debug mode, you can input breakpoints, single-step through the
code, inspect variable and property values, and execute any ECMAScript from the query console.
Composer provides real-time debugging capabilities for SCXML-based Orchestration Server (ORS)
applications. The ORS Debugger is integrated within the workflow designer for making test calls,
creating breakpoints, viewing call traces, stepping through an SCXML document/workflow, and
debugging applications. Debugging can be started on an existing session or it can wait for the next
session that runs the application at a given URL.

Deployment

Composer provides the ability to deploy applications. Future releases will provide the ability to deploy
routing applications.

Project Management

Composer provides full project management capabilities for managing all the resources in a
Composer project.
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Routing Strategies

Composer is integrated with Genesys Configuration Server, which provides the ability to define and
fetch strategy-related data residing in the Configuration Server database. This integration allows
developers to find and select routing targets when using Composer's Target block. When creating
routing strategies, developers can define List objects and routing-related Statistics.
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Software Prerequisites

Consult the following:

e Installation topic in the Composer 8.1.4 Deployment Guide.

e The Composer section in the Genesys Supported Operating Environment Reference Guide.

Composer Help 39


https://docs.genesys.com/Documentation/Composer/latest/Deployment/Preinstallation

Introduction to Composer

Interface Overview

Note: The minimum screen resolution for Composer is 1024x768 on a standard 4:3 aspect ratio
monitor. The recommended resolution is 1280x1024. Lesser resolutions, such as 800x600, are not
supported.

Introduction to the Interface

Below is a short video introducing the Composer interface.

Link to video

Sample Applications

For a sample voice applications, see Hello World Sample, which describes a text-to-speech
application. For a sample routing applications, see Your First Application, which describes a DNIS
routing application.

Blocks, Connectors, and Properties

The Composer interface uses workflow and callflow design components (blocks and connectors) to
create voice and routing applications
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It uses drag-and-drop to arrange, add, and delete blocks on a design area. The blocks are connected
within the design area to build the flow for the application. You define the properties for a selected
block in Composer's Properties view. Also see: Working With Diagram Layouts

Interface Elements

The first time you enter the Composer perspective, since your workspace is empty and does not
contain any Projects, you will see an empty Project Explorer on your top-left, and a blank center area.
After you create a voice or routing Project, the Project Explorer shows all the files and resources
that make up the Project. The figure below shows the GUI elements in Composer perspective for a

sample routing application.
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GUI Element Descriptions

The numbers in the figure above are keyed to the table below.

The Project Explorer shows all the files and
1 resources that make up a Project. See Composer
Projects and Directories for more information.

For large flows, the Outline view (shown above)
2 allows you to navigate to the portion of the flow to
view in the design area.

The History view maintains previous versions of
3 flows and application files, allowing you to revert to
any previous version if needed.
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The design area is where you create flows by
placing and connecting blocks. Composer's design
area is the work area that you will use for building
your applications.

The Palette contains workflow diagram-building
blocks or callflow diagram-building blocks grouped
in various categories: Voice Block Palette Reference
and Routing Block Palette Reference.

The Properties view shows block properties and
allows you to modify settings, set variables, and
otherwise change or set the properties
corresponding to a block. This area also displays
Call Traces during debugging, or Problems during
validation or testing.

In the top toolbar, the Validate button allows you
to check for syntax errors. The Generate Code
button creates VXML and SCXML pages from the
diagrams you create.

7,8

Menus and Toolbars provide commands and
operations for running Composer.

Perspective buttons show the active perspective
and let you easily move between perspectives. By
default, when you enter the workbench for the first
time, you will be taken inside the Composer
perspective. Perspectives are arrangements of

10 different sections of the GUI in a manner that
facilitates easy use of a particular feature. For
example, the GVP and ORS Debugging
perspectives will show those sections (Breakpoints,
Call Trace, Variables, and so on) that are useful
when debugging an application.

Composer displays a Help view on the right if you select Help > Search or Help > Dynamic Help.

Perspectives

When you select Window > Perspective > Open Perspective > Other, all perspectives available
in Eclipse are listed, including those not used by Composer.

Use the following Composer perspectives for building applications:

* GVP Debugger, for debugging applications you build or import
¢ ORS Debugger, for debugging routing applications you build or import

e Prompts Manager perspective, which provides the ability to quickly review all prompts in a Composer
Project

e The Composer perspective shows the Project Explorer, Outline view, design area, and Palette of blocks.
Composer perspective can show the following tabs in the lower pane: Properties, Prompts Manager,
Problems, Console, and Call Trace. Select Window > Open Perspective.
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e Composer Design perspective can be used to show only the palette of blocks, the canvas area, and the
Properties tab.

Any customized perspective appears in this list. You can configure perspectives on the Window >
Preferences > General > Perspectives preference page.

Customizing the Show View Menu

A view can be displayed by selecting it from the Window > Show View menu. You can customize
this menu by using Window > Customize Perspective. Click the Submenus down arrow and
select Show View.
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Using the Interface

Blocks

A block is the basic building unit that you use to create applications. In Composer perspective, the
palette of blocks is located in the right-most part of the main window (unless the Help window is also
visible) and contains various categories of blocks. Every application must start with an voice Entry
block or routing Entry block. You can also create Custom Blocks. A routing applications starts with

Interaction Process Diagram Blocks.

Using Blocks
When creating voice application callflows and routing application workflows using the designer:

¢ You double-click or drag-and-drop callflow blocks and/or workflow blocks to place them onto the center
area (canvas).

¢ You configure properties for each block.

* You connect the blocks together by drawing connection links to define the flow.

Block Names and Multi-Byte Characters

Composer block names can contain only alphanumeric characters. If multiple-byte characters are
used in block names, the code generation step fails and no SCXML or VXML file is generated from the

Composer diagram.

Methods for Adding Blocks

There are a few ways to add blocks from the Palette to the canvas. The most common methods are
as follows:

e Click on the block icon on the palette, release the mouse and click on the target location on the canvas
area.

¢ Double-click a block icon on the palette.
¢ Click on the block icon on the palette, and while holding down the mouse button, drag and drop the
block to the canvas.

Any of these methods will add the new block and you can then type the name of the block on the
canvas itself. Click here to read about block naming restrictions.
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Outline View

For large call or workflows, the Outline view allows you to navigate to a portion of the flow diagram to
view in the main canvas. It can also be used to facilitate navigation for other types of elements that
might appear in the canvas or editor window, such as a large VXML file displayed in the VXML Editor.
For more information, see the Outline View topic in the Eclipse Workbench User Guide (Help > Help
Contents).

Simulation View

Simulation view shows the VoiceXML or SCXML code (read only) for a selected block (IPD blocks do
not have this view). To add the Simulation view to the current perspective:

e Click Window > Show View > Other > Composer > Simulation.

Block Context Menus

Or, you can use a block's context menu as follows:

e Select a block in the canvas, then right-click the box and select Simulate Code from the context menu
as shown in the figure below. The Simulation view displays the code for the selected block.

The History view maintains previous versions of call and workflows and application files, allowing
you to revert to any previous version if needed.

¢ For more information, see the Local History topic in the Eclipse Workbench User Guide (Help > Help
Contents).

The Problems view is used during validation of callflows, workflows, and files (VXML, SCXML, GRXML,
and so on). It displays information about errors encountered when validating an application.

e For more information, see the Problems View topic in the Eclipse Workbench User Guide (Help > Help
Contents).
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Connection Links

Blocks are connected to each other using connection links. There are two types of connection links:

1. Use OutLinks to connect one block's output port to another block's input port: s QutLink

2. Use Exception Links to indicate error or exception conditions by connecting from a block's exception
port to another block's input port:
w—a ExcephionLink

Find the connection links at the top of the palette on the right side of the Composer window.

Example

The figure below shows examples of using the link tools:

—
rorm Menu
=TI MenLl
ey . '
- Prompt ;e
. Exceaded [
imL O
_ @ Record
Recordl

In the above example, the red links (going from the Menu block to the Prompt block) result from using

the Exception Link tool to connect the two blocks. The black links (going from the Menu block to the
Record block and the Log link) result from using the Outlink tool.

Adding a Link

To add a new Output Link (or Exception Link):

1. Click the Output Link (or Exception Link) icon in the palette.
2. Move the mouse over to the source block. The cursor will change to an upward arrow.
3.

Click once on the source block and keep the mouse button pressed. Then drag the mouse onto the
target block and release the mouse button.

This will add the connection link between the two blocks. To use an Exception Link, the source block
must have an exception port defined. This is done by selecting at least one supported exception
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within the block's Exceptions property. Another method for adding an Output Link or Exception Link
between two blocks is as follows:

1. Click once on the source block to select it.
2. Hold the Ctrl key and click once on the target block to select it as well.

3. Double-click the Output Link (or Exception Link) icon in the palette to create a connection between the
two blocks.

Again, to use an Exception Link, the source block must have an exception port defined.

Changing Style and Appearance

Composer allows you to change the style and appearance of your connection links to suit your needs.
To change connection link appearance:

1. Select the connection link(s) you wish to change on the diagram (Ctrl-click to select multiple links). If
the Properties view for the selected link is not visible, select Window > Show View > Properties. Or
right-click the link and select Show Properties View from the shortcut menu.

2. In the Properties view, click the Appearance button to the left. A palette of appearance options is
displayed in the Properties view.

You may change any of the following:

e Font, Font Size, Font Style, and Color

Line and Arrow Style

¢ Smoothness of the connection line (None, Normal, Less, or More)

Routing Style (Oblique, Rectilinear [default], or Tree), as well as the option to avoid obstructions or
choose the closest distance for the link (even if it must cross over another block)

e Jump links set how links will be displayed when a link needs to jump over or cross another link (None,
All, Below, Above), and the shape of the link crossing over can be Semi-Circle, Square, or Chamfered

¢ Reverse jump links switches the orientation of the semi-circle, square, or chamfered shape of a crossing
link
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Composer Code Editors

File > New > <file_type>

Composer provides the ability to hand-code SCXML, VoiceXML, CCXML, GRXML, JSP, and ASP.NET for
custom scripts as a part of the application development process. The editors have standard editing
capabilities and time-saving features such as a code snippet library, validation checks for errors
(during design and save time), and syntax highlighting.
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Code Editing Features

The editors provide:
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e Standard editing features such as cut, copy, paste, undo, show line numbers, search and replace,
bookmarks and TODO markers

e Standard Eclipse Editor features; local file history support, Team support for source code control,
compare files.

e The ability to do background validation of the text as the user types, showing squiggly marks for errors
as is done in Microsoft Word.

e A Validate option to validate against the schemas.

¢ A code snippet library with the ability for developers to add their own custom scripts.

* An outline view for quick navigation and the ability to view and edit the XML in tree format.
e Syntax coloring with the ability to customize the colors.

e A spell checking feature; a yellow squiggly line is shown below words that are misspelled.

* Quick-fix choices to fix the spelling or ignore / disable the check.

¢ Task tags features for setting preferences to auto scan comments with TODO in comments, and
automatically add tasks corresponding to these comments.

e Context-sensitive help as the user types in the code

Using the Editors

Composer editors are embedded/integrated within the user interface and are made available to you
whenever a .scxml, .vxml, .ccxml, .grxml, or .jsp file is created or accessed within Composer.

For additional information, see Accessing the Editors and Templates.
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Enabling/Disabling Functionality

You may hide voice application (GVP) and/or routing application development capabilities through a
Composer preference setting. This feature is useful for developers who are only developing
applications for GVP or Universal Routing. To hide voice or routing development capabilities:

Select Window > Preferences.
Expand General and select Capabilities.
Click the Advanced button.

In the Advanced Capabilities dialog box, expand Composer.

A

Check or uncheck Composer Route or Composer Voice based on your need.

* If you uncheck Composer Voice, the ability to create Projects and diagrams with callflows will no
longer be available. Also, perspectives and views exclusive to callflows will not be available. This

means you temporarily won't be able to design voice applications for GVP until you re-enable
Composer Voice capability.

* If you uncheck Composer Route, the ability to create Projects and diagrams with workflows is not
available. Also, perspectives and views exclusive to workflows are not available. This means you

temporarily won't be able to design routing applications for Universal Routing 8.x until you re-
enable Composer Route capability.

6. Click OK in both dialog boxes.
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Hiding File Types and Blocks

You can hide Composer file types by using basic Eclipse functionality in Composer. This may be
desired when certain functionality is not applicable to your environment. For example, when using
Voice capabilities, and VXML is used but not CCXML, you may wish for the CallControlXML file type to
be hidden from the File > New menu. The following steps may be used:

1. Select Window > Customize Perspective. The Customize Perspective dialog appears.
2. Click the Shortcuts tab.

3. Expand Composer and check Others.

4. In the list of shortcuts, uncheck <file-type>, where <file-type> is the type to be hidden.
5. Click OK.
6

. Repeat for other perspectives if desired.

This customization is specific to the workspace. If you use other workspaces, you must customize
them as well. This is base Eclipse behavior where customization is saved within the workspace.

Hiding Diagram Building Blocks

You can also customize the palette of diagram-building blocks. Right-click a block category (such as
Flow Control) and select Customize. You can then hide and unhide blocks in that category.

Hiding/Displaying the Palette

Should you accidentally cause the palette to disappear, click the Hide/Show Palette (right-pointing)
triangle.
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Localization

The information below describes translating various elements of the Composer user interface in your
preferred language. For information on translating the entire user interface in French Canadian, see
Language Locales in the Composer 8.1.4 Deployment Guide.

To localize Eclipse IDE supplied strings, installation of Eclipse language packs is
required. You can download the required Eclipse language packs from Eclipse Babel
Project Downloads.

Limitations

There are some limitations to localization, which are detailed here.

Translating the Palette

After installing the Composer Language Pack, if you open Composer and continue to use an existing
workspace, you will discover that the Palette is not localized. This is because Palette customization
happens within Composer. You can change the labels, descriptions, and visibility of individual tools in
the Palette. Composer preserves your customizations and, for that reason, Composer keeps the
settings of your workspace Palette even after a Language Pack is installed. To workaround this issue,
you can perform one of the following actions.

1. Start a new workspace. The Palette will be localized in the new workspace.

2. If you are willing to lose your current Palette settings:

e Shut down Composer.

* In a file explorer, go to <workspace>\.metadata\.plugins\com.genesyslab.composer.diagram,
where <workspace> is your Composer workspace.

Delete the file paletteSettings.xml.

¢ Restart Composer. The Palette will be localized in your existing workspace.

Translating Diagram Properties

The diagram preferences shown below use the Eclipse GMF runtime preferences, including their
message strings. Due to limitations in Eclipse related to translating GMF Runtime, when localizing,
certain diagram preferences are not translated.

¢ Window > Preferences > Composer > Composer Diagram > Appearance
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¢ Window > Preferences > Composer > Composer Diagram > Connections
¢ Window > Preferences > Composer > Composer Diagram > Pathmaps
* Window > Preferences > Composer > Composer Diagram > Printing

e Window > Preferences > Composer > Composer Diagram > Rulers and Grid

Translating Enumeration Properties

In the Properties view, many properties of blocks are enumerations, which are collection of fixed
values, from which one is selected. Internally within Composer, a number of different dialogs, drop-
down boxes, and various other mechanisms are used to display the various enumeration properties.
The 8.1.3 release of Composer does not to enforce uniform behavior when translating enumeration
properties. As a result, some enumeration properties will appear localized, while others may not. This
has no impact on diagram validation, code generation, or runtime behaviour. It is merely the values
displayed in the Properties view that appear either translated or untranslated. The underlying code
that is generated will always be the same.

East Asian Characters

If you are using characters from an East Asian language (for example, Chinese, Japanese, Korean) in
Expression Builder, you may find that they do not display properly, and appear as squares rather
than the expected characters. The most likely cause of this issue is that the operating system font
does not support East Asian language characters. As a workaround, change the Dialog Font setting
from within Composer.

. In Composer, go to Window > Preferences.

. Select General > Appearance > Colors and Fonts.

. In the preference dialog, select Basic > Dialog Font.

1

2

3

4. Click Edit to bring up the font selection dialog.

5. Choose a font which can render East Asian languages, such as Arial Unicode MS.
6

. Click OK on the font selection dialog, then click OK on the preferences dialog.

Connection Profile and Non-ASCII Characters

Database Connection Profiles do not support non-ASCII characters. Use only ASCII characters when
creating Connection Profiles.
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Composer Compared to IRD

Here is a short video on the advantages of moving to Composer from Interaction Routing Designer as
well as an interface comparison.

Composer Compared to IRD
Link to video

Integrated Development Environment

e« Composer is a single Integrated Development Environment (IDE) for creating applications to routing
interactions as well as to orchestrate the entire customer experience. Composer-created voice and
routing applications can command and control the customer experience through all channels (IVR,

voice, e-services, and so on).

* Composer's open framework enables widely-available, existing competencies to be used to create
reusable components that manage the customer experience. The IDE allows both customers and
integrators to utilize existing code sets (HTML, VXML, java, perl, REST and others) to control the

customer experience.

e The open framework also allows simplified integration into all Enterprise applications to harness the
information within the Enterprise to drive and personalize the customer experience.

Session-Based Versus Interaction-Based

Composer works with the Orchestration Server platform, which is session-based as compared to the
Universal Routing Server (URS) platform, which is "interaction based.' A session can last for the
length of the customer journey, across multiple interactions. URS only executes strategies
(workflows) that interact on a single interaction. In contrast, ORS does not need to have an
interaction to perform useful functionality. All ORS requires is an API call in order to execute. In this
manner, the ORS platform can be thought of as a general purpose workflow platform to control the
workflow regardless of whether or not you have an interaction (email, SMS, mobile, social, voice, and

SO on).

Differences from IRD

In the past, Universal Routing's Interaction Routing Designer was the only Genesys tool to create
routing applications. Genesys Composer is now the tool of choice for creating both routing and voice

self-service applications.

A few of the differences between Composer and Interaction Routing Designer are listed below.
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e Composer is integrated with Orchestration Server allowing you to manage customer conversations
spread out over time using the ORS session-based functionality and persistent storage as well as
Orchestration Extensions.

e Composer encompasses IRD's functionality and much more routing functionality in general.

e Composer lets you create routing applications using an open language (SCXML) and ECMAScript for
decision-making. In contrast, IRD uses a closed Genesys proprietary language (IRL) and you are limited
to IRD's objects and functions.

e Composer gives the option of writing your own SCXML code and/or using predefined blocks.

e Unlike IRD, you can also use Composer to create voice self-service applications for Genesys Voice
Platform, including VoiceXML and CCXML-based applications. You can also create integrated voice and
routing applications.

e Any routing application created in IRD can easily be created in Composer.

Composer Routing Application Types

You can use Composer's predefined blocks and/or write your own SCXML code to create routing
applications that route based on various criteria such as:

* Agent, Agent Group, ACD Queue, Place, Place Group, Route Point, Skill, or Variable

* last called agent

« date and time

* the value of a statistic,

* dialed number (DNIS)

¢ originating number (ANI)

* percent and conditional routing

* Service Level Routing
The above list is by no means complete. It represents only a few types of routing applications that

can be created in Composer. Since Composer uses open languages (SCXML and ECMAScript), you are
not limited to its pre-defined blocks, but are free to create many types of routing applications.

Composer Blocks Mapped to IRD Objects

Composer refers to the fundamental element of a workflow as a block whereas in IRD documentation,
this element is referred to as an object. A few IRD object/Composer block equivalents are presented
below. The tables group IRD objects based on their IRD toolbar category name and point to the
corresponding functionality in Composer.
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Tip

For a complete list of Composer blocks, including all those without an IRD equivalent,
see RoutingBlockPaletteReference.

IRD Data & Services

IRD Object Name

Database Wizard

Web Service

IRD Miscellaneous
IRD Object Name

Assign

Multi-Assign

Call Subroutine

Entry

Exit

Error Segmentation

Function

Multi-Function

Composer Block Name

DB Data

Web Service

Web Request

Composer Block Name

Assign

Subroutine

Entry

Exit

Multiple error output ports can be
created in Composer blocks
based on each block's Exception
property.

ECMAScript

Description

DB Data retrieves information
from the database. Uses a Query
Builder.

Invokes Web Services. GET, POST
and SOAP over HTTPS are
supported.

Invoke any supported HTTP web
request or REST-style web
Service. See sample: Routing
Based on Web Request.

Description

Assigns a computed value/
expression or a literal value to a
variable. Variables are defined
in the Entry block. Capable of
multiple assignments.

Creates reusable sub-modules.

Sets global error (exception)
handlers. Defines global
variables (see Variables section
below).. All routing strategy
diagrams must start with an
Entry block.

Terminates the strategy and
returns control back to calling
workflow in case of a subroutine.

Builds an ECMAScript expression
using the Expression Builder.
Many URS functions are
available as Genesys Functional
Modules described the
Orchestration Server
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If
Multi-Attach
IRD Routing

IRD Object Name

Selection

Percentage

Default

Routing Rule

Switch to Strategy

Force Route

Statistics

IRD Segmentation

IRD Object Name

ANI

DNIS

Assign, Branching,
ECMAScriptBlock blocks all open
Expression Builder

ECMAScript

Composer Block Name

Target

Target

Default Route

Force Route

Target

Composer Block Name

Branching

Branching

Documentation Wiki Can invoke
multiple functions.

Expression Builder can be used
to create IF expressions.

Can be used for attaching data to
an interaction.

Description

Routes an interaction to a target,
which can be Agent, AgentGroup,
ACDQueue, Place, PlaceGroup,
RoutePoint, Skill, or Variable. Skill
target uses Skill Expression
Builder.

Statistics Order property in
Target block, lets you perform
percentage allocation. Also see
sample: Routing Based on
Percent Allocation.

Routes the interaction to the
default destination.

Orchestration Server 8.1 does
not support service level routing
rules.

Orchestration Server 8.1 does
not support switch to strategy
routing rules.

Not exposed as a routing rule in
Composer.

Although statistical routing rules
are not yet supported as in IRD's
Statistics routing object, users
can use the Target object
Statistic property to route based
on the value of a statistic. A
Statistics Manager and Builder let
you create your own statistics
from URS predefined statistics.

Description

See YourFirstApplication: DNIS
Routing for an example.

See Your First Application: DNIS
Routing for an example.
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Date
Day of Week

Time

Classification Segmentation

Generic

Also see Context Services Blocks.

IRD Voice Treatment

Branching
Branching

Branching

Branching

Branching

See Composer Equivalent to IRD Treatment.

IRD Multimedia

See Composer Equivalent to IRD Treatment.

IRD Outbound

See Outbound Common Blocks

Context Services

See Context Services Blocks

Business Process

See the sample: Routing Based
on Date and Time.

See the sample: Routing Based
on Date and Time.

See the sample: Routing Based
on Date and Time.

For classification segmentation,
an ECMAScript function
determines if a particular
category name or ID exists in the
array of category objects
represented by an application
variable.

Use as a decision pointin a
workflow. It enables you to
specify multiple application
routes based on a branching
condition.

See Interaction Processing Diagrams Overview and Interaction Process Diagram Blocks.

Reusable Objects

e IRD List Object: See Composer's List Object Manager.
¢ |IRD Variable List Dialog Box: See Entry block Variables property.

In contrast to IRD, which defines variables in a special dialog box outside of the strategy, Composer
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defines both workflow and Project variables.
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Getting Started with Composer

This section is your first stop for getting started with Composer. It discusses the following topics:

* Running Composer for the First Time
» Software Updates Functionality

¢ Integrating with Source Control Systems
e Composer Projects and Directories

* Working with Diagram Layouts

¢ Accessing the Editors and Templates
e Multiple User Environments

* Security Configuration

¢ Upgrading Projects/Diagrams

* Keyboard Shortcuts

¢ Default Logging

¢ |RD Functionality Included in Composer

Also see: Composer 8.1 Routing Applications User's Guide
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Running Composer for the First Time

When running Composer for the first time, check out the video Getting Started After Installation.
Composer is built on Eclipse. If you have not already done so, run Eclipse as described in the video.

Workspaces

When you run Composer, before the user interface appears, a dialog box opens with a suggested
workspace, which is a location (folder) for your projects and files in addition to any special folders
that Eclipse needs to maintain for its internal bookkeeping. The dialog box gives the option of
changing the workspace to a different location. New projects created in Composer will be created
under this workspace as subfolders. After the Composer interface opens, the Project Explorer shows
this location. You can change this location by selecting File > Switch Workspace.

¢ Genesys recommends that the workspace folder name has no spaces in its path (for
example, c:\comp81ldev). This recommendation is not required and Composer does not
enforce this. Genesys also recommends using the component version in the name to
avoid confusion during upgrades.

* When prompted for a workspace folder, do not specify parenthesis in the workspace
path.

e The workspace should not be located in a ClearCase view, as this will cause problems
accessing files later during development.

Setting Up Your Workspace

The first time you open Composer, it asks you to specify the location of your workspace. Eclipse
remembers this location and will present it for all subsequent times when you open Composer. If you
do not wish to be prompted each time for this path and plan to use the same location for all your
projects, you can check the Use this as the default and do not ask again option to skip this screen on

future launches.

Welcome Screen

When a new workspace is created for the first time, you will be taken to the Welcome screen, which
provides getting started overview topics, tutorials and links for references on the Web. The next time
you open Composer, if the Welcome screen still opens, close it by clicking the "x" on the Welcome
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tab. To go back to the Welcome screen at any time:

¢ Select Help > Welcome.

Opening Composer Perspective

Select Window > Perspective > Open Perspective > Other. All perspectives (views) available in
Eclipse are listed, including those not used by Composer. Select Composer perspective.
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Software Updates Functionality (Plugins)

You can find information on installing new software (such as for Dynamic Web Projects or updating
existing plug-ins in the Eclipse help. For example, using "update software" as search words displays
plugin topics in the Eclipse Workbench User Guide (Help > Contents).
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Search Results o : A [do = hlged oo
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2 Trfocenter N * N
usin peveipment encronmentcuge | LNNSEAllation Details forr Plug-ins
1 POE - wihat's Hewin 3.5
Workbench User Guide Yow can browse detaled wdormation about the mdisideal ghig-ms that comgose wour instalaton. Ths
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Plugin Installation Requirements

It is standard Eclipse behavior for plugins to be installed in C:\Program Files\... (i.e. the base
Composer installation directory), and NOT in the user's workspace. The installation of plugins must be
performed by an adminn user.
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Dynamic Web Projects

After you install Java EE Developer Tools plugins, you can create a Dynamic Web Project containing
pages with active content. Unlike with static Web Projects, dynamic Web Projects enable you to
create resources such as JavaServer Pages and servlets. Here's how to get started:

Composer Help >> Install New Software.

Click Add. In the resulting box, enter http://download.eclipse.org/releases/galileo/

Select it to see the available package.

Select the Web, XML, and Java EE Development Eclipse Java EE Developer Tools entry.

Install the plugins.

Restart Composer.

N o v kA w N

Create a Dynamic Web Project.

Note: Other missing project types can be similarly enabled.
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Integrating with Source Control

This section describes setup instructions for using source control with Composer. The ClearCase
source control system is supported as well as Subversion.

ClearCase Plug-in Installation

To install ClearCase plug-ins for use with Composer:

1. Install ClearCase on the machine that Composer will run on.

2. Exit Composer. If you want to print these instructions to use after closing Composer, click the Print Page
icon at the top-right of the Eclipse Help window.

3. Install the ClearCase Eclipse plug-in from IBM:

a. Get the following files from IBM's website:com.rat.cc.win32-20080131A.zip and
com.r.cc.ccrefresh.all-20061107.zip

http://www.ibm.com/developerworks/rational/library/content/03July/2500/2834/ClearCase/
clearcase_plugins.html

Note: Actual ZIP file and directory names may change as IBM continues to update the plug-ins.
These documented names are current at the time of this writing. These plug-ins are for Eclipse v3.3
and not 3.4. Even though Composer 8.1. is based on Eclipse 3.4, Genesys recommends that you
install the plug-ins listed for Eclipse 3.3.

b. Extract the two ZIP files to a location of your choosing, essentially merging the contents.
There is a duplicate file .eclipseextension in the two ZIPs; you can safely ignore that file. The
ZIP files, when extracted, create a directory structure like:

= ) eclipse
=l 155 Features
| com.ibm.rational.clearcase, coimport. feature_7.0,0,200706 126
|53 com.ibm.rational . clearcase.corefresh_7.0,0, 200611074
|5 com.rational.dearcase_7.0.0,200801514
= 153 plugins
|3 com.ibm.rational.clearcase. coimport_7.0.0, 200706126
I3 com.ibm.rational. clearcase corefresh_7.0.0,200611074
I3 com.rational clearcase. ackivities_7.0.0,200801314
|53 com.rational. dearcase. help_7.0.0,200301314
| com.rational.dearcase_7.0.0.200801314

c. If it does not already exist, create the directory ${Composer 8.1.Install}\features, where
${Composer 8.1.Install} is the installation root of your Composer 8.1 installation.For
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example, ${Composer 8.1.Install} might be C:\Program Files\GCTI\gvp\Composer
8.1

d. From the directory where the ZIP files were extracted, copy the folders in the features
directory to ${Composer 8.1.Install}\features, and copy the directories in the plugins
directory to ${Composer 8.1.Install}\plugins.

Note: Instead of dropping the extracted zip file content in these two locations, you may place the
entire (eclipse folder) extracted content in the following folder location ${Composer 8.1.Install
dir}\dropins.

4. Ensure that ClearCase capabilities are enabled.

a. Go to Window > Preferences > General > Capabilities.

b. Make sure that the Team checkbox is checked. It must be checked in order for ClearCase
MVFS Support and ClearCase SCM Adapter preference items to appear in the Preferences
window. Please note you must restart Composer to see the changes.

5. Enable MVFS Support:

a. Start Composer.
b. Select Window > Preferences > Team > ClearCase MVFS Support.

c. Click the Workspace link underMVFS Support Preferences and select the Refresh
Automatically check box.

d. Click the Apply button.
e. Click OK to close the Workspace dialog box.
f. Again, open Window > Preferences > Team > ClearCase MVFS Support and make sure

that Enable ClearCase dynamic view file system support is selected, then click OK.

6. Configure the ClearCase plug-in. Configuration can be accessed from Window > Preferences > Team
> ClearCase SCM Adapter from the tree in the left-side panel. The recommended settings are shown
in the image below:
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¥ Request Stabus information on demand oy
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(7] oK EI Cancel |

Note: You can read more about ClearCase features and working with ClearCase view from the help
topic Rational ClearCase SCM Adapter available from the Eclipse Help system. These help topics will
be available only after installing ClearCase plugins.

ClearCase Usage

To use ClearCase functionality within Composer:

1. Create a view using ClearCase Explorer, or use an existing view.

2. In Eclipse, if you don’t see the ClearCase toolbar, make the toolbar appear by clicking Window >
Customize Perspective. In the dialog box that displays, click the Commands tab, select the
ClearCase command group and click OK.
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fvvailable command groups: Menubar details: Toolbar details:
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3. Once the toolbar is available, click on the =& button.

After this, any Composer Project that resides in a ClearCase view will have the view name displayed
next to it in the Project Explorer window. Also, the icons for files and folders under source control will
show the status, such as checked out, hijacked, and so on.

Creating a Composer Project Managed by ClearCase

To create a new Composer Project that will be managed by ClearCase:
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1. Bring up the Project wizard (File > New).

2. Clear the Use default location check box and enter in the Location field a path that resides inside
your ClearCase view.

The path becomes the root of the Composer Project. Note that the files in the new project will not be
checked into ClearCase until you use the Add to Source Control function.

To add a project that is already checked into ClearCase to your Composer 8.x workspace:

1. Use the Import wizard (File > Import).
2. Select Existing Projects into Workspace.

3. In the Select root directory field, enter the path of the project residing in your ClearCase view. Check
the box corresponding to the Project name.

Important: Leave the Copy projects into workspace box unchecked. If it is checked, the imported
project will not be under ClearCase control.

To edit a file that is under source control, it must be checked out from ClearCase. After editing, it can
either be checked in to create a new source control version, or the checkout can be undone to revert
the file back to its previous version. You can also compare changes to the previous version before
checking it. All of these operations can be accessed in several alternative ways:

* Right-click the file name in Composer's Project Explorer view, and use the Team submenu.

¢ Select the file in Composer's Project Explorer view, and use the ClearCase menu on the top menubar.

¢ Select the file in Composer's Project Explorer view, and use one of the buttons on the ClearCase toolbar.
Note: If you choose to remove a ClearCase-managed Composer Project from your workspace, you
will be prompted with a Confirm Project Delete message. Genesys strongly recommends that you

choose the Do not delete contents option. This leaves the files in your ClearCase view untouched.
Otherwise, the files may be removed from source control.

Subversion Configuration

Subversion is a client-server versioning system. You can integrate Subversion with Composer in order
to have a version control over Projects. Subversion creates and maintains a repository on the Project
web server. Its clients run on Composer machines and connect to the Subversion server over the
Internet.

Note! The integration steps below are not version-specific or Composer-specific. The steps refer to
the interface and capabilities provided by the Eclipse Integrated Development Environment (IDE)
(Subclipse Team Provider plug-in) and CollabNet (CollabNet Subversion Server) products.

The recommended steps are as follows:

1. Install and Configure Subversion Server.

2. Download the Collabnet Subversion server from the website: http://www.collab.net/downloads/
subversion/
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3. Follow the installation and configuration instructions from the vendor for the operating system you are
working with. Complete registration if required. When the installation executable runs, the wizard has
an option to View Installation Information.

CollabMet Subversion Server 1.6.6 Setup O] x|

Yiew Latest Readme

ﬁil : Collabhet Subwversion Server For Windows

L 3

The latest installation inFormation is maintained and updated on
the openCollabMet web site, Click the link below to open waur
web browser and view the latest information prior ko installation.

‘Wiew inskallation information on openCaollabiet

allabiet Subyversion

Cancel |

Note: If you are running IIS on the server machine during installation of Collabnet Subversion server,
you may wish to change the Apache port to “81” instead of the default 80 to avoid conflict.

4. Follow post installation instructions from the vendor and complete Collabnet Subversion server
configuration.

5. Configure the Subversion repository. Follow the instructions provided by the vendor
(http://www.collab.net/downloads/subversion/) to define the permissions, user name, and password for
accessing the repository. Use the instructions for the specific version of the Callabnet Subversion server
that you installed in step 1.

Note: Subclipse provides an option for creating a repository, but this is more suited for personal
development where you do not need to share your code. Typically, you would set up a Subversion
server, create the repository on the server and then point Subclipse at the server.

6. Install the Subversion client using the capabilities of Eclipse by adding Subclipse to the Eclipse IDE.
Subclipse is a project to add Subversion support to the Eclipse IDE. Use Eclipse's Software Manager to
add Subclipse to our Eclipse IDE.

a. Add the Subclipse update version compatible with Subversion server installed in step 1.
b. From Composer's Help menu, choose Install New Software to open the Install wizard.

c. Select the required Subclipse update from the site: (http://subclipse.tigris.org/update_1.6.x/)
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Note: The above link may not be current. In this case, check the http://subclipse.tigris.org/ site. The
Download and Install section lists update sites for various Eclipse versions. Choose the correct site
based on the Eclipse version for Composer. Composer’s Eclipse version can be determined from Help
> About and clicking the Eclipse.org icon.

d. Click on the Download link to go to the download page. There you will find the URL to enter
into the Eclipse Install wizard.

e. Follow the wizard and instructions provided in the Help > Contents > Workbench User
Guide for installing new software.

f. Restart Composer if required by installer.

7. Create the CVN (Subversion) item in Composer menu bar. Follow the Eclipse instructions on customizing
perspectives /creating command groups (Help > Contents > Workbench User Guide > Concepts
> Perspectives > Configuring perspective command groups.

8. Define CVN repository location to your Eclipse IDE. Follow the instructions provided in Help > Contents
> Workbench User Guide > Getting Started > Team SVN Tutorial. Use the instructions for
Specifying a project location.

For more details working with CVN, please, see Help: Subclipse - Subversion Eclipse plugin.

Checkin Error

If you are using Source Control tools, checking in Composer Projects contents after a Project Upgrade
may results in an error. See Checkin Error During Source Code Integration.
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Project Types and Directories

A Composer Project is associated with either:

e A voice application for Genesys Voice Platform or

* A routing application for the Orchestration Platform.

In general, a Project consists of a predefined, structured set of files and folders that contain all
resources for the application. See the Project Explorer below.
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For information on Projects referencing other Projects, see the figure in topic Project Properties dialog
box. Expand Project References.
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Java and NET Projects

There are two types of Composer Projects:

* Java Composer Projects -- Use JSP and Java to implement custom business logic. These Projects can
be deployed on web applications servers as described in the Composer 8.1 Deployment Guide. See
Creating a New Project.

* .NET Composer Projects -- Use ASP.NET and C# to implement server-side blocks and custom business
logic. The Project can only be deployed to Microsoft IIS. See .DOTNet Troubleshooting for steps for
working with Composer .NET Projects when a machine does not have WSE 3.0:

Starting a New .NET Project

To start a new .NET Project:
1. Click the Create a NET Composer Project button in the menu bar. You can also click the button above the
Project Explorer and select Composer > Composer > Projects > .NET Composer Project.
2. In the Project dialog box, type a name for your Project.

3. If you want to save the Composer Project in your default workspace, select the Use default location
check box. If not, clear the check box, click Browse, and navigate to the location where you wish to
store the Composer Project.

4. Select the Project type.
5. Click Next.

6. If you want to use templates, expand the appropriate Project type category and select a template for
your application.

.NET Project Warning

.NET Projects may show this warning in the Console View: include\getWebServiceData.aspx(482):
warning CS0618: 'Microsoft.Web.Services3.SoapContext.Security' is obsolete:
'SoapContext.Security is obsolete. Consider deriving from SendSecurityFilter or
ReceiveSecurityFilter and creating a custom policy assertion that generates these
filters. This warning can be ignored and no workarounds are needed. It will not show up as an error
or warning in the Problems View.

.NET Project Logging

Starting with 8.1.410.14, .NET Project logging configuration is handled with file web.config located in
the Project root directory. The level of logging can be changed to values:

OFF The highest possible rank and is intended to turn off logging.

FATAL Severe errors that cause premature termination. Expect these to be immediately
visible on a status console.

ERROR Other runtime errors or unexpected conditions. Expect these to be immediately
visible on a status console.

WARN Use of deprecated APIs, poor use of API, 'almost' errors, other runtime

situations that are undesirable or
unexpected, but not necessarily "wrong". Expect these to be immediately visible on a
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status console.
INFO Interesting runtime events (startup/shutdown). Expect these to be immediately
visible on a console, so be

conservative and keep to a minimum.

DEBUG Detailed information on the flow through the system. Expect these to be written
to logs only.
TRACE More detailed information. Expect these to be written to logs only.

Voice Application Project Types

Voice applications are VoiceXML applications with full support for the Genesys Voice Platform. A Voice
application can be deployed on a web application server that meets the minimum prerequisites
described in the Composer 8.1 Deployment Guide. Also see Creating Voice Applications for GVP.

Routing Application Project Types

Routing applications are SCXML applications with full support for the modules described in the
Orchestration Developer's Guide. A Routing application can be deployed on a web application server
meeting the minimum prerequisites described in the Composer 8.1 Deployment Guide. Also see
Creating a New Routing Project.

Project Structure/Directories

A Composer Project (Java or .NET) will contain some or all of these subfolders depending on the type
of Project:

e App_Code -- .NET Composer Projects only. This folder will be empty by default as Composer bundles all
the C# classes in to the ComposerBackend.dll file. Custom C# classes will also go into this folder.

e bin -- Any libraries used in a .NET Composer Project go here.

e Callflows -- Folder for storing all the callflow diagrams (.callflow files)

* db -- Database connection.properties and .sql files are stored here.

¢ include -- Composer-provided standard include files used by Backend logic blocks.

e debugging-results -- The Run As option on a VXML file creates a debugging-results folder when no
debugging-results folder exists in the Project.

Custom JavaScript files (.js) can be included in a routing application by placing the file(s) in the
include/user folder. Re-generating code for all IPD diagrams in the project is required after placing
the files. The JavaScript functions in the specified .js file can then be used from any Workflow block
that supports writing expressions e.g. the Assign, Branching and ECMASCript blocks.

e META-INF -- Created when you create a new Java Composer Project. It is needed for Java and is included
when a .war file is exported from Composer. Do not make changes to this directory.

e WEB-INF/1ib -- Java Composer Projects only. Folder for external dependency libraries such as JAR files.
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Note: The Tomcat application server should be restarted after changing any JAR files in this folder.
e Interaction Processes -- Folder for storing all the interaction process diagrams (.ixnprocess files).
* Resources -- Folder for the audio and grammar resources.Resources/grammars -- Folder for Grammar
Builder (.gbuilder files) and GrXML files.
e Resources/grammars/<language code> -- Place language-specific grammars here (such as
en-US or es-MX folders).

e Resources/prompts -- Folder for prompts files.

e Resources/prompts/<language code> -- Place language-specific prompts here. If the
application language is changed mid-call using a Set Language block, prompts audio
resource paths in these language folders will be translated to the current language at run
time.

e Scripts -- Folder for user-written ECMAScript. Custom JavaScript files (.js) can be included in a voice
application by placing the file(s) in the Scripts folder.
* src-gen -- Folder for the code generation VXML/SCXML files.

e upgradeReports -- When migrating IRD strategies into Composer, folder for migration reports. Also
used for reports as result of upgrading Projects and diagrams.

e src -- Folder for custom code such as backend logic pages written by the user. The
ComposerPlayTreatments VXML file is located here.

¢ Workflows -- Folder for storing all the workflow diagrams (.workflow files).

Static VXML/SCXML code is generated with the name of the Composer diagram file. The code will be
saved in the src-gen folder under the current active Project. The two types of Projects have different
Project natures. Based on these Project natures, different builders, editors and preferences are
associated with the Projects. For example, .NET Composer Projects and Java Composer Projects have
different preferences for deployment since they are deployed to different web/application servers.

Project Folders and Resources

Common Project folders and resources (Resources, src, include, db, and so on) do not change
between .NET and Java Projects. Project Export and deployment procedures related resources will
differ between .NET and Java Projects (bin folder for .NET and WEB-INF, META-INF folders for Java).
For more information, see Migrating a Composer Application From Lab to Production.

Sub-Directories

Composer 8.1.440.18 adds support for sub-directories:

Feature Scope Comments

Instead of selecting direct files
from the diagram folders,

e Fieses Generate All now includes all the
folders and files recursively.
Locales Project property Project Used to update Project locales.
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Feature

Command Line Code Generation

Command Line Upgrade

Command Line Publish

Java Project Export

Debugger

Project Upgrade

SubModule handling

New callflow/workflow file
creation

Scope

Project

Project

Project

Project

Diagram

Project

Diagram

Project

Comments

Now includes all the folders and
files recursively.

Used to generate code for all the
diagrams. Now includes all the
folders and files recursively.

Used to upgrade callflow,
workflow, and IPD diagram files.
Now includes all the folders and
files recursively.

Used to publish all IPD files. Now
includes all the folders and files
recursively.

Used to generate code while
exporting WAR files. Now
includes all the folders and files
recursively.

Includes all the folders and files
recursively for code generation
during debugging.

Used to upgrade callflow,
workflow, and IPD diagram files.
Now includes all the folders and
files recursively.

Used to find the sub-module
diagram when using auto-
synchronization of parameters.

Allows you to create new
callflow/workflow files under the
selected sub-directories (right-
click and New > Other >
Composer > Diagrams).
Previously, it was created only
under the callflows or workflows
directory.

Folders Created When Upgrading Projects and Diagrams

The following additional folders may also be created in the Project Explorer:

e When upgrading to 8.1, a Project upgrade creates the folder . /WEB-INF/1ib, copies files from ./1ib to
./WEB-INF/1lib, then removes the ./1ib folder from the Java Composer Project.

e archive -- For placing zipped original contents of the Composer Project (created during an upgrade).

e upgradeReports -- For upgrade reports (created during an upgrade).
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Adding Files to an Existing Project

Composer recommends adding files (i.e., a prompts audio file) to an existing Project within Composer
using the following methods:
¢ Use the File > Import capability.

e Add directly from Windows Explorer and then refresh the resource list by pressing F5 in Composer’s
Project Explorer.

e Drag and drop files onto Composer’s Project Explorer.

For out of sync files, please see troubleshooting topic Workspace Files Not in Sync.

Project Permissions

Composer Project upgrade and code generation processes need current\launching user WRITE
permission to the Composer Project Directories and Files. If you move Projects between Windows and
OS X, these considerations may apply:

WRITE permission:

In Windows 7 OS, Projects created using Mac OS needs Effective Permission to be set. To do that:

1. Open Windows Explorer and browse to Composer Project directory.

2. Right Click the Project folder and select the Properties option to open the properties dialog.

3. Select the Security tab and click the Advanced button.

4. In the Advanced properties dialog, select the Effective Permissions tab.

5. In the Effective Permissions tab, select the current User / Groups to grant Full Permission.

Also uncheck the Read-only and Hidden properties in the General tab for the Project and sub
directories. Note: While importing Composer Projects, if the Copy Projects into Workspace option

is selected, the above mentioned permissions needs to be set for the copied Project directory
separately.

Using Composer Shared Subroutines

Typically subroutines are a part of the Project in which other diagrams call them. This makes the
project self-contained that can be deployed as a unit with minimum dependencies on other Projects.
However, in some cases subroutines may be used by multiple Projects but are required to be present
in only one location in the workspace. This need for residing in a single Project within the workspace
is usually governed by the need to deploy to all subroutines to a single location from where these
subroutines may be referenced by multiple applications - similar to how a service is exposed. It is
recommended that subroutines be a part of the Project they are consumed in and to enable this
"sharing" via an SCM system (e.g., symbolic links in ClearCase; other system will support this
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capability differently). If that is not an option, subroutines in Composer can be placed into a
"common" Project, so that multiple other Projects can access and reuse them. NOTE: In order to
support the URL substitution from the "$$" tokens, this feature requires Orchestration Server version
8.1.300.27 and above.

In our example, we will create two Projects:

¢ CommonProject - the Project containing subroutines

e MainProject - the Project containing the main diagrams, which will use the subroutines in

CommonProject

T, = = -

(4 Project Explorer £3 S =3 = |m
> 7% CommonProject

» 7% MainProject

After subroutines have been created in CommonProject, MainProject must be set to reference
CommonProject. This means that MainProject can use the subroutines files in CommonProject.

To do this, open the Project properties page of MainProject by right-clicking and selecting
Properties. Select the Project References page on the left-hand side, and enable the checkbox for
CommonProject:
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eno ... PropertiesforMa A— N—
type filter taxt Project References Sv Lvw
¥ Resouroe

Buitders Projects may refer to other projects in the workspace.

Code Ceneration Made Use this page to specify what other projects are referenced by the project.
Default Legging i

ICM Suppaort Praject references for ‘MainPraject”

Locales o {5 CommenPrejea

Praject Facets

Project Properties

Project References

Prarmpt Management
Refactoring Histary
Reset IPD Publish Informatic
Run/Debug Settings
Server
I Task Repository
Task Tags
Tomcat Deployment
FYalkdation

@ [ ame | ok

In a callflow in MainProject, you can create a Subdialog block which uses a Subcallflow diagram in
CommonProject:
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Debug and Release Modes

When using shared subroutines, it may be helpful to separate the development process from the final
deployed application. During the development process, it is assumed that CommonProject resides in
the same Workspace as MainProject. However, in a production environment, a more complex

service may be needed to host subroutines.

Composer supports the concept of Debug and Release mode code generation. Using this mode flag,
the same Project can generate different code suitable for specific tasks.

Debug and Release mode can be set by Project properties dialog:

Composer Help

82



Getting Started with Composer

- NaNs) Properties for MainProject
type filter text Code Generation Mode L= . -
F Resource
Builders Composer projects can be set to Debug or Release mode. The setting will
Code Ceneration Mode affect the eode generated from the diagrams in the project. Debug mode
Default Logging is intended for code that will be run in a development testing
ICM SUSport emdronment, and Release mede |5 Intended for production envirgnments,
Locales
Project Facets

Praject Properties Code Generation Mode | Debug = |

Project References
Prompt Management
Refactoring Histoery
Reset IPD Publish Informatic
Run/Debisg Settings
Server
¥ Task Repository
Task Tags.
Tomcat Deployment
Fvalidation

|_Restore Defaults | | Apply |

@ [ canes | [om

To apply Release Mode to shared subroutines development, open the Properties view of the
Subdialog block in the the callflow for MainProject. Enable the Show Advanced Properties option:

1 Properties &% mE ™M Y=n [
™ New Properties View |
i Subdialog v & Show Categories '

Model PROPOALY — Show Advanced Properties

Appearance | "-“‘:‘erm Configure Columns... |
=# Pin to Selection
n ——

This will reveal a Release Mode URI property:

¥ Location
Method FEget
Release Mode Uri W http:/ (5 SSUBROUTINE SERVICES S fsubroutines /S SSUBROUTINE VERSIONSS
Tyoe EiE Project File
Ui g

Note that any token delimited by “$$” in this property can be substituted at runtime.

Once the Application is ready to deploy, set the Code Generate Mode of the Project to Release.
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This will generate code that uses the Release Mode URI property value.

Project Properties

Selecting Properties from the Project menu opens a dialog box showing the properties of the
selected Project or of the Project that contains the selected resource.
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Project Properties

Right-click a Project and select Properties to bring up a dialog box where you can view/update

various Project properties. This topic describes the various Project Properties pages. For more help on

each property, select the property and press F1. A help view appears on the right.

Resource

@ Properties for RouteExtlavaComposerProject

Project Properties
Project References
Prompt Management
Reset IPD Publish Information O Other: Windows -
Runy/Debug Settings
Server

» Task Repository
Task Tags
Tomcat Deployment

» Validation
WikiText

Mews toxt file line delirmiter
(®) Inhgrited from container (Windows)

®

type filter text Resource
» [Resource Path: fRouteExtiavaComposerPraject
Builders _ i .
Code Generation Mode . . . .
Composer Callflow Opti Location: ChUsers\bonniemyworkspace' RouteExtlavaComposerProject
i L:;;_'ngw FenE Last modified: January 17, 2017 at 11:41:56 AM
Ll
ICM Support Text file encoding
Locales (®) Inherited from container (UTF-8)
Orchestration Options O Other:  UTF-8
Project Facets [ stere the encoding of derived resources separately

The Resource page contains general information on the selected Project. For information on UTF-8,

see the VXML File Preferences topic.
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Builders

@ Properties for RouteExtlavaComposerProject O X

type filter text Builders PYD Y

Builders
Code Generation Mod
Composer Callflow O :
Default Logging Import...
ICM Support -
Locales
Orchestration Options Remove
Project Facets
Project Properties
Project References
Prompt Management Down
Reset IPD Publish Infoi
Run/Debug Settings

> Task Repository

Task Taas
< >

Configure the builders for the project:

I s Java Composer Project Builder | New...

Edit...

Up

@ 0K Cancel

The Builders page indicates the Project type, It indicates whether the Project is a Java Composer
Project, a .NET Composer Project, or another type of Project.
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Code Generation Mode

@ Properties for RouteExtlavaComposerProject O bt
type filter text Code Generation Mode Qv
» Resource -~

Composer projects can be set to Debug or

Bullders Release mode. The setting will affect the code
Code Generation Mode generated from the diagrams in the project.
Composer Callflow Optio Debug mode is intended for code that will be run
Default Logging in a development testing environment, and

ICM Support Release mode is intended for production

Locales environments.

Orchestration Options

Project Facets Code Generation Mode Debug  ~

Project Properties

Project References
Prompt Management
Reset IPD Publish Inform:

Run/Debug Settings
< il 3 Restore Defaults Apply
@ oK | Cancel

Used to determine whether a Project will be used in a production or development environment. See
the Debug and Release Modes topic.
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Composer Callflow Options

@ Properties for RouteExtlavaComposerProject O >
Composer Callflow Options hd ™
+ Resource " Use Initialize GVPSessionID option to lookup
Builders

. x-genesys-gvp-session-id value from sip.headers Session variable,
Code Generation Mode otherwise userData Session variable will be used during VoiceXML
Composer Callflow Optio code generation. If this option is changed, code generation is

Default Logging required for the Callflow diagram files.

ICM Support

Locales Initialize GVPSessionlD variable from sip.headers Session Variable
Crchestration Options

Project Facets

Project Properties

Project References
Prompt Management
Reset IPD Publish Inform:

Run/Debug Settings
. b
; Task Repository . Restore Defaults Apply
@ oK | Cancel

See the GVP SessionlD System Variable topic.
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ICM Support

Code Generation Mod
Composer Callflow Of
Default Logging
1CM Support
Locales
Crchestration Options
Project Facets
Praject Properties
Project Referonces
Prompt Management
Reset D Publish Infon
Ruin/Debug Settings
» Task Repository
Task Tags
Tomcat Deployment
* Validation e
L4 >

@

8] Properties for RouteExtlavaComposerPraject O X
type filker text ICM Support LW o
’ ::::? ICM Support can be enabled at a project level. If enabled, ICM variables will be made available te the voice application

[] Enable 1CM

: Restore Defaults.

Apply

Cancel

See the ICM Interaction Data Block topic.
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Default Logging

18] Properties for IntegloadBallwvaComposerProject O 4
type filber teat Delault Logging Gw L owow

» Resource
Builders
Code Generation Mode Vedoe Default Log Level
Cemposer Callflow Options
Default Logging
ICM Suppost Assign Block
R [Log Assign block Variable assignments
Orchestration Options 1f emabled, Assign blocks will grint the variable assignments in platform logs.
FrErbisces If changed. code generation is required for the projoct.

Praoject Properties

Praject References

Prompt Management

Reset IPD Publish Informatio
Run/Debug Settings

Server

* Task Repository
Task Tags
Tomeat Deployment

» Validation

WikiText
€ Y Restore Defaults Apply

0 =

See the Assign Common Block topic.

The value selected here will be used in blocks where the Log Level is set to Progect Default.

Routing Defautt Log Level
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Locales
] Properties for RouteExtlavaComposerProject O )4
Locales S
» Resource
Builders Project Locales
Code Generation | To set active locales use the checkboxes next to the locale items.
Composer Callfloy To set the primary default locale, highlight an item and click the "Set As Default’ button.
Default Logging | Lix
:":;;:"p"“ 1 English - United States (en-US) ~
nchestration it 1@ Arabic - Jordan (ar-10)
Br '::-‘.; Fal:::t: v 1@ Basque - Basque (eu-ES)
o0,
, _ [ Bengali - India (bn-IN)
Project Properties
Project References 19 Cantonese - Hong Kong (en-HK)

[19 Catalan - Spain (ca-ES)

Prompt Managerr _ %3 Add Custom
Reset IPD Publish 1@ Chinese - China (Simplified Chinese) (zh-CN) :
Run/Debug Settin M@ Chinese - Hong Kong SAR (zh-HK) ¥ Delete Custom
Server 1@ Chinese - Taiwan (Traditional Chinese) (zh-TW)
» Task Repository 19 Czech - Czech Republic (es-CZ)
Task Tags 1% Danish - Denmark (da-DK)
Tomcat Deployme 1@ Dutch - Belgium (nl-BE)
» Walidation 1@ Dutch - The Netherlands (nl-ML)
Wik Tenct L1 Canlink Asistentin fam ALT i |
2 Set As Default

Select existing Composer diagrams to update with the default locale language: :Diﬂgram Selectio
< » L4 2

@ Cancel

See the Locales topic.
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Orchestration Options

8 Properties for RouteExtlavaComposerProject [ >
type filter text Orchesfration Oplions LT T
d Fte?nurce Transitioning on events L)

Culkcur Use external events

Code Generation Mode - }

Compaser Callfiow Optio Use external events for transitioning out of ECMAScript based blocks. A new

Default Logging external event e.g. interaction.deleted is processed after all internal events

generated as a result of the previous external event have been processed.

ICM Support Therefore using internal events for this setting, depending on the number of

Locales ECMAScript based blocks in the application, may result in new external events not

Orchestration Options being processed in a timely manner. By default this option is checked. If changed,

Project Facets code generation is required for the praject.

Project Properties

Start Workflow Application (Voice Interaction)
[] start Waorkflow SCOML application on interaction.onroutereguest event

If this opion is enabled, IPD diagram will start Workflow SCXML application on receiving ‘interac
fior Vioice interactions, else ‘interaction.added’ is used for regular Vioice calls and ‘interaction.attac

Project References
Prompt Management
Resat IPD Publish Informa

Run/Debug Settings
» Task Repository Mote: This option should not be enabled for Multimedia (non-Voice) interactions.
Tesk Tags Change in option requires Code generation for all the IPD diagram files in this Project.
Tomcat Deplayment Single Session Treatrment
» Validation . .
WikiTeat [Juse single GVP session to execute treatrments
1
¢ Mumber of wait treatrment executions by GVP before the next treatment request &0
(Total GVP wait timeout = gvp_Wait_Treatment_Timeout * no of wait treatment executions)
Multimedia processing
Use Interaction Submitters
If this option is enabled, Composer publishes some Interaction Submitter scripts
to the configuration to deal with multimedia interactions, This is supported anly
with ORS 8.1.4 or higher.
Interaction Detach
(®) Use Platform () Use Application
If ‘Use Platform’ option is selected 'Detach’ property Blocks will generate "detach’ w
< » £ >

o o

Orchestration Options topic.

See the
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Project Facets

E Properties for RouteExtlavaComposerPraject O b4
type filker text Project Facets i T
* Resource

: This praject is not configured to use project facets. Converting this project to faceted form will allow
Builders you to easily control the available technolagies.

Code Generation [ Gonvert to faceted fonm..
Composer Callfloy

Default Logging
ICM Support
Locales
Orchestration Opt
Project Facets
Project Properties
Project References
Prompt Managernr
Reset IPD Publish
Run/Debug Settin
Server

» Task Repository
Task Tags
Tomcat Deployime

» Walidation
WikiText

£ 3 Revert Apply

@ [ ok ]I cone
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Project Properties

E Properties for RouteExtlavaComposerPraject O b4

type filter text Project Properlies i
* Resource
Builders

Code Generation [ Project Details
Composer Callfloy Project Name: RouteExtlavaComposerProject Composer Project Version: 8.1.440.01

Default Logging | pyoiact Type: Java User Project Version:  0.0.0
ICM Support

Locales

Orchestration Opt
Project Facets Timestamp Projec.. User V.. Action User  Com.. Host OS

Project Properties 177 . 8144 Project C... wlan0... wi...
Project References
Prompt Managernr
Reset IPD Publish
Run/Debug Settin
Server

» Task Repository
Task Tags
Tomcat Deployime

» Validation
WikiText

€ » Restore Defaults Apply

@ [ ok ]I cone

See the Project Properties section of the Project Menu topic.

Project properties

Project History
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Project References

ﬂ Properties for RouteExtlavaComposerPraject _

type filter text Project References 2w S

* Resource Projects may refer to other projects in the workspace.

Builders Use this page to specify what other projects are referenced by the project.
Code Generation [

Composer Callfloy | Project references for 'RouteExtlavaComposerProject”
Default Logging
ICM Support
Locales
Orchestration Opt
Project Facets
Project Properties
Project References
Prompt Managernr
Reset IPD Publish
Run/Debug Settin
Server

» Task Repository
Task Tags
Tomcat Deployime

» Walidation
WikiText

m 8 AssignDotNetCoampaoserProject
[N IntegloadBallavaComposerProject
M= RemoteSystemsTempFiles

L4 >

@ [ ok ]I cone

Use when a Project refers to other Projects in the workspace.

Prompt Management

Use this dialog box to configure the recording of prompts and to enable dynamic prompts.

Recording Prompts

See the Recording Prompts topic.

Enabling Dynamic Prompts

Starting with 8.1.440.18, Composer provides support to optionally include dynamic prompts
supporting JavaScript files in the generated VoiceXML. Use the Enable Dynamic Prompts property
in the Prompt Management page to enable or disable dynamic prompts. If enabled (default), use of
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dynamic prompt options in the Prompt or other blocks will be validated during code generation. If
disabled, callflow diagram code generation will exclude the Javascript files related to the dynamic and
custom Prompts (including locale JavaScript files).

type filter text

» Resource
Builders
Code Generatic
Compaser Call
Default Loggin
ICM Support
Locales
Orchestration (
Project Facets
Project Propert
Project Referen
Prompt Manac
Reset IPD Publ

< >

@

Properties for IntegLoadBallavaComposerProject [m] b4

™

W

Prompt Management S

Prompts Manager - Recorder

File Type: WAY -
Encoding: ULAW
[Orynamic Prompts

Enable Dynamic Prompts

If disabled, Callflow Diagram code generation will exclude the Javascript files related to Dynamic and Custom Prompts (including locale js files)

o

For information on dynamic prompts, see:

¢ GVP 8.1 VoiceXML Help

¢ GVP 8.1 Legacy Genesys VoiceXML 2.1 Reference Manual
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Reset IPD Publish Information

18] Properties for RouteExtlavaComposerProject O *
type filter text Reset IPD Publish Information e il
ICM Support ~ _ i o N
Local You can reset the publish information of the IPDs in this project here.
ocales

Do this if there is a conflict with the existing objects in the configuration server.

QOrchestration Options After resetting the publish infarmation, you should also rename the blocks

Project Facets in the diagram before republishing.
Project Properties
Praoject References Reset IPD Publish Information

Prompt Management
Reset IPD Publish Infor
Run/Debug Settings

» Task Repository
Task Tags
Tomecat Deployment

» Validaticn
WikiText

< 3 Restore Defaults Apply

@ oK | Cancel

See the Publishing Updates topic.
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Run Debug Settings

@ Properties for RouteExtlavaComposerProject O X

| Run/Debug Settings =R
> Resource |
Builders
Code Generation Maode
Compaoser Callflow Optioi

This page allows you to manage launch configurations associated
with the currently selected resource.

Launch configurations for 'RouteExtlavaComposerProject”:

Default Logging New...
ICM Support Duplicate
Locales

Orchestration Options Edit..
Project Facets Delete

Project Properties
Project References
Prompt Management
Reset IPD Publish Informa
Run/Debug Settings

» Task Repository

Task Tags
Tomcat Deployment
> Validation
WikiText .
< 3  Restore Defaults | Apply
@ OK _ Cancel

See the Debugging Routing Applications topic.
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Task Repository

@ Properties for RouteExtlavaComposerProject O X
type filter text . Task Repository B e
> Resource ' .

Select a task repository to associate with this project below:

]_lﬂa. Local
I10; Eclipse.org

Builders
Code Generation Mode
Compaoser Callflow Optioi
Default Logging
ICM Support
Locales
Orchestration Options
Project Facets
Project Properties
Project References
Prompt Management
Reset IPD Publish Informa
Run/Debug Settings

» Task Repository
Task Tags
Tomcat Deployment

» Validation
WikiText

< >

:Add Task Haepositnry...:

@ OK Cancel
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Task Tags

ﬂ Properties for RouteExtlavaComposerProject

:type filter text Task Tags

» Resource
Builders
Code Generation Mode
Composer Callflow Optio
Default Logging

Task Tags Filters

ICM Support Tags in comments

indicat

[_| Enable project specific settings  Configure Workspace Settings...

Enable searching for Task Tags

ng Tasks

Locales Tag
Orchestration Options TODO
Project Facets FIXME
Project Properties WHK
Project References
Prompt Management
Reset IPD Publish Informa
Run/Debug Settings

» Task Repository
Task Tags
Tomcat Deployment

» Validation
WikiText

Priority
Mormal
High

MNormal

_ Edit... _

Bemove

£ >

@

OK

Cancel

Use to specify or add a Task Repository.

Composer Help

100



Getting Started with Composer

Tomcat Deployment

ﬂ Properties for RouteExtJavaComposerProject O X

|| \ Tomcat Deployment Sy Doy o
Code Generation Mod A

Composer Callflow Op

@ Unable to check deployment status. Please ensure that Tomcat is started, and that the Tomcat Preferences are set corre

Default Logging
ICM Support Deploy
Locales Undeploy
Orchestration Options
Project Facets

Project Properties
Project References
Prompt Management
Reset IPD Publish Infor
Run/Debug Settings
Task Repository

w

Task Tags

Tomcat Deployment
» Validation

WikiText v | Restore Defaults || Apply
< > < >

@ | oK | | Cancel

See the Testing your Application topic.
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Validation
E Properties for RouteExtlavaComposerProject O X
type filter text Validation SSEEISAT
Re
’ Isnurce [] Enable project specific settings nfigur r in
Builders
Code Generation Mode Suspend all validators
Composer Callflow Optior | Add Validation Builder to project
Default Logging
ICM Support The selected validators will run when validation is performed:
Locales Validator Manual Build Settings
Orchestration Options Composer Validator = =
Projacibace: DTD Validator - 2|
PipjecHTapertss HTML Syntax Validator = - o
:ru_ject R:EMCES ISP Content Validator = = =
RIS anagement Tag Library Descriptor Vali.. = = =
Reset IPD Publish Informa i
X WSDIL Validator ¥ w &
Fun/Debug Settings i
: W5-I Message Validator = o
» Task Repositary
XML Schema Validator = = pid
Rekings XML Valid =
Tomcat Deployment a_' B
> Validation XSL Validator = o =
WikiText
Epable All| Disable All
< 51 | . Restore Defaults {| Apply
@ [ o ]| conce

See the Validation topic.
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WikiText
@] Properties for RouteExtlavaComposerProject O X
type filter text WikiText U SR Y

Code Generation Mod A Configure WikiText properties for your project

Composer Callflow O |:| Enable validation

Default Logging
ICM Support
Locales
Orchestration Options
Project Facets
Project Properties
Project References
Prompt Management
Reset IPD Publish Infor
Run/Debug Settings
Task Repository
Task Tags
Tomcat Deployment
» Validation

WikiText W
< >

'

Restore Defaults Apply

@ oK Cancel

Selecting Enable validation causes WikiText to validate wiki markup files in your project. This is
done as part of the Project build process, so it helps to have automatic building enabled (Preferences
>Workspace >Build Automatically). Validation is performed on all resources that match a wiki markup
file extension. In addition, validation includes any files for which the markup language setting was
set, even if the file does not have a registered wiki markup file extension.
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Multiple User Environments

When more than one Composer user attempts to log into the same Workspace, the following
message appears: Workspace in use or cannot be created, choose a different one.
Whenever Composer uses a Workspace, it locks the Workspace so other Composer instances cannot
access it. A Workspace is meant to be a "private" development area, until the developer decides to
share it with the team. It is not possible to share a single Workspace among multiple users, so you
need to set up (private) workspaces for each developer. To merge the work of different developers
together, use source control, which could be be SVN (Subversion), Git, or something else. This is the
best way to manage a Composer Project with multiple users working simultaneously on it, and
prevent the developers from interferring with each other's work.

You could consider the Subversion plugin in Composer as a connector to source countrol like SVN. To
install the Subversion plugin, see Software Updates Functionality (Plugins). Continuing with this
example, once the Subversion plugin is installed, the Project can be shared using source control.
When you right-click on a Project, you will find all the relevant options under the Team menu. For the
first time, a Project needs to be shared with source control. After this, there will be options on the
Team menu.
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Security Configuration

You have the option of configuring:

e A secure Transport Layer Security (TLS) connection between Composer and Universal Contact Server
(UCS) during application design when connecting to Context Services.

e A secure TLS connection when connecting to Configuration Server during design time.
You can also configure:

e A security banner that displays when users establish a Configuration Server connection.

¢ An inactivity timeout. If a Composer user has authenticated with Configuration Server, Composer times
out after a configurable number of minutes of inactivity.

¢ Both certificate-based and key-based authentication.

For information on configuring the above features, see the Genesys Security Deployment Guide.
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Upgrading Projects and Diagrams

When deciding whether to upgrade, consult the Composer 8.1.x Release Note for a summary of new
features and other updates.

Composer does not support upgrading diagram files from 8.0.4 versions to 8.1.2 or
higher versions. If a callflow/workflow diagram upgrade is required, first upgrade the
Projects to 8.1.1 versions and then upgrade to 8.1.2 or higher versions.

Project Upgrade Report

Introduced in 8.1.400.33. Whenever a Project is imported into the workspace as part of the process of
upgrading to a newer version, you must perform a Project Upgrade. Composer applications will not
work or work unpredictably unless the Project is successfully upgraded. Right-click the Project and
select Upgrade Composer Project. After the upgrade completes, a Project Upgrade report appears
in the design area. An example is shown below.
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Project Upgrade Report
Project Details
Project Name MyRouteAfterAutoResponse  |Project Type
Project Version 8.1.420.12 |Cumpnser IP version
Project Location: C:\Users\bonniem\workspace\MyRouteAfterAutoResponse
Upgrading Project contents From 8.1.420.12 To 8.1.430.02

Changes Details

[+] Project Changes

[+] RouteToAgentWithAutoResponse.workflow
[+] RouteToAgent.ixnprocess

[+] percent.workflow

[+] default.workflow

[+] ProcessAgentReply.workflow
' yarade has Jleted success

Important

Other than when pooling reusable subflows, accessing system resources (include/jsp)
across Projects is not supported.

Java Composer Projects

Java Composer Projects were referred to as Java Voice projects in earlier versions of Composer, such
as Composer Voice. While working with the current version of Composer, an upgrade is required for a
previously-created Composer Project and Project diagrams. If you simply copy diagrams into a new
Composer Project instead of upgrading the Project itself, then you must use the diagram upgrade
procedure as described below. Genesys recommends that you create a dedicated workspace for 8.1
Projects and do not reuse the previously created workspace. This will provide a clean separation
between the two versions as well as ensure that a backup copy is preserved for later reference or
rollback.

Composer Help 107


https://docs.genesys.com/Documentation/IW/8.1.4/Help/BestPractices

Getting Started with Composer

Upgrade Summary

A summary of the Composer diagram upgrade process is as follows:

1. Obtain Composer 8.1 through Genesys Technical Support.
2. Uninstall the older version of Composer. Before uninstalling the older version of Composer:

* Make a copy of your Composer workspace folder (which contains all your Project files), as your
workspace may be deleted if it is located under the installation directory (C:\Program Files\GCTI\
Composer 8.1\workspace).

e Uninstall the older version of Composer.

w

Install Composer 8.1.

P

Upgrade at a Project level or at the Diagram level as described below.

Routing Upgrade Limitations

See IRD To Composer Migration Guide.

Project Upgrades

A Project-level upgrade will automatically apply diagram-level upgrades for all the diagram files
directly residing within the diagram (Callflows or Workflows) folder. As part of the upgrade process,
Composer makes a back-up of the Project and its files, which are saved under the archived folder; for
example: ./JavaComposerProject/archive/JavaComposerProject20100809184446388.zip

Note: If you are using your previous Workspace, importing Projects is not required. For a new
Workspace folder, Projects have to be imported.

To upgrade a Project when using a new Workspace folder:
1. Import an old Composer Project into Composer's Project Explorer view. From the menu, select File >
Import.
In the Import dialog, navigate to General and double-click Existing Projects into Workspace.
Browse to the Composer Project location and select the Project(s).
Mark the checkbox Copy projects into workspace.
Click Finish.
In the Project Explorer, select the imported project and type F5 to refresh.

Right-click the imported Project and select Upgrade Composer Project from the context menu.

© N o v A~ W N

If the Project is upgraded, a message appears indicating that it is the current version. Otherwise, a
prompt appears asking if you would like to upgrade this Project. Click the Yes button to start the
upgrade process.
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9. View the upgrade report. Once the upgrade process is complete, Composer displays a report. The report
is located in the Reports folder of the Project; for example:C:\Work\Templ\Gate3IPTest\Reports\
UpgradeReport Gate3IPTest20090513155840979.html

Project Version Validation

Starting with Release 8.1.410.14, Composer validates the Project version during the Generate All
and Upgrade Project operations. Projects of a version lower than installed version are validated to
upgrade before continuing with these operations. Projects of a version higher than the installed
version are not allowed to proceed with these operations.

Example Scenarios

Scenario #1

* Create A JAVA/.NET Project in any older version of Composer.
e Uninstall the older version and install Composer 8.1.410.xx.
e Open Eclipse and import the Project.

e Right click the Project and select Generate All. The Finish button is disabled state. The Generate All
dialog shows Project is not up-to-date, upgrade the Project and then Generate Code. The
error message is Project version is not up-to-date. Project version should match the
Composer IP version.

Scenario #2

e Create A JAVA/.NET Project in any older version of Composer.
¢ Uninstall the older version and install Composer 8.1.410.xx.
¢ Open Eclipse, select the Project menu from the menu bar and select Build Automatically.

¢ Import the Project and open the Problems view. A warning message appears: The diagram version
is not up-to-date. Consider upgrading the diagram or the enclosing Project.

Scenario #3

* Create a JAVA/.NET Project in Composer 8.1.410.xx.
¢ Uninstall 8.1.410.xx and install an earlier Composer 8.1.410.xx version.

* Open Eclipse and perform a Generate All or Upgrade Project. A warning message appears:
Mismatched project version or Project version is higher than IP version.

Workbench Project builds will validate Project versions and show any error in the Problems View.

Intra Version Upgrades

Starting with Release 8.1.400.33, Composer Project and Diagram upgrades between minor versions
are now supported (for example, 8.1.400.26 to 8.1.400.32). This enables upgrading diagrams to the
IP version from both the major and minor versions. An intra-version upgrade for an IPD diagram to
the 8.1.400.33 version works as follows:
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1. IPD events are categorized to media-specific sets to improve the interaction handling. Please check the
Events property for more details on this and the items below.

1. The pre-defined sets are non-editable: Voice, Multimedia, and Ixn-less processing.
1. A Custom category can be used for customizing the events.

1. If Events were customized, an upgrade from 8.1.301.01 versions and later would use the Custom
category. Older versions will be chosen to one of the pre-defined sets based on the media-specific
blocks used in the IPD diagram.

1. If Events are not customized, one of the predefined sets will be selected upon an upgrade.
1. Using the pre-defined sets provides improved future upgrades.

1. In the case where a Composer upgrade overwrites any custom changes, use the Load Last Revision
option in the Events dialog to reload the selected event to the last revision. This is applicable only for
the Custom category.

Upgrade Error Message

After a Composer Project upgrade, the Project Upgrade Report may display the following error
message: error while updating the .studio config.properties. In this case, permissions for
.studio config.properties may be read-only or hidden. To resolve this issue, go to the file system
and check for the studio config.properties file located under the Composer Project directory. Set
the file permissions so that the read-only and hidden file attributes are disabled/unchecked. Hint: To
find where the current Project directory is located, do the following:

1. Go to Composer's Project Explorer view.
2. Right-click the Composer Project.

3. From the shortcut menu, select Properties > Resource and look for Location., for example, Location:
C:\Program Files\GCTI\Composer 8.1\workspace\JavaComposerProject

Tip

While upgrading Composer 812 projects to higher versions, if you encounter the error,
The project is corrupted or version higher than the IP version. Project cannot be
upgraded., check the .studio_config.properties file for unwanted timestamp texts
and remove them. The .studio_config.properties file must not have multiple lines
and any extra characters and must only contain the following:
createdVersion=8.1.2xx.xx.
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Diagram File Upgrade

Composer does not support upgrading diagram files from 8.0.4 versions to 8.1.2 or
higher versions. If a diagram upgrade is required. first upgrade the Projects to 8.1.1
versions and then upgrade to 8.1.2 or higher versions.

In Composer 8.0.2 and later, diagrams for voice applications are called callflow diagrams whereas in
earlier versions of Composer they were called studio_diagrams. Follow the steps below if you have
only copied older diagram files to a current version of Composer Project (or to an already upgraded
Composer Project).

1.

In Composer's Project Explorer, select the Project destination folder to where you want the files to be
imported, such as the Callflows or Workflows Project folder.

. Right-click and select Import.
. In the Import wizard, select the diagram files to import.

. After the import operation completes, right-click the imported diagram file and select the upgrade

option: Upgrade Callflow Diagram or Upgrade Workflow Diagram.

Changes as a Result of Upgrading

It is important to note the following:

¢ When upgrading to 8.1.1, references to internal variable names may have to be edited manually. See

Variables Project and Workflow, Internal Variables Naming for details and examples. It is recommended
that internal variables such as DB Data block database result variables not be used; instead, create
User variables to store these results.

A Project upgrade does not upgrade any custom blocks. When Composer is launched, it checks if any
custom blocks need upgrading and upgrades them. There are no manual steps involved.

When upgrading to 8.0.4/8.1, Project upgrading creates the folder . /WEB-INF/1ib, copies files from
./1lib to ./WEB-INF/1lib, then removes the ./1ib folder from the Java Composer Project.

When upgrading from 8.0.2, the Entry block variable _COMPOSER _WSSTUBBING is
renamedCOMPOSER WSSTUBBING.

When upgrading from 8.0.1 to 8.0.2, the Studio Diagram file extension changes from .studio_diagram
to .callflow. For example: MyDiagram.studio diagram changes to MyDiagram.callflow.

To avoid any resulting file name conflict, the diagram upgrade will append a timestamp to the file name
only if a .callflow file with the same file name already exists in the same folder; for example:
Main 2010 02 19 123010.callflow. The Timestamp is of the following format: yyyy MM_dd_HHmmss

Starting with 8.0.2, the following callflow blocks contain a mandatory Output Result property: Menu, DB
Input, Grammar Menu, Input, Get Access Number, Transfer, Statistics and Record. You supply this
property by selecting a variable. Since this property is mandatory; if not supplied, an error occurs in the
Problems View when validating the callflow.
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e Upgrading to 8.0.2 or higher automatically populates this variable. For example, if the block is a Menu
block and the block's name is Main_Menu, upgrading will add a Main_Menu variable to the Entry block
(as if you added it manually) and will set the Output Results property to this variable.

¢ The GVP Next Generation Interpreter does not support the error.badfetch.badxmipage event. If
upgrading a callflow application from an earlier version that listed this event under Supported in its
Entry block Exceptions dialog box, you will need to modify that Entry block by removing that event
under Supported in the Exceptions dialog box.

e Composer workflow and callflow diagrams do not directly store diagram grid information. This
preference is workspace-specific. If you are using a new workspace, you can set this value prior to
upgrading Projects and diagrams so that the grid information does not change during the upgrade

process.

Note: Workspace preferences can be exported and imported from File > Export or Import >

General - Preferences.

Command Line Code Generation

A command line option is available in Composer to generate code for all diagrams for all Projects in a

Workspace.

eclipse.exe -application com.genesyslab.composer.voice.generator.commandline.app

-nosplash -console -consoleLog -data .\workspace -options

Where:

* You open the command prompt as Administrator.

* You execute the command line application under where eclipse.exe is located.

¢ .\workspace is the relative path to the workspace from where the command line is run. You can specify

an absolute path.

¢ At least one of the below options is specified.

Options

—u

Option

Description

Upgrade the Projects in the
workspace including common
and diagram files. Mutually
exclusive with -u option
(recommended option).

Upgrade diagram files only.
Mutually exclusive with -p
option.

Deploys the .NET Project to the
IIS Web Server. Port number must
be specified, for example, -d 80.
For .NET Projects, open the

Code will be generated for all the diagram files irrespective of the options specified.

Comment
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Notes

Option Description

Command prompt as
Administrator.

Deploys the Java Project to the
Tomcat web server. Port number
must be specified, for example,
-d 8090. For Tomcat admin role
access login should be admin/
admin.

Update the IPD diagrams Events
Property to Voice default set.

Publish IPD to Configuration
Database. Publishes to default
Tenant. Parameters:
$CMEApplicationName$
$HostIP$ $CmePort$
$UserName$ $Password$

Comment

Release 8.1.410.14 adds support
publishing IPDs at the command
line:

e Eclipse should not be running. This command line will launch a headless instance of Eclipse that will exit
once code generation is complete.

e Eclipse.exe should be executed from its installed location.

* .\workspace is the relative path to the Workspace that contains your Projects for which code should be
generated. This will generate code for all supported types of diagrams:

callflow : VXML
sub-callfow : VXML
workflow : SCXML
sub-workflow : SCXML

interaction process diagram : SCXML

Examples:

Project Upgrade Report

eclipse.exe —application com.genesyslab.composer.voice.generator.commandline.app
-nosplash -console -consoleLog -data .\workspace —p )

Publis

hing IPDs

eclipse.exe -refresh -application
com.genesyslab.composer.voice.generator.commandline.app -nosplash -console

-consoleLog -data “WorkspacePath” -c $CMEApplicationName$ $HostIP$ $CmePort$
$UserName$ $Password$
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Working with Diagram Layouts

Composer routing workflow and voice callflow diagrams follow a vertical layout scheme by default.
The in port of a block is always positioned at the top of the block while one or more out ports are
positioned at the bottom edge of the block. Exception ports are displayed on the left edge. Following
this vertical layout can quickly exceed the available vertical screen space. The Outline view can then
be used to determine which part of a large diagram is being displayed currently and to quickly
navigate to a different part by clicking the outline view.

It is possible to follow a horizontal layout where the in ports and out ports can be manually re-
positioned to any edge of the block and lose some features. For example, elbowed (bent) connectors
and individual ports may not display on the block making it difficult to know how many unconnected
ports are present and also to connect out ports out of order. See Show Connection Ports for more
details. Please note that switching between the default vertical layout and the more flexible
horizontal layout will rearrange connection links and manual rearrangement may be necessary. While
working with diagrams, you may run into odd looking links. The figures below show some of these
and lists suggestions on how to fix them.

[ Link Issue Steps to resalve End Result
1. Grab the extreme laft and right
points of the infinity curve and
coax tham towards the center
A until they merge intothe =
%, User Data vertical line, —o L
UserData2 UserData2
2T t (@) Target
entongueus, bt & Targe errorusuesbngh
Targeti Ta‘gau
r
-
[
Exit [ Exit
@ Exit1 | @ Exitl
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pr—
‘ O

Exit

“Web Request
webReguastL

Increase the vertical spacing
batwean the two blocks linked
by this connector until the
broken connectar fixas itsalf,

! Entry
.En:rn
o) Web Request
WebREquEtL
55 Web Service
WebServidel

® Bt

Exit1

To make it easier to align blocks, Composer diagrams have enabled "just in time" guides. They show
up when a block is dragged near another block, when blocks are aligned, and help for about a
second. To place the block in an aligned position, drop the block when the guides confirm the block is

aligned.

“b Web Request

WebReguestl

) web Service
WebServicel
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Accessing the Editors and Templates

Composer editors are embedded/integrated within the user interface and are made available to you
whenever a .scxml, .vxml, .ccxml, .grxml, or .jsp file is created or accessed within Composer.

Creating a New File

In Composer or Composer Design perspective, create a new VoiceXML, SCXML, or CallControlXML
file as follows:

¢ Select File > New > Other > Composer > Others > Others> Others.

* Select the file type, such as SCXML.

¢ Select the parent folder; usually an existing Project.

e Enter a name for the file.

» If applicable, click Advanced to link to the file system and use an existing file.

e Click Finish.

Using an Existing Template

e Select File > New > Other > Composer > Others.

* Select the file type.

e Select the parent folder; usually an existing Project.

* Enter a name for the file.

* If applicable, click Advanced to link to the file system and use an existing file.

* Click Next.

e Select the template.

¢ Click the Use SCXML Template checkbox.

* Click Finish.

The editor opens with your new file. When working with XML files, the view contains Source and
Design tabs. All editor functions described at the top of this topic are available to you. The

appropriate Composer editor also opens whenever you open an existing .vxml, .ccxml, .grxml, .aspx,
or .jsp file, whether previously created as described above, or previously imported into Composer.
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Open an Existing File
Open an existing file as follows:

* Select File > Open File.
* Navigate to the file to open, OR

Open a Composer Project's src or src-gen folder in the Project Explorer, then double-click the file to
open it in the editor.

Creating a Custom Code Template

When writing manual SCXML/VXML/CCXML/GRXML code in the file editors, you may run into code that
becomes repetitive. You may consider creating a code template to avoid retyping this block of code.
Creating templates will improve the speed and consistency for writing code. The following steps show
how to create a code template.

¢ Select Window > Preferences.

¢ In the Preferences dialog box, navigate through the Composer category, and expand the file type (VXML
Files / CCXML Files / GRXML / SXCML Files) in which you want to add your template. Then select the
Templates section. For example, select VXML Templates.

¢ Click the New button to add a new code template.

¢ Fill in the fields for the new template. The Context drop down box specifies at what context level you
want the code template to appear as a context sensitive help.

¢ Click the OK button when finished.

XML File Preferences

You can also set XML File Preferences: Window > Preferences > XML > XML Files. When
specifying Encoding formats in the XML Preference page: encoding formats are applicable only for
new File creation using the Template option: (File > New > XML > XML File > Create XML File
from an XML Template > Select XML Template). This applies only to new XML, VXML, CCXML and
SCXML files. Existing files within the Project will not get impacted.

Creating a Backend JSP File

¢ Create a new JSP file by selecting File > New > Backend JSP file.

* In the Create Backend JSP File folder, navigate to the src folder within the Java Composer Project in
which the Backend JSP file belongs.

¢ Type a name In the File Name field.
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¢ Click Finish.

The Editor opens with a JSP file template. You can see your new file in the src folder of your Java
Composer Project in the Project Explorer. A template is provided when you create a new Backend JSP
file in Composer. You implement a performLogic method as a JSON object, store a result and return it
to the voice application if desired. You have the flexibility to enter any valid JSP code that you wish.

Creating a Backend ASP NET File

e Create a new ASP.NET file by selecting File > New > Backend ASPX file.

In the ASPX File folder, navigate to the include folder within the .NET Composer Project in which the
Backend ASPX file belongs.

e Type a name In the File Name field.

Click Finish.

The Editor opens with an ASPX file template. You can see your new file in the include folder of your
.NET Composer Project in the Project Explorer. A template is provided when you create a new
Backend ASPX file in Composer. You implement a performLogic method as a JSON object, store a

result and return it to the voice application if desired. You have the flexibility to enter any valid
ASP.NET/C# code that you wish.
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Keyboard Shortcuts

When working in Composer, you can use the following keyboard shortcuts. Click in the Package

Explorer on the left. Then use the keyboard shortcuts shown below.

Ctrl+Alt+P

Ctrl+Alt+)

Ctrl+AIt+T

Ctrl+Alt+0
Ctrl+Alt+R

Alt+1+C

Alt+1+D

Ctrl+Alt+C

Alt+M
Alt+P+P

Alt+H

Alt+H+C

Alt+H+A

Ctrl+Alt+D
Ctrl+Alt+S

Space

Alt+A

Alt+D

Alt+R

Create new interaction process
diagram

Create new Java Composer
project

Create new .NET Composer
project

Create a new voice callflow
Create a new routing workflow

Open dialog box for connecting
to Configuration Server

Disconnect from a connected
Configuration Server

Generate all

Open Prompt Manager
perspective

Open Project properties

Open Composer Help
Open Cheat Sheet

Open About Composer
Open Database Connection
Profiles

Open Statistic Builder

To toggle a check box
Jump to an Add button in a

wizard

Jump to a Delete button in a
wizard

Jump to a Remove button in a
wizard

Create Interaction Process
Diagram Wizard opens

Wizard for Java Composer project
opens

wizard for .NET Composer project
opens

Callflow Diagram wizard opens
Workflow Diagram wizard opens

Connect to Configuration Server
dialog box opens

A connected Configuration Server
is disconnected

Brings up the Generate All
wizard. Creates properly
formatted VoiceXML (callflows) or
SCXML (workflows) diagram files
for the Project.

Prompt Manager perspective
opens

Properties dialog box opens

Help menu appears. Select Help
Contents.

Help menu appears. Select Cheat
sheets.

About Composer dialog box
opens

Database Connection Profiles
opens

Statistic Builder opens.

The check box mark toggles on/
off

The Add button is selected
The Delete button is selected

The Remove button is selected
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ALT+U Jump to an UP button in a wizard  The UP button is selected
ALT+W Ju_mp to a DOWN button in a The DOWN button is selected
wizard
Jump to a Test/Preview button in The Test/Preview button is
Alt+T :
a wizard selected
Alt+R/Alt+W Ju_mp to a Browse button in a The Browse Event button is
wizard selected
Alt+B Jump to a Back button in a wizard The Back button is selected
Alt+N Jump to a Next button in a wizard The Next button is selected

Jump to a Finish button in a

Alt+F .
wizard

The Finish button is selected
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Default Logging

For information on setting Default Logging, see the figure in topic Project Properties.
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IRD Functionality Included in Composer

Composer enables you to create SCXML-based routing applications to run on the Universal Routing
8.x platforms and, as such, it includes functionality that was previously provided through Genesys
Interaction Routing Designer (IRD). The information below is provided for existing Genesys customers
transitioning to Composer, who are familiar with creating strategies in IRD.

Composer Blocks and IRD Objects

Composer refers to the fundamental element of a workflow as a block; whereas in IRD
documentation, this element is referred to as an object. The tables below group IRD objects based on
their IRD toolbar category name and point to the corresponding functionality in this release of
Composer. Summary information is presented below.

e Learn about the differences between Composer and Interaction Routing Designer, which has
historically been used to create routing applications.

e See the Composer Quick Start for how to create a simple routing strategy, attach data that will appear
on the agent desktop, and route to the preferred agent.

Data & Services

IRD Object Name Composer Block Name Description

DB Data retrieves information
Database Wizard DB Data from the database. Uses a Query
Builder.

Invokes Web Services. GET, POST
Web Service Web Service and SOAP over HTTPS are
supported.

Invoke any supported HTTP web
request or REST-style web
Service. See sample: Routing
Based on Web Request.

Web Request

Also see Composer's Server Side Blocks.

Miscellaneous

IRD Object Name Composer Block Name Description

Assigns a computed value/

Assign Assign . .
9 9 expression or a literal value to a
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Multi-Assign

Call Subroutine

Entry

Exit

Error Segmentation

Function

Multi-Function

Multi-Attach

Subroutine

Entry

Exit

Multiple error output ports can be
created in Composer blocks
based on each block's Exception
property.

ECMAScript

Assign, Branching, ECMAScript
blocks all open Expression
Builder

ECMAScript

Also see Composer's Routing Flow Control Blocks.

Routing

IRD Object Name

Selection

Percentage

Default

Composer Block Name

Target

Target

Default Route

variable. Variables are defined
in the Entry block. Capable of
multiple assignments.

Creates reusable sub-modules.

Sets global error (exception)
handlers. Defines global
variables (see Variables section
below).. All routing strategy
diagrams must start with an
Entry block.

Terminates the strategy and
returns control back to calling
workflow in case of a subroutine.

Builds an ECMAScript expression
using the Expression Builder.
Many URS functions are
available as Genesys Functional
Modules described the
Orchestration Server
Documentation Wiki can invoke
multiple functions.

Expression Builder can be used
to create IF expressions.

Can be used for attaching data to
an interaction.

Description

Routes an interaction to a target,
which can be Agent, AgentGroup,
ACDQueue, Place, PlaceGroup,
RoutePoint, Skill, or Variable. Skill
target uses Skill Expression
Builder.

Statistics Order property in
Target block, lets you perform
percentage allocation. Also see
sample: Routing Based on
Percent Allocation.

Routes the interaction to the
default destination. Can be
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Routing Rule

Switch to Strategy

Force Route

Statistics

Force Route

Target

Also see Composer's Routing Blocks.

Segmentation

IRD Object Name

ANI

DNIS

Date

Day of Week

Time

Classification Segmentation

Generic

Composer Block Name

Branching
Branching
Branching
Branching

Branching

Branching

Branching

overrridden by the Set Default
Route block.

Orchestration Server 8.1 does
not support service level routing
rules.

Orchestration Server 8.1 does
not support switch to strategy
routing rules.

Not exposed as a routing rule in
Composer.

Although statistical routing rules
are not yet supported as in IRD's
Statistics routing object, users
can use the Target object
Statistic property to route based
on the value of a statistic. A
Statistics Manager and Builder let
you create your own statistics
from URS predefined statistics.

Description

See Your First Application: DNIS
Routing for an example.

See Your First Application: DNIS
Routing for an example.

See the sample Routing Based on
Date & Time.

See the sample Routing Based on
Date & Time.

See the sample Routing Based on
Date & Time.

For classification segmentation,
an ECMAScript function
determines if a particular
category name or ID exists in the
array of category objects
represented by an application
variable.

Use as a decision pointin a
workflow. It enables you to
specify multiple application
routes based on a branching
condition.
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Also see:
Composer Common Blocks

Context Services Blocks.

Voice Treatment

See Composer Equivalent to IRD Treatment.

eServices Multimedia

See Composer Equivalent to IRD Multimedia.

Outbound

See Outbound Common Blocks

Context Services

See Context Services Blocks

Business Process

See Interaction Processing Diagrams Overview and Interaction Process Diagram Blocks. Reusable

Objects

¢ |IRD List Object: See Composer's List Object Manager.
* |IRD Variable List Dialog Box: See Entry block Variables property.

In contrast to IRD, which defines variables in a special dialog box outside of the strategy, Composer

defines both workflow and Project variables.
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Composer Menus

Tip
This help wiki discusses the menu items that you use for Composer. Other menu items
are part of the Eclipse integrated development environment.

This section discusses Composer's top-level menus.

e FileMenu

» EditMenu

¢ DiagramMenu

* NavigateMenu

* SearchMenu

¢ ProjectMenu

¢ ConfigurationServerMenu
* RunMenu

¢ Window_Menu

* Help_Menu

e CanvasShortcutMenu

¢ PaletteGroupMenu
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File Menu

The commands active in the File menu change depending on the object you have selected, the
perspective, and where you are within the perspective. Commands available from the File menu are
described below. Also see the Hiding File Types topic.

Select New > Other, which can be a new:

¢ Java Composer Project

.NET Composer Project
e Project

e Callflow Diagram

e Workflow Diagram

e Grammar builder file

New « VoiceXML file
(Alt+Shift+N) e SCXML file
e GrammarXML file
e CallControlXML file
e Backend JSP file
e Folder
e File
You can also select Example... or Other... (for example, to create
a new Interaction Process Diagram). Both of these bring up the
Select a Wizard dialog box.
Open File Opens the selected object.
Close ) )
Closes the current callflow or workflow diagram in
(Ctrl+W) the canvas.
Close All
(Ctrl-+Shift+ W) Closes all open elements in the workbench area.
Save
(Ctrl+S) Saves the selected object.
Save As Saves the selected object under another name
Save All

(Ctrl+Shift+S)

Revert

Saves all files in all open editors.

Reverts to an earlier saved version of a file
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Move
Rename
Refresh

Convert Line Delimiters To

Print

Page Setup

Print Preview
Switch Workspace...

Restart

Import

Export

Properties

Exit

selected from the History.

Moves Project resources.

Renames Project resources.

Reloads the configuration.

Converts line delimiters within the callflow design
canvas to one of the following:

* Windows (default)
e Unix

¢ MacOS 9

Prints the selected object(s) within the callflow
design canvas

Brings up a dialog box where you can specify to
use workplace settings or diagram settings. You
can also change orientation, units, size, and the
margin as well as configure workplace settings.

Previews the output before printing.

Browses for/selects a different workspace storage
area. Changes the set of projects and resources
that you are working on.

Restarts Composer.

Brings up a wizard that leads you through the
process of importing various types of files.

Expand Composer to import from the file systems, such an IRD

strategy or a Realtime Debugger Launch Configuration.

Brings up a wizard that leads you through the
process of exporting various types of files.

Shows properties for the selected resource (such as
a Project). When a Project is selected, includes the
Deployment property.

Exits Composer.
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Edit Menu

Use the Edit menu to move around within the current application; cut, copy, paste, and delete blocks
from the displayed callflow or workflow; find individual blocks within the callflow; and open the
Properties dialog box for a selected block. Edit menu items include standard Windows and Eclipse

edit functions:

Undo

(Ctrl+2)

Redo

Cut

Copy

Paste
Delete

Select All

Find/Replace

Add Bookmark

Add Task

After you perform an action on an object, the Undo
command becomes Undo <action>. For example,
Undo Deleting appears after you perform a
deletion.

Select Redo <action> after using Undo <action> to
go back to the most recent edit.

Removes selected object(s) and moves the objects
to the clipboard.

Copies the selected object(s) to the clipboard.

Moves copies of selected object(s) from the
clipboard to the selected location.

Deletes the selected object(s).

Selects all text or objects in the currently active
view or editor.

Use in text files, such as JSP, VXML, CCXML, and
SCXML files. Place your cursor inside the file and
then select from Edit menu. Not used for callflows
or workflows. Brings up the Find/Replace dialog
box.

When the cursor is positioned on a file in the
Project Explorer, opens the Bookmark Properties
window. A bookmark helps you quickly navigate to
a frequently used resource. You can place an
"anchor" either on a resource within the
Workbench, or at a specific line within a file, by
creating a bookmark. Then you can use the
Bookmarks view to return to those files quickly. The
Bookmarks view (Window > Show View >
Bookmarks) displays all bookmarks that you have
created.

When a Project is selected in the Project Explorer,
opens a properties dialog box. You can associate
tasks with an editable resource, for instance to
remind yourself to update a line of source code
later.
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Diagram Menu

This menu contains a number of standard diagram-related menu commands that can be used within
the Project Explorer view and callflow/workflow diagram canvas.

Invokes the system font dialog used to modify the

el font associated with the selected diagram element

Applies a color to the selected diagram element's

Fill Color interior

Applies a color to the selected diagram element

Lin lor )
e Colo lines

Modifies the style of the selected diagram
connector element to one of the following:

* solid

* dash

* dot

» dash dot

* dash dot dot

Line Type

Modifies the width of the selected diagram
connector to one of the following:

e one point
Line Width * two points
e three points
e four points
¢ five points
Modifies either the source end or the target end of

the arrow connector element to one of the
following:

Arrow Type * NO arrow

¢ solid arrow

* open arrow

Changes the diagram connector to one of the
following:

Line Style + Rectilinear Style Routing
e Oblique Style Routing
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e Tree Style Routing

Select all diagram elements, all shapes, or all

lect
Selec connectors

Applies a layout to all diagram elements, or to the

Arrange
9 selected ones only

Aligns all selected diagram elements to: the left,
Align the right, the center, the top, the bottom, or the
middle of the selection

Text Alignment Aligns the text left, right, or center

Re-orders the selected diagram elements to: the

Order front, the back, forward once, or backward once

Resets the size of the selected diagram elements
Auto Size to the default size, usually just enough to see an
embedded label within the shape

Sets the size of the selected diagram elements to
Make Same Size the size of the last selected element, either
horizontally, vertically, or both

Does one of the following:
e sort/filter Compartment items
Filters ¢ show/hide Compartment items
(all Compartments or named Compartments only).

Compartment items refer to Composite attributes within your
editor, which can optionally be collapsed or expanded.

Shows or to hides various diagram features:
e ruler

View e grid
* page breaks

Controls the snap to grid behavior.

Changes the diagram magnification to one of:
e in

e out

* 100%

e To Fit

e To Width

* To Height

Zoom

e To Selection

Copies various appearance properties, such as fill

Apply Appearance Properties color, of the first selected diagram element to the
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Generate Code

(Alt+G)

Import Custom Blocks

Export Custom Blocks

Validate

(Alt+V)

other selected ones

Creates a properly-formatted VoiceXML file from a
callflow diagram built with Composer. Static VXML
pages (pure VXML code) are generated in the src-
gen folder of the Composer Project. This selection
is enabled when the Project is selected in the
Explorer after a new edit.

In the case of a routing workflow, check the Problems tab for
errors and fix any problems. If code generation succeeds, click
OK at the confirmation dialog box. The SCXML code is generated
in the src-gen folder.

Allows you to import a custom block that was
previously exported so the block can be shared
across multiple users/installations of Composer.

Allows you to export a custom block so the block
can be shared across multiple users/installations of
Composer.

Validates the diagram that is open for
completeness and accuracy. This selection is
enabled when the Project is selected in the
Explorer after a new edit.
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Navigate Menu

This menu allows you to locate and navigate through resources and other artifacts displayed in the
Workbench. The Navigate menu differs from the Find/Replace command on the Edit menu. Instead of
entering text to find, the Navigate menu uses directional commands. The Navigate menu contains

the following items:

Go Into

Go To

Show In

(Alt+Shift+W)

Next

Previous

Last Edit Location
Back

Forward

Refocuses the active view so that the current
selection is at the root. This allows web browser
style navigation within hierarchies of artifacts.

Refocuses the active view to one of the following:

e Back: Displays the hierarchy that was displayed
immediately prior to the current display. For
example, if you Go Into a resource, then the
Back command in the resulting display returns
the view to the same hierarchy from which you
activated the Go Into command. This command
is similar to the Back button in an HTML
browser.

e Forward: Displays the hierarchy that was
displayed immediately after the current display.
For example, if you've just selected the Back
command, then selecting the Forward
command in the resulting display returns the
view to the same hierarchy from which you
activated the Back command. This command is
similar to the Forward button in an HTML
browser.

* Up one level: Displays the hierarchy of the
parent of the current highest-level resource.

Finds and selects the currently selected resource in
another view. If an editor is active, these
commands are used to select the resource
currently being edited in another.

Navigates to the next item in a list or table in the
active view. For example, when the search results
view is active, this navigates to the next search
result.

Navigates to the previous item in a list or table in
the active view. For example, when the search
results view is active, this navigates to the previous
search result.

Jumps to the last edit position

Navigates to the previous resource that was viewed
in an editor. Analogous to the Back button on a web
browser.

Navigates to undo the effect of the previous Back
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command. Analogous to the Forward button on a
web browser.
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Search Menu

Search results are displayed in the Search view, which appears if not previously present. The Search
menu contains the following items:

Opens the Search dialog box, where you can
perform file, text or Java searches. Java searches
operate on the structure of the code. File searches
operate on the files by name and/or text content.
Java searches are faster, since there is an
underlying indexing structure for the code
structure. Text searches allow you to find matches
inside comments and strings.

Search

Opens the Search dialog box. If it is not already
selected, select the File Search tab. In the
Containing text field, type the search string. For a
Java search, make sure that the File name patterns
field is set to *.java. The Scope should be set to
Workspace. Then click Search. Note: To find all files
of a given file name pattern, leave the Containing
Text field empty.

File

After selecting text, searches a workspace, a
project, a file, or a working set. Working sets group
elements for display in views or for operations on a
set of elements. They restrict the set of resources
that are displayed. If a working set is selected in
the navigator, only resources, children of
resources, and parents of resources contained in
the working set are shown.

Text
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Project Menu

The Project menu contains the following items:

Opens the currently selected Project(s). The
Open Project selected Project(s) must currently be closed for this
command to be available.

Closes the currently selected(s) Projects. Closing a
Project will remove all of that Project's state from
memory, but the contents on disk are left
untouched.

Close Project

Performs an incremental build on all Projects in the
Workbench. This command builds (compiles) all

Build All resources in the Workbench that are affected by
any resource changes since the last incremental
(Ctrl+B) build. This command is only available if auto-build

is turned off. Auto-build is turned off via the Build
Automatically menu option or from the General >
Workspace preference page.

Performs an incremental build on the currently
selected Project. This command builds (compiles)
all resources in the Project that are affected by any
resource changes since the last build. This
command is only available if auto-build is turned
off. Auto-build is turned off via the Build
Automatically menu option or from the General >
Workspace preference page.

Build Project

Performs an incremental build on a working set.
This command builds (compiles) all resources in
the working set that are affected by any resource
Build Working Set changes since the last build. This command is only
available if auto-build is turned off. Auto-build is
turned off via the Build Automatically menu option
or from the General > Workspace preference page.

Discards all previous build results. If autobuild is

Clean on, then this invokes a full build.

Toggles the auto build preference on and off. The
Build Automatically auto-build preference is also located on the
General > Workspace preference page.

Opens the Project Properties dialog box as

Properties described below.

Project Properties

Selecting Properties from the Project menu opens a dialog box showing the properties of the
selected Project or of the Project that contains the selected resource.
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Run Menu

¢ See the Debugging voice applications and Debugging routing applications topics for supported

functionality.

The Run Menu contains all of the actions required to run, debug, step through code and work with
breakpoints. Different parts of the menu are visible at different times, as each perspective can be
customized to show only specific capabilities. The Run menu contains the following items:

Resume

Suspend

Terminate

Step Into

Step Over

Step Return
Run to Line
Use Step Filters

(Shift+F5)

Run

Debug

Run History

Run As

Run Configurations

Resumes execution of the currently selected Debug
target.

Halts the execution of the currently selected thread
in a debug target. Once the selected thread is
suspended, you can then examine it.

Terminates the selected debug target.
[Disabled for GVP Debugger]

Steps over the highlighted statement. Execution
will continue at the next line either in the same
method or (if you are at the end of a method) it will
continue in the method from which the current
method was called.

The cursor jumps to the declaration of the method and selects
this line.

[Disabled for GVP Debugger]
[Disabled for GVP Debugger]

Toggles step filters on and off. When on, all step
functions apply step filters.

Re-launches the most recently launched
application, or launches the selected resource or
active editor depending on the launch operation
preference settings found on the Run/Debug >
Launching preference page.

Re-launches the most recently launched application
under debugger control, or launches the selected
resource or active editor depending on the launch
operation preference settings found on the Run/
Debug > Launching preference page.

Displays a submenu of the recent history of launch
configurations launched in run mode

When a callflow is selected, displays Run Callflow.
In the Run mode, call traces are provided and the
application continues without any breakpoints.
Note: Run on Server is an Eclipse feature and is not
used by Composer.

Used for debugging callflow diagrams. Opens the
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Debug History

Debug As

Debug Configurations

External Tools

Create URL Breakpoint

Toggle Breakpoint

Toggle Line Breakpoint

Toggle Method Breakpoint

Toggle Watchpoint

Run Configurations dialog box that lets you create,
manage, and run launch configurations of different
types.

Displays a submenu of the recent history of launch
configurations launched in debug mode.

Displays a sub menu of registered debug launch
shortcuts. Launch shortcuts provide support for
workbench or active editor selection sensitive
launching.

Note: Debug on Server is an Eclipse feature and is not used by
Composer.

Used for debugging callflow diagrams. Opens the
Debug Configurations dialog box that lets you
create and modify launch configurations and debug
applications.

Displays external tools that allow you to configure
and run programs, batch files, Ant buildfiles, and
others using the Workbench. You can save these
external tool configurations and run them at a later
time. Output from external tools is displayed in the
console view. Selecting External Tools presents the
following sub-menus: Run As, External Tool
Configurations, Organize Favorites.

Creates a breakpoint, which suspends the
execution of a workflow at the location where the
breakpoint is set.

Appears in Debugging perspective. Select to
suspend the execution of a program at a particular
location in a callflow. When a breakpoint is
encountered during execution of a program, the
program suspends and triggers a SUSPEND debug
event with BREAKPOINT as the reason.

Select to set a breakpoint on an executable line of
a program.

Use when working with types that have no source
code (binary types).

Open the class in the Outline View, and select the method
where you want to add a method breakpoint. Select Toggle
Method Breakpoint to have a breakpoint appear in the
Breakpoints View. If source exists for the class, then a
breakpoint also appears in the marker bar in the file's editor for
the method that was selected. While the breakpoint is enabled,
thread execution suspends when the method is entered, before
any line in the method is executed.

Appears in GVP Debugging perspective. You must
select a Java field object to use this command. Use
after you have created a watchpoint on the
currently selected field. Whenever that field is
accessed or modified, execution will be suspended.
If the selected field already has a watchpoint,
selecting this command will remove it.
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Skip All Breakpoints

Remove All Breakpoints

Select to mark all breakpoints in the current view
as skipped. Breakpoints marked as skipped will not
suspend execution.

Select to remove all breakpoints from the
Breakpoints View.
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Configuration Server Menu

URS applications may be developed either:

e With a connection to Configuration Server

e Orin an offline mode, without connecting to Configuration Server

Connect Select to connect to Configuration Server.

Disconnect Select to disconnect from Configuration Server
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Window Menu

The Window menu allows you to display, hide, and otherwise manipulate the various views,
perspectives, and actions in the Workbench. The Window menu contains the following items:

New Window

New Editor

Open Perspective

Show View

Customize Perspective

Save Perspective As

Reset Perspective

Close Perspective

Close All Perspectives

Navigation

Opens a new workbench window with the same
perspective as the current perspective. The
Composer perspective is the default for building
your application.

Opens an editor based on the currently active
editor. It will have the same editor type and input
as the original.

Opens a new perspective in this workbench window

Displays the selected view in the current
perspective. Views support editors and provide
alternative presentations as well as ways to
navigate the information in your workbench. For
example, the Project Explorer and other navigation
views display projects and other resources that you
are working with. You can configure how views are
opened on the Window > Preferences > General >
Perspectives preference page.

Opens the Customize Perspective dialog box. The
Shortcuts tab lets you select shortcuts you want
added as cascade items to submenus. The
Commands tab lets you select command groups
that you want added to the current perspective.

Saves the current perspective thereby creating
your own custom perspective. You can open more
perspectives of this type using the Window > Open
Perspective > Other menu item once you have
saved a perspective.

Changes the layout of the current perspective to its
original configuration

Closes the active perspective

Closes all open perspectives in the workbench
window

Displays the following submenu and shortcut keys:

¢ Show System Menu (Alt+-): Shows the menu
that is used for resizing, closing or pinning the
current view or editor

¢ Show View Menu (Ctrl+F10): Shows the drop
down menu that is available in the toolbar of
the active view

¢ Quick Access (Ctrl+3): Shows a listing of
available quick access categories
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Preferences

* Maximize active view or editor (Ctrl+M): Causes
the active part to take up the entire screen, or if
it already is, returns it to its previous state

e Minimize active view or editor: Causes the
active part to be minimized.

e Activate Editor (F12): Makes the current editor
active

¢ Next Editor (Ctrl+F6): Activates the next open
editor in the list of most recently used editors

e Previous Editor (Ctrl+Shift+F6): Activates the
previous open editor in the list of most recently
used editors

e Switch to editor (Ctrl4+Shift+E): Shows a dialog
that allows switching to opened editors. Shows
a dialog that allows switching to opened
editors.

* Next View: Activates the next open view in the
list of most recently used views

e Previous View (Ctrl+F7): Activates the previous
open view in the list of most recently used
editors

e Next Perspective (Ctrl+F8): Activates the next
open perspective in the list of most recently
used perspectives

e Previous Perspective (Ctrl+Shift+F8): Activates
the previous open perspective in the list of
most recently used perspectives

Opens a dialog box for indicating various Composer
preferences. There are a wide variety of
preferences for configuring the appearance of
Composer and its views, and for customizing the
behavior of all tools that are installed in the
workbench. See Preferences for Voice Applications
and Preferences for Routing Applications.
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Help Menu

The Help menu contains the following items:

Welcome Displays a welcome screen.
Displays the Eclipse help system.
Note: The Composer Help, which introduces the Composer Help

wiki, is integrated as a workbook within the overall Eclipse Help
system.

Help Contents

Opens a help pane where you can enter a search

Sese expression and view results.
Dynamic Help Opens a help pane to show context-sensitive help.
Key Assist

’ Opens a help pane with a listing of keyboard
(Ctrl+Shift+L) shortcuts.

Opens a Tips and Tricks dialog box with a variety of

Tips and Tricks topics:

Opens the Cheat Sheet Selection dialog box with
Cheat Sheets several available Cheat Sheets that lead you
through key tasks.

Check for Updates Currently not used by Composer.

Opens the Install dialog box where you can select
or enter a site that has the software you want to
install. As described in the Composer 8.1
Deployment Guide, use this menu item to install
Install New Software later versions of Composer. Use the About Eclipse
SDK menu item to uninstall the current version of
Composer prior to updating to a later version. For
another usage example, see the Integrating with
Source Control Systems topic, Subversion section.

Opens the About Composer dialog box, which
displays version, licensing, and Eclipse links. It also
contains buttons to access Feature Details, Plug-in
Details, and Configuration Details.

About Composer
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Canvas Shortcut Menu

When creating a callflow or workflow in Composer or Composer Design perspective, a shortcut menu
opens when you right-click inside the canvas area. The figure below shows the menu when creating a

workflow.
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Canvas Menu

The Canvas menu contains the following items:

Add

File

QueLel

Allows you to add a note, text, or one of the shapes
shown in the figure above.

When creating note objects in a diagram there are two ways to
create them. After selecting the note tool, you can either click a
single point or drag a box to indicate initial size. In the former
case, the note will continue to grow horizontally as text is
entered. With the latter case, text will automatically wrap text
using the input width.

Gives the option of printing the diagram or saving
it as an image file.

Selecting Save as Image opens a dialog box giving the option to
save in one of the following formats: GIF, BMP, JPEG, SVG, PNG,
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or PDF. You can also select Export to HTML.

Delete from Model Deletes the selected block from the workflow.

Allows you to select:
o All
Select e All Shapes

e All Connectors

Use to arrange blocks and connectors in a callflow/
workflow in @ more orderly fashion. If you don't like
the result, select Undo Arrange All from the Edit
menu.

Arrange All

Filters Allows you to show/hide connector labels.

Use to view a grid, snap to a grid, view rulers, view

YT page breaks, and re-calculate page breaks.

Use to:

e Zoom In

e Zoom Out

e Zoom 100%
Zoom e Zoom to Fit

 Fit to Width

* Fit to Height

* Fit to Selection

Upgrade Workflow Diagram
= < Use to upgrade a previously created diagram to the

or Upgrade Callflow Diagram current version of Composer.

Load Resource Allows you to browse for/load Resource URIs.

Shows the Properties view for the selected block or

Show Properties View diagram.
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Palette Group Menu

When creating a callflow or workflow in Composer or Composer Design perspective, a shortcut menu
opens when you right-click on a palette title bar. The figure below shows an example:

[:=% Flaw Conkral
Lawvauk
=] Enkr %
=] i Use Large Icons
[ Exit
) Cuskomize. ..
L= Disconnec Settings. ..
=] &ssign
d Pinned
éﬂ Ecrna Script
IE'I Subroutine
£+ Branching
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Note: You can customize the palette of diagram building blocks. Right-click a block category (such as
Flow Control) and select Customize. You can then hide and unhide blocks.

The Palette Group menu contains the following items:

Layout

Use Large Icons

Customize

Settings

Pinned

Allows you to specify how the blocks in this palette
group should be displayed:

e Columns
e List
e |cons Only

e Detail

Allows you to increase the size of the icons
representing the callflow or workflow blocks.

Opens a dialog box where you can change block
names and descriptions, hide/unhide blocks from
the palette, configure the block drawer to open
upon Composer startup, and pin the block drawer
open upon Composer startup.

Opens a dialog box where you can change the font,
layout, and palette drawer options.

Allows you to prevent a block drawer from closing
when you switch to a different palette group.

Composer Help

148


https://docs.genesys.com/Documentation/IW/8.1.4/Help/InterfaceOverview#Perspectives
https://docs.genesys.com/Documentation/IW/8.1.4/Help/InterfaceOverview#GUI_Element_Descriptions

Composer Toolbars and Views

Composer Toolbars

This section discusses Composer's toolbars.

ToolbarsOverview
MainToolbar

View Toolbars
PerspectiveSwitcherToolbar
TrimStackToolbar
Debugging Toolbar

MinimizingandRestoringViews

and Views
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Toolbars Overview

Composer has a number of toolbars for various purposes:

Main Toolbar

View Toolbars

Perspective Switcher Toolbar
Trim Stack Toolbar
Debugging Toolbars

Minimizing and Restoring Views

Note: To see a tooltip containing the name of a toolbar button (icon), hover the cursor over the
button.
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Main Toolbar

The Composer main toollbar is shown below (8.1.440 release).

P =

Save

Save All
Terminal

Resume
Suspend

Terminate
Disconnect

Step Into
Step Over

Step Return

Drop to Frame

Tip

Toolbar Buttons

The table below identifies buttons that can appear on the toolbar.

SlEwivEw s @O L eRBEC

Prompts Manager
DB Connection Prop

Generate Code

——Generate All Validate
—5Start Tomcat Debug As
Stop Tomcat Run Default Workflow
rftatistics Mgr. Fllun L|ast Tool

v = |

Use [Step Filters
Java Composer Proj
NET Composer Proj
Callflow Diagram
Workflow Diagram
Ixn Process Diagram
Prompts Manager
DB Connection Prop
Generate All
Start Tomcat
Stop Tomcat

Statistics Mgr

New

TSR EYOrQa

e

o S LA S A= A1 00%)

Launch GAX Portal
Diagram Variables
Diagram Properties

Disconnect Config Server

Connect Config Server

List Objects Mgr

Buttons on the main toolbar change based on the active perspective. Iltems in the
toolbar might also be enabled or disabled based on the state of either the active view
or editor. Sections of the main toolbar can be rearranged using the mouse.

Select to create one of the following new resources: Java
Composer Project (includes callflows and workflows), .NET
Composer Project, Project..., Grammar builder file, VoiceXML file,
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GrammarXML file, CallControlXML file, Backend JSP file, SCXML
file, or Folder, or File. You can also select Example or Other.
Note: Before you can create a new file, you must create a
project in which to store the file.

Save

Saves the content of the active editor.

Print

Prints the contents of the active editor.

Debug

Re-launches the most recently launched application under

ﬁ - debugger control, or launches the selected resource or active
editor depending on the launch operation preference settings
found on the Run/Debug > Launching preference page. Used for
voice applications.

Run

Re-launches the most recently launched application, or launches

0 - the selected resource or active editor depending on the launch
operation settings found on the Run/Debug > Launching
preference page. Click the down arrow to select Run As or Run
Configurations. You can also organize favorites.

Run Last Tool

Allows you to quickly repeat the most recent launch in run mode
% & or quickly run the selected resource, if that mode is supported

(based on your current launch settings). Click the down arrow to

select Run As or bring up the External Tool Configurations dialog

box.
Search
i Brings up a Search dialog box where you can perform one of the
- following types of searches: File, Java, Java Script. The General
> Search preference page allows you to set preferences for
searches.

Launch GAX Server portal

Launches the Genesys Administrator Extension used by the GAX

@I’ Server (see GAX Server OPM Block). Composer uses the host,
port, username, and password used on the GAX Server
Preferences page to fetch ARM parameters or audio resource IDs
list.

Access Project Variables

&

Opens a dialog box where you can set or delete application
variables. The appearance of this button changes depending on
what type of diagram you are working with. When working with

= a callflow or workflow, the button appears as shown on the top
@ left. When working with an interaction process diagram, the
button appears as shown on the bottom left.
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Create Java Composer Project

Brings up a wizard dialog box for creating a new Java Composer
Project.

Create .NET Composer Project

& &

Brings up a wizard dialog box for creating a new .NET Composer
Project.

Create New Callflow

&)

Brings up a wizard dialog box for creating a main callflow
diagram or a sub-callflow diagram.

Create New Workflow

20

Brings up a wizard dialog box for creating a main workflow
diagram or sub-workflow diagram.

Create New Interaction Process

1

Brings up a wizard dialog box for creating an interaction process
diagram.

Show Properties View

Shows the properties of the selected diagram.

Open the Prompts Manager View

e Displays the Prompts Manager view in the lower center pane of

the Composer main window.
Open Database Connection Properties

& Opens the Connection Profiles tab where you can define a
database connection profile and test the connection. This button
becomes enabled when you select the connection.properties file
in the Project db folder.
Generate All

@ Opens the Generate all dialog box, which lets you create

properly formatted VoiceXML or SCXML files for all callflow and/
or workflows in the Project.
Start Tomcat

ﬂ i Starts the Tomcat web server, which can be used for testing and

deployment. If Tomcat has already started, displays a message
to this effect.

@ Stop Tomcat

Stops the Tomcat web server.

Connect to Configuration Server

Opens a dialog box where you can connect to Configuration
Server. Used for routing applications. When you set up your
Configuration Database (Configuration Server), you define
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certain database objects, such as agents (Persons), Agent
Groups, Skills, and so on. These objects can be defined in
Configuration Manager or in Genesys Administrator. When you
use Composer to create SCXML routing strategies executed by
Orchestration Server (and Universal Routing Server), there is a
button to connect to Configuration Server. When creating a
routing strategy in Composer, those Configuration Database
objects will be available in the Composer routing strategy
building blocks that use them. For example, you might be
creating a routing strategy that routes to an Agent Group and
using Composer’s Target block. The Agent Group you defined in
the Configuration Database would be available for selection in
the Target block.

Disconnect from Configuration Server

Disconnects from Configuration Server.

Statistics Manager

Opens the Statistics Manager view for working with Universal
Routing Server predefined statistics. Used for routing
applications.

List Objects Manager

Opens the List Object Manager view, which allows you to create
List Objects in Configuration Server. Use for creating
parameterized applications. This provides System
Administrators with the control to configure and change values
from inside Configuration Server. Used for routing applications.

Publish active interaction process diagram to
Configuration Server

If an interaction process diagram is selected, this toolbar button
appears.

Generate Code

Creates a properly-formatted VoiceXML file from a callflow
diagram or a SCXML file from a workflow diagram. Static pages
(pure VXML or SCXML code) are generated in the src-gen folder
of the Composer Project.

Validate

Checks your diagram files and other source files for
completeness and accuracy. In the case of errors, the Problems
view becomes visible and error markers are put on the blocks
that contain errors. Double clicking on an error in the Problems
view will take you to the corresponding blocks that contain the
errors. Review each of the errors and do the fixes, then validate
again.

Next Annotation

Selects the next annotation. Supported in the Java editor.

Previous Annotation

Selects the previous annotation. Supported in the Java editor.
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Last Edit Location

Reveals the location where the last edit occurred.

Back To

Reveals the previous editor location in the location history.

Forward To

Reveals the next editor location in the location history.

Turn Grammar Constraints Off

When editing an XML file that has a set of constraints or rules
defined by a DTD or an XML schema, you can turn the
constraints on and off to provide flexibility in the way you edit,
but still maintain the validity of the document periodically. When
the constraints are turned on, and you are working in the Design
view, the XML editor prevents you from inserting elements,
attributes, or attribute values not permitted by the rules of the
XML schema or DTD, and from removing necessary or
predefined sets of tags and values.

Reload Dependencies

If you make changes to a DTD file or XML schema associated
with an XML file (that is currently open), click to update the XML
file with these changes. The changes will be reflected in the
guided editing mechanisms available in the editor, such as
content assist.

Expand All

Select to expand all of the items in the Breakpoints view.

Collapse All

Select to collapse all of the current elements in the view.

Font Style

Allows you to change the font style of the selected text.

Font Size

Allows you to change the font size of the selected text.

Bold Font Style

Allows you to bold the selected text.

Italic Font Style

Allows you to change the selected text to italics.

Font Color

Allows you to change the font color of the select text.
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Fill Color

Allows you to change the fill color of the selected object.

Line Color

Allows you to change the color of the selected line.

Line Style

Allows you to change the style of the selected line.

Apply Appearance Properties

Allows you to apply the applicable appearance properties of the
first application shape to the other selected shapes.

Select All

Selects all objects in the diagram.

Arrange All

Arranges all or only the selected objects in the diagram.

Align

Aligns the selected objects in the callflow diagram: left, right,
center, top, middle, bottom.

Auto Size

Allows you to change the size of the selected object.

All Connector Labels

Shows labels for all connector lines in the diagram.

No Connector Labels

Hides labels for all connector lines in the diagram.

Show/Hide Compartment

Shows or hides composite attributes within an editor, which can
optionally be collapsed or expanded.

Magnification

Allows you to zoom and out of the current view, as well as to
change the magnification from 5% to 400%. You can also fit to
height, width, or selection.
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View Toolbars

The title bar of a view contains a toolbar. This topic describes the following view toolbars:

Project Explorer

The Project Explorer toolbar is shown below.

[E: Callflows

Each toolbar button is identified in the table below.

=

3

Collapse All

Select to collapse all of the current elements in the view.

Link Open Editors

When you have multiple files open for editing, select to bring an
open file to the foreground (make its editor session the active
editor) every time you select that open file in one of the
navigation views.

View Menu

Select to show additional actions for this view.

e Top Level Elements. Select from Projects or
Working Sets (see below).

¢ Folder Presentation. Select from Flat or
Hierarchical.

¢ Working Set. Select from Window Working Sets,
No Working Sets, Selected Working Sets.
Working sets group elements for display in
views or for operations on a set of elements.
The navigation views use working sets to
restrict the set of resources that are displayed.
If a working set is selected in the navigator,
only resources, children of resources, and
parents of resources contained in the working
set are shown.

e Deselect Working Set. Deselects the active
working sets. All elements are shown after
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invoking this action

» Edit Active Working Set. Opens the Edit Working
Set wizard to edit the currently active working
set.

* Package Presentation. Select from Flat or
Hierarchical.

e Customize View. Allows you to filter the Project
Explorer view to hide projects, folders, or files
that you do not want to see.

e Link Editor. Brings an open file to the foreground
(makes its editor session the active editor)
every time you select that open file in one of
the navigation views.

Bookmarks View

The Bookmarks view is shown below.

L Baokmarks 52 = Eq
2 ikems
Descripkion ™ Resource Path Location
Iy Bookmark, JanesFile, bxk JaneQuser line 3
&n important bookm  JanesFile, bk JaneQuser line 5

Each view button is identified in the table below.

View Menu

Select to show additional actions for this view.

e Sort By: Select from Description, Resource, Path,
Location, Ascending.

¢ New Bookmarks View.

e Configure Contents. Opens a window where you
= can filter the contents of the Bookmarks tab.

e Columns. Opens a dialog box where you can set
the width and move the following columns up
and down: Description, Resource Path, and
Location columns.

e Preferences. Opens a dialog box where you can
hide and show the following columns:
Description, Resource, Path, Location, Creation
Time, ID, Type.
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—_ Minimize
Minimizes the Bookmarks tab.
Maximize
B
Maximizes the Bookmarks tab.

Canvas View

The canvas is where you create callflows for your voice applications and workflows for your routing
applications. The Canvas view toolbar is shown below in the upper-right.

{ | E-\
-] < Palette [
Entry
. Startopo m@ellj
l w—a CQukput Link,
0 & w—a Excepkion Link,
¢ Prompt &% Record
(= Basic Blocks 4
WelcomePrompt RecordMessage Srtry
; T [E= Exit
_L & Prompt
Menu B5E Input
Mainenu Menu
A Ciptior
¢ Prompt
PromptPlaybad:
Ly

Each view button is identified in the table below.

— Minimize
[So— Minimizes the Canvas area.
Maximize
=)
Maximizes the Canvas area.
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Palette View

The Palette contains link tools as well as various types of blocks. To create callflow diagrams, the
block categories are: Basic Blocks, Server Side Blocks, CTI Blocks, Reporting Blocks, External Message
Blocks, Database Blocks, and Context Services Blocks. To create workflow diagrams, the block
categories are: Flow Control Blocks, Routing Blocks, Voice Treatment Blocks, Server Side Blocks,
eService Blocks, and Context Services Blocks. The Palette view toolbar is shown below.

| -2 Palette [

m R [ )~

i CbpUt Link,

w—a Exccephion Link

[~ Basic Blocks 4
=] Enkry

Each toolbar button is identified in the table below.

Select

K

Use to select a block for a callflow or workflow.

Zoom In
#]
Click left to zoom in, Shift + left click to zoom out, drag to zoom
to selection.
Zoom Out

Click left to zoom out, Shift + left click to zoom in.

Create Note

Click to create a note, text document, or note attachment. When
_______ creating note objects in a diagram there are two ways to create
Lo~ them. After selecting the note tool, you can either click a single
point or drag a box to indicate initial size. In the former case,
the note will continue to grow horizontally as text is entered.
With the latter case, text will automatically wrap text using the
input width.

Properties View

The Properties view shows the properties for a selected block and allows you to set/modify them. An
example Properties view and toolbar is shown below.
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fﬁ Properties 23 E Cu:-nsu:ulew ﬁ Zall Trace} Qn Searclﬂ E_L, F'ru:ul:ulems} = }:b Sy
@ Prompt Block Prompt1
m Froperty | Yalue |
= Block,
Appearance Parne I'= Prompt1
=] Prompk
Bargeintyvpe I= speech
Clear Buffer v False
Immediate Plavback. I False
Interrupkible [ brue
Prompks % Hello World
Timeaouk 10

Each toolbar button is identified in the table below.

Show Categories

i If enabled, method, field and type labels contain the categories
specified in their block properties
i Show Advanced Properties
3
_ If enabled, the Properties view shows advanced properties.
Restore Default Value
Use after changing a value in the Properties view to revert back
to the default value.
View Menu
=
Select to show additional actions for this view: Show Categories,
Show Advanced Properties, and Columns.
— Minimize

Minimizes the Properties tab.
Maximize

=
Maximizes the Properties tab.

You can change settings for consoles on the Window Preferences Run/Debug Console page. An
example Query Console view is shown below.
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i -y
£l Properties El cansale 52 @% Zall Trace} ‘Qn Search\l EA Prnblems} =l
Qetry Consale B Eﬁ| = = Fﬁ- . |

Buildfile: /C:/Program Files.a"GCTI.a"gvp.a"CDmpnserfa.szcunfiguratiﬂ

Jjspo:
[echo] Projlame: JavaVoicePro]EBELH

compile:
[javac] Cowpiling 5 source files
[Javac] MNote: Sowe input files use or override a deprecated
[Javac] MNote: Recompile with -Xlint:deprecation for details

clean:

I [Arlete]l Deleting directorsy C:hvProogram Filesh GOTTY rmrnt Cnmnf
4 3 ]

Each toolbar button is identified in the table below.

: Clear Console
En

Clears the currently active console.
Scroll Lock

@'—ﬁ Changes if scroll lock should be enabled or not in the current
console.
Pin Console

=
Pins the current console to remain on top of all other consoles.
Display Selected Console

E T Opens a listing of current consoles and allows you to select
which one you would like to see.
Open Console

_{‘hr._ W

L1

Opens a new console of the selected type.

Call Trace View

The Call Trace view displays metrics which describe the events occurring in the application, such as
recognition events, audio playback, user input, errors and warnings, and application output. An
example Call Trace view and Toolbar are shown below.
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Kﬁ Propetties ﬂf‘. Prampks Man (E_l. Problems (E Console |ﬁ ii iiii ﬁ i El] Bu:u:ukmarkﬂ 0
Call Trace <terminaked: - | i
Tirmnestamp | Zake. .. I Texk | <
2009-05,,, é’? pl...  appl_begin INIT_JRL=http://172.21.26.61:8030/SpeachInputsrc-gen/Mai, .
2009-05.., a’? plo..  wf_lookop htkps /172,21, 26,61 8080) SpeechInput)src-genMain, studio_di, ..
2009-05... l“ pl... Fetch_start document:htbp: 172,21, 26,61 8080/ 9peechInputsrc-genMai. ..
2009-05... l“ pl...  wf_lookop file: f)C: [Program Files)GCTIigypYP Media Contral Plakform &.1),,,  —

2009-05... l“ pl... Fetch_start docurment:file: /) C: [Program Files)GCTIigypYP Media Contral PLL ..
2009-05.,.. c? pl...  wf_arrived s (File):file: ) C: [Program Files/GCTI gvpWP Media Conkral Platfa. ., ;I

Each toolbar button is identified in the table below.

Call Trace History

@ i Lists past calls. Once you select a past call, shows call trace
history for that past call.

Terminate

Terminates the process that is associated with the current
Process Console.

Filter Metrics
@ Brings up the Filter Metrics dialog box where you can select the

following filters: Platform actions, User input, Application output,
Document flow, Errors and warnings.

Search View

The search dialog lets you perform text string, File, Java, and JavaScript searches. When you first click
the Search tab, there is a link to bring up the Search dialog box. The figure below shows the results of
an example search and the toolbar.

' e !
=l Properties I,L.=;!. Prompts Manage ﬂ__& Problems (E Console (@% all Trace ﬁ,-. iiiiii ﬁ *.\ S

| RRBE| Y e

"“Welcome' - 77 matches in workspace
= 1= SpeschInput
B2 Calflows
E E||§| Main. studio_diagram (3 matches)
----- =» 221 <blocks xsiibype="gvp:PromptElock” xmizid="_riaAFkCgvEde4vroh4iFy7a" name="""_
e 235 <prompts xmitid="_MObvCgWEdGderOhdiFY 7A" name="welcome Prumpt_PrDE
]

Each toolbar button is identified in the table below.

rFS
—
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Show Next Match

Shows the next items that meets the search criteria.
& Show Previous Match

Shows the previous item that met the search criteria.

Remove Selected Matches

Removes matched items that you have selected from the results

Remove All Matches

Removes all matches from the results.

Expand All
Select to expand all of the current elements in the view.
Collapse All
Select to collapse all of the current elements in the view.
Run Current Search Again

Rﬁ'
Repeats the search with currently-defined parameters.
Cancel Current Search
Cancels the current search.

T Show Previous Searches

Bl

Displays a list of previous searches.
; Pin the Search View

{ -
Pins the current search view to remain on top of all other views.
View Menu

=

Select from the following: Show as List, Show as tree, Filters,
Preferences.

As you work with resources in the workbench, various builders may automatically log problems,
errors, or warnings in the Problems view. For example, when you save a Java source file that contains
syntax errors, those will be logged in the Problems view. When you double-click the icon for a
problem, error, or warning, the associated block is highlighted in the canvas area. Also see topics
Diagram Validation and Validating a Single Flow Diagram.

Problems View

An example Problems view with toolbar is shown below.
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=5
E| Propetties ﬂ_.=' Prompks Manage Iii iiih iWi ﬁ i = Cnnsule} @93 Zall Trace} = Searchw

0 errors, 2 warnings, 0 athers

1|

Descripkion | Resource = | Path I Location | Tvpe

= & wWarnings (2 items)
# locations.gbuilder doesn't he locations. gbuilder  SpeechInputf... | Unknown Composer Proje
% services.gbuilder doesn't ha services.gbuilder | SpeechInput/... | Unknown Composer Proje

| 2

Each toolbar button is identified in the table below.

=)

Statistics Manager View

View Menu

Select to show additional actions for this view. Show: All Errors,
Warning on Selection, Show All. Group By: Java Problem Type,
Type, JavaScript Problem Type, Severity, None. Sort by:
Description, Resource, Path, Location, Type, Ascending New
Problems View Configure Contents. Opens a window where you
can filter the contents of the Problems tab. Columns. Opens a
dialog box where you can set the width and move the following
columns up and down: Description, Resource Path, and Location.
Preferences. Opens a dialog box where you can hide and show
the following columns: Description, Resource, Path, Location,
Creation Time, ID, Type.

Minimize
Minimizes the Problems tab.

Maximize

Maximizes the Problems tab.

The Statistics Manager view lets you easily create, delete, and organize created statistics into folders.
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- T
(ﬁ Properties (& Problems FE iiiiiiii Niﬂiiii ﬁ i C= Listobjects Manager} ECDI‘ISEJE-] C4% & | s ¥ =0

kvpe Filker bexk

Mame | Type | Cakeqgory | Subject | Filter | Arcess | :I
E allsit aiting Predefined
U5 InW QW aitTime Predefined J
E PositionInQueus Predefined
E RatatCallsInQueus Predefined
E RstatCallsInTransition Predefined
E R.5katCosk Predefined
E RSkatExpeckedl BEMWTLAS Predefined
E RStatExpectedloadBalance Predefined ;I

Each toolbar button is identified in the table below.

Add New Folder

L H
D You have the option of creating folders to organize statistics that
you create. Click this button to create a new folder.

Add New Statistic

S

Ula To build a new statistic, select a folder and click this button to
bring up Statistics Builder.
Delete Selected Item

x To delete a statistic that you have created, select the statistic

and click this button to delete.

Help View

The Help view shows the following toolbar after selecting Search from the Help menu.
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f@ Help &2 . Bl Cheat Sheets\l

ul
t

1]}

% Search

¥ Search expression:

| Wakch Expression

¢ Search scope Defaul
+ Local Help {1-10 of 16 hits)

ﬂgn Reevaluate Watch Expression
Select the Reevaluate Watch Expression cormmand ko Force
the selected watkch expression to be evaluated,
[Reevaluate Watch Expression] [Felated Reference]
Expressions Yiew

H\Jn Disable Wakch Expression
Select the Disable cormmand to disable the selected watch

Each toolbar button in the Help view is identified in the table below.

¢

0oo

i}

Once you select a topic, the toolbar changes as sh

Show All Topics

Select to display all available Help topics.

Show Result Categories

Select to display the categories for the Help results.

Show Result Descriptions

Select to display the descriptions of the Help topics.

Back

Move back through topics.

Forward

Move forward to next topic.

own below.
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f@ Help &3 = Cheat Sheets} i
i EE I

Composer Voice = Debugging Yoice Applications

Debugging a Callflow

The following graphic shows the interface's
elements forthe GVEF Debugging perspective
(callflow debugoing):

Each toolbar button is identified in the table below.

&

Show All Topics

Select to display all available Help topics.

Show in External Window

Select to display the results in an external window.

Show in All Topics

Select to display the results in all topics.

Print

Select to print the results/topic.

Bookmark

Select to bookmark the results/topic

Highlight Search Term

Select to highlight a search term.

Back

Move back through results.

Forward

Move forward to next result.
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Perspective Switcher Toolbar

Perspectives are task-oriented layouts for organizing the views and windows in your workbench. The
Perspective Switcher Toolbar allows quick access to perspectives that are currently open.

:=f ‘ T Composer £ Composer Design @ GVP Debugging

= 8
« Palette b
|E &:{. L=,
“*Output Link

“* Exception Link

Open Perspective Button

An Open Perspective button Ef (displaying all Eclipse perspectives) may be located at the start
or end of the Perspective Switcher toolbar, depending on your version of Eclipse.

Perspective Switcher Toolbar

The Perspective Switcher Toolbar is normally positioned below the main toolbar (top-left), but you can
also position it vertically on the left-hand side of the workbench.

Shortcut Menu for Perspective Buttons

Right-clicking the button for an active perspective opens a shortcut menu. The first three entries in
the table below do not appear if the perspective is not selected.

Customize Opens the customize perspective dialog box.

Opens a dialog box for saving a customize
Save As perspective. Once saved, the customize
perspective appears in the list that opens when
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you click the Open Perspective button.

Reset Resets the changes you made to a perspective.

Close Removes the button for the perspective.
Allows you to dock the perspective button: Top

Dock On Right, Top Left, or Left (left-hand side of work
bench).

Show Text Toggles between an icon and text on the

perspective button.
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Trimstack Toolar

Minimizing a view stack will also produce a toolbar in the trim at the outer edge of the workbench
window (a Trim Stack). This bar will contain a button for each of the views in the stack. Clicking on
one of these icons will result in the view being displayed as an overlay onto the existing presentation.
This is an example of a Trim Stack Toolbar containing buttons for Restore, Properties, Problems,
Console, Call Trace, and Prompts Manager views:

|le B8 B g B3

=
The first button is Restore 4, which restores the normal view.
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Debugging Toolbars

In GVP and ORS Debugging perspectives, the first pane contains Debug and Navigator views. The

second pane contains views for Variables, Breakpoints, and Expressions. A GVP example is shown
below.

g EYPF Debugging - SpeechInput/src-gen/Main.y=ml - Composer ‘Jﬂ]ﬂ
Eile Eﬂ ﬂavl-nate Search  Profeck Run  Configuration Server  Window Help

}r | Jf‘ i - % J‘Q"] @.u'ﬂpﬂﬁ.ml‘?m’] wipl w XD O e o -

EEEE % Gve Debuggng KD Strategy Designer %5 Composer

o D M Variables 33\99 &ndq:-urt\l“-‘r';}fExpmssuw-\I e AT D\
i e ] | o & o § |3 7| Hame | value =
El ¢ Main.v=ml {(SpeechInput) [NEI Real-time Debugg = Ao Session Object |5
& n:'F} RTD @ calidref fasdeicd 480a0r 1
= ..’% L Thread (Pauced) ;‘ : ;II:' mm ﬁﬁ .
B4 ML Excecution [URL: hetp:fil72.21, X I ¥

Debug View

The Debug view shows the name of the callflow or workflow diagram being debugged, as well as the
status of the debug progress or result.

(FrEONGIEEE 7

% Ow | 23R BY
B lﬁ Main.wxml {SpeechInput) [MGI Real-time Debugger]
= g# RTD
YxMLI Thread (Paused)

------ = WML Execution [URL: htkpsff172.21 . 26,61:8080) 3peechInput)src-o
< | 1|

Each toolbar button is identified in the table below.

% | Remove All Terminated Launches

Select to clear the Debug view of all terminated launches.

Resume
[

Select to resume the execution of the currently suspended
debug target.
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Suspend
(0

[Not supported in Composer]

Terminate

Select to terminate the launch associated with the selected

debug target. Once a launch is terminated it can be
automatically removed from the Debug view. When using the
ORS Debugger, Terminate means that the session in ORS will
end along with the debugging session.

Disconnect
&‘*T Not supported for the GVP Debugger. When using the ORS

Debugger, Disconnect means that the debugging session ends,
but ORS will continue executing the SCXML.

Step Into

&

Disabled for both routing and voice applications.

Step Over

Step Over is the only way to step for both routing and voice

i applications. Select to step over the next method call (without
entering it) at the currently executing line of code. Even though
the method is never stepped into, the method will be executed
normally.

Step Return

%
[Not supported in Composer]
— Drop to Frame
=%
[Not supported in Composer]
=% Use Step Filters
—— [Not supported in Composer]
View Menu
Select from the following:
= e View Management

¢ Java (then select from: Show Monitors, Show
System Threads, Show Qualified Names, Show
Thread Groups)

Navigator View

The Navigator view shows the same Project folder structure shown in the Project Explorer window of
the Composer perspective.
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T

F-1=F March23davaoiceProj |
El'J_ﬁ SpeechInput
IE? Jsettings
E? Zallflows
¥ (2= debugging-results
[;'; include

Each toolbar button on the Navigator toolbar is identified in the table below.

-

L]

E

Back

Moves back.

Forward

Moves forward.

Up

Navigate up one level in the hierarchy

Collapse All

Select to collapse all of the current elements in the view.

Link Open Editors

When you have multiple files open for editing, select to bring an
open file to the foreground (make its editor session the active
editor) every time you select that open file in one of the
navigation views.

View Menu

Select to show additional actions for this view.

* Select Working Set. Working sets group
elements for display in views or for operations
on a set of elements. The navigation views use
working sets to restrict the set of resources that
are displayed. If a working set is selected in the
navigator, only resources, children of resources,
and parents of resources contained in the
working set are shown.

¢ Deselect Working Set. Deselects the active
working sets. All elements are shown after
invoking this action.

e Edit Active Working Set. Opens the Edit
Working Set wizard to edit the currently active
working set.

e Sort (by name or type).
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Variables View

* Filters (class, JETEmitters, general, or *).

e Link with Editor. Brings an open file to the
foreground (makes its editor session the active
editor) every time you select that open file in
one of the navigation views.

The Variables view displays information about the variables associated with the stack frame selected
in the Debug view. When debugging a Java program, variables can be selected to have more detailed
information as displayed below. In addition, Java objects can be expanded to show the fields that a

variable contains.

-
()= Yariables &3 g Breakpu:uints} g Expressinns} lﬁ WL Prnperw lﬁ Cnnfiguratinw 7

o

s B

Mame | Yalue

e

[Fl % session.conneckion
& callidref
@ coxml
F % local

“

Session Ohject

cfea?a1410ch95ef1 323c265340d5396@1 72,

1500 Ohiject
150N Ohject
sip: dialogi@ 135

20,54, 47 :5070; voicexml=h i

sip:dialogflis.120.584.47:5070;voicexml=http://172.21.26. El:;l

Each toolbar button in the Variables view is identified in the table below.

=t

Show Type Names
Select to change if type names should be shown in the view or

not. Unavailable when columns are displayed. Hint: Select
Layout from View menu and de-select Show Columns.

Show Logical Structure

Select to change if logical structures should be shown in the
view or not.

Collapse All

Select to collapse all the currently expanded variables.

View Menu

Select from the following:

¢ Layout: Vertical View Orientation, Horizontal

Composer Help

175



Composer Toolbars and Views

Breakpoints View

View Orientation, Variables view Only, Show
Columns, Select Columns.

¢ Java: Show Constants, Show Static Variables,
Show Qualified Names, Show Null Array Entries,
Show References, Java Preferences.

The Breakpoints view and toolbar manage breakpoints within a debugging session.

Each toolbar button in the Breakpoints view is identified in the table below.

b

Remove Selected Breakpoints

Select to clear all selected breakpoints.

Remove All Breakpoints

Select to clear all breakpoints.

Show Breakpoints Supported by Selected
Targets

Select to show all breakpoints supported by the selected
targets.

Go To File For Breakpoint

[Not supported in Composer]

Skip All Breakpoints

Select to skip over all breakpoints.

Create URL Breakpoint

Select to create a breakpoint that uses a URL.

Expand All

Select to expand all the current breakpoints.

Collapse All

Select to collapse all the current breakpoints.

Link With Debug View

[Not supported in Composer]

Add Java Exception Breakpoint
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Select to open a dialog box where you can:

e Type a string that is contained in the name of
the exception you want to add. You can use
wildcards as needed ("* " for any string and "? "
for any character).

e Select the exception types you want to add.

¢ Select Caught and Uncaught as needed to
indicate on which exception type you want to
suspend the program.

[This option is not relevant to GVP Debugging in Composer.]

View Menu

Select from the following:

e Group By: Breakpoints, Breakpoint Types,
Breakpoint Working Sets, Files, Projects,
Resource Working Sets, Advanced...

* Default Working Set
e Deselect Default Working Set
e Working Sets

¢ Show Qualified Names

Expressions View

Use the Expressions view to inspect data from a stack frame of a suspended thread, and other
places.

i = !
()= Variables (‘90 Breakpoirkt Mﬁ WL F'rn:np] b CDnFiguratq B

AR Y X%
- E?‘“l" "args"= String[0] {id=17) ;!

"

EEY oList'= ArrayList<E> (id=21)
®- @ elementData= Object[10] {id=51)
----- < modCount= 3

Each toolbar button in the Expressions view is identified in the table below.

Show Type Names

ﬁ- Select to change if type names should be shown in the view or
not. Unavailable when columns are displayed. Hint: Select
Layout from View menu and de-select Show Columns.
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Show Logical Structure

=4

E Select to change if logical structures should be shown in the
view or not.
Collapse All

= P

Select to collapse all the currently expanded expressions.

Create a New Watch Expression

5%—’:-‘ Select to open the Create New Expression dialog box, which
allows you to create a new watch expression based on the
selected variable and add it to the Expressions View.

o Remove Selected Expressions

Select to remove the selected expressions.

Remove All Expressions

% |

Select to remove all expressions.

View Menu

Select from the following:

e Layout: Vertical View Orientation, Horizontal
View Orientation, Expressions View Only.

¢ Java: Show Constants, Show Static Variables,
Show Qualified Names, Show Null Array Entries,
Show References, Java Preferences.
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Minimizing and Restoring Views

Panes in the Composer window contain various views. Each view has its own tab. To minimize a pane
containing views:

{ e |

¢ Click the —— button to minimize the pane. This causes the views to appear in a toolbar (trim stack
toolbar). The toolbar appears in close proximity to where the pane was located.

The toolbar could be on the side or at the bottom of the Composer window depending on the selected
perspective. For example, assume you are editing a file in Composer Design perspective and
minimize the pane below, which contains Properties, Prompts Manager, Problems, Console, Call Trace,
and Bookmark views. In this case, the minimization causes a toolbar to appear at the bottom of the
Composer window. Depending on your screen, you may have to maximize the entire Composer
window in order to see this toolbar.

| 74 ExampleSCRMLCode, scml - March23)avalioiceProj [ amofzsm [ |
| @ Disconnected #,AEDI’-[:“E&EHI}

restore

To restore a minimized view:

=
¢ Click the 4, button to restore all minimize views.

¢ Click a single view button to restore an individual view.

Restore All Views

Select Window > Reset Perspective. If the desire view does not appear, select Window > Show
View.

Show Advanced Properties

When creating a diagram in Composer perspective, this button appears on the right side of the
Composer GUI, between the palette of blocks and the Properties view.

E: i ==

[ Show Advanced Properties

Composer Help 179


https://docs.genesys.com/Documentation/IW/8.1.4/Help/TrimStackToolbar
https://docs.genesys.com/Documentation/IW/8.1.4/Help/TrimStackToolbar

Composer Toolbars and Views

Certain block properties are hidden by default from the Palette. If you have permission you can use
the Show Advanced Properties button to display/hide these properties.

Moving the Location of a View

To move a view to another location, hold down the cursor next to the view name until you see a red
circle with a slash in the middle. Keep holding down the cursor, move the view to the desired
location, and release the cursor.
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Strategy Manager View

The Strategy Manager view lists all Routing Points from the connected Configuration Server. This view
provides options to directly deploy Composer generated strategies to routing points in Configraution

Server.

To access the Strategy Manager view, select the Strategy Manager icon from the toolbar. The

Strategy Manager view is displayed.

[T4 Strategy Manager &2

type filter text

U A

= 0

MName Number Script €3
v [ Switches
ng 2223 SIP_Switch 2223 script:BasicVR_VD.Basic/VR. Worlkflow
%7 3094140_5IP_Switch 3094140
%7 3084141_5IP_Switch 3094141 script:RoadAssistance
LSJ 3094742 _SIP_Switch 3094142 Personal Assistant-Voicemail
LSJ 6304663243 _SIP_Switch 6504663243 script:BasiclVR.BasiclVR.Workflow1_Basic VR
%7 6504663244 _SIP_Switch 6504663244 http://localhost/gms_demo/inbound.scxml
%7 6304663247 _SIP_Switch 6504663247 script:GenesysOne_Voice.default.GenesysOne_Voice
LSJ B000_S4B_Switch 8000
LSJ B000_SIP_Switch a0on SIP_Switch_B000-Router Controlled Callflow
ng 2001_SIP_Switch anm SIP_Switch_8001-Reute To Agent
%7 B002_SIP_Switch 8002 SIP_Switch_8002- Premier Financial Services
%3 B003_SIP_Switch 8003 SIP_Switch_B8003_8004-iCFD
LSJ 2004_SIP_Switch 8004 SIP_Switch_8003_8004-iCFD
LgJ B005_SIP_Switch 8005
ng 8006_SIP_Switch 8006 sim_Gi2 %
%7 B007_SIP_Switch 8007 MNov2013_WFMRouting
%3 B008_SIP_Switch 800a GVP_Behind_CTIC
LSJ 2009 _SIP_Switch 2009 SIP_Switch_8009 - Qutbound
LSJ B011_SIP_Switch 2011 scriptlava_refactor_32.default. defaultWorkflow
ng B012_5IP_Switch an12 Personal Assistant-Voicemail
%7 B013_5IP_Switch 8013 SIP_Server_2013_Route_To_Outbound_Agents
%7 B014_SIP_Switch 8014 Simulator - 2206 - Workforce Predictive Route
LSJ B015_5IP_Switch an1s Transfer_to_GAS_agent
LSJ B016_5IP_Switch anie Route_to_GAS_agent
ng B8017_SIP_Switch a7 SIP_Switch_8017-Chat_To_Video
W 2018 _Story_VM 2018 script:8018:101
%7 BO20_SIP_Switch 8020 scriptV_DeployScript_RP_J.default.defaultWorkflow
& 8021_5IP_Switch 8021 Send_Email w
£
This view is available from version 8.1.450.33.
To deploy a script to a routing point,
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e Select the required routing point and right-click Deploy Script. The Please select script for
<specified routing point> dialog is displayed.

* Select the required script and click OK. The script is deployed.
To undeploy a script from a routing point,
e Select the required routing point and right-click UnDeploy Script. A confirmation prompt is displayed.

* Click Yes. The script is undeployed.
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Voice Applications and Callflows

This section contains the following:

* Callflow Post Installation

* What is GVP and How Do Voice Applications Work?
* CallflowBlocks

* VariablesinCallflows

* HelloWorldSample

¢ Creating Voice Applications for GVP

e CreatingCCXMLApplications

* CreatingVXMLApplications

¢ Working with Java Composer Projects
e Working with .NET Composer Projects
¢ VXMLProperties
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Getting Started with Voice Applications

This section contains the following topics:

* Callflow Post Installation Configuration
* Working with Java Composer Projects
¢ Working with .NET Composer Projects

* Accessing the Editors and Templates

Also see Upgrading Projects/Diagrams.
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Callflow Post Installation

After installation of Composer, you need to perform some post-installation configuration tasks. Note:
If you plan to use IIS as your web server for testing and deployment, you will also need to configure
IIS preferences in Composer so that your applications can be auto-deployed to IIS from within the
workbench. Composer can work only with IIS installed on the local machine. You can work with both
Tomcat and IIS from the same installation of Composer. Also see: Context Services Preferences.

Tomcat

1. Select Window > Preferences, then expand Composer and select Tomcat. Starting with 8.1.420.14,
Composer supports Tomcat 7. Composer installation adds the role for manager-gui to Tomcat
configuration for callflows and workflows. The default username and password for the bundled Tomcat
is admin. The username and password for manager-gui is tomcat.

2. Provide the same port number that you specified during installation. The default user name and
password for the bundled Tomcat is admin.

3. To start Tomcat, click the ‘@ ' button on the main toolbar.

If you already have Java Composer Projects in the workspace and did not perform the Tomcat
configuration earlier, perform the following steps to deploy the project on Tomcat:
4. From the Project Explorer, right-click on the Java Composer Project and select Properties.

5. Select Tomcat Deployment and click the Deploy button.

Note: This also needs to be done if a Java Composer Project is imported.

Internet Information_Services

1. Select Window > Preferences, then expand Composer and select 11S/.NET.

2. Provide the IS website port number where you want to deploy your .NET Composer Project. The IIS
Default Website Site port number is 80.

3. If you plan to use .NET Composer Project builder to compile the server-side files (.aspx) in your .NET
Composer Project, you will need to configure the location of the aspnet _compiler.exe file in the
Microsoft .NET Installed Path field.

Note: The typical location of the ASP.NET compiler is:C:\WINDOWS\Microsoft.NET\Framework\
v2.0.50727\aspnet _compiler.exe.

4. Specify the Web Services Enhancement (WSE) path. This must be specified before Composer .NET
Projects can work.

Composer Help 185


https://docs.genesys.com/Documentation/IW/8.1.4/Help/SettingContextServicesPreferences

Voice Applications and Callflows

If you already have .NET Composer Projects in the workspace and did not perform the IIS
configuration earlier, perform the following steps to deploy the project on IIS:

5. From the Project Explorer, right-click on the .NET Composer Project and select Properties.

6. Select IIS Deployment and click the Deploy button.

Note: This also needs to be done if a .NET Composer Project is imported or renamed as well.

GVP Debugger

1. Select Window > Preferences, then expand Composer and select Debugging.
2. Specify the following settings:

* Network Interface. Composer debugging uses this setting to make the socket connection
for the Debugger control channel. Select the interface that is applicable to your scenario.
The debugging server (GVP or ORS) must be able to access the Tomcat server, bundled as
part of Composer, for fetching the Voice or Routing application pages. If you have multiple
NIC cards of multiple networks (such as Wireless and LAN) select the interface on which GVP
or ORS will communicate to your desktop. In case you are connected over VPN, select the
VPN interface (such as PPP if connected via a Windows VPN connection).

¢ Client Port Range. Enter a port range to be used for connection to ORS for SCXML
debugging sessions.

3. Select GVP Debugger and specify:

¢ SIP Phone User Name. This is the user name or phone number of your SIP Phone.

SIP Phone Hostname/IP . This is the IP address on which your SIP phone is running. It is
possible to send the call to a SIP Phone located on some other machine, but it is generally
advisable to have the SIP Phone locally for ease of access. If you have multiple NIC cards or

interfaces, make sure you specify the same IP address as corresponds to the Network
Interface selected above.

SIP Phone Port. This is the port on which your SIP phone is running.

Platform IP. This is the IP address of your GVP Server. Note: Composer 8.1 is compatible
with GVP 8.1. Operation with GVP 8.0 is not supported.

Platform Port. Typically, this will be the default port 5060 or the port that you configured
for the Resource Manager (RM) or Media Control Platform (MCP) on your GVP Server. You can

make direct calls to MCP from the debugger. However, if using pre-provisioned DNIS, then
you will need to make test calls to the RM.

* Use Secure Connection. See Debugging TLS Support.

Composer may display a prompt asking if you wish to propagate these settings to an existing launch
configurations.
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MIME Types

MIME (Multipurpose Internet Mail Extensions) refers to a common method for transmitting non-text
files via Internet e-mail. By default the SCXML MIME type is already configured in the Tomcat server
bundled with Composer. If you are using the Internet Information Services (11S) Application Server to

deploy ASP.NET projects, add the following MIME type extensions through the IIS Manager of your
webserver:

.json text/json
vxml text/plain
.scxml text/plain
xml text/xml

Prompt Resource Validation

This preference enables diagram validation warnings where prompt audio resources no longer exist in
the given file path. If the audio file is no longer present, the diagram block will show a warning icon.

1. Select Window > Preferences.
2. Select Composer > Composer Diagram.

3. Select the option Enable Validation for Prompt Resources. By default the preference is not enabled.

Media Control Platform

GVP 8.1 provides a debugger interface to allow Composer to make direct calls. By default it is turned
off and you will have to enable it to allow GVP to accept calls from the debugger interface.

1. Outside of Composer, locate your Media Control Platform (MCP) Application. For example, you can open
your MCP Application object in Configuration Manager or in Genesys Administrator for the Configuration
environment that is serving the MCP platform.

2. Under the vxmli section of the MCP, look for a setting called debug.enabled. By default, it is set to
false. Change the value to true and restart your MCP.

Firewall

If you have a local firewall on your machine, open up the following ports:

e Tomcat port (generally, this is set to port 8080). If you installed Tomcat on a different port, open its
corresponding port in the firewall.

e IS port (generally, this is set to port 80). If you installed IIS on a different port, open its corresponding
port in the firewall.
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e The UDP port on which your SIP phone is running (by default, this will be either 5060 or 5070). Check
your SIP phone settings for the exact port number.

e RTP ports on which your SIP phone will get the audio stream. Check your SIP phone Help file for details
on this. Some SIP phones will autoconfigure this during installation.

If you continue to run into problems with the firewall and calls are not coming through successfully,
consult your network administrator.
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Working with Java Composer Projects

A Java Composer Project contains voice application files, callflows, and related server side .jsp / Java
files for building an IVR application. A Java Composer Project can also contain routing workflows. It
has an associated Java Composer Project builder that will compile source files in the project.
Composer ships with a bundled Tomcat and it is used as the web/application server for Java
Composer Projects during the development and testing phase. For information on supported
operating systems for Java Composer Projects, see the Composer 8.1 Deployment Guide.

Getting Started

To start using Java Composer Projects:

1. Create a new Java Composer Project.

2. Use the Project Properties tab to deploy the Java Composer Project to Tomcat within Composer. (Right-
click the project > Properties > Tomcat Deployment.)

3. Create callflows and use Run or Debug mode to launch the call with Next Generation Interpreter.
Note: Run as / Debug as will automatically pick the port number from the preferences and form the

corresponding Application URL. For example: http://machinelP:portno/JavaVoiceProjectName/src-gen/
CallflowName.vxml
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Working with .NET Composer Projects

A .NET Composer Project contains voice application files and related server side .aspx / C# / files for
building an IVR program. It has an associated .NET Composer Project builder based on Microsoft .NET
Framework that can incrementally compile .aspx source files as they are changed.

Prerequisites

This step is not a mandatory prerequisite. Starting with 8.1.420.14, Composer allows creating .NET
Composer Projects without the WSE dll files. Microsoft Web Services Enhancements (WSE) is also
required for creating .NET projects in Composer. However, the WSE installer may not install on
Windows 2008. These steps give a workaround:

Download the Microsoft WSE 3 "msi" installer bundle.

Use 7Zip to extract the contents to a folder.

In Composer, select Window > Preferences > Composer > IIS/.NET.

Set the Microsoft WSE 3.0 Installed Path field the $Folder\Microsoft.Web.Services3.dll file.

M

Create your Composer .NET Projects.

Getting Started

To prepare for using .NET Composer Projects:

1. Install Microsoft IIS.
2. Install Microsoft .NET and .NET Framework.

Note: Microsoft .NET is required for Composer Server Side blocks.

1. Enable ASP.NET in your IIS.
2. Configure the following MIME settings in your IIS:

e .ccxml - application/ccxmi+xml
e .vxml - text/xml

e .grxml - application/srgs+xml

* .vox - audio/basic

e .scxml - application/xml

3. Configure the IIS Website Port number in Composer |IS Preferences (Window > Preferences > .NET)
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By default, IS comes with the DefaultWebSite which runs on port 80. If you want to deploy the .NET
Composer Project in your custom website, configure the corresponding port number in the IIS Website

Port field.

1. Create a .NET Composer Project.

2. Use the Project Properties tab to deploy the .NET Composer Project to IIS within Composer. (Right-click
Properties > IIS Deployment.)

3. Create the diagram callflows and perform Run as / Debug as to launch the call with NGI.
Note: Run as / Debug as will automatically pick the port number from the preferences and form the

corresponding application URL. For example: http://machineIP:portno/NETProjectName/src-gen/
CallflowName.vxml Also see: Request.Form Error Message for .NET Projects

Composer Help 191


https://docs.genesys.com/Documentation/IW/8.1.4/Help/CreatingVoiceApplicationsforGVP
https://docs.genesys.com/Documentation/IW/8.1.4/Help/DebuggingVoiceApplications#Run_Versus_Debug
https://docs.genesys.com/Documentation/IW/8.1.4/Help/Request.FormErrorMessage

Preferences for Voice Applications

Preferences for Voice Applications

Composer Preferences are applicable at a workspace level. They apply to all projects within the
workspace. To open the Preferences dialog box for Composer, select Window > Preferences and
expand Composer.

Note: You can also set options in the Project Properties dialog box by right-clicking a Project and
selecting Properties.

¢ CCXMLFile Preferences

* Diagram Preferences

* GAX Server Preferences

¢ GRXML File Preferences

* VXML File Preferences

¢ GVP Debugger Preferences

e .NET Preferences

* Time Zone Preferences

* Tomcat Preferences

e XML Preferences

¢ Context Services Preferences

There are also Refresh automatically and Time zone preferences.

Tip
You can also set options in the Project Properties dialog box. Right-click a Project and
select Properties
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CCXML File Preferences

Select Window > Preferences > Composer > CCXML Files. The following preferences for CCXML
files can be set in the Preferences dialog box:

Creating Files

1. Under Creating Files, select the Suffix to use for CCXML files from the drop-down list: * ccxml
2. Select the Encoding type from the drop-down list. The encoding attribute in a CCXML document

specifies the encoding scheme. The encoding scheme is the standard character set of a language. The
CCXML processor uses this encoding information to know how to work with the data contained in the
CCXML document. UTF-8 is the standard character set used to create pages written in English. Select
from the following:

e |1SO 10646/Unicode(UTF-8)

¢ |SO 10646/Unicode(UTF-16) Big Endian

e |SO 10646/Unicode(UTF-16BE) Big Endian

¢ |SO 10646/Unicode(UTF-16LE) Little Endian

e US ASClI

e |SO Latin-1

e Central/East European (Slavic)

e Southern European

e Arabic, Logical

e Arabic

* Chinese, National Standard

e Traditional Chinese, Big5

e Cyrillic, ISO-8859-4

e Cyrillic, ISO-8859-5

* Greek

* Hebrew, Visual

* Hebrew

e Japanese, EUC-JP

* Japanese, ISO 2022

e Japanese, Shift-JIS

e Japanese, Windows-31]
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Korean, EUC-KR
* Korean, ISO 2022
Thai, TISI

e Turkish

Validating Files

e Select or clear the Warn when no grammar is specified check box (not selected by default).

Source and Syntax Coloring

Source and Syntax Coloring preferences for CCXML files are set under the XML preferences provided
by Eclipse.

* Use Window > Preferences, expand the Web and XML entry, then expand the XML Files subentry.

Templates

In addition to previewing templates, you can create, edit, and remove selected templates. There are
also buttons to:

¢ Restore a removed template.

e Revert back to a default template

¢ Import a template.

Export a template.
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Diagram Preferences

Select Window> Preferences > Composer > Composer Diagram. The following preferences for
diagrams can be set in the Preferences dialog box:

Global Settings

1. Select or clear the check box for each of the following diagram global settings:

« Show Connection Ports. If enabled, connection ports (both exception ports and out ports)
are always displayed on blocks. This makes it convenient to draw links between blocks and
to get immediate feedback on how many ports each block provides. However, in this case,
the ability to reposition connections on a block is not available. If switched off, connection
ports are not displayed by default, but repositioning or finer control over connection link
placement becomes available. Note: This preference applies to all projects and is not
available for individual projects.)

* Show popup bars. If enabled, this setting displays basic blocks from the blocks palette in a
pop-up bar if you hover your mouse on the diagram for one or two seconds without clicking.
Note: blocks are shown in icon view only.)

* Enable animated layout. If enabled, causes diagrams to gradually animate to their
location when the Diagram \> Arrange \> Arrange All menu option is clicked.

* Enable animated zoom. If enabled, while using the zoom tools, shows a gradual transition
between the initial and final state of the diagram on the canvas. If off, the zoom is
instantaneous. Similar behavior for animated layout when the Diagram \>\> Arrange \>\>
Arrange All menu option is clicked.

¢ Enable anti-aliasing. If enabled, improves the appearance of curved shapes in the
diagram. You can see its effect on the circles in the Entry and Exit blocks.

e Show CodeGen success message. If unchecked, then the confirmation dialog at the
completion of code generation will not be shown.)

* Prompt to Save Before Generating Code. If checked, when you generate code for an
unsaved diagram, a prompt appears indicating the diagram has been modified and asking if
you want to save the changes before generating code. The dialog box also contains a
checkbox: Automatically save when generating code and do not show this message again.

* Show Validation success message. If unchecked, then the confirmation dialog at the time
of Validation will not be shown.)

¢ Enable Validation for Prompt Resources. This preference is used for voice applications.
If unchecked, then a validation check for missing prompts is not performed at the time of
Validation.

e Interaction Process Diagram. If unchecked, Composer will save Interaction Process
Diagrams before publishing.

* Prompt to delete Published objects when Interaction Process Diagram is deleted. If
unchecked, Composer will attempt to delete any Published objects when an Interaction
Process Diagram is deleted. If Composer is not connected to Configuration Server, object
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deletion will not work.

* Parameters auto synchronization (available starting with 8.1.410.14). This option
reduces developer coding time by enabling Composer to automatically declare variables in a
Main diagram to match input/output variable names in Subdialog block/Subroutine diagrams
and to automatically perform the mapping. This feature is available for both user and
system variables. For example, if a Subroutine diagram returns a variable called “xyz” and if
Composer automatically declares “xyz” in the Main diagram to hold the output, then you do
not have to manually do the mapping. If enabled, you are prompted for auto-
synchronization whenever there is a need to change parameters names or add new
variables in the dialogs.

Scenarios:

1. Subdialog or Subroutine Diagram: Entry Block—The auto-synchronization process will
synchronize any newly added/updated variables and existing variables in the
Subdiagram. If you add a new Input type variable, a prompt appears asking whether to
add a corresponding Input parameter. You are also prompted to select or add the Input
source variable in all the called Subroutine diagrams. New parameter naming in the
calling Subdialog block is the same as the Input variable added in the Entry Block. If the
Subroutine diagram is called from many diagrams, Composer provides a variable
selection option for the called diagrams.

2. Main callflow Diagram: Entry Block—If you add a new Input type variable, a prompt
appears asking whether to add the corresponding input parameter. You are also
prompted to select or add an Input source variable in all the called Play Application
blocks. New Parameter naming in the calling Play Application block is the same as the
Input variable added in the Entry Block. If the Main diagram was called from multiple
Play Application blocks, a variable selection option for all the called blocks is provided.

3. Subdialog or Subroutine diagram: Exit Block—If you change or delete a return parameter,
a prompt appears on whether to delete the Output parameter and/or the missing ones in
case of a change in all the called Subroutine or Subcallflow diagrams.

4. The auto-synchronization parameter option also applies when there is a change in a
configured Subroutine diagram. The auto-synchronization dialog confirmation appears as
soon as a Subroutine diagram is added/updated. If the confirmation dialog is selected, it
automatically synchronizes the Subroutine parameters to the Main diagram. This auto-
synchronization prompt always appear even though the same diagram is updated again.
When Output parameters are added in the Exit block, parameter synchronization also
occurs.

5. Application URL for Publish and Debugging. Select Use IP Address or Use Host
Name.

Notes:

Composer creates unique names for auto-sync variables, such as <SubBlockName>_<VariableName>.
SubBlockName is the name of the Subroutine/ Subdialog / Play Application blocks where the Subroutine diagram is
being invoked. VariableName is the input variable name created in a Subroutine diagram.

2. Click Apply.

Colors and Fonts

1. Select Appearance under Composer Diagram.
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2. Click Change and make selections to change the default font if you wish.

3. Click the appropriate color icon beside any of the following and make selections to change color:

* Font color

¢ Fill color

e Line color

* Note fill color

¢ Note line color

4. Click Apply.

Connections

1. Select Connections under Composer Diagram.

2. Select a line style from the drop-down list:

¢ Oblique

¢ Rectilinear

3. Click Apply.

Pathmaps

1. Select Pathmaps under Composer Diagram.

2. Click New to add a path variable to use in modeling artifacts, or If the list is populated, select the check
box of a path variable in the list.

3. Click Apply.

Printing

Select Printing under Composer Diagram.
Select Portrait or Landscape orientation.
Select units of Inches or Millimetres.

Select a paper size (default is Letter).

v ok W

Select a width and height (for inches, defaults are 8.5 and 11; formillimeters, defaults are 215.9 and
279.4).

6. Select top, left, bottom, and right margin settings (for inches, defaults are 0.5; for millimeters, defaults
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7.

are 12.7).
Click Apply

Rulers and Grid

You can make use of rulers and grids when creating diagrams. Rulers and grids can provide a
backdrop to assist you in aligning and organizing the elements of your callflow diagrams.

1.
2.
3.

Select Rulers and Grid under Studio Diagram.
Select or clear the Show rulers for new diagram check box (not selected by default).

Select ruler units from the drop-down list:

¢ Inches
¢ Centimeters

¢ Pixels

Select or clear the Show grid for new diagrams check box (not selected by default).

. Select or clear the Snap to grid for new diagrams check box (selected by default).

Type a value for grid spacing (for inches, the default is 0.125; for centimeters, the default is 0.318; for

pixels, the default is 12.019).

. Click Apply.
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GAX Server Preferences

Select Window > Preferences > Composer > GAX Server.

If using the OPM Block for a voice or routing application, you must set GAX Server Preferences.

Tip

GAX refers to a Genesys Administrator Extension (GAX) plug-in application used by
Genesys EZPulse, which is accessible from a web browser. EZPulse enables at-a-
glance views of contact center real-time statistics in the GAX user interface.
Composer diagrams connect to GAX using the preference login credentials for fetching
the Audio Resource Management (ARM) parameters or IDs list configured for the

tenant as described in the Configuration options appendix of the Genesys
Administrator Extension Deployment Guide.

The following preferences can be set in the GAX Server Preferences dialog box:

Server Host Name/IP. Enter the hostname or address of the Application server hosting the GAX
Server.

* Port Number. Enter the port number for the GAX Server used in your environment.

¢ Username. Enter the username defined in the Configuration Database for logging into the GAX
server.

* Password. Enter the password defined in the Configuration Database for logging into the GAX
server.
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GRXML File Preferences

Select Window > Preferences > Composer > GRXML Files. The following preferences for GRXML
files can be set in the Preferences dialog box:

Creating Files

1. Under Creating Files, select the Suffix to use for GRXML files from the drop-down list:* grxml
2. Select the Encoding type from the drop-down list. The encoding attribute in a GRXML document

specifies the encoding scheme. The encoding scheme is the standard character set of a language. The
GRXML processor uses this encoding information to know how to work with the data contained in the
GRXML document. UTF-8 is the standard character set used to create pages written in English. Select
from the following:

e |1SO 10646/Unicode(UTF-8)

¢ |SO 10646/Unicode(UTF-16) Big Endian

e |SO 10646/Unicode(UTF-16BE) Big Endian

¢ |SO 10646/Unicode(UTF-16LE) Little Endian

e US ASClI

e |SO Latin-1

e Central/East European (Slavic)

e Southern European

e Arabic, Logical

e Arabic

* Chinese, National Standard

e Traditional Chinese, Big5

e Cyrillic, ISO-8859-4

e Cyrillic, ISO-8859-5

* Greek

* Hebrew, Visual

* Hebrew

e Japanese, EUC-JP

* Japanese, ISO 2022

e Japanese, Shift-JIS

e Japanese, Windows-31]
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Korean, EUC-KR
* Korean, ISO 2022
Thai, TISI

e Turkish

Validating Files

e Select or clear the Warn when no grammar is specified check box (not selected by default).

Source and Syntax Coloring

Source, Syntax Coloring, and Template preferences for GRXML files are set under the XML
preferences provided by Eclipse.

* Use Window > Preferences, expand the Web and XML entry, then expand the XML Files subentry.

Templates

In addition to previewing templates, you can create, edit, and remove selected templates. There are
also buttons to:

¢ Restore a removed template.

e Revert back to a default template

¢ Import a template.

Export a template.

Composer Help 201



Preferences for Voice Applications

VXML File Preferences

Tip
Composer natively supports VXML 2.1.

Select Window > Preferences > Composer > VXML Files.The following preferences for VXML
files can be set in the Preferences dialog box:

Creating Files

1. Under Creating Files, select the Suffix to use for VXML files from the drop-down list: *.vxml
2. Select the Encoding type from the drop-down list. The encoding attribute in a VXML document specifies

the encoding scheme. The encoding scheme is the standard character set of a language. The VXML
processor uses this encoding information to know how to work with the data contained in the VXML
document. UTF-8 is the standard character set used to create pages written in English. Select from the
following:

* 1SO 10646/Unicode(UTF-8)

* ISO 10646/Unicode(UTF-16) Big Endian

¢ |SO 10646/Unicode(UTF-16BE) Big Endian

e 1SO 10646/Unicode(UTF-16LE) Little Endian

e US AsClI

e |SO Latin-1

e Central/East European (Slavic)

e Southern European

¢ Arabic, Logical

e Arabic

e Chinese, National Standard

¢ Traditional Chinese, Big5

e Cyrillic, ISO-8859-4

e Cyrillic, ISO-8859-5

* Greek

* Hebrew, Visual

¢ Hebrew
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* Japanese, EUC-JP

* Japanese, ISO 2022

* Japanese, Shift-JIS

e Japanese, Windows-31])
Korean, EUC-KR
Korean, ISO 2022

Thai, TISI

e Turkish

Validating Files

e Select or clear the Warn when no grammar is specified check box (not selected by default).

Source, Syntax Coloring, and Templates

Source, Syntax Coloring, and Template preferences for VXML files are set under the XML preferences
provided by Eclipse.

¢ Use Window > Preferences, expand the Web and XML entry, then expand the XML Files subentry.

This preference allows you to add custom VXML schemas into Composer to be used in namespaces
for new VXML files created through the VXML editor.
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GVP Debugger Preferences

Select Window > Preferences > Composer > Debugging > GVP Debugger. GVP Debugger
preferences are usually set during callflow post-installation configuration, when you first run
Composer. Detailed post-installation configuration instructions are also provided in the Configure
Tomcat and Debugger Settings Cheat Sheet (Help > Cheat Sheets > Composer > Voice

Applications).
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IIS.NET Preferences

Select Window > Preferences > Composer > IIS/.NET.

[IS/.NET preferences are usually set during post-installation configuration, when you first run
Composer. Detailed post-installation configuration instructions are provided in the Setting IIS
Preferences Cheat Sheet (Help > Cheat Sheets > Composer > Building Voice Applications),
and also in Post-Installation Configuration.
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Setting Context Services Preferences

Go to Window > Preferences > Composer > Context Services to open the Context Services
dialog box. If using a Composer version prior to 8.1.440.18, the dialog box will not contain a Service

management section.
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Context Services

& v o

Context Services are provided by the Universal Contact Server (UCS) and the Genesys Mobile

Services (GMS).

Customer Profile management. These settings apply to Profile related blocks.

[ ] Connect to the Universal Contact Server when designing diagrams

Server Hostname | 127.0.01

Server Port 80

Base URL |

Security Settings
Sa Sedlre connmeaciiomn
MNever TS
[ Use authentication

User |

Password |

Test Connection
Service management. These settings apply to Service related blocks.

Use Genesys Mobile Services
Connect to the Universal Contact Server when designing diagrams

Server Hostname | 127.0.0.1

Server Port | 80

Base URL | genesys/1/cs

Tenant | 1

Security Settings
Ise secure connection

Mever TLS
[ ] Use authentication

User |

Password |

Test Connection

Context Services objects Validation
(O No validation

(®) Validate if connected

(O Validate

Locale settings
Time Zone (GMT-08:00) America/Los_Angeles =

Restore Defaults |

Apply

OK |

Cancel
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Guidelines for Context Services Preferences

[+] Guidelines for Context Services Preferences

The table below supplies some guidelines for defining Context Services Preferences.

Installation Type

Context Services 8.1 or earlier -
Profile and Service APIs served
by UCS

Context Services 8.5 or later - No
Load Balancer

Context Services 8.5 or later -
Load Balancer (LB)

Customer Profile
Management

Set UCS parameters according to
UCS options.

Set UCS parameters according to
UCS options.

Set UCS parameters to match the
LB options.

Customer Profile Management Section

Service Management

Do not check the Use Genesys
Mobile Service checkbox. Set
the UCS parameters according to
UCS options.

Check the Use Genesys Mobile
Service checkbox. Set GMS
parameters according to GMS
options.

Check the Use Genesys Mobile
Service checkbox. Set GMS
parameters to match the LB
options.

1. Use the Guidelines for Context Services Preferences section above for selecting/unselecting the
Connect to Universal Contact Server when designing diagrams box.

2. Under Server Host Name, enter the server host IP address in your Configuration Database, which
identifies the Universal Contact Server. See Tip below.

3. Enter the Server Port number for Universal Contact Server. For the port number, open the Universal
Contact Server Application object in your Configuration Database, go to Options tab, select the
cview section, and the port option.

4. Enter the Base URL for the Context Services server. This should only be configured if you use UCS 8.1.

Do not set if you use UCS 8.5.

5. Under Security Settings, Use secure connection, select Never or TLS if Transport Layer Security is
implemented as described in the Genesys 8.1 Security Deployment Guide.

6. Select Use Authentication to require a user name and password when connecting to Universal
Contact Server. If selected, enter the User and Password fields.

7. Click the Test Connection button (enabled if the Connect to Universal Contact Server when
design diagrams box is checked). Clicking should cause connection successful to appear. If not, check
that Universal Contact Server is running and that the entered host/port values are correct. Other
sources of error could be that the base URL parameter value is incorrect or the UCS version is not 8.1 or

higher.

8. Under Context Services object Validation, select one of the following: No validation, Validate if
connected, or Validate. This setting is used and shared by the Profile/Service blocks.
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Tip

Host/port/URL/tenant are used at design time by Composer (when the Connect to
Universal Contact Server when designing diagrams box is selected). They are
also used by Composer when publishing an interaction process diagram. Composer
stores these parameters in the EnhancedRoutingScript objects. SCXML applications
can then read those settings at runtime to connect to UCS/GMS accordingly.

Service Management Section

1.

u A W N

10.

Select either Use Genesys Mobile Services or Connect to the Universal Contact Server when
designing diagrams. See Guidelines for Context Services Preferences section above for more
information. Steps 2, 3, and 4 below relate to UCS or GMS, depending on the Use Genesys Mobile
Services box.

. Under Server Host Name, enter the host IP address. See above note (Tip).
. Enter the server port number.
. Enter the Base URL for the host. When using GMS, the base URL is normally /genesys/1/cs.

. Enter the Tenant. GMS Context Services (optionally) supports multi-tenancy. The tenant to use is

passed as a header (ContactCenterId=x) of the request. This field is disabled when Connect to the
Universal Contact Server when designing diagrams is selected.

. Under Security Settings, Use secure connection, select Never or TLS if Transport Layer

Security is implemented as described in the Genesys 8.1 Security Deployment Guide.

. Select Use authentication to require a user name and password. If selected, enter the User and

Password fields.

. Click the Test Connection button. Clicking should cause connection successful to appear. When using

GMS, no connection is made from Composer to GMS. Connections to GMS are initiated only at runtime
by ORS/MCP.

. Under Context Services object Validation, select one of the following: No validation, Validate if

connected, or Validate. This setting and the setting below is used and shared by the Profile/Service
blocks.

Under Local Settings, select the time zone.

Tip

Composer can successfully communicate with UCS at design stage whatever the UCS
mode is (production or maintenance). However, UCS needs to be in production mode
at runtime stage (when running Context Services SCXML or VXML applications, even
when using GVP Debugger).
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Time Zone Preferences

Composer displays all date/time elements in the user-preferred time zone with the time zone
identifier. You can change the preferred time zone in Window > Preferences > Composer >
Context Services.
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Tomcat Preferences

Select Window > Preferences > Composer > Tomcat Tomcat preferences are usually set during
post-installation configuration, when you first run Composer. Detailed post-installation configuration
instructions are provided in the Configure Tomcat and Debugger Settings Cheat Sheet (Help > Cheat
Sheets > Composer > Building Voice Applications), and also in Callflow Post-Installation
Configuration or Workflow Post Installation Configuration.

Composer Help 211


https://docs.genesys.com/Documentation/IW/8.1.4/Help/CallflowPostInstallation#Tomcat
https://docs.genesys.com/Documentation/IW/8.1.4/Help/CallflowPostInstallation#Tomcat
https://docs.genesys.com/Documentation/IW/8.1.4/Help/WorkflowPostInstallation#Tomcat

Preferences for Voice Applications

XML Preferences

You can also set XML File Preferences for both routing and voice applications: Window >
Preferences > XML > XML Files. When specifying Encoding formats in the XML Preference page:
encoding formats are applicable only for new File creation using the Template option: (File > New >
XML > XML File > Create XML File from an XML Template > Select XML Template). This
applies only to new XML, VXML, CCXML and SCXML files. Existing files within the Project will not get
impacted.
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Creating Voice Apps for GVP

This section provides key information about using Composer to build VoiceXML-based callflow
applications after callflow post installation configuration. You should be well-versed in VoiceXML, XML,
and HTML before attempting to use Composer. You should also have reviewed Getting Started with
Voice Applications. To help you get started:

e From within Composer, select Help > Cheat Sheets > Composer to see how some basic voice
applications can be created.

* Your First Application
* Sample Applications & Templates.

To start immediately, see:

* Creating VXML Applications or
¢ Creating CCXML Applications
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What is GVP and How Do Voice Apps Work

The Genesys Voice Platform (GVP) is a VoiceXML-based media server for network service providers
and enterprise customers.

What is GVP?

At the most basic level, Genesys Voice Platform (GVP) is Interactive Voice Response software (soft
IVR). At a more complex level, GVP is a software suite that integrates a combination of call
processing, reporting, management, and application servers with Voice over IP (VoIP) networks, to
deliver web-driven dialog and call control services to callers.

Using features such as Automatic Speech Recognition (ASR) and Text-to-Speech (TTS), GVP provides a
cost-effective way to implement automated voice interactions from customers calling your contact
center. At the technology level, GVP is a collection of software components that complement and
work with other Genesys products in order to provide a complete voice self-service solution.

Notes:

Whereas GVP is commonly used in enterprise self-service environments, many other applications of
GVP —including those outside of the contact center—are possible.

A machine on which GVP components are installed is also referred to as a GVP Server in other places
in this Help system.

Use Case

An example flow for a GVP voice self-service application is presented below:

* A customer calling into an IVR would get Prompts / Announcements with a Welcome message. These
prompts could be specific to a region based on incoming DNIS number or customized based on user
options, such as a prompt to select a language.

¢ The applications could have business control logic allowing Business users to define open and close
hours, set emergency announcements and flags, define special days, and so on. These options could be
defined within Genesys Administrator or Genesys Rules System.

e The application can have the capability to collect user input with multiple options and repeatability to
handle no input / no match capabilities.

¢ Once the application gets the user input, such as account numnber, this information can be verified
against back office applications or can have the capability to pull data from a Conversation Manager
Solution

¢ Customer information retrieved can be attached to the interaction as user data and could be used for
Customer Segmentation and thereby determine how a particular customer would be managed within
the self-service
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The application can provide self-service with Voice Recognition options and DTMF options in menus.

The application can be configured to allow users to opt out of the self-service by default or within the
predefined flow of the application.

When users opt out of the IVR, they could be routed to an external source or to an Agent based on the
environment as defined above. For example, customers could make a choice to get routed to “Last
Called Agent” or be routed to any Agent by pressing repetitive “0”.

Customers can have defined activities across the flow of the self-service and also be able to set
milestones to define success/failure criteria within each segment of the flow.

How Do Voice Applications Work?

Just as one uses HTML to create visual applications, VoiceXML is a mark-up language one uses to
create voice applications. With a traditional web page, a web browser will make a request to a web
server, which in turn will send an HTML document to the browser to be displayed visually to the user.
With a voice application, it's the VoiceXML interpreter that sends the request to the web server, which
will return a VoiceXML document to be presented as a voice application via a telephone. What makes
VoiceXML so powerful is that all of the most popular tools for making web pages are available for
making voice applications. Developers can use technologies they are already familiar with such as
JavaScript, JSP and ASP.NET/C# to generate exciting new voice applications.

The "Big Picture"

Data Sources / Servie

Voice App VXML
Page(s)

Voice App Server
Side Pages

WebService

Design, develop et

voice application

Composer [{Voice)
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Composer is a fully featured VXML application development tool. Users can develop, debug and test
their applications in its Integrated Development Environment (IDE) that provides developer-friendly
features to test and debug VXML applications and server side web pages. Once the application is
ready, it can be exported or manually deployed using an exported package onto an application
server/web server like Tomcat or Microsoft 1IS. Once deployed, GVP can access the voice application’s
VXML pages and any server side pages (JSP/ASP.NET) using HTTP.

When a call comes in to GVP, GVP determines the location of the VXML application through its
provisioning data. It then fetches VXML page(s) and uses its VXML engine to execute them. The
results are played back to the caller on his/her phone. Any server side pages that access databases
or web services or other server side pages are executed on the application server/ web server
through server side constructs implemented by Composer.

During development, Composer can use its bundled Tomcat or a local installation of Microsoft IIS as
the web server and make test calls to the application right through GVP from within the IDE. This
feature provides a quick way to test applications by removing the need to of deploy applications to
another server and then point GVP to that location.

Once the application is deployed in production, Composer is no longer in the picture. The application
is usually deployed on its own dedicated web server and application server from where it is accessed
by GVP. The web/application server provides access to all pages and scripts that make up the
application and executes any server side pages of the application.
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Creating CCXML Applications

CCXML (Call Control XML) is a specification developed by the Call Control subgroup of the Voice
Browser Working Group of the W3C. CCXML provides mechanisms for implementing advanced call
control functionality in a standards-based way. It provides the advanced call control features not
supported by VoiceXML. You develop CCXML a little differently than VXML or SCXML applications.
Rather than creating flow diagrams, you invoke a CCXML text editor and enter the code while
Composer performs syntax checking. To create a new CCXML file in Composer perspective:

1. From the menu, select File > New > Other > CallControlXML File.
2. In the wizard, select the Project folder, name the file, and click Finish or Next to use a template.

3. If you click Next, select a template and click Finish. Composer opens the the CCXML editor view.
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Creating VXML Applications

When building any application in Composer, you first need to create a Project. A Project contains all
the callflows, audio and grammar files, and server side logic for your application. By associating a

routing strategy with a Project, you enable Composer to manage all the associated files and
resources in the Project Explorer.

Cheat Sheet

Composer provides a cheat sheet to walk you through the steps for building a voice application.

* In the Welcome Screen (Help > Welcome), click the icon for Tutorials and select the Create a Voice

Application tutorial. It will also describe the steps for how to make test calls and debug your
application.

e If you are already inside the Workbench and Perspectives, access the same cheat sheet from the Menu

bar at the top by selecting Help > Cheat Sheets, then Create Voice Application from the Building Voice
Applications category.

Creating a New Project

You can follow the steps below to create a new Project:

1. For a Java Composer Project to be deployed on Tomcat, click the toolbar button to create a Java

Composer Project. For a .NET Composer Project to be deployed on IS, click the toolbar icon to create
a .NET Composer Project.

2. In the Project dialog box, type a name for your Project.

3. If you want to save the Composer Project in your default workspace, select the Use default location

check box. If not, clear the check box, click Browse, and navigate to the location where you wish to
store the Composer Project.

4. Select the Project type:

¢ Integrated Voice and Route. Select to create a Project that contains both callflows and
workflows that interact with each other; for example a routing strategy that invokes a GVP
voice application. For more information on both voice and routing applications, see What is
GVP and How Do Voice Apps Work? and What Is a Routing Strategy, respectively.

¢ Voice: Select to create a Project associated with the GVP 8.x. This type of Project may
include callflows, and related server-side files. For more information on this type of Project,
see topic, How Do Voice Applications Work.

¢ Route: Select to create a Project associated with the Orchestration SCXML Engine/
Interpreter and Universal Routing Server. For more information on this type of Project, see
topic, What Is a Routing Strategy.
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5. Click Next.

6. If you want to use templates, expand the appropriate Project type category and select a template for
your application. Templates are sample applications for different purposes. If you want to start from
scratch, choose the Blank Project template and click Next.

7. Select the default locale and click Next.

8. Optional. If using the in a VoiceXML application, select the Enable ICM checkbox to enable integration.
When checked, ICM variables will be visible in the Entry block. See the ICM Interaction Data block for
more information.

9. Click Finish. Composer now creates your new Project. Your new Project folder and its subfolders appear
in the Project Explorer.

10. To view/change settings not included under Preferences, right-click the Project and select Properties.

If you have never created a Composer Project, we recommend starting with Your First Application.
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Creating a New Callflow

To add a new callflow diagram to an existing Composer Project:

5
1. Click the button on the main toolbar to create a new callflow. Or use the keyboard shortcut:
Ctrl+Alt+0.

2. In the wizard, select the tab for the type of the callflow. There are two main types of callflows in
Composer represented by wizard tabs:
e Main Callflow: Used for the main application where the call will land or be transferred to from
another application.

e Subcallflow: Used for modularizing your applications. It is useful for structuring large
applications into manageable components.

Additionally you will benefit from the automated transaction reports associated with Subcallflows.
Action Start and Action End VAR events are auto-generated for Entry and Exit blocks.

Select either Main Callflow or Subcallflow.

Select the type of diagram.

Click Next.

Select the Project.

Click Finish.

® N o v AW

Create the callflow.
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Validation

Composer can validate your diagram files and other source files for completeness and accuracy. For
more information, see Validation.
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Code Generation

The process of generating code creates a properly-formatted VoiceXML file from a callflow diagram
built with Composer or a SCXML file from a workflow diagram. Static pages (pure VXML or SCXML
code) are generated in the src-gen folder of the Composer Project. You can generate code in a couple
of ways:

e Select Diagram > Generate Code.

¢ Click the Generate Code icon on the upper-right of the Composer main window when the callflow/
workflow canvas is selected.

Note: If your project uses the Query Builder or Stored Procedure Helper-generated queries in DB Data
blocks, the process of code generation will create one SQL file in the db folder for each such DB Data
block. These SQL files will be used at runtime and should not be deleted.

Code Generation for Multiple Callflows

When using the Run as Callflow function, Composer automatically generates the VXML files from the
diagram file that you want to run. When generating code, with the generate code function for a Java
Composer Project that has multiple callflows, Composer attempts to generate the VXML for all the
callflows before running (because the application might move between multiple callflows for
subdialogs). However, if one of the callflows has an error, Composer provides the option to continue
running the application anyway, because the erroneous callflow may be a callflow that’'s not used by
the one being run (if there are two or more main callflows, for example). When this happens, the
VXML files are basically out of sync with the diagram files and this may affect execution. Genesys
recommends that you fix all errors before running the application.
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Deploying/Testing Your Application

After you have saved your files and generated code for your application, test the application as
follows:

1. Deploy the project for testing.

e If deploying a Java Composer Project, Composer bundles Tomcat for running test
applications, such as routing applications. If you configured the Tomcat settings prior to
creating your Project, it will be auto-deployed on the Tomcat Server. You can double check
this by clicking on the name of the project in the Project Explorer, then right-click and select

Project Properties. Select the Tomcat deployment category and verify that the project is
deployed. If not, click Deploy.

e If deploying a .NET Composer Project, deploy your project on an IIS Server. Be sure you have
configured the IIS settings. Click on the name of the project in the Project Explorer, then

right-click and select Project Properties. Select the IIS deployment category and verify that
the project is deployed. If not, click Deploy.

2. For Voice Projects, use Run mode to run the application by selecting Run > Run As > Run Callflow, or by
right-clicking on the callflow file name in the Project Explorer and selecting Run As > Run Callflow. The
code is generated in the src-gen folder and the debugger sends the call to your SIP Phone.

3. Accept the call and you will be connected to the application on GVP. The call traces will become visible
in the Call Trace window, and you should hear the voice application run.

Composer Help 223


https://docs.genesys.com/Documentation/IW/8.1.4/Help/CodeGeneration
https://docs.genesys.com/Documentation/IW/8.1.4/Help/WorkflowPostInstallation#Tomcat

Creating Voice Apps for GVP

Hello World Sample

Here is a simple voice application to help you get started with Composer. This application says Hello
World when the call is answered.

Simple Text-to-Speech Application

To build a simple text-to-speech (TTS) application that says Hello World to the caller:

1.
2.

e

10.
. Click OK.
12.

13.

14.

15.

16.

17.
18.

Create a new Composer Project called Hello World.

Add the following blocks from the Basic Blocks Palette to the canvas area: Entry, Prompt, and Exit, then
connect them with Output Links.

. Select the Entry block, or right-click the Entry block and select Show Properties View from the

shortcut menu, if you want to set any properties (optional).

Select the Prompt block, or right-click the Prompt block and select Show Properties View from the
shortcut menu.

Select the Name property and type a name in the Value field.

Select the Prompts property and click the E=1 button.

Click the Add button and type a name in the Name field (optional).
Select Value in the Type drop-down list (default).

Select Text in the Interpret-As drop-down list (default).

Type HelloWorld (one word) in the Value field.

Save the file by selecting File > Save. You will not be able to generate code if you do not save the file.

Generate the code by selecting Diagram > Generate Code, or by clicking the Generate Code icon
on the upper-right of the Composer main window when the callflow canvas is selected.

If you get any errors, double-click on the error to get the details and fix the problem. For the Hello World
application, typical problems would be forgetting to add the Hello World prompt or forgetting to link the
blocks together.

If code generation succeeds, click OK at the confirmation dialog box.

Make sure the project is deployed for testing. Composer bundles Tomcat for running test applications. If
you configured the Tomcat settings prior to creating your Composer Project, it will be auto-deployed on
the Tomcat Server. You can double check this by clicking on the name of the project in the Project
Explorer, then right-click and select Project Properties. Select the Tomcat deployment category and
verify that the project is deployed. If not, click Deploy.

Select the callflow in the Project callflows folder.

Run the application by selecting Run > Run As > Run Callflow, or by right-clicking on the callflow file
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name in the Project Explorer and selecting Run As > Run Califlow.
The code is generated in the src-gen folder and the GVP debugger sends the call to your SIP Phone.

19. Accept the call and you will be connected to the application on GVP. The call traces will become visible
in the Call Trace view, and you should hear Hello World played through the phone.

Adding Blocks

There are a few ways to add blocks from the Palette to the canvas. The most common methods are
as follows:

e Click on the block icon on the palette, release the mouse and click on the target location on the canvas
area.

¢ Double-click a block icon on the palette.

¢ Click on the block icon on the palette, and while holding down the mouse button, drag and drop the
block to the canvas.

Any of these methods will add the new block and you can then type the name of the block on the
canvas itself. Click here to read about block naming restrictions.

Connecting Blocks

Blocks are connected to each other using connection links. There are two types of connection links:

e Output Links used to connect one block's output port to another block's input port, and

e Exception Links used to indicate error or exception conditions by connecting from a block's exception
port to another block's input port.

To add a new Output Link (or Exception Link):

1. Click the Output Link (or Exception Link) icon in the palette.
2. Move the mouse over to the source block. The cursor will change to an upward arrow.

3. Click once on the source block and keep the mouse button pressed. Then drag the mouse onto the
target block and release the mouse button.

This will add the connection link between the two blocks. To use an Exception Link, the source block
must have an exception port defined. This is done by selecting at least one supported exception
within the block's Exceptions property.

Another method for adding an Output Link or Exception Link between two blocks is as follows:

1. Click once on the source block to select it.

2. Hold the Ctrl key and click once on the target block to select it as well.
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3. Double-click the Output Link (or Exception Link) icon in the palette to create a connection between the
two blocks.

Again, to use an Exception Link, the source block must have an exception port defined.

The preference Show Connection Ports (in Composer DiagramPreferences) affects how connection
links can be drawn to connect blocks. If it is switched on, links may be drawn directly by dragging
from an outport of a block and dropped onto a block or its inport. This method will work in addition to
using the Output link and Exception link tools. If the setting is switched off, connection ports are not
displayed and therefore the method of drawing links mentioned above is not available.
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Callflow Blocks

A block is the fundamental element of a callflow. Each block defines specific properties and how to
handle specific events. You use the Link tools to connect these blocks in the order that the application
should follow. A single VXML application is generated per callflow. Each block in a callflow becomes a
form in the generated VXML document.

VXML Properties

Each block has custom VoiceXML properties. These properties appear within a Properties view at the
bottom of the Composer window when you right-click the block and then select Show Properties View
from the shortcut menu. For each block, specific properties determine how events are handled. There
are several categories of properties depending on the specific block. The blocks build a callflow or
subcallflow. Generate code either from the Toolbar or from the Diagram menu. Static VXML pages
(pure VXML code) are generated in the src-gen folder.

Main Versus Subcallflow

There are two types of callflows:

¢ Main Callflow: This is the starting callflow for any application.

e Subcallflow: This is a component callflow that can be called from the main callflow or another
subcallflow.

Each main callflow or subcallflow application should have at least three blocks:

e The Entry block to start the application. This block also specifies the relative file locations of the audio
files for the generated application code and default exception handling.

¢ At least one other block to perform specific functions such as passing a call to an agent, creating a log
of an activity, requesting caller input, playing a prompt, and so on.

¢ The Exit block to end the application, or, for example, the GoTo block to direct the application to another
application.

Subcallflows

Subcallflows are used for modularizing applications and for writing components that can be reused by
multiple applications (such as a credit card validation subcallflow). The usage of subcallflows within a
main callflow is very similar to a function call in a programming language. One or more input
parameters can be passed to a subcallflow. Similarly, the subcallflow can return one or more output
parameters. Therefore, a subcallflow can be designed to behave differently depending on the input
parameter(s) passed.
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Variables in Callflows

You can define voice application (session) variables using the Entry block Variables property.

Note: For information on user data and GVPSessionID, see the Project Properties dialog box,
Composer Callflow Option.

Types of Variables

Composer supports the following types of variables for callflow diagrams:

¢ Application Root--Automatically filled from either session.com.genesyslab.userdata or
session.connection.protocol.sip.requesturi based on the Nnn-CTIC or CTIC flow. Also see the
Entry Application Root Property.

* System --Pre-defined application variables (Entry block Variables property) hold Project and application-
related values. While you cannot delete System variables, you can have your application modify the
values.
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B ropiionvaives S — Ve

Set the application variables (
St the application vanables !
type filter text @
Variable Name Categ... Value Description Delete

o Application Root Variat

4 G System Variables Up
APP_LANGUAGE System  ‘en-US Application Language o
APP_ASR_LAMNGUAGE System  'en-US' ASR Language
PREV_APP_LANGLIAC System ‘undefined’ Temparary Value of Previous ..
PREV_APP_ASE_LANC System  ‘undefined’ Temporany Value of Previous ..
GRAMMARFILEDIR  System . /Resources/Grammars' Grammar File Directory
VOXFILEDIR System ./Resources/Prompts’ Audio File Directory
SCRIPTSDIR System . /Seripts’ JavaScript Directory
EnableReports Systemn  false Reporting Flag
EnableSNMP System false Flag for enabling SMMP Traps
CalluuiD Systeém  session.connectionuuid Universal [D
GYPSessionlD Systemn  session.genesys.userdata[™G. GVP Session 1D
DNIS System  getDNIS( DMIS associated with Called p...
AMI System  getANL) AN associated with the callin.
LAST_EVENT_NAME Systern ‘undefined’ Last event or error name
LAST EVENT MSG  System ‘undefined’ Last event or error details
LAST_EVENT_URL System  ‘undefined’ URL of the last event. |
LAST_EVENT_ELEMES System  ‘undefined’ Element name of the last event
LAST_EVENT_LINE  System ‘undefined’ Line number of the last event '
EnableFCR System  true Flag for enabling Full Call Rec_
COMPOSER_WSSTUE System 0¥ Flag to conirol WebServices St..
USE_LCASE USERDA System 0 Flag to control lowerCase ook,
APP_OPM System  eval{[+sessionconnection... Operational Parameters Data —
OCS_RecordUR] Systern  getCallflowRecordURI) OCS Record URI
OCS_URI System  getCallflowCCSURID QS URI
OS5 _Record System  getCallflowOCSRecord() 0CS Record

B User Variables

] I | »

Restore system variables default values
@ [Cok_] [ cancel

— — e

* User--User-defined (Input) custom variables that you create by clicking the Add button in the Set
Application Variables dialog box above and selecting User. Your application can delete and modify
these variables supplied as input to the called diagram. During runtime, these input variables get auto-
filled from the calling context. Typically these variables are created on the SubCallflow side to notify the
MainCallflow about the Parameter-passing details while designing the application flow. Composer does
auto-synchronization of the input variables in the Subdialog block. Input variables are also used on the
MainCallflow while invoking the VoiceXML application from workflows in case of Voice Treatment
execution - computer telephony integration (CTI) scenario (Play Application).
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¢ SubcCallflow--Automatically filled from the VXML subdialog-invoking methodology.

Variable Versus Static Data

Many blocks enable the use of variables rather than static data. For example, the Prompt block can
play the value of a variable as Text-to-Speech. Variables whose values are to be used in other blocks
must be declared here so that they appear in the list of available variables in other blocks. The value
collected by an Input block or a Menu block is saved as a session variable whose name is the same as
the block Name. Also see information on the AppState variable used by the DB Data block.

Entry Block Variables

Entry block variables can access User Data (attached data from a routing workflow) from
session.com.genesyslab.userdata and SIP Request-URI parameters from
session.connection.protocol.sip.requesturi session variables.

Request URi parameters created in IVR Profiles during the VoiceXML application provisioning are
passed to the Composer generated VoiceXML application as request-uri parameters in the
session.connection.protocol.sip.requesturi session array. An Entry block variable can use
these parameters by setting the following expressions to the variable values: typeof
session.connection.protocol.sip.requesturi['varl'] == 'undefined' ?
"LocalDefaultValue" : session.connection.protocol.sip.requesturi['varl'].

If parameters are set as part of IVR Profiles provisioning in the Genesys VoiceXML provisioning
system, and if these parameters have the same names as variables set in the Entry block's
Variables property with the above mentioned sip.requesturi expression, then the SIP-Request-
URI parameters will take precedence over the user variable values set in the Entry block.

For more information on valid values and syntax for the the gvp.services-parameter
section, refer to page number 121 in the GVP 8.5 User's Guide.

IVR profiles for GVP can be created using the Genesys Administrator. For more information, refer to
the Voice Platform Solution Guide and the gvp.services-parameter section in the GVP 8.5 User's
Guide.

Attaching Results to User Data

While you can assign Classify object results to a variable, Genesys does not recommend this. The
recommended way of dealing with the classification results is to attach them to the interaction. Then
User Data will have the keys listed in the table below with the corresponding values returned by
Classification Server. As an example, User Data would have the following pairs after the attachment:
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Parameter Value

Ctgld 00001a05F5U900QW
CtgRelevancy 95

CtgName Cooking
Ctgld_00001a05F5U900QW 95
Ctgld_00001a05F5U900QX 85
Ctgld_00001a05F5U900QY 75
Ctgld_00001a05F5U900QZ 65
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VXML Properties

This page provides details about the properties used to manage platform behavior: Note: Properties
apply to their parent tag and all the descendants of the parent. A property at a lower level overrides
a property at a higher level. If you already have GVP, note that the properties in defaults-ng.vxml will
be (re)set as documented below only when a system is newly installed. If you simply upgrade from a
previous release, the old values will be preserved. This means that any manual configuration of
defaults-ng.vxml will be saved when you upgrade. It also means that when moving to newer versions
in which GVP uses different default values, the defaults will not be reset unless you newly install
(rather than upgrade).

Receive External Message

Property Description Default Value

This property specifies whether
an external message will be
received asynchronously. The
valid values are:
com.genesyslab. * True--If the value equals true,
(GVP extension) external messages will be false
received asynchronously.

* False--If the value equals
false, external messages will
be received synchronously.

This property specifies whether
an external message will be
queued or discarded. The valid
values are:

e True--If the value equals true,
external messages will be
queued. The external
message is reflected to the
application in the
com.genesyslab. application.lastmessage$
variable (an ECMAScript false

(GVP extension) .
object).

e False--If the value equals
false, external messages will
not be delivered as a
VoiceXML event (they will be
discarded).

Note:If no external messages have been
received, application.lastmessage$ is
ECMAScript undefined. Only the last
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Speech Recognizer

Property

confidencelevel

sensitivity

speedvsaccuracy

completetimeout

incompletetimeout

received message is available. To
preserve a message for future reference
during the lifetime of the application,
copy the data to an application-scoped
variable.

Description

Specifies the speech recognition
confidence level. Values range
from 0.0 (minimum confidence)
to 1.0 (maximum confidence).
Recognition results are rejected
(a nomatch event is thrown) if
the confidence level of the
results is below this threshold.

Specifies the level of sensitivity
to speech. Values range from 0.0
(least sensitive to noise) to 1.0
(highly sensitive to quiet input).

A hint specifying the desired
balance between speed versus
accuracy when processing a
given utterance. Values range
from 0.0 (fastest recognition) to
1.0 (best accuracy).

Note: The Nuance MRCP engine uses the
value of the speedvsaccuracy property to
set its proprietary rec.Pruning parameter,
using the following algorithm: If x is the
speedvsaccuracy value, and x <= 0.5
then rec.Pruning = (x * 400) + 600 else
rec.Pruning = (x * 800) + 400

The length of silence required
following user speech before the
speech recognizer finalizes a
result (either accepting it or
throwing a nomatch event). The
completetimeout is used when
the speech is a complete match
of an active grammar and no
further words can be spoken.

The length of silence required
following user speech before the
speech recognizer finalizes a
result (by either accepting it or
throwing a nomatch event). In
contrast to completetimeout, the
incompletetimeout is used when
the speech is an incomplete

Default Value

0.5

0.5

0.5

1s

1s
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match to an active grammar, or
when the speech is a match but
it is possible to speak further.

The maximum duration of user
speech. If this time elapses
before the user stops speaking,
the maxspeechtimeout event is
thrown. Note: Refer to your ASR
engine documentation for
support details.

maxspeechtimeout

Maximum number of results

returned by the recognizer. Also
represents the maximum size of
the application.lastresult$ array.

DTMF Recognizer

Property Description

The timeout period allowed
between each digit when
recognizing DTMF input.

interdigittimeout

The terminating timeout to use

ST when recognizing DTMF input.

The terminating DTMF character

termchar for DTMF input recognition.

This property makes it possible
to use the DTMF Recognizer that
comes with your ASR Engine

instead of using the one provided
by Genesys. The valid values are:

e True--If the value equals true,
offboard DTMF recognition is

com.genesyslab.dtmf.offboard_recognitighaPled for the call.

e False--If the value equals
false, offboard DTMF
recognition is disabled for the
call.

(GVP extension)

Note:If the value is invalid, an
error.semantic will be thrown. Note: The
recognizer will use the engine specified
by the ASR engine property. Note: If you
switch engines in mid call, any buffered
digits will be lost.

60s

=

Default Value

3s

#

False
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Prompt and Collect

Property Description Default Value

Determines which input methods
to use. Value is a space
separated list of input methods:

inputmodes + dtmf--allows DTMF sequences  dtmf voice
as input

e voice--allows voice as input

Once the prompt has finished
playing, the length of time to

timeout wait, if no speech or dtmf input 10s
occurs, before throwing a noinput
event.

Specifies universal command
grammars to activate. Value is a
space-separated list of all or
fewer of the following command
grammars:

e cancel--If this grammar is
activated, and the caller says
"cancel" (or equivalent
phrase configured for another
language), the cancel event
is thrown.

e exit--If this grammar is
activated, and the caller says
universals "exit" (or equivalent phrase none
configured for another
language), the exit event is
thrown.

¢ help--If this grammar is
activated, and the caller says
"help" (or equivalent phrase
configured for another
language), the help event is
thrown.

A setting of none disables universal
commands. A setting of all can be used
as a short form for activating all 3
command grammars.

Specifies the name of the ASR
(Automatic Speech Recognition)

com.genesyslab.asrengine engine to use. For details apout
available names, consult with latf ifi
(GVP extension) your platform administrator. platform-specihic

Note: If this property is not specified, the
per call configuration value specified in
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com.genesyslab.ttsengine

(GVP extension)

com.genesyslab.endbeep

(GVP extension)

com.genesyslab.utterancedest

(GVP extension)

recordutterance

(VoiceXML 2.1 feature)

the vxmli.asr.defaultengine property (see
the Genesys Voice Platform 8.1
Configuration Options Reference) will be
used. The default is empty string ("").
Note: It is valid to specify a particular
engine only if that engine is installed for
the platform running the application.
Otherwise, an error.asr.unknownengine
event will be thrown. Note: The
configured name for SpeechWorks OSR
must be speechworks, otherwise a
recognition error will occur.

Specifies the name of the TTS
(Text-to-Speech) engine to use
(that is, the voice). For details
about available names, consult
with your platform administrator.

Note: If this property is not specified, the
per call configuration value specified in
the vxmli.asr.defaultengine property (see
the Genesys Voice Platform 8.1
Configuration Options Reference) will be
used. Note: It is valid to specify a
particular engine only if that engine is
installed for the platform running the
application. Otherwise, an
error.tts.unknownengine event will be
thrown.

Specifies whether a beep should
be played at the end of prompts
in fields, when bargein is
disabled. When bargein is
enabled, this attribute has no
effect (there is never a beep).
Platform owners can access the
audio file (endofprompt.vox) in
the configured audio path.

false

Specifies the path of the
directory to use for saved
utterance audio files. The value
will be resolved to the configured
audio path. This property can be
used with the recordutterance
property. Note: If you specify the
utterancedest and enable the
savetmpfiles property, the
utterance will only be saved
under the utterancedest path. It
will not also be saved with the
other tmp files.

This property tells the platform to
enable recording while
simultaneously gathering input
from the user. Set to true to
enable user utterance to be
recorded. Set to false otherwise.
Upon completion of user input,

false

platform-specific

files are written to the tmp
directory (may or may not be
saved, depending on whether the
savetmpfiles property is enabled)
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recordutterancetype

(VoiceXML 2.1 feature)

com.genesyslab.asr.get_swi_literaltirtﬁﬂ

(GVP extension)

com.genesyslab.tts.<Your vendor
specific name>

(GVP extension)

com.genesyslab.asr.<Your
vendor specific name>

(GVP extension)

the recording shadow variable
will be set. Note: The <vxml>
version attribute must be
specified as 2.1 (or higher) to use
this property. Note: If the
recordutterance property has
been specified in a VoiceXML 2.0
page, it will behave as if itis a
VoiceXML 2.1 page.

This property specifies the audio
format to use for recording
utterances. Only used with the
recordutterance property. GVP
currently supports the following
types:

e audio/basic--Raw (headerless)
8kHz 8-bit mono mu-law
[PCM] single channel. (G.711)

e audio/x-alaw-basic--Raw audio/basic
(headerless) 8kHz 8-bit mono
A-law [PCM] single channel.
(G.711)

e audio/x-wav--WAV (RIFF
header) 8kHz 8-bit mono mu-
law [PCM] single channel.

e audio/x-wav--WAV (RIFF
header) 8kHz 8-bit mono A-
law [PCM] single channel.

Set to true to allow the special
OSR variable, SWI_literalTimings,
accessed through the
application.lastresult$ variable.
Requires
com.genesyslab.fieldobject to be
set to true. Available with
SpeechWorks ASR only.

Users will be able to define TTS
vendor-specific global properties

in the Entry block. The exact set

of property names is not known

to Composer and therefore no
validations will be performed on

the names. The general format of
these properties will follow this
pattern:
com.genesyslab.tts.<property_name>

When using GVP's MRCP direct

integration with an ASR engine,

the VoiceXML application can use parameter-specific
this property format to specify

arbitrary vendor-specific

false
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parameters to be sent to the ASR
engine.

In the property name, <Your vendor

specific name> is replaced with the

actual vendor-specific parameter name;

and the value of the property must be a

valid value for that vendor-specific

parameter. For example, to set Nuance's
rec.GrammarWeight parameter to 10:

<property
name="com.genesyslab.asr.rec.GrammarWeight"
value="10"/> Notes:

e Vendor parameter names and
values could be case-
sensitive. Refer to the vendor
documentation to ensure you
are using valid names and
values.

* You can only set a vendor
parameter using <property>
if the parameter can be set
by the ASR engine at runtime.
Refer to the vendor
documentation to confirm
which parameters are
runtime-settable.

¢ Once a vendor parameter is
set using <property>, the
setting will stay in effect for
the remainder of the call,
unless it is set again later in
the VoiceXML application.

Many of OSR's swiep_*/swirec_*
configuration parameters can
also be set as VoiceXML
properties.

To find out whether a particular
parameter can be set as a property, look
it up in the OSR Reference Manual. If the
line under the parameter name includes
"API" (and if the description mentions
SWlepSetParameter() or

swiep_*/swirec_* SWirecRecognizerSetParameter()), then it
. can be set as a property. Some of the parameter-specific
(GVP extension) parameters that are commonly used are:

e swirec_suppress_event_logging
* swirec_suppress_waveform_logging

* swirec_audio_environment
(OSR 2.0+ only)

* swirec_backward_compatible_confidence_scores
(OSR 2.0+ only)
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com.genesyslab.logtoasr

(GVP extension)

See the OSR Reference Manual for details
about the values/usage for each
parameter. These properties are specific
to Nuance OSR, and are only supported in
GVP's MRCP native integration with OSR.
(They are not supported in GVP's MRCP
direct integration with OSR, using SWMS.)

If set to true, this will enable GVP
to log data directly to the ASR
engine's log. Note: If this
property is true, then the <log>
tag's level attribute is ignored.

Prompt and Collect--Barge-in

GVP supports Recognition Based Barge-in.

Property

bargein

bargeinype

MARK Tag

Description

Controls whether user input can
be collected before prompts have
finished playing:

e true--Any user input can
barge in during prompts.

e false--No user input can barge
in during prompts.

Specifies the bargein type:

* speech--Any user utterance
can barge in the prompt.

e hotword (equivalent to
recognition)--Only user input
that matches a grammar can
barge in on the prompt.

Note: Not all bargeintypes are supported
with all ASR engines.

true

Default Value

true

speech

Composer and GVP support the use of the MARK tag from the VXML Specs to detect whether or not a
barge-in was detected. The Mark tag in VXML is used to set the place in a sequence of prompts and
can be used to detect the barge-in position during the playback of prompts.

As described in the GVP 8.1 Legacy Genesys VoiceXML 2.1 Reference Manual, the variable
application.lastresult$ is a read-only session variable that holds information about the last
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recognition to occur within this application. Additionally, application.lastresult$[i] provides the
ability to use an array of tags when using N-best recognition.

e The GVP 8.1 Legacy Genesys VoiceXML 2.1 Reference Manual provides a good reference for the
differences between VXML 2.0 and 2.1 tags.

* The GVP 8.1 Application Migration Guide provides a reference for the delta between the GVP
interpreters and mentions the GVP-specific platform extensions.

e Lastly, the GVP Voice XML Help describes the VoiceXML 2.1 standards and tags supported by GVP
version 8.0 and later.

Prompt and Collect--Wakeup Word Spotting Recognition Mode

In GVP's MRCP native integration with Nuance OSR, OSR's "magic word" feature is exposed through
the following properties.

Property Description Default Value

Specifies whether Wakeup Word

Spotting should be used for input

in fields, menus, and initials. If
com.genesyslab.wakeupword set to true, recognition is only
performed if input length is false
between a minimum and
maximum length, and (only with
Nuance OSR 2.0+) if input
matches a grammar.

(GVP extension)

If com.genesyslab.wakeupword is
com.genesyslab.wakeupwordminimuet to true, this specifies the
minimum length that input must
be in order for recognition to be
performed.

(GVP extension)

If com.genesyslab.wakeupword is
com.genesyslab.wakeupwordmaximyét to true, this specifies the
maximum length that input may
be in order for recognition to be
performed.

(GVP extension)

Prompt and Collect--Magic Word / Selective Barge-in Recognition
Modes

With Nuance SWMS 3.1.4+, OSR's "magic word" and "selective barge-in" features are exposed
through the following properties. GVP does not have default values for the following properties. If the
application specifies them, GVP passes the specified values through to SWMS. Otherwise, GVP does
not pass anything to SWMS - in which case, SWMS would use its own default settings (see the SWMS
documentation for these details).
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Property

com.genesyslab.ASR.Recognition-
Mode

(GVP extension)

com.genesyslab.asr.Hotword-Min-
Duration

(GVP extension)

com.genesyslab.asr.Hotword-
Max-Duration

Description Default Value

Set to hotword to enable the OSR
selective barge-in or magic word
recognition mode:

e Selective Barge-in--Only user
input that matches a
grammar can barge in on the
prompt. (This mode is
enabled if
com.genesyslab.ASR.Hotword-
Max-Duration is set to 0.)

e Magic Word--Only user input
that matches a grammar, and
whose duration is between a
minimum and maximum
length, can barge in on the
prompt. (The minimum and
maximum utterance lengths
are specified by
com.genesyslab.asr.Hotword-
Min-Duration and
com.genesyslab.asr.Hotword-
Max-Duration.)

For example: <property
name="com.genesyslab.asr.Recognition-
Mode" value=""hotword""/> Note: After
setting this property, the specified mode
will remain in effect for all subsequent
recognitions (even if the property is not
set in subsequent input fields), unless a
new mode is explicitly set. So, to switch
back to normal recognition mode after
using one of the above hotword modes,
the application must explicitly set this
property back to normal (and not set any
of the three related properties listed
below). For example: <property
name="com.genesyslab.asr.Recognition-
Mode" value=""normal""/> (Available
with Nuance SWMS 3.1.4+ only.)

If
com.genesyslab.asr.Recognition-
Mode is set to hotword, this
specifies the minimum length (in
ms) that input must be in order
for recognition to be performed.
For example:

<property
name="com.genesyslab.asr.Hotword-Min-
Duration" value=""50""/> If
com.genesyslab.asr.Hotword-Max-
Duration is set to 0, this property will be
ignored.

If
com.genesyslab.asr.Recognition-
Mode is set to hotword, this
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specifies the maximum length (in
ms) that input may be in order
for recognition to be performed.
For example:

<property
name="com.genesyslab.asr.Hotword-
Max-Duration" value=""2000""/> If this
property is set to 0, the OSR selective
barge-in mode will be enabled (for

(GVP extension) example, no minimum and maximum
duration constraints are used, so
com.genesyslab.asr.Hotword-Min-
Duration will be ignored). Otherwise, the
OSR magic word mode will be enabled
(for example, the minimum and
maximum duration constraints specified
by com.genesyslab.asr.Hotword-Min-
Duration and
com.genesyslab.asr.Hotword-Max-
Duration will be used).

If
com.genesyslab.asr.Recognition-
Mode is set to hotword, this
specifies the speech recognition
confidence level that should be
used. Values range from 0
(minimum confidence) to 1000
(maximum confidence).
com.genesyslab.asr.Hotword- Recognition results are rejected
Confidence-Threshold (a nomatch event is thrown) if
the confidence level of the

VP extensi . .
(GHEExtEnSTon) results is below this threshold.

For this property to take effect, you must
also set the standard confidencelevel
property to an equivalent decimal
percentage. For example: <property
name="com.genesyslab.asr.Hotword-
Confidence-Threshold" value=""100""/>
<property name="confidencelevel"
value="0.1"/>

Fetching

Property Description Default Value
Defines when audio files can be
fetched:

* prefetch--audio file may be
downloaded when the page is
audiofetchhint loaded prefetch

* safe--only load the audio file
when needed

Currently, all audio is fetched when
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audiomaxage

audiomaxstale

datafetchhint

datamaxage

datamaxstale

documentfetchhint

documentmaxage

documentmaxstale

grammarfetchhint

grammarmaxage

needed.

Defines maximum acceptable
age, in seconds, of cached audio
resources.

Defines maximum staleness, in
seconds, of expired cached audio
resources.

Defines when XML data files can
be fetched:

e safe--only load the XML data
file when needed

Currently, all data files are fetched when
needed.

Defines maximum acceptable
age, in seconds, of cached XML
resources.

Defines maximum staleness, in
seconds, of expired cached XML
resources.

Defines when next document can
be fetched:

¢ safe--only load the next
document when needed

Currently, all documents are fetched
when needed.

Defines maximum acceptable
age, in seconds, of cached
documents.

Defines maximum staleness, in
seconds, of expired cached
documents.

Defines when grammar files can
be fetched:

e prefetch--grammar file may
be downloaded when the
page is loaded

e safe--only load the grammar
file when needed

Currently, all grammars are fetched when
needed.

Defines maximum acceptable
age, in seconds, of cached
grammar resources.

undefined

undefined

safe

undefined

undefined

safe

undefined

undefined

prefetch

undefined
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grammarmaxstale

objectfetchhint

objectmaxage

objectmaxstale

scriptfetchhint

scriptmaxage

scriptmaxstale

fetchaudio

fetchaudiodelay

fetchaudiominimum

SpeechWorks OSR 1.x does not support
this.

Defines maximum staleness, in
seconds, of expired cached
grammar resources.

SpeechWorks OSR 1.x does not support
this.

Defines when objects can be
fetched:

e prefetch--object may be
downloaded when the page is
loaded

* safe--only load the object
when needed

Defines maximum acceptable
age, in seconds, of cached object
resources.

Defines maximum staleness, in
seconds, of expired cached
object resources.

Defines when scripts can be
fetched:

e prefetch--script may be
downloaded when the page is
loaded

» safe--only load the script
when needed

Currently, all scripts are fetched when
needed.

Defines maximum acceptable
age, in seconds, of cached script
resources.

Defines maximum staleness, in
seconds, of expired cached script
resources.

The URI of audio to play while
waiting for documents to be
fetched.

The length of time to wait at the
start of a fetch delay before
playing fetchaudio.

The minimum length of time to
play fetchaudio, once started,
even if the fetch result arrives in
the meantime.

undefined

prefetch

undefined

undefined

prefetch

undefined

undefined

builtin:background_audio.wav

1s

Os
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fetchtimeout

Audio Control

Timeout for fetches. This is not
supported when using

Nuance(MRCP). An error.badfetch

is thrown when a fetch duration
exceeds fetchtimeout.

30s

The Audio Control Feature is an extension to VoiceXML. Note: Audio control functions are only applied
to the currently playing prompt, and not across the queued prompt list. Note: These properties may
not work properly for TTS. <tbody></tbody>

Property

com.genesyslab.noaudiocontrol

(GVP extension)

com.genesyslab.audiocontrol

(GVP extension)

com.genesyslab.audio.skipduration

(GVP extension)

com.genesyslab.audio.skipahead

(GVP extension)

com.genesyslab.audio.skipback

(GVP extension)

com.genesyslab.audio.louder

(GVP extension)

com.genesyslab.audio.softer

Description

If this property is set (to any
value), the
com.genesyslab.audiocontrol
property is disabled.

(Only used if
com.genesyslab.noaudiocontrol
is undefined.) Set to true to
enable Audio Control during
playing of audio. Set to false to
disable the feature.

Sets the duration of audio to be
skipped when using the
skipahead/skipback features.
Note: Time units (s or ms) must
be provided.

Sets the DTMF button for
skipping ahead in the audio file/
TTS. The duration skipped
depends on the value of the

com.genesyslab.audio.skipduration

property. If set to "-" or
undefined, this feature is
disabled.

Sets the DTMF button for
rewinding the audio file/TTS. The
duration rewound depends on
the value of the

com.genesyslab.audio.skipduration

property. If set to - or undefined,
this feature is disabled.

Sets the DTMF button for turning
volume up. If set to - or
undefined, this feature is
disabled. This is not supported
with VolP.

Sets the DTMF button for turning
volume down. If set to - or

Default Value

undefined

true

6000ms

undefined

undefined

undefined

undefined
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undefined, this feature is

(GVP extension) disabled. This is not supported
with VolIP.
. Sets the DTMF button for pausing
com.genesyslab.audio.pause playback temporarily, until the

pause button is pressed a second undefined
time. If set to- or undefined, this
feature is disabled.

(GVP extension)

com.genesyslab.audio.stop Sets the DTMF button for
stopping all queued audio undefined
(GVP extension) playback. If set to - or undefined,
this feature is disabled.
Sets the DTMF button for
com.genesyslab.audio.next interrupting the current audio
playback, and starting the next undefined
(GVP extension) audio playback in the queue. If
set to - or undefined, this feature
is disabled.
Sets the DTMF button for
. increasing the rate of audio
com.genesyslab.audio.faster playback. If set to - or undefined, .
(GVP extension) this feature is disabled. undefined
This is not supported with VolP.
Sets the DTMF button for
com.genesvslab.audio.slower decreasing the rate of audio
9 y ’ ’ playback. If set to - or undefined, i
(GVP extension) this feature is disabled. undefined
This is not supported with VolP.
Miscellaneous
Property Description Default Value
com.genesyslab.loglevel The loglevel limits execution of
<log> tags to the ones whose 1
(GVP extension) level attribute have a value up to

(including) the loglevel value.

This property enables data
masking. This means that private
data like credit card numbers,
social insurance numbers, and so
on are converted to asterisks (for
example, 123 would be
converted to ***). The valid
values are:

com.genesyslab.private

e True--If com.genesyslab.
equals true, data masking is
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Platform

enabled. The data that is

masked includes: - asr_trace

(result) - dtmf (digit) -
input_end (phrase) - prompt
_play (all) - subdialog_start

(param_value and URL query
string) - eval_cond - eval_expr

(expression and value) -
eval_var (expression and

value) - submit (namelist and

URL query string) - link (URL
query string) - parse_error
(URL query string) -

wf_arrived (URL query string)
- wf_lookup (URL query string)

- event_handler_enter (URL

query string) - filling (value) -

filled_enter (namelist)

* False--If com.genesyslab.

equals false, data masking is

not enabled.

Note: The default value is false. Note:
This attribute is overridden by the
gvp:private attribute (in the <block>,
<field>, <transfer>, <record>,
<subdialog>, and <initial> tags).

The following properties are specific to GVP. The first three are useful for debugging purposes.

Property

com.genesyslab.maintainer.sendwhen .
9 y Should be sent. Valid values are:

com.genesyslab.savetmpfiles

Description

This property indicates if the
maintainer email message

always, never, on_message.

The value is interpreted as a
string with a list of words. The
words may be: all, none,
prompts, inputs, pages,
recordings. When a list of
keywords is specified, the
superset of all the keywords are
saved. In particular, this means
if someone specifies <property
name=
"com.genesyslab.savetmpfiles"
value="none inputs" /> it is
equivalent to specifying
<property name=

Default Value

on_message

none
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"com.genesyslab.savetmpfiles"
value="inputs"/>.

This property two valid
values:immediate or delayed.
This property only takes effect
when

com.genesyslab.savetmpfilesmode com.genesyslab.savetmpfiles is
enabled. If set to immediate the
files are written to disk
immediately. If set to delayed the
files are stored in memory.

This property specifies whether
or not keep temp files around
after the VoiceXML session has
ended. This property will only
have meaning if at least one

. ., __temp files has been saved. If this
com.genesyslab.oneX|t.keeptmpﬁlesvalue is false, all temp files on
the disk will be erased, and any
files in memory will be discarded.
If this value is true, all temp files
on disk will be kept, and files in
memory will be flushed to disk.

Defines the default (also the
upper limit) for the maxtime
attribute of the <record> tag.

com.genesyslab.maxrecordtime

Order of Precedence

immediate

true

10 minutes

To find the property value that will take effect at a particular point in an application, the current form
item is checked first (to see if the property is defined there), and enclosing scopes are checked as

necessary. Here is the full order of precedence for properties:

1. First, look for a property in the current form item (for example, in <field>, <record>, <transfer>, and so

on.). If found, use its value.

2. If not found, check the current form (for example, lookdirectly under <form> or <menu>). If the

property is found, use its value.

3. If not found, check the current document (for example, look directly under <vxml>). If the property is

found, use its value.

4. If not found, check the current document's application root document (if specified by <vxml
application="..."> in the current document). If the property is found, use its value.

5. Finally, if not found in any of the above, use the setting from the interpreter context for the current call,
which includes the settings in the defaults file (for example, defaults.vxml) and hard-coded default

values that are used if no value is configured anywhere else.
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Voice Block Palette Reference

Composer's palette contains the diagram building blocks. The block categories that appear depend
on what tab is selected above the design area or what workflow or callflow is selected in the Project
Explorer. For example, to see blocks for creating GVP voice applications, click a *.callflow tab or a
callflow in the Project Explorer.

W Palette
Eaam
T Cutput Link

* Exception Link
= Basic Blocks

= Entry

& Exit

< Prompt

= Input

T Menu

# Lag

“ Transfer

|& Reporting Blocks

|2 External Messaging Blocks
| Database Blocks

| Contest Services

|~ Outbound

= GWP

Hide Palette

The palette for GVP voice application blocks accesses the following types of blocks:

e Basic Blocks

« Database Blocks

« Computer Telephony Integration (CTI) Blocks

* External Message Blocks

e GVP Blocks

* Reporting Blocks

e Server-Side Blocks

¢ Outbound Blocks

Also see Single Session Treatments.
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https://docs.genesys.com/Documentation/IW/8.1.4/Help/SingleSessionTreatments

Voice Block Palette Reference

Tip
Should you accidentally cause the palette to disappear, click the Hide/Show Palette
triangle
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Voice Blocks Basic

The Basic Blocks provide the GVP VoiceXML element functionalities used to perform IVR activities and

GVP platform extensible object elements:

Block Name

Assign Block

Branching Block

Disconnect Block
End FCR Block

Entry Block

Exit Block
Go To Block

Grammar Menu Block

Input Block

Log Block
Looping Block
Menu Block
Prompt Block
Raise Event Block
Record Block

Release ASR Engine
Set Language Block

SNMP Block

Start FCR Block
Subdialog Block

Transfer Block

Basic Blocks

Usage

Assign a computed value/expression or an entered
value to a variable

Specify multiple application routes based on a
branching condition

Explicitly hang-up a phone call
Indicate the end of a recording segment

Begin an application. Only one Entry block can be
present in each application.Sets global error
(exception) handlers. Defines all global application-
level properties, global variables (which appear in
the list of available variables for other blocks in the
diagram), and global commands. Sets default
application scripts and parameters.

End the application
Direct the application to a specific URL

Uses Grammar Builder files to determine the input
options

Accepts DTMF or speech input from callers
Record information about an application

Iterate over a sequence of blocks multiple times
Collects DTMF and/or speech input from the caller
Play specific data to the caller

Throw custom events

Record voice input from the caller

Control when the ASR engine(s) being used in the
current session will be released

Changes the current active language from that set
in the Entry block or a previous Set Language block

Send SNMP traps from the application using the
NGI ‘dest’ extension attribute of the <log> tag

Indicate the start of a recorded audio file

Invoke VoiceXML subdialogs, which are a
mechanism for reusing common dialogs and
building libraries of reusable applications.

Transfer the call to another destination
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https://docs.genesys.com/Documentation/IW/8.1.4/Help/MenuBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/PromptBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/RaiseEventBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/RecordBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/ReleaseASREngineBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/SetLanguageBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/SNMPBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/StartFCRBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/SubdialogBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/TransferBlock

Voice Blocks Basic

Block Name Usage

Embed VXML code directly into a callflow diagram

VXML Form Block with using <subdialog>

Use the Link tools to connect the blocks.
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Voice Blocks Basic

Assign Common Block

Use the Assign common block to assign a computed value/expression or an entered value to a
variable.

See the Query Services block Service Data property for an example of using the Assign block and
Expression Builder to parse a JSON string and assign the service data to a variable.

Function getSIPHeaderValue(headername) returns the SIP header value associated with the given SIP
headername. You may wish to use this function with the Assign block. By default, this option is
disabled for backward compatibility. To set this preference, right-click the Project, select Properties,
Default Logging and check Log Assign block Variable assignments. Applicable for both Java
and .NET Projects.

Starting with 8.1.440.18, Composer Assign blocks are enhanced to generate logging statements as
part of code generation. With this enhancement ORS and MCP logs will show the Assign variables and
expressions.

VXML script

cassign name="AppState.var®” expr=""This is a callflow diagram file'" />
<log expr=""Assigning variable Appstate.var® with value * +'This is a callflow diagram file'™/»

SCXML seript

<scripte

vard = 'Welcome to workflow diagram®;

__Log(Assigning variable vare with value * +'wWelcome to workflow diagram’);
<fscripts

A new Project-level property, Default Logging, is added to control this logging capability. By default,
this option is disabled for backward compatibility. Applicable for both Java and .NET Projects.
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The Assign block has the following properties:

Name Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Block Notes Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Assign Data Property

This property assigns a value (expression) to a variable. You select the variable and then enter an
expression, either a literal or one created in Expression Builder.

To select a variable and assign a value:
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1. Click the Assign Data row in the block's property table.

2. Click the Bz putton to open the Assign Data to Variables dialog box.
3. Click in the Variable field to display a down arrow.

4. Click the down arrow and select a variable whose value will be evaluated to determine the branching
condition. Default application variables are described in the Entry block for voice applications and the
Entry block for routing applications. You can also use a custom variable.

5. Click under Expression to display the £z button.

6. Click the Ez putton to open Expression Builder. For examples of how to use Expression Builder, see the
Expression Builder topic.

7. Select an operator for the branching condition.Your variable's value will be equal to (==), less than (<),
greater than (>). less than or equal to (<=), greater than or equal to (>=) or not equal to (!=) to value
you enter in the Expression field.

8. In the Expression field, create a value to compare to the variable's value. Enclose the value in single
quotes (* ).

9. Click the ﬁ button to validate the expression. Syntax messages appear under the Expression Builder
title.

10. Click OK to close Expression Builder and return to the Assign Data to Variables dialog box.

11. You can make multiple variable/value assignments. Click the Add button if you wish to add more
assignments and repeat the steps above.

Editing Expressions
To edit an expression:

1. Click its row under Expression in the Assign Data to Variables dialog box. This causes the E=3 button to
appear.

2. Click the Bz putton to re-open Expression Builder where you can edit the expression.

Exceptions Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

» For callflows, invalid ECMAScript expressions may raise the following exception event: error.semantic.

e For workflows, invalid ECMAScript expressions may raise the following exception events:
error.script.SyntaxError, and error.script.ReferenceError.

You can use custom events to define the ECMAScript exception event handling.
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Condition Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Log Level Property

Find this property's details under CommonProperties for Callflow Blocks or Common Properties for
Workflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.
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Branching Common Block

The Branching block is used for both routing and voice applications. Use the Branching block as a
decision point in a callflow or workflow. It enables you to specify multiple application routes based on
a branching condition. Depending on which condition is satisfied, the call follows the corresponding
application route. A default path is automatically created once the conditions have been defined. If
the application cannot find a matching condition, it routes the call to the default flow.

Date/Time Functions

You can open Expression Builder from the Condition property and access the following date/time URS

functions (Data Category=URS Functions > Data Subcategory=genesys):

e genesys.session.timeInZone(tzone)

* genesys.session

* genesys.session.
* genesys.session.
* genesys.session.
* genesys.session.
e genesys.session.
* genesys.session.
* genesys.session.

* genesys.session.

The Branching block has the following properties:

.dayInZone(tzone)

day.
day.
day.
day.
day.
day.
day.

dateInZone(tzone)

Wednesday
Tuesday
Thursday
Sunday
Saturday
Monday
Friday

Exceptions Property

The Branching block has no page exceptions.

Name Property

Find this property's details under Common Properties for Callflow Blocks.
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Block Notes Property

Find this property's details under Common Properties for Callflow Blocks.

Exceptions Property

Find this property's details under Common Properties for Callflow Blocks. You can also define custom
events.

Conditions Property
This property allows you to define scripts for branching conditions and post-processing.

1. Click under Value to open the Branch Node setting dialog box.
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Branching Node settings

S

Conditionl 'Please enter a value ...

Marne Expressicn Post Action

Remowve

Remowe All

Wariables

@

OK

Cancel

N

. Click Add.

w

. Change the default Name to a more descriptive name.

N

branching expression.

. Under Expression, click under Value to open Expression Builder where you can define a script for a

5. Composer 8.1.410.14 adds a new Post Action column. Click opposite Post Action to open Expression
Builder where you can define a script for post-processing. The post-processing script get executed if the

configured option/condition was selected.

6. Click OK when done.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.
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Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

Composer Help 260


https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Log_Level_Property
https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Enable_Status_Property

Voice Blocks Basic

Disconnect Block

Use the Disconnect block to explicitly hang-up a phone call. It differs from the Exit block as follows:

* When an Exit block is used, if the application was called from a CCXML or CTI application, control is sent
back to the calling application.

¢ In the case of the Disconnect block, the entire call is terminated.

Notes

e The Disconnect block returns values (a list of variables) back to the calling context, such as a CCXML
application.

¢ The Disconnect block has no page exceptions.

e There is also a Disconnect Block for use in routing workflows as described below.

Use the routing Disconnect block and not this Disconnect block when invoking a callflow as part of a
Play Application treatment. GVP 8.x Integration Guide states the following: For a URS-centric
application, the incoming call arrives at a Routing Point DN configured in the SIP Server switch. A
routing strategy loading on the Routing Point executes a Play Application treatment to collect customer
input. SIP Server sends an INVITE specifying the URI for the voice application. Media Control Platform
executes the application. Customer data is collected, then returned to SIP Server in the BYE message.
The routing strategy receives the attached data and determines the next action for the call. The call
will return to URS where the call can be disconnected in the strategy.

The Disconnect block has the following properties:

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments. Use this Property to specify a
reason for the disconnect. The content can be either an ECMAScript expression created in Expression
Builder or free-form text. The string should conform to the standard specified in RFC 3326

(http://www.ietf.org/rfc/rfc3326.txt), Reason Header Field for the Session Initiation Protocol (SIP). To
use Expression Builder to create the reason:

1. Click under Value to display the Ez=1 button.

2. Click the Bz putton to open Expression Builder. For examples of how to use Expression Builder, see the
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Expression Builder topic.

Return Values Property

Use this property to specify the variable(s) whose value(s) will be returned once the Disconnect block
is executed. To select return variables:

1. Click the Return Values row in the block's property table.

2. Click the EZ button to open the Return Values dialog box.
3. Select individual variables, or click Select all or Deselect all as needed.

4. Click OK to close the Return Values dialog box.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

ORS Extensions Property

Starting with 8.1.4, Composer blocks used to build routing applications (with the exception of the
Disconnect and EndParallel blocks) add a new ORS Extensions property.
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End FCR Block

Use the End FCR block to indicate the end of a recording segment. There must be a matching End
FCR block for each Start FCR block used.

Note: Starting and stopping at tapped points (as marked by the Start FCR block and either EndFCR
block or the end of call) depends on the Prompt Queuing feature. For this reason, all Prompts
between Start FCR and End FCR should have their Immediate Playback property set to true.

The End FCR block has the following properties:

The End FCR block has no page exceptions.

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.
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Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.
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Entry Block and Variables

Use an Entry block to begin an application. Only one Entry block can be present in each application.
The Entry block:
* Sets global error (exception) handlers.

¢ Defines all global application-level properties, global variables (which appear in the list of available
variables for other blocks in the diagram), and global commands. See topic Variables in Callflows.

e Sets default application scripts and parameters.

¢ Accesses Expression Builder.
The Entry block is used as the entry point for a main callflow or a sub-callflow. It contains the list of all
the variables associated with the callflow (referred to as global variables). Note: Outlinks starting

from the Entry block cannot be renamed or assigned a name through the Properties view. The Entry
block has the following properties:

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Exceptions Property

Find this property's details under Common Properties. The Entry block has all global exception
events, with the defaults of all, connection.disconnect.hangup, and error. Also see Exception Events.

Note on No Input and No Match Events

When selecting exceptions for the Entry block, use both
com.genesyslab.composer.toomanynoinputs / com.genesyslab.composer.toomanynomatches and
noinput/nomatch to catch all the possible no input and no match events. The selection of
com.genesyslab.composer.toomanynoinputs / com.genesyslab.composer.toomanynomatches is
required when noinput / nomatch exceeds the maximum retries in the lower block. The selection of
noinput / nomatch is required when the lower block does not retry at all.

e com.genesyslab.composer.toomanynoinputs occurs when the number of no inputs exceeds the
maximum retries in the Menu, Input, DBInput, and Record blocks, and the blocks do not have local
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noinput exception ports.

e com.genesyslab.composer.toomanynomatches occurs when the number of no matches exceeds the
maximum retries in the Menu, Input, DBInput, and Record blocks, and the blocks do not have a local
nomatch exception port.

Note on error.badfetch.badxmlpage

NGI no longer supports this event. If upgrading an application from an earlier version of Composer
that supported this event in its Entry object, you will need to modify that object via the Exceptions
property dialog box.

Application Root Property

e Starting with 8.1.410.14, Composer Projects have a default root VXML file (ComposerRoot.vxml)
bundled inside the src folder. This file, which you can edit to create Project-level defaults such as Input
and Menu block variables and values, is present in newly created Projects and upgraded Projects. New
Callflow diagrams have this default root VXML document automatically configured in the Application
Root property of the Entry block.

You have the option to specify a VXML file to be used as an application root document allowing
multiple callflows to share variables. Background: Starting with 8.1.1, each Composer Project can
have (at most) one root document (VXML file). If a Project has no root document, each callflow is its
own stand-alone application. If a Project contains a root document, the set of callflows with Entry
blocks that reference that root document make up the application.

e If a callflow or sub-callflow references an application root document, the variables specified in the
application root become available for selection in all dialogs in that diagram.

¢ Variables defined in the application root directly under the <vxml> tag become available as global
variables to callflows and sub-callflows that access them.

To select an application root document:

1. Click the Application Root row in the block property table.

2. Click the EZ button to open the Select Resource dialog box.
3. Select the VXML file in the Project src folder and click OK.

Global Commands Property

The Global Commands property sets rootmap elements for the entire application. A rootmap element
is a phrase (user-defined phrase or external grammar) and/or tone the application reacts to at any
time the application is running. Use the Global Commands property to set rootmap elements for the
entire application. The application uses these rootmap elements as global grammars (subsets of a
spoken language that callers are expected to use) in each Input block. Composer creates one outport
for each rootmap element; the outport specifies the application path in the event to which the
rootmap element is matched. Use the Entry block Global Commands property to set rootmap
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elements for a subcallflow as well. Note: The RootMap elements defined in the Entry block do not
apply to blocks inside a subcallflow. To add, delete, or arrange global phrases, DTMF keys, and
grammars:

1. Click the Global Commands row in the block's property table.

2. Click the EZ button to open the Set Rootmap Commands dialog box.
Fields in Set Rootmap Commands Dialog Box

¢ Name-- Displays the name of the command.

e DTMF Option--Displays the DTMF key to recognize.

¢ Phrase-- Displays the phrase to recognize.

e Grammar--Displays the built-in or custom grammar used.
Genesys recommends that you use only the GRXML grammar. Otherwise, GSL support--which is not a
part of the VoiceXML 2.1 specification--deprecates over time. Note: Built-in grammar support for

languages other than U.S. English is dependent on the ASR vendor. Before using this feature, make
sure that your ASR Engine supports built-in grammars for your language.

Add Button

Use the Add button to enter global phrases, DTMF keys, and grammars.

Click Add to enable Command Details fields.

In the Name* box, accept the default name or change it.

From the DTMF Option drop-down list, select the global DTMF key.
In the Phrase box, type the phrase.

M

In the Grammar drop-down list, select a grammar. The grammar source is the custom or built-in
grammar for recognition.

Up/Down Buttons

Use the Up and Down buttons to reorder your rootmap elements. Select the element you want to
reposition, and then click Up or Down, as necessary.

Delete Button

To delete a phrase, DTMF key, or grammar entry:

1. Select an entry from the list.

2. Click Delete.
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Global Properties Property

This property allows suppression of data within the Nuance 9 platform ASR logs. For more information
on this property, see the Properties topic on the Genesys Voice Platform wiki. Use Global Properties to
select global settings for VXML properties, Automatic Speech Recognition vendor-specific properties
or Text-to-Speech vendor-specific properties. To enter properties and values:

1. Click the Global Properties row in the block's property table.

2. Click the Ez putton to open the Global Property Settings dialog box.
3. Click Add to enable the Property Name and Property Value fields.

4. Enter or select a Property Name by doing one of the following:

¢ Select the Property Name from the drop-down list, or

* Type the Property Name in the Property Name field.
5. Enter or select a Property Value by doing one of the following:

¢ Select the Property Value from the drop-down list, or

* Type the Property Value in the Property Value field.

6. Click OK.

Scripts Property

Use the Scripts property for including custom JavaScript includes into the application. The JavaScript
functions in the specified .js file can then be used in the Assign or Branching blocks in the expression.

1. For this property, enter the filename of your file (for example: script.js). If there are multiple files to be
loaded, you can delimit by using the | character; for example: scriptl.js|script2.js.
2. Then place the custom ECMAScript file in the Scripts subfolder of your project.

There is also a Global Variable SCRIPTSDIR, which specifies the default folder for the scripts files (and
works very similar to VOXFILESDIR for audio files).

Variables Property

Variables can be predefined system variables (provided by Composer, which you cannot delete) or
user-defined variables. See the Variables in Callflows topic for more information. Many Composer
blocks have properties that require you to select a variable. Examples:

e The following callflow blocks contain a mandatory Output Result property: Menu, Record, DB Input,
Grammar Menu, Input, Get Access Number, Transfer, and Statistics. After defining variables in the Entry
block, you supply this property by selecting the variable to contain the output result.
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* When creating a new voice project, a Project-level flag, Enable_ICM, controls whether ICM variables are

available for selection and assignment to variables within Composer's Entry block.

e For information on user data and GVPSessionID, see the Project Properties dialog box, Composer

Callflow Option.

To declare for the application or subcallflow:

1. In the Properties tab, click opposite Variables under Value to display the EZ3 putton.

2. Select Project, System, or User Variables.

3. Click the arrow to display the selected type. An example System Variables dialog box is shown below.
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The above figure shows the dialog box after clicking the Add button. The Value field for the new
variable (VarQ) contains a button to access Expression Builder.

Composer Help

269


https://docs.genesys.com/Documentation/IW/8.1.4/Help/ICMInteractionDataBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/ProjectMenu#Project_Properties
https://docs.genesys.com/Documentation/IW/8.1.4/Help/ExpressionBuilder

Voice Blocks Basic

GVPSessionID System Variable

Composer Projects have a callflow options property page to control how the GVPSessionID system
variable is initialized. It can be used to control if it is initialized from the X-Genesys-GVP-Session-ID
SIP header or the session.com.genesyslab.userdata object.

Restoring System Variable Default Values

Projects created in earlier versions of Composer may throw runtime errors due to incorrectly
initialized system variables after upgrading to Composer 8.1.3. This was due to changes in how
system variables were stored and handled in 8.1.3. To resolve this, the Entry block Variables dialog
adds a button to restore system variables to default values, which can be used to reset variables and
fix initialization. Note that this also removes any custom values set in system variables. As system
variables cannot be updated, after clicking the Restore System Variables Default Values button,
you cannot update the customized system variables.

Starting with 8.1.410.14, you can:

* Invoke the Entry Block variables dialog when a property is selected in the Properties view using ALT+V.

* Enable Composer to automatically declare variables in a Main callflow to match input/output variable
names in Sub-callflows and perform the mapping. For more information, see the auto
synchronization option in Diagram Preferences.

Defining Variables

Important! When defining a variable name, the name:

e Cannot start with APP_ (callflow diagrams).
e Must not start with a number or underscore.

¢ May consist of letters, numbers, or underscores.

When you define and initialize a variable that is expected to be played as a date later on in the
callflow, define the value using the following format: yyyyymmdd. Example: MyDate=20090618. You
must use this format; Composer does not perform any conversions in this case. When you define and
initialize a variable that is expected to be played as a time later on in the callflow, define a 12 hour-
based value using the following format: hhmmssa or hhmmssp. Example: MyTime=115900a or
MyTime=063700p. Define a 24 hour-based value using the following format: hhmmssh Example:
MyTime=192000h. You must use this format; Composer does not perform any conversions in this
case. If variables are set as part of provisioning by the Genesys VoiceXML provisioning system, and if
these variables have the same names as variables set in the Variables property dialog box, the
VoiceXML provisioning system values take precedence over the global variables set here. Many
blocks enable the use of variables rather than static data. For example, the Prompt block can play the
value of a variable as Text-to-Speech. Variables whose values are to be used in other blocks must be
declared here so that they appear in the list of available variables in other blocks. The value collected
by an Input block or a Menu block is saved as a session variable whose name is the same as the
block Name.
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System Variables

These variables apply only to the Entry block, unless otherwise indicated.

APP_LANGUAGE--Holds the application language setting. The value should be the RFC 3066 language
tag of an installed language pack. Examples of valid RFC 3066 language tags include en-US and fr-FR.
This setting also acts as a default language for the application. This variable may be set using the Set
Language block for a multilingual application.

APP ASR LANGUAGE--Holds the language locale for ASR resources. You must define this variable if the
application needs to use a different language locale for ASR from TTS resources.

GRAMMARFILEDIR--Gives the relative path from the application to the directory that contains the
grammar files. By default, it is set to ../Resources/Grammars. If a voice application supports multiple
languages, you can enable the application to switch between them, by changing the value of this
variable. In the Subcallflow_Start block, the GRAMMARFILEDIR global variables are not defined by
default. This allows the subcallflows to inherit the value of this variable from the main callflow. If the
subcallflow overrides this value, the variable can be defined in the Subcallflow_Start block.

VOXFILEDIR--Gives the relative path in the application to the directory that contains the audio files
(.vox/.wav). By default, it is set to ../Resources/Prompts. If a voice application supports multiple
languages, you can enable the application to switch between them, by changing the value of this
variable.

SCRIPTSDIR--Default location for JavaScript files

EnableReports--Enables VAR reporting. (Reporting blocks)

EnableSNMP--Enables the SNMP block, if present in the application

CallUUID--Session connection Universal ID

GVPSessionlD--The Genesys Userdata Session ID

LAST_EVENT_NAME--Stores the name of the last event or error that was handled in the Entry block.
LAST_EVENT_MSG--Stores the message of the last event or error that was handled in the Entry block
LAST_EVENT_URL--Stores the URL of the last event or error that was handled in the Entry block.

LAST_EVENT_ELEMENT--Stores the element name of the last event or error that was handled in the
Entry block

LAST_EVENT_LINE--Stores the line number of the last event or error that was handled in the Entry
block

EnableFCR--A flag for enabling Full Call Recording
COMPOSER WSSTUBBING

App_OPM--Used for fetching OPM parameters. Stores JSON content passed by GVP in session variables.
Available throughout the callflow diagram. The OPM block works with this variable by extracting values
from it into application variables. Available for main callflows only.

OCS_RecordURI--Used by Outbound blocks. Its default value will be set from userdata passed into the
application. For workflows (SCXML):
_genesys.ixn.interactions[InteractionID].udata.GSW_RECORD_URI.For callflows: (VXML)
session.com.genesyslab.userdata.GSW_RECORD_URI.

OCS_URI--Used by Outbound blocks. Holds the OCS resource path ([http|https]://<host>:<port>). Its
default value will be deduced from OCS_Record_URI. You may change this variable value in order to use
a different OCS application for all Outbound blocks in the workflow.
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* OCS_Record--Used by Outbound blocks. Holds the Record Handle value deduced from
OCS_Record_URI.

Note: Request URi parameters created in IVR Profiles during the VoiceXML application provisioning
are passed to the Composer generated VoiceXML application as request-uri parameters in the
session.connection.protocol.sip.requesturi session array. An Entry block variable can use
these parameters by setting the following expressions to the variable values: typeof
session.connection.protocol.sip.requesturi['varl'] == 'undefined' ?
"LocalDefaultValue" : session.connection.protocol.sip.requesturi['varl']. If parameters
are set as part of IVR Profiles provisioning in the Genesys VoiceXML provisioning system, and if these
parameters have the same names as variables set in the Entry block's Variables property with the
above mentioned sip.requesturi expression, then the SIP-Request-URI parameters will take
precedence over the user variable values set in the Entry block.

Many blocks enable the use of variables rather than static data. For example, the Prompt block can
play the value of a variable as Text-to-Speech. Variables whose values are to be used in other blocks
must be declared here so that they appear in the list of available variables in other blocks. The value
collected by an Input block or a Menu block is saved as a session variable whose name is the same as
the block name.

Variable Name

You can use the Variable name field for either of the following purposes:

¢ To enter the name of a new variable.

¢ To change the name of an existing variable. To do this, select an existing variable from the list of
variables. The variable's name appears in the Variable box, and you can the change its value in the
Value box.

Excluded Characters

The Variable name field will not accept the following special characters:

e less-than sign (<)

e greater-than sign (>)

e double quotation mark ()
e apostrophe (‘)

e asterisk (*)

e ampersand (&)

e pound (#)

e percentage (%)

e semi colon (;)

e question mark (?)

e period (.)

The variable Value field will not accept the following special characters:
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e |less-than sign (<)

e greater-than sign (>)

¢ double quotation mark ()
e apostrophe (‘)

e ampersand (&)

e plus sign (+)

* minus sign (-)

* asterisk (¥)

e percentage (%)

Condition Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.
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Exit Block

Use the Exit block to end the application. There will usually be an Exit block in every main callflow,
unless you use a GoTo block, blind transfer, or other mechanism to end a callflow. Return Mode
should be set to false in the main callflow's Exit block. The Exit block is typically connected to the
connection.disconnect.hangup exception handler. It is also connected to the last block in the
application (for example, when the application wants to play an error message and terminate the
call). You can have multiple Exit blocks inside a callflow. The Exit block has no page exceptions.

Using an Exit Block Inside a Subcallflow

The Subdialog block is used to create subcallflows, which are VoiceXML subdialogs. An Exit block
terminates the subcallflow application. If the control has to be returned to the main application, then
the Return Mode property should be set to true and the user can send a list of parameters to the
main call flow as the output parameters. Name

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Reason Property

This property is visible only for subcallflows. Enter a reason for the implicit ActionEnd to be used for
VAR reporting.

Return Mode Property

This property is visible only for subcallflows. Click the down arrow under Value and select one of the
following:

e true to return control back to the calling callflow.

e false to exit the application.
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Return Values Property

Use this property to specify the variable(s) whose value(s) will be returned once the Exit block is
executed. To select return variables:

1. Click the Return Values row in the block's property table.

2. Click the Bz putton to open the Return Values dialog box.

3. Select individual variables (including ICM variables if applicable), or click Select all or Deselect all as
needed.

4. Click OK to close the Return Values dialog box.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

Result Property

This property is visible only for subcallflows. Click the down arrow and select one of the following to
be used for VAR reporting:

* UNKNOWN
* SUCCESS
* FAILED
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Golo Block

Use this block to direct the application to a specific URL. This block enables you to pass parameters in
the current application to the URL by selecting them from the User Parameters list. This block is
normally used to transfer to another voice application. Genesys recommends that you use
subcallflows for modularizing the application and the GoTo block for calling an external application.
Note: If an application enables Voice Application Reporting, Genesys recommends that you use
subcallflows instead of a GoTo block. The GoTo block has no page exceptions. The GoTo block has the
following properties:

Name Property

Please find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.
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Parameters

Use to select variables/parameters to pass to the target application. Note: If the Type property is set
to ProjectFile, the Parameters property does not apply. To select parameters (Type property is set to
URL):

1. Click the Parameters row in the block's property table.

2. Click the EZ button to open the Parameters dialog box.
3. Select individual parameters, or click Select all or Deselect all as needed.

4. Click OK to close the Parameters dialog box.

Type
Sets the type of the destination application. There are two options:

e URL--The destination application can be found at the location specified in the Uri property.

e ProjectFile--The destination can be another location inside the same Composer Project.
To select a value for the Type property:

1. Select the Type row in the block's property table.

2. In the Value field, select URL or ProjectFile from the drop-down list.

URI

Specifies the destination (URL or Composer Project) depending on the value of the Type property. To
set a URL destination for the Uri property (Type property is set to URL):

1. Select the Uri row in the block's property table.
2. In the Value field:

* Type a valid URL, which can be specified as a relative path if the file is in the same project (for
example, .../src/WSJNews.vxml).

* Or select a variable from the drop-down list.
To set a Composer Project destination for the Uri property (Type property is set to ProjectFile):

1. Click the Uri row in the block's property table.

2. Click the E& pbutton to open the Uri dialog box.
3. Select a Voice Project file in the list.

4. Click OK to close the Uri dialog box.
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Fetch Audio Property

Enter the fetchaudio file to play when executing a long-running tasks, such as a server side web
query. By default, Next Generation Interpreter NGI) supplies a built-in fetchaudio file. For information
on GVP support of fetchaudio, see:

¢ Fetching Properties in GVP Voice XML Help.
e The VoiceXML Properties section of the GVP 8.1 Legacy Genesys VoiceXML 2.1 Reference Manual.
¢ The Prompt block, VXML Behavior and Queueing of Prompts.

Fetch Audio Delay Property

Enter the length of time to wait at the start of a fetch delay before playing fetchaudio. For more
information, see Fetching Properties in GVP Voice XML Help

Fetch Audio Minimum Property

Enter the minimum length of time to play fetchaudio, once started, even if the fetch result arrives in
the meantime. For more information, see Fetching Properties in GVP Voice XML Help

Fetch Hint Property

Select prefetch or safe to define when XML data files can be fetched. Selecting safe indicates to only
load the XML data file when needed. For more information, see Fetching Properties in GVP Voice XML
Help.

Fetch Timeout Property

Enter the timeout for fetches. This is not supported when using Nuance (MRCP). An error.badfetch is
thrown when a fetch duration exceeds fetchtimeout. For more information, see Fetching Properties in
GVP Voice XML Help.

Max Age Property

Enter the maximum acceptable age, in seconds, of cached audio resources. For more information,
see Fetching Properties in GVP Voice XML Help.
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Max Stale Property

Enter the maximum staleness, in seconds, of expired cached audio resources.For more information,
see Fetching Properties in GVP Voice XML Help.
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Grammar Menu Block

Creating a Simple Grammar Video

Below is a video tutorial on building a simple grammar with the Grammar Menu block.

While the interface for Composer in this video is from release 8.0.1, the steps are the
basically the same for subsequent releases.

Link to video

The Grammar Menu block uses Grammar Builder files to determine the input options.

Menu Block Exception Events

The Menu block has eight local exception events.

e error
e error.noresource

¢ maxspeechtimeout

* noinput

* nomatch

¢ error.badfetch.grammar.uri

¢ error.badfetch.grammar.syntax

* error.badfetch.grammar.load

The Grammar Menu block has the following properties:

Name Property

Find this property's details under Common Properties.
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Block Notes

Can be used for both callflow and workflow blocks to add comments.

Exceptions

Find this property's details under Common Properties.

Gbuilder File Property

A Gbuilder file is created using Grammar Builder and may contain grammar-related information for
multiple locales in a proprietary format. The Grammar Menu block can work with the Gbuilder file
directly. The Gbuilder File property is used to select a Gbuilder file in the project. This step also
selects the particular rule Rule ID to use for the Grammar Menu block. Once specified, the Grammar
Menu block creates menu options based on the information contained in the specified Rule ID in the
selected Gbuilder file. To select a grammar builder file and rule:

1. Select the Gbuilder File row in the block's property view.

2. Click the EZ putton to open the GBuilder File dialog box.

Grammar builder files that are defined for this Composer Project are shown in the GBuilder Files pane
on the left. These files are usually located in the project folder path: [VoiceProject] > Resources
> Grammars > [ locale] > [gbuilderfile].gbuilder . Note: Gbuilder files also contain DTMF
information.

1. Select a grammar builder file in the left pane.

2. Rules defined for the selected grammar builder file are displayed in the Rules in selected file pane to the
right. Select the rule you want to use in this Grammar Menu block, then click OK.

Your selection automatically populates the information for the following three properties: Rule IdRule
TagsMenu Options Note: The Grammar Menu block does not pick up changes automatically if you
change your Gbuilder file. To synchronize the block with the latest changes, click on the Gbuilder File
property. In the popup make sure that the correct Gbuilder file and RulelD are selected. Click OK to
close the dialog box. Your diagram will now reflect any menu options changes made in the Gbuilder
file.

Rule ID Property

The Rule ID property is automatically populated with the rule you selected from the Rules in selected
file pane in the GBuilder File dialog box. (Refer to the Gbuilder File property.) This is a read-only
property in the properties view.
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Rule Tags

The Rule Tags property is automatically populated with the specific rule tags that have been defined
for the rule you selected from the Rules in selected file pane in the GBuilder File dialog box. (Refer to
the Gbuilder File Property and Rule Id property.) This is a read-only property in the properties view.

Language

The language set by this property overrides any language set by the Set Language block, the Project
preferences, or the incoming call parameters. The property takes effect only for the duration of this
block, and the language setting reverts back to its previous state after the block is done. In the case
of the Grammar Menu block, this property affects the language of grammars of TTS output:

1. Click under Value to display a down arrow.

2. Click the down arrow and select English - United States (en-US) or the variable that contains the
language.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

Menu Mode

To assign a value to the Menu Mode property:
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1. Select the Menu Mode row in the block's property table.
2. In the Value field, select DTMF, Voice, or Hybrid from the drop-down list.

The DTMF format indicates the menu option mode of input will be via the telephone keypad. Note:
Grammar Builder treats DTMF as another locale. The Voice format indicates the menu option mode of
input will be a voice phrase. The Hybrid menu mode will handle both DTMF and Voice inputs, that is
via telephone keypad and voice phrase. Note: If you select the Hybrid menu mode, you will have to
provide both voice and DTMF values for all menu options.

Menu Options

The Menu Options property is automatically populated with generated menu items (options) that
apply to the selected rule tags in the grammar builder file. You do not modify this property. (Refer to
the Gbuilder File property, Rule ID property, and Rule Tags property.) This is a read-only property in
the properties view.

Clear Buffer

Use the Clear Buffer property for clearing the DTMF digits in the key-ahead buffer. If it is not set to
true, the DTMF digits entered are carried forward to the next block. It is commonly used for
applications with multiple menus, enabling the caller to key ahead the DTMF digits corresponding to
the menu choices. To assign a value to the Clear Buffer property:

1. Select the Clear Buffer row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Interruptible

The Interruptible property does not apply to the Record block. This property specifies whether the
caller can interrupt the prompt before it has finished playing. To assign a value to the Interruptible
property:

1. Select the Interruptible row in the block's property table.
2. In the Value field, select true,false,or DTMF (for DTMF barge-in mode support) from the drop-down list.

Prompts

Find this property's details under Common Properties. Note: When Type is set to Value and Interpret-
As is set to Audio, you can specify an HTTP or RTSP URL. When Type is set to Variable and Interpret-
As is set to Audio, you can specify a variable that contains an HTTP or RTSP URL. Starting with
8.1.410.14, validation displays a warning message if a resource file does not exist.
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Timeout

The Timeout property defines the length of the pause between when the voice application plays the
last data in the list, and when it moves to the next block. To provide a timeout value:
1. Select the Timeout row in the block's property table.

2. In the Value field, type a timeout value, in seconds.

Security

When the Security property is set to true, data for this block is treated as private. GVP will consider
the data entered by the caller for this block as sensitive and will suppress it in platform logs and
metrics. To assign a value to the Security property:

1. Select the Security row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Output Result

You must use the Output Result property to assign the collected data to a user-defined variable for
further processing. Note! This property is mandatory. You must select a variable for the output result
even if you do not plan on using the variable. If this is not done, a validation error will be generated in
the Problems view.

1. Select the Output Result row in the block's property table.

2. In the Value field, click the down arrow and select a variable.

For more information, see Upgrading Projects/Diagrams.

Get Shadow Variables

Shadow variables provide a way to retrieve further information regarding the value of an input item.
By setting this property to true, it will expose the block’s shadow variable within the callflow. When
enabled, the shadow variable will be included in the list of available variables. (For example, the Log
block’s Logging Details will show GrammarMenul$.) A shadow variable is referenced as
blockname$.shadowVariable, where blockname is the value of the input item's name attribute, and
shadowVariable is the name of a specific shadow variable, for example: GrammarMenul$.duration. To
assign a value to the Get Shadow Variables property:

1. Select the Get Shadow Variables row in the block's property table.

2. In the Value field, select true or false from the drop-down list.
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Number of Retries Allowed

This property determines how many opportunities the user will be provided to re-enter the value. If
Use Last Prompt Indefinitely is set to true, this property has no effect; otherwise, the
error.com.genesyslab.composer.toomanynomatches or
error.com.genesyslab.composer.toomanynoinputs errors will be raised on reaching the maximum
retry limit. To provide a value for the number of retries allowed:

1. Select the Number Of Retries Allowed row in the block's property table.

2. In the Value field, type a value for the number of retries that will be allowed.

Retry Prompts

Find this property's details under Common Properties. A selection can only be made if the Number Of
Retries Allowed Property is greater than 0. Starting with 8.1.410.14, validation displays a warning
message if a resource file does not exist.

Use Last Reprompt Indefinitely

If you set the Use Last Reprompt Indefinitely property to true, the application uses your last re-
prompt as the prompt for all further retries. Therefore, the exception handlers that come out for
nomatch and noinput are redundant--even if you set the default exceptions that come out as red dots
on the left-side of the block. To assign a value to the Use Last Reprompt Indefinitely property:

1. Select the Use Last Reprompt Indefinitely row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Use Original Prompts

If you set the Use Original Prompts property to true, in the event of an error requiring a retry, the
application first plays back the retry error prompt, and then plays back the original prompt for the
block (as specified in the Prompts property). To assign a value to the Use Original Prompts property:

1. Select the Use Original Prompts row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Use Single Counter For Nomatch And Noinput

If you set the Use Single Counter For Nomatch And Noinput property to true, the application
maintains a single combined counter for the nomatch and noinput errors. For example, if the block
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has three nomatch retry messages and three noinput retry messages, the user gets three retry
attempts. If you do not select this option, the application generates a total of six retries; and the user
gets up to six retry attempts while not exceeding three of each type -- noinput or nomatch. Note: This
property not available on the Record block. To assign a value to the Use Single Counter For Nomatch

And Noinput property:

1. Select the Use Single Counter For Nomatch And Noinput row in the block's property table.

2. In the Value field, select true or false from the drop-down list.
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Input Block

The Input block accepts DTMF or speech input from callers. It differs from the Menu block in that it
enables taking input that might not belong to a simple choice list (as for the Menu block). It can be
used to collect numerical data; for example, phone numbers, account numbers, amounts, or speech
data, such as a Stock name. It uses speech or DTMF grammars to define the allowable input values
for the user responses. Built-in system grammars are available for data, such as dates and amount.

Built-in grammars may not be available for all languages. If you specify a language
other than U.S. English and refer to an unsupported built-in grammar, a parse error
error.unsupported.builtin will be thrown.

In case of user input blocks (Menu, Input, Record, Transfer), Composer adds a global variable of type
"Block" to the variables list. You can conveniently use this variable for accessing the user input
value. Also see Menu Block, Number of Allowed Attempts Exceeded. The Input block has the following
properties:

Input Block Exception Events

The Input block has eight exception events:

e error
* error.noresource

* maxspeechtimeout

* noinput

¢ nomatch

* error.badfetch.grammar.uri

¢ error.badfetch.grammar.syntax

¢ error.badfetch.grammar.load

Name Property

Please find this property's details under Common Properties.
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Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Exceptions Property

Find this property's details under Common Properties.

Language Property

The language set by this property overrides any language set by the Set Language block, the Project
preferences, or the incoming call parameters. The property takes effect only for the duration of this
block, and the language setting reverts back to its previous state after the block is done. In the case
of the Input block, this property affects the language of grammars of TTS output:

1. Click under Value to display a down arrow.

2. Click the down arrow and select English - United States (en-US) or the variable that contains the
language.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

Composer Help 288


https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Exceptions_Property
https://docs.genesys.com/Documentation/IW/8.1.4/Help/SetLanguageBlock
https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Condition_Property
https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Logging_Details_Property
https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Log_Level_Property
https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Enable_Status_Property

Voice Blocks Basic

Output Result Property

You must use the Output Result property to assign the collected data to a user-defined variable for
further processing.

This property is mandatory. You must select a variable for the output result even if you
do not plan on using the variable. If this is not done, a validation error will be
generated in the Problems view.

1. Select the Output Result row in the block's property table.

2. In the Value field, click the down arrow and select a variable.

For more information, see Upgrading Projects/Diagrams.

Clear Buffer Property

Use the Clear Buffer property for clearing the DTMF digits in the key-ahead buffer. If it is not set to
true, the DTMF digits entered are carried forward to the next block. It is commonly used for
applications with multiple menus, enabling the caller to key ahead the DTMF digits corresponding to
the menu choices. To assign a value to the Clear Buffer property:

1. Select the Clear Buffer row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Interruptible Property

This property specifies whether the caller can interrupt the prompt before it has finished playing. To
assign a value to the Interruptible property:

1. Select the Interruptible row in the block's property table.

2. In the Value field, select true,false,or DTMF (for DTMF barge-in mode support) from the drop-down list.

Prompts Property

Find this property's details under Common Properties.
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When Type is set to Value and Interpret-As is set to Audio, you can specify an HTTP or
RTSP URL. When Type is set to Variable and Interpret-As is set to Audio, you can
specify a variable that contains an HTTP or RTSP URL. Starting with 8.1.410.14,
validation displays a warning message if a resource file or URL does not exist.

Security Property

When the Security property is set to true, data for this block is treated as private. GVP will consider
the data associated with this block as sensitive and will suppress it in platform logs and metrics.
Composer uses the com.genesyslab.private property for the Security property of callflow blocks.
For more information see the GVP 8.1 Voice XML Help.

To assign a value to the Security property:

1. Select the Security row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Timeout Property

The Timeout property defines the length of the pause between when the voice application plays the
last data in the list, and when it moves to the next block. To provide a timeout value:
1. Select the Timeout row in the block's property table.

2. In the Value field, type a timeout value, in seconds.

Grammar Type Property

To assign a value to the Grammar Type property:

1. Select the Grammar Type row in the block's property table.

2. In the Value field, select one of the following from the drop-down list:

* builtinBoolean
e builtinCurrency
e builtinDate

* builtinDigits

e builtinNumber
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¢ builtinPhone
e builtinTime

e externalGrammar

All the builtinXXX selections are grammars that are provide by the platform or the
ASR Engine. Built-in grammar support for locales other than U.S. English is dependent
on the ASR vendor. Before using this feature, make sure that your ASR Engine
supports built-in grammars for your locale. This feature has the following critical
prerequisites: The ASR Engine must support built-in grammars for that language.
Contact your ASR Vendor for details. If the ASR Engine supports the language you
want to use, then you must install the Language Pack for that language on the GVP
Server.

builtinBoolean

Valid inputs include affirmative and negative phrases appropriate to the current locale. DTMF 1
represents " yes," and 2 represents "no." The result is ECMAScript true for yes or false for no. The
value is submitted as the string true or the string false.

builtinCurrency

Valid spoken inputs include phrases that specify a currency amount. For DTMF input, the asterisk (*)
character acts as the decimal point. The result is either a string with the format UUUmm.nn, where
UUU is the three-character currency indicator according to ISO standard 4217:1995, or null if not
spoken by the caller.

builtinDate

Valid spoken inputs include phrases that specify a date, including a month, day, and year. DTMF
inputs are: four digits for the year, followed by two digits for the month, and then two digits for the
day. The result is a fixed-length date string with format yyyymmdd--for example, 20000704. If the
year is not specified, yyyy is returned as ?7?77?; if the month is not specified mm is returned as ??; and
if the day is not specified dd is returned as ?7.

builtinDigits

Valid spoken or DTMF inputs include one or more digits, 0--9. The result is a string of digits.

builtinNumber

Valid spoken inputs include phrases that specify numbers--for example, one hundred twenty-three, or
five point three. Valid DTMF input includes positive numbers entered using digits and the star (*)
character (to represent a decimal point). The result is a string of digits from 0-9 and that can
optionally include a decimal point (.), and/or a plus sign (+) or minus sign (-).
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builtinPhone

Valid spoken inputs include phrases that specify a phone number. DTMF star (*) represents x. The
result is a string that contains a telephone number consisting of a string of digits and optionally, the
character x to indicate a phone number with an extension--for example, 8005551234x789."

builtinTime

Valid spoken inputs include phrases that specify a time, including hours and minutes. The result is a
five-character string in the format hhmmx, where x is either a for AM, p for PM, h to indicate a time
specified according to the 24-hour clock, or ? to indicate an ambiguous time. Because there is no
DTMF convention for specifying AM/PM, in the case of DTMF input, the result is always end with h

or ?. If the field value is subsequently used in a prompt, the value is spoken as a time appropriate to
the current locale.

externalGrammar

The application can also define an external grammar. The grammars can be written using the GRXML
Editor, or GRXML files can be imported into the Composer Project. Look at the User Input Project voice
application template in Composer for an example of the use of an external grammar file. Note for
Voice Application Developers When developing a VoiceXML application, you must set the web
server connection timeout so that it is appropriate to the task that the application performs. It should
be greater than one or all of the following callflow applications:

¢ Maximum talk time

¢ Maximum recording time

e Maximum wait time for a user input

Input Grammar Dtmf Property

Multiple grammars by using “|” is supported only when literal values are used and not
for expressions and variables. Also, the grammar file URI must be specified within
single quotes.

Use the Input Grammar Dtmf (Dual Tone Multi-Frequency as described below) property to specify the
DTMF Grammar for the Input Block. The DTMF Grammar is processed and handled by GVP. In the case
of external grammars, this specifies the actual path of the grammar file / resource for DTMF
Grammars. This is only valid when the Grammar Type is externalGrammar and Input Mode is dtmf or
hybrid. To assign a value to the Input Grammar Dtmf property:

1. Select the Input Grammar Dtmf row in the block's property table.

2. In the Value field, select a value from the drop-down list. >br>
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Values are the Voice Application Variables described under the Variables You can specify multiple
grammars by separating the grammars with the "|" character.

Multiple Inputs:
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About Dual Tone Multi Frequency (DTMF) Signaling

DTMF signaling is used for telecommunication signaling over analog telephone lines in the voice-
frequency band between telephone handsets and other communications devices and the switching
center. The version of DTMF used for telephone tone dialing is known by the trademarked term,
Touch-Tone. There are some situations where the interpreter (NGI) cannot accept DTMF keypresses
immediately as input. In these situations, the keypresses are stored in the DTMF input buffer, for
possible later use as input. Throughout the execution of the application, the interpreter must decide
whether to save the current contents of the DTMF input buffer (and use them at the next input state),
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or to discard them. Buffering DTMF input can be useful in allowing typeahead, where users input
DTMF for multiple fields rapidly, separated by the termchar. Whatever input is left after the first
termchar, may be used in subsequent fields, meaning that the user does not have to wait to hear
each prompt.

Input Grammar Voice Property

Multiple grammars by using “|"” is supported only when literal values are used and not
for expressions and variables. Also, the grammar file URI must be specified within
single quotes.

Use the Input Grammar Voice property to specify the Voice Grammar for the Input block. If you are
writing hybrid applications that allow both DTMF and Speech input, specify both the DTMF and Voice
grammars. The Voice Grammar is sent to the ASR Engine for processing, whereas the DTMF grammar
is processed by GVP. As a result, you need two separate grammars for Voice and DTMF in the case of
hybrid applications that allow both Voice and DTMF inputs. In the case of external grammars, this
specifies the actual path of the grammar file / resource for ASR Grammars.. This is only valid when
Grammar Type is externalGrammar and Input Mode is voice or hybrid. To assign a value to the Input
Grammar Voice property:

1. Select the Input Grammar Voice row in the block's property table.

2. In the Value field, select a value from the drop-down list. You can specify multiple grammars by
separating the grammars with the "|" character.

Values are the Voice Application Variables described under the Variables Property.
Multiple Inputs:
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Single Input:

Input Mode Property

To assign a value to the Input Mode property:

1. Select the Input Mode row in the block's property table.

2. In the Value field, select one of the following from the drop-down list:

e dtmf
e voice

* hybrid

DTMF

The DTMF format indicates the menu option mode of input will be via the telephone keypad.

Voice

The Voice format indicates the menu option mode of input will be a voice phrase.

Hybrid

The Hybrid menu mode will handle both DTMF and Voice inputs, that is via telephone keypad and
voice phrase.
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Slot Property

The Slot property enables you to specify the slot name of the return value from the grammar. If the
slot name is not specified, it is assumed that the grammar will return the value of a slot having the
same name as the INPUT block itself. To provide a slot name:

1. Select the Slot row in the block's property table.

2. In the Value field, type a slot name that conforms to the restrictions above.

Input Termination Character Property

The Input Termination Character property defines any character that callers can input in order to
indicate that they have finished entering data. For example, the prompt given to the caller may say
"Enter your account number, and then press the pound key." The pound key is the input-ending
character. To provide a value for the input termination character:

1. Select the Input Termination Character row in the block's property table.

2. In the Value field, type a value for a character to represent the end of the input string.
A typical value that is often used, as indicated above, is: # Example:

e To use # or * then type the value as # or *

Warning

Only 1 character can be used as the termination character.

Inter Digit Timeout Property

The Inter Digit Timeout property defines the longest wait time between input characters before a
timeout is generated. This is mandatory if dtmf is selected as the Input Mode. Note: Inter Digit
Timeout property is applicable only for DTMF input. To provide an Inter Digit timeout value:

1. Select the Inter Digit Timeout row in the block's property table.

2. In the Value field, type a timeout value, in seconds.
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Maximum Input Digits Property

Tip

This property only applies if the builtinDigits grammar is selected.

The Maximum Input Digits property defines the maximum number of characters that the caller may
input. If the input is variable, an input character such as pound sign (#) should be used to terminate
the input. This is mandatory if dtmf is selected as the Input Mode. To provide a value for the
maximum number of input digits:

1. Select the Maximum Input Digits row in the block's property table.

2. In the Value field, type a value for the maximum number of input digits.

Minimum Input Digits Property

Tip

This property only applies if the builtinDigits grammar is selected.

The Minimum Input Digits property defines the minimum number of characters that the caller must
input. This is mandatory if dtmf is selected as the Input Mode. To provide a value for the minimum
number of input digits:

1. Select the Minimum Input Digits row in the block's property table.

2. In the Value field, type a value for the minimum number of input digits.

Get Shadow Variables Property

Shadow variables (optional) provide a way to retrieve further information regarding the value of an
input item. By setting this property to true, it will expose the block’s shadow variable within the
callflow. When enabled, the shadow variable will be included in the list of available variables. (For
example, the Log block’s Logging Details will show Inputl$.) A shadow variable is referenced as
blockname$.shadowVariable, where blockname is the value of the input item's name attribute, and
shadowVariable is the name of a specific shadow variable, for example: Inputl$.duration. Shadow
variables can provide platform-related information about the interaction/input. For example, for
speech recognition, this may be the confidence level the platform receives from the ASR engine
about how closely the engine could match the user utterance to specified grammar. To assign a value
to the Get Shadow Variables property:
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1. Select the Get Shadow Variables row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Number Of Retries Allowed Property

The Number Of Retries Allowed property determines how many opportunities the user will be
provided to re-enter the value. If Use Last Prompt Indefinitely is set to true, this property has no
effect; otherwise, the error.com.genesyslab.composer.toomanynomatches or
error.com.genesyslab.composer.toomanynoinputs errors will be raised on reaching the maximum
retry limit. To provide a value for the number of retries allowed:

1. Select the Number Of Retries Allowed row in the block's property table.

2. In the Value field, type a value for the number of retries that will be allowed.

Retry Prompts Property

Find this property's details under Common Properties.

Use Last Reprompt Indefinitely Property

If you set the Use Last Reprompt Indefinitely property to true, the application uses your last reprompt
as the prompt for all further retries. In this case the NoMatch and Nolnput exception handlers will
never get executed, as the retry loop keeps executing forever. To assign a value to the Use Last

Reprompt Indefinitely property:

1. Select the Use Last Reprompt Indefinitely row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Use Original Prompts Property

If you set the Use Original Prompts property to true, in the event of an error requiring a retry, the

application first plays back the retry error prompt, and then plays back the original prompt for the

block (as specified in the Prompts property). To assign a value to the Use Original Prompts property:
1. Select the Use Original Prompts row in the block's property table.

2. In the Value field, select true or false from the drop-down list.
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Use Single Counter For Nomatch And Noinput Property

If you set the Use Single Counter For Nomatch And Noinput property to true, the application
maintains a single combined counter for the nomatch and noinput errors. For example, if the block
has three nomatch retry messages and three noinput retry messages, the user gets three retry
attempts. If you do not select this option, the application generates a total of six retries; and the user
gets up to six retry attempts while not exceeding three of each type -- noinput or nomatch.

Tip
This property not available on the Record block.

To assign a value to the Use Single Counter For Nomatch And Noinput property:

1. Select the Use Single Counter For Nomatch And Noinput row in the block's property table.

2. In the Value field, select true or false from the drop-down list.
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Log Common Block

Use a Log block to record information about an application. For example, you can log caller-recorded
input collected while an application is running or error messages. You can use the Log block for any of
the following purposes:

1. Informational - To log the application specific data
2. Error - for logging error details

3. Warning - to flag any warnings

4. Debug - for debugging

The categories in the Log Level property correspond to the above.

When used for a callflow, the Log block writes the log to the Genesys Voice Platform logs (Media
Control Platform) using the VoiceXML <log> tag.

The Log block has the following properties:

The Log block has no page exceptions.

Name Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow blocks.

Block Notes Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Exceptions Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

For callflows, invalid ECMAScript expressions may raise the following exception events:
error.semantic. For workflows, invalid ECMAScript expressions may raise the following exception
events:

e error.log.ReferenceError
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e error.illegalcond.SyntaxError

e error.illegalcond.ReferenceError

You can use custom events to define the ECMAScript exception event handling.

Condition Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Label Property

This property applies to workflows only. It provides meta-data for the logging details.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

ORS Extensions Property

Starting with 8.1.4, Composer blocks used to build routing applications (with the exception of the
Disconnect and EndParallel blocks) add a new ORS Extensions property.
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Looping Common Block

Use this block to iterate over a sequence of blocks multiple times in the following scenarios:

1. Iterate over a sequence of blocks based on a self-incrementing counter (FOR).
2. lterate indefinitely until an exit condition is met (WHILE).

3. Iterate over records/data returned by the DB Data block (CURSOR/FOREACH). Also, populate variables if
variables mapping is defined.

4. lterate over data returned by Context Services blocks (FOREACH). Also, populate variables if Variables
Mapping is defined.

5. Iterate over JSON Array defined in the application.
For scenarios 1 and 2 above, use the Looping block with a reference to the block retrieving the data.

Scenarios 3 and/or 4 can be used in conjunction with 1 or 2, in which case the loop will exit when
either of the exit conditions is met.

Prerequisite

You must perform the following steps in order for the Looping block to be used to iterate over data
returned by the DB Data block:

1. Create a folder named Scripts in the Project folder.

2. In the Entry block, specify a value for the Scripts property such as ../include/DBRecordSetAccess.js

The Looping block has the following properties:

Name Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Block Notes Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.
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Counter Initial Value Property

A Counter variable controls the number of loops. Specify the initial value by entering a positive
integer (including zero) or selecting the variable that contains the initial value. Composer will
increment the Counter variable after each iteration. The value of the Counter variable is available
after the looping has exited. This is a mandatory property if the Counter Variable property is
specified.

Counter Variable Property

Enter a name for the variable used to store the Counter value or select the variable that contains the
name. This is a mandatory property if the Counter Initial Value property is specified.

Current Record Variable Property

Select a variable to be used to store the current record when iterating over records. Composer will
assign the current record after each iteration. This property is ignored if the Data Source Property is
not set

Data Source Property

Specify a block reference to the DB Data or a Context Services block (with Variables Mapping
support) that provides the data to be iterated or select the variable that contains a JSON Array. This is
a mandatory property if Counter Initial Value and Counter Variable are not specified.

Exceptions Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks. You can also define custom events.

Counter Max Value Property

Specify the maximum value by entering a positive integer greater than the initial value or selecting
the variable that contains the maximum value. When the Counter variable reaches the maximum
value, then the block connected to the Exit port is executed. This is a mandatory property if the
Counter Variable property is specified or if the Data Source property is not specified.
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Exit Expression Property

This property is optional. If specified, prior to each iteration the exit expression is evaluated. If true,
the flow goes out via the Exit port of the block. This condition is used in conjunction with max records
(if Data Source is specified) or Counter Max Value (if Counter Variable is specified). To enter an exit
expression

1. Opposite the Exit Expression property, click under Value to display the B button.

2. Click the Bz putton to open Expression Builder. For examples of how to use Expression Builder, see the
Expression Builder topic.

3. Create the exit expression and click OK.

Condition Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

ORS Extensions Property

Starting with 8.1.4, Composer blocks used to build routing applications (with the exception of the
Disconnect and EndParallel blocks) add a new ORS Extensions property.
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Using the Looping Block (Counter-based without a Data Source)

1. Add a Looping block and connect the previous block outport to the Looping block.

2. Connect the Next outport to the sequence of connected blocks.

3. Connect the outport of the last block in the sequence in step 2 back to the looping block to form a loop.
4

. Connect the Exit outport of the looping block to the block(s) to continue processing after the loop has
exited. The diagram when a looping block is used should appear as follows:
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FOR loop: To iterate over the PromptCounter block 10 times, the following properties are set:

1. Counter Initial Value is 1.
2. Counter Variable Name is Variable(MyCounterVariable).

3. Counter Max Value is 10.

WHILE loop: To iterate over the PromptCounter block until a condition is satisfied, the following
property is set: Exit expression is loginSuccessful != true.
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Using the Looping Block with a DB Data/Context Services Block

1. Add a Looping block and connect the DB Data/Context Services block outport to the Looping block.

2. Connect the Next outport to the sequence of connected blocks.

3. Connect the outport of the last block in the sequence in step 2 back to the looping block to form a loop.
4

. Connect the Exit outport of the looping block to the block(s) to continue processing after the loop has
exited. The diagram when a looping block is used should appear as follows:
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CURSOR/FOREACH loop: To iterate over the PromptColumnl block for each record returned by the
DBDatal block, the following property is set: Data Source = Block Reference (DBDatal) This example
assumes variables were mapped for Columnl in DB Datal. If variables were not mapped, then
another Assign block would be needed to store the value into a variable and the variable is then
specified in the PromptColumnl block.
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Menu Block

The Menu block collects DTMF and/or speech input from the caller. Typically, you use it for directed
input choices (such as selecting to pay bills, get account balances, and so on) so that users are
directed to the correct place in the application to perform their transactions, talk to an operator, or
other options. In case of speech applications, tones can be associated with phrases to allow either
speech or DTMF input from the caller. The phrases and tones are defined in the Menu tab. In case of
user input blocks (Menu, Input, Record, Transfer), Composer adds a global variable of type "Block" to
the variables list. You can conveniently use this variable for accessing the user input value. The
Menu block has the following properties:

Menu Block Exception Events

The Menu block has four local exception events as described in Exception Events.

* error
* error.noresource
* noinput

¢ nomatch

Number of Allowed Retries Exceeded

Assume you need to configure the following use case:
1. User is allowed one invalid entry attempt and one no input attempt. User will then be re-prompted and
given a chance to repeat the attempt.

2. When all allowed attempts are exceeded, the user hears a prompt (something like You have exceeded
the number of possible retries; please call us later when you have correct information. Good bye).

3. At this point, the call should be terminated (or transferred to an agent or some other action taken.
To handle step 2 during application design: In Menu/Input blocks, move exceptions (nomatch,

noinput) to supported events. You can then define the flow path(s) for the case when number of
attempts is exceeded. The callflow below illustrates this configuration:
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Name Property

Please find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Exceptions Property

Find this property's details under Common Properties.

Language Property

The language set by this property overrides any language set by the Set Language block, the Project
preferences, or the incoming call parameters. The property takes effect only for the duration of this
block, and the language setting reverts back to its previous state after the block is done. In the case
of the Menu block, this property affects the language of grammars of TTS output:

1. Click under Value to display a down arrow.

2. Click the down arrow and select English - United States (en-US) or the variable that contains the
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language.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

Menu Mode Property

To assign a value to the Menu Mode property:

1. Select the Menu Mode row in the block's property table.

2. In the Value field, select one of the following from the drop-down list:

DTMF

The DTMF format indicates the menu option mode of input will be via the telephone keypad.

Voice

The Voice format indicates the menu option mode of input will be a voice phrase.

Hybrid

The Hybrid menu mode will handle both DTMF and Voice inputs, that is via telephone keypad and
voice phrase. Note: If you select the Hybrid menu mode, you will have to provide both voice and
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DTMF values for all menu options.

Menu Options Property

Use the Menu Options property to add phrases and/or tones to the VoiceMap. To add, delete, or
arrange menu options:

1. Click the Menu Options row in the block's property table.

2. Click the EZ putton to open the Menu Options dialog box.Available Menu Details fields depend on the
option selected in the Menu Mode property.

For DTMF mode:

* Name*-- Displays the name of the menu option.

¢ DTMF-Option*--Indicates where the option appears on the menu (1 for first option, 2 for second option,
and so on).

Return Value*--Displays the menu option's return value.

e Post Action*--Specify a script (optional).
For Voice mode:

* Name*-- Displays the name of the menu option.

¢ Voice-Option*--Allows input of a voice phrase that will be played for the menu option.

Return Value*--Displays the menu option's return value.

Post Action*--Specify a script (optional).
For Hybrid mode:

* Name*-- Displays the name of the menu option.

DTMF-Option*--Indicates where the option appears on the menu (1 for first option, 2 for second option,
and so on).

e Voice-Option*--Allows input of a voice phrase that will be played for the menu option.

Return Value--Displays the menu option's return value.

e Post Action*--Specify a script (optional).

Menu Options Table

In a new Menu block, four menu options populate the Menu Options table by default. To set or change
one of the existing menu options:

1. Select a menu option in the Menu Options table to enable Menu Options fields.
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2. In the Name* box, change the default name to a more descriptive name.

3. From the DTMF-Option* drop-down list, select a numeric value to indicate the order that this option will
appear in the menu.

4. In the Return Value box, type a return value for this menu option.

5. Composer 8.1.410.14 adds a new POST ACTION column. Click to open Expression Builder where you
can define a script for post-processing. The Post processing script get executed if the configured option/
condition was selected.

Add Button
Use the Add button to add a new menu option.

1. In the Name* box, change the default name to a more descriptive name.

2. From the DTMF-Option* drop-down list, select a numeric value to indicate the order that this option will
appear in the menu.

3. In the Return Value box, type a return value for this menu option.
Up/Down Buttons

Use the Up and Down buttons to reorder your menu option elements. Select the element you want to
reposition, and then click Up or Down, as necessary.

Delete Button
To delete a menu option:

1. Select an entry from the list.

2. Click Delete.

Repeat Menu Option Property

Use for specifying a Repeat DTMF key that will cause the menu to be replayed to the caller, from the
beginning. The generated VXML will use a <reprompt/> when this DTMF is entered by the caller.
Composer's variable support and application root document support allows specifying the same key
across blocks. To enable the re-prompting functionality for both DTMF and ASR, you can connect a
Menu block outport back to the Menu block itself. To specify:

1. Click the Repeat Menu Options row in the block's property table.
2. Click the Ez putton to open the Repeat Menu Options dialog box.
3. Click Add.

4. Name the option.

5

. Click the down arrow and select a number to indicate where the option appears on the menu (1 for first
option, 2 for second option, and so on).
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6. Specify the menu option's return value.

7. Click OK.

Use Utterance to Segment Property

Select true or false. You can use this property for Menu block segmentation based on input
utterance (the raw string of words that were recognized by the platform). If set to false, Menu block
segmentation is based on menu options or return values.

Output Result Property

You must use the Output Result property to assign the collected data to a user-defined variable for
further processing. Note! This property is mandatory. You must select a variable for the output result
even if you do not plan on using the variable. If this is not done, a validation error will be generated in
the Problems view.

1. Select the Output Result row in the block's property table.

2. In the Value field, click the down arrow and select a variable.

For more information, see Upgrading Projects/Diagrams.

Security Property

When the Security property is set to true, data for this block is treated as private. GVP will consider
the data associated with this block as sensitive and will suppress it in platform logs and metrics. To
assign a value to the Security property:

1. Select the Security row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Clear Buffer Property

Use the Clear Buffer property for clearing the DTMF digits in the key-ahead buffer. If it is not set to
true, the DTMF digits entered are carried forward to the next block. It is commonly used for
applications the caller is familiar with. For example, the caller hears a welcome prompt but knows the
next prompt will solicit the caller's input or menu selection. The caller may start inputting with dtmf
while the welcome prompt plays and expect the input to carry forward. To assign a value to the Clear
Buffer property:

1. Select the Clear Buffer row in the block's property table.
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2. In the Value field, select true or false from the drop-down list.

Interruptible Property

This property specifies whether the caller can interrupt the prompt before it has finished playing. To
assign a value to the Interruptible property:

1. Select the Interruptible row in the block's property table.

2. In the Value field, select true,false,or DTMF (for DTMF barge-in mode support) from the drop-down list.

Prompts Property

Find this property's details under Common Properties. Note: When Type is set to Value and Interpret-
As is set to Audio, you can specify an HTTP or RTSP URL. When Type is set to Variable and Interpret-
As is set to Audio, you can specify a variable that contains an HTTP or RTSP URL. Starting with
8.1.410.14, validation displays a warning message if a resource file does not exist.

Timeout Property

The Timeout property defines the length of the pause between when the voice application plays the
last data in the list, and when it moves to the next block. To provide a timeout value:

1. Select the Timeout row in the block's property table.

2. In the Value field, type a timeout value, in seconds.

Get Shadow Variables Property

Shadow variables (optional) provide a way to retrieve further information regarding the value of an
input item. By setting this property to true, it will expose the block’s shadow variable within the
callflow. When enabled, the shadow variable will be included in the list of available variables. (For
example, the Log block’s Logging Details will show Menul$.) A shadow variable is referenced as
blockname$.shadowVariable, where blockname is the value of the input item's name attribute, and
shadowVariable is the name of a specific shadow variable, for example: Menul$.duration. Shadow
variables can provide platform-related information about the interaction/input. For example, for
speech recognition, this may be the confidence level the platform receives from the ASR engine
about how closely the engine could match the user utterance to specified grammar. To assign a value
to the Get Shadow Variables property:

1. Select the Get Shadow Variables row in the block's property table.

2. In the Value field, select true or false from the drop-down list.
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Number of Allowed Attempts Exceeded Property

Determines how many opportunities the user will be provided to re-enter the value. If Use Last
Prompt Indefinitely is set to true, this property has no effect; otherwise, the
error.com.genesyslab.composer.toomanynomatches or
error.com.genesyslab.composer.toomanynoinputs errors will be raised on reaching the maximum
retry limit. To provide a value for the number of retries allowed:

1. Select the Number Of Retries Allowed row in the block's property table.

2. In the Value field, type a value for the number of retries that will be allowed.

Retry Prompts Property

Find this property's details under Common Properties.

Use Last Reprompt Indefinitely Property

If you set the Use Last Reprompt Indefinitely property to true, the application uses your last reprompt
as the prompt for all further retries. Therefore, the exception handlers that come out for nomatch and
noinput are redundant--even if you set the default exceptions that come out as red dots on the left-
side of the block. To assign a value to the Use Last Reprompt Indefinitely property:

1. Select the Use Last Reprompt Indefinitely row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Use Original Prompts Property

If you set the Use Original Prompts property to true, in the event of an error requiring a retry, the
application first plays back the retry error prompt, and then plays back the original prompt for the
block (as specified in the Prompts property). To assign a value to the Use Original Prompts property:

1. Select the Use Original Prompts row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Use Single Counter For Nomatch And Noinput Property

If you set the Use Single Counter For Nomatch And Noinput property to true, the application
maintains a single combined counter for the nomatch and noinput errors. For example, if the block
has three nomatch retry messages and three noinput retry messages, the user gets three retry
attempts. If you do not select this option, the application generates a total of six retries; and the user
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gets up to six retry attempts while not exceeding three of each type -- noinput or nomatch. Note: This
property not available on the Record block. To assign a value to the Use Single Counter For Nomatch
And Noinput property:

1. Select the Use Single Counter For Nomatch And Noinput row in the block's property table.

2. In the Value field, select true or false from the drop-down list.
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Prompt Block

Use the Prompt block to play specific data to the caller. The Prompt block has no page exceptions.
The Prompt block has the following properties:

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Language Property

The language set by this property overrides any language set by the Set Language block, the Project
preferences, or the incoming call parameters. The property takes effect only for the duration of this
block, and the language setting reverts back to its previous state after the block is done. In the case
of the Prompt block, this property affects the language of grammars of TTS output:

1. Click under Value to display a down arrow.

2. Click the down arrow and select English - United States (en-US) or the variable that contains the
language.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.
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Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

Clear Buffer Property

Use the Clear Buffer property for clearing the DTMF digits in the key-ahead buffer. If it is not set to
true, the DTMF digits entered are carried forward to the next block. It is commonly used for
applications the caller is familiar with. For example, the caller hears a welcome prompt but knows the
next prompt will solicit the caller's input or menu selection. The caller may start inputting with dtmf
while the welcome prompt plays and expect the input to carry forward. To assign a value to the Clear
Buffer property:

1. Select the Clear Buffer row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Immediate Playback Property

Important! See Note in Timeout section below.

* When Immediate Playback is set to true, prompts are played immediately on the execution of the
prompt without queuing them.

* When Immediate Playback is set to false (default), the interpreter goes to the transitioning state and
queues the TTS Prompt until the interpreter waits for an input (such as the Menu, Input, Record,and
Transfer blocks.

To assign a value to the Immediate Playback property:

1. Select the Immediate Playback row in the block's property table.

2. In the Value field, select true or false from the drop-down list. Selecting false will causes prompts only
to be played when waiting for input. Set to false if you want prompts to be played consistent with the
VXML default behavior as described below. Otherwise select true to have Composer force immediate
playback.
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VXML Behavior and Queueing of Prompts

A prompt gets played only when the platform is waiting for input. As described in Voice Extensible
Markup Language (VoiceXML) Version 2.0, section 4.1.8, a VoiceXML interpreter is at all times in one
of two states:

e waiting for input in an input item (such as <field>, <record>, or <transfer>), or

e transitioning between input items in response to an input (including spoken utterances, dtmf key
presses, and input-related events such as a noinput or nomatch event) received while in the waiting
state. While in the transitioning state no speech input is collected, accepted or interpreted...

The waiting and transitioning states are related to the phases of the Form Interpretation Algorithm as
follows:

* the waiting state is eventually entered in the collect phase of an input item (at the point at which the
interpreter waits for input), and

¢ the transitioning state encompasses the process and select phases, the collect phase for control items
(such as <block>s), and the collect phase for input items up until the point at which the interpreter
waits for input.

An important consequence of this model is that the VoiceXML application designer can rely on all
executable content (such as the content of <filled> and <block> elements) being run to completion,
because it is executed while in the transitioning state, which may not be interrupted by input. While
in the transitioning state, various prompts are queued, either by the <prompt> element in
executable content or by the <prompt> element in form items. In addition, audio may be queued by
the fetchaudio attribute. The queued prompts and audio are played either

¢ when the interpreter reaches the waiting state, at which point the prompts are played and the
interpreter listens for input that matches one of the active grammars, or

* when the interpreter begins fetching a resource (such as a document) for which fetchaudio was
specified. In this case the prompts queued before the fetchaudio are played to completion, and then, if
the resource actually needs to be fetched (i.e. it is not unexpired in the cache), the fetchaudio is played
until the fetch completes. The interpreter remains in the transitioning state and no input is accepted
during the fetch.

Interruptible Property

This property specifies whether the caller can interrupt the prompt before it has finished playing. To
assign a value to the Interruptible property:

1. Select the Interruptible row in the block's property table.

2. In the Value field, select true,false,or DTMF (for DTMF barge-in mode support) from the drop-down list.

Note: For Prompts to be interruptible, there must be a an Input block (Menu, Input, etc.) in the
execution path. If there are no such blocks further down in the execution path, the Interruptible
property has no effect. If a Backend or Subdialog block has to be used after the Prompt block, insert
an Input block before the Backend or Subdialog block for the prompt to be uninterruptible.
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Prompts Property

Find this property's details under Common Properties. Note: When Type is set to Value and Interpret-
As is set to Audio, you can specify an HTTP or RTSP URL. When Type is set to Variable and Interpret-
As is set to Audio, you can specify a variable that contains an HTTP or RTSP URL. Starting with
8.1.410.14, validation displays a warning message if a resource file does not exist.

Timeout Property

The Timeout property defines the length of the pause between when the voice application plays the
last data in the list, and when it moves to the next block. To provide a timeout value:

1. Select the Timeout row in the block's property table.

2. In the Value field, type a timeout value, in seconds.
Note: Composer does not honor the Timeout setting if you keep the Immediate Playback default

setting (=false); for example, where sequential prompts are used. In order for Composer to honor the
timeout, you must set Immediate Playback to true.
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Raise Event Block

Use the Raise Event block for Composer to throw custom events. You specify the event name and a
message, which is selection of a dynamic variable. It is a terminating block (can end an application
instead of an Exit block). Orchestration Server 8.1.2+ versions are required for Raise and Cancel
Event blocks.

Also see CustomEvents.

The Raise Event block has the following properties:

¢ The Raise Event block has no page exceptions.

Name Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Block Notes Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Delay Property

Enter the timeout or select a variable. Maps to <send delay>.

Unit Property

Select seconds or milliseconds for the delay. Maps to <send delay>.

Condition Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.
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Logging Details Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks or Common Properties for
Workflow Blocks.

Event Property

Select the variable or enter a value. Maps to <send event>.

Parameters Property

Add a list of key-values. Maps to <param>.

EFnable Status

This property controls whether or not a block contributes code to the application. You may wish to
use this property if there is a need to temporarily remove a block during debugging or, for other
reasons during development, temporarily disable a block. This saves the effort of having to remove
the block and then add it back later.

ORS Extensions Property

Starting with 8.1.4, Composer blocks used to build routing applications (with the exception of the
Disconnect and EndParallel blocks) add a new ORS Extensions property.
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Record Block

The Record block records voice input from the caller. Also see Number of Allowed Attempts Exceeded
Property. In case of user input blocks (Menu, Input, Record, Transfer), Composer adds a global
variable of type "Block" to the variables list. You can conveniently use this variable for accessing the
user input value. The Record block has the following properties: Record Block Exception Events The
Record block has four exception events as described in Exception Event Descriptions:

error
error.badfetch
noinput]] (supported by default)

error.com.genesyslab.composer.recordCapture.failure

Name Property

Please find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Exceptions Property

Find this property's details under Common Properties.

Language Property

The language set by this property overrides any language set by the Set Language block, the Project
preferences, or the incoming call parameters. The property takes effect only for the duration of this
block, and the language setting reverts back to its previous state after the block is done. In the case

of the Record block, this property affects the language of grammars of TTS output:

1.

Click under Value to display a down arrow.

2. Click the down arrow and select English - United States (en-US) or the variable that contains the

language.
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Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

Output Result Property

You must use the Output Result property to assign the collected data to a user-defined variable for
further processing. Note! This property is mandatory. You must select a variable for the output result
even if you do not plan on using the variable. If this is not done, a validation error will be generated in
the Problems view.

1. Select the Output Result row in the block's property table.

2. In the Value field, click the down arrow and select a variable.

For more information, see Upgrading Projects/Diagrams.

Web Server Record File Name Property

User-defined variable (to be assigned) containing the file name of the recorded file located in the
folder as specified in the Capture Location property.

1. Select the Web Server Record File Name row in the block's property table.

2. In the Value field, click the down arrow and select a variable.
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Prompts Property

Find this property's details under Common Properties. Note: When Type is set to Value and Interpret-
As is set to Audio, you can specify an HTTP or RTSP URL. When Type is set to Variable and Interpret-
As is set to Audio, you can specify a variable that contains an HTTP or RTSP URL. Starting with
8.1.410.14, validation displays a warning message if a resource file does not exist.

Timeout Property

The Timeout property defines the length of the pause between when the voice application plays the
last data in the list, and when it moves to the next block. To provide a timeout value:

1. Select the Timeout row in the block's property table.

2. In the Value field, type a timeout value, in seconds.

Audio Format Property

This property specifies the audio format for the recording.

1. Select the Audio Format row in the block's property table.

2. In the Value field, select a format value from the drop-down list.

You can modify this value in order to specify enhanced format information such as the codec and the
rate as in the following: audio/x-wav;codec=g726;rate=<rate>

Note: You can specify a bit rate as shown in the above example only for the g726 codec.

Beep Before Recording Property

The Beep Before Recording property indicates whether a beep sound will be played for the caller just
before recording begins. When set to true, a beep sound will be played; when set to false, no beep
will be played. To assign a value to the Beep Before Recording property:

1. Select the Beep Before Recording row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Dtmf Term Character Property

The Dtmf Term Character property defines any character that callers can input in order to indicate
that they have finished entering data. For example, the prompt given to the caller may say "Enter
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your account number, and then press the pound key." The pound key is the Dtmf-ending character. To
provide a value for the Dtmf Term Character:

1. Select the Dtmf Term Character row in the block's property table.

2. In the Value field, type a value for a character to represent the end of the Dtmf string.
A typical value that is often used, as indicated above, is: # If several different DTMF tones could be
used to indicate the end of data entry, type all values for the supported tones. No separation signs or
characters are required. Examples:

e To use # or * then type the value as #*

e If any numeric key could be used for termination, type the value as 1234567890*#

Final Silence Property

The value supplied for the Final Silence property indicates the amount of silence (in seconds) that is
allowed to elapse before recording will be stopped. The default value is 3 seconds. To provide a value
for the Final Silence property:

1. Select the Final Silence row in the block's property table.

2. In the Value field, type a value for the allowable final silence before recording is stopped.

Max Duration Property

In the context of a Record block, the Max Duration property specifies the maximum recording
duration. The default is 60 seconds.

To provide a value for the maximum recording duration:

1. Select the Max Duration row in the block's property table.

2. In the Value field, type a value for the maximum recording duration.

For more information on this property, refer to the Record VXML tag topic in GVP 8.1 Voice XML Help.

Min Duration Property

In the context of a Record block, the Min Duration property specifies the minimum allowed recording
duration. The default is 1 second. To provide a value for the minimum recording duration:

1. Select the Min Duration row in the block's property table.

2. In the Value field, type a value for the minimum recording duration.
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Capture Filename Property

A value for the Capture Filename property is required when the Capture Filename Type property is set
to the value useSpecified. To provide a filename for the captured recording:
1. Select the Capture Filename row in the block's property table.

2. In the Value field, you can:

e Type a name for the recording file.

¢ Click the down arrow and select a variable.

Capture Filename Prefix Property

A value for the Capture Filename Prefix property is required when the Capture Filename Type property
is set to the value usePrefix. To provide a prefix for the captured recording filename:
1. Select the Capture Filename Prefix row in the block's property table.
2. In the Value field, you can:
e Type a value for the recording file prefix.

¢ Click the down arrow and select a variable.

Capture Filename Type Property

The Capture Filename Type property indicates the type of the filename for saving the recording. To
assign a value to the Capture Filename Type property:
1. Select the Capture Filename Type row in the block's property table.

2. In the Value field, select one of the following from the drop-down list:

e auto-generate a recording filename.

* usePrefix' to add the prefix value specified in the Capture Filename Prefix property to the default name
that is generated for the recording.

* useSpecified to use the value specified in the Capture Filename property as the filename for the
recording. In this case, the file will be overwritten for each call.

Capture Location Property

The Capture Location property specifies the destination path on the Web Application server where the
recording is to be saved.
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If no location is specified, the recordings are saved in the working directory the web application
server process. This location may change depending on the web server environment, and therefore,
it is recommended that a fixed location is always specified in the Capture Location property. To
specify a capture (recording) location:

1. Click the Capture Location row in the block's property table.

2. Type a file path where the recording is to be saved that is located on the web server hosting the
application. If the web server is running on Linux, a UNIX-style path can be entered. Composer will not
validate the path.

Security Property

When the Security property is set to true, data for this block is treated as private. GVP will consider
the data associated with this block as sensitive and will suppress it in platform logs and metrics. To
assign a value to the Security property:

1. Select the Security row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Use Last Reprompt Indefinitely Property

If you set the Use Last Reprompt Indefinitely property to true, the application uses your last reprompt
as the prompt for all further retries. Therefore, the exception handlers that come out for nomatch and
noinput are redundant--even if you set the default exceptions that come out as red dots on the left-
side of the block. To assign a value to the Use Last Reprompt Indefinitely property:

1. Select the Use Last Reprompt Indefinitely row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Get Shadow Variables Property

Shadow variables (optional) provide a way to retrieve further information regarding the value of an
input item. They can provide platform-related information about the interaction/input. For example,
for speech recognition, this may be the confidence level the platform receives from the ASR engine
about how closely the engine could match the user utterance to specified grammar. By setting this
property to true, it will expose the block’s shadow variable within the callflow. When enabled, the
shadow variable will be included in the list of available variables. (For example, the Log block’s
Logging Details will show Record1$.) A shadow variable is referenced as blockname$.shadowVariable,
where blockname is the value of the input item's name attribute, and shadowVariable is the name of
a specific shadow variable, for example: Record1$.duration. To assign a value to the Get Shadow
Variables property:

1. Select the Get Shadow Variables row in the block's property table.
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2. In the Value field, select true or false from the drop-down list.

Number of Retries Allowed Property

The Number Of Retries Allowed property determines how many opportunities the user will be
provided to re-enter the value. If Use Last Prompt Indefinitely is set to true, this property has no
effect; otherwise, the error.com.genesyslab.composer.toomanynomatches or
error.com.genesyslab.composer.toomanynoinputs errors will be raised on reaching the maximum
retry limit. To provide a value for the number of retries allowed:

1. Select the Number Of Retries Allowed row in the block's property table.

2. In the Value field, type a value for the number of retries that will be allowed.

Retry Prompts Property

Find this property's details under Common Properties. Starting with 8.1.410.14, validation displays a
warning message if a resource file does not exist.

Use Original Prompts Property

If you set the Use Original Prompts property to true, in the event of an error requiring a retry, the

application first plays back the retry error prompt, and then plays back the original prompt for the

block (as specified in the Prompts property). To assign a value to the Use Original Prompts property:
1. Select the Use Original Prompts row in the block's property table.

2. In the Value field, select true or false from the drop-down list.
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Release ASR Engine Block

Use the Release ASR Engine block to control when the ASR engine(s) being used in the current
session will be released. The Release ASR Engine block has the following properties: The Release ASR
Engine block has no page exceptions.

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Engine Name Property

The optional Engine Name property specifies the name(s) of the ASR engine(s) to release. If no
engine is specified, all open ASR engines will be released. To specify an ASR engine to release:

1. Select the Engine Name row in the block's property table.

2. In the Value field, type the name of the ASR engine to release.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.
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Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.
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Script Block

Script block is used to write custom ECMAScript code and VoiceXML code. The Script block has the
following properties:

Name Property

Click under Value and enter the block name. Composer will use the name to identify the block in the
diagram and as the state name in the code.

Block Notes Property

Find this property's details under Common Properties.

Exceptions Property

Use to configure the exception nodes, with each port being hooked up to an event configured by you
and selectable using Add Custom Event. Find this property's details under Common Properties.

Condition Property

Find this property's details under Common Properties.

Logging Details Property

Find this property's details under Common Properties.

Log Level Property

Find this property's details under Common Properties.
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Enable Status Property

Find this property's details under Common Properties.

Script Property

Click under Value to open ExpressionBuilder where you can enter the code.

e — o 55 ]

9 Expression Builder

Expression Builder

Build an expression in the Expression field by selecting the operator(s) and data
element(s) from the categories and subcategories below.
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Set Language Block

The Set Language block changes the current active language from that set in the Entry block or a
previous Set Language block. The language specified will be used for all subsequent prompts and
grammars. This updates the APP LANGUAGE and APP ASR LANGUAGE global variables to the
specified values. All audio and grammar resources will get picked from the specified language folder
under the Resource folder of the Composer Project. Set Language is only applicable for audio and
grammar files in Composer. Note: Locales that are not defined in Composer must be manually set in
the diagram’s Assign block. Example: ASR LANGUAGE="te-IN" Also see topic Developing Multi-Lingual
Applications. The Set Language block has the following properties: The Set Language block has no
page exceptions.

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Language
To set the active language for prompts and grammars:

1. Select the Language row in the block's property table.

2. In the Value field, select one of the following:

e Alanguage from the list of locales defined in the Project settings.

e A variable that contains the active language.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.
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Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.
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SNMP Block

Use the SNMP block to send SNMP traps from the application. This uses the NGI ‘dest’ extension
attribute of the <log> tag. All application-generated SNMP traps are mapped to a single TrapID as
defined by the MCP. The EnableSNMP voice application variable is a flag to turn SNMP traps on or off
from the SNMP block. The SNMP block has the following properties: The SNMP block has no page
exceptions.

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.
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Message Property

The Message property uses a dynamic variable as the message for the SNMP trap. To assign a
variable as an SNMP trap:

1. Select the Message row in the block's property table.

2. In the Value field, enter the name of the variable containing the message for the SNMP trap.
The SNMP block will append the following information to the log message:

¢ session-id

¢ block name

The format will be : <session-id>::<block-name>::<log message>
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Start FCR Block

Use the Start FCR (Start Full Call Recording) block to indicate the start of a recorded audio file. You
specify the audio format of the recorded file, which is saved in the MCP folder specified in the Capture
Location property. Once recording has started, all interactions will be recorded the End FCR block is
reached or the call is terminated Notes:

e Starting and stopping at tapped points (as marked by the Start FCR block and either EndFCR block or
the end of call) depends on the Prompt Queuing feature. For this reason, all Prompts between Start FCR
and End FCR should have their Imnmediate Playback property set to true.

e The enableFCR system variable in the Entry block must be set to true in order to use this block.

The Start FCR block has the following properties: The Start FCR block has no page exceptions.

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Audio Format Property

This property specifies the audio format for the recording.

1. Select the Audio Format row in the block's property table.

2. In the Value field, select an audio format value from the drop-down list.
The following audio formats are currently supported:

* audio/vox

* audio/basic

* audio/x-alaw-basic
e audio/x-g726-24
* audio/x-g726

* audio/x-adpcm
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* audio/adpcm

e audio/x-adpcm8

* audio/x-g726-40

e audio/L8

* audio/L16

* audio/x-wav

* audio/wav

* audio/x-wav;codec=ulaw
* audio/wav;codec=ulaw
* audio/x-wav;codec=alaw
* audio/wav;codec=alaw

* audio/x-vox

¢ audio/x-wav;codec=pcm
e audio/wav;codec=pcm

¢ audio/x-wav;codec=pcm1l6
e audio/wav;codec=pcm1l6
e audio/x-wav;codec=g726
e audio/wav;codec=g726
* audio/x-gsm

e audio/x-g729

You can modify this value in order to specify enhanced format information such as the codec and the
rate as in the following: audio/x-wav;codec=g729;rate=<rate>

Capture Location Property

The Capture Location property specifies the location for the FCR files on MCP. The default value is
.\callrec, but this value can be changed. To specify a capture (recording) location for the FCR files:

1. Click the Capture Location row in the block's property table.
2. Select the Value field and type a directory path, or keep the default ..\callrec path.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.
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Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.
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Subdialog Block

Use the Subdialog block for invoking VoiceXML subdialogs, which are a mechanism for reusing
common dialogs and building libraries of reusable applications. Subcallflows called from a main
callflow encapsulate VXML subdialogs and provide modularization for large VXML applications. An
application can specify the URI of the subdialog to be invoked, pass parameters, and receive output
results. Parameters of type In, Out and InOut are supported. You have the option to select how the
parameters are to be passed to the invoked subdialog. In the case of Dynamic pages (like JSPs) you
can specify the method for sending Get / Post and Use Namelist to indicate the parameters are to be
passed as Query String values.

These two choices do not apply in the case of static subdialogs (such as those generated by
Composer Voice). The Subdialog block also has the ability to invoke subcallflows created by
Composer Voice. In this case, auto-synchronization of input and output parameters is provided. A
developer will be able to select a subcallflow to invoke from the current Composer Project.

Also see Using Composer Shared Subroutines.

Starting with Composer 8.1.3 versions, the callflow diagram Subdialog block and the
workflow diagram Subroutine block use absolute paths with the Project name to refer
to the location of the selected resource in the Workspace, e.g., workspace: ///WFM/
Workflows/subroutine.workflow. Renaming or copying Projects requires a manual
update to change the Project name in the Subroutine and Subdialog blocks.

The Subdialog block has the following properties:

The Subdialog block has no page exceptions.

Name Property

Please find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.
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Exceptions Property

Find this property's details under Common Properties.

Method Property

This property Indicates the method for invoking the subdialog:

¢ get--Invoked using HTTP Get

e post--Invoked using HTTP Post. This option is valid only when the parameters are passed as a namelist
(Use Namelist property is set to true). This is generally used when a large amount of data needs to be

sent as an input value for a subdialog.
To select a value for the Method property:

1. Select the Method row in the block's property table.

2. In the Value field, select get or post from the drop-down list.

Type Property

The Type property sets the type of the invoked subdialog. There are two options:

¢ URL--The invoked subdialog can be found at the location specified in the Uri property.

e ProjectFile--The invoked subdialog is a subcallflow in the Composer Project.

To select a value for the Type property:

1. Select the Type row in the block's property table.

2. In the Value field, select URL or ProjectFile from the drop-down list.

Uri Property

The Uri property specifies the destination (URL or Composer Project) depending on the value of the
Type property. To set a URL destination for the Uri property (Type property is set to URL):

1. Select the Uri row in the block's property table.

2. In the Value field, type a valid URL, or select a variable from the drop-down list.

To set a Composer Project destination for the Uri property (Type property is set to ProjectFile):

1. Click the Uri row in the block's property table.

Composer Help 341


https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks
https://docs.genesys.com/Documentation/IW/8.1.4/Help/EntryBlock#Variables_Property

Voice Blocks Basic

2. Click the Bz putton to open the Uri dialog box.
3. Select a callflow in the list.

4. Click OK to close the dialog box.

Composer automatically synchronizes the Input and return variables of the selected sub-callflow with
the main callflow by adding them as Input/Output parameters in the corresponding Subdialog Block.
Open the Parameters Property of the Subdialog Block to assign the desired value. Note: For a
selected studio diagram file, right-click the block's context menu and select the Open Sub Callflow
Diagram option to open the chosen Subcallflow diagram file in the Workbench window.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

Security Property

When the Security property is set to true, data for this block is treated as private (for example, credit
card account numbers, Social Security numbers, date of birth information, and so on). GVP will
consider the data associated with this block as sensitive and will suppress it in platform logs and
metrics. To assign a value to the Security property:

1. Select the Security row in the block's property table.

2. In the Value field, select true or false from the drop-down list.
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Parameters Property

Use the Parameters property to specify parameters to pass to the invoked subdialog. To specify
parameters:

1. Click the Parameters row in the block's property table.

2. Click the Bz putton to open the Parameter Setting dialog box.

If the Type Property is ProjectFile,all the Input/Output parameters are automatically synchronized
between the sub-callflow and the main callflow. The Input/Output parameters are automatically
added based on the sub-callflow Input/Output parameters. In this case, there are no Add and Delete
buttons in the Parameter Setting dialog box as described below. You must fill in the Variables column.

Add Button

Use the Add button to enter parameter details.

1. Click Add to add an entry to SubDialog Parameters.
2. In the Parameter Name field, accept the default name or change it.

3. From the Parameter Type drop-down list, select In, Out, or InOut:

In Input parameters are variables submitted to the

subdialog.
Output parameters are variables that the subdialog
Out returns and will be reassigned back to the current
callflow.
Inout InOut parameters are parameters that act as both

input and output.

1. In the Expression drop-down list, select from among the variables shown, type your own expression, or
click the EZ& button to use Expression Builder.

2. In the Definition field, type a description for this parameter.

3. Click Add again to enter another parameter, or click OK to finish.

Delete Button

To delete a parameter:

1. Select an entry from the list.

2. Click Delete.
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Use Namelist

Indicates whether the subdialog parameters need to submitted as a namelist (if set to true) to the
called subdialog. To select a value for the Use Namelist property:

1. Select the Use Namelist row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Fetch Audio Property

Enter the fetchaudio file to play when executing a long-running tasks, such as a server side web
query. By default, Next Generation Interpreter NGl)supplies a built-in fetchaudio file. For information
on GVP support of fetchaudio, see:

¢ Fetching Properties in GVP Voice XML Help.
* The VoiceXML Properties section of the GVP 8.1 Legacy Genesys VoiceXML 2.1 Reference Manual.
¢ The Prompt block,VXML Behavior and Queueing of Prompts.

Fetch Audio Delay Property

Enter the length of time to wait at the start of a fetch delay before playing fetchaudio. For more
information, see Fetching Properties in GVP Voice XML Help

Fetch Audio Minimum Property

Enter the minimum length of time to play fetchaudio, once started, even if the fetch result arrives in
the meantime. For more information, see Fetching Properties in GVP Voice XML Help

Fetch Hint Property

Select prefetch or safe to define when XML data files can be fetched. Selecting safe indicates to only
load the XML data file when needed. For more information, see Fetching Properties in GVP Voice XML
Help.

Fetch Timeout Property

Enter the timeout for fetches. This is not supported when using Nuance (MRCP). An error.badfetch is
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thrown when a fetch duration exceeds fetchtimeout. For more information, see Fetching Properties in
GVP Voice XML Help.

Max Age Property

Enter the maximum acceptable age, in seconds, of cached audio resources. For more information,
see Fetching Properties in GVP Voice XML Help.

Max Stale Property

Enter the maximum staleness, in seconds, of expired cached audio resources.For more information,
see Fetching Properties in GVP Voice XML Help.
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Transfer Block

Use the Transfer block to transfer the call to another destination. By default, blind transfer is enabled,
and it has no outports. However, if you enable bridging, the block will have one or more outports. In
case of user input blocks (Menu, Input, Record, Transfer), Composer adds a global variable of type
"Block" to the variables list. You can conveniently use this variable for accessing the user input value.

Use the Transfer block for non-CTI VXML transfers and Route Request block for CTI transfers.

The Transfer block has the following properties:

Transfer Block Exception Events

The Transfer block has the following exception events as described in Exception Event Descriptions:

connection.disconect.hangup
connection.disconnect.transfer (supported by default)
error (supported by default)
error.connection.baddestination (supported by default)
error.connection.noauthorization
error.connection.noresource

error.connection.noroute

error.connection

error.unsupported.transfer.blind
error.unsupported.transfer.consultation

error.unsupported.uri

Name Property

Please find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.
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Exceptions Property

Find this property's details under Common Properties.

Language Property

The language set by this property overrides any language set by the Set Language block, the Project
preferences, or the incoming call parameters. The property takes effect only for the duration of this
block, and the language setting reverts back to its previous state after the block is done. In the case
of the Transfer block, this property affects the language of grammars used for ASR input:

1. Click under Value to display a down arrow.

2. Click the down arrow and select English - United States (en-US) or the variable that contains the
language.

Condition Property

Find this property's details under Common Properties for Callflow Blocks.

Logging Details Property

Find this property's details under Common Properties for Callflow Blocks.

Log Level Property

Find this property's details under Common Properties for Callflow Blocks.

Enable Status Property

Find this property's details under Common Properties for Callflow Blocks.

Output Result Property

You must use the Output Result property to assign the collected data to a user-defined variable for
further processing. Note: This property is mandatory. You must select a variable for the output result
even if you do not plan on using the variable. If this is not done, a validation error will be generated in
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the Problems view.

1. Select the Output Result row in the block's property table.

2. In the Value field, click the down arrow and select a variable.

For more information, see Upgrading Projects/Diagrams.

Transfer Audio Property

The optional Transfer Audio property plays a prompt to the end user while the number is being dialed
out. You provide the URI of the audio source to play while the transfer attempt is in progress (before
the other end answers). If the callee answers, the interpreter terminates playback of the recorded
audio immediately. If the end of the audio file is reached and the callee has not yet answered, the
interpreter plays the audio tones from the far end of the call (ringing, busy). If the resource cannot be
fetched, the error is ignored and the transfer continues. To provide a Transfer Audio value:

1. Select the Transfer Audio row in the block's property table.

2. In the Value field, type a Transfer Audio value URI (HTTP or RTSP) specifying the location of the audio
file to play.

Aail Property

Use the optional Application-to-Application Information (the Aai property) for the data that is to be
transferred from the current application to another application. Use this option to transfer the call to
a number that initiates another voice application. To assign a value to the Aai property:

1. Select the Aai row in the block's property table.

2. In the Value field, select a value from the drop-down list.

Values are the Voice Application Variables described under the Variables Property.

Authorization Code Property

GVP supports dialing of an authorization code as part of an outbound call on a two-leg transfer. Use
free form text to specify the authorization code in the application.

Connect Timeout Property

Use the Connect Timeout property for the connection timeout value. The default is 15 seconds. For
information on what happens if a timeout occurs, select Help > Contents and see the GVP 8.1Voice
XML 2.1 Reference Help'. Specifically see Standard VoiceXML > Variables > Transfer, attribute
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connecttimeout. To provide a timeout value:

1. Select the Connect Timeout row in the block's property table.

2. In the Value field, type a timeout value, in seconds.

Connect When Property

This property controls when the call is connected to the end point. To assign a value:

1. Select the Connect When row in the block's property table.

2. In the Value field, select answered or immediate from the drop-down list.

Destination Property

The Destination property contains the destination phone number. The destination number can be one
of the following:

e A Virtual Route point number on which the IRD Strategy is loaded

e Extension number of an Agent

e External number

The value must be specified in one of the formats below:

e sip:[user@]host[:port]
¢ tel:phonenumber e.g., tel:+358-555-1234567

For information on this property, select Help > Contents and see the GVP 8.1 Voice XML 2.1
Reference Help. Specifically see Standard VoiceXML > Variables > Transfer, attribute dest. To
assign a value to the Destination property:

1. Select the Destination row in the block's property table.

2. In the Value field, select a value from the drop-down list.

Values are the Voice Application Variables described under the Variables Property.

Max Call Duration Property

Use the Max Call Duration property for the maximum call duration. The default is 3600 seconds. (This
is not supported for Consultation Transfer Type.) Note: If this is set to 0 (zero), an infinite value is
supplied, and there is no upper limit to the call duration. To provide a value for the maximum call
duration:
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1. Select the Max Call Duration row in the block's property table.

2. In the Value field, type a value for the maximum call duration.

Transfer Type Property

Specifies the type of the Transfer, which determines whether or not the caller’s session with the
VoiceXML interpeter resumes after the call initiated by the transfer ends. Note: Composer also
supports AT&T blind transfers with the following options: Out of Band Courtesy, Out of Band Consult,
and Out of Band Conference. For more information on these options, start with the GVP 8.1 Voice XML
Reference Help (Help > Contents). Search for ATTOOBCOURTESY, ATTOOBCONSULT, and
ATTOOBCONFERENCE (Transfer topic). Also see the Genesys Voice Platform 8.1 Deployment Guide.
To assign a value to the Transfer Type property:

1. Select the Transfer Type row in the block's property table.

2. In the Value field, select one of the following from the drop-down list:

Blind is the default setting. The platform redirects the caller to the agent without remaining in the
connection, and it does not monitor the outcome. Once the caller is handed off to the network, the
caller's session with the VoiceXML application cannot be resumed. The VoiceXML interpeter throws a
connection.disconnect.transfer immediately, regardless of whether the transfer was successful or not.

Bridge causes the platform add the agent to the connection. Document interpretation suspends until
the transferred call terminates. The platform remains in the connection for the duration of the
transferred call; listening during transfer is controlled by any included <grammar>s.If the caller
disconnects by going onhook or if the network disconnects the caller, the platform throws a
connection.disconnect.hangup event. If the agent disconnects, then transfer outcome is set to
near_end_disconnect and the original caller resumes her session with the VoiceXML application.

Consultation causes the consultation transfer to be similar to a blind transfer except that the
outcome of the transfer call setup is known and the caller is not dropped as a result of an
unsuccessful transfer attempt. When performing a consultation transfer, the platform monitors the
progress of the transfer until the connection is established between caller and agent. If the
connection cannot be established (e.g. no answer, line busy, etc.), the session remains active and
returns control to the application. As in the case of a blind transfer, if the connection is established,
the interpreter disconnects from the session, connection.disconnect.transfer is thrown, and document
interpretation continues normally. Any connection between the caller and the agent remains in place
regardless of document execution. Note: The selected transfer type will work only if the platform is
provisioned to support that type of transfer.

Variables Property

The Transfer block Variables property is for Transfer signaling (gvp:signalvar)
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variable configuration and not for user data. To send user data in the transfer
<gvp:transfer> request use the Route Request block.

This is the list of variables that can be optionally sent by the application as part of the Transfer
Request to the far end. It corresponds to the signalvars extension attribute of the NGI VXML
Interpreter. Check the Genesys Voice VXML 2.1 Reference Manual for more details.

All variables that are selected (checked) will be sent as part of the signalvars . The name of the
variable will be used as the key name and the actual value will be the corresponding value. Refer to
the GVP Documentation for details on the signalvars attribute. The variable name must match the
name of the key that will be sent as signalvars.

To declare session variables for the application or subcallflow:

Click the Variables row in the block's property table.

Click the ... button to open a Variables dialog box.

1.

2.

3. Click Add and enter key-value pairs.
4. Click Value is an integer if application.
5.

You can also click Remove or Removal All.

The steps below are valid up to 8.1.430.01. After that, the Variables dialog box
supports the key-value pairs.

To declare session variables for the application or subcallflow:

Click the Variables row in the block's property table.
Click the ... button to open a Variables dialog box,
Select individual variables.

You can also click Select All or Deselect All.

Click OK.

v ok W N

Method Property

The Method property specifies the type of SIP transfer method that the Media Control Platform (MCP)
uses. To assign a value to the Method property:

1. Select the Method row in the block's property table.

2. In the Value field, select one of the following from the drop-down list (descriptions below):
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Bridge
A Bridge method indicates that the Media Control Platform (MCP) bridges the media path.

1. The platform sends an INVITE request to the callee, and a dialog is established between the callee and
the platform.

2. The transfer fails if a non-2xx final response is received for the INVITE request.

This is a two-leg transfer (in other words, it occupies two channels on the platform). The platform
stays in the signaling path and is responsible for bridging the two call legs.

Hkf (Hookflash)

A Hookflash method indicates a transfer using DTMF digits (RFC 2833).

1. The Media Control Platform (MCP) sends DTMF digits on the media channel. The platform leaves it to the
media gateway or switch to perform the transfer on the network.

2. Configurable options enable you to specify whether the call will be disconnected by the platform or by
the remote end. Otherwise, the call is disconnected after a configured timeout.

This is a one-leg transfer (in other words, it occupies only one channel on the platform).

Refer

A Refer method indicates that the transfer is based on a SIP REFER message (RFC 3515).
1. The platform sends a REFER request to the caller, with the callee (as specified in the VoiceXML
application) in the Refer-To: header.

2. The transfer fails if a non-2xx final response is received for the REFER.

This is a one-leg transfer (in other words, it occupies only one channel on the platform).

Referjoin
A Referjoin method indicates a consultative REFER transfer (RFC 3891).
1. The platform sends an INVITE request to the callee, and a dialog is established between the callee and

the platform.

2. The platform also sends a REFER request to the caller, with the callee’s information in the Replaces
header.

3. The platform considers the transfer to be successful if it receives a BYE from the caller after a 2xx
response for the REFER.

4. The transfer fails if a non-2xx final response is received for the INVITE request or for the REFER request.

This is a two-leg, or join-style, transfer (in other words, it occupies two channels on the platform).
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Mediaredirect

A Mediaredirect method indicates a media redirection transfer. The Media Control Platform (MCP)
uses SIP to handle call control between the caller and the callee, and the RTP media channel is
connected directly between the caller and callee.

. The platform sends an INVITE request to the callee without SDP.

. If the transfer is proceeding, the callee responds with a 200 OK that includes an SDP offer.

. The platform forwards the SDP offer in a re-INVITE request to the caller.

1

2

3

4. The caller responds with a 200 OK that includes the SDP answer.

5. The platform forwards the SDP answer to the callee in an ACK response.
6

. The transfer fails if a non-2xx final response is received for the initial INVITE request.

This is a two-leg transfer (in other words, it occupies two channels on the platform). attcourtesy
attconsult attconference attoobcourtesy attoobconsult attoobconference For information on these
methods, consult the section on how the Media Control Platform works in the Genesys Voice Platform
8.1 Deployment Guide.

Disconnect on Answering Machine Property

This property indicates whether or not the FAX / Answering machine has to be detected. To assign a
value:
1. Select the Disconnect on Answering Machine row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Do CPA Analysis Property

This property indicates whether or not the platform is enabled to detect who/what answered the call.
To assign a value:

1. Select the Do CPA Analysis row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Get Shadow Variables Property

Shadow variables (optional) provide a way to retrieve further information regarding the value of an
input item. They can provide platform-related information about the interaction/input. For example,
for speech recognition, this may be the confidence level the platform receives from the ASR engine
about how closely the engine could match the user utterance to specified grammar. By setting this
property to true, it will expose the block’s shadow variable within the callflow. When enabled, the
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shadow variable will be included in the list of available variables. (For example, the Log block’s
Logging Details will show Transferl$.) A shadow variable is referenced as
blockname$.shadowVariable, where blockname is the value of the input item's name attribute, and
shadowVariable is the name of a specific shadow variable, for example: Transferl$.duration. To assign
a value:

1. Select the Get Shadow Variables row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Transfer Results Property

There are several types of transfer results supported for applications. When you select a transfer
result, a corresponding outport node is added to the block to allow specific actions to be taken for
that condition. Please note that a default outport is always present. The default path is executed if
none of the selected transfer results are set. The available transfer results are:

e far_end_disconnect (selected by default)

¢ noanswer (selected by default)

* busy (selected by default)

* near_end_disconnect
Note: Consultation Transfer supports only noanswer, busy, and near_end_disconnect transfer results.
To select transfer results:

1. Click the Transfer Results row in the block's property table.

2. Click the ... button to open the Transfer Results dialog box.

3. Select items from the list of available CPA results, or click Select all or Deselect all as needed.

Input Grammar Dtmf Property

Use the Input Grammar Dtmf (Dual Tone Multi-Frequency) property to specify the DTMF Grammar for
the Transfer block, which accepts DTMF signals or speech input from callers. The DTMF Grammar is
processed and handled by GVP. In the case of external grammars, this specifies the actual path of the
grammar file / resource for DTMF Grammars. This is only valid when the Grammar Type is
externalGrammar and Input Mode is dtmf or hybrid. To assign a value to the Input Grammar Dtmf
property:

1. Select the Input Grammar Dtmf row in the block's property table.

2. In the Value field, select a value from the drop-down list.

Values are the Voice Application Variables described under the Variables Property. Section 2.3.7.2.1,
of the Voice Extensible Markup Language (VoiceXML) Version 2.0 specification (http://www.w3.org/TR/
voicexml20/#dml2.3.7.2.1), contains the following information on listening for user input during a
transfer (interrupting a transfer): Platforms may optionally support listening for caller commands to
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terminate the transfer by specifying one or more grammars inside the <transfer> element. The
<transfer> element is modal in that no grammar defined outside its scope is active. The platform will
monitor during playing of prompts and during the entire length of the transfer connecting and talking
phases:

e DTMF input from the caller matching an included DTMF grammar

e an utterance from the caller matching an included speech grammar
A successful match will terminate the transfer (the connection to the callee); document interpretation
continues normally. An unsuccessful match is ignored. If no grammars are specified, the platform will

not listen to input from the caller. The platform does not monitor in-band signals or voice input from
the callee.

Input Grammar Voice Property

Use the Input Grammar Voice property to specify the Voice Grammar for the Input block, which
accepts DTMF or speech input from callers. If you are writing hybrid applications that allow both
DTMF and Speech input, specify both the DTMF and Voice grammars. The Voice grammar is sent to
the ASR Engine for processing, whereas the DTMF grammar is processed by GVP. As a result, you
need two separate grammars for Voice and DTMF in the case of hybrid applications that allow both
Voice and DTMF inputs. In the case of external grammars, this specifies the actual path of the
grammar file / resource for ASR Grammars.. This is only valid when Grammar Type is
externalGrammar and Input Mode is voice or hybrid. To assign a value to the Input Grammar Voice
property:

1. Select the Input Grammar Voice row in the block's property table.

2. In the Value field, select a value from the drop-down list.

Values are the Voice Application Variables described under the Variables Property.

Input Mode Property

To assign a value to the Input Mode property:

1. Select the Input Mode row in the block's property table.

2. In the Value field, select one of the following from the drop-down list (descriptions below):

DTMF

The DTMF format indicates the menu option mode of input will be via the telephone keypad.

Voice

The Voice format indicates the menu option mode of input will be a voice phrase.
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Hybrid

The Hybrid menu mode will handle both DTMF and Voice inputs, that is via telephone keypad and
voice phrase.
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VXML Form Block

Use this block to embed VXML code directly into a callflow diagram.

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Exceptions Property

Find this property's details under Common Properties.

Enable Status Property

Find this property's details under Common Properties.

Body Property

This property contains all the executable content of the <form> element before directing to a block
or external application.

1. Click opposite Body under Value. This brings up the Ez1 pbutton.
2. Click the Bz putton to bring up the Configure Body dialog box.

3. Enter the executable content of the <form> element. .

4. When through, click OK. Note: The editor does not validate against the VXML schema.
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Gotostatements Property

This property allows the you to configure the output nodes of the blocks. An output port is created for
every GOTOStatement item with target enabled.

1. Click opposite Gotostatements under Value. This brings up the =2 button.

2. Click the Bz putton to bring up the Gotostatements dialog box.
3. Click Add.
4. When Target is disabled, select ProjectFile or URL to indicate the destination application type. When

ProjectFile is selected, you can click the button to enter the URI. When URL is selected, you can click
the URI button and specify a literal or a variable.

5. When URL is selected, you can also click the Parameters button to select a system variable.
6. For each goto statement, specify at least one event, condition, or target (you are not required to
complete all three fields). An output port is created for every goto statement.
* Name--Composer uses the name of the goto statement to label the outport.
¢ Event--Use to select the event that will trigger the goto statement.

* Condition--The guard condition for this goto statement. The goto statement is selected only
if the condition evaluates to true.

* Target--If a target is set, an outport for that goto statement will appear and you can connect
it to other blocks. If a target is not set, an outport for that goto statement does not appear;
in this case, you can add some VXML code to handle the event.
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Voice Database Blocks

The Database palette provides blocks that enable VXML applications to use databases.

Types of Blocks

There are three Database blocks:

* DB Data Block for connecting to a database and retrieving/manipulating information from/in a database.

e DB Prompt Block for speaking out prompts generated using TTS based on the data returned by an
associated DB Data block.

e DB Input Block for accepting a DB Data block as its data source and acting as an input field that accepts
input based on a grammar created from the results returned from the database.

Also see:

e Working with Database Blocks for an overview of database support in Composer including a high level
description of how it works as well as level of support for various databases.

e Supported SQL Datatypes.

Video Tutorial

Below is a video tutorial on using the Database Blocks.

Important Note: While the interface for Composer in this video is from release 8.0.1,
the steps are the basically the same for subsequent releases.

B Genomys infs Mat Bunnses Corinuly Dapicyren] Geids =
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Using the Database Blocks

Using these blocks, VXML applications can connect to databases and query data from them. It also
provides blocks that consume this retrieved data and perform high level operations on it like
speaking out the returned data or accepting user input against a grammar generated from the

returned data.
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DB Data Block

The DB Data block is used for both routing and voice applications. See the DB Data Block topic in the
Common Blocks book. Also see Working with Database Blocks.
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Database Input Block

The DB Input block accepts a DB Data block as its data source and acts as an input field that accepts
input based on a grammar created from the results returned from the database.

It accepts DTMF or speech input. This block differs from the Menu block in that it enables taking input
that might not belong to a simple choice list (as for the Menu block). The DB Input block can be used
to collect numerical data; for example, phone numbers, account numbers, amounts, or speech data,
such as a Stock name. It uses speech or DTMF grammars to define the allowable input values for the
user responses. Built-in system grammars are available for data, such as dates and amount.

The user input result will be stored in a block name variable in the VXML application.

Note: If the DB Input block uses a DB Data block as its data source, it uses only the first column from
returned results to generate the grammar.

The DB Input block can also use a variable as a data source instead of a DB Data block. In this case,
grammar for the input is generated based on data in the array. The variable should represent a JSON
array similar to the sample below:

myvariab|e="[[""GOOgle""],[""App|e""],[""M0t0r0|a""],[""Samsung""],[""NOkia""]]"

The DB Input block has the following properties:

DB Input Block Exception Events

The DB Input block has four exception events as described in Exception_Event Descriptions:

e error
* error.noresource
* noinput

¢ nomatch

Name Property

Please find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.
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Data Source Property

The Data Source property allows you to select the DB Data block that contains a previously-defined
database query. This is used when DBDataBlock is selected as the Data Source Type property value.
The results of this database query will be used to create the input field.

To select the data source (a DB Data block):

1. Select the Data Source row in the block's property table.
2. In the Value field, select the appropriate DB Data block from the drop-down list.

Data Source Type Property

The Data Source Type property allows you to select whether your data source is the contents of a DB
Data block or a variable.

To select the data source type:

1. Select the Data Source Type row in the block's property table.

2. In the Value field, select DBDataBlock or Variable from the drop-down list.

Data Source Variables Property

The Data Source Variables property allows you to select the contents of a variable as your data
source. This is used when Variable is selected as the Data Source Type property value.

To select the variable that serves as your data source:

1. Select the Data Source Variable row in the block's property table.

In the Value field, select one of the available variables from the drop-down list. This can also be a

2.
custom variable you assigned in the Entry block.

Exceptions Property

Find this property's details under Common Properties.

Language Property

The language set by this property overrides any language set by the Set Language block, the Project
preferences, or the incoming call parameters. The property takes effect only for the duration of this
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block, and the language setting reverts back to its previous state after the block is done. In the case
of the DB Input block, this property affects the language of grammars of TTS output:

1. Click under Value to display a down arrow.

2. Click the down arrow and select English - United States (en-US) or the variable that contains the
language.

Clear Buffer Property

Use the Clear Buffer property for clearing the DTMF digits in the key-ahead buffer. If it is not set to
true, the DTMF digits entered are carried forward to the next block. It is commonly used for
applications that the caller is familiar with. For example, the caller hears a welcome prompt but
knows the next prompt will solicit the caller's input or menu selection. The caller may start inputting
with DTMF while the welcome prompt plays and expect the input to carry forward.

To assign a value to the Clear Buffer property:

1. Select the Clear Buffer row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Interruptible Property
This property specifies whether the caller can interrupt the prompt before it has finished playing.
To assign a value to the Interruptible property:

1. Select the Interruptible row in the block's property table.
2. In the Value field, select true,false,or DTMF (for DTMF barge-in mode support) from the drop-down list.

Prompts Property

Find this property's details under Common Properties.

Note: When Type is set to Value and Interpret-As is set to Audio, you can specify an HTTP or RTSP
URL. When Type is set to Variable and Interpret-As is set to Audio, you can specify a variable that
contains an HTTP or RTSP URL.

Timeout Property

The Timeout property defines the length of the pause between when the voice application plays the
last data in the list, and when it moves to the next block.
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To provide a timeout value:

1. Select the Timeout row in the block's property table.

2. In the Value field, type a timeout value, in seconds.

Security Property

When the Security property is set to true, data for this block is treated as private. GVP will consider
the data associated with this block as sensitive and will suppress it in platform logs and metrics.

To assign a value to the Security property:

1. Select the Security row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Output Result Property

You must use the Output Result property to assign the collected data to a user-defined variable for
further processing.

* Note! This property is mandatory. You must select a variable for the output result even if you do not
plan on using the variable. If this is not done, a validation error will be generated in the Problems view.

1. Select the Output Result row in the block's property table.

2. In the Value field, click the down arrow and select a variable.

For more information, see Upgrading Projects/Diagrams.

Get Shadow Variables Property

Shadow variables provide a way to retrieve further information regarding the value of an input item.
By setting this property to true, it will expose the block’s shadow variable within the callflow. When
enabled, the shadow variable will be included in the list of available variables. (For example, the Log
block’s Logging Details will show DBInputl$.)

A shadow variable is referenced as blockname$.shadowVariable, where blockname is the value of the
input item's name attribute, and shadowVariable is the name of a specific shadow variable, for
example: DBInputl$.duration.

To assign a value to the Get Shadow Variables property:

1. Select the Get Shadow Variables row in the block's property table.
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2. In the Value field, select true or false from the drop-down list.

Number of Retries Allowed Property

The Number Of Retries Allowed property determines how many opportunities the user will be
provided to re-enter the value. If Use Last Prompt Indefinitely is set to true, this property has no

effect; otherwise, the error.com.genesyslab.composer.toomanynomatches or
error.com.genesyslab.composer.toomanynoinputs errors will be raised on reaching the maximum

retry limit.

To provide a value for the number of retries allowed:

1. Select the Number Of Retries Allowed row in the block's property table.

2. In the Value field, type a value for the number of retries that will be allowed.

Retry Prompts Property

Find this property's details under Common Properties.

Use Last Reprompt Indefinitely Property

If you set the Use Last Reprompt Indefinitely property to true, the application uses your last reprompt

as the prompt for all further retries. In this case the NoMatch and Nolnput exception handlers will
never get executed, as the retry loop keeps executing forever.

To assign a value to the Use Last Reprompt Indefinitely property:

1. Select the Use Last Reprompt Indefinitely row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Use Original Prompts Property

If you set the Use Original Prompts property to true, in the event of an error requiring a retry, the

application first plays back the retry error prompt, and then plays back the original prompt for the

block (as specified in the Prompts property).

To assign a value to the Use Original Prompts property:

1. Select the Use Original Prompts row in the block's property table.

2. In the Value field, select true or false from the drop-down list.
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Use Single Counter for Nomatch And Noinput Property

If you set the Use Single Counter For Nomatch And Noinput property to true, the application
maintains a single combined counter for the nomatch and noinput errors. For example, if the block
has three nomatch retry messages and three noinput retry messages, the user gets three retry
attempts. If you do not select this option, the application generates a total of six retries; and the user
gets up to six retry attempts while not exceeding three of each type - noinput or nomatch.

Note: This property not available on the Record block.

To assign a value to the Use Single Counter For Nomatch And Noinput property:

1. Select the Use Single Counter For Nomatch And Noinput row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Condition Property

Find this property's details under CommonPropertiesforCallflowBlocks.

Logging Details Property

Find this property's details under CommonPropertiesforCallflowBlocks.

Log Level Property

Find this property's details under CommonPropertiesforCallflowBlocks.

Enable Status Property

Find this property's details under CommonPropertiesforCallflowBlocks.

Composer Help 367


https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Condition_Property
https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Logging_Details_Property
https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Log_Level_Property
https://docs.genesys.com/Documentation/IW/8.1.4/Help/CommonPropertiesforCallflowBlocks#Enable_Status_Property

Voice Database Blocks

DB Prompt Block

The DB Prompt block speaks out prompts generated using TTS based on the data returned by an
associated DB Data block. The DB Prompt block will speak each row of the data result set as a
sentence. To speak data returned by a DB Data block in a specific format, Genesys recommends
using the Prompt block along with ECMA script. A template application (Database Query Result
Access Project) is provided which demonstrates the use of ECMA script to allow Prompting of currency
and data formats as an example.

Tip

The DB Prompt block speaks out all columns for each record returned by the database
as the result of a query. The ordering of columns and of the records is controlled by
the query itself and DB Prompt plays them all in the same order without any breaks.
To introduce breaks or to add prefix or suffix text to individual columns, you can use a
custom query and introduce these features in that query. For example: SELECT ‘name
‘ + employee.firsthname + employee.lastname + ‘. . .“ FROM employee WHERE
employee.emp_id < 10. This query will speak out the text name with a small gap
before speaking out each name of each employee returned from the database. After
each record, it will pause for a small period due to the ‘. . .’ literal in the query.

The DB Prompt block has no page exceptions.

The DB Prompt block has the following properties:

Name Property

Find this property's details under Common Properties.

Block Notes Property

Can be used for both callflow and workflow blocks to add comments.

Data Source Property

The Data Source property allows you to select the DB Data block that contains a previously-defined
database query. The results of this database query will be used to create the voice prompt. To select
the data source (a DB Data block):
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1. Select the Data Source row in the block's property table.

2. In the Value field, select the appropriate DB Data block from the drop-down list.

Language Property

The language set by this property overrides any language set by the Set Language block, the Project
preferences, or the incoming call parameters. The property takes effect only fr the duration of this
block, and the language setting reverts back to its previous state after the block is done. In the case
of the DB Prompt block, this property affects the language of grammars of TTS output:

1. Click under Value to display a down arrow.

2. Click the down arrow and select English - United States (en-US) or the variable that contains the
language.

Clear Buffer Property

Use the Clear Buffer property for clearing the DTMF digits in the key-ahead buffer. If it is not set to
true, the DTMF digits entered are carried forward to the next block. It is commonly used for
applications the caller is familiar with. For example, the caller hears a welcome prompt but knows the
next prompt will solicit the caller's input or menu selection. The caller may start inputting with DTMF
while the welcome prompt plays and expect the input to carry forward. To assign a value to the Clear
Buffer property:

1. Select the Clear Buffer row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Immediate Playback Property

When Immediate Playback is set to true, prompts are played immediately on the execution of the
prompt without queuing them. When Immediate Playback is set to false, the interpreter goes to the
transitioning state and queues the TTS Prompt until the interpreter waits for an input (such as the
Menu, Input, Record,and Transfer blocks). To assign a value to the Immediate Playback property:

1. Select the Immediate Playback row in the block's property table.

2. In the Value field, select true or false from the drop-down list.

Interruptible Property

This property specifies whether the caller can interrupt the prompt before it has finished playing. To
assign a value to the Interruptible property:
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1. Select the Interruptible row in the block's property table.
2. In the Value field, select true,false,or DTMF (for DTMF barge-in mode support) from the drop-down list.

Prompts Property

Find this property's details under Common Properties. Note: When Type is set to Value and Interpret-
As is set to Audio, you can specify an HTTP or RTSP URL. When Type is set to Variable and Interpret-
As is set to Audio, you can specify a variable that contains an HTTP or RTSP URL.

Timeout Property

The Timeout property defines the length of the pause between when the voice application plays the
last data in the list, and when it moves to the next block. To provide a timeout value:

1. Select the Timeout row in the block's property table.

2. In the Value field, type a timeout value, in seconds.

Condition Property

Find this property's details under CommonPropertiesforCallflowBlocks.

Logging Details Property

Find this property's details under Common Properties.

Log Level Property

Find this property's details under Common Properties.

Enable Status Property

Find this property's details under Common Properties.
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Working with Database Blocks

This page contains general information on working with the Database blocks.

Database Connection Profiles

Before you can connect to a database in your application, you need to define a database connection
profile that will maintain all information necessary to connect to a particular instance of a database.

»

[ Connection Profiles =]

Profiles = % Details

Set the properties of the Connection Profile, Required fields are denoted by "™,

Click "+" to add a new profile and "x" to
delete a selected profile. Select a profile to
edit its details on the Details pane,

Profile Marme® ConnectionProfilel

ConnectionProfilel tonnection Pooling Clenable

Connection Pool Marme

IMDT Marmespace Javaicornpferee

Database Type* MSSQL =
Huostharme” L
Part 1433

Instance Marme

Database Mame® S0
Username*
Password [C]show  [C]Encrypt

» Encryption

Connection String

Preview and add the custom pararmeters to the Connection String,

The Connection Profile is imvalid,

Custarn Pararmeters Test Connection

The DB Data block requires that you specify the name of a connection profile in its properties so that
it can use that information to connect to the database at runtime. Multiple connections profiles can
be defined in one Project and these profiles can be shared by multiple DB Data blocks even if they
are in different callflows. A connection profile consists of the basic information required to connect to
a database. The information provided in a connection profile includes the following:
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¢ Profile Name. The internal name that Composer uses to identify connections uniquely.

¢ Connection Pooling. Select to enable connection pooling, which maintains a set of database
connections that can be reused for requests to databases. You can use this feature to enhance
performance by avoiding time-consuming re-establishment of connections to databases.

¢ Connection Pool Name. Specify a Java Naming and Directory Interface (JNDI) name for the pooled
data source. Composer applications can use any JNDI data source exposed by the web server. The .war
files exported by Composer contain configuration files to support connection pooling with JBoss and
WebSphere; other configuration changes to the web application may be required for other web servers.

* JNDI Namespace. Starting with 8.1.410.14, Composer introduces the JNDI Namespace option for Java
Composer Projects. The default value is java:comp/env. You can edit this value to match your web
server/database requirements. Fore example, you can use JBoss Connection Pooling with MSSQL and
Oracle databases for both callflows and workflows.

 Database Type. The type of database from the list of supported databases

 Hostname. The host on which the database server is running. In case of Database Cluster, Virtual IP/
Cluster Alias/SCAN Name is specified here.

¢ Port. The TCP port on which the database server is listening for connections. The most commonly used
defaults for supported database types are pre-populated by Composer. If your database server uses
custom ports, you will need to specify them here.

¢ Instance Name. The MSSQL Instance that need to connect in SQL Server. Port will take precedence if
specified. This field is disabled when Database Type is selected as ORACLE.

« Database Name. The name of the database/catalog for SQLServer and the SID in case of Oracle.

¢ SID. The check box to specify if value provided in "Database Name" is SID. This check box is disabled
when "Database Type" is MSSQL

e Username. The username that should be used to access the database
¢ Password. The password that should be used to access the database
* Encrypt. Select the encrypt the password.

¢ Show. Select to show the password

¢ Custom Parameters. The supported custom parameters can be included in connection string along
with other parameters. To define custom parameters click on the button "Custom Parameters". In the
dialog opened add the parameter name and value, in the order that need to be appended to
connection string.

¢ Note: Starting with 8.1.410.14, you can use the DB Data block Connection String property to
dynamically access the database at runtime and override the Connection Profile settings in the block.

Configuration for Database Cluster:

e For MSSQL Cluster, Virtual IP/Cluster Alias is specified in Hostname field of Connection Profile. To
connect to particular named instance in cluster, Instance parameter is configured.

e For ORACLE Cluster, Cluster Alias/SCAN Name is specified in Hostname field of Connection Profile.

Additionally, to enable TAF functionality in ORACLE clusters, connection pool is created similar to
pooling capability in other application servers. Connection pool can be created as the example below
(This need to be added in Tomcat server.xml present in Composer installed path) <Resource
name="jdbc/oraclePooled" auth="Container"
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type="com.mchange.v2.c3p0.ComboPooledDataSource"
factory="org.apache.naming.factory.BeanFactory"
driverClass="oracle.jdbc.driver.OracleDriver"

user="scott"

password="tiger" jdbcUrl="jdbc:oracle:oci:@(DESCRIPTION=(LOAD BALANCE=on) (FAILOVER=o0n)
(ADDRESS=(PROTOCOL=tcp) (HOST=172.21.184.70) (PORT=1521) ) (ADDRESS=(PROTOCOL=tcp)
(HOST=172.21.184.71) (PORT=1521) ) (CONNECT DATA=(SERVICE NAME=rac.genesyslab.com)
(FAILOVER MODE=(TYPE=session) (METHOD=basic))))" />

Encryption:

Parameters under "Encryption" tab allows you to configure SSL encryption and server authentication
for Database connections made during Design time (Query Builder, Stored Procedure) and Runtime.
When security is enabled, SSL encryption is used for all data sent between composer and SQLServer,
if the SQL server has a certificate installed.

+ Encryption

Set connection properties ko encrypt the connection to the database

Secure Conneckion Enable
Trust Certificate [ Enable

Match Certificate Subject [ Enable

Certificate Hostname |dev-irnnlus.int.genesyslab.mm |
Trusk Store Location ||::'l,trustst|:ure |
Trusk Sktore Twpe |JKS |
Trust Skore Password |******** | O show

Connection String

Preview and add the cusktom parameters ko the Connection String.

jdbe: aracle:thin: @({DESCRIPTION=(ADDRESS={PROTOCOL=teps W HOS T=dev-iron iPORT=1521 10 COMMECT_DATA=(SERVIC
E_MAME=COMPDEL 1Y

bur

javax, net,ssl truskStore=c: ftruskstore

java, net,ssl truskStore Type=1K3

Cuskom Parameters | | Test Connection

To establish a Secure Database connection from Composer, following parameters are to be configured
under encryption tab:

e Secure Connection. Enabling this check box will make all connections from Composer to Database
Server encrypted with a choice of server authentication

¢ Trust Certificate. Enabling "Secure Connection" and "Trust Certificate" will be sufficient to establish
SSL Connection. When "Trust Certificate" is disabled, other optional attributes are enabled to validate
server certificate,

* Match Certificate Subject. This is enabled in order to force the matching of the certificate subject
available in Server Certificate and client's trusted copy.
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* Certificate Hostname. This parameter is specified in case the client certificate carries a different
subject name than the server certificate and user wishes to ignore the difference by providing the
subject name expected in the server certificate explicitly.

¢ Trust Store Location. Location where the Trust Store file is present. The trust store file contains all the
certificates trusted by the client, including the certificate that the server uses to autheticate itself.

Trust Store Type. JKS truststore is supported when Database Type is ORACLE. This parameter is not
editable. This is not applicable when Database Type is MSSQL

Trust Store Password. Password to access the trust store.

Certificate configuration for Secure Connection:

e For Java Composer Projects, when "Secure Connection" is enabled and "Trust Certificate" is disabled,
certificates are placed in "TrustStore Location" specified in connection profile.

For .NET Composer Projects Design time (i.e. for Query Builder and Stored Procedure Builder),
certificates are placed in "TrustStore Location" specified in connection profile.

For .NET Composer Projects Runtime and MSSQL database, certificates are installed in "Certificate
Windows Snap-In" accessed from MMC console in Windows.

For .NET Composer Projects Runtime and ORACLE database, certificates are installed in Oracle wallet
both in client and server. tnsnames.ora configuration will have service name with TCPS protocol.
Example is given below.

SSLTEST =

(DESCRIPTION =
(ADDRESS LIST =
(ADDRESS = (PROTOCOL = TCPS) (HOST = dev-rose.us.int.genesyslab.com) (PORT = 2484))

)
(CONNECT _DATA =
(SERVER = DEDICATED)
(SERVICE NAME = SSLTEST)
)
)

Notes:

To establish a connection profile, you must be working with a Project file that was upgraded to
Composer 8.0.2 or higher from an earlier Composer release. Connection profiles are not available in
Projects created using Composer 8.0. They become available after the Project is upgraded. The
method for specifying additional pooling parameters varies based on the database being used and
the Project type. Java Composer Projects use the c3p0 library for both SQLServer and Oracle
databases. Otherwise, in the case of Oracle databases, Composer uses the c3p0 library and the
library exposes its own configuration parameters for pooling via an XML file. In case of SQLServer,
additional pooling parameters can be specified in the connection string.

Creating/Editing a Connection Profile

To create (or edit) a connection profile:
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1. Select the Project for which you are creating a connection profile in the Project Explorer, and expand
your project folder set.

2. Expand the db folder.

3. Double-click the connection.properties file. The Connection Profiles view opens.

4. To create a new profile, click the Add Profile " icon in the Profiles pane. (If you wish to edit an
existing profile, you can select an existing profile in the Profiles pane.)

5. In the Details pane, enter (or update) the appropriate information in each field (fields containing the *
character are required).

(]
6. Click the Save Profile ['3] icon in the upper-right of the Connection Profiles window. You must save the
profile in order for it to be available for selection in the Select Connection Profile dialog box.

7. Test the connection profile by clicking the Test Connection button to connect to the database.

* The message Database connection was successful indicates your connection profile
successfully connected to the intended database.

* The message Database connection failed followed by additional details indicates a
problem with your connection profile. Update the profile, save it, and test it again.

Note: For information on creating the configuration for the connection pool on the application server
side, see Connection Pooling.

Preview Connection Strings

The connection to the database with the specified parameters in the connection profile can be
previewed and tested in the Connection profile editor. In case of Java project as the design and
runtime connections use JDBC connection , JDBC connection string is available to preview and test. In
case of Dotnet projects as the design time uses JDBC connection and runtime uses OLEDB
connection, both strings are available to preview and test. Note: The Dotnet project must be
deployed correctly in IIS to preview the OLEDB connection string. The parameters apart from ones
explicitly collected in the editor can be added using the custom parameters dialog which takes the
parameters as a name value pair.

Using the Query Builder

The Composer Query Builder provides a visual method of building a database query without the need
to type SQL code. The Query Builder is accessed through the Query Type property in the DB Data
block. It can be used for both voice callflows and routing workflows. Note: The Query Builder can
only be accessed when a valid connection profile has been created and selected in the Connection
Profile property of the DB Data block. The Query Builder with an example query is shown below.
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B Query Bullder

Database Structure Selected Colemns and Sorting
Uise the tree bo select the tabies and columrs thatyou. Sorting (Urder By clause) can be specified by selectng the Sort Order and Soct Pricrity, To sort by miitipk
woLkd e b include in the querny. Colmne Sort Prionity shoukd be specfied.
= 10 testabl | | Golsmnname | Table Mame |sortorde | SortErionty Imw W |
=& doo stock_symbeod chostock_price Ascending 2 StockMame
® [0 Prompadames | | quote_vale cbostock_prce  Descendng 1 ShockPrice m
® []m Prompts quete_datetime o stock_prce T
# O comparess |
w7 prompt_fles
# [F] O stock_price [
@[] M stock_purchase_order _ _ [ I _
% ]/ t_peompts [
& []m t_prompts2 Concitions

CorddiBons cam be Lsed to narmow the query results to the spacfisd parametars. The Bockean colenn definss the
retatonship of the condtons, 1t can be ANDJOR,

Conditon |Bockean |
|
SO View
The curment SOL queny & dsplayed here. Yiou can also execute the query o geta préview of the results.
SELECT 'md"."sm_pﬂce"."sm_wmbd'. “dioa. "stock_pnice™, “quicte_valuse®, "dbo"."stock_pnce”."quiote_datetime" -
EROM _I Ereview Diata
"™, "shock_price” 0 Limitrows
CROER BY "dpo'."stock _pnce”,"quate_value™ DESC, “dbo."stock_price"."stock _symbal” ASC T -
Quiery Result Preview
|
K | Cancel

Building a Database Query

The Query Builder opens when Composer is successfully able to connect to the database specified in
your connection profile. Any schemas, tables (and table synonyms) and columns of the database
accessible from the specified user account are shown in hierarchical format in the Database Structure
pane of the Query Builder. In the example below, EMPLOYEESSYNONYM is a table synonym.
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Database Structure

Iise the bres to select the kables and colurnns that vou would like to
include in the query.
=200 =« -
B[ & cTesys
6 [ & DBSHMP
=[] FLOWS_020100
-] FLOWS_FILES
-0 iR
- = [ coUNTRIES
# [] 7] DEPARTMENTS
=-[] = empLOYEES
[= E @1 EMPLOYEESSYMNOMYM
00 B * (Al columns)
“[J 8 MANAGER_ID : DECIMAL
] ¥ DEPARTMENT IO : DECIMAL
----- g salLary : DECIMAL
| HIRE_DATE : DATE
g FIRST_MAME : YARCHAR
8 COMMISSION_PCT : DECIMAL
B
H
g

EMAIL : YARCZHAR,
EMPLOYEE _ID - DECIMAL
J0E_ID : YARCHAR x|

TableSyn.gif

Note: MSSQLServer table synonyms are read from the system table sys.synonyms. Oracle table
synonyms are read from the system table user_synonyms. To build a query:

1. Specify which table columns are returned as query results.

e Select the tables and columns to include in your query by checking appropriate items in the
Database Structure pane. Expand table entries to see the columns. To select all columns
in a table, select the appropriate (All columns) check box under the appropriate table.

e Selected columns and tables appear in the Selected Columns pane. To alter the order in
which selected columns are returned in query results, use the Up and Down buttons to
reorder columns within the list.

* To specify the order in which query results should be sorted, click on the Sort Order field for
a column and select a Sort option (ascending or descending). This will automatically fill in
the Sort Order, which indicates the sequence in which multiple sort criteria will be applied. It
is possible to sort by multiple columns and you can change the sorting sequence by clicking
on the Sort Priority column. For example, you might sort a query of names by last name
and then sort by first name for those people with the same last name. In that case, last
name has Sort Order 1, and first name has Sort Order 2.

Note: The order in which columns appear in the Selected Columns list does not affect the sort order.

¢ To specify the variables into which the column values need to be copied, click on the
Variable Mapping field for a column and select a variable. If a variable is specified for a
column, DB Data block execution will result in the column values of the first record being
copied into the specified variable. If more than one record is returned by the query, then use
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the Looping block along with the DB Data block to iterate over records and populate the
variables specified for the columns.

2. Specify filter criteria. In the Conditions pane, you build the search or filter criteria to identify the data
you want to retrieve from the database. You can can specify multiple conditions.

e Click Add to create a new condition. A new row will be added to the Conditions list. Click on
the Condition column, and then click the =] to open the Condition Builder.

¢ Select a column from the Select Column drop-down list which the search condition will
operate on.

¢ Select the operator (=, <>, <, >, and so on) from the Operator drop-down list. This
operator will be used to compare the specified column with the value specified in the next
step.</li>

* In the Value field, type or select your value for the condition depending on the value type
option:

e Column Reference: a table column that you can select from a drop-down list.
This option will compare the two selected columns based on the specified
operator.

* Application Variable: a variable defined in your application that can be
selected from a drop-down list. At runtime the current value of the selected
variable will be used for comparing the column’s value based on the specified
operator.

¢ Custom Value: a value that is not validated by the query builder and is added
directly to the query. It can be used to specify SQL functions or more complex
expression.

¢ Literal: a value that is interpreted as a string or a number. Type in the literal
value. The value will be enclosed in quotes automatically if it is a string. If the
literal value represents a number, you will need to enclose it in quotes
depending on the data type of the selected column. This option will compare
the selected column’s value to the specified literal using the specified operator.

¢ Click OK to complete the condition.

¢ Using the above steps, you can define multiple conditions. These conditions can be
combined using logical operators to further refine your search criteria. You can select AND
or OR in the Boolean field to specify the logical operator.

3. Test your query.

» To test the query, you can click the Preview Data button. This executes the query against
the appropriate database. If the database tables contain data and if any records match the
specified conditions, they will be displayed in the Query Results Preview pane. A message
will also show the number of records returned as a result of the query.

¢ If you expect that the number of matching records will be large and want to preview a subset
of returned data, click the Limit Rows check box and enter a numeric value to limit the
number of returned results.

Note: The message will now show the number of records displayed rather than the actual number of
matching records. The query results preview is shown in the Query Result pane.
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4. Click OK to save your query and update the DB Data block with the new query. If you click Cancel, all
changes are discarded and no changes are made to the DB Data block.

Specifying Custom Queries

The DB Data block can use queries specified in a SQL (.sql) file in your Project instead of a query
created using the Query Builder. To use a custom query:

e Create a .sql file in your db folder and specify the filename in the Query File property of the DB Data
block. Make sure that the operation type is SQLScriptFile. Composer will read this file at runtime and
use it to query the specified database.

The ability to use custom queries is useful in cases where the SQL query is already created using
other tools, or if the query uses features not supported by the Visual Query Builder. The next topic
describes limitations of the query builder.

Application Variables

You can use Application variables in custom query files as part of the SQL statement. To use a
variable, include its name within curly braces without the AppState. prefix. For example, the following
statement uses varnamel and varname?2. Their values will be substituted at the time the DB Data
block queries the database. SELECT name_of function({varnamel}, {varname2}) from dual
Results of the query are stored in a variable as a two-dimensional JSON array. This data can then be
accessed via a Looping block or via scripting in the Assign or ECMAScript block. For example, if the
database result set looks like this in tabular form:

Vegetables Animals
lettuce chicken
broccoli lion

The JSON for the result will look like this: {"db_result":[["lettuce", "chicken"], ["broccoli",
"lion"]1],"db result columns":["vegetables", "animals"]} Note: An example of custom
queries is in the Database Stocks Template application.

Stored Procedure Helper

If you select StoredProcedure for the Query Type property in the DB Data Block, you can click the

EZ1 button on the property row to open the Stored Procedure Helper dialog box. Here you can
select a stored procedure, execute it, and get query results. A completed example is shown below.
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Setting up a Stored Procedure Call

The Stored Procedure Helper opens when Composer is successfully able to connect to the database
specified in your connection profile. Any stored procedures in the database accessible from the
specified user account are shown in hierarchical format in the Database Structure pane of the Stored
Procedure Helper. To set up a stored procedure call:

1. Specify which stored procedure should be executed.
2. Select the stored procedure to execute by checking appropriate item in the Database Structure pane.

3. Parameters and Return Value appear in the Parameters pane. Specify the value (application variable) for
each of the parameter into which the output value is stored after the stored procedure has executed.
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4. To test the stored procedure, click the Execute button. This executes the stored procedure in the
appropriate database. If the stored procedure returns any records, they are displayed in the Query
Results Preview pane. Any output values are displayed in the Query Result Parameters pane. A
message shows the number of records returned as a result of the query.

5. Click OK to save your query and update the DB Data block with the new query. If you click Cancel, all
changes are discarded and no changes are made to the DB Data block.

Note: Composer does not support the REF CURSOR return type in a stored procedure.

Password Encryption

Composer can now encrypt the database connection profile passwords so that they are not written in
the clear to the connection.properties file.

Encryption Key

In order to enable encryption, you must first create an encryption key. Composer requires a 128-bit
(16 bytes) key, in hex-encoded format. This can be randomly generated by the OpenSSL tool, using
the following command line:

$ openssl rand -hex 16 75b8ec9a3ce60a21c4f94236alb55fh2

Any random source will do. Another example is http://www.random.org/cgi-bin/
randbyte?nbytes=16&format=h (With this example, you will have to remove the spaces in the
output.)

Save the encryption key to a text file. Note that this file should be securely stored, so that it can only
be read by the Composer process and the backend Tomcat/IIS processes.

Configuring Composer Preferences

In the Composer > Security preference page, set the Encryption Key Location preference to point
to the encryption key file created in the previous step.

Encrypting the Database Connection Profile Password

In the Connection Profile Editor, next to the Password field, enable the Encrypt checkbox. Now, when
you save the Connection Profile, the password will be scrambled in the connection.properties file.

Enabling Decryption in the Backend

When the application runs, the application server will need to be able to decrypt the password so that
it can connect to the database. For this, the application needs to be configured with the location of
the encryption key file.
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Java Composer Projects

If it doesn't already exist, create the file WEB-INF/composer.properties inside the project. Inside the
file, enter the following line:

composerEncryptionKey=C:\\secrets\\encryption-key.txt

(Note that the backslashes here must be escaped.)

.NET Composer Projects
Edit the web.config file's appSettings entry:
<appSettings>

<add key="composerEncryptionKey" value="C:\secrets\encryption-key.txt" />

</appSettings>

(Backslashes here are fine.)

Limitations and Workarounds

The Query Builder supports creating SELECT statements. The following is a list of limitations along
with suggested workarounds:

¢ INSERT, UPDATE, and DELETE statements cannot be created using the Query Builder. Advanced SQL
features, such as outer joins, subqueries, and unions are also not supported. A custom query can be
used to overcome these limitations.

e if you rename a DB Data block, its corresponding SQL statement file in the db folder will not be updated
and will not be valid until you generate code again.

e For details on SQL datatypes supported by Composer, see Supported SQL Datatypes.

Oracle Client Setup for IIS

To set up an Oracle client for Internet Information Services:

1. Install the Oracle client components on the application server.

2. Create a tnsnames.ora file in the C:\oracle\ora81l\network\ADMIN folder where C:\oracle is the
installation folder of Oracle client components.

3. Add the following lines to tnsnames.ora where COMPDBL1 is any alias of choice, XYZ is the Oracle
server, COMPOSER is the Service Name as configured on the Oracle listener (server). After doing this,
you should be able to connect to Oracle using sqlplus user/pwd@COMPDB1 as the command at the
command prompt.
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COMPDB1 = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST =

XYZ.us.int.genesyslab.com)(PORT = 1521)) ) (CONNECT_DATA = (SERVICE_NAME =
COMPOSER) ) )

4. Create a System DSN using the Data Sources (ODBC) under Administrative Tools.
5. Make sure that Data Source Name specified above is exactly same as the Database Name specified

in the Composer database connection profile and TNS Service Name is the same as the alias in step
3.

6. Click on Test Connection in the database connection profile. The connection should be successful and
the Composer VXML application should be able to connect to the database.

Steps 4, 5 and 6 can be avoided if the alias used in the tnsnames.ora file is same as the database
name specified in Composer.

Working with Oracle 12c R2 from Composer NET projects

Starting with release 8.1.450.20, Composer supports Oracle 12c R2. Perform the following steps to
work with Oracle 12c R2 from Composer .NET projects:

1. Download and install the Oracle 12c client. An Oracle 12c client is required to connect to an Oracle 12c
database (the Oracle 12c client can be either 32-bit or 64-bit).

2. Register the ORAOLEDB.ORACLE DLL file on the client machine as follows:
1. Open the Command Prompt in administrator mode on the client machine.

2. Browse to the Oracle Client installed path and identify the OraOLEDB12.dll file.

3. Execute the command, C:\Windows\System32\regsvr32.exe 0raOLEDB12.d1l1, to register the
OraOLEDB12.dll file.

3. Oracle 12c client bitness and IIS bitness configuration must match. Both must be either 32-bit or 64-bit.
1. Navigate to /IS Manager > Application Pools.

2. Click on the advanced settings of the pool used by the project (usually DefaultAppPool).
3. Use the Enable 32-bit Application option to adjust IIS bitness as required.
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Supported SQL Datatypes

Composer's DB Data Block can access many common types of data stored in supported databases.
The following tables summarize the level of support that Composer provides. The tables are
organized by the Composer project type (Java or .NET), and by whether you're doing a standard SQL
query or executing a stored procedure. The levels of support that Composer claims:

The levels of support that Composer claims:

? Datatype is fully supported.

Datatype is supported, but in the Composer Uls
(Query Builder and Stored Procedure Helper), it

2%

’ may appear as "Unknown" or "Other." The queries
themselves will work

? Datatype is not currently supported.

Supported SQL Server Datatypes

Java Project .NET Project

Java Project .NET Project

patatype (L G Prit:oerg:re R Pritcc:er::re
bigint ? ? ? ?
int ? ? ? ?
decimal ? ? ? ?
int ? ? ? ?
numeric ? ? ? ?
smallint ? ? ? ?
tinyint ? ? ? ?
float ? ? ? ?
real ? ? ? ?
date ? ? ? ?
datetime ? ? ? ?
datetimeoffset 7% 7% 7 7%
char ? ? ? ?
text ? ? ? ?
varchar ? ? ? ?
nchar ? ? ? ?
ntext ? ? ? ?
nvarchar ? ? ? ?
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Java Project R el

patatype Selb GG Priit:er;l?re
binary ? ?
sql_variant ? ?
timestamp ? ?

Supported Oracle Datatypes

Java Project L L e

patatype b G Pritcoerc?t?re
number ? ?
binary_float [ >
binary_double s ?
date ? ?
char ? ?
varchar ? ?
varchar2 [ [
nchar [ ?
nvarchar2 [ ?

7%

7%

Vil

Vel
7%

réol

.NET Project
SQL query

.NET Project
SQL query

7%

7%

o

o

.NET Project

Stored
Procedure

.NET Project

Stored
Procedure
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Voice CTI Blocks

CTI (which stands for Computer Telephony Integration) blocks provide interfaces between Genesys
Voice Platform (GVP) and Genesys Framework components and SIP Server. There are six CTl blocks:

* Get Access Number Block for using Get access number to retrieve the access code (number) of a
remote site from an IVR Server.
¢ Interaction Data Block for sending attached data. Get and Put operations are supported.

* Route Request Block for sending route requests. It uses the Userdata extension attribute for sending
back data attached to an interaction (attached data).

e Statistics Block to retrieve statistics from Stat Server via IServer.

¢ ICM Inter