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Note: There is both a Prompts Manager perspective and a Prompts Manager perspective. The Prompts
Manager provides the ability to quickly review all prompts in a Composer Project from a central place.
It displays the relevant information about all prompts in all callflows present in your workspace, one
project at a time. It displays prompt item text, associated audio file(s) and allows you to play prompt
resource files directly from the Prompts Manager view. The Prompts Manager also enables you to
tweak your prompts by rearranging prompt items, changing prompt item text, and recording new
audio files using microphone input and associating them with prompts in your Projects. It provides the
ability to quickly jump to a specific prompt block in the callflow diagram with a simple right-click so
that other changes can be made to the prompt. Prompt Manager works in conjunction with the
prompts properties popup dialog.

Opening the Prompts Manager

To open the Prompts Manager perspective:

¢ Select Window > Open Perspective > Other > Prompts Manager.

_I
s

¢ Or select the Prompts Manager Perspective toolbar button.

To open the Prompts Manager view:

¢ Select Window > Show View > Prompts Manager.

-
EPerErtiESV_' .'Ii||ﬁ}{5|.|ﬁv=a
Select a Composer Project to manage prompts

Composer Projeck: I j Language Resource: I vl

Prompks | Tvpe | Prompt Ikem Text | Audio File | Tirne Skarp | Instructions Mokes

4 | B

Selecting a Composer Project

To select a Composer Project for which to manage prompts, the Prompts Manager view:

* Select a project from the Composer Project drop-down list.
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Selecting a Language Resource

e Select a Language Resource. If not using en-US, see the special note on Non-US Locales.

The Prompts Manager displays all the prompt-related blocks for all the callflows in the selected
project.

T prompts Manager 51 > m| G L] @|aT o0

atwyy e aE T ) Tl T 5 sbas e Stocks JavaComposerProject Language Resource: IE”'US vl

Prompks | Tvpe I Prompk Ikem Texk I Audio File I Tirne Skarmp I Inskru, .. I Mokes I =
= [sal] Main
[ [ DBConnectionError
" DBConnectionError_Promp Yalue There was an error connec... N4
= EE' DEConneckionErrors
. DBConnectionError_Promp Yalue  There was an error connec... Wi
EE'. DEInputGetZomparny oz
= EE' Prompkl
7 Prompt1_Promptisgl Yalue  Goodbve T
= £ PramptDBErrar
" PromptDEError_PromptMst value & database error occurred L. NJA

2 PromptDEError_PromptMse Yariable LAST_EVENT_MSS JTF:)
7 PromptDBError_PromptMs; Yalue  This call will now end. T
= EE' PromptDEErrarz
:\ PromptDEErrorZ_Prompth: Yalue & database error occurred .. NJA LI

Notes

e The Prompts Manager will not work with non-Composer projects (such as hand-coded applications).

* Note the Language Resource dropdown selection box. The prompt audio resource is located in the
appropriate language resource folder location (for example:/Resources/
Prompts/<locale>/audioResourceFile.vox.

e Starting with 8.0.2, a Composer Project upgrade sets the default Project locale to en-US. If other than
en-US, right-click the Composer Project in the Project Explorer, and select Properties > Locales to set
the default and active locales.

Columns in the Prompts Manager View

A prompt item row in the Prompts Manager view displays the following column details:

* Prompts -- A tree hierarchy consisting of the following elements; Root elements, studio diagram
callflow/sub-callflow file name. Studio diagram elements may have diagram block elements. These
diagram block elements may have prompt/retry prompt item elements.

¢ Type -- The type of prompt item (audio resource/value/variable)
¢ Prompt Item Text -- Any associated text with the prompt item.

e Audio File -- The relative path of the audio file associated with this prompt item.
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e Time Stamp -- The Date/Time stamp when the audio file was created or recorded. This helps in
identifying the newer/older prompts.

* Instructions -- If additional item specific information needs to be given, such as a certain word needs
to be emphasized when recording at the recording studio.

* Notes -- Any notes that you would like to associate with the prompt item for later reference.

Non-US Locales

By default, Composer provides prompts audio resources for the en-US locale. The supplied
PlayBuiltinType. js under Resources/Prompts in the Project Explorer defines a global variable
called promptBaseUrl with the value en-US. When using a different locale in a callflow (other than
en-US in the Language Resource field in Prompts Manager), you must provide the associated audio
files and PlayBuiltinType. js. Adjust the path with the associated prompt resource locale folder

path.

Reviewing and Managing Prompts

Once you have laid out your diagram and wish to review the flow of the application, you can use the
Prompts Manager to do the review. It is useful to have the callflow and Prompts Manager view open
together so that the flow of the application can be traced using the callflow while reviewing prompts
using the Prompts Manager. Select the Composer Project(s) containing prompts you wish to manage.
You can review and manage your prompts as follows:

1. Expand a Prompt block in the Prompts column of the Prompts Manager view to display all prompts
associated with that block.
2. Select a prompt row. The Prompts Manager view displays detailed information about the prompt.

3. You can view prompt item text in the Prompts Manager.

* For prompts that have an associated audio file, click the Play icon B in the Prompts
Manager view to hear the audio file.

e Click the Stop icon = to stop playing the audio file.

Note: To play back VOX audio files in their correct encoding (U-Law/A-Law), you may need to set the
encoding properties in the Composer Project settings. To change the settings, go to the Project
Explorer, right-click the Composer Project folder, and select Properties. Select the Prompts
Management section and set the Encoding property accordingly.

4. To modify the sequential order of the prompt items within a block, select a prompt item element row

and click the Up or Down icon (LR in the Prompts Manager view.

5. To locate the diagram block in the studio diagram callflow that is associated with a selected row, right-
click a prompt row and select Display in callflow from the context menu. If the callflow (or studio
diagram) is not currently open, it will be opened in the editor and the selected block will be highlighted

with a blue outline as shown below.
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wr
L1

< Prompt
PromptRetriesExoesded

| error.com.genesyslab, composer dbconnectionsmcr
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A |
EPerertieslﬁ- Prompts Manager &2 > @ | {F‘ d

Composer Project: IDatal:uaseStcucksJavaCnmpnserPrDject j Language Resource: Ien-US TI
Prompks | Tvpe | Prompk Ikem Text | Audio File | Time Stamp | Inskruction
27 PrompkQueryTimeout! Yalue Database query timed ouk ... MNjA
o7 PromptCueryTimeout? variable | DEINpukGetCompany MjA
= l::' PromptR.ettiesExceeded

¥ Fromptl_Promptso 1R Sorry, the number of retrie... R/A
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7 Promptl_PromptMsgl value Sorry, I did not hear anvth... MG

6. To modify a value (for example, the prompt item name, the prompt item text, and so on) from within the
Prompts Manager view, double-click the table cell, type a new value, and press Enter. Certain table cell
values may not be modified.(for example, callflow diagram name, prompt type, and so on).

Supported Audio File Formats Audio files are encoded and outputted in various audio file formats.
The following audio file formats are recommended and supported for playback and recording within
Prompts Manager:

File . Bit rate . .

Extension Sample Rate Sample Size (Bandwidth) File Format Encoding

vox 8000 Hz 8-bit 64 bits/sec Raw audio u-law
(mono)

.VOX 8000 Hz 8-bit 64 bits/sec Rawaudio a-law
(mono)
Audio with

.wav 8000 Hz 8-bit 64 bits/sec .wav header PCM
(mono)

Refer to the VoiceXML 2.1 Reference Help on the Genesys Voice Platform Wiki for additional formats
that GVP supports. Those additional formats can be played back and recorded using third party tools
outside of Composer.

Recording Prompts

The Prompts Manager view provides a button to launch a recorder/player that can record and play
back a single prompt item’s audio file. The newly-recorded file will replace any existing audio file
associated with the highlighted prompt item. Notes:
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¢ Related prompt audio settings are located in the Composer Project Settings. In the Project Explorer,
right-click the Composer Project folder, and select Properties. Select the Prompts Management

section for prompt audio settings.

e To record a prompt item using Prompts Manager, the prompt item must be of type Resource in the
Prompts Manager view. If you do not want to specify an audio resource at this time or wish to record
your own resource prompt using the Prompts Manager, you may instead define a value in the

Alternate Text field shown below.

¢ Please note for recording prompts that are of type Value to interpret-as "Text," you will need to change
the prompt type to Resource. Supply the prompt text value in the Alternate Text field for the

Resource prompt type.

To record a prompt from within the Prompts Manager view:

1. Select an existing prompt row of type Resource.

2. Click the Record icon @ to open the Prompts Manager - Recorder dialog box as shown below:
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Prompts Manager - Recorder : . ﬂ

Record Audio: BronzeQueuePrompt_Prompt

Resource file | Resources|Prompts/en-U5/Quele_Bronze_PFS.viox >
~Recording
My Mokes

Effective 01/01/09. |

Alkernake Text

For Bronze customers

Location : I ResourcesiPrompts/en-U5 Browse

IILI*_IL

File: Marme |Queue_Bru:unze_F‘F5

Audio Format @ [wo - Encoding : ||_||_,.:.,-.,-.|.- j

> | ]| | i | |Resn:nurn:es,l'F‘rn:nmpts,l'en-LlS,l'Queue_Ern:nnze_PFS.vn:nx
i [ I Cancel |

The Prompts Manager - Recorder dialog box assists in the recording, playback, and storing of the
audio file.

1. Type any notes for this prompt in the My Notes field.

2. Type an alternate text string in the Alternate Text field. This text is used to generate audio using
#Text-to-Speech in place of the audio file should the audio file not be available at runtime.

3. Select the default recording location, or click Browse to navigate to an alternate location. Note:
Genesys recommends that you keep your language specific audio files in the/Resources/
Prompts/<language-code> folder.

4. Type a recording file name or keep the current name.

5. If the audio recording format displayed in the Recorder is not the format you wish to use, click Audio
Recording Format to open the Properties dialog box for this Composer Project, from which you can
change the audio format to WAV or VOX. You can also specify the encoding as ALAW or MULAW.
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10.
11.

. Click OK in the Properties dialog box to accept the new audio format setting for this Composer Project.

. Click Clear if you want to clear the current resource file and create a new one.

. Click the Record icon e to record your audio prompt. A microphone should be connected and volume

levels should already be set properly.

. Click the Stop icon = to stop the recording.

Click the Play icon B to play back the new audio prompt. You can re-record if necessary.

Click OK when you are finished to close the Prompts Manager - Recorder dialog box. At this point,
Prompt Manager will save any changes you have made. If you click Cancel, no changes are saved to
the project.

Exporting a Prompt Listing

The Composer Prompts Manager provides the ability to export a prompt listing of all prompts in a
Composer Project along with the attributes shown in Prompts Manager, such as instructions and
notes. This facility is useful if you need to send your prompts out for professional recording and want
to include instructions and text to be recorded along with prompt names. To export a prompt listing
from within the Prompts Manager view:

1.

P
Click the Export Composer Project Prompts icon = in the Prompts Manager view, or

¢ From the File menu, select Export. Expand Composer and select Export Prompt Listing,
or

* Right-click with any prompt or Prompt block selected, and select Export Composer Project
Prompts from the context menu, to open the Export dialog box as shown below:

Composer Help



Working with Prompts

Prompt Listing Export

@ Please input a destination or use the Browse bukbon to select,

=10 |

Select the Composer Project:

IDatabaseStu:ucksJavaCDmsterPrDject j
Select the type of file format:
E

File system destination:

Erowse, .. |

(7) Einish I

Cancel

2. Select the Composer Project whose prompts you wish to export from the drop-down list.

3. Select the file format for your exported data from the drop-down list. You may select either xml or csv

format.

4. Click Browse to navigate to a destination location to hold your prompt export file. The exported file will
have the name: <voiceprojecthame>.xml or <voiceprojectname>.csv].

5. Click Finish to complete the export request.

XML Format Description Below is an example snippet from a prompt listing export in XML format:
<prompts project="JavaComposerProject Voice Business"> <prompt callflow="Main"
block="WelcomePrompt" name="WelcomePrompt Promptl" type="Resource" interpret-

as="Audio" value="Resources/Prompts/en-US/Brand A.vox" format="" alternateText=""
instructions="" notes="" />..</prompts>
XML Tag Attribute Name Description
. The Composer project that is
<prompt> project being exported.
The name of the callflow diagram
S[ETEE.= e where the prompt resides.
<prompt> block The name of the diagram block

where the prompt resides.
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<prompt>

<prompt>

<prompt>

<prompt>

<prompt>

<prompt>

<prompt>

<prompt>

name
type

interpret-as

value

format

alternatetext

instructions

notes

The name of the prompt item.

The type of prompt, such as
Value, Resource, or Variable.

The interpretation of the prompt
value.

The value of the prompt item.

If applicable, the format of the
value. Used for interpret-as, Date
or Time. For example, 24 Hour or
12 Hour.

The alternate text for the prompt.
Used for an invalid value. For
example, if an audio resource
does not exist or the variable
data is invalid.

Text for additional or specific
information instructions. For
example, if a certain word needs
to be emphasized when
recording at the recording studio.

Any further notes from the user.
For example, identify if an
associated audio file was
recorded by the Prompts
Manager or if the audio file was
from a recording studio. Shows
the source, which will be set by
the user (Recorded/Imported/
Unknown).

CSV Format Description The CSV format separates each prompt-related value by commas. The
ordered values represents the following:

Callflow
Block Name
Prompt Type
Interpret-As
Prompt Name
Value

Format

Alternate Text

© o N o U A W N

Instructions

=
o

Notes

The following is a snippet from the prompt listing Export in CSV format:
Main,WelcomePrompt,Resource,Audio,WelcomePrompt Promptl, "Resources/Prompts/en-US/

BrandiA.VOX" , nn . nn , nn

Composer Help
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Prompt Listing Usage For a Recording Studio

A recording studio may use the details in the sample exported prompt listing below when preparing
an audio recording for a prompt item. This transcript-like format is intended to assist with producing
professional sounding recordings. The five prompt items are in sequenced order to provide a sense of
tone in relation to where the recorded message is at the beginning/middle/end of the overall
message. The recorder:

e Uses the block name attribute to determine which set of prompt items belong together.. For example,
the last five prompt items are from the same Menul prompt block.

¢ |s typically interested in prompts where type="Resource" and interpret-as="Audio", as these are the
audio resources that are to be professionally replaced.

* Uses the value from the alternateText attribute to determine what should be said for the recording.

e Uses the instructions attribute for additional details from the developer, such as instructions to
emphasize a certain word in the prompt message.

Sample Exported Prompt Listing

<prompts project="JavaComposerProject Voice Business"> <prompt callflow="CompanyABC"
block="Promptl" name="Promptl PromptMsgl" type="Resource" interpret-as="Audio"
value="Resources/Prompts/en-US/Welcome.vox " format="" alternateText="Welcome to A B
C bank." instructions="" notes="Prompts Manager recorded file." /> <prompt
callflow="CompanyABC" block="Menul" name="Menul PromptMsgl" type="Resource"
interpret-as="Audio" value="Resources/Prompts/en-US/MainMenu A.vox" format=""

alternateText="Main menu." instructions="" notes="Default Composer audio file." />
<prompt callflow="CompanyABC" block="Menul" name="Menul PromptMsg2" type="Resource"
interpret-as="Audio" value="" format="" alternateText="To check your balance press

one or say check balance." instructions="Place emphasis on 'check balance'" notes=""
/> <prompt callflow="CompanyABC" block="Menul" name="Menul PromptMsg3"

type="Resource" interpret-as="Audio" value="" format="" alternateText="To make a bank
to bank transfer press two or say transfer." instructions="Place emphasis on the word
"transfer'" notes="" /><prompt callflow="CompanyABC" block="Menul"

name="Menul PromptMsg4" type="Resource" interpret-as="Audio" value="" format=""
alternateText="To repeat these options press five or say repeat." instructions="Place
emphasis on the word 'repeat'" notes="" /> <prompt callflow="CompanyABC"

block="Menul" name="Menul PromptMsg5" Naming For ease of importing the new audio recordings
into Composer, Genesys recommends making the name the same as the attribute value of the
respective prompt entry. For example, MainMenu_A.vox in the below snippet. This avoids having to
rename the files when they are imported into Composer as described in the Importing Prompt
Resources topic. <prompt callflow="CompanyABC" block="Menul" name="Menul PromptMsgl"
type="Resource" interpret-as="Audio" value="Resources/Prompts/en-US/MainMenu_ A.vox"
format="" alternateText="Main menu." instructions="" notes="Default Composer audio
file." />
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Importing Prompt Resources

See the Sample Exported Prompt Listing, which should be used as a transcript by the recording
studio. After receiving the prompt audio resources from the professional audio recording studio, be
sure to place the audio files in the correct Composer Project resource path. This ensures that the
resources will work properly with the existing callflows that will use them. The Composer prompt
resources are stored under the Composer Project folder ../Resources/Prompts. Example: ../Resources/
Prompts/en-US/Brand_A.vox For a prompt item with audio resource Resources/Prompts/en-US/
Brand_A.vox, the new professionally recorded audio file must be identically located and named
Resources/Prompts/en-US/Brand_A.vox. If you do not do this, you must go to the callflow diagram
block properties to set the new prompt resource path, or rename the file to match existing prompt
settings. Note: When importing multilingual prompts, be sure to place the audio resource files in
their corresponding prompt resource locale folder. For example,

e English -- United States ../Resources/Prompts/en-US

e Spanish -- Spain ../Resources/Prompts/es-ES

To import file resources to the target Composer Project, use the Project Explorer. Or simply copy and
paste the files to the target prompts resource folder location of the Project Explorer. As an alternative,
importing may be achieved by using File > Import... Expand and select General > File System. In
the Import dialog, set the From directory field and Into folder fields, select the desired files, and click
Finish. A sample is shown below.
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I

: i o [=]1E3
File system
Impart resources From the local file syskem,| @
L

From directory: | CiiDocuments and Settingsibyo . CAMELO T\ DeskioplAudio Thingsh, [ Browse, ., ]

------ [B] = wavinout [] Elrun.bat
;“J test,way

|:| ;'}] testout.way

ol wavIO.cIass

[ [3] wavio.java

[ Clwavio.zip

[] ElwavioTest bat

[ wavIOTest.cIass
] m wavIOTest, java

<]

[Filter T':.fpes...][ Select Al ] [ Deselect Al J

Into Faolder: |JavaCDmsterF‘ru:ujeu:I:_'u'u:uice_Business,l'Resu:uuru:es,l'F‘ru:umpts,l'en-LlS | [ Browse, ., ]

Opkions
|:| Crverwrite existing resources withouk warning
() Create complete Folder structure

{(®) Create selected Folders only

@ Mext = i Finish i[ Cancel ]
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